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Introduction 
 
Objective 
 
Survey Data Processing consists of verifying, coordinating, formatting and processing full field 
survey data, field mapping enhancement data, additional survey data and existing right of way 
and property data.  This data is then submitted to end users as planimetric MicroStation (.DGN) 
files, topographic 3D Digital Terrain Model (.DTM) files and Geometry Project (.ALG) files in 
InRoads. The digital field/mapping data is used as a database in the development of highway 
project plans.    
This tutorial is grouped into several Sections – each of which comprises stand-alone Labs 
depicting the Survey Data Processing workflow. 
 

Lab Objectives 
 
Section 1: Processing Full Field Survey Data 
 Lab 1:  Start InRoads and Set Project Defaults 
 Lab 2:  Create Survey Data Project and Import CSV Survey Data 
 Lab 3:  Create/Import a Geometry Project (.ALG) and a Surface Project (.DTM) 
 Lab 4:  Resolving Crossing Segments 
 Lab 5:  Create/Import an Exterior Boundary 
 Lab 6:  Resolve DTM Errors 
 Lab 7:  Final Processing of the Field Surface 

 
Section 2: Processing of Mapping and Field Survey Enhancements   
 Lab 8:  Create Survey Enhancement Project and Import CSV Enhancement Data 
 Lab 9:  Process the Mapping Obscured Areas and Merge Field Enhancements into the 
                   Mapping Surface 

 
Section 3: Generate and Input Existing Alignment, Existing R/W and Property Data   
 Lab 10:  Create & Store the Existing Centerline (ACL) from Field Surveyed Points 
 Lab 11:  Modifying Centerline Alignments 
 Lab 12:  Store Existing R/W 
 Lab 13:  Store Property 
 Lab 14:  Store Property by Angle and Create/Edit Alignment by Cogo Points 
 Lab 15:  Additional Property Alignment Creation and Editing Commands 
 

Section 4: Depict Procedures for Generating the Required Project Deliverables 
 Lab 16:  Preparing the 1234567_Prop.dgn for Delivery to the Designer 
 Lab 17:  Preparing the DTM Surface, TOPO and UTLE Files for Initial Delivery 
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 Lab Format Standards 
 
In the following labs, user input and action will be displayed in bold type.  You will be 
instructed to either type-in information, click on a command or button, or press a particular key 
or function button.  When instructed to click on something, you will need to press on the left 
mouse button and then release it.  When instructed to double-click, you will need to quickly 
press the left mouse button twice in rapid succession and then release it.  Additionally, the  
symbol is used to designate successive pull down menus.  ie. FileSave.  If the lab asks you to 
press a particular key on the keyboard -- Key strokes will be displayed in < > brackets (ie.  
<CTRL> or <F4>). 
 
The lab format will be as follows: 
 
Step 
Number 

The top line will display the instructions or the user input.  The user actions will be 
displayed in the format described above. 
 
The bottom line will be in italics and will indicate the system response.  It will also 
display some additional information regarding the process you have just performed. 

 
 

         Note: 

    Each step of the lab depends on a previous step, so please read   
    everything carefully and DO NOT skip any steps. 

 
 
 
 
InRoads and MicroStation Delineation 
 
In the following labs, the user will be working in both the InRoads Design Software and the 
MicroStation CADD Software.  The InRoads Software is the database in which the surveying 
data is created and processed.  The MicroStation CADD Software is used for the viewing and 
manipulation of graphics derived from InRoads.  
 
In order to differentiate between the two software(s) the following symbolization will be utilized: 
 

InRoads Software  User performs steps in InRoads 
MicroStation Software  User performs steps in MicroStation 
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Lab 1 
Start InRoads and Set Project Defaults 

 
Objective 
 
The recommended File Structure for InRoads is a Project Folder (which is named for the PI # of 
the Project – Example: 1234567) located as a sub-folder under C:\InRoads Data – Example: 
C:\InRoads Data\1234567.  The Project Files are then located in an SDE sub-folder under the 
PI #.  Example: C:\InRoads Data\1234567\SDE 
 
This Project Folder will contain the individual InRoads Data Files.  Some Examples of InRoads 
Data Files are: 
 
1. .DTM ------ (Digital Terrain Model File) – contains Surface data 
2. .FWD ------ (Survey File) – contains Field Survey data 
3. .ALG------- (Geometry File) – contains Geometric Point, Horizontal and Vertical data 
4. .IRD ------- (Roadway Design File) – contains the Design Surface data 
5. .RWK------ (Project File) – contains project data for InRoads files in ASCII format 
6. .ITL-------- (InRoads Template File) – contains InRoads Templates for cross-sections 
7. .SDB------- (Drainage File) – contains the InRoads Storm and Sanitary data   
 

 
  
 
 
 
 
The objective of Lab 1 is to: 
 

• Create a Project Folder 
• Start InRoads 
• Set the InRoads Project Defaults 
• Set Survey Default Preferences 
• Set the InRoads “Locks” 
• Add the Application and Variable Manager Add-Ins 

 

 
 
 
 

It is highly recommended to backup the Project Folder (which contains these individual 
data files) after each work session to your Group Account on the GDOT Server if you are a 
GDOT Employee (or to an appropriate Business Server if you are a GDOT Consultant).  
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Lab1A Create a Project Folder & Copy Lab Project Files 
 
In this section of the lab you will be creating a folder or directory.  This folder is where your 
projects and all of your InRoads project data files will be located.  The newly created InRoads 
project directory will be (C:\InRoads Data\PI#).  This is the recommended file structure for 
InRoads projects.   (For this tutorial only -- you will also copy the “SDE Lab” Files to this folder 
in order to access the InRoads “1234567” Lab Files.) 
 
1.  From the desktop, double-click on the My Computer icon.  

 
This will open the My Computer dialog box.  This is your computer’s file manager.  Via 
this dialog box, you may view the content of your computer’s various hard-drives.   

2.  Double-click on the C: directory (also referred to as folder or drive). 
 
This will open the C: directory box, listing the contents of the C: drive. 

3.  If the C: directory does not contain a folder named InRoads Data -- create the folder. 
 
Creates folder InRoads Data under the C: drive. 

 

 
Figure L1-1 InRoads Project Folder In C:\ directory 

 
4.  Using Windows Explorer, create a new folder under InRoads Data and name it 

1234567. This is the project folder you will use for the Lab Lessons (C:\InRoads 
Data\1234567).   
 
Creates folder 1234567 under C:\InRoads Data. 

5.  Using Windows Explorer, copy the folder SDE Labs from C:\ to (C:\InRoads 
Data\1234567).   
 
Places the SDE Labs in C:\InRoads Data\1234567 
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Figure L1-2 Folder SDE Labs in the C:\InRoads Data\1234567 folder 

 
 

6.  Close the Explorer window by clicking on the          in the upper right-hand corner of the 
window. 
 
This will close the Explorer window. 
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Lab1B Start InRoads 
 
In this section of the lab you will be opening MicroStation V8i Select Series 2 in the ‘GDOT-
Corporate Workspace’ and InRoads Suite V8i Select Series 2. You will also select a “seed” file 
to use for the “Working” DGN file.  This “Working” DGN file is used to display the temporary 
and/or permanent graphics in InRoads.  MicroStation is opened first and then InRoads is 
opened from the MicroStation Menu bar. 
 
7.  From the desktop, double-click on the GDOT MicroStation V8i SS2 (x86) icon.   

 
 
 
 
 
  

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ is 
documented in the SDE Guidelines).  Click Open.  

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
After the MicroStation Splash Screen appears, the MicroStation Manager dialog (See 
Figure L1-3) will open so that you can select a “Working” DGN file.   Once InRoads 
and MicroStation are up and running, your desktop should look similar to that of Figure 
L1-4 and Figure L1-5. 

      
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure L1-3 Starting MicroStation V8i and InRoads Suite  
 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86).  
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Figure L1-4 Main MicroStation V8i Window 
 

 
 

Figure L1-5 Main InRoads Suite V8i Window 
 
8.  As mentioned previously - you will be working in both the InRoads Design Software 

and the MicroStation CADD Software.  The InRoads Software is the database in 
which the Surveying data is created and processed.  The MicroStation CADD Software 
is used for the viewing and manipulation of graphics derived from InRoads.  
 
Please review the diagram depicted below for a brief overview of the InRoads Explorer 
Interface: 
 
Details the components of the InRoads Explorer Interface. 
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• Workspace Bar – Contains all of the InRoads Project Data information   
• Menu Bar – Contains the pull-down menus to access InRoads commands  
• Toolbars – Contains default and customized toolbars to access InRoads commands 
• Feedback Pane – Contains details of selected Project Data from the Workspace Bar 
• Scroll Bar – Enables the user to view more of the InRoads Explorer Interface. (The 

Scroll Bar may not be visible if the InRoads Interface is already viewed to extents). 
• Status Bar – Contains InRoads messages and prompts (Please note:  InRoads may direct 

you to locate something graphically in MicroStation -- some of these prompts may 
display in the MicroStation Status Bar instead).  It is very important that the user review 
both the InRoads and the MicroStation Status Bar for prompts and information. 

  

Menu Bar Toolbars 
Workspace 

Bar 
Feedback 

Pane 

Status Bar Scroll Bar 
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Lab1C Set InRoads Project Defaults 
 
 The InRoads Project Defaults setting allows you to define the “default folder locations” for 
projects.  A Project Default configuration can then be saved for each project so that multiple 
projects can be accessed.  This configuration allows you to easily navigate between projects. 
Once the Project Folder locations are saved in the Configuration, the projects can be accessed by 
selecting the appropriate Project Configuration Name.  The Project Defaults also contains the 
location for selecting the standard GDOT InRoads Preference File (GDOT_Standard 
V8i_SS2.xin). 
 
 
 
 
 
9.  Click FileProject Defaults from the InRoads pull-down menu.   

 
 
 
The Set Project Defaults dialog box appears.  Each Project will require an individual 
setup as detailed in the following steps.  

10.  Click New and enter 1234567_SDE in the New Configuration dialog box.  
Then click OK. 
 
 
The New Configuration dialog box will appear.  After entering in the Project Name and 
clicking OK – a new configuration will be created that is named 1234567_SDE. 

11.  Under the Default Preferences section - Click in the Preferences (*.xin): field and then 
click the Browse button to navigate to the following file:  
 
 
C:\InRoads Data\1234567\SDE Labs\Standards\GDOT_Standard V8i_SS2.xin.  
Select the GDOT_Standard V8i_SS2.xin file and click Open. 
 
 
The GDOT_Standard V8i_SS2.xin file is added as the Project Preference File. 

12.  Under the Default Directory Paths Section - Click in the Project Default Directory: 
field and then click the Browse button to navigate to the folder:  
 
 
C:\InRoads Data\1234567\SDE Labs\.  Next - click Open. 
 
 
 
 
The Current Configuration for the 1234567 project will now default to the following 
path: C:\InRoads Data\1234567\SDE Labs.    
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13.  Under the Default Directory Paths Section – copy and paste the following text into each 
entry field shown below: C:\InRoads Data\1234567\SDE Labs\  
 
• Report Directory:  

C:\InRoads Data\1234567\ SDE Labs \ 
• Projects (*.rwk):  

C:\InRoads Data\1234567\ SDE Labs \ 
• Surfaces(*.dtm):  

C:\InRoads Data\1234567\ SDE Labs \ 
• Geometry Projects:(*.alg): 

C:\InRoads Data\1234567\ SDE Labs \  
• Template Libraries:(*.itl):  

C:\InRoads Data\1234567\ SDE Labs \ 
• Roadway Design: (*.ird):   

C:\InRoads Data\1234567\ SDE Labs \ 
• Survey Data: (*.fwd):  

C:\InRoads Data\1234567\ SDE Labs \ 
• Drainage: (*.sdb):  

C:\InRoads Data\1234567\ SDE Labs \ 
• Quantity Manager: (*.mdb):  

C:\InRoads Data\1234567\ SDE Labs \ 
• Site Modeler Projects: (*.gsf):  

C:\InRoads Data\1234567\ SDE Labs \ 
 

The Configuration for the 1234567 project will now default to the path listed above. 
14.  Under the Default Directory Paths Section - Click in the Style Sheet (*.xsl): field and 

then click the Browse button to navigate to the folder:  
 
C:\InRoads Data\Style Sheets\GDOT\.  Next - click Open. 
 
The Current Configuration for the Style Sheets will now default to the following path: 
C:\InRoads Data\Style Sheets\GDOT\.   

15.  The Project Defaults should now correspond to the screen capture depicted in  
Figure L1-6 (as shown below).  Verify to ensure that your 1234567 Project Defaults 
match the inputs in the screen capture.   
 
The Project Default Fields are verified for accuracy.    
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Figure L1-6 Set Project Defaults 

 
 

16.  Click Apply and then click Close. 
 
The Set Project Defaults dialog box will close and the settings for this configuration of 
Project 1234567_SDE will be the default settings until the configuration is changed to 
another Project.  This folder location will also be the default folder when FileSave and 
FileClose are used.   

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
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Lab1D Set Survey Default  Preferences 
 
 The Survey Default Preferences must be loaded in InRoads in order to conform to standards for 
the processing of Surveying Projects.  This is a very important step to ensure that standards are 
followed for any Survey data that will be processed. The Survey Default Preference loads the 
Precision Settings, Tolerances, Units and Formats, etc.  Once the Survey Default Preference is 
loaded – the project will retain these settings each time the project is accessed.  
 
17.  Click File Project Options from the InRoads pull-down menu to access the Project 

Options dialog box.   
 
The Project Options dialog box appears.    

18.  In the Project Options dialog box - click on the General Tab.   
 

      
  
 
 
 
The General Tab dialog box appears.   

19.  In the General Tab dialog box click the command button named Preferences… 
(Located at the bottom of the dialog box). 
 

                            
   
 
 
 
 
 
 
The Preferences dialog box will open. 

20.  In the Preferences dialog box – select Survey Default.  Then click Load and then click 
Close.  
 
The Survey Default Preference will be loaded. This will load the appropriate data for 
ALL of the tabs in the Options dialog box. The individual tabs (Tolerances, Geometry, 
Units and Format, etc.) will automatically be configured for use in Mapping and 
Surveying. These individual tab options will NOT need to change. Once the Survey 
Default Preference is loaded – the project will retain these settings each time the project 
is accessed.    

General Tab 
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21.  Important Information: 
 
In the Project Options dialog box - click on the Geometry Tab.   

 
Notice in the image at right, the 
Seed Alignment Name: and Seed 
Point Name: 
default settings of SV1 and 1.  These 
values were set when the Survey 
Default Preference was loaded in 
the preceding step. 
 
 

These settings are of particular importance 
to the SDE.  Alignments must have a SV 
prefix.  Points must have NO prefix  
as well as numbering starting at 1.  In order for  
survey enhancements to be properly to a project, it is essential that  
SDE’s pay particular attention to this setting.  
SV stands for survey. 
 

22.  Click back to the General Tab.   
 
 
The Survey Default Preference should now correspond to the screen capture depicted in  
Figure L1-7 (as shown below).  Verify to ensure that the Project Options dialog box for 
Project 1234567 matches the inputs in the screen capture.   
 
The Project Options are verified for accuracy.    
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Figure L1-7 Survey Default Settings 

 
 

23.  Click Apply and then click Close. 
 
The Project Options dialog box will close and the Survey Default Preference for this 
configuration of Project 1234567 will be the default settings until the configuration is 
changed to another Project.   

  

Ensure that the  
“Refresh Command 
Settings on Preference 
Change” is checked: 
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Lab1E   Set InRoads “Locks” 
 
 InRoads contains several “Locks” which are used by many InRoads commands to control 
different aspects of the selection and viewing of data as well as the reporting of data.  There are 
basically two types of “Locks” – On/Off “Locks” and Switch “Locks”. (Switch “Locks” contain 
different modes but one mode is always active and the user can switch between modes). Both 
types of “Locks” can be changed by the user as the situation dictates during the course of the 
database generation.  These locks affect many commands – so it is very important that the user 
understand the use of these locks.    
 
The following Lab contains a brief overview of some of the InRoads “Locks”.  Only the “Locks” 
pertaining to the Survey aspect will be reviewed.  These “Locks” must be set according to the 
following Lab --- (Lab1E) ---- for the use in upcoming Labs.  
 
24.  Click ToolsLocks from the InRoads pull-down menu.   

 
This command accesses the available InRoads “Locks”. Each time a “Lock” is changed 
– the pull-down menu will close and the user must click on ToolsLocks again to access 
the Locks pull-down. 

25.  Ensure that the following locks are selected/unselected as appropriate: 
 
 Feature Filter        _____ Unchecked   
 
Feature Highlight         __ Unchecked 
 
Style         ____________ Unchecked 
 
Pencil/Pen        ________ Set to Pencil 
 
Delete Ink    ________ Unchecked 
 
Locate         ___________Set to Features 
 
Point Snap        ________ Checked 
 
Element Snap        ______Unchecked 
 
Station        ___________ Unchecked 
 
Report          __________ Checked 
 
Cogo Audit Trail      ____ Unchecked 
                             
Toolbar            ________ Checked 
 
The InRoads “Locks” are set accordingly. 



 Introduction to InRoads- SDE  InRoads SS2- Lab 1 

   
 Lab1-14   

26.  Following is a brief overview of the “Locks”: 
 
 Feature Filter   
 displays or obscures Surface Features based on a filter (also controls Survey Style Filter) 
 
Feature Highlight 
 highlights the feature in plan view when selected from a list 
 
Style 
 determines if a dialog box is displayed for a surface command or cross sections 
 
Pencil/Pen   
controls the redisplaying of Graphics 
 
Delete Ink  
allows redisplayed graphics to replace graphics in pen mode 
 
Locate    
controls if Locate Buttons snaps to Graphics or Features 
 
Point Snap   
 controls the ability to snap to points in Geometry Project 
 
Element Snap 
controls the ability to snap to elements in Geometry Project 
 
Station   
controls the Stationing as it pertains to Cross Sections 
 
Report  
controls if Report is displayed or not displayed in a dialog box    
 
Cogo Audit Trail 
controls the reporting of coordinate geometry results to a text file 
                          
Toolbar 
displays or turns off the Locks Toolbar 
 
Describes a “brief” overview of the InRoads “Locks”. 
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Lab1F Add Application and Variable Manager Add-Ins 
 
InRoads contains several Application and Variable Manager “Add-Ins” which must be selected 
and added to the InRoads Program in order to access the standard GDOT customized menu 
applications/translators for Survey.  Once the Application and Variable Manager Add-Ins are 
selected – the settings are written to registry keys in the user’s profile.  This ensures that each 
time InRoads is accessed in the user profile -- these settings will already be available. These add-
ins will only need to be added once and will then be accessible in all of the InRoads Modules and 
InRoads Projects.   
 
The following Lab contains a brief overview of the InRoads “Application and Variable Manager 
Add-Ins”.   These “Application and Variable Manager Add-Ins” must be set according to the 
following Lab --- (Lab1F) ---- for their use in upcoming Labs. This is a very important step to 
ensure that the “Add-Ins” are set accordingly.     
 
 
27.  The Application Add-Ins will be selected: 

 
Click ToolsApplication Add-Ins from the InRoads pull-down menu and the following 
dialog box will appear:   
 

 
 
 Select the following Application Add-Ins by clicking an         by the appropriate Add-In:  

        
 
 
The InRoads “Application Add-Ins” are selected accordingly.   
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28.  Click OK to accept the settings and to close out of the dialog box. 
 
The Application Add-Ins dialog box will close and the selected Application Add-Ins will 
be available for use.  

29.  Next the Variable Manager Add-Ins will be selected: 
 
Click ToolsVariable Manager from the InRoads pull-down menu and the following 
dialog box will appear:   

 
 
Select the following Variable Manager Add-Ins by clicking an         by the appropriate 
Variable:  
 

 
 
The InRoads “Variables” are selected accordingly.   

30.  Click Apply to accept the settings and then click Close to close out of the dialog box. 
 
The Variable Manager dialog box will close and the selected Variables will be available 
for use. 

31.                    
                 This concludes Lab 1.  Do not proceed until the Instructor directs you to do so. 
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Lab 2  
Create Survey Data Project and Import 

 CSV Survey Data 
 
Objective 
 
An InRoads Survey Data Field Book (.FWD File) must be created and must be made active in 
order to import and translate the GDOT Trimble CSV Data from Survey.  In this tutorial, Project 
1234567_A.fwd (Survey Data Field Book File) will be created.  This active field book database 
will be used to import, generate and translate the GDOT Trimble “CSV” data from Survey.  
 
InRoads contains a GDOT Trimble CSV to InRoads Translator which converts the CSV file 
into a format that is usable for InRoads.  The translator converts the .CSV file based on a format 
of Point Number, Northing, Easting, Elevation, Alpha Feature Code and Attribute Name 
and Attribute Value if applicable.  After the CSV file is translated and imported into the Field 
Book, the data can then be imported into a Surface Project and/or Geometry Project.  The 
processing and triangulating of the Surface Data/Geometry Data will be discussed in more detail 
in later Labs. 
 
*Please Note: 
The Attribute Value (such as Pipe Size, Tree Dimensions, etc.) are now included during the 
import. The value that is entered in the CSV file will appear in the Description Field in InRoads 
after the conversion. 
   
The objective of Lab 2 is to: 
 

• Create a Survey Data Field Book Project (Project 1234567_A.fwd) 
• Save the Survey Data Field Book Project (Project 1234567_A.fwd) 
• Translate and Import the Trimble CSV File(s) 
• Review the Survey Data in the Field Book and correct errors as needed 
• View the Planimetric Survey Data in InRoads/MicroStation 
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Lab 2A Create 1234567  Survey Data Project (1234567_A.fwd) 
 
In the following Lab – an InRoads Survey Data Field Book (1234567_A.fwd) will be created and 
saved to the Project Folder. This Survey Data Field Book data will be used in later Labs to create 
a .DTM (Digital Terrain Model database) and an .ALG (Geometry database).   
 
1.  If MicroStation and InRoads are not open, follow Step 7 in Lab 1B to open 

MicroStation and InRoads.  
 
 
Starts the MicroStation and InRoads Software Product(s).   

 
 
 

 

 
Figure L2-1 InRoads Interface 

 
 
 

2.  Click on the Survey Tab (Located at the bottom – left hand side of the InRoads Explorer 
Interface).  If this tab is not visible – use the scroll bars to scroll to the Survey Tab. 
  

                                            
 
 
 
 
Opens the Survey Tab in the InRoads Explorer Interface. 

InRoads Explorer Interface 

Survey TAB 

Scroll Bars 
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3.  Create the 1234567_A.fwd Survey Data Project by selecting FileNew from the 
InRoads Menu.  The New dialog box will open.  Select the Survey Data Tab. 
 

• In the Name: Field – enter 1234567_A 
 
The inputs should now correspond to the screen capture depicted in  
Figure L2-2 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the New dialog box allowing you to create a Survey Data Project. 

 
 
 
 
 
 

                              
Figure L2-2 “New” Survey Data Project 

 
 
 
 
 
 
4.  Click Apply and then click Close to create the Survey Data Project.   

 
The Survey Data Project is created and the New dialog box closes.   
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5.  Even though the InRoads Survey Data Project was created – it has not yet been saved. 
InRoads retains the data in temporary memory but does not save the data on the fly. It is 
highly recommended to Save the project periodically after any major modifications or 
changes to the data. 
 

• Select FileSave Survey Data from the InRoads Menu.   
• The Save As dialog box will appear as shown in Figure L2-3. 

  
 
             

  
Figure L2-3 Save As 1234567_A.fwd 

 
6.  Save the 1234567_A.fwd file. 

 
• Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 2\ 
• Enter the File name: as  1234567_A 
• Enter the Save as type:  as Survey Data (*.fwd) 
• Click Save and then click Cancel. 

 
 The  FWD File is saved to the following location:  
C:\InRoads Data\1234567\SDE Labs\Lab 2\                                     
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7.  Click on the Survey Tab (Located at the bottom – left hand side of the InRoads Explorer 
Interface). 
 

                                     
 
Then double-click on the 1234567_A Survey Data Project.  Note that the Survey Project 
has been created but is currently empty and contains no data – this is denoted by the 
“blank” coordinate data in the InRoads Explorer Interface. See Figure L2-4 (as shown 
below).   
 
Opens the InRoads Survey Tab and displays the 123456_A Survey information in the 
InRoads Explorer Interface. 

 
 

 
Figure L2-4 Survey Tab – InRoads Explorer (Before File Importation) 

 
 
 
 
 
 
 
 
 
 
 

Survey TAB 
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8.  In the screen capture depicted below –  
 
Note that in the InRoads Explorer Interface Workspace Bar that the 1234567_A Survey 
project has a “Red Rectangle” around the icon. 
 
This denotes that this is the “Active” Survey Project.  Any survey commands will be 
initiated and performed on the current “Active” Survey Project. 
 

 Also note that there will always be a Default  
“Book 1” Project listed.  InRoads includes this 
Default “Book 1” for internal InRoads 
functionality --- Remember to never save data 
to this Default Survey Data Book.    
 
 
 
 
 
 

 
 
 
 
Displays a red rectangle around the 1234567_A Survey icon to reflect that this is the 
Active Survey Project upon which commands will be performed. 
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Lab 2B Translate and Import the GDOT Trimble “CSV” File 
 
In the following Lab – a Trimble “CSV” Field Survey File will be translated and imported into 
the 1234567_A.fwd field book by using the InRoads “Import Survey Data” command.  After 
the data has been translated and imported – the Survey Data will be saved to the 1234567_A.fwd 
Survey Project.   
 
9.  Following are two example formats of the GDOT standard Trimble CSV File. The data 

in both are the same, the only difference is if the File is opened in Excel, it will look like 
the first screen capture depicted in Figure A. If the File is opened in a Text Editor such 
as NotePad or WordPad, it will look like the second screen capture depicted in Figure B: 
 
It is highly recommended to only open the CSV file in a Text Editor and NOT in Excel. 
The reason is when opening in Excel; additional commas are placed at the end of the 
attribute name and may cause issues in the InRoads description fields. 
 
Figure A: (Screen Capture from Excel) 
PT # –Northing–Easting–Elevation–Feature Code–Attribute Name–Attribute Value 

 
 
Figure B: (Screen Capture from WordPad) 
PT # –Northing–Easting–Elevation–Feature Code–Attribute Name–Attribute Value 
203,1263914.015,2244692.182,922.143,SDCD,ATTRNAME,CD203 
204,1264915.721,2244406.908,929.411,SDCD,ATTRNAME,CD204 
205,1265779.781,2244196.015,945.983,SDCD,ATTRNAME,CD205 
206,1266807.164,2243938.752,948.854,SDCD,ATTRNAME,CD206 
207,1268577.467,2243523.159,941.923,SDCD,ATTRNAME,CD207 
208,1269722.906,2243229.502,932.556,SDCD,ATTRNAME,CD208 
209,1271707.277,2242672.591,941.302,SDCD,ATTRNAME,CD209 
531,1278246.098,2237121.145,863.166,DSBST61,, 
532,1278247.861,2237119.81,862.491,DSEST62,, 
533,1278248.867,2237117.916,861.555,DSCST63,, 
534,1278229.978,2237105.246,864.358,DSB61,, 
535,1278230.896,2237101.55,862.359,DSE62,, 
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10.  The GDOT Trimble “CSV” File will be translated and imported: (1234567A.csv) 
 
Select FileImport Survey Data from the InRoads Menu.  The Import dialog box 
will open.   
   
Select the CSV file by browsing to the file in the “Look in” drop down box. Navigate to 
the CSV file which is located in the following path: 
 
C:\InRoads Data\1234567\SDE Labs\Lab 2\Trimble CSV Files\  
 
 Select the 1234567A.csv file --- by left-clicking on the file.  
 

• In the File name: Pulldown – ensure 1234567A.csv is listed 
• In the Files of type: Pulldown – ensure GDOT Trimble Format(*.csv) is listed 
• The Template: Pulldown – should be blank 
• The Linear Units: Selection  - should be US Feet 
• The Angular Units: Selection – should be Degrees 

 
The inputs should now correspond to the screen capture depicted in  
Figure L2-5 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Import dialog box allowing you to import a CSV File.   

 

 
Figure L2-5 Import CSV Translator 
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11.  Click Import.  
(This command selects the data to be imported.) 
 
 Click Close.  
(The Survey Data is actually imported when the Close command is selected.) 
 
Please Note: 
In certain situations, you may receive an error message that says “One or more target 
heights missing from file”. If you click OK, the data will still import in correctly - but the 
message means that one or more points in the CSV file are missing coordinates and/or 
elevations. If this situation does occur, the CSV file should be reviewed to correct the 
errors and then import in the data again.  
 

                        
 
Please Be Patient! 
It may take a while for the CSV data to import depending on the size of the file! 
 
Once the data is imported – the Import dialog box will close automatically. 
 
Please Note: 
In this tutorial – only one CSV file will be imported for demonstration purposes.  
 
In a “real world” project, if additional CSV file(s) need to be imported – create a new 
Survey Project (Ex. 1234567_B) and repeat Steps 3-10.  
 
The CSV File data is translated and imported into the 1234567_A Survey Project. 

12.  The CSV File data is now imported into the 1234567_A Survey Project.  Click on the 
Survey Tab (Located at the bottom – left hand side of the InRoads Explorer Interface) 
and then double-click on the 1234567_A Survey Project.   
 
 
A 1234567A folder will appear. Double-click on the 1234567A 
 folder.  
 
Review the InRoads Explorer data frame and note that the Survey Project now contains 
point data and coordinate information.  Your InRoads Explorer Interface should look 
similar to the screen capture shown below (See Figure L2-6).   
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Figure L2-6 Survey Tab – InRoads Explorer (After File Importation) 

 
 
13.  Even though the CSV data has been imported into the InRoads Survey Project 

(1234567_A.fwd) – the data has not yet been saved. As mentioned previously, InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Survey Project – it is advisable to Save the project 
and its associated modifications or changes. 
 
Select FileSave Survey Data from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Survey Project has 
already been saved initially). 
 
 The Survey Project (1234567_A.fwd) will  be saved to Lab 2 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 2 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Survey Project has been saved. (See screen capture below): 
 

 
                         

 
 
 
 
The 1234567_A Survey Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab2     

 
 
 
 
 
 

Survey 
Project 
Saved 
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Lab 2C Review the Survey Data in the Survey Field Book 
 
In the following Lab – the GDOT Trimble CSV Field Survey data will be reviewed for accuracy 
in the Survey field book to determine if there was any erroneous data introduced in the CSV file. 
Although the Field Book is a good tool to utilize for reviewing and determining error in the data 
– it is highly advisable to use this field book as a review tool only.  If any errors are found during 
the review – the user needs to make any corrections or adjustments of the data in the original 
GDOT Trimble CSV file or recompile the survey data contained in the data collector to create a 
new CSV file.  
 
 The field book can be utilized to determine the validity of many aspects regarding point and 
alignment data represented in the CSV file. Although this tutorial does not demonstrate all of the 
review functions contained in the field book – following are some of the tools available for 
point/alignment verification: 
 

• Unrecognized Feature Codes which are not found in InRoads (will be in Bold Red text) 
• One Point on Chain collection errors may be found in InRoads.  They will be in Bold 

Black text in the Fieldbook.  Appendix B of the Survey Processing Guidelines details 
using the InRoads Fieldbook to locate One Point on Chain errors. 

• Errors in Elevation (Busts in elevations) 
• Errors in points which should contain attribute(s). (Example: attributes for Drain Pipes). 

Attributes include the pipe sizes, dimensions, etc. 
 
As mentioned previously if any errors are found during the review of the field book data – all 
corrections should be made in the original CSV file or data collector. 
 
 
14.  Select SurveyFieldbook Data  from the InRoads Menu and the 1234567_A Survey 

Field Book will open.   
 
Briefly review the field book data information for potential errors/problems. See the 
Survey Field Book screen capture depicted in Figure L2-7 (as shown below).    
 
Opens the Fieldbook dialog box for review.                     
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Figure L2-7 Survey Field Book  

 
 

15.  For Information Only: 
 
Very Important! 
 
If the CSV file is manually edited to correct an error – please be sure that there is NOT a 
hard return after the last entry in the CSV file (Depicted by a blank line beneath the last 
entry).  
 
If this should occur and is not corrected in the CSV file – the last entry in the InRoads 
Field Book will be erroneous. If this situation is present in the field book  – it will be as 
depicted by the screen capture shown below highlighted in Blue –  
 
 
 
 
 
   
 
To resolve the issue – edit the CSV file by deleting the last blank line represented in the 
CSV file.  
 
Depicts example of a common error in the InRoads Field Book.                     
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16.  Close the Fieldbook Data dialog box. 

 
 Left click on the Red X in the upper right corner of the Fieldbook Data dialog box as 
shown here. 
 

 
 
Closes the Fieldbook Data dialog box. 

 
  

Click Red X 
to close the 
Fieldbook. 



Introduction to InRoads - SDE                      InRoads SS2 – Lab 2 
 

   
 Lab2-28   

Lab 2D View the Planimetric Survey Data  
 
When the Survey Data is imported into the Survey Field Book, the data can be viewed as 
Planimetric data in MicroStation.  
 
Please Note: 
At this time - the data can be viewed only. This data is not actually written as Graphics to the 
DGN file. The user may zoom in or out in MicroStation but actual manipulations to the data 
cannot be initiated because it has not yet been imported into a Surface or Geometry database.  
The steps to write the survey data to the Surface and Geometry InRoads modules will be detailed 
in later Labs.  
 
17.  View the selected Features in the [MicroStation Software] by using the following 

commands located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Features. 
            

                    
       
 
 
 
 
 
 
Views the Features in MicroStation. 

18.  To turn Planimetric Survey Data on/off: 
 
The Planimetric View can be turned on/off in InRoads by the following steps: 
 
Select SurveyView Survey Data Planimetrics from the InRoads Menu.   
 
A check mark by Planimetrics – turns the planimetric data on for viewing. 
Removing the check mark by Planimetrics – turns the planimetric viewing data off. 
 
Steps to view the Planimetric Survey Data in InRoads/MicroStation. 

19.                    
                 This concludes Lab 2.  Do not proceed until the Instructor directs you to do so. 
 

 
 
 
 

Fit View 
Zoom In or Out 
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Lab 3 
Create/Import a Geometry Project (.ALG) 

and a Surface Project (.DTM)    
 
Objective 
 
In the previous Lab, the field survey data was translated and imported into InRoads by using a 
Survey Project (an .FWD Survey Field Book). The next Lab depicts the process of creating a 
Geometry Project (.ALG) and a Surface Project (.DTM file) and importing the translated survey 
data into these database(s).  
 
The survey data which is imported into the Geometry Project (.ALG) is survey that consists of 
Property data, Existing Right of Way, Alignment data, etc.  Basically it is survey which is 
“Geometry related” and which will be used in the creation of the property, alignment and COGO 
database.  This Geometry data will not be represented in the DTM. All other Survey Data will be 
imported into the Surface Project (.DTM) and will be represented as Surface Features. 
 
In order to automate this process - Survey Style Filters have been created which automatically 
“filters” the data so that the appropriate data will import into the Geometry Database and/or 
Surface Database as required.   
 
 The following Lab depicts the procedures to create the Geometry Project (.ALG) and the 
Surface Project (.DTM) and the process of importing the Survey Data into these database(s). 
 
Please Note: 
The naming conventions used for the creation of the ALG and DTM are critical in order for 
additional survey data to be added in later Labs. 
 
The objective of Lab 3 is to: 
 

• Create and Import data into an InRoads ALG (Geometry Database Project) 
• Create and Import data into an InRoads DTM (Surface Database Project) 
• Learn how to use Survey Style Filters and Feature Filter “Locks” 
• View the Graphical Geometry and Surface Information 
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Lab3A Create a Geometry Project Database (.ALG) 
 
In this section of the lab you will be creating a Geometry Database Project. This database will be 
used in the next Lab to import the Geometry information contained in the Survey Field Book 
(.FWD) into the Geometry Database Project (.ALG).   
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Load the InRoads Survey File 
 
Select FileOpen from the InRoads Menu.   
 
The Project Defaults (which were set up in Lab 1C) are set to the following Path: 
C:\InRoads Data\1234567\SDE Labs. 
 
Browse to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab3 
Select the file named: 1234567_A.fwd 
 
Click Open and then click Cancel. 
 
The 1234567_A.fwd Survey file will open. 

5.  Click on the Survey Tab (Located at the bottom – left hand side of the InRoads Explorer 
Interface).  Note that the “Red Rectangle” denotes that the 1234567_A project is the 
active Survey Project. 
 

                                                  
 
 
 
 
 
 
Opens the “Survey Tab” in the InRoads Workspace Bar. 

6.  Turn off the Planimetric Survey Data: 
 
 
The Planimetric View can be turned on/off in InRoads by the following steps: 
 
Select SurveyView Survey Data Planimetrics from the InRoads Menu.   
 
Remove the check mark by Planimetrics to turn the planimetric viewing data OFF. 
 
 
 
Steps to turn the Planimetric Survey Data OFF in InRoads/MicroStation. 

Survey TAB 
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7.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the following Locks 
are turned ON.   
 
There should be a check mark next to the  following: 
 
Feature Filter is checked  
 
Point Snap is checked 
 
Report is checked 
 
Toolbar is checked 
 
This is an important step.  If the Feature Filter is not turned on (has a check mark next 
to it) – the Survey Style Filters will not work… 
 
Ensures that the appropriate Locks are turned ON. 

8.  Click on the Geometry Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the 
Geometry Tab. 
 
 
 
 
 
 
 
 
 
 
 
Opens the Geometry Tab in the InRoads Explorer Interface. 

9.  Create the 1234567_SDE.alg Geometry Project by selecting FileNew from the 
InRoads Menu.  The New dialog box will open.  Select the Geometry Tab. 
 

• In the Type: Pulldown – select Geometry Project 
• In the Name: Field – enter 1234567_SDE 
• In the Description: Field – enter Training Data 
• In the  Style: Field – (Leave Blank) 
• In the Curve Definition:  Field – (Leave Blank) 

 
The inputs should now correspond to the screen capture depicted in  
Figure L3-1 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the New dialog box allowing you to create a Geometry Project. 

Geometry TAB 

Scroll Bars 
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Figure L3-1 “New” Geometry Project 

 
 
10.  Click Apply and then click Close to create the Geometry Project.   

 
The Geometry Project is created and the New dialog box closes.   

11.  Even though the InRoads Geometry Project was created – it has not yet been saved. 
InRoads retains the data in temporary memory but does not save the data on the fly. It is 
highly recommended to Save the project periodically after any major modifications or 
changes to the data. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
• The Save As dialog box will appear as shown in Figure L3-2. 

 
 

• Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 3\ 
• Enter the File name: as  1234567_SDE 
• Enter the Save as type:  as Geometry Projects (*.alg) 
• Click Save and then click Cancel. 

 
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 3     
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Figure L3-2 Save As 1234567_SDE.alg 

 
12.  Click on the Geometry Tab (Located at the bottom – left hand side of the InRoads 

Explorer Interface). If this tab is not visible – use the scroll bars to scroll to the 
Geometry Tab. 
 
 
 
 
 
 
 
 
 
 
 
 
                                          
 
Then double-click on the 1234567_SDE Geometry Project.  Note that the Geometry 
Project has been created but is currently empty and contains no data – this is denoted by 
the “blank” point/coordinate data in the InRoads Explorer Interface.   
 
Opens the InRoads Geometry Tab and displays the 1234567_SDE Geometry information.  

Geometry 
TAB 
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13.  In the screen capture depicted below –  
 
Note that in the InRoads Explorer Interface Workspace Bar that the 1234567_SDE 
Geometry project has a “Red Rectangle” around the icon. 

 
This denotes that this is the “Active” Geometry 
Project.  Any Geometry commands will be initiated 
and performed on the current “Active” Geometry 
Project. 
 
 Also note that there will always be a Default  
Project listed.  InRoads includes this Default Project 
for internal InRoads functionality --- Remember to 
never save data to this Default Project.    
 
 

 
 
 
Displays a red rectangle around the 1234567_SDE Geometry icon to reflect that this is 
the Active Geometry Project upon which commands will be performed. 
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Lab3B Import Survey Data into the Geometry Project (.ALG) 
 
The following Lab depicts the process of importing in the Survey Data (property, alignment, etc) 
into the 1234567_SDE Geometry Project. A Survey Filter has been created which will automate 
the selection of the appropriate Survey Data which is to be imported into the Geometry Project. 
The following codes/styles (which are composed of data which will be used for the generation of 
Property and Alignment information) are included in the Survey Style Filter which is named 
Property and Alignment Codes: 
 

Property and Alignment Codes Survey Style Filter 
PROP_E_RWM Right-of-Way Marker Found 
PROP_E_RWC Right-of-Way Point Computed 
PROP_E_RWU Right-of-Way Utility Company 
PROP_E_RWE Right-of-Way Prescription Pt 
PROP_E_POEL Point on Easement Line 
PROP_E_PCF Property Corner Found 
PROP_E_PPOL Property Point on Line 
PROP_E_PPC Property Point Computed 
PROP_E_APOT Point in Tangent, Existing 
PROP_E_APC Point of Curvature, Existing 
PROP_E_APOC Point on Curve, Existing 
PROP_E_APT Point of Tangency, Existing 
PROP_E_API Point of Intersection 
PROP_E_ACL Alignment Centerline 
PROP_E_BCOL County Line 
PROP_E_BCTL City Limit Line 
PROP_E_BLDL Land District Line 
PROP_E_BLLL Land Lot Line 
PROP_E_BSL State Line 
TOPO_E_SNGSCM NGS Control Monument 
TOPO_E_SLCM Location Control Monument 
TOPO_E_SLCD Location Control Delta 
TOPO_E_SDCD District Control Delta 
TOPO_E_SBNCHMK Benchmark 
 
These codes are imported into the Geometry Project (.ALG File). All Codes which are not listed 
in the above tables – will be imported into the Surface Project (.DTM File).   
 
14.   Important Step! 

 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned ON.  There should be a check mark next to the Feature Filter Lock. 
 
Ensures that the Feature Filter Lock is turned ON.  
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15.  Select the Property and Alignment Codes 
 
    ** WARNING ** – During this step take care not to roll the scroll button on your 

mouse. 
 
Click Survey Survey Style Filter  and the Survey Style Filter dialog box will appear:  
 
In the Survey Style Filter dialog box --- input the following: 
 

• In the Filter Name: Pulldown – select Property and Alignment Codes 
 
Leave all other entries as default!! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L3-3 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Survey Style Filter dialog box. 

 

                                    
Figure L3-3 Survey Style Filter 

 
 
 

Use the pull-down 
arrow to select the Filter 
named ‘Property and 
Alignment Codes’. 

When the filter name is 
selected the data will be 
filtered as depicted here. 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 3 
 
 

   
 Lab3-10   

16.  Click OK and the Survey Style Filter dialog box will Close and the Filter will be made 
active. 
 
Closes the Survey Style Filter dialog box.  

17.  From the InRoads Menu - click Survey Survey Data to Geometry and the Survey 
Data to Geometry dialog box will appear:   
 
 

• In the Project Name: Pulldown – select 1234567_SDE 
• In the Description: Pulldown – select the default Use Style Description 
• In the Curve Stroking: Pulldown – select the default Horizontal and Vertical 
• In the  Duplicate Names: radio button – select default of Rename 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L3-4 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Survey Data to Geometry dialog box. 

 
                               

                                   \  
Figure L3-4 Survey Data to Geometry 

 
 

 
 
 
18.  Click Apply and then click Close.  

 
 
The Survey Data will be imported into the 1234567_SDE Geometry Project and the 
Survey Data to Geometry dialog box will close.   
 
The Survey Data is imported and the Survey Data to Geometry dialog box closes. 
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19.  The Survey Data is now imported into the Geometry Project. Click on the Geometry 
Tab (Located at the bottom – left hand side of the InRoads Explorer Interface).  
 

 
Then double-click on the 1234567_SDE Geometry 
Project.  A Cogo Buffer folder will appear.  
 
Double-click on the Cogo Buffer folder. 
 
 
 
 
 

 
 
 
Review the InRoads Explorer data frame and note that the Geometry Project now 
contains point data and coordinate information.  Your InRoads Explorer Interface should 
look similar to the screen capture shown below (See Figure L3-5).   
 
Opens the InRoads Geometry Tab and displays the 1234567_SDE Geometry Data 
information in the InRoads Explorer Interface. 

 
 

 
Figure L3-5 Geometry Tab – InRoads Explorer (After File Importation) 
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20.  Save the InRoads Geometry Project: 
 
Even though the Survey data has been imported into the InRoads Geometry Project 
(1234567_SDE.alg) – the data has not yet been saved. As mentioned previously, InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – it is advisable to Save the 
project and its associated modifications or changes. 
 
Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will  be saved to Lab 3 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab 3 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Geometry Project has been saved.                       
                              
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab3     

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 3 
 

   
 Lab3-13   

Lab3C Create a Surface Project Database (.DTM) 
 
In this section of the lab you will be creating a Surface Database Project. This database will be 
used in the next Lab to import the Surface information contained in the Survey Field Book 
(.FWD) into the Surface Database Project (.DTM).   
 
21.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 

Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the Surfaces 
Tab. 
 
 
 
 
 
 
 
 
 
 
 
Opens the Surface Tab in the InRoads Explorer Interface. 

22.  Create the 1234567_SDE.dtm Surface Project by selecting FileNew from the InRoads 
Menu.  The New dialog box will open.  Select the Surface Tab. 
 

• In the Type: Pulldown – select Existing 
• In the Name: Field – enter 1234567_SDE 
• In the Description: Field – enter Training Data 
• In the Maximum Length: Field – enter 300.00 
• In the Preference: pulldown – select EXISTING 

 
The inputs should now correspond to the screen capture depicted in  
Figure L3-6 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the New dialog box allowing you to create a Surface Project. 

 
 
 
 
 
 
 
 
 
 
 

Surfaces TAB 

Scroll Bars 
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Figure L3-6 “New” Surface Project 

 
 
23.  Click Apply and then click Close to create the Surface Project.   

 
The Surface Project is created and the New dialog box closes.   

24.  Even though the InRoads Surface Project was created – it has not yet been saved. 
InRoads retains the data in temporary memory but does not save the data on the fly. It is 
highly recommended to Save the project periodically after any major modifications or 
changes to the data. 
 

• Select FileSave Surface from the InRoads Menu.   
• The Save As dialog box will appear as shown in Figure L3-7. 

 
 

• Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 3\ 
• Enter the File name: as  1234567_SDE 
• Enter the Save as type:  as Surfaces (*.dtm) 
• Click Save and then click Cancel. 

 
Select FileSave Surface from the InRoads Menu.   
 
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 3     
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Figure L3-7 Save As 1234567_SDE.dtm 

 
25.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 

Explorer Interface). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 Then click on the 1234567_SDE Surface.  Note that the Surface Project has been created 
but is currently empty and contains no data – this is denoted by the 0’s depicted in the 
Data Types in the InRoads Explorer. See Figure L3-8 (as shown below).   
 
Opens the InRoads Surface Tab and displays the 1234567_SDE Surface information in 
the InRoads Explorer Interface.  

Surfaces TAB 
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Figure L3-8 Surface Tab – InRoads Explorer (Before File Importation) 

 
 
26.  In the screen capture depicted below –  

 
Note that in the InRoads Explorer Interface Workspace Bar that the 1234567_SDE 
Surface Project has a “Red Rectangle” around the icon. 
 

This denotes that this is the “Active” Surface 
Project.  Any Surface commands will be initiated 
and performed on the current “Active” Surface 
Project. 
 
Also note that there will always be a Default  
Project listed.  InRoads includes this Default Project 
for internal InRoads functionality --- Remember to 
never save data to this Default Project.    
 
 

 
Displays a red rectangle around the 1234567_SDE Surface icon to reflect that this is the 
Active Surface Project upon which commands will be performed. 
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Lab3D Import Survey Data into the Surface Project (.DTM) 
 
The following Lab depicts the process of importing in the Survey Data (Random Terrain Data, 
Breakline Data, etc.) into the 1234567_SDE Surface Project. A Survey Filter has been created 
which will automate the selection of the appropriate Survey Data which is to be imported into the 
Surface Project. The following codes/styles (which are composed of data which includes all 
survey data --- except --- Property and Alignment information) are included in the Survey Style 
Filter which is named DTM Surface Codes: 
 
 
 
27.   Important Step! 

 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned ON.  There should be a check mark next to the Feature Filter Lock. 
 
Ensures that the Feature Filter Lock is turned ON.  

28.  Select the DTM Surface Codes 
 
    ** WARNING ** – During this step take care not to roll the scroll button on your 

mouse. 
 
Click Survey Survey Style Filter  and the Survey Style Filter dialog box will appear:  
 
In the Survey Style Filter dialog box --- input the following: 
 

• In the Filter Name: Pulldown – select DTM Surface Codes 
 
Leave all other entries as default!! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L3-9 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Survey Style Filter dialog box. 
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Figure L3-9 Survey Style Filter 

 
29.  Click OK and the Survey Style Filter dialog box will Close and the Filter will be made 

active. 
 
Closes the Survey Style Filter dialog box.  

30.  From the InRoads Menu - click Survey Survey Data to Surface and the Survey 
Data to Surface dialog box will appear:   
 

• In the Surface Name: Pulldown field– select 1234567_SDE 
• In this dialog box – click on the Preferences… button and the following dialog 

box will appear: 
 

                   
 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 

Use the pull-down 
arrow to select the Filter 
named ‘DTM Surface 
Codes’. 

When the filter name is 
selected the data will be 
filtered as depicted here. 
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• In the dialog box – select the Preference of GDOT.  Then click Load and then 

click Close and the Preferences dialog box will close. 
 
The following entries will automatically be set after selecting the Preference named 
GDOT: 
 

• In the Parent Name: Field – (Blank) 
• In the Description: Pulldown –Use Attributes 
• In the Tolerance: Field – 0.0000 
• In the Maximum Segment Length: Field – 300.0000 
• In the Curve Stroking: Pulldown – Horizontal and Vertical 
• In the Triangulate Surface: Check Box – Checked 
• In the  Duplicate Names: Radio Button – Rename 

 
The inputs should now correspond to the screen capture depicted in  
Figure L3-10 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Survey Data to Surface dialog box. 

 

                                  
Figure L3-10 Survey Data to Surface 
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31.  Click OK and the Survey Data will be imported into the 1234567_SDE Surface Project 
and the Survey Data to Surface dialog box will close.     
 
The Triangulate Surface dialog box will then appear in order to create a “Preliminary” 
Triangulated Surface. 
 
The Survey Data is imported and the Survey Data to Surface dialog box closes. 

32.  In the Triangulate Surface dialog box: 
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Maximum Length: field enter – enter 300.000 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L3-11 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Triangulate Surface dialog box.   

 
 

                                    
Figure L3-11 Triangulate Surface 
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33.  Click Apply.     
 
For Information Only: 
 
Depending on the size of the project – (on most Field Survey Projects which are smaller 
in size) – the triangulation of surfaces is usually very fast.  On these types of projects a 
Results Box will appear which lists the number of Points/Triangles/Elapsed Time. (See 
screen capture below). When these Results appear – the surface has completed 
triangulating. 
 

                         
 
 
On larger projects (such as Mapping Projects) – the triangulation may take awhile. On 
these types of projects --the InRoads Status Bar (Located at the bottom – left hand side of 
the InRoads Interface) usually will depict the completion percentage of the triangulation 
on larger projects. (See screen capture below): 
 

  
 
The “Preliminary” DTM Surface is triangulated. 

34.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface dialog box. 
 
Closes the Triangulate Surface dialog box. 

35.  The Survey Data is now imported into the 1234567_SDE Surface Project.  Click on the 
Surfaces Tab (Located at the bottom – left hand side of the InRoads Explorer Interface) 

and then click on the 1234567_SDE Surface.   
 
 
Review the InRoads Explorer Data Type frame 
and note that the Surface Project now contains 
Data Types that have Features that are active and 
have been populated with points and breaklines. 
Your InRoads Explorer Interface should look 
similar to the screen capture shown below. (See 
Figure L3-12).   
 

 
 

Percentage of 
Completion 
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Figure L3-12 Surface Tab – InRoads Explorer (After File Importation) 

 
 
36.  Save the InRoads Surface Project: 

 
Even though the Survey data has been imported into the InRoads Surface Project 
(1234567_SDE.dtm) – the data has not yet been saved. As mentioned previously, 
InRoads retains the data in temporary memory but does not save the data on the fly. 
Whenever a change has been made to an InRoads Surface Project – it is advisable to 
Save the project and its associated modifications or changes. 
 
Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface Project has 
already been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will  be saved to Lab 3 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 3 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Surface Project has been saved.                        
                              
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 3     
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Lab3E View the Graphical Geometry and Surface Information 
 
The following Lab depicts the process of viewing the Geometry Database information and the 
Surface database information in InRoads and MicroStation. During the viewing of the data – 
numerous commands are utilized in the [MicroStation Software].   The user will need to become 
familiar with MicroStation commands in order to successfully perform the steps required to view 
the Geometry and Surface data.   A good resource for this information is the “MicroStation Help 
Files” which are located in the [MicroStation Menu] under HelpContents.  Please refer to this 
resource for additional information. 
 
  
37.  Steps to view the Geometry Data: 

 
 Click on the Geometry Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the 
Geometry Tab. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Then click on the 1234567_SDE Geometry Project.  Note that the 1234567_SDE 
Geometry Project has a “Red Rectangle” around the icon. This denotes that this is the 
“Active” Geometry Project.  Any Cogo and viewing commands will be initiated and 
performed on the current “Active” Geometry. 
   
Opens the InRoads Geometry Tab and displays the 1234567_SDE Geometry information 
in the InRoads Explorer Interface. 

38.  View the Horizontal Annotation (Geometry Cogo Points) 
 
In the InRoads Software: 
 
Select GeometryView GeometryHorizontal Annotation from the InRoads Menu. 
 
The View Horizontal Annotation dialog box will open. Select the “Main” Tab.   
 
The View Horizontal Annotation dialog box opens. 

Geometry TAB 

Scroll Bars 
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39.  In the  View Horizontal Annotation “Main” Tab: 
 

• Click the Preferences button located at the bottom of the dialog box.   
 

 
 

• In the Preferences dialog box that opens, highlight NO BEARING & 
DISTANCE by left clicking on it once. 
 

 
                         

 
• Click Load & Close. 
• You are then returned to the View Horizontal Annotation Dialog. 

 
  
The inputs should now correspond to the screen capture depicted in  
Figure L3-13 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets the Viewing Options for the View Horizontal Annotations dialog box.   
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Figure L3-13 View Horizontal Annotation 

 
 
40.  Note: 

This Geometry Project contains only Cogo Points (which were collected in the Field 
Survey) and does not contain any Horizontal Alignments. So only Cogo Points will be 
viewed in this Lab. 
 

• The Filter button on the dialog box will be grayed out. Place the curser in the 
Cogo Points ‘Include’ field to activate the Filter button.  (See Screen Capture 
depicted above). 

 
• Click the Filter button to open the Geometry Selection Filter dialog box. See 

Figure L3-14 (as shown below).   
 
Activates the Filter button and opens the Geometry Selection Filter dialog box. 

 

Click here to activate 
Filter button. 
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Figure L3-14 Geometry Selection Filter 

 
 
41.  The Geometry Selection Filter will be utilized to view all of the Geometry Cogo points 

in the 1234567_SDE.alg Project.   
 
 For this Lab – we will leave all entries of Name, Description and Style -- as 

default of Ignore 
 

Once the default entries are selected – use the mouse to left click in the Available: field.  
See Figure L3-14 (as shown above).   
 
Selects the Feature Styles in the Geometry Selection Filter. 

42.  Once the data has been selected – it will be moved from the Available: field to the 
Selected: field.   
 
Click the ALL button. The data will be selected and moved -- then displayed in the 
Selected: field. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L3-15 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
The filtered data is moved from the Available field to the Selected field. 

Left Click once in the 
‘Available:’ field to accept 
the Feature Styles.  
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Figure L3-15 Geometry Selection Filter 

 
 
43.  Click OK to close out of the Geometry Selection Filter dialog box.    

 
Closes the Geometry Selection Filter dialog box.   

44.  View Filtered Points 
 
The Cogo points have been filtered and are available for viewing.  The View 
Horizontal Annotation dialog box should still be active from the previous steps.  This 
dialog box depicts the filtered points in the Cogo Points Area as Selected: points. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L3-16 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
The filtered point data is available for viewing. 
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Figure L3-16 View Horizontal Annotation 

 
 
 
45.  Click Apply and then click Close to close out of the View Horizontal Annotation 

dialog box. 
 
The View Horizontal Annotation dialog box closes and the filtered Cogo Points are 
viewed in MicroStation. 
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46.  View the selected Points in the [MicroStation Software] by using the following 
command located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 

• Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Points. 

 

                    
 
 

 
  
            

• Verify that the MicroStation view window matches that shown in Figure L3-17 
below. 

• Then clear the MicroStation view by selecting Edit ► Select All. 
• Then select the <DELETE> key on the computer keyboard.  All of the DGN 

Graphics will then be deleted from the GDOT 3D Working File.dgn. 
               
The points are displayed and the view is then cleared. 

 
 

   
Figure L3-17 MicroStation View of Geometry Cogo Points 

Fit View 
Zoom In or Out 
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47.   Steps to view the Surface Data: 
 
Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the Surfaces 
Tab. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Then click on the 1234567_SDE Surface Project.  Note that the 1234567_SDE Surface 
Project has a “Red Rectangle” around the icon. This denotes that this is the “Active” 
Surface Project.  Any surface and viewing commands will be initiated and performed on 
the current “Active” Surface. 
   
Opens the InRoads Surfaces Tab and displays the 1234567_SDE Surface information in 
the InRoads Explorer Interface. 

48.  Important Step! 
 
In order to view ALL of the Surface Feature Data, the Feature Filter Lock will need to 
be turned OFF.  
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned OFF.  There should NOT be a check mark next to the Feature Filter 
Lock. 
 
This is an important step! This Lock must be turned OFF in order to view all of the 
Surface Features.  
 
Note: 
If you had only wanted to view selected Features – you would have left the Feature 
Filter turned On - but in order to view ALL Features – the Filter should be turned off. 
 
Ensures that the Feature Filter Lock is turned OFF. 

Surfaces TAB Scroll Bars 
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49.  Click Tools ►Locks from the InRoads pull-down menu.  Ensure that the Feature 
Highlight lock is turned OFF.  There should not be a check mark next to the Feature 
Highlight Lock.  When this lock is turned off … The viewing of features is much faster. 
 
 
Ensures that the Feature Highlight Lock is turned off. 

50.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Style Lock is 
turned off.  There should not be a check mark next to the Style Lock. 
 
Ensures that the Style Lock is turned off. 

51.  For Information Only: 
 
Do not perform the following information contained in Step 51. This information will be 
performed in later Labs. 
 
The View Features command contains a Feature Filter which can be utilized to view 
specific Features instead of All Features. (To use this command the Feature Filter Lock 
must be turned on). For example a Filter can be created to view just random points or 
breaklines, etc.  
 
The use of the Feature Filter will be described in later Labs. For this Lab – you will 
view ALL of the Features. 
 
Information regarding the use of Feature Filters. 

52.  View the Surface Features  
 
In the InRoads Software - select SurfaceView SurfaceFeatures and the View 
Features dialog box will appear: 
 

• In the Surface: Pulldown – select 1234567_SDE 
 

When the dialog is first opened – all of the Features in the Features: list will be 
highlighted in blue (Leave all of the features “highlighted blue).  This will ensure that all 
Features are graphically viewed.  
 
The Features which you wish to view MUST be highlighted Blue. Features can be 
highlighted by selecting them with the mouse and a combination of the Ctrl key or Shift 
key on the keyboard. 

 
Leave all other entries as default. 
 
The inputs in the View Features dialog box should now correspond to the screen 
capture depicted in Figure L3-18 (as shown below).  Verify to ensure that your input 
matches the screen capture.  
 
Opens the View Features dialog box. 
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Figure L3-18 View Features 

 
 
53.  Click Apply and then click Close and the View Features dialog box will close.  

 
Closes the View Features dialog box. 

54.  View the selected Surface Features in the [MicroStation Software] by using the following 
command located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Features. 
 

 
            
 
 
 
 
 
Verify that the MicroStation view window matches that shown in Figure L3-19. 
 
The Surface Features are displayed and the view is fit to the MicroStation screen. 

 
 

IMPORTANT: 
Ensure that the Features you 
wish to view are highlighted 
in blue.  Features can be 
highlighted by selecting them 
with the mouse and a 
combination of the Ctrl key 
or Shift key on the keyboard. 

Fit View 
Zoom In or Out 
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Figure L3-19 MicroStation View of Surface Features 

 
55.  For Information Only: 

 
The Geometry Data and Surface Data have been imported from the 1234567_A.fwd 
Survey Field Book into the respective Geometry/Surface databases and a “Preliminary” 
DTM has been triangulated.  
 
The data contained in the MicroStation View is “graphical” only. The actual data is 
contained in the InRoads database(s). Any data deleted in MicroStation can be re-viewed 
using InRoads and MicroStation commands.   
 
Information regarding the deleting of graphical MicroStation data. 

56.  Very IMPORTANT Step !!   
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn.  
 

57.                    
                 This concludes Lab 3.  Do not proceed until the Instructor directs you to do so. 
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Lab 4 
Resolving Crossing Segments 

 
Objective 
 
In the previous Lab(s) a Geometry Project and a Surface Project were created from the data 
contained in the Survey Field Book. The next step for the processing of the Geometry Project 
includes the establishment of Existing Centerline data, Existing Right of Way data and Property 
data.  The process for inputting in the Geometry Project data will be discussed in Section 3 – 
beginning with Lab 10. 
  
The following Lab(s) will detail the procedures for processing the Field Survey Data for a 
Surface Project (.DTM).  
 
During the processing of the survey data, situations can occur where breaklines may overlap or 
breaklines may cross at mismatched elevations. If these segment crossings are not resolved, 
erroneous point and breakline data may affect the triangulation and accuracy of the DTM 
(Digital Terrain Model). These crossings need to be addressed and resolved prior to the final 
creation of the DTM Surface to ensure that an accurate Surface Model is generated.  
 
A Surface must first be triangulated in order to resolve crossing segments. This is a preliminary 
triangulation only – the final creation and processing of the Existing DTM Surface will be 
discussed in later Labs. InRoads contains a View Crossing Segments command which not only 
views the crossing and/or overlaps but also generates a Crossing Segments report. InRoads also 
contains a  Resolve Crossing Segments command which is an automated tool which can assist 
in the repairing of crossing and overlapping segments that have small differences in elevation.  
 
There are several tools and methods in InRoads to resolve crossing segments and mismatched 
elevations.  The following Lab depicts one method of resolving this issue. 
 
The objective of Lab 4 is to: 
 

• Create a “Preliminary” triangulated Surface to check for crossing segments. 
• Utilize the View Crossing Segments command to determine the location of crossing 

segments. 
• Utilize the Resolve Crossing Segments command to assist in the resolution of 

crossing segments. 
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Lab4A Create a “Preliminary” Triangulated Surface 
 
In this section of the lab you will be creating a “Preliminary” triangulated surface which will be 
utilized in resolving crossing breaklines. A triangulated surface must first exist in order to use the 
Crossing Segments commands.  
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Load the InRoads Survey, Geometry and Surface File(s)   
 
Select FileOpen from the InRoads Menu.   
 
The Project Defaults (which were set up in Lab 1C) are set to the following Path: 
C:\InRoads Data\1234567\SDE Labs. 
 
Browse to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab 4 
 
Selects the path to open the Survey, Geometry and Surface File(s). 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  After navigating to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab 4 
 
Select the file named:  
1234567_A.fwd – then click Open.  
 
Select the file named:  
1234567_SDE.alg – then click Open.  
 
Select the file named:  
1234567_SDE.dtm – then click Open 
 
Then click Cancel.   
 
 
The 1234567_A.fwd, 1234567_SDE.alg and 1234567_SDE.dtm file(s) will open. 

5.  This is an important step.  Turn off the Planimetric Survey Data: 
 
The Planimetric View can be turned on/off in InRoads by the following steps: 
 
Select SurveyView Survey Data Planimetrics from the InRoads Menu.   
 
Remove the check mark by Planimetrics to turn the planimetric viewing data OFF. 
 
Steps to turn the Planimetric Survey Data OFF in InRoads/MicroStation. 

6.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  Note that the “Red Rectangle” denotes that the 1234567_SDE 
project is the active Surface. 
 
  

                                 
 
 
 
 
 
 
Opens the “Surfaces Tab” in the InRoads Workspace Bar. 

Surfaces TAB 
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7.  The “Preliminary” Surface will now be triangulated for use in the resolution of crossing 
segments. 
 
Select SurfaceTriangulate Surface.  The Triangulate Surface dialog box will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Maximum Length: field enter – 300.000 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L4-1 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Triangulate Surface dialog box.   

      
 
 

                               
Figure L4-1 Triangulate Surface 
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8.  Click Apply.   
 
Please be Patient! 
 
It may take a while for the Surface to triangulate depending on the size of the file! 
 
The InRoads Status Bar (Located at the bottom – left hand side of the InRoads Interface) 
usually will depict the completion percentage of the triangulation on larger projects. (See 
screen capture below): 
 
 
 

  
 
 
The “Preliminary” DTM Surface is triangulated. 

9.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface dialog box. 
 
Closes the Triangulate Surface dialog box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Percentage of 
Completion 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 4 
 
 

   
 Lab4-6   

Lab4B View Crossing Segments 
 
In the following Labs, the View Crossing Segments and the Resolve Crossing Segments 
commands will be used to eliminate certain segment crossings.   (NOTE: Not all segment 
crossings will be resolved in this Lab.) 
 
 The View Crossing Segments command requires a surface to be triangulated before using this 
utility. This utility can be used -- not only for the viewing of the crossing segments -- but also to 
generate a Report detailing information of the crossing segments. When using the View 
Crossing Segments command -- crossing segment points are represented by a Yellow X.  
Mismatched elevations are represented by a Red O.   Basically there are two main types of 
crossing segments: overlaps and mismatched elevations.  
 
Overlaps:  InRoads has a basic rule that the longest segment of two overlaps is dominant.  Based 
on this rule InRoads automatically “ignores” the shorter segment during the triangulation process 
and triangulates according to the dominant breakline. The resolution of these overlaps is 
determined during the triangulation process. The Segment Crossings which have been resolved 
during the triangulation are represented by (a Yellow X).  These segment crossings with (a 
Yellow X) can be ignored. 
 
Mismatched Elevations:  Mismatched elevations occur when crossing breaklines have the same 
XY Coordinate but different elevations (Z).  Minimal elevation differences (any elevation 
difference less than 0.020) can be repaired using the InRoads Resolve Crossing Segments 
command (Automatic Option).  Any elevation differences that are greater than 0.020 must be 
manually repaired by using the InRoads Resolve Crossing Segments (Interactive Option).  If a 
specific elevation needs to be modified to correct the crossing segment – the Surface Edit 
Feature Points command may be used. The Mismatched Elevations are represented by (a Red O).  
These must be resolved to ensure an accurate surface. 
 
The View Crossing Segments command is used to assist in determining the location of segment 
crossing points – both visually and in Report format. 
  
10.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Style Lock is 

turned off.  There should not be a check mark next to the Style Lock. 
 
Ensures that the Style Lock is turned off.  

11.  Click Surface View SurfaceView Crossing Segments and the View Crossing 
Segments dialog box will appear:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In this dialog box – click on the Preferences… button and the following dialog 

box will appear: 
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• In the dialog box – select the Preference of EXISTING. Then click Load and 
then click Close and the Preferences dialog box will close.  
 
 

Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L4-2 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the View Crossing Segments dialog box 

 
 
 

    
Figure L4-2      View Crossing Segments 

 
 
 
 

*FYI: Segment Crossing Points and Mismatched 
elevations are both placed in MicroStation on the 
named level ‘ECON_E_Crossing-Breakline-Cell’.  
Segment Crossing Points are viewed with a yellow X 
and are controlled through ‘ByLevel’.  Since 
ByLevel can only control one symbol at a time, the 
Mismatched elevations are not set up as ByLevel.  
Mismatched elevations will view as a red O and are 
manually set in the InRoads Text Symbology dialog 
which can be accessed by double clicking the 
Mismatched Elevation text under the Object heading.  
This information is provided to explain why one 
object says BYLEVEL and the other object has a red 
square in the View Crossing Segments dialog. 
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12.   Click Apply.    Then click Results. 

 
A Results Report will appear which details the overlaps and/or mismatched elevations. 
(Ignored) will be listed by the segment for each point coordinate that was ignored for 
calculations. 
 
Review the Report.  
 
If desired -- the Report can also be printed or saved to disk by selecting the Print or Save 
As command on the Report interface.  
 

                                                                                                                   
 
Following is a partial screen capture of the Results Report.  See Figure L4-3 (as shown 
below).   
 
 
The Results Report from the View Crossing Segments command is generated. 

 
 

 
Figure L4-3 Results Report (View Crossing Segments) 
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13.   In the “Results Report” – click Close.   The View Crossing Segments dialog box should 
still be active.   
 
 
The View Crossing Segments Results Report is closed. 

14.  Click Close to close out of the View Crossing Segments dialog box.  The next Lab will 
detail how to resolve the mismatched elevations. 
 
 
Closes the View Crossing Segments dialog box.     

15.  There are still some mismatched elevations present in the database.  These crossings can 
be viewed in MicroStation and are depicted by the following:  Segment Crossings (a 
Yellow X) ----- Mismatched Elevations (a Red O). 
 
 
View some of the crossings in [MicroStation] by using the following commands located 
under the MicroStation View 1 Window: 
 
 
In the [MicroStation Software] – 
 
 
 Select the “Fit View” Icon:  
 
 
Select the “Zoom In or Zoom Out” Icon as appropriate to view the X’s and O’s. 
 
 
 

                  
            
 
 
 
 
 
 
 
 
 
 
Please Note:  DO NOT Delete the MicroStation DGN Graphics at this time – these 
graphics containing the X’s and O’s will be used later in Lab 4C and Lab 4D. 
 
 
Views the Segment Crossings and Mismatched Elevations in MicroStation     

Fit View Zoom In or Out 
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Lab4C Resolve Crossing Segments – Automatic  Mode 
 
In the following Lab, the Resolve Crossing Segments command will be used to eliminate 
mismatched elevations.  
 
(NOTE:  Not all mismatched elevations will be resolved in this Lab.) 
 
The Resolve Crossing Segments command requires a surface to be triangulated before using 
this utility. The Automatic Mode Option resolves all crossing segments with mismatched 
elevations that have a Delta Tolerance of 0.020 or less.  This is considered the standard GDOT 
default tolerance.  Any mismatched elevations with a 0.020 tolerance or less are considered to be 
of minimum significance. Any mismatched elevations greater than a Delta Tolerance of 0.020 
should be manually evaluated and resolved by using the Resolve Crossing Segments command 
or the Edit Surface Tools. The Resolve Crossing Segments command uses a Match Elevation 
of Median (point elevation) to resolve the mismatched elevations with a 0.020 tolerance or less. 
 
After utilizing the Resolve Crossing Segments command the first time in a dataset – all 
mismatched elevations of tolerance 0.020 or less will be resolved and a Results Report will list 
these items which have been resolved. The Unresolved mismatched elevations are Not listed in 
the Results Report. These mismatched elevations are listed by using the Interactive Mode Option 
in the Resolve Crossing Segments command. 
 
Please Note: 
After using this command and resolving the mismatched elevations – the surface must be re-
triangulated in order to view the Surface Data.  
 
The Resolve Crossing Segments command is used to assist in resolving mismatched elevations 
(Points which contain the same XY Coordinate but different Z elevations).   
 
 
16.  Click Surface UtilitiesResolve Crossing Segments and the Resolve Crossing 

Segments dialog box will appear:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Mode: field –  select Automatic  
• In the Delta Tolerance: field – select < 0.020 

(Ensure the Less Than Sign is selected) 
• In the Match Elevation: entry – select       Median 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L4-4 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Resolve Crossing Segments dialog box 
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Figure L4-4 Resolve Crossing Segments - Automatic 

 
17.  Click Apply.  Then click Results. 

 
A Report will appear which details the Crossing Segments and Mismatched Elevations. 
Any Mismatched Elevations LESS THAN 0.020 were automatically resolved.       
 
Review the Report.  
 
As shown in the Report – the Resolved Items were 42 

 
Items greater than the 0.020 Delta Tolerance will need to be manually edited to correct 
the mismatched elevations.    
  
If desired -- the Report can also be printed or saved to disk by selecting the Print or Save 
As command on the Report interface.  
 
 
 
                                                             
 
 
 
 
 
Following is a partial screen capture of the Results Report.  See Figure L4-5 (as shown 
below).   

**WARNING**  
 
Ensure the Delta 
Tolerance of < 0.020 is 
selected.  
 

**Information** 
 
When using the 
Automatic Mode the 
Delta Tolerance should 
be set to < 0.020. 
When using the 
Interactive Mode the 
Delta Tolerance should 
be set to > 0.020. 
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Figure L4-5 Results Report (Resolve Crossing Segments) 

 
 

 
18.   In the “Results Report” – click Close.   The Resolve Crossing Segments dialog box 

should still be active.  Do not close the Resolve Crossing Segments dialog box. It will 
be used in the next Lab to demonstrate how to interactively resolve the mismatched 
elevations. 
 
The Resolve Crossing Segments Results Report is closed. 

19.  Please Note:   
 
DO NOT Delete the MicroStation DGN Graphics at this time – these graphics containing 
the X’s and O’s will be used later in Lab 4D. 
 
Views the Segment Crossings and Mismatched Elevations in MicroStation     
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Lab4D Resolve Crossing Segments – Interactive  Mode 
 
As mentioned in the previous Lab, the Resolve Crossing Segments command Automatic Mode 
Option resolves all crossing segments with mismatched elevations that have a Delta Tolerance of 
0.020 or less.  Any mismatched elevations greater than a Delta Tolerance of 0.020 will be 
manually evaluated and resolved by using the Resolve Crossing Segments Interactive Mode 
Option or the Edit Surface Tools commands. The following Lab demonstrates the use of the 
Interactive Mode Option. 
 
Please note:   There are also several Edit Surface commands which may be used to eliminate 
mismatched elevations. 
 
In the following Lab, the Resolve Crossing Segments Interactive Mode Option will be used to 
eliminate certain segment crossings of mismatched elevations. (NOTE: Not all mismatched 
elevations will be resolved in this Lab). 
 
 
20.  The Resolve Crossing Segments dialog box should still be open from the previous Lab 

4C.  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Mode: field –  select Interactive 
• In the Delta Tolerance: field – select > 0.020 

(Ensure the Greater Than Sign is selected) 
• In the Match Elevation: entry – select       Median 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L4-6 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
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Figure L4-6 Resolve Crossing Segments - Interactive 

 
21.  Click Apply.    

 
A List of Crossing Segments (highlighted in red) will appear in the list field of the dialog 
box. There are 19 Crossing Segments that will need to be manually resolved.  The 
Feature 1, Feature 2 and the Elevation Delta of the mismatched elevation crossings are 
also depicted.   
 
The Resolve Crossing Segments dialog should now correspond to the screen capture 
depicted in Figure L4-7 (as shown below).  Verify to ensure that your input matches the 
screen capture.    
 
 

 
 
 
 
 
 
 
 

**WARNING**  
 
Ensure the Delta 
Tolerance of > 0.020 is 
selected.  

**Information** 
 
When using the 
Automatic Mode the 
Delta Tolerance should 
be set to < 0.020. 
When using the 
Interactive Mode the 
Delta Tolerance should 
be set to > 0.020. 
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Figure L4-7 Resolve Crossing Segments - Interactive 

 
 

22.  For Information Only 
 
In InRoads Select Series 2, the method for manually resolving crossing 
segments/mismatched elevations has changed.  The crossing can now be interactively 
resolving using the Resolve Crossing Segments dialog. There are three methods to 
choose in order to resolve the crossings: High, Low and Median. 
 
The method for the option to utilize will be up to the Survey Data Engineer. The method 
selected depends on the situation and will need to be manually evaluated by the SDE 
before resolving the crossing. Once the High, Low or Median option is selected, any 
modifications or resolutions will reflect the current Match Elevation setting that is 
selected. 
 
In the following Steps, we will utilize the Match Elevation Median option.  
 
 

There are 19 Crossing 
Segments which need 
to be resolved. 

List of the 19 Crossing 
Segments depicted in 
Red text. 

Set to Median 
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23.  The easiest method to resolve the Mismatched Elevations (depicted by a Red O) is to 
view the Feature 1 and Feature 2 Features.    
 

• Left click on the Feature1/Feature2 of TPBL170/TPBL170 and the line will 
highlight in Blue. 

• Notice that a Purple X denotes the location of the mismatched crossing in the 
MicroStation view. 

 
                           

                                                 
 

24.  • Next, Right Click on the Blue Highlighted line of 
 
            and a right click menu will appear: 
 

              
 

• Select the Display Features command and the TPBL170 feature will appear in 
the MicroStation view. This allows you to see the crossing intersection of the  
Feature (s). 

• Again, Right Click on the Blue Highlighted line of 
 
            and the right click menu will appear. 

• Select the Insert Point command. A MEDIAN point will automatically be 
inserted. The Elevation Delta will then change to Zero and the Features will no 
longer have Red text but will change to a Black Text.  

 
The Resolve Crossing Segments dialog should now correspond to the screen capture 
depicted in Figure L4-8 (as shown below).  Verify to ensure that your input matches the 
screen capture.    
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Figure L4-8 Resolve Crossing Segments - Interactive 

 
25.  The other 18 Crossings will not be resolved in this Lab. 

 
• Click Apply and then click Close to exit the Resolve Crossing Segments dialog. 

 
26.  Whenever the Resolve Crossing Segments command is used, the Features will need to 

be re-triangulated for the changes to be represented in the DTM. This should only be 
done after all of the Crossings have been resolved.  
 
Select SurfaceTriangulate Surface.  The Triangulate Surface dialog box will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Maximum Length: field enter – 300.000 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L4-9 (as shown below).   

There are now 18 
Crossing Segments 
which need to be 
resolved. 

Feature TPBL170 has 
been resolved and now 
has a Zero Elevation 
Delta and is shown in 
Black Text. 
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Figure L4-9 Triangulate Surface 

 
27.  Click Apply.   

 
Please be Patient! 
 
It may take a while for the Surface to triangulate depending on the size of the file! 
 
The InRoads Status Bar (Located at the bottom – left hand side of the InRoads Interface) 
usually will depict the completion percentage of the triangulation on larger projects. (See 
screen capture below): 
 
 
 

  
 
 
The  DTM Surface is triangulated. 

28.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface dialog box. 
 
Closes the Triangulate Surface dialog box. 

 
 
 
 
 
 
 
 
 

Percentage of 
Completion 
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29.  Save the InRoads Surface File 
 
Even though several of the Segment crossings have been resolved – the data has not yet 
been saved. As mentioned previously, InRoads retains the data in temporary memory but 
does not save the data on the fly. Whenever a change has been made to an InRoads 
Surface Project – Save the project and its associated modifications or changes. 
 
Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface has already 
been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will be saved to Lab 4 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 4 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Surface Project has 
been saved.                       
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 4   

30.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
  
 
Deletes the Graphics from the GDOT 3D Working File.dgn file to ensure a clean DGN 
file for the next Lab. 

31.                    
                 This concludes Lab 4.  Do not proceed until the Instructor directs you to do so. 
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Lab 5 
Create/Import an Exterior Boundary 

 
Objective 
 
After the Segment Crossings have been resolved – an Exterior Boundary (a Limit Line with 
Feature Style of TOPO_E_TLIML) will be created to represent the bounds of the field data.  
This Exterior Boundary is also used in the trimming of extraneous triangles from the DTM 
Surface.  During the creation of a DTM Surface, extraneous triangles (erroneous triangle data) 
will be generated which does not represent actual Surface data. A common situation where this 
occurs is at “T Intersections”.  In order to remove these triangles (which represent inaccurate 
data) an Exterior Boundary is required.  
 
Although there are several methods to create an Exterior Boundary – the method depicted in the 
following Lab represents a common practice which will work for most situations.  Due to the 
current InRoads Software functionality, InRoads requires that the Exterior Boundary be 
composed of existing surface data located inside or on the outer-most Feature Points (TLIML 
points) represented in the DTM Project.  In order to create the Exterior Boundary a complex 
shape (one continuous entity) must be created so that the DTM triangulation will honor the limits 
of the Exterior Boundary.   
 
*Please Note the following InRoads Requirements: 
 

• InRoads has a requirement that only ONE Exterior Boundary may be present in a DTM 
Project. 

• The Exterior Boundary must be one continuous complex shape. 
• The Existing Feature Points on the exterior Boundary must be located on the Existing 

Surface in order for the Boundary to trim triangles correctly.  
• If there are Obscured Areas on the outside of the Surface data – the Exterior Boundary 

must not include these areas inside of the Exterior Boundary. 
• Interior Obscured Areas can be included inside the Exterior Boundary. 

 
 
The objective of Lab 5 is to: 
 

• Create an Exterior Boundary in MicroStation  
• Import the Exterior Boundary into InRoads 
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Lab5A Create an Exterior Boundary 
 
 In this Lab you will be creating an Exterior Boundary which will represent the extents of the 
Field Data.  This Exterior Boundary will be used in a later Lab to trim extraneous triangles from 
the Existing Surface Model.  
 
The majority of the Lab work for the generation of the Exterior Boundary will be performed in 
the [MicroStation Software].   The user will need to become familiar with MicroStation 
commands in order to successfully perform the steps to generate the Exterior Boundary.  
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
  

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Load the InRoads Survey, Geometry and Surface File(s) 
 
Select FileOpen from the InRoads Menu.   
 
The Project Defaults (which were set up in Lab 1C) are set to the following Path: 
C:\InRoads Data\1234567\SDE Labs. 
 
Browse to the following path: C:\InRoads Data\1234567\SDE Labs\Lab 5 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  After navigating to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab 5 
 
Select the file named:  
1234567_A.fwd – then click Open.  
 
Select the file named:  
1234567_SDE.alg – then click Open.  
 
Select the file named:  
1234567_SDE.dtm – then click Open 
 
Then click Cancel.   
 
The 1234567_A.fwd, 1234567_SDE.alg and 1234567_SDE.dtm file(s) will open. 

5.  This is an important step.  Turn off the Planimetric Survey Data: 
 
The Planimetric View can be turned on/off in InRoads by the following steps: 
 
Select SurveyView Survey Data Planimetrics from the InRoads Menu.   
 
Remove the check mark by Planimetrics to turn the planimetric viewing data OFF. 
 
Steps to turn the Planimetric Survey Data OFF in InRoads/MicroStation. 

6.  This is an important step.  Click ToolsLocks from the InRoads pull-down menu.   
 
Ensure that the following Lock is set as indicated below:   
 
 
Feature Filter          (There SHOULD be a Check Mark next to Feature Filter)  
 
Ensures that the Feature Filter Lock is turned ON. 

7.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the following Locks 
are turned OFF.   
 
 
There should not be a check mark next to the  following: 
Feature Highlight   
Style 
Delete Ink 
Element Snap 
Station 
 
 
 
 
Ensures that the appropriate Locks are turned OFF. 
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8.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the following Locks 
are set as indicated below:   
  
Pencil Lock is set to Pencil   
Locate Lock is set to Features  
Point Snap Lock is checked 
Report Lock is checked  
Toolbar Lock is checked   
 
Ensures that the appropriate Locks are turned ON. 

9.  View the TOPO_E_TLIML Surface Features.  
 
Click SurfaceView SurfaceFeatures from the InRoads pull-down menu and the 
View Features dialog box will appear.    
 

• In the Surface: Pulldown – select 1234567_SDE 
 
 
Click on the Filter button. 
 
 
 
 
 
 
Opens the View Features dialog box 

10.  View the selected Features: 
 
    ** WARNING ** – During this step take care not to roll the scroll button on your 

mouse. 
 
The Feature Selection Filter dialog box will open. In the Feature Selection Filter 
dialog box --- input the following: 
 

• In the Filter Name: pulldown – select TLIML BREAKLINE 
 
This will filter the view to include the following Surface Feature codes:  
TLIML 
 
Leave all other entries as default! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L5-1 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Feature Selection Filter dialog box. 
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Figure L5-1 Feature Selection Filter 

 
 

 
11.   Click OK and the Feature Selection Filter dialog box will Close.  The View Features 

dialog box should still be open from the previous steps. 
 
The inputs in the View Features dialog box should now correspond to the screen capture 
depicted in Figure L5-2 (as shown below).  Verify to ensure that your input matches the 
screen capture.    
 
Closes the Feature Selection Filter dialog box. 

 
 
 
 
 
 
 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 

Use the pull-down arrow to 
select the Filter Named 
‘TLIML BREAKLINE’. 

When the filter name is 
selected the data will be 
filtered as depicted here. 
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Figure L5-2 View Features 

 
 
 
 

12.  Click Apply. 
 
 
 Views the  1234567_SDE (TLIML Features) in MicroStation 

13.  Click Close to close out of the View Features dialog box. 
 
 
Closes the View Features dialog box. 

14.  In order to create the Exterior Boundary – the user must become familiar with the 
appropriate settings and commands to utilize in MicroStation. A good resource for this 
information is the “MicroStation Help Files” which is located in the [MicroStation 
Menu] under HelpContents.  Please refer to this resource for additional information. 
 
 
 
 
 
 
Refers to the location for the MicroStation “Help Files”. 
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15.  For Information Only: 
 
The following MicroStation options will assist the user in creating the Exterior 
Boundary.  These may be turned on/off based on the situation and the user’s preference.  
 
 
Note:  
The user will be provided the steps to turn these options on/off later in this Lab. 
 

A. AccuDraw should be turned off. (When turned on – the point is harder to select.) 
B. AccuSnap should be turned off (unless selecting a point).  
C. When selecting a point (if AccuSnap is turned on) - a “yellow         will appear to 

denote the point location.   
D. The Default Snap must be set to “Keypoint”. 
E. When selecting the point – do not use the tentative snap button to pick the point --

- select the point by LEFT clicking on the point!   
 
Initiates the appropriate MicroStation settings. 

16.  To turn MicroStation AccuDraw on/off – 
 
Click the AccuDraw icon in the Primary Tools tool box: 
 
 
 
 

  
 
 
AccuDraw is off when the XYZ Coordinate Window (See screen capture below) is not 
depicted:  Ensure AccuDraw is turned Off. 
 
 
                      
                   AccuDraw Docked View                             AccuDraw Undocked View 
 

 
                                
 
                                                                                             
 
 
 
 
 
Depicts AccuDraw settings and turns AccuDraw Off. 

AccuDraw Icon 
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17.  To turn AccuSnap on/off –  
 
In the [MicroStation Menu] -- Select SettingsSnapsAccuSnap.   
 
Under the General Tab – remove the checkmark        next to the option “Enable 
AccuSnap” to turn off AccuSnap.  Add the checkmark         to turn on AccuSnap.   (See 
dialog box shown below.) 
 
Ensure AccuSnap is turned Off. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Initiates the AccuSnap command and turns AccuSnap off. 

18.  To turn “Keypoint” Snap on –  
 
Hold down the <SHIFT> key and Tentative Snap in the MicroStation Window.   
A list box will appear – select the Keypoint Snap option from the list. A Black Dot 
 next to the Keypoint Snap represents the currently active Snap.   
 
 
 
 
 
 
 
 
 
 
Initiates the Keypoint Tentative Snap. 
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19.  For Information Only 
 
Since this is a “Working DGN File” and the Exterior Boundary is a temporary graphic – 
it does not matter what color, level, linestyle, etc. you select to create the Exterior 
Boundary.  After importation of the boundary into InRoads – the temporary graphics will 
be deleted. The actual Exterior Boundary (after it is imported into InRoads) will 
automatically depict the correct Feature Style attributes - color, weight, level, etc.   
 
 
Sets the Element Attributes to use for the Exterior Boundary. 

20.  View the selected Features in the [MicroStation Software] by using the following 
commands located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Features. 
 
 

                     
 
 
            
 
 
 
 
 
Views the Features in MicroStation. 

21.  In the [MicroStation Software] – 
 
Select “Fit View” and all of the TOPO_E_TLIML Features will be depicted in the 
MicroStation View Window.  See screen capture depicted below. 
 
 
 
 
 
 
 
 
 
 
 
 
Views the extents of the Features in MicroStation. 

Fit View Zoom In or  Out 
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22.  For Information Only  
 
An Exterior Boundary must be one continuous complex shape. Although sometimes the 
TOPO_E_TLIML (Topo Limit Line) Feature is collected as one continuous 
alignment/segment - in many cases – the TOPO_E_TLIML may consist of several 
independent alignments/segments. In order for InRoads to utilize the Exterior Boundary 
for trimming extraneous triangles, one continuous concatenated Feature must be created. 
To accomplish this task - the “segments” will need to be joined into a Complex Shape. 
 
 
The following steps depict the process of creating a complex shape. 
 
  
 
Details information regarding a complex shape. 

23.   To Create a Complex Shape: 
 
In the [MicroStation Software] –  
 
 
Select “Create Complex Shape”   
From [MicroStation Main Toolbar] 
 
 
 
The Create Complex Shape dialog box will open. In the Create Complex Shape dialog 
box --- input the following: 
 

• In the Method Pulldown – select Manual 
• In the Area Pulldown – select Hole 

 
Leave all other entries as default! 
 
The inputs should now correspond to the screen capture depicted below. Verify to ensure 
that your input matches the screen capture.    
  

                   
 
Opens the Create Complex Shape dialog box in MicroStation.  
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24.  Next - Left click on Feature TOPO_E_TLIML108 and then Left click on Feature 
TOPO_E_TLIML. Each segment will highlight in purple when selected.  Left click at a 
random location in the MicroStation window to “accept” the input.  The Complex Shape 
will now form one continuous entity. 
 
Right click at a random location in the MicroStation window to exit the command. 
 
 
The MicroStation view should now correspond to the screen capture depicted in Figure 
L5-3 (as shown below).  Verify to ensure that your input matches the screen capture.    
 
 
     
 
Depicts steps to create a Complex Shape in MicroStation. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure L5-3 Steps to create a Complex Shape 
 
 
 
25.  For Information Only:  

 
The TOPO_E_TLIML Surface Features have now been concatenated into one 
continuous entity (Complex Shape).  The next Lab (Lab 5B) will depict the process of 
importing the TOPO_E_TLIML Surface into the InRoads 1234567_SDE.dtm Surface 
Project.     
 
Depicts steps to create a Complex Shape in MicroStation. 

 
 

Left Click Here—to 
select 
TOPO_E_TLIML108 

Left Click Here—to 
select 
TOPO_E_TLIML 
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Lab5B Create a “Preliminary” Triangulated Surface 
 
In this section of the lab you will be creating a “Preliminary” triangulated surface which will be 
used later in (Lab 5C) to “drape” the Exterior Boundary on in order to obtain point elevations 
(Delta Z).   
 
26.  This is an important step.   

 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the following Locks 
are turned OFF.   
 
There should not be a check mark next to the  following: 
 
Feature Filter           
Feature Highlight   
Style 
Delete Ink 
Element Snap 
Station 
 
Ensures that the appropriate Locks are turned OFF. 

27.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the following Locks 
are set as indicated below:   
 
Pencil Lock is set to Pencil   
Locate Lock is set to Features  
Point Snap Lock is checked 
Report Lock is checked  
Toolbar Lock is checked   
 
Ensures that the appropriate Locks are turned ON. 

28.  The “Preliminary” Surface will now be triangulated for use in draping the Exterior 
Boundary. 
 
Select SurfaceTriangulate Surface.  The Triangulate Surface dialog box will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Maximum Length: field enter – 300.000 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L5-4 (as shown below).  Verify to ensure that your input matches the screen 
capture.  
 
Opens the Triangulate Surface dialog box.   
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Figure L5-4 Triangulate Surface 

 
 
 
29.  Click Apply.   

 
The “Preliminary” DTM Surface is triangulated. 

30.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface   dialog box. 
 
Closes the Triangulate Surface dialog box. 
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Lab5C      Import the Exterior Boundary (TOPO_E_TLIML) into InRoads 
 
After the Exterior Boundary has been created in MicroStation, the graphic complex shape will be 
imported into the InRoads Existing Surface Model.  The Exterior Boundary will be given a 
Feature Style of TOPO_E_TLIML and will be tagged as Point Type of Exterior.   This 
Exterior Boundary will be used to trim out extraneous triangles from the Field DTM Surface.    
 
The following requirements must be met for the Exterior Boundary to import correctly. 
 
InRoads Requirements for Exterior Boundary Importation: 
 

• InRoads has a requirement that only ONE Exterior Boundary may be present in a DTM 
Project. 

• The Exterior Boundary must be one continuous complex shape. 
• The Existing Feature Points on the exterior Boundary must be located on the Existing 

Surface in order for the Boundary to trim triangles correctly. The Exterior Boundary will 
therefore use ‘element elevations’ from the field surveyed TOPO_E_TLIML features as 
opposed to draping the surface as is done on photogrammetric mapping projects. 

 
In this section of the lab you will be importing the Exterior Boundary (the complex shape created 
in MicroStation) into the 1234567_SDE.dtm Surface Project.  The Exterior Boundary will then 
be available for trimming of the extraneous triangles from the DTM Surface.  

 
On a side note:  If there were any Interior Boundaries (Interior “Obscured Areas”) – 
TOPO_E_DOBSC Feature Style ---- these Obscured Areas are tagged internally by 
InRoads to automatically be obscured. There is no extra step in the obscuring of 
interior areas of the DTM – these interiors triangles will already be trimmed. 
 
 

31.  In the [MicroStation Software] – 
 
 

                  
 
 
 
 
 
 
 
 
Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Exterior Boundary. 
 
Zoom in or out to view the Exterior Boundary in MicroStation. 

 Fit View 
 Zoom in or out 
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32.  Import the Exterior Boundary into InRoads  
 
In the InRoads Software: 
 
Select FileImportSurface from the InRoads Menu. The Import Surface dialog 
box will open. Select the “From Graphics” Tab. 
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Load From: Pulldown – select Single Element 
• In the Elevations: Pulldown – select Use Element elevations 

**NOTE:  The Drape Surface option is used during photogrammetric mapping 
projects.  Full Field mapping projects use element elevations from 
the Topo limit lines (TOPO_E_TLIML) picked up in the field 
which are not available during photogrammetric mapping projects. 

 
In the Features Area of the dialog box: 
 

• In the Seed Name: field – type the word XBOUNDARY   
(all upper case letters -- it is case sensitive) 

• In the Feature Style: Pulldown – select TOPO_E_TLIML 
• In the Point Type: Pulldown – select Exterior 
• In the Duplicate Names: radio button – select       Rename 
• In the Exclude from Triangulation: check box –  

(Make sure there is NO Check Mark) 
 

Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L5-5 (as shown below).  Verify to ensure that your input matches the screen 
capture exactly.    
 
Opens the Import Surface dialog box allowing you to import an Exterior Boundary.   
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Figure L5-5 Import Surface (From Graphics) Tab 

 
33.  Click Apply. 

 
You will then be prompted in the [MicroStation Software] to … Identify element… (See 
the prompt information at the bottom – left corner of the MicroStation View Window). 
 
   
 
Left Click on the Exterior Boundary in MicroStation to select the Boundary. 
Left Click again on the Exterior Boundary in MicroStation to accept the Boundary. 
 
The Boundary has now been imported to the 1234567_SDE.dtm project.  
(Do NOT click Apply again in the Import Surface dialog box – the Boundary was 
imported once it was selected in MicroStation).  
 
Selects the Exterior Boundary. 
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34.  After the importation is completed – click Close to close out of the Import surface 
dialog box. 
 
Closes the Import Surface dialog box. 

35.  The Exterior Boundary should still be highlighted in purple.  To remove the highlight –  
 
In the [MicroStation Software] – 
 
Left Click “Element Selection”            in  the MicroStation “Main Toolbar” 
 
Once the “Element Selection” is clicked – the Boundary will un-highlight. 
 
 
 
Removes the highlight from the Boundary. 

36.  The DTM Surface will now need to be re-triangulated in order to include the Exterior 
Boundary in the DTM Surface.  
 
Select SurfaceTriangulate Surface.  The Triangulate Surface dialog box will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Maximum Length: field enter – 300.000 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L5-6 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Triangulate Surface dialog box.   

 
                       

                         
Figure L5-6 Triangulate Surface 
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37.  Click Apply.   

 
The DTM Surface is triangulated. 

38.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface   dialog box. 
 
Closes the Triangulate Surface dialog box. 

39.  Important:  In order to start with a CLEAN DGN file for the next steps: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
  
 
Deletes the Graphics from the GDOT 3D Working File.dgn file to ensure a clean DGN 
file. 

40.  The “XBOUNDARY” that was imported will now be viewed. 
 
Click Surface View SurfaceFeatures and the View Features dialog box will 
appear:  

• In the Surface: Pulldown – select 1234567_SDE 
 

When the dialog is first opened – all of the Features in the Features: list will be 
highlighted in blue. Left Click anywhere in the Features List box to “un-highlight” the 
Features. 
                                                               
Left Click on the Feature: 
XBOUNDARY 
 
Click Apply and then click Close and the View Features dialog box will close. 
 
 
Opens the View Features dialog box and selects the XBOUNDARY to view. 

 
 
 
 
 
 
 
 
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 5 
 

   
 Lab5-19   

 
 
41.  The “Trimmed Triangles” will now be viewed. 

 
Click Surface View SurfaceTriangles and the View Triangles dialog box will 
appear:  

 
 

• In the Surface: Pulldown – select 1234567_SDE 
• In this dialog box – click on the Preferences… button and the following dialog 

box will appear: 
 

                                        
 
 

• In the dialog box – select the Preference of EXISTING. Then click Load and 
then click Close and the Preferences dialog box will close.  
 

 
 
 
Click Apply. 
  
 
Click Close and the View Triangles dialog box will close. 
 
Opens the View Triangles dialog box and selects the triangles to view. 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 5 
 
 

   
 Lab5-20   

42.  In the [MicroStation Software] – 
 
 
Select the “Zoom In or Zoom Out” or “Fit View” commands as appropriate to view the 
XBOUNDARY and the triangles.        
 
Views the XBOUNDARY and triangles. 

43.  Save the InRoads Surface File 
 
Even though the Exterior Boundary has been imported into InRoads – the data has not 
yet been saved. As mentioned previously, InRoads retains the data in temporary memory 
but does not save the data on the fly. Whenever a change has been made to an InRoads 
Surface Project – Save the project and its associated modifications or changes. 
 
Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface has already 
been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will  be saved to Lab 5 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab5 
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab5  

44.  Important Step:  In order to Start with a CLEAN DGN file for the next Lab (Lab 6): 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
  
 
Deletes the Graphics from the GDOT 3D Working File.dgn file to ensure a clean DGN 
file for the next Lab. 

45.                    
                 This concludes Lab 5.  Do not proceed until the Instructor directs you to do so. 
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Lab 6 
Resolve DTM Errors 

 
Objective 
 
After the Exterior Boundary has been incorporated into the DTM – the final processing of the 
DTM Surface can begin. The Exterior and/or Interior Boundaries have already been included 
into the DTM to ensure that all of the appropriate extraneous triangles and obscured areas are 
trimmed and/or obscured.  The Crossing Segments have also been resolved.  
 
The next step in the process is to review the DTM Surface to ensure that there are no erroneous 
or “bad” data included in the DTM.  This review will determine if there are any elevations that 
are incorrect or bad shots that were picked up. The DTM will be reviewed in a 3D environment 
as a “shaded model” to assist in the resolutions of any “spikes” or erroneous data. This Lab will 
examine the process of resolving any “spikes” or bad data in the DTM Surface and 
review/resolve any crossing segments which may have been introduced when the Exterior 
Boundary was incorporated, etc.   
  
The objective of Lab 6 is to: 
 

• Review the DTM Surface as a shaded 3D model and check for any erroneous or 
“bad” data. 

• Resolve any “spikes” or incorrect Field Data 
• Review to ensure that no segment crossings have been introduced in the Surface 
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Lab6A Review the DTM Surface 
 
In this section of the lab you will be reviewing the 1234567_SDE.dtm Surface to check for any 
erroneous data, busts in elevations, spikes, etc. The DTM will be viewed as a 3D shaded model 
to assist in the location of invalid data.    
 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Load the InRoads Survey, Geometry and Surface File(s) 
 
Select FileOpen from the InRoads Menu.   
 
The Project Defaults (which were set up in Lab 1C) are set to the following Path: 
C:\InRoads Data\1234567\SDE Labs. 
 
Browse to the following path: C:\InRoads Data\1234567\SDE Labs\Lab 6 
 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86).  
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 6 
 

   
 Lab6-3   

4.  After navigating to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab 6 
 
Select the file named:  
1234567_A.fwd – then click Open.  
 
Select the file named:  
1234567_SDE.alg – then click Open.  
 
Select the file named:  
1234567_SDE.dtm – then click Open 
 
Then click Cancel.   
 
The 1234567_A.fwd, 1234567_SDE.alg and 1234567_SDE.dtm file(s) will open. 

5.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  Note that the “Red Rectangle” denotes that the 1234567_SDE 
project is the active Surface. 
 

                                        
 
Opens the “Surfaces Tab” in the InRoads Workspace Bar. 

6.  The DTM Triangles will now be reviewed. 
 
Click Surface View SurfaceTriangles and the View Triangles dialog box will 
appear:  

 
 

Surfaces TAB 
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• In the Surface: Pulldown – select 1234567_SDE 
• In this dialog box – click on the Preferences… button and the following dialog 

box will appear: 
 

 
 
 

• In the dialog box – select the Preference of EXISTING. Then click Load and 
then click Close and the Preferences dialog box will close.  

 
 
Click Apply. 
 
(See the Example screen capture depicted below in Figure L6-1). 
 
Opens the View Triangles dialog box and selects the triangles to view. 

      
 
 
 

 
 
 
 
 
 
 
 
 
 
 

Figure L6-1 Wireframe Triangles 
 
 
 
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 6 
 

   
 Lab6-5   

7.  Click Close and the View Triangles dialog box will close. 
 
Closes the View Triangles dialog box. 

8.  In order to review the DTM Surface – the user must become familiar with the appropriate 
settings and commands to utilize in MicroStation. A good resource for this information is 
the “MicroStation Help Files” which is located in the [MicroStation Menu] under 
HelpContents.  Please refer to this resource for additional information. 
 
Refers to the location for the MicroStation “Help Files”. 

9.  In order to view the DTM Surface triangles as shaded or smooth and to obtain a clearer 
representation of the Surface and triangles –  
 
In the [MicroStation Software] – 
 
Click SettingsView Attributes and the following View Attributes dialog box will 
appear. 

 
 

• In the Presentation Section– Display Style area – select the style of Smooth    
• Please be patient – it may take a second for the display to change from wireframe 

to  smooth 
• Click the Red             in the View Attributes dialog to close the dialog box. 

          
 (See the Example screen capture depicted below in Figure L6-2). 
 
Views the triangles as a shaded/smooth surface. 
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Figure L6-2 Shaded Triangles 
 
 
 
 
10.  In order to rotate the DTM Surface and view in 3D  -  

 
In the [MicroStation Software] – 
 
Select -- the “Rotate View icon”.       (Your icon may appear differently). 
 
(Left Click and hold down the Left Mouse Button).  
 
 This command is located under the “View 1” window in MicroStation. See the screen 
capture below: 
 
 

                  
 
 
                      
 
 
 
 
 
 
 
Select – “Rotate View”  
 
 
 
 
 
 Rotates the view of the DTM Surface. 

       Rotate View 
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11.  Left Click in the MicroStation Window and rotate the DTM accordingly by left clicking 
and panning in the view. Review the DTM surface by “zooming in/out”, “panning”  - 
Look underneath the DTM to determine if there are spikes, bad elevations, areas of the 
DTM that look incorrect, etc.  
 
Whenever you need to return to a TOP View: 
 
 
Select – “Top View”  
 
Review the DTM Surface for errors. 

12.  During the review of the DTM – notice that there is a “spike” located in the West 
Quadrant of the DTM. 
 

 
 
Review the West Quadrant of the Surface. 

13.  The next Lab (Lab 6B) will include steps for determining the cause of the spike(s) and 
the methods to resolve the erroneous elevation data to correct the DTM. 
 
In the [MicroStation Software] – 
 
Select -- the “Rotate View icon”.          
 

 
 
 
 
 
 
 
 
Select – “Top View”  
 
Returns the view to a “Top View”. 

 
 

       Rotate View 
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Lab6B Resolve the “spikes” in the Mapping Data 
 
The following Lab will detail the methods to resolve spikes and erroneous DTM data.  Please 
note that for this tutorial – all of the erroneous data will not be resolved.  
  
14.  In order to resolve the “spike” – it is easier to review the point data in a wireframe mode. 

 
In the [MicroStation Software] – 
 
Click SettingsView Attributes and the following View Attributes dialog box will 
appear. 
 
 

 
 
 
 

• In the Presentation Section– Display Style area – select the style of Wireframe   
• Please be patient – it may take a second for the display to change from smooth 

back to Wireframe. 
• Click the Red             in the View Attributes dialog to close the dialog box. 

 
Views the triangles as a wireframe surface. 
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15.   
The spike which we will resolve is located in the area depicted by the “rectangle” shown 
below:   
 
             
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Depicts the area of the spike. 

16.  Zoom into the area depicted by the “rectangle”. 
 
Zooms to the area of the spike. 

17.  Rotate the view in MicroStation to the spike location and zoom close into the area where 
the base of the spike originates. (For rotate instructions – see previous Lab 6A –  
Steps 10-11).  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Zoom to the base of the spike. 
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18.  The following Step --- ( Step 18) for Information Only: 
 
For this particular spike – there is one erroneous point with a zero (0.00) elevation which 
is creating this spike. See the screen capture shown below: 
 

                        
 
In a “Real World” project - To determine which Feature is causing the spike – a user 
would view all Features to see which Feature is the source of the erroneous point. 
When all Features are viewed – it should be obvious which Feature contains the bust 
in elevation. 
 
Information regarding “spikes”. 

19.  The easiest method to resolve the spike issue is to view the Feature so that the Feature 
Points are readily available for editing.  For this tutorial – we will view only the one 
Feature which is the source of this particular spike: 
 
In the InRoads Software: 
 
 Click Surface View SurfaceFeatures and the View Features dialog box will 
appear:  

• In the Surface: Pulldown – select 1234567_SDE 
 

When the dialog is first opened – all of the Features in the Features: list will be 
highlighted in blue. Left Click anywhere in the Features List box to “un-highlight” the 
Features. 
                                                               
Left Click on the Feature: 
TPBL106 
 
Click Apply and then click Close and the View Features dialog box will close. 
 
Opens the View Features dialog box and selects the TPBL106 breakline to view. 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 6 
 

   
 Lab6-11   

20.  After viewing the TPBL106 breakline – we can see that there is one point that has a bust 
in the elevation of 0.00. (This is the result of the spike): 
 
Zoom into MicroStation as needed to review the point: 
 
                         

            
 
 
 
 
 
Views the TPBL106 breakline with erroneous point. 

21.  As determined in the previous steps – the spike problem is caused by breakline 
TPBL106.  This breakline has an erroneous elevation at point Number 1 – the bust in 
elevation is approximately 300 ft +/-. 
 
To resolve the spike – perform the following steps: 
 
In the InRoads Software: 
 
Click Surface Edit SurfaceEdit Feature Point and the Edit Feature Point dialog 
box will appear:  
 

          
 
 
 

Opens the Edit Feature Point dialog box.   
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22.  In the  InRoads Software  Edit Feature Point dialog box – enter the following:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Feature: Pulldown –  select TPBL106 
• In the Point Scroll box – scroll to Point 1 
• Place a Check Mark       in the Center View box 
• Retain the  Northing of  –  1088136.671 
• Retain the Easting of  –  513531.084 
• Enter an Elevation of  –  295.350 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L6-3 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Edit Feature Point Dialog Box. 

 
 
 

                               
Figure L6-3 Edit Feature Point 
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23.   Click Apply and then click Close to close out of the Edit Feature Point dialog box.  
 
Closes the Edit Feature Point dialog box.                    

24.  Even though the point which was causing the spike has been corrected. The DTM will 
not reflect this change until the Surface has been re-triangulated.    
 
Re-triangulate the DTM 
 
In the InRoads Software – 
 
Select SurfaceTriangulate Surface.  The Triangulate Surface dialog box will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Maximum Length: field enter – enter 300.000 

 
Leave all other entries as default. 
 
 
 
Opens the Triangulate Surface dialog box.   

25.  Click Apply.   
 
The InRoads Status Bar (Located at the bottom – left hand side of the InRoads Interface) 
will depict the completion percentage of the triangulation.   
 
The DTM Surface is triangulated. 

26.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface dialog box. 
 
 
Closes the Triangulate Surface dialog box. 

27.  The DTM Surface will now be viewed to ensure that the spike has been corrected. 
 
Click Surface View SurfaceView Triangles and the View Triangles dialog box 
will appear:  
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• In the Surface: Pulldown – select 1234567_SDE 
• In this dialog box – click on the Preferences… button and the following dialog 

box will appear: 
 
 

 
 
 

• In the dialog box – select the Preference of EXISTING. Then click Load and 
then click Close and the Preferences dialog box will close.  

• Click Apply. 
    
 
Opens the View Triangles dialog box and selects the triangles to view. 

28.  Click Close and the View Triangles dialog box will close. 
 
 
Closes the View Triangles dialog box. 

29.  In the [MicroStation Software] – 
 
Select -- the “Fit View icon” and “Rotate View icon” to view the DTM in 3D.        
   
 

           
 
 
 
 
 
 
 
 
Rotate the view as needed to ensure that the spike has been corrected. 
 
 
Reviews the DTM Surface. 

       Rotate View 
        Fit View 
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30.   Important Step:   
 
In the [MicroStation Software] – 
 
To return the view back to the correct settings for the next Lab --- 
Select the “Rotate View icon” and then select the “Top View”.          
 
 

                  
 
 
 
 
 
 
 
 
 
Select – “Top View”  
 
 
Returns the view to a “Top View”. 

31.  Important Step:   
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn.  
 
Deletes the Graphics from the GDOT 3D Working File.dgn file to ensure a clean DGN 
file for the next Lab. 

 
 
 
 
 
 
 
 
 
 
 
 
 

       Rotate View 
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Lab6C Review --- the Resolve Crossing Segments 
 
Before the final processing of the DTM Surface -- the Resolve Crossing Segments command 
Interactive Mode Option will be used to ensure that no new segment crossings were 
inadvertently introduced when the Exterior Boundary was incorporated and when the spikes 
were corrected, etc.   
 
 The Resolve Crossing Segments command requires a surface to be triangulated before using 
this utility. This step has already been completed in Lab 6B.  
 
  
32.   Click Surface UtilitiesResolve Crossing Segments and the Resolve Crossing 

Segments dialog box will appear:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Mode: field –  select Interactive 
• In the Delta Tolerance: field – select > 0.020 

(Ensure the Greater Than Sign is selected) 
• In the Match Elevation: entry – select       Median 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L6-4 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Resolve Crossing Segments dialog box 
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Figure L6-4 Resolve Crossing Segments 

 
 
 

33.  Click Apply.   
 
If there are any Crossing Segments, these will be depicted (highlighted in Red) in the list 
field of the dialog box. In this case, all of the crossings have been resolved and the list 
box is empty.   
 
The Resolve Crossing Segments dialog should now correspond to the screen capture 
depicted in Figure L6-5(as shown below).  Verify to ensure that your input matches the 
screen capture.    
 
 

 

**WARNING**  
 
Ensure the Delta 
Tolerance of > 0.020 is 
selected. 
 

**Information** 
 
When using the 
Automatic Mode the 
Delta Tolerance should 
be set to < 0.020. 
When using the 
Interactive Mode the 
Delta Tolerance should 
be set to > 0.020. 
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Figure L6-5 Resolve Crossing Segments 

 
 
 

34.  Click Close to close out of the Resolve Crossing Segments dialog box.   
 
Closes the Resolve Crossing Segments dialog box.     

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

There are NO 
Crossing Segments 
listed. 
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35.  In a “Real World” project - if Crossing Segments had been introduced – the user could 
refer back to Lab 4 for additional information regarding Resolving Crossing Segments 
and then proceed with the steps accordingly before final processing of the DTM. 
 
Save the InRoads Surface File 
 
Even though the “spikes” and errors have been corrected – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. When a change has been made to an InRoads Surface Project – Save the project. 
 
Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface has already 
been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will  be saved to Lab 6 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab6 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Surface Project has 
been saved.                     
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 6 

36.  Important Step:  In order to Start with a CLEAN DGN file for the next Lab (Lab 7): 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
  
 
Deletes the Graphics from the GDOT 3D Working File.dgn file to ensure a clean DGN 
file for the next Lab. 

37.                    
                 This concludes Lab 6.  Do not proceed until the Instructor directs you to do so. 
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Lab 7 
Final Processing of the Field Surface 

 
Objective 
 
The DTM Surface data has been verified and all erroneous data corrected in the previous Lab.  
The next step is the completion of the final processing of the Full Field DTM Surface. The DTM 
Surface will be re-triangulated and compressed (which will release memory slots that contain 
deleted data). This Lab will depict the procedures for the final DTM processing. Lab 17 will 
depict the process to create topographical and utility DGN file(s) of the final deliverables for 
submission to the Design Engineers. 
 
The DTM Deliverable will include the following: 
 

• A processed DTM Surface file (PI#_SDE.dtm) 
 
 
The objective of Lab 7 is to: 
 

• Process a completed DTM Surface File 
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Lab7A Process the DTM Surface for Final Submission 
 
In this section of the lab you will be re-triangulating the DTM Surface and compressing the 
DTM for final submission to the Design Engineers. 
 
 
1.   Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Load the InRoads Geometry and Surface File(s) 
 
Select FileOpen from the InRoads Menu.   
 
The Project Defaults (which were set up in Lab 1C) are set to the following Path: 
C:\InRoads Data\1234567\SDE Labs. 
 
Browse to the following path: C:\InRoads Data\1234567\SDE Labs\Lab 7 
 
Selects the path to open the Surface and Geometry File(s). 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86).  
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4.  After navigating to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab 7 
 
 
Select the file named:  
1234567_SDE.alg – then click Open.  
 
Select the file named:  
1234567_SDE.dtm – then click Open 
 
Then click Cancel.   
 
The 1234567_SDE.alg and 1234567_SDE.dtm file(s) will open. 

5.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  Note that the “Red Rectangle” denotes that the 1234567_SDE 
project is the active Surface. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Opens the “Surfaces Tab” in the InRoads Workspace Bar. 

6.  The “Completed” Surface will now be triangulated for final submission. 
 
Select SurfaceTriangulate Surface.  The Triangulate Surface dialog box will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Maximum Length: field enter – enter 300.000 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L7-1 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
 
Opens the Triangulate Surface dialog box.   

 
 

Surfaces TAB 
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Figure L7-1 Triangulate Surface 

 
 
7.   Click Apply.     

 
The DTM Surface is triangulated. 

8.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface dialog box. 
 
Closes the Triangulate Surface dialog box. 

9.  The “Completed” Surface will now be compressed (deleted data will be removed from 
memory) which will reduce the size of the DTM file.  
 
Select SurfaceUtilitiesCompress Surface and the Compress Surface dialog box 
will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
 

Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L7-2 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Compress Surface dialog box.   
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Figure L7-2 Compress Surface 

 
10.  Click Apply. 

 
A dialog box will appear that warns that the Surface will be re-triangulated.  
(See Figure L7-3 as shown below). 
 
Generates a re-triangulate warning box.                     

 
 
 

                               
Figure L7-3 Re-Triangulate Message Box 

 
 
 
 
 
 
11.  Click Yes.  

The DTM Surface will be re-triangulated. 
 
Re-triangulates the Surface.                     

12.  After the re-triangulation is completed – click Close to close out of the Compress 
Surface dialog box. 
 
Closes the Compress Surface dialog box. 
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13.  Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface has already 
been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will be saved to Lab 7 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab7 
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 7 

14.  For Information Only: 
The *1234567_SDE.dtm is a “working surface” for the use of Survey Data Engineers. 
After submission to the Designer(s) – the Designer will re-name the surface to 
1234567_Exist.dtm. The procedure of re-naming the Surface will be the responsibility of 
the Designer and will be described in the Design Guidelines and Tutorials.  
 
*(The reason the SDE does not work in a 1234567_Exist.dtm will be described in more 
detail in later Labs. The main reason is for enhanced data. During the addition of 
enhancements – the SDE will be working in several DTM files. Therefore it is 
advantageous to have a “working DTM” to input in all of the compiled enhanced data. 
The final compiled DTM data will be submitted to the Designer(s) as PI#_SDE.dtm file 
for tracking purposes). The Designer will then re-name the file to 1234567_Exist.dtm. 
 
Depicts Surface Information. 

15.  For Information Only: 
 
The 1234567_A.fwd file is NOT to be submitted to Design. The Designer will have all of 
the information which is contained in the field book in the 1234567_SDE.dtm, the 
1234567_SDE.alg file and the associated DGN File deliverables. 
 
Depicts FWD File Information. 

16.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
 
Deletes the Graphics from the GDOT 3D Working File.dgn to ensure a clean DGN file 
for the next Lab. 

17.  In the [MicroStation Software] – 
Select File CompressDesign to reduce the DGN File Size. 
 
 Compresses the DGN File Size. 
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18.   To CLOSE MicroStation and InRoads –  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

End 
                  
                 This concludes Lab 7. Do not proceed until the Instructor directs you to do so. 
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Lab 8 
Create Survey Enhancement Project(s) and  

Import CSV Enhancement Data 
 
Objective 
  
Labs 1-7 depict the processes for generating data on Full Field Survey Projects. The following 
Labs 8-9 describe the process for adding enhancements to Photogrammetry (Mapping) Projects. 
This process can also be utilized for adding any additional enhancements which may be required 
for Full Field Survey Projects. 
 
The SDE will receive a Mapping Project (PI#_Map.dtm) along with the associated Topography 
DGN file, roll-plots, etc. from Photogrammetry at the Office of Design Policy and 
Support/Location Bureau. This Mapping Project will be enhanced with Field Survey Data which 
includes: property data, drainage data, enhancement of obscured areas, new construction data, 
etc. The SDE will process and then merge the applicable field survey data into the Mapping 
Data. A new DTM for the enhancements will be created as well as a Geometry Project (ALG) 
file. The ALG file will be created which will contain the Property, Existing Alignment and 
Existing R/W Data.  The ALG file will be discussed in more detail in Section 3 (Labs 10-15). 
 
Several of the file and importation steps for Mapping Enhancements are similar to a Full Field 
Survey Project (as it pertains to the creation of an FWD database and import of CSV files). 
Basically several DTM’s will be created which contain the enhancement data. The DTM’s can 
be considered comparable to the CAiCE SRV files process and the naming conventions similar 
to the CAiCE Segment Naming process. The process for adding additional enhancements will 
utilize the same procedures (except for the file naming conventions which adds different alpha 
character(s) for enhancement tracking purposes).  
 
InRoads contains a GDOT Trimble CSV to InRoads Translator which converts the CSV file 
into a format that is usable for InRoads.  The translator converts the .CSV file based on a format 
of Point Number, Northing, Easting, Elevation, Alpha Feature Code and Attribute Name 
and Attribute Value if applicable.  After the CSV file is translated and imported into the Field 
Book, the data can then be imported into a Surface Project and/or Geometry Project.     
 
The objective of Lab 8 is to: 
 

• Open a Mapping File obtained from Photogrammetry and Create a “Working DTM 
Surface” to merge Photogrammetry and Field Data 

• Create a Survey Data Field Book and Translate/Import the CSV File(s) 
• Create a Surface Database and a Geometry Database for Field Enhancements 
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Lab8A Set  Survey Defaults and Create a “Working DTM Surface” 
 
In the following Lab – the Survey Data Processing Default Settings will be initiated. Also a 
Mapping Surface obtained from Photogrammetry will be utilized to create a “Working DTM 
Surface” (1234567_SDE).  This Surface will be used to merge the Mapping and Enhancement 
data into one surface.  
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).       

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Verify Project Defaults 
• In InRoads -- select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_SDE which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L8-1. 
• Click Apply & Close. 

 
Sets the SDE Project Defaults. This folder location will also be the default folder when 
FileSave and FileClose are used.   

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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Figure L8-1 Set Project Defaults 

 
4.  Set Survey Default Preferences 

 
• In InRoads  - Select File Project Options. 
• In the Project Options dialog box select the General Tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Survey Default.  Click Load and Close. 
• In the Project Options dialog box - Click Apply and Close. 

 
Sets the Survey Defaults Preference. 

 

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
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5.  *Set InRoads “Locks”     
*It is very important to ensure that the “Locks” are set according to the steps and 
instructions for each Lab when indicated.  
 
Click ToolsLocks from the InRoads pull-down menu.   
 
Ensure that the following locks are selected/unselected as appropriate: 
 
 Feature Filter        _____ Unchecked   
 
Feature Highlight         __ Unchecked 
 
Style         ____________ Unchecked 
 
Pencil/Pen        ________ Set to Pencil 
 
Delete Ink    ________ Unchecked 
 
Locate         ___________Set to Features 
 
Point Snap        ________ Checked 
 
Element Snap        ______Unchecked 
 
Station        ___________ Unchecked 
 
Report          __________ Checked 
 
Cogo Audit Trail      ____ Unchecked 
                             
Toolbar            ________ Checked 
 
The InRoads “Locks” are set accordingly. 

6.  Open/Load the Mapping (Photogrammetry) DTM Surface received from the 
Location Bureau: (1234567_Map.dtm) 
 
Select FileOpen from the InRoads Menu.    
 
Browse to the following path:  
C:\InRoads Data\1234567\SDE Labs\Lab 8\Photogrammetry 
 
Select the file named: 1234567_Map.dtm 
 
Click Open and then click Cancel. 
 
The 1234567_Map.dtm Surface file will open. 
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7.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the Surfaces 
Tab. 
 
 
 
 
 
 
 
 
 
 
 
 
The 1234567_Map file should be listed under the surfaces. 
 
Ensure that in the InRoads Explorer Interface Workspace Bar that the 1234567_Map 
Surface Project has a “Red Rectangle” around the icon.  
 
This denotes that this is the “Active” Surface Project.  Any Surface commands will be 
initiated and performed on the current “Active” Surface Project. 
 
 
Opens the Surface Tab in the InRoads Explorer Interface. 

DTM Information: 
 
The 1234567_Map.dtm is the Original Mapping Surface file received from the Location 
Bureau. This DTM contains all of the Surface Features such as points, breaklines, obscured 
areas, triangulated data, etc. This file is similar to the CAiCE SRV file -- the main 
difference is that this file already contains the triangulated DTM data along with the 
associated Features in a Surface format. 
 
In order to ensure that the SDE has a backup of this 1234567_Map.dtm file (for repository 
purposes) – the SDE will copy all of the data from the 1234567_Map.dtm file into a 
working DTM file named 1234567_SDE.dtm. The SDE will then “close” the 
1234567_Map.dtm and work from the 1234567_SDE.dtm. 
 

Surfaces TAB 

Scroll Bars 
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8.  Copy the data from the 1234567_Map.dtm to the 1234567_SDE.dtm 
 
Select SurfaceCopy Surface from the InRoads Menu and the Copy Surface dialog 
box will appear.   
 
Listed will be a From frame and a To frame for inputs. 
 
In the From frame: 

• In the Name: Pull-down – select 1234567_Map 
 
In the To frame: 

• In the Name: Field – enter 1234567_SDE 
• In the Description: Field – enter Training Data 
• In the Preference: Pull-down – select EXISTING  

 
 
The inputs should now correspond to the screen capture depicted in  
Figure L8-2 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Copy Surface dialog box. 

 
 
 

  
Figure L8-2 Copy Surface 

 
9.  Click Apply and then click Close to create the 1234567_SDE Surface.   

 
 
 
The 1234567_SDE Surface is created and the Copy Surface dialog box closes. 
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10.  Even though the 1234567_SDE Surface Project was created – it has not yet been saved.   
 
Select FileSave Surface from the InRoads Menu.   
 

• Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 8  
• Enter the File name: as  1234567_SDE 
• Enter the Save as type:  as Surfaces (*.dtm) 
• Click Save and then click Cancel. 

 
 

The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8     

11.  The 1234567_Map and the 1234567_SDE Surface should now both be listed in the 
Surfaces Tab. The Data for both surfaces are identical. 
 
As mentioned previously we will be adding enhancements to the “working” surface of 
the 1234567_SDE Surface – therefore the 1234567_Map Surface can now be closed. 
 

• Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).   

• Select the 1234567_Map surface (by Left clicking) and the Name will highlight 
in blue. 

• Then (Right click) over the surface and a pop-up dialog will appear. 
  
 
 
 
 
 
 
 
 
 
 
 

• Click Close and a dialog will open asking if you want to Close the 1234567_Map 
Surface ---- select Yes.     
 

                                                                                   
 
The 1234567_Map Surface is Closed.  
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Lab8B  Survey Enhancement --- Field Book 1234567_XO (.FWD) 
 
In the following Labs – a Survey Field Book (FWD), Surface Database (DTM) and Geometry 
Database (ALG) will be created to import in the field enhancement data. The process depicted in 
this Lab is for the Original Enhancements but similar processes can also be used to add 
additional enhancements during the life of the Project.  
 
Please Note: 

o Future Enhancements for Mapping DTM Databases will remain the same (except for the 
Naming Convention of the Enhancement – Example: 1234567_XA, 1234567_XB, 
1234567_XC, etc). 

o Future Geometry Enhancements (Additional Field Collected Property) – will differ in the 
import process. Since a Geometry Database will already exist – the additional property 
data will be imported into the original Geometry Database. It will be critical for the Field 
Surveyor’s to be given a range of points in order to collect any future enhancements so 
that data will not be overwritten. 

 
For these Labs: 
 

• A 1234567_XO.fwd ---  
Survey Book (FWD file) will be created to import in the Original Enhancement Field 
Survey Data. 

• A 1234567_XO.dtm ---  
 Surface Database (DTM) will be created to import in the Original Enhancement DTM 
data. 

• A 1234567_SDE.alg ---  
 Geometry Database (ALG) will be created to import in the Original Field Collected 
Property and Existing Alignment Data. 

 
All of the Original Enhancement Data is imported into the Survey Field Book. This Field Book 
is utilized to transfer the data from the CSV file to the database(s) in InRoads. After the Data is 
imported into the Field Book – the applicable data (depending on whether it is DTM Data or 
Geometry Data) – will then be selected by a pre-defined filter and imported into the appropriate 
database.   
 
An InRoads Survey Data Field Book (.FWD File) must be created and must be made active in 
order to import and translate the CSV Data from Survey.  In this tutorial, Project 
1234567_XO.fwd (Survey Data Field Book File) will be created.  This active field book database 
will be used to import, generate and translate the CSV data from Survey.  
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12.  If MicroStation and InRoads are not already open -- follow Step 2 in Lab 8A to open 
MicroStation and InRoads  
 
Starts the MicroStation and InRoads Software Products.   

13.  Click on the Survey Tab (Located at the bottom – left hand side of the InRoads Explorer 
Interface).  If this tab is not visible – use the scroll bars to scroll to the Survey Tab. 
 
 
 
 
 
 
 
 
 
 
 
Opens the Survey Tab in the InRoads Explorer Interface. 

14.  Create the 1234567_XO.fwd Survey Data Project by selecting FileNew from the 
InRoads Menu.  The New dialog box will open.  Select the Survey Data Tab. 
 

• In the Name: Field – enter 1234567_XO 
 
The inputs should now correspond to the screen capture depicted in  
Figure L8-3 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the New dialog box allowing you to create a Survey Data Project. 

 

                                                                                    
Figure L8-3 “New” Survey Data Project 

 

Survey TAB 

Scroll Bars 
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15.  Click Apply and then click Close to create the Survey Data Project.   
 
The Survey Data Project is created and the New dialog box closes.   

16.  Even though the 1234567_XO Field Book was created – it has not yet been saved. 
InRoads retains the data in temporary memory but does not save the data on the fly. It is 
highly recommended to Save the project periodically after any major modifications or 
changes to the data. 
 
Select FileSave Survey Data from the InRoads Menu.   
 

• Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 8  
• Enter the File name: as  1234567_XO 
• Enter the Save as type:  as Survey Data (*.fwd) 
• Click Save and then click Cancel. 

 
The 1234567_XO Survey Data Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8     

17.  In the screen capture depicted below –  
 
Note that in the InRoads Explorer Interface Workspace Bar that the 1234567_XO Survey 
project has a “Red Rectangle” around the icon. 

 
This denotes that this is the “Active” Survey Project.  
Any survey commands will be initiated and performed 
on the current “Active” Survey Project. 
 
  Also note that there will always be a Default  
“Book 1” Project listed.  InRoads includes this Default 
“Book 1” for internal InRoads functionality --- 
Remember to never save data to this Default 
Survey Data Book.    
 

 
 
Displays a red rectangle around the 1234567_XO Survey icon to reflect that this is the 
Active Survey Project upon which commands will be performed. 
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18.  For Information Only: 
 
Figure B: (Screen Capture from WordPad) 
PT # –Northing–Easting–Elevation–Feature Code–Attribute Name–Attribute Value 
203,1263914.015,2244692.182,922.143,SDCD,ATTRNAME,CD203 
204,1264915.721,2244406.908,929.411,SDCD,ATTRNAME,CD204 
205,1265779.781,2244196.015,945.983,SDCD,ATTRNAME,CD205 
206,1266807.164,2243938.752,948.854,SDCD,ATTRNAME,CD206 
207,1268577.467,2243523.159,941.923,SDCD,ATTRNAME,CD207 
208,1269722.906,2243229.502,932.556,SDCD,ATTRNAME,CD208 
209,1271707.277,2242672.591,941.302,SDCD,ATTRNAME,CD209 
531,1278246.098,2237121.145,863.166,DSBST61,, 
532,1278247.861,2237119.81,862.491,DSEST62,, 
533,1278248.867,2237117.916,861.555,DSCST63,, 
534,1278229.978,2237105.246,864.358,DSB61,, 
535,1278230.896,2237101.55,862.359,DSE62,, 
 
Depicts “Example” format of standard GDOT CSV File.   

19.  The GDOT Trimble “CSV” File will be translated and imported: (1234567XO.csv) 
 
Select FileImport Survey Data from the InRoads Menu.  The Import dialog box 
will open.   
   
Select the CSV file by browsing to the file in the “Look in” drop down box. Navigate to 
the CSV file which is located in the following path: 
 
C:\InRoads Data\1234567\SDE Labs\Lab 8\1234567XO CSV File\  
 
 Select the 1234567XO.csv file --- by left-clicking on the file.  
 

• In the File name: Pulldown – ensure 1234567XO.csv is listed 
• In the Files of type: Pulldown – ensure GDOT Trimble Format(*.csv) is listed 
• The Template: Pulldown – should be blank 
• The Linear Units: Selection  - should be US Feet 
• The Angular Units: Selection – should be Degrees 

 
 Opens the Import dialog box allowing you to import a CSV File.   

20.  Click Import.  
(This command selects the data to be imported.) 
 
 Click Close.  
(The Survey Data is actually imported when the Close command is selected.) 
  
It may take a while for the CSV data to import depending on the size of the file! 
 
Once the data is imported – the Import dialog box will close automatically.  
 
The CSV File data is translated and imported into the 1234567_XO Survey Project. 
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21.  The CSV File data is now imported into the 1234567_XO Survey Project.  Click on the 
Survey Tab (Located at the bottom – left hand side of the InRoads Explorer Interface) 
and then double-click on the 1234567_XO Survey Project.   
 
 
A 1234567XO folder will appear. Double-click on the 
1234567XO folder.  
 
 
Review the InRoads Explorer data frame and note that the Survey Project now contains 
point data and coordinate information.    
 
Opens the InRoads Survey Tab and displays the 1234567_XO Survey Data information 
in the InRoads Explorer Interface. 

22.  Even though the CSV data has been imported into the InRoads Survey Project 
(1234567_XO.fwd) – the data has not yet been saved. Whenever a change has been 
made to an InRoads Survey Project – it is advisable to Save the project and its associated 
modifications or changes. 
 
Select FileSave Survey Data from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Survey Project has 
already been saved initially). 
 
 The Survey Project (1234567_XO.fwd) will  be saved to Lab 8 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Survey Project has been saved. (See screen capture below): 
 

 
                         

 
 
 
 
The 1234567_XO Survey Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8     

23.  Select SurveyFieldbook Data  from the InRoads Menu and the 1234567_XO 
Survey Field Book will open.   
 
Information Only: Review the field book data information for potential errors/problems. 
For additional detailed information regarding the reviewing/correction of field book 
errors – please refer back to Lab 2C.   
 
Opens the Fieldbook dialog box for review.             

Survey 
Project 
Saved 
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24.  Close the Fieldbook Data dialog box. 
 
 Left click on the Red X in the upper right corner of the Fieldbook Data dialog box as 
shown here. 
 

 
 
 
Closes the Fieldbook Data dialog box. 

25.  View the Planimetric Survey Data (Enhancement Data): 
 
The Planimetric data (Enhancement Data) depicted will be merged into the associated 
DTM and ALG databases. 
 
Take a minute to view the selected Features in the [MicroStation Software] by using the 
following commands located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Features. 
 

               
     
 
 
 
 
 
Views the Features in MicroStation. 

Click Red 
X to close 
the 
Fieldbook
 

Fit View Zoom In or Out 
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26.   Information Only: 
 
At this time - the data can be viewed only. This data is not actually written as Graphics to 
the DGN file. The user may zoom in or out in MicroStation but actual manipulations to 
the data cannot be initiated because it has not yet been imported into a Surface or 
Geometry database.  The steps to write the survey data to the Surface and Geometry 
InRoads modules will be detailed in the following Labs.  
 
Planimetric Survey Data in InRoads/MicroStation. 

27.  To turn Planimetric Survey Data on/off: 
 
The Planimetric View can be turned on/off in InRoads by the following steps: 
 
Select SurveyView Survey Data Planimetrics from the InRoads Menu.   
 
A check mark by Planimetrics – turns the planimetric data on for viewing. 
Removing the check mark by Planimetrics – turns the planimetric viewing data off. 
 

• For this Lab – remove the check mark in order to turn the Planimetrics off. 
 
Steps to turn off the Planimetric Survey Data in InRoads/MicroStation.  
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Lab8C Survey Enhancement  --- Surface 1234567_XO (.DTM) 
 
In this section of the lab you will be creating a Surface Database Enhancement Project. This 
database will be used to import the Surface information contained in the Survey Field Book 
(.FWD) into the Surface Database Project (.DTM) by using a pre-defined Filter. 
 
28.    Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 

Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the Surfaces 
Tab. 
 
 
 
 
 
 
 
 
 
 
 
Opens the Surface Tab in the InRoads Explorer Interface. 

29.  Create the 1234567_XO.dtm Surface Project by selecting FileNew from the InRoads 
Menu.  The New dialog box will open.  Select the Surface Tab. 
 

• In the Type: Pulldown – select Existing 
• In the Name: Field – enter 1234567_XO 
• In the Description: Field – enter Original Enhancement 
• In the Maximum Length: Field – enter 300.000 
• In the Preference: pulldown – select EXISTING 

 
The inputs should now correspond to the screen capture depicted in  
Figure L8-4 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the New dialog box allowing you to create a Surface Project. 

 
 
                         
 
 
 
 
 
 
 
 

Surfaces TAB 

Scroll Bars 
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Figure L8-4 “New” Surface Data Project 

 
 

30.  Click Apply and then click Close to create the Surface Project.   
 
The Surface Project (1234567_XO) is created and the New dialog box closes.   

31.  Even though the InRoads Surface Project was created – it has not yet been saved.   
 
Select FileSave Surface from the InRoads Menu.   
 

• Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 8  
• Enter the File name: as  1234567_XO 
• Enter the Save as type:  as Surfaces (*.dtm) 
• Click Save and then click Cancel. 

 
 
The 1234567_XO Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8     
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32.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface). 
 
 
 
 
 
 
 
 
 
 
 
Notice that there are Two Surfaces shown: 

o 1234567_SDE (the Mapping Data Surface) 
o 1234567_XO (the Original Enhancement Surface) 

 
 
 The 1234567_SDE Surface contains the Mapping Data. At this point the 1234567_XO 
Surface is empty and contains no data – this is denoted by the 0’s depicted in the Data 
Types in the InRoads Explorer.     
 
Opens the InRoads Surface Tab and displays the 1234567_SDE and the 1234567_XO 
Surface information in the InRoads Explorer Interface.  

33.  In the screen capture depicted below –  
 
Note that in the InRoads Explorer Interface Workspace 
Bar that the 1234567_XO Surface Project has a “Red 
Rectangle” around the icon. 
 
This denotes that this is the “Active” Surface Project.  
Any Surface commands will be initiated and 
performed on the current “Active” Surface Project. 
 
 

 
Also note that there will always be a Default Project listed.  InRoads includes this 
Default Project for internal InRoads functionality --- Remember to never save data to 
this Default Project.    
 
IMPORTANT!!    In the following Labs – it is critical to remember which Surface is the 
Active Surface (depicted by the Red Rectangle ). You will be switching from one 
Surface to another periodically to perform commands and it is very important to make 
sure the correct surface is the active one. 
 
Displays a red rectangle around the Active Surface.   

Surfaces TAB 
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34.  Information Only: 
In this section of the lab you will be importing in the Enhancement Data contained in the 
Survey Field Book (.FWD) into the 1234567_XO Surface Database Project (.DTM).   
 
 
Information regarding importing the Enhancement Data to the Surface Database 
Project. 

35.   
 
 
 
 
Ensure that the 1234567_XO database is the Active Project (has a red rectangle) next to 
the 1234567_XO name. 
 
Ensures that the correct DTM --- (1234567_XO) is active. 

36.    
 
 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned ON.  There should be a check mark next to the Feature Filter Lock. 
 
Ensures that the Feature Filter Lock is turned ON. 

37.  Select the DTM Surface Codes 
 
    ** WARNING ** – During this step take care not to roll the scroll button on your 
mouse. 
 
Click Survey Survey Style Filter  and the Survey Style Filter dialog box will appear:  
 
In the Survey Style Filter dialog box --- input the following: 
 

• In the Filter Name: Pulldown – select DTM Surface Codes 
• Then Left Mouse Click in the Rules: section frame to ensure that the Numeric 

Code is accepted. 
 
Leave all other entries as default!! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L8-5 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Survey Style Filter dialog box. 

 
 

Important Step---!!! 

Important Step---!!! 
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Figure L8-5 Survey Style Filter 

 
 
38.  Click OK and the Survey Style Filter dialog box will Close and the Filter will be made 

active. 
 
Closes the Survey Style Filter dialog box.  

39.  From the InRoads Menu - click Survey Survey Data to Surface and the Survey 
Data to Surface dialog box will appear:   
 

• In the Surface Name: Pulldown field– select 1234567_XO 
• In this dialog box – click on the Preferences… button and the following dialog 

box will appear: 
 

                     
 

Use the pull-down 
arrow to select the Filter 
named ‘DTM Surface 
Codes’. 

When the filter name is 
selected the data will be 
filtered as depicted here. 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 
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• In the dialog box – select the Preference of GDOT.  Then click Load and then 

click Close and the Preferences dialog box will close. 
 
The following entries will automatically be set after selecting the Preference named 
GDOT: 
 

• In the Parent Name: Field – (Blank) 
• In the Description: Pulldown –Use Attributes 
• In the Tolerance: Field – 0.0000 
• In the Maximum Segment Length: Field – 300.0000 
• In the Curve Stroking: Pulldown – Horizontal and Vertical 
• In the Triangulate Surface: Check Box – Checked 
• In the  Duplicate Names: Radio Button – Rename 

 
 The inputs should now correspond to the screen capture depicted in  
Figure L8-6 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Survey Data to Surface dialog box. 

 

                            
Figure L8-6 Survey Data to Surface 

 
40.  Click OK and the Survey Data will be imported into the 1234567_XO Surface Project 

and the Survey Data to Surface dialog box will close.     
 
The Triangulate Surface dialog box will then appear in order to create a Triangulated 
Surface. 
 
The Survey Data is imported and the Survey Data to Surface dialog box closes. 
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41.  In the Triangulate Surface dialog box: 
 

• In the Surface: Pulldown – select 1234567_XO 
• In the Maximum Length: field enter – enter 300.000 

 
Leave all other entries as default. The inputs should now correspond to the screen capture 
depicted in Figure L8-7 (as shown below). 
 
Opens the Triangulate Surface dialog box.   

 

                                   
Figure L8-7 Survey Data to Surface 

 
42.  Click Apply.     

 
 For Information Only: 
 
Depending on the size of the project – (on most Field Survey Enhancement Projects 
which are smaller in size) – the triangulation of surfaces is usually very fast.   
 
On these types of projects a Results Box will appear which lists the number of 
Points/Triangles/Elapsed Time. (See screen capture below). When these Results appear – 
the surface has completed triangulating. 
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43.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface dialog box. 
 
 
Closes the Triangulate Surface dialog box. 

44.  View the Surface Features  
 
In the InRoads Software - select SurfaceView SurfaceFeatures and the View 
Features dialog box will appear: 
 

• In the Surface: Pulldown – select 1234567_XO 
 

When the dialog is first opened – all of the Features in the Features: list will be 
highlighted in blue (Leave all of the features “highlighted blue).  This will ensure that all 
Features are graphically viewed.  
 
The Features which you wish to view MUST be highlighted Blue. Features can be 
highlighted by selecting them with the mouse and a combination of the Ctrl key or Shift 
key on the keyboard. 

 
Leave all other entries as default.  
 
Opens the View Features dialog box. 

45.  Click Apply and then click Close and the View Features dialog box will close.  
 
Closes the View Features dialog box. 

46.  View the Surface Triangles: 
 

• Select SurfaceView Surface Triangles from the InRoads Menu. The 
following dialog box will appear: 

 

                          
 

• In the Surface: pulldown – select 1234567_XO 
• In this dialog box – click on the Preferences… button and the following dialog 

box will appear: 
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• In the dialog box – select the Preference of *ENHANCEMENTS. Then click 
Load and then click Close and the Preferences dialog box will close. 
 

*NOTE:  
This 1234567_XO Surface is utilizing a Preference named “ENHANCEMENTS” and 
utilizes a different color scheme in order to differentiate between the 1234567_SDE.dtm 
Existing Surface. The 1234567_XO.dtm surface is an enhancement surface and will 
eventually be merged into the Existing 1234567_SDE.dtm. So basically this is a 
temporary surface and the color is different in order to help the user distinguish between 
the surfaces during the processing phase before the final merging of the DTM’s. 
 
 
Sets the Preference for the viewing of the 1234567_XO.dtm Surface. 

47.  In the View Triangles dialog box – click Apply and then click Close and the 
1234567_XO Enhancement Surface will view and the View Triangles dialog box will 
close. 
 
View the 1234567_XO Enhancement data triangles. 

48.  View the selected Surface Features/Triangles in the [MicroStation Software] by using the 
following command located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Features. 
 

             
            
 
 
 
 
 
 The Surface Features/Triangles are displayed on the MicroStation screen. 

Fit View Zoom In or Out 



Introduction to InRoads - SDE  InRoads SS2 – Lab 8 
 

   
 Lab8-24   

49.  Important Note: 
In a “real world” Project – any obvious errors, segment crossings, etc.  would be 
reviewed in the 1234567_XO Surface and would be resolved at this point. Please see 
Lab 4 in the Full Field Survey Section for steps in resolving crossing segments. 
 
For this Lab – the 1234567_XO Surface has been reviewed and all crossing segments 
eliminated. 

50.  The Survey Data is now imported into the 1234567_XO Surface Project. 
 
Save the InRoads Surface Project: 
 
 Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface Project has 
already been saved initially). 
 
 The Surface Project (1234567_XO.dtm) will  be saved to Lab 8 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Surface Project has been saved.   
 
The 1234567_XO Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8     
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Lab8D Survey Enhancement  --- Geometry 1234567_SDE  (.ALG) 
 
In this section of the lab you will be creating a Geometry Database Enhancement Project. This 
database will be used to import the Geometry information contained in the Survey Field Book 
(.FWD) into the Geometry Database Project (.ALG) by using a pre-defined Filter.   
 
 
51.  Click on the Geometry Tab (Located at the bottom – left hand side of the InRoads 

Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the 
Geometry Tab. 
 
 
 
 
 
 
 
 
 
 
 
 
Opens the Geometry Tab in the InRoads Explorer Interface. 

52.  Create the 1234567_SDE.alg Geometry Project by selecting FileNew from the 
InRoads Menu.  The New dialog box will open.  Select the Geometry Tab. 
 

• In the Type: Pulldown – select Geometry Project 
• In the Name: Field – enter 1234567_SDE 
• In the Description: Field – enter Training Data 
• In the  Style: Field – (Leave Blank) 
• In the Curve Definition:  Field – (Leave Blank) 

 
The inputs should now correspond to the screen capture depicted in  
Figure L8-8 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
 
Opens the New dialog box allowing you to create a Geometry Project. 

 
 
 
 
 
 
 
 

Geometry TAB 

Scroll Bars 
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Figure L8-8 “New” Geometry Project 

 
 
53.  Click Apply and then click Close to create the Geometry Project.   

 
The Geometry Project is created and the New dialog box closes.   

54.  Even though the InRoads Geometry Project was created – it has not yet been saved.  It is 
highly recommended to Save the project periodically after any major modifications or 
changes to the data. 
 
Select FileSave Geometry Project from the InRoads Menu.   
 

• Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 8  
• Enter the File name: as  1234567_ SDE 
• Enter the Save as type:  as Geometry Projects (*.alg) 
• Click Save and then click Cancel. 

 
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8     

 
 
 
 
 
 



Introduction to InRoads - SDE  InRoads SS2 – Lab 8 

   
 Lab8-27   

55.  Click on the Geometry Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface). If this tab is not visible – use the scroll bars to scroll to the 
Geometry Tab. 
 
 
 
 
 
 
 
 
 
 
 
                                          
Then double-click on the 1234567_SDE Geometry Project.  Note that the Geometry 
Project has been created but is currently empty and contains no data – this is denoted by 
the “blank” point/coordinate data in the InRoads Explorer Interface.   
 
Opens the InRoads Geometry Tab and displays the 1234567_SDE Geometry information.  

56.  In the screen capture depicted below –  
 
Note that in the InRoads Explorer Interface Workspace Bar that the 1234567_SDE 
Geometry project has a “Red Rectangle” around the icon. 
 

This denotes that this is the “Active” Geometry 
Project.  Any Geometry commands will be 
initiated and performed on the current “Active” 
Geometry Project. 
 
 Also note that there will always be a Default  
Project listed.  InRoads includes this Default 
Project for internal InRoads functionality --- 
Remember to never save data to this Default 
Project.    
 

Displays a red rectangle around the 1234567_SDE Geometry icon to reflect that this is 
the Active Geometry Project upon which commands will be performed. 

57.            Information Only: 
In this section of the lab you will be importing in the Enhancement Data contained in the 
Survey Field Book (.FWD) into the 1234567_SDE Geometry Database Project (.ALG).   
 
 
 
Information regarding importing the Enhancement Data to the Geometry Database 
Project. 

Geometry 
TAB 
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58.  Ensure that the 1234567_SDE database is the Active Project (has a red rectangle) next to 
the 1234567_SDE name. 
 
Ensures that the correct ALG--- (1234567_SDE) is active. 

59.    
 
 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned ON.  There should be a check mark next to the Feature Filter Lock. 
 

60.  Information Only: 
 
 
 
The Survey Style Filter named Property and Alignment Codes has been created in order 
to filter out just the Geometry Data from the Field Book. The following Codes will be 
imported into the 1234567_SDE Geometry Database: 
 

 
Property and Alignment Codes Survey Style Filter 

PROP_E_RWM Right-of-Way Marker Found 
PROP_E_RWC Right-of-Way Point Computed 
PROP_E_RWU Right-of-Way Utility Company 
PROP_E_RWE Right-of-Way Prescription Pt 
PROP_E_POEL Point on Easement Line 
PROP_E_PCF Property Corner Found 
PROP_E_PPOL Property Point on Line 
PROP_E_PPC Property Point Computed 
PROP_E_APOT Point in Tangent, Existing 
PROP_E_APC Point of Curvature, Existing 
PROP_E_APOC Point on Curve, Existing 
PROP_E_APT Point of Tangency, Existing 
PROP_E_API Point of Intersection 
PROP_E_ACL Alignment Centerline 
PROP_E_BCOL County Line 
PROP_E_BCTL City Limit Line 
PROP_E_BLDL Land District Line 
PROP_E_BLLL Land Lot Line 
PROP_E_BSL State Line 
TOPO_E_SNGSCM NGS Control Monument 
TOPO_E_SLCM Location Control Monument 
TOPO_E_SLCD Location Control Delta 
TOPO_E_SDCD District Control Delta 
TOPO_E_SBNCHMK Benchmark 

Important Step---!!! 

Important Step---!!! 
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These codes are imported into the Geometry Project (.ALG File). All Codes which are not listed 
in the above table – will be imported into the Surface Project (.DTM File).   
 
61.  Select the Property and Alignment Codes 

 
    ** WARNING ** – During this step take care not to roll the scroll button on your 

mouse. 
 
Click Survey Survey Style Filter  and the Survey Style Filter dialog box will appear:  
 
In the Survey Style Filter dialog box --- input the following: 
 

• In the Filter Name: Pulldown – select Property and Alignment Codes 
• Then Left Mouse Click in the Rules: section frame to ensure that the Numeric 

Code is accepted. 
 
Leave all other entries as default!! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L8-9 (as shown below).    
 
Opens the Survey Style Filter dialog box. 

 

                                 
Figure L8-9 Survey Style Filter 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 

Use the pull-down 
arrow to select the Filter 
named ‘Property and 
Alignment Codes’. 

When the filter name is 
selected the data will be 
filtered as depicted here. 
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62.  Click OK and the Survey Style Filter dialog box will Close and the Filter will be made 
active. 
 
Closes the Survey Style Filter dialog box.  

63.  From the InRoads Menu - click Survey Survey Data to Geometry and the Survey 
Data to Geometry dialog box will appear:   
 
 

• In the Project Name: Pulldown – select 1234567_SDE 
• In the Description: Pulldown – select the default Use Style Description 
• In the Curve Stroking: Pulldown – select the default Horizontal and Vertical 
• In the  Duplicate Names: radio button – select default of Rename 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L8-10 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Survey Data to Geometry dialog box. 

 
 
 

                                 
Figure L8-10 Survey Data to Geometry 

 
 
 
 
 
64.  Click Apply and then click Close.  

 
The Survey Data will be imported into the 1234567_SDE Geometry Project and the 
Survey Data to Geometry dialog box will close.   
 
The Survey Data is imported and the Survey Data to Geometry dialog box closes. 
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65.  The Survey Data is now imported into the 1234567_SDE Geometry Project. 
 
Save the InRoads Geometry Project: 
 
 
 Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 
The Geometry Project (1234567_SDE.alg) will  be saved to Lab 8 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Geometry Project has been saved.   
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 8     

66.  Information Only: 
 
Procedures regarding the viewing of the graphical geometry data will be depicted in 
upcoming Labs. 
 
Detailed information regarding the adding of Field Enhancement Data to the Mapping 
DTM and the process to enhance obscured areas will be described in Lab 9. 
 
Detailed information regarding the processing of the Geometry Data and the input of 
Property Data will be described in Labs 10-15. 
 
Information Only: 
Lab 8 Review: -- The Original Enhancement Database(s) have been created and the 
associated Original Enhancement Data has been added to the appropriate Databases.  The 
following data has been created/added in Lab 8: 
 

• 1234567_SDE.dtm – (The “Working” Mapping DTM) 
• 1234567_XO.fwd --- (The Original Enhancement Field Book) 
• 1234567_XO.dtm --- (The Original Enhancement Surface) 
• 1234567_SDE.alg --- (The Original Enhancement Geometry) 

 
The next Lab 9 will detail the process of the steps required to enhance the obscured 
areas, enhance “partially” obscured areas as well as the steps to clip out “Old” data which 
will be replaced by New Construction Data. The process will also include merging the 
Original Enhancement Data into the Mapping Database.  
 
Information and Review of Labs 8 and 9. 
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67.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
  
 
Deletes the Graphics from the GDOT 3D Working File.dgn file to ensure a clean DGN 
file for the next Lab. 

68.   
                  
                 This concludes Lab 8.  Do not proceed until the Instructor directs you to do so. 
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Lab 9 
Process the Mapping Obscured Areas and 

Merge Field Enhancements into the  
Mapping Surface 

 
Objective 
 
In the previous Lab 8 – the SDE created a “Working DTM Surface” – 1234567_SDE which 
contained the Mapping DTM Surface data. The Field Enhancements were imported into the 
appropriate 1234567_XO Surface file for DTM data and into the 1234567_SDE Geometry file 
for the Geometry data.  
 
Labs 10-15 depicts the process of utilizing the 1234567_SDE Geometry file to input in the 
COGO Property (Parcel Data), Existing Alignment and Existing Right of Way data. Lab 9 – 
depicts the DTM enhancement process only.  
 
In Lab 9 – the SDE will process the original field enhancement data and merge this data into the 
Mapping “Working DTM Surface”. Lab 9 depicts the merging of DTM data and the processing 
of obscured areas with the new enhancement information.  The steps will be demonstrated which 
depict adding the enhancement data for new construction areas, obscured/partially obscured 
areas and new data outside of the exterior boundary. In this Lab -- all obscured area situations 
will not be represented. In a “real world” project – other situations regarding obscured areas may 
be present – the same tools used in this Lab can also be used in these other situations. 
 
*Please Note the following for these Labs: 

• Not all obscured areas will be addressed or enhanced. This in turn will result in crossing 
segments – which would normally not be present if the appropriate obscured areas that 
are located within the footprint of the project are addressed. 

• Also – when enhancements are added in areas of existing data – crossing segments may 
occur if not resolved. These will need to be addressed before submittal of the project to a 
Designer. 

• This Lab will not address the process of resolving crossing segments – please refer back 
to Lab 4 in the Full Field Survey Section for steps in resolving crossing segments. 

 
The objective of Lab 9 is to: 
 

• Depict the process of adding enhancements to new construction areas, 
obscured/partially obscured areas and data located outside of the current existing 
exterior boundary. 

• Depict the process of merging the enhancement data from the 1234567_XO DTM to 
the 1234567_SDE DTM.  
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Lab9A Clip Areas for Enhancements to “New Construction” Areas 
 
NOTE: Please read each step carefully before performing each process. 
 
In the following Labs – the process for adding Enhancement Data to New Construction Areas of 
a DTM will be depicted. The first step will be to clip out the data in the 1234567_SDE Surface 
so that in later Labs the data from the 1234567_XO Surface can be added/merged.  
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).       

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Load the InRoads “Working” Surface, “Enhancement” Surface,  Geometry and 
Survey File(s) 
 
Select FileOpen from the InRoads Menu.   
 
Browse to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab 9 
 
Selects the path to open the Surface(s), Geometry and Survey File(s). 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.                     After navigating to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab 9 
 
Select the file named:   
1234567_SDE.alg – then click Open.  
 
Select the file named:  
1234567_SDE.dtm – then click Open 
 
Select the file named:  
1234567_XO.dtm – then click Open.  
 
Select the file named:  
1234567_XO.fwd – then click Open 
 
Then click Cancel.   
 
The 1234567_SDE.alg, 1234567_SDE.dtm, 1234567_XO.dtm, and 1234567_XO.fwd 
file(s) will open. 

5.  To turn Planimetric Survey Data Off: 
 
The Planimetric Survey Data View will be turned on by default. This is the Original 
Enhancement Data (1234567_XO.fwd) which will eventually be merged into the 
1234567_SDE Surface. In order to clear this view -- You will need to turn off the 
Planimetric Data. This can be turned off in InRoads by the following steps: 
 
Select SurveyView Survey Data Planimetrics from the InRoads Menu.   
Remove the check mark by Planimetrics – to turn the planimetric viewing data off. 
 
Steps to turn off the Planimetric Survey Data in InRoads/MicroStation. 

6.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the Surfaces 
Tab. 
 
 
 
 
 
 
 
 
 
 
 
Opens the Surface Tab in the InRoads Explorer Interface. 

Surfaces TAB 

Scroll Bars 
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7.  IMPORTANT!!    In the following Labs – it is critical to remember which Surface is the 
Active Surface -depicted by the Red Rectangle . You will be switching from one Surface 
to another periodically to perform commands and it is very important to make sure the 
correct surface is the active one. 
 
 
 
 
Ensure that the 1234567_XO database is the Active Surface (has a red rectangle) next to 
the 1234567_XO name. 
 
Ensures that the correct DTM --- (1234567_XO) is active. 

8.  *Set InRoads “Locks” 
 
During the course of these Labs – the “Locks” will be turned on/off as the situation 
dictates. *It is very important to ensure that the “Locks” are set according to the steps and 
instructions for each Lab when indicated.  
 
 
 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned ON.  There should be a check mark next to the Feature Filter Lock. 
 
Ensures that the Feature Filter Lock is turned ON. 

9.  *View the TOPO_E_TLIML Features in the 1234567_XO Surface: 
 
*Note: The TOPO_E_TLIML Features will be viewed in order to depict the areas of 
new survey data which will be merged into the 1234567_SDE.dtm. Please note that not 
all areas will be processed in this Lab. 
 
Click SurfaceView SurfaceFeatures from the InRoads pull-down menu and the 
View Features dialog box will appear.    
 
 

• In the Surface: Pulldown – select 1234567_XO 
 

 
Click on the Filter button. 
 
 
 
 
 
 
Opens the View Features dialog box 

Important Step---!!! 

Important Step---!!! 
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10.  View the selected Features: 
 
    ** WARNING ** – During this step take care not to roll the scroll button on your 

mouse. 
 
The Feature Selection Filter dialog box will open. In the Feature Selection Filter 
dialog box --- input the following: 
 

• In the Filter Name: pulldown – select TLIML BREAKLINE 
 
This will filter the view to include the following Surface Feature codes:  
TOPO_E_TLIML 
 
Leave all other entries as default! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-1 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Feature Selection Filter dialog box. 

 

                                       
Figure L9-1 Feature Selection Filter 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 

Use the pull-down arrow to 
select the Filter Named 
‘TLIML BREAKLINE’. 

When the filter name is 
selected the data will be 
filtered as depicted here. 
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11.   Click OK and the Feature Selection Filter dialog box will Close.  The View Features 
dialog box should still be open from the previous steps. 
 
The inputs in the View Features dialog box should now correspond to the screen capture 
depicted in Figure L9-2 (as shown below).  Verify to ensure that your input matches the 
screen capture.    
 
 
Closes the Feature Selection Filter dialog box. 

 
 

 
Figure L9-2 View Features 

 
12.  Click Apply. 

 
 Views the  1234567_XO (TOPO_E_TLIML Features) in MicroStation 

13.  Click Close to close out of the View Features dialog box. 
 
Closes the View Features dialog box. 

14.  In order to add Enhancements to a DTM Surface – the user must become familiar with 
the appropriate settings and commands to utilize in MicroStation. A good resource for 
this information is the “MicroStation Help Files” which is located in the [MicroStation 
Menu] under HelpContents.  Please refer to this resource for additional information. 
 
Refers to the location for the MicroStation “Help Files”. 
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15.  The following MicroStation options will assist the user in adding Enhancement Data.  
These may be turned on/off based on the situation and the user’s preference.  
 
(It is advisable to turn the MicroStation AccuDraw OFF for the following Labs). 
 
To toggle MicroStation AccuDraw on/off – 
Click the AccuDraw icon in the Primary Tools tool box: 
 
 
 
 

  
 
 
AccuDraw is off when the XYZ Coordinate Window (See screen capture below) is not 
depicted: 
 
 
                      
                   AccuDraw Docked View                             AccuDraw Undocked View 
 

 
                                
 
                                                                                             
Depicts AccuDraw settings. 

16.  View the selected TOPO_E_TLIML Features in the [MicroStation Software] by using 
the following commands located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Features. 
 

                
            
 
 
 
 
 
 
 
Views the Features in MicroStation. 

 

AccuDraw Icon 

Fit View Zoom In or Out 
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17.  In the [MicroStation Software] – 
 

• Select “Fit View” and all of the TOPO_E_TLIML Features will be depicted in 
the MicroStation View Window.  See screen capture depicted below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Views the extents of the Features in MicroStation. 

18.  In the [MicroStation Software] – 
 

• Zoom (window in) to the top NE Corner of the MicroStation View so that the 
screen appears as the following: 

 

 
 
Zooms into the area depicted on the right. 

19.  In the [MicroStation Software] – 
• Place a Fence (Block Fence) around the area as depicted in the screen capture on 

the above right by selecting the following command: 
 
 
 
 
 
Selects the Place Fence Command. 

Place Fence  
Command 
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20.  In the [MicroStation Software] – 
 

• When the Place Fence command is selected – the following dialog box will 
appear in MicroStation: 

 

     
 

• Select Fence Type = Block 
• Select Fence Mode = Inside 

 
• Next place the fence (Block Fence) around the area depicted below: 

 
 
 
 
 
 
 
 
 
 
 
 
 
Places a fence around the area shown above. 

21.  Information Only: 
 
In the next Lab steps – we will be adding “New Construction Data” to the 
1234567_SDE Surface. First - this will entail removing the “old” data from the Mapping 
DTM (1234567_SDE) by basically creating a “hole” which is delineated by the 
TOPO_E_TLIML lines depicted in the screen captures in the previous steps.  This will 
be accomplished by clipping out the points and breaklines so that the new enhancement 
data can be added. (The New Enhancement Data will be added in later Labs). 
 
In the following Labs – the 1234567_SDE Surface will need to be the “Active Surface” 
because the old data must be removed from the 1234567_SDE surface before new data 
can be added. 
 
 
 
 
 
Information regarding the “Active Surface” of 1234567_SDE.dtm. 
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22.   In the [InRoads Software] – 
 
 
  
 
We will now Change the Active Surface to the 1234567_SDE surface. 

 
 

Ensure that the 1234567_SDE database is the Active Surface     
(has a red rectangle) next to the 1234567_SDE name by performing the following steps: 

 
 

• Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).   

• Select the 1234567_SDE surface (by Left clicking) and the Name will highlight 
in blue. 

• Then (Right click) over the surface and a pop-up dialog will appear. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
  

• Click Set Active and a red rectangle will appear beside the 1234567_SDE 
Surface Name.      

 
Sets the “Active Surface” of 1234567_SDE.dtm. 

23.  In the [InRoads Software] – 
 
 
 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned OFF.  There should NOT be a check mark next to the Feature Filter 
Lock. 
 
Ensures that the Feature Filter Lock is turned OFF. 

Select “Set 
Active” 

Important Step---!!! 

Important Step---!!! 
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24.  Click SurfaceView SurfaceFeatures from the InRoads pull-down menu and the 
View Features dialog box will appear.    
 
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Fence Mode: Pulldown – select Inside 

 
The inputs should now correspond to the screen capture depicted in  
Figure L9-3 (as shown below).  Verify to ensure that your input matches the screen 
capture.    

 
 

Closes the Feature Selection Filter dialog box. 
 
 

 
Figure L9-3 View Features 

 
25.  Click Apply. 

 
 Views the 1234567_SDE (Features) in a MicroStation Fenced Area. 

26.  Click Close to close out of the View Features dialog box. 
 
Closes the View Features dialog box. 
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27.  Information Only: 
For these Labs - the reason we are viewing the 1234567_SDE Features within a fenced 
area is to speed up the viewing/processing time and to assist the user in finding the areas 
to enhance. Due to the amount of data in the 1234567_SDE database – it is much faster 
to work in sections than in the entire database.  The user – may of course - view the 
entire surface features – but it appears to be much easier to work in just the sections that 
require processing.  
 
Viewing Information. 

28.  In the [MicroStation Software] – 
 

• Your view should now appear similar to the following: 
• Zoom into the area depicted by the red arrow --- 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Zooms to the area depicted by the red arrow. 

29.  In the [MicroStation Software] – 
 

• Your view should now appear similar to the following: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Zooms to the area of the TOPO_E_TLIML174 Limit Line. 

Zoom to this Limit Line 
TOPO_E_TLIML174 

Limit Line 
TOPO_E_TLIML174 
(Clip the Points and 
Breaklines from this 
area). 
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30.  Information Only: 
 
The Points and Breaklines will need to be clipped (deleted) from this area so that “New 
Construction” data can be merged into this Limit Line area for later labs.  
 
Please Note: 
Several different Limit Line Areas are represented in this dataset which should be clipped 
out. For this Lab – we will only process one area for demonstration purposes. 
 
Clipping Information. 

31.  In the [MicroStation Software] – 
 

•  Select the Place Fence Command: 
 
 
 
 
 
 
Selects the Place Fence Command. 

32.  In the [MicroStation Software] – 
 

• When the Place Fence command is selected – the following dialog box will 
appear in MicroStation: 
 

                     
 

• Select Fence Type = Element 
• Select Fence Mode = Inside 
• Place the Fence on the element (TOPO_E_TLIML174) by left-clicking twice to 

select the element. 
• When the Fence is placed -- a white boundary will appear around the 

TOPO_E_TLIML174. 
 

Places the Fence by Element. 
33.  Information Only: 

 
The following steps depict the procedure of clipping out and deleting Random Points by 
using a Fence in MicroStation. 
 
 
Point Clipping Information. 

Place Fence  
Command 
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34.  In the [InRoads Software] –  
 
The following points will be clipped out and deleted by fence. 
 
Click SurfaceEdit Surface Delete Feature Points and the Delete Feature Points 
dialog box will appear.  
 

• In the Surface: Pulldown – Select 1234567_SDE 
• In the Fence Mode: Pulldown – Select Inside 
• In the Random Features: Section 

o Select both TRP and TRP1 (By holding down the “Control Button” on the 
keyboard and left clicking TRP and TRP1 in the dialog box. After 
selection – the TRP and TRP1 should be highlighted in blue). 

• In the Range to Keep field: 
o In the Low: field -- Enter 0.000 
o In the High: field – Enter 1.000 

 
The inputs should now correspond to the screen capture depicted in  
Figure L9-4 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Selects the Points to Delete. 

 

 
Figure L9-4 Delete Feature Points 
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35.   Click Apply and then click Close and the Random Points will be deleted. 
 
 Deletes the Random Points inside of the TOPO_E_TLIML174 Limit Line. 

36.  Information Only: 
 
The following steps depict the procedure of clipping out and deleting Breaklines. The 
Breaklines will be clipped out manually by selecting each Breakline individually. This 
is a much quicker method than clipping out by Fence. When using the Fence Method – it 
can take a considerable amount of time to process the breaklines and delete them.  
 
Please Note:  
Although the steps depict the process of deleting all of the breaklines from within the 
Limit Line Boundary – the user may inadvertently not delete all of the breaklines in this 
Lab. This will not cause a problem because the user will be provided a processed dataset 
for later Labs so that all users’ data will be identical. 
 
Breakline Clipping Information. 

37.  In the [InRoads Software] –  
 
The Breaklines inside of the TOPO_E_TLIML174 Limit Line will be clipped out and 
deleted.   
  
Click SurfaceEdit Surface Delete Feature and the Delete Feature dialog box will 
appear.  
 

             
  

• In the Surface: Pulldown – Select 1234567_SDE 
• In the Fence Mode: Pulldown – Select Inside 

 
• Click the Locate Button   and then hold down the Control Key on the 

Keyboard and the Delete Feature dialog box will disappear. 
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• Next (continue to hold down the Control Key… and left quick twice on each 
Breakline inside of the TOPO_E_TLIML174 in MicroStation. One left click 
selects the Breakline and the other accepts it).  
 

• Continue selecting/accepting each Breakline until all of the Breaklines within the 
Limit Line are highlighted in purple. 

• After all are selected – release the Control Key and Right Mouse Click. This will 
bring back the Delete Feature dialog box. 

• Then click the Apply button. 
• A dialog box will appear: 

 

                                       
 

• Select OK. Please be Patient!! It will take a short while – but when the Delete 
Feature dialog re-appears – the Breaklines should be deleted. 

 
• Click Close to Close out of the Delete Feature dialog box. 
 

Deletes the Breaklines inside of the TOPO_E_TLIML174 Limit Line. 
38.  Once the Breaklines and Random Points are deleted – your MicroStation View should 

appear as shown below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
If your view does not match exactly – it will not be a problem because a processed 
dataset will be provided in later Labs. 
 
Basically the “old” data from the 1234567_SDE dataset has been clipped and deleted and 
will be replaced with the “New Construction Data” in later Labs. 
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39.  In the [MicroStation Software] – 
 

• De-select the MicroStation Place Fence Command by clicking on the Fence Icon 
(see below). 

 
 
 
 
 
 
 
 
 
De-Selects the Place Fence Command. 

40.  You will need to save your work periodically whenever changes have been made to the 
dataset. 
 
Save the InRoads Surface Project: 
 
 Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface Project has 
already been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will  be saved to Lab 9 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 9 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Surface Project has been saved.   
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 9   

41.  VERY Important Step:   
 
DO NOT DELETE --- the Data in the DGN file (GDOT 3D Working File.dgn). These 
DGN Graphics will be used in the next Lab 9B. 
  
  
 
Informs the User to NOT DELETE  the Graphics from the GDOT 3D Working File.dgn   
for the next Lab. 

 
 
 
 
 

De-selects 
the Fence  
Command 
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Lab9B  Process Enhancements for Partially Obscured Areas   
 
In the following Labs – the process for modifying partially obscured areas will be described. 
During the enhancement process – there are sometimes situations where only partial new 
enhancement data for an obscured area will be collected. The rest of the obscured area will 
remain obscured because it may be outside of the bounds of the footprint of the Project.  The first 
step will be to modify the obscured areas in the 1234567_SDE Surface so that in later Labs the 
data from the 1234567_XO Surface data can be added/merged to the area that is partially 
obscured. Please note that all obscured areas will not be addressed in this Lab. 
 
 
 
42.   If MicroStation and InRoads are not already open – refer back to Steps 1 – 5 in Lab 9A 

to open MicroStation and InRoads and the associated database files. 
 
Starts the MicroStation and InRoads Software Products (if they were closed previously).   

43.  IMPORTANT!!    In the following Labs – it is critical to remember which Surface is the 
Active Surface -depicted by the Red Rectangle . You will be switching from one Surface 
to another periodically to perform commands and it is very important to make sure the 
correct surface is the active one. 
 
 
 
 
 
Ensure that the 1234567_SDE database is the Active Surface (has a red rectangle) next 
to the 1234567_SDE name. If this is Not the Active Surface – Please see Lab 9A Step 
22 to set the Active Surface. 
 
Ensures that the correct DTM --- (1234567_SDE) is active. 

44.  *Set InRoads “Locks” 
 
During the course of these Labs – the “Locks” will be turned on/off as the situation 
dictates. *It is very important to ensure that the “Locks” are set according to the steps and 
instructions for each Lab when indicated.  
 
 
 
 
 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned ON.  There should be a check mark next to the Feature Filter Lock. 
 
 
Ensures that the Feature Filter Lock is turned ON. 

Important Step---!!! 

Important Step---!!! 
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45.  *View the TOPO_E_MOBSC (Obscured Area) Features in the 1234567_SDE DTM 
 
*Note: The TOPO_E_MOBSC Features will be viewed in order to depict the obscured 
areas in which new survey data will be merged into the 1234567_SDE.dtm. Please note 
that not all obscured areas will be processed in this Lab. 
 
Click SurfaceView SurfaceFeatures from the InRoads pull-down menu and the 
View Features dialog box will appear.    
 

• In the Surface: Pulldown – select 1234567_SDE 
 

Click on the Filter button. 
 
 
 
 
 
 
Opens the View Features dialog box 

46.  View the selected Features: 
 
    ** WARNING ** – During this step take care not to roll the scroll button on your 

mouse. 
 
The Feature Selection Filter dialog box will open. In the Feature Selection Filter 
dialog box --- input the following: 
 

• In the Filter Name: pulldown – select OBSCURED- MOBSC, DOBSC, TCBA 
 
This will filter the view to include the following Surface Feature codes:  
TOPO_E_MOBSC 
TOPO_E_DOBSC 
 TOPO_E_TCBA  
 
Note:  
The TOPO_E_MOBSC is a Photogrammetry Obscured Area. The TOPO_E_DOBSC 
is a Field Survey Obscured Area and the TOPO_E_TCBA Construction Boundary 
feature is used for both Mapping and Field. 
 
Leave all other entries as default! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-5 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Feature Selection Filter dialog box. 
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Figure L9-5 Feature Selection Filter 

 
 

47.  Click OK and the Feature Selection Filter dialog box will Close.  The View Features 
dialog box should still be open from the previous steps. 
 
The inputs in the View Features dialog box should now correspond to the screen capture 
depicted in Figure L9-6 (as shown below).  Verify to ensure that your input matches the 
screen capture.    
 
 
Closes the Feature Selection Filter dialog box. 

 
 
 
 
 
 
 
 
 
 
 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 

Use the pull-down arrow to 
select the Filter Named 
‘OBSCURED - MOBSC, 
DOBSC, TCBA” 

When the filter name is 
selected the data will be 
filtered as depicted here. 
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Figure L9-6 View Features 

 
48.  Click Apply. 

 
 Views the  1234567_SDE (TOPO_E_MOBSC Features) in MicroStation 

49.  Click Close to close out of the View Features dialog box. 
 
Closes the View Features dialog box. 

50.  Important Step!  
In the [MicroStation Software] – Turn AccuDraw off for the following Lab. 
 
Toggle the MicroStation AccuDraw off – 
Click the AccuDraw icon in the Primary Tools tool box: 
 
 
 

     
  
                   AccuDraw Docked View                                 AccuDraw Undocked View 
 

 
                                
 
                            
 Depicts AccuDraw settings.         

AccuDraw Icon 
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51.  In the [MicroStation Software] – 
 

• Select “Fit View” and all of the TOPO_E_MOBSC Features (Red Obscured 
Areas) will be depicted in the MicroStation View Window.  See screen capture 
depicted below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Views the extents of the Features in MicroStation. 

52.  In the [MicroStation Software] – 
 

• Zoom (window in) to the top mid-NE Area of the MicroStation View so that the 
screen appears as the following: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Zooms into the area depicted on the right. 
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53.  In the [MicroStation Software] – 
 

• Zoom (window in) more so that the screen appears similar to the following: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Zooms into the obscured area depicted above. 

54.  Information Only: 
 
In the next Lab steps – we will be modifying an obscured area so that new enhancement 
data can be incorporated into this area. The obscured area is basically three separate 
obscured limit lines.  
 
MOBSC33 
MOBSC38 
MOBSC27 
 
Two of the obscured areas (MOBSC33 and MOBSC38) can be removed/deleted but in 
the third area (MOBSC27) only a “partial” area will be removed. The rest of this 
obscured area will remain as obscured.  This will entail using the partial delete command 
in InRoads. Once these obscured areas have been deleted the new enhancement data will 
be added to these areas in later Labs.  
 
 
 
Obscured Areas – Partial Delete Information. 

 
 
 
 
 
 
 
 

MOBSC 27 

MOBSC 38 

MOBSC 33 
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55.  In the [InRoads  and MicroStation Software(s)] –  
 
The obscured area (MOBSC27) will be partially deleted where it intersects the 
TOPO_E_TLIML175 Limit Line. All of the obscured area within the boundaries of the 
TLIML will be deleted. The rest of the MOBSC27 will remain obscured. 
 
Click SurfaceEdit Surface Partial Delete 
 
**Please Note: 

•   A Dialog Box will not appear for this command. A prompt in MicroStation is 
initiated instead of a dialog box. Look in the bottom left-hand corner of  
MicroStation for the following prompt:  

 
 

• To Identify Feature – left-click on the MOBSC27 Obscured line. 
• Left-Click again to accept it. 
• A prompt will appear to “Identify Starting Point” – Left click (at the Starting 

Point) on the area depicted in the screen capture below: 
• A prompt will then appear to “Identify Ending Point”  - Left click (at the 

Ending Point) on the area depicted in the screen capture below: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
The MOBSC27 Obscured Area is partially deleted. 

 
 
 
 
 
 
 
 
 

MOBSC27 

(Starting 
Point) 

(Ending  
Point) 

TOPO_E_TLIML175 
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56.  The Partially Obscured Area for MOBSC27 should now look similar to the following 
screen capture: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Depicts the MOBSC27 Obscured Feature after the partial deletion. 

57.  Although the MOBSC27 Obscured area was partially deleted – if you zoom in close – 
you will see that there is still a slight overlap of the obscured alignment in the TLIML 
area. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Depicts the overlap into the TLIML Area. 

 
 
 
 
 
 
 

MOBSC27 

MOBSC38 

MOBSC33 
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58.   In the [InRoads Software] 
 
To resolve the overlap – follow these steps in InRoads. 
 
Click SurfaceEdit Surface Edit Feature Point and the Edit Feature Point dialog 
will appear. 
 
Opens the Edit Feature Point dialog box. 

59.  In the Edit Feature Point dialog box – enter the following:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Feature: Pulldown –  select MOBSC27 
• In the Point Scroll box – enter the number 39 and click the tab key 
• Place a Check Mark       in the Center View box 
• Enter a Northing of  –  1362332.985 
• Enter an Easting of  –  1959893.517 
• Retain the  Elevation of  –  1071.228 
• Uncheck the Start of Discontinuity check box.  This recloses MOBSC27 so it 

will be a closed shape.  If it is not closed, triangulation will occur across it.  The 
Interior Boundary designation is only recognized on closed shapes. 
 

Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-7 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Edit Feature Point Dialog Box. 

 
 

                                                          
Figure L9-7 Edit Feature Point 39 
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60.  Click Apply --- but DO NOT close out of the Edit Feature Point dialog box.  
 
Resolves the overlap for Point 39 in the MOBSC27 Feature by using the Edit Feature 
Point dialog box. 

61.  In the Edit Feature Point dialog box – enter the following:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Feature: Pulldown –  select MOBSC27 
• In the Point Scroll box – enter the number 40 and click the tab key 
• Place a Check Mark       in the Center View box 
• Enter a Northing of  –  1362295.997 
• Enter an Easting of  –  1959857.605 
• Retain an Elevation of  –  1074.459 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-8 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Edit Feature Point Dialog Box. 

 
 

                                 
Figure L9-8 Edit Feature Point 40 

 
 

62.  Click Apply and then click Close to close out of the Edit Feature Point dialog box.  
 
Resolves the overlap for Point 40 in the MOBSC27 Feature by using the Edit Feature 
Point dialog box. 
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63.  Information Only!! 
 
In order to maintain consistency in the Labs – the above steps used a hard coded entry so 
that the Lab Data would correspond. In a “real world” project – the User could utilize the 
Locate Buttons and graphically resolve the overlaps. Also - the overlaps do not need to 
be resolved so that the points exactly correspond with the TLIML area. There can be a 
slight gap or overlap – just ensure that the points are close in order for the triangulation to 
be accurate. 
 
Another method to resolve the gap or overlap for a Partially Deleted Area is to click the 
following Locate Buttons and graphically resolve the areas. 
 
 
 
 

                 
 
 
 
 
 
 
 
 
 
 
 
  
 
  
 
 
 
Additional Information regarding the Edit Feature Point Command. 

 

Locate Button to select 
the Feature 

Locate Button to select 
the Point Locate Button to select 

the Northing and 
Easting 
 
 (The User can then – 
rubber band the points 
to a desired location). 
 
Note: The Elevation 
should not need to be 
changed (Just the NE 
Coordinates). 
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64.  Information Only!! 
 
The MOBSC27 Feature has been partially deleted. The next step is to change the 
MOBSC33 and the MOBSC38 Feature from an Interior Boundary to a **Breakline so 
that these Features can be deleted from inside the “TOPO_E_TLIML175” Limit Line.  
 
**The Feature MUST be a Breakline in order to be deleted. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Information regarding the processing of the MOBSC38 and MOBSC33 Features. 

65.  In the [InRoads Software] 
 
To change the MOBSC38 and MOBSC33 Features from Interior Boundaries to 
Breaklines – follow these steps in InRoads. 
 
Click SurfaceFeature Feature Properties and the Feature Properties dialog will 
appear. 
 
Opens the Feature Properties dialog box. 

66.   In the Feature Properties dialog box perform the following steps: 
 

• In the Surface: Pulldown ensure that 1234567_SDE is the selected Surface. 
• In the Feature: List box:  

Scroll down the list – and Highlight the Name of MOBSC33 and MOBSC38 by 
holding down the Control Key on the keyboard and left-clicking the MOBSC33 
and MOBSC38 Features. 
o These should now be highlighted in blue. 

• In the Triangulation Field next to Feature Type: – change the type from Interior 
to Breakline. 

 
The inputs should now correspond to the screen capture depicted in  
Figure L9-9 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Feature Properties Dialog Box.  

MOBSC27 

MOBSC38 

MOBSC33 
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Figure L9-9 Feature Properties 

 
67.  Click Apply and then click Close to close out of the Feature Properties dialog box.  

 
Changes the MOBSC33 and MOBSC38 Features from Interior to Breaklines.    

68.  To Delete the MOBSC33 and MOBSC38 Features: 
 
Click SurfaceEdit Surface Delete Feature and the Delete Feature dialog box will 
open. 
 

• In the Surface: Pulldown – ensure that 1234567_SDE is selected. 
•  In the Feature: List box:  

Scroll down the list – and Highlight the Name of MOBSC33 and MOBSC38 by 
holding down the Control Key on the keyboard and left-clicking the MOBSC33 
and MOBSC38 Features. 
o These should now be highlighted in blue. 

• Click Apply and the following Dialog Box will appear: 
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• Select OK and the MOBSC33 and MOBSC38 breaklines will be deleted.  
• Click Close to close out of the Delete Feature dialog box. 

 
Deletes the MOBSC33 and MOBSC38 Features. 

69.  Information Only!! 
 
The MOBSC33 and the MOBSC38 Features must be changed to a Feature Type of 
Breakline before removing (deleting) the features.  If the Feature Type is left as an 
Interior – the points of the feature are deleted but not the alignment. In order to ensure 
that all obscured area boundaries (points and alignments) are removed so that there is no 
overlapping of data -- the Breakline Feature Type is used.  
 
Information regarding the deleting of obscured area boundaries. 

70.  You will need to save your work periodically whenever changes have been made to the 
dataset. 
 
Save the InRoads Surface Project: 
 
 Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface Project has 
already been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will be saved to Lab 9 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 9 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Surface Project has been saved.   
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 9   

71.  VERY Important Step:   
 
DO NOT DELETE --- the Data in the DGN file (GDOT 3D Working File.dgn). These 
DGN Graphics will be used in the next Lab 9C. 
   
Informs the User to NOT DELETE  the Graphics from the GDOT 3D Working File.dgn   
for the next Lab. 
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Lab9C Process Enhancements Outside of  the Exterior Boundary 
 
In the following Lab – the process of modifying the Exterior Boundary will be depicted. There 
may be situations where enhancement data for an obscured area will be collected outside of the 
current existing Exterior Boundary. This will result in the Exterior Boundary being extended 
outward in order to encompass the new enhancement data.  The first step will be to modify the 
Exterior Boundary in the 1234567_SDE Surface so that in later Labs the data from the 
1234567_XO Surface data can be added/merged to the obscured area.   
 
72.    If MicroStation and InRoads are not already open – refer back to Steps 1 – 5 in Lab 9A 

to open MicroStation and InRoads and the associated database files. 
 
Starts the MicroStation and InRoads Software Products (if they were closed previously).   

73.  IMPORTANT!!    In the following Labs – it is critical to remember which Surface is the 
Active Surface -depicted by the Red Rectangle . You will be switching from one Surface 
to another periodically to perform commands and it is very important to make sure the 
correct surface is the active one. 
 
 
 
 
 
Ensure that the 1234567_SDE database is the Active Surface (has a red rectangle) next 
to the 1234567_SDE name. If this is Not the Active Surface – Please see Lab 9A Step 
22 to set the Active Surface. 
 
Ensures that the correct DTM --- (1234567_SDE) is active. 

74.  *Set InRoads “Locks” 
 
During the course of these Labs – the “Locks” will be turned on/off as the situation 
dictates. *It is very important to ensure that the “Locks” are set according to the steps and 
instructions for each Lab when indicated.  
 
 
 
 
 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned ON.  There should be a check mark next to the Feature Filter Lock. 
 
 
Ensures that the Feature Filter Lock is turned ON. 

 
 

Important Step---!!! 

Important Step---!!! 
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75.                          *View the TOPO_E_MOBSC (Obscured Area) Features in the 1234567_SDE DTM 
 
*Note: The TOPO_E_MOBSC Features will be viewed in order to depict the obscured 
areas in which new survey data will be merged into the 1234567_SDE.dtm. Please note 
that not all obscured areas will be processed in this Lab. 
 
Click SurfaceView SurfaceFeatures from the InRoads pull-down menu and the 
View Features dialog box will appear.    
 

• In the Surface: Pulldown – select 1234567_SDE 
 

Click on the Filter button. 
 
 
 
 
 
 
Opens the View Features dialog box 

76.  View the selected Features: 
 
    ** WARNING ** – During this step take care not to roll the scroll button on your 

mouse. 
 
The Feature Selection Filter dialog box will open. In the Feature Selection Filter 
dialog box --- input the following: 
 

• In the Filter Name: pulldown – select OBSCURED- MOBSC, DOBSC, TCBA 
 
This will filter the view to include the following Surface Feature codes:  
TOPO_E_MOBSC 
TOPO_E_DOBSC 
 TOPO_E_TCBA  
 
Note:  
The TOPO_E_MOBSC is a Photogrammetry Obscured Area. The TOPO_E_DOBSC 
is a Field Survey Obscured Area and the TOPO_E_TCBA Construction Boundary 
feature is used for both Mapping and Field. 
 
Leave all other entries as default! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-10 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Feature Selection Filter dialog box. 
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Figure L9-10 Feature Selection Filter 

 
 

77.  Click OK and the Feature Selection Filter dialog box will Close.  The View Features 
dialog box should still be open from the previous steps. 
 
The inputs in the View Features dialog box should now correspond to the screen capture 
depicted in Figure L9-11 (as shown below).  Verify to ensure that your input matches the 
screen capture.    
 
 
Closes the Feature Selection Filter dialog box. 

 
 
 
 
 
 
 
 
 
 
 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 

Use the pull-down arrow to 
select the Filter Named 
‘OBSCURED - MOBSC, 
DOBSC, TCBA” 

When the filter name is 
selected the data will be 
filtered as depicted here. 
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Figure L9-11 View Features 

 
78.  Click Apply. 

 
 Views the  1234567_SDE (TOPO_E_MOBSC Features) in MicroStation 

79.  Click Close to close out of the View Features dialog box. 
 
Closes the View Features dialog box. 

80.  Important Step!  
In the [MicroStation Software] – Turn AccuDraw off for the following Lab. 
 
Toggle the MicroStation AccuDraw off – 
Click the AccuDraw icon in the Primary Tools tool box: 
 
 
 

  
  
                   AccuDraw Docked View                                 AccuDraw Undocked View 
 

 
                                
 
                            
  

AccuDraw Icon 
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81.  In the [MicroStation Software] – 
 

• Select “Fit View” and all of the TOPO_E_MOBSC Features (Red Obscured 
Areas) will be depicted in the MicroStation View Window.  See screen capture 
depicted below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Views the extents of the Features in MicroStation. 

82.  In the [MicroStation Software] – 
 

• Zoom (window in) to the mid-West Area of the MicroStation View so that the 
screen appears as the following: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Zooms into the area depicted on the right. 
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83.  In the [MicroStation Software] – 
• Place a Fence (Block Fence) around the area as depicted in the screen capture 

above by selecting the following command: 
 
 
 
 
 
Selects the Place Fence Command. 

84.  In the [MicroStation Software] – 
 

• When the Place Fence command is selected – the following dialog box will 
appear in MicroStation: 

 

 
 

• Select Fence Type = Block 
• Select Fence Mode = Inside 

 
• Next place the fence (Block Fence) around the area depicted below: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Places a fence around the area shown above. 

Place Fence  
Command 
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85.  *Set InRoads “Locks” 
 
During the course of these Labs – the “Locks” will be turned on/off as the situation 
dictates. *It is very important to ensure that the “Locks” are set according to the steps and 
instructions for each Lab when indicated.  
 
 
 
 
 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned OFF.  There should NOT be a check mark next to the Feature Filter 
Lock. 
 
 
Ensures that the Feature Filter Lock is turned OFF. 

86.  Click SurfaceView SurfaceFeatures from the InRoads pull-down menu and the 
View Features dialog box will appear.    
 
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Fence Mode: Pulldown – select Inside 

 
The inputs should now correspond to the screen capture depicted in  
Figure L9-12 (as shown below).  Verify to ensure that your input matches the screen 
capture.    

 
 

Closes the Feature Selection Filter dialog box. 
 
 

Important Step---!!! 
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Figure L9-12 View Features 

 
 
 
 
 
 
 
 
87.  Click Apply. 

 
 Views the 1234567_SDE (Features) in a MicroStation Fenced Area. 

88.  Click Close to close out of the View Features dialog box. 
 
 
Closes the View Features dialog box.  

89.  Information Only: 
 
As mentioned previously -- the reason we are viewing the 1234567_SDE Features within 
a fenced area is to speed up the viewing/processing time and to assist the user in finding 
the areas to enhance. Due to the amount of data in the 1234567_SDE database – it is 
much faster to work in sections than in the entire database.  The user – may of course - 
view the entire surface features – but it appears to be much easier to work in just the 
sections that require processing.  
 
Viewing Information.    
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90.     In the [MicroStation Software] – 
 

• De-select the MicroStation Place Fence Command by clicking on the Fence Icon 
(see below). 

 
 
 
 
 
 
 
 
De-Selects the Place Fence Command. 

91.  In the [MicroStation Software] – 
 

• Your view should now appear similar to the following: 
• Zoom into the area depicted by the red arrow --- 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Zooms to the area depicted by the red arrow. 

92.  In the [MicroStation Software] – 
• After zooming in -- Your view should now appear similar to the following: 

 
 
 
 
 
 
 
 
 
 
Zooms to the area of the MBOUNDARY. 

De-selects 
the Fence  
Command 

Exterior Boundary: 
MBOUNDARY 
  

Zoom to this Limit Line 
TOPO_E_TLIML 
Exterior Boundary 
named 
MBOUNDARY (the 
white dashed line). 

Obscured Area: 
MOBSC14 
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93.  Information Only: 
 
In the next Lab steps – we will be modifying the MBOUNDARY so that it will be 
extended to encompass the obscured area of MOBSC14 so that new enhancement data 
can be incorporated into this area.   
 
This will entail using the “Edit Feature Point” command in InRoads. Once the Exterior 
Boundary of (MBOUNDARY) has been extended around the obscured area 
(MOBSC14) the new enhancement data will be added to these areas in later Labs.  
 
 
Extending the Exterior Boundary Information. 

94.   In the [InRoads Software] 
 
To extend the MBOUNDARY – follow these steps in InRoads. 
 
Click SurfaceEdit Surface Edit Feature Point and the Edit Feature Point dialog 
will appear. 
 
Opens the Edit Feature Point dialog box. 

95.  In the Edit Feature Point dialog box – enter the following: (Make Sure you retain the 
same coordinate information for Point 1022). 
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Feature: Pulldown –  select MBOUNDARY 
• In the Point Scroll box – enter the number 1022 and click the tab key 
• Place a Check Mark       in the Center View box 
• Retain the Northing of  –  1360922.489 
• Retain the Easting of  –  1956318.783 
• Retain the Elevation of  –  1084.665 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-13 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Edit Feature Point Dialog Box. 
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Figure L9-13 Edit Feature Point 1022 

 
96.  Information Only: 

 
The Point 1022 coordinates on MBOUNDARY will not be edited. This point and 
succeeding points will be deleted from the MBOUNDARY in order to encompass the 
obscured area. 
 
Information regarding the deleting of points from MBOUNDARY. 

97.  Important Step!! 
 
In the Edit Feature Point dialog box – perform the following steps: 

• Click the Delete key in the dialog box until the Current Point Number in the Edit 
Feature Point dialog box depicts the following: Point 1022 of 4543. 
 

 
 

• You will be able to see the selected points being deleted by the depiction of a 
purple box which traces each point as it is being deleted. 

• When Point Number 4543 appears ----- Stop and do not close out of the dialog 
box!! 

 
Selects the points to be deleted from the MBOUNDARY. 

98.  Although the Points on the MBOUNDARY have been selected to be deleted – they will 
not be removed until the Apply button is clicked. 
 

• Click Apply --- but DO NOT Close out of the Edit Feature Point dialog box.  
 
The MBOUNDARY should now correspond to the screen capture depicted in  
Figure L9-14 as shown below.    
 
Deletes the selected points from the MBOUNDARY. 

 

Stop Deleting when 
this number appears 
(4543) 
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Figure L9-14 Edited MBOUNDARY  

 
 

99.  The Edit Feature Point dialog box should now correspond to the screen capture 
depicted in Figure L9-15 as shown below.    
 
Depicts the Edit Feature Point dialog box current settings. 

 
 
 

 
Figure L9-15 Edit Feature Point 1022 

 
 
 
 

100.  Information Only: 
 
The original MBOUNDARY contained 4634 points. After deleting approximately 91 
points – the total number of points in the MBOUNDARY now contains 4543.  InRoads 
removes this “empty” numbers gap and continues numbering with 1022 so that there are 
no empty number place holders. Basically the points are renumbered to remove this gap.   
 
Information regarding the deleting of points from MBOUNDARY. 
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101.  The next step is to modify Point 1022 in the MBOUNDARY to ensure that the 
MBOUNDARY will encompass the obscured area of MOBSC14. 
 
In the Edit Feature Point dialog box – enter the following:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Feature: Pulldown –  select MBOUNDARY 
• In the Point Scroll box – enter the number 1022 and click the tab key 
• Place a Check Mark       in the Center View box 
• Enter a Northing of  –  1360772.985 
• Enter an Easting of  –  1955932.969 
• Retain an Elevation of  –  1061.473 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-16 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Edit Feature Point Dialog Box. 

 
 

 
Figure L9-16 Edit Feature Point 1022 

 
 
 

102.  Click Apply but DO NOT Close out of the Edit Feature Point dialog box.  
 
Please be patient. It may take a moment for the point to modify graphically in 
MicroStation. 
 
Modifies Point Number 1022 so that it will encompass the obscured area of MOBSC14. 
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103.  The next step is to modify Point 1021 in the MBOUNDARY to ensure that the 
MBOUNDARY will encompass the obscured area of MOBSC14. 
 
In the Edit Feature Point dialog box – enter the following:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Feature: Pulldown –  select MBOUNDARY 
• In the Point Scroll box – enter the number 1021 and click the tab key 
• Place a Check Mark       in the Center View box 
• Enter a Northing of  –  1360927.456 
• Enter an Easting of  –  1956304.564 
• Retain an Elevation of  –  1085.498 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-17 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Edit Feature Point Dialog Box. 

 
 

                            
Figure L9-17 Edit Feature Point 1021 

 
104.  Click Apply.  

 
Please be patient. It may take a moment for the point to modify graphically in 
MicroStation. 
 
Now click Close to close out of the Edit Feature Point dialog box 
 
Modifies Point Number 1021 so that it will encompass the obscured area of MOBSC14. 
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105.  Information Only!! 
 
In order to maintain consistency in the Labs – the above steps used a hard coded entry so 
that the Lab Data would correspond. In a “real world” project – the User could utilize the 
Locate Buttons and graphically modify the MBOUNDARY so that it encompasses the 
obscured area. The boundary does not need to be modified so that the points exactly 
correspond with the MOBSC area. There can be a slight gap or overlap – just ensure that 
the points are close in order for the triangulation to be accurate. 
 
Another method to modify the MBOUNDARY is to click the following Locate Buttons 
and graphically modify the Exterior Boundary. 
 
 
 
 
                 

                  
 
 
 
 
 
 
 
 
 
 
  
 
  
 
 
 
Additional Information regarding the Edit Feature Point Command. 

Locate Button to select 
the Feature 

Locate Button to select 
the Point 

Locate Button to select 
the Northing and 
Easting 
 
 (The User can then – 
rubber band the points 
to a desired location). 
 
Note: The Elevation 
should not need to be 
changed (Just the NE 
Coordinates). 
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106.  Information Only!! 
 
The MBOUNDARY Feature has been modified to encompass the MOBSC14 Obscured 
Area. The next step is to change the MOBSC14 Feature from an Interior Boundary to a 
**Breakline so that the Feature can be deleted. 
 
**The Feature MUST be a Breakline in order to be deleted. 
 
Information regarding the processing of the MOBSC14 Feature. 

107.  In the [InRoads Software] 
 
To change the MOBSC14 Feature from an Interior Boundary to a Breakline – follow 
these steps in InRoads. 
 
Click SurfaceFeature Feature Properties and the Feature Properties dialog will 
appear. 
 
Opens the Feature Properties dialog box. 

108.   In the Feature Properties dialog box perform the following steps: 
 

• In the Surface: Pulldown ensure that 1234567_SDE is the selected Surface. 
• In the Feature: List box:  

Scroll down the list – and Highlight the Name of MOBSC14 by left-clicking the 
MOBSC14 Feature. 
o The Feature should now be highlighted in blue. 

• In the Triangulation Field next to Feature Type: – change the type from Interior 
to Breakline. 

 
The inputs should now correspond to the screen capture depicted in  
Figure L9-18 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Feature Properties Dialog Box.  
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Figure L9-18 Feature Properties 

 
109.  Click Apply and then click Close to close out of the Feature Properties dialog box.  

 
Changes the MOBSC14 Feature from Interior to Breaklines.    

110.  To Delete the MOBSC14 Feature: 
 
Click SurfaceEdit Surface Delete Feature and the Delete Feature dialog box will 
open. 
 

• In the Surface: Pulldown – ensure that 1234567_SDE is selected. 
•  In the Feature: List box:  

Scroll down the list – and Highlight the Name of MOBSC14 by left-clicking the 
MOBSC14 Feature. 
o The Feature should now be highlighted in blue. 

• Click Apply and the following Dialog Box will appear: 
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• Select OK and the MOBSC14 breakline will be deleted.  
• Click Close to close out of the Delete Feature dialog box. 

 
Deletes the MOBSC14 Feature. 

111.  Information Only!! 
 
The MOBSC14 Feature must be changed to a Feature Type of Breakline before 
removing (deleting) the features.  If the Feature Type is left as an Interior – the points of 
the feature are deleted but not the alignment. In order to ensure that all obscured area 
boundaries (points and alignments) are removed so that there is no overlapping of data -- 
the Breakline Feature Type is used.  
 
 
Information regarding the deleting of obscured area boundaries. 

112.  You will need to save your work periodically whenever changes have been made to the 
dataset. 
 
Save the InRoads Surface Project: 
 
 Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface Project has 
already been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will be saved to Lab 9 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 9 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Surface Project has been saved.   
 
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 9   
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113.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
  
 
Deletes the Graphics from the GDOT 3D Working File.dgn file to ensure a clean DGN 
file for the next Lab. 
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Lab9D Merge Original Field Enhancements into Mapping Surface 
 
In the previous Labs (Lab 9A- Lab 9C) – the process for preparing areas of the Mapping 
Surface for different enhancement situations were depicted. The process of adding enhancements 
to new construction areas, obscured/partially obscured areas and data located outside of the 
current existing exterior boundary were demonstrated. The next step is to merge/add these 
enhancements from the 1234567_XO Original Field Enhancements Surface to the 
1234567_SDE Mapping Surface.  
 
Please Note: When this data is merged there will be segment crossings due to the fact that for 
these Labs not all crossings were resolved -- especially in the obscured areas. In a “Real World” 
Project it is important to correct these areas in order to ensure correct triangulation of the surface 
data. For additional information regarding the resolution of Segment Crossings – please refer to 
Lab 4 in these Tutorials.  
 
Please Note: When the data from the Original Enhancements are added to the Mapping Surface 
– your data may not exactly match the screen captures or triangulation calculations depicted in 
this tutorial due to the fact that some selections and inputs in previous Labs may have differed 
slightly. This should not be a concern. As long as the steps were followed in the previous Labs – 
the calculations should not differ greatly.  
 
 
 
 
114.  If MicroStation and InRoads are not already open – refer back to Steps 1 – 5 in Lab 9A 

to open MicroStation and InRoads and the associated database files. 
 
Starts the MicroStation and InRoads Software Products (if they were closed previously).   

115.  *Set InRoads “Locks” 
 
During the course of these Labs – the “Locks” will be turned on/off as the situation 
dictates. *It is very important to ensure that the “Locks” are set according to the steps and 
instructions for each Lab when indicated.  
 
 
 
 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned OFF.  There should NOT be a check mark next to the Feature Filter 
Lock. 
 
 
 
Ensures that the Feature Filter Lock is turned OFF. 

Important Step---!!! 
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116.  To Merge/Add the Original Enhancement Data to the Mapping Surface: 
 
Click SurfaceEdit Surface Copy Portion of Surface and the Copy Portion of 
Surface dialog box will open. (The following steps are critical!). 
 

• In the Source Surface: Pulldown – ensure that 1234567_XO is selected. 
• In the Destination Surface: Pulldown – ensure that 1234567_SDE is selected. 
• In the Clip By: Pulldown – ensure that Fence is selected. 
• In the Duplicate Names: Radio Buttons – ensure that Rename is selected. 

 
 

 Leave all other entries as Default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-19 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets entries in the Copy Portion of Surface Dialog Box. 

 
 

                                   
Figure L9-19 Copy Portion of Surface 

 
 
 
 

117.  Click Apply and then click Close to close out of the Copy Portion of Surface dialog 
box 
 
Merges the data from the 1234567_XO Surface to the 1234567_SDE Surface. 



Introduction to InRoads - SDE  InRoads SS2 – Lab 9 

   
 Lab9-53   

118.  Information Only: 
 
The Original Field Survey Enhancements from Surface 1234567_XO have been merged 
into the Mapping Surface of 1234567_SDE. The data will now be triangulated in the 
1234567_SDE Surface. 
 
Information regarding the merging of original enhancement data to Mapping Surface. 

119.  IMPORTANT!!    In the following Labs – it is critical to remember which Surface is the 
Active Surface - depicted by the Red Rectangle .  
 
(In the previous command ---- the 1234567_XO Surface became active – so make sure 
that you change the active surface back to 1234567_SDE!!) 
 
 
 
 
 
 
Ensure that the 1234567_SDE database is the Active Surface (has a red rectangle) next 
to the 1234567_SDE name.   
 

• Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).   

• Select the 1234567_SDE surface (by Left clicking) and the Name will highlight 
in blue. 

• Then (Right click) over the surface and a pop-up dialog will appear.  
• Click Set Active and a red rectangle will appear beside the 1234567_SDE 

Surface Name.      
 
Ensures that the correct DTM --- (1234567_SDE) is active. 

120.  The 1234567_SDE Surface will now be triangulated in order to incorporate the merging 
of the 1234567_XO Enhancement Data. 
 
Select SurfaceTriangulate Surface.  The Triangulate Surface dialog box will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Maximum Length: field enter – 300.000 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-20 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Triangulate Surface dialog box.   

 

Important Step---!!! 
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Figure L9-20 Triangulate Surface 

 
 
121.  Click Apply.  Please be Patient! 

 
It may take a while for the Surface to triangulate depending on the size of the file! 
The InRoads Status Bar (Located at the bottom – left hand side of the InRoads Interface) 
usually will depict the completion percentage of the triangulation on larger projects.   
 
The 1234567_SDE DTM Surface is triangulated. 

122.  A dialog box may appear informing you that 16 TRP1 points have been deleted 
successfully. If this dialog box does not appear – the reason is the user may have the 
Report Lock turned off. 
 

• Click the Close button in this dialog box to close the message. 
 
Note: These points were the MBOUNDARY points that were deleted in Lab 9C. 
 
Depicts a message informing the user that points were deleted from the DTM 
successfully. 

123.  After the triangulation is completed – click Close to close out of the Triangulate 
Surface   dialog box. 
 
Closes the Triangulate Surface dialog box 

124.  Information Only: 
 
The next step is to determine if any crossing segments were introduced during the 
merging of data. (Please Note – there will be crossing segments in this Lab due to the 
fact that not all obscured areas were addressed and processed). In a “real world” project 
these errors will need to be corrected in order to ensure an accurate DTM surface. 
 
 
Information regarding crossing segments. 



Introduction to InRoads - SDE  InRoads SS2 – Lab 9 

   
 Lab9-55   

125.  Click Surface UtilitiesResolve Crossing Segments and the Resolve Crossing 
Segments dialog box will appear:  
 

• In the Surface: Pulldown – select 1234567_SDE 
• In the Mode: field –  select Interactive 
• In the Delta Tolerance: field – select > 0.020 

(Ensure the Greater Than Sign is selected) 
• In the Match Elevation: entry – select       Median 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-21 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Resolve Crossing Segments dialog box 

 
 
 
 

                                
Figure L9-21 Resolve Crossing Segments  

 

**WARNING**  
 
Ensure the Delta 
Tolerance of > 0.020 is 
selected. 

 

**Information** 
 
When using the 
Automatic Mode the 
Delta Tolerance should 
be set to < 0.020. 
When using the 
Interactive Mode the 
Delta Tolerance should 
be set to > 0.020. 
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126.  Click Apply.   
 
If there are any Crossing Segments, these will be depicted (highlighted in Red) in the list 
field of the dialog box. In this case, there are 6 Crossing Segments listed in the list field. 
 
These 6 Crossing Segments will need to be manually resolved.  The Feature 1, Feature 
2 and the Elevation Delta of the mismatched elevation crossings are also depicted.   
 
The Resolve Crossing Segments dialog should now correspond to the screen capture 
depicted in Figure L9-22 (as shown below).  Verify to ensure that your input matches the 
screen capture.    

 

                              
Figure L9-22 Resolve Crossing Segments  

 
127.  Information Only: 

 
As mentioned previously – this Lab will not depict the process of resolving the crossing 
segments. The upcoming Labs will provide a dataset which has already been processed 
and all crossing segments resolved.  For additional information – please refer back to Lab 
4 for the procedures for resolving crossing segments. 

There are 6 Crossing 
Segments which need 
to be resolved. 

List of the 6 Crossing 
Segments depicted in 
Red text. 
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128.  Click Close to exit the Resolve Crossing Segments dialog box.   
 
Closes the Resolve Crossing Segments dialog box.     

129.  View the DTM Triangles and MBOUNDARY to ensure that the extraneous triangles are 
deleted and to ensure that no spikes or erroneous data were introduced. 
 
View the Surface Triangles: 
 

• Select SurfaceView Surface Triangles from the InRoads Menu. The 
following dialog box will appear: 
 

 
  

• In the Surface: pulldown – select 1234567_SDE 
• In this dialog box – click on the Preferences… button and the following dialog 

box will appear: 
 

 
 
 
 
 
 
 
 
 
 
 
  

• In this dialog box – select the Preference of EXISTING. Then click Load and 
then click Close and the Preferences dialog box will close.  

 
 
 
 
Sets the Preference for the viewing of the 1234567_SDE.dtm Surface. 
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130.  In the View Triangles dialog box – click Apply. 
 
Please Note: 
At this point you may encounter a dialog box which says that the “Triangles are out of 
Date. Re-triangulate?”  
 
 
 
 
 
 
 
 
 
 
 
 
 

• If you receive this dialog box – select Yes. 
 
The reason that this box appears --- is because whenever the Resolve Crossing 
Segments Command is utilized the DTM must be re-triangulated in order to ensure that 
all triangles are up to date. 
 
 
View the 1234567_SDE Enhancement data triangles 

131.  Please be patient – it may take a while to view the triangles depending on the size of the 
DTM. 
 

• In the View Triangles dialog box – click Close to close out of the dialog box. 
 
 
Closes the View Triangles dialog box and views the triangles. 

132.  View the MBOUNDARY Feature: 
 
Select SurfaceView SurfaceFeatures and the View Features dialog box will open.   
 
 

• In the Surface: Pulldown – select 1234567_SDE 
• When the dialog box is opened – all of the Features in the Features: list will be 

highlighted in Blue.  
• Left click on MBOUNDARY so that it is the only Feature highlighted in Blue. 
• Click Apply. (It may take a moment for the Feature to View). 
• Then click Close to close out of the dialog box. 

 
Selects the MBOUNDARY Feature to view. 
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133.  View the selected Surface Features/Triangles in the [MicroStation Software] by using the 
following command located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Zoom In or Zoom Out” or “Fit View” Icons as appropriate to view the 
Features. 
 

              
 
            
 
 
 
 
 
  
 
 
The Surface Features/Triangles are displayed on the MicroStation screen. 

134.  Important Note: 
In a “real world” Project – any obvious errors, segment crossings, etc. would be reviewed 
in the 1234567_SDE Surface and would be resolved at this point. Please see Lab 4 and 
Lab 6 in the Full Field Survey Section for steps in resolving crossing segments and/or 
spikes in the DTM. 
 
 
Review the 1234567_SDE data. 

135.  The “Merged” Surface will now be compressed (deleted data will be removed from 
memory) which will reduce the size of the DTM file.  
 
Select SurfaceUtilitiesCompress Surface and the Compress Surface dialog box 
will open.   
 

• In the Surface: Pulldown – select 1234567_SDE 
 

Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L9-23 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Compress Surface dialog box.   

 
 
 

Fit View 
Zoom In or Out 

Rotate 
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Figure L9-23 Compress Surface 

 
 

136.  Click Apply. 
 
A dialog box will appear that warns that the Surface will be re-triangulated.  
(See Figure L9-24 as shown below). 
 
Generates a re-triangulate warning box.                     

 
 

                     
Figure L9-24 Re-Triangulate Message Dialog box. 

 
 
 

137.  Click Yes.  
 
The 1234567_SDE DTM Surface will be re-triangulated. 
 
Re-triangulates the Surface.                     

138.  After the re-triangulation is completed – click Close to close out of the Compress 
Surface dialog box. 
 
 
Closes the Compress Surface dialog box. 
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139.  Information Only: 
 
 
The *1234567_SDE.dtm is a “working surface” for the use of Survey Data Engineers. 
After submission to the Designer(s) – the Designer will re-name the surface to 
1234567_Exist.dtm. The procedure of re-naming the Surface will be the responsibility of 
the Designer and will be described in the Design Guidelines and Tutorials.  
 
 
** During the addition of enhancements – the SDE will be working in several DTM files. 
Therefore it is advantageous to have a “working DTM” to input in all of the compiled 
enhanced data. The final compiled DTM data will be submitted to the Designer(s) as 
PI#_SDE.dtm file for tracking purposes. The Designer will then re-name the file to 
1234567_Exist.dtm. 
 
 
 
Depicts Surface Information. 

140.  Information Only: 
The majority of the different types of Obscured Area situations have been depicted (as 
shown in Labs 9A-9C). The Original Field Enhancement Data (1234567_XO) has been 
merged into the Mapping Project (1234567_SDE) and the DTM has been reviewed for 
errors and compressed to reduce the size of the database. 
 
Lab 17 will depict the procedures for preparing the associated DGN files for TOPO and 
UTLE files. Labs 10-15 will depict the COGO aspect of inputting in Existing 
Alignments, Existing Right of Way and Property. 
 
The 1234567_XO.fwd file is NOT to be submitted to Design. The Designer will have all 
of the information which is contained in the field book in the 1234567_SDE.dtm, the 
1234567_SDE.alg file and the associated DGN File deliverables. 
 
Information regarding upcoming Labs.   

141.  Information Only: 
 

• In a “Real World” Project -- when viewing the DTM triangles and the 
MBOUNDARY (the Topo Limit Line) at the same time – please be aware that if 
you use this combination and view the DTM as “Smooth” instead of 
“WireFrame” --- the Triangles will be intermixed with the color of white and 
green and will appear as a mottled color. 

• If you view the DTM triangles in the “Smooth” mode – it is best NOT to view the 
MBOUNDARY at the same time. This will allow the triangles to view as the 
Existing Green color. 
 
 

Information regarding the viewing of DTM Triangles. 
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142.  Save the InRoads Surface Project: 
 
 Select FileSave Surface from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Surface Project has 
already been saved initially). 
 
 The Surface Project (1234567_SDE.dtm) will be saved to Lab 9 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 9 
 
Note that the InRoads Status Bar (Located at the bottom of the InRoads Interface) will 
depict a message when the Surface Project has been saved.   
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 9   

143.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
 
Deletes the Graphics from the GDOT 3D Working File.dgn to ensure a clean DGN file 
for the next Lab. 

144.  In the [MicroStation Software] – 
Select File CompressDesign to reduce the DGN File Size. 
 
 Compresses the DGN File Size. 

145.                    
 
                 This concludes Lab 9.  Do not proceed until the Instructor directs you to do so. 
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Lab 10 
Create & Store the Existing Centerline 

(ACL) from Field Surveyed Points 
 
Objective 
 
The Existing Centerline Alignment (Feature Style PROP_E_ACL) is established by utilizing 
tangent and curve points collected from Field Survey. The degrees of curves are computed by 
using field points which are then compared to existing plans. An appropriate degree is then 
assigned to the curve. The Existing Centerline Alignment is used as the basis for setting the 
Existing Right-of-Way for the project. 
 
The objective of Lab 10 is to: 
 

• Set forth the workflow required to create and store existing roadway centerlines to GDOT 
standards from mapping and field survey information. 

 
Workflow 
 

• View the centerline Cogo points with the feature styles 
PROP_E_APOT, PROP_E_APOC, PROP_E_APC, PROP_E_APT 
and PROP_E_API. 

• Determine the tangent and curve locations and use tangent points to 
define bearings and to store PI’s of curves. 

• Store the Existing Centerline Alignments. 
• Evaluate and define curves in the alignments. 
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Lab10A Start InRoads and Set Survey Defaults 
 
In this section of the lab you will be opening the MicroStation V8i Select Series 2 GDOT-User 
Workspace and InRoads Suite V8i Select Series 2. You will also open a “Working” DGN file.  
This “Working” DGN file is used to display the temporary and/or permanent graphics in 
InRoads.  MicroStation is opened first.  InRoads is then opened from within MicroStation. 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Verify Project Defaults 
• In InRoads -- select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_SDE which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L10-1. 
• Click Apply & Close. 

 
Sets the SDE Project Defaults. This folder location will also be the default folder when 
FileSave and FileClose are used.   

 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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Figure L10-1 Set Project Defaults 

 
 
4.  Set Survey Default Preferences 

 
• In InRoads  - Select File Project Options. 
• In the Project Options dialog box select the General Tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Survey Default.  Click Load and Close. 
• In the Project Options dialog box - Click Apply and Close. 

 
Sets the Survey Defaults Preference. 

 
 

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
                                                  
 
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 10 
 
 

   
 Lab10-4   

5.  *Set InRoads “Locks”     
*It is very important to ensure that the “Locks” are set according to the steps and 
instructions for each Lab when indicated.  
 
Click ToolsLocks from the InRoads pull-down menu.   
 
Ensure that the following locks are selected/unselected as appropriate: 
 
 Feature Filter        _____ Unchecked   
 
Feature Highlight         __ Unchecked 
 
Style         ____________ Unchecked 
 
Pencil/Pen        ________ Set to Pencil 
 
Delete Ink    ________ Unchecked 
 
Locate         ___________Set to Features 
 
Point Snap        ________ Checked 
 
Element Snap        ______Unchecked 
 
Station        ___________ Unchecked 
 
Report          __________ Checked 
 
Cogo Audit Trail      ____ Unchecked 
                             
Toolbar            ________ Checked 
 
The InRoads “Locks” are set accordingly. 
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Lab10B Load Surface (.dtm) and Geometry (.alg) Files 
 
In this section of the Lab you will load the Surface file 1234567_SDE.dtm and the Geometry 
file 1234567_SDE.alg.  These files will be used to create the Existing Centerline Alignment 
(ACL). 
 
6.  Load the InRoads Surface File 

 
Select FileOpen from the InRoads Menu.   
 
The Project Defaults (which were set up in Lab 10A) are set to the following Path: 
C:\InRoads Data\1234567\SDE Labs. 
 
Browse to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab10 
Select the file named: 1234567_SDE.dtm 
 
Click Open and then click Cancel. 
 
 
The 1234567_SDE.dtm Surface file will open. 

7.  Load the InRoads Geometry File 
 
Select FileOpen from the InRoads Menu.   
 
The Project Defaults (which were set up in Lab 10A) are set to the following Path: 
C:\InRoads Data\1234567\SDE Labs. 
 
Browse to the following path:  C:\InRoads Data\1234567\SDE Labs\Lab10 
Select the file named: 1234567_SDE.alg 
 
Click Open and then click Cancel. 
 
 
The 1234567_SDE.alg Geometry file will open. 
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Lab10C View Geometry  and Surface Information 
 

In the first section of Lab 10C - you will view the alignment points collected in the field.  These 
points have Feature Styles of PROP_E_APOT, PROP_E_APOC, PROP_E_APT, 
PROP_E_APC and PROP_E_API and are contained in the 1234567_SDE.alg project. In the 
second section of Lab 10C – you will view the Existing Roadway Feature Styles contained in 
the 1234567_SDE.dtm file.  These Feature Styles will assist in the creation of the Existing 
Centerline Alignment.  

 
8.  Click on the Geometry Tab (Located at the bottom – left hand side of the InRoads 

Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the 
Geometry Tab. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Then click on the 1234567_SDE Geometry Project.  Note that the 1234567_SDE 
Geometry Project has a “Red Rectangle” around the icon. This denotes that this is the 
“Active” Geometry Project.  Any Cogo commands will be initiated and performed on the 
current “Active” Geometry. 
   
Opens the InRoads Geometry Tab and displays the 1234567_SDE Geometry information 
in the InRoads Explorer Interface. 

9.  View the Horizontal Annotation  
 
In the InRoads Software: 
 
Select GeometryView GeometryHorizontal Annotation from the InRoads Menu. 
 
The View Horizontal Annotation dialog box will open. Select the “Main” Tab.   
 
 
The View Horizontal Annotation dialog box opens. 

  

Geometry TAB Scroll Bars 
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10.  In the  View Horizontal Annotation “Main” Tab: 
 

• Click the Preferences button and highlight NO BEARING & DISTANCE. 
• Click Load & Close. 
• The inputs should now correspond to the screen capture depicted in   

Figure L10-2 (as shown below).  Verify to ensure that your input matches the 
screen capture.    

 
Sets the Viewing Options for the View Horizontal Annotation dialog box.   

 
 

                                
Figure L10-2 View Horizontal Annotation 

 
 

11.  The Filter button on the dialog box will be grayed out. Place the cursor in the Cogo 
Points Include: field to activate the Filter button.  (See Screen Capture depicted above). 
 
Click the Filter button to open the Geometry Selection Filter dialog box. See Figure 
L10-3 (as shown below).   
 
Activates the Filter button and opens the Geometry Selection Filter dialog box. 

Click here to activate 
Filter button. 
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Figure L10-3 Geometry Selection Filter 

 
12.  The Geometry Selection Filter will be utilized to view the Alignment Feature Styles of 

PROP_E_APOT, PROP_E_APOC, PROP_E_APT, PROP_E_APC and 
PROP_E_API. 
 

• In the Style: pull-down – Select Included 
• Click the Preferences button and highlight the ACL Cogo Point Feature Styles 

Preference. 
• Click Load & Close.  This loads the Feature Styles of 

PROP_E_APOT, PROP_E_APOC, PROP_E_APT, PROP_E_APC and 
PROP_E_API into the Style text entry field. 

• Verify to ensure that your input matches the screen capture depicted in Figure 
L10-4. 

 
Selects the Feature Styles in the Geometry Selection Filter. 

 

 
Figure L10-4 Geometry Selection Filter 
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13.  Once the data has been filtered – it needs to be moved from the Available: field to the 
Selected: field.   
 

• Click the ALL button. The data will be moved and then displayed in the 
Selected: field. 

 
The inputs should now correspond to the screen capture depicted in  
Figure L10-5 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
The filtered data is moved from the Available field to the Selected field. 

 

 
Figure L10-5 Geometry Selection Filter 

 
 

14.  Click OK to close out of the Geometry Selection Filter dialog box and load data into 
the View Horizontal Annotation field.    
 
Closes the Geometry Selection Filter dialog box.   

15.  View Filtered Points 
 
The Alignment Feature Style points have been filtered and are available for viewing.   
The View Horizontal Annotation dialog box should still be active from the previous 
steps.  This dialog box depicts the filtered points in the Cogo Points Area as Selected: 
points. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L10-6 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
The filtered point data is available for viewing. 
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Figure L10-6 View Horizontal Annotation 

 
16.  Click Apply and then click Close to close out of the View Horizontal Annotation 

dialog box. 
 
The View Horizontal Annotation dialog box closes and the filtered Points are viewed in 
MicroStation. 

17.  View the selected Points in the [MicroStation Software] by using the following 
command located under the MicroStation View 1 Window. In the [MicroStation 
Software] – 
 

• Select the “Fit View” Icon to view the Points. 
 

              
 
 
 
           Verify that the MicroStation view window matches that shown in Figure L10-7. 
 
The points are displayed and the view is fit to the MicroStation screen. 

Fit View Button 
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Figure L10-7 MicroStation View depicting PROP_E_APOT, 
PROP_E_APOC, PROP_E_APT, PROP_E_APC and PROP_E_API Points. 

 
18.  In screen capture L10-7 (depicted above) - the locations of the different alignments can 

be determined from the Cogo points.  In order to assist in identifying the alignments -- 
the following Surface Feature data --- such as edge of pavements and other similar 
identifying features will be viewed.  
 

• Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the 
Surfaces Tab. 

 
 
 
 
 
 
 
 
 

• Next click on the 1234567_SDE Surface Project.  Note that the 1234567_SDE 
Surface Project has a “Red Rectangle” around the icon. This denotes that this is 
the “Active” Surface Project.  Any surface commands will be initiated and 
performed on the current “Active” Surface. 

   
Opens the InRoads Surfaces Tab and displays the 1234567_SDE Surface information in 
the InRoads Explorer Interface. 

Surfaces TAB Scroll Bars 
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19.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Feature Filter 
Lock is turned ON.  There should be a check mark          next to the Feature Filter 
Lock. 
 
This is an important step! This Lock must be turned ON in order to view the Features. 
 
Ensures that the Feature Filter Lock is turned ON. 

20.  Click Tools ►Locks from the InRoads pull-down menu.  Ensure that the Feature 
Highlight lock is turned OFF.  There should not be a check mark next to the Feature 
Highlight Lock.  When this lock is turned off … The viewing of features is much faster. 
 
 
 
Ensures that the Feature Highlight Lock is turned off. 

21.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Report Lock is 
turned ON.  There should be a check mark         next to the Report Lock. 
 
Ensures that the Report Lock is turned ON. 

22.  Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Style Lock is 
turned off.  There should not be a check mark next to the Style Lock. 
 
Ensures that the Style Lock is turned off. 

23.  View the Surface Features:  
 
In the InRoads Software: 
 
Select SurfaceView SurfaceFeatures and the View Features dialog box will 
appear: 
 

• In the Surface: Pulldown – select 1234567_SDE 
 
 Click on the Filter button. 
 
 
 
 
 
 
Opens the View Features dialog box. 

24.  View the selected Features: 
 
The Feature Selection Filter dialog box will open. In the Feature Selection Filter 
dialog box --- input the following: 
 

• In the Filter Name: pulldown – select EXIST_RDWY- ACL+ EOP +RR 
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This will filter the view to include the following Surface Feature codes:  
 
         TOPO_E_TAC              TOPO_E_TEST               TOPO_E_ TBCL 
         TOPO_E_TEDR            TOPO_E_THC                TOPO_E_ TRCL 
         TOPO_E_TEAD            TOPO_E_TCGT             TOPO_E_ TRCRE 
         TOPO_E_TECD            TOPO_E_TCGF              TOPO_E_ TEDD 
         TOPO_E_TEAP            TOPO_E_TVG                 TOPO_E_ TDR 
         TOPO_E_TEAS            TOPO_E_TBAS               TOPO_E_ TDD 
         TOPO_E_TECP            TOPO_E_ TBGL              TOPO_E_ TRCR 
                                                                                          TOPO_E_ TETL 
Leave all other entries as default! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L10-8 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Feature Selection Filter dialog box. 

 

                                          
Figure L10-8 Feature Selection Filter 

 
25.  Click OK and the Feature Selection Filter dialog box will Close.  The View Features 

dialog box should still be open from the previous steps. 
 
The inputs in the View Features dialog box should now correspond to the screen capture 
depicted in Figure L10-9 (as shown below).   
 
Closes the Feature Selection Filter dialog box. 

Use the pull-down 
arrow  to select the 
Filter named 
EXIST_RDWY- ACL 
+ EOP + RR 

When the filter name is 
selected the data will be 
filtered as depicted here. 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 10 
 
 

   
 Lab10-14   

 

                                    
Figure L10-9 View Features 

 
26.  Click Apply and then click Close and the View Features dialog box will close.  

 
Closes the View Features dialog box. 

27.  View the selected Surface Features in the [MicroStation Software] by using the following 
command located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Fit View” Icon to view the Surface Features. 
 

                  
            
 
 
 
 
 
Verify that the MicroStation view window matches that shown in Figure L10-10. 
 
The Surface Features are displayed and the view is fit to the MicroStation screen. 

 
 
 
 
 
 

Ensure that the Features you 
wish to view are highlighted 
in blue.  Features can be 
highlighted by selecting them 
with the mouse and a 
combination of the Ctrl key 
or Shift key on the keyboard. 

Fit View 
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Figure L10-10 MicroStation View depicting the Surface Features 

 
 
28.  The Horizontal Alignment which will be created and stored is the US 78 Alignment. The 

alignment location is depicted and labeled in Figure L10-11 (as shown below).  
 
View the US 78 Alignment area in the [MicroStation Software] by using the following 
commands located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Zoom In or Zoom Out” Icons as appropriate to zoom closer to the US 78 
Alignment. 
 

                    
 
 
 
 
 
            
 
Verify that the MicroStation view window matches that shown in Figure L10-11. 
 
View the area depicting the US 78 Alignment points and features. 

Zoom In or Out 
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Figure L10-11 MicroStation View Window 

 
 
29.  Window into the area depicted by the “rectangle” as shown above in Figure L10-11.   

 
In the [MicroStation Software] – Select the “Window Area” Icon. 
 
  

                
 
 
            
 
 
NOTE: 
If this Icon is not depicted in your MicroStation window – perform the following step: 
(Right click on any of the icons depicted in the screen capture above – a list box will then 
appear. Ensure a check mark is placed next to the Window Area option). 
 
After windowing in and zooming into this area – your MicroStation view should appear 
similar to that depicted in Figure L10-12 (as shown below). 
 
Zoom into the area depicted by the rectangle. 

Window Area Icon 

Window Area here 

US 78 
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Figure L10-12 MicroStation View Window 

 
 
30.  Pan along US 78 to review the PROP_E_APOT and PROP_E_APOC points 217, 244, 

286, 287, 295, 299, 300, 301, & 302 and also edge of pavements.  These are the 
centerline points that were field surveyed to assist in storing the US 78 Alignment.   
 

* Hint: Remember from previous MicroStation Training that in order to “pan” a 
view -- use a combination of the shift key on the keyboard and the left mouse key. 

 
When you have completed reviewing the above listed points – return to the view shown 
in Figure L10-12 (as depicted above). 
 
Pan to view the US 78 Alignment points and features. 
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Lab10D Store the Existing Centerline Alignment 
 

The following Lab (Lab 10D) depicts the steps to store an Existing Centerline Alignment with a 
Feature Style of PROP_E_ACL. Point numbers 217 and 287 will be used to determine the back 
tangent and points 301 and 302 will be used to determine the ahead tangent. These tangents will 
be intersected in order to store a PI and a 01°00’00” degree curve. See Figure L10-13 shown 
below.   
 

 
Figure L10-13 MicroStation View Window (Back and Ahead Tangents) 

 
 
 
31.  Verify that the Locate Features Lock & Point Snap Lock are set before continuing.  

These two settings must be set correctly in order to use the Locate Button. 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Point Snap 
Lock has a check mark          next to it. 
 
Click ToolsLocks from the InRoads pull-down menu.  Ensure that the Locate Lock 
depicts a Green Symbol next to it. 

                           The Locate Lock should have this green symbol next to it              
which indicates it is set to Features rather than Graphics. 

 
Turns on the Point Snap Lock & Locate Features Lock. 

217 to 287  
(Used for Back 
Tangent) 

PT 287 

PT 301 

PT 302 

PT 217 

301 to 302  
(Used for 
Ahead Tangent) 
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32.  Store the PI of the curve.  Points 217 and 287 will be used to determine the direction of 
the back tangent and points 302 and 301 will be used to determine the direction of the 
ahead tangent.  The intersection of these two tangents will result in the location of the PI. 
 
Select Geometry►Locate►Intersection.  The Intersection dialog box opens. 
 

                                
 

Opens the Intersection dialog box. 
33.  In the Intersection dialog box - use the Locate buttons as shown in Figure L10-14 

(depicted below) to select the points in MicroStation and define the tangent directions. 
 
For the Type: - select Direction/Direction  
 

* HINT: When you click the Locate buttons, look in the lower left corner of the 
MicroStation window for prompts.  MicroStation will prompt you to pick a point. 
When you select a point, the MicroStation Status bar informs you which point 
you have picked and prompts you to accept it.  To accept, click in a blank portion 
of the MicroStation window. 
 

The inputs should correspond to the screen capture depicted in Figure L10-14 (as shown 
below).  Verify to ensure that your input matches the screen capture.    

 
 Sets the inputs in the Intersection dialog box. 
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Locate Button to select point 217. 
*HINT: When you click point 217 in 
MicroStation you will see a purple X.                                                                                                                                                                
                                                                                   

Locate Button to select point 302. 
                                                                                   

Locate Button to define direction 
from point 302 to point 301. 
                                                                                   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure L10-14 Intersection dialog box 
 
 
 
 
 
 
34.  Click Apply - in the Intersection dialog box.   

 
The Locate Results dialog box will then appear. See Figure L10-15 as shown below.  
 
NOTE: (Also – in MicroStation - the two tangent bearings are tentatively extended to 
the PI and highlighted in a purple color as shown in Figure L10-16).  Take a moment to 
pan up and down US 78 to review the tentative location of the PI. 
 
In the Locate Results dialog box – enter the following: 
 

• In the Style: Pulldown – select PROP_E_API 
 
Leave all other entries as Default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L10-15 (as shown below).  Verify to ensure that your input matches the screen 
capture. 
 
Opens the Locate Results dialog box. 

Locate Button to define direction 
from 217 to 287.   
*HINT: When you click the first point 
217, you will notice no purple X as 
before.  When you move your mouse 
near a point you will see a direction 
line snap to the nearest point.  Pan to 
287 and click it when the direction 
line snaps to it. 
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Figure L10-15 Locate Results dialog box 

 
 
      

 
Figure L10-16 MicroStation View Window (PI Location) 

 

The tangents are 
tentatively shown in 
purple and extended to the 
PI. 
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35.  Click Accept - in the Locate Results dialog box.  
 
If the Report Lock is turned on, a “Results Report” will appear depicting the 
coordinates of the PI intersection: 
 

 
 

 
Click Close to close out of the Results Report dialog box. 
Click Close to close out of the Intersection dialog box. 
 
 The PI has been stored as a Cogo point and given the Point Number of 1 as shown in 
Figure L10-17. 
 
     *Note: No point prefixes shall be used by the surveyor/SDE when storing points and 
the surveyor/SDE shall work in the point range of 1-9999.  This is to eliminate problems 
with enhancements during the life of the project.  If points beyond 9999 are needed the 
SDE shall contact the designer and request a range of points be set aside for the SDE to 
work in that the designer will not use.  This is for the same reason as stated earlier. 
 
Stores the point at the PI of the tangents and closes the Intersection dialog box. 
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Figure L10-17 MicroStation View Window (Stored PI Point 1) 

 
 

36.  Create a Horizontal Alignment and name it SV4 and give it the description  
EXIST C/L US 78. 
 
Create the SV4 Horizontal Alignment by selecting FileNew from the InRoads Menu.  
The New dialog box will open.  Select the Geometry Tab. 
 

• In the Type: Pulldown – select Horizontal Alignment 
• In the Name: Field – enter SV4 

*Note:  Surveyors/SDE’s are instructed to use the prefix SV for all alignments 
including roadway, property, etc.  InRoads is case sensitive.  Use only CAPITAL 
letters.  InRoads accepts either lower or uppercase letters.  ‘SV4’ would be a 
completely different alignment than ‘sv4’.  Failure to use the proper prefix will 
result in survey enhancement delivery problems to the designer. Please keep this 
in mind as you store alignments. 

• In the Description: Field – enter EXIST C/L US 78 
• In the Style: Field – enter PROP_E_ACL 
• In the Curve Definition: Pulldown – select Arc 

 
The inputs should now correspond to the screen capture depicted in  
Figure L10-18 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the New dialog box allowing you to create an empty Horizontal Alignment. 

The PI is stored and given 
Point Number 1. 
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Figure L10-18 “New” Horizontal Alignment 

 
37.  Click Apply and then click Close to create the Horizontal Alignment.   

 
 
An Empty Horizontal Alignment named SV4 is created.   

38.  At this point you have an empty alignment named SV4 (this is the current Active 
Alignment).  The next step is to add points to alignment SV4.  The beginning point will 
be 217, the PI will be 1 (the same PI that was stored in the previous steps), and the 
ending point will be 302. 
 
Select Geometry►Utilities►Create/Edit Alignment by Cogo Points and the 
Create/Edit Alignment by Cogo Points dialog box will open. 
 
Ensure that the following information is depicted in the dialog box: 
 

• Name: = SV4 
• Description:  = EXIST C/L US 78 
• Style:  = PROP_E_ACL 
•  

In the Alignment Definition: field ---- key-in the following points: 217 1 302 
(Theses points should be entered and separated by spaces) 
 
The inputs should now correspond to the screen capture depicted in  
Figure L10-19 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Create/Edit Alignment by Cogo Points dialog box. 

** WARNING** 
Select the Type first as 
it will clear the 
remaining fields once 
it is selected. 
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Figure L10-19 Create/Edit Alignment by Cogo Points 

 
39.   Click Apply and then click Close to close out of the dialog box. 

 
Points are added to Horizontal Alignment SV4. 

40.  For Information Only - 
(An alternative method for selecting the points to include in the Alignment). 
 
Note:  
The points 217, 1 and 302 may also be selected with the mouse by clicking the Start 
button (see Figure L10-19 above) and clicking the points in MicroStation.  When you 
click a point in MicroStation, the point you select is shown in the lower left corner of the 
InRoads Status Bar (as shown in Figure L10-20 depicted below).  If this is the correct 
point, you may move on to the next point to select.  If an incorrect point is selected, then 
you may right mouse click to select the next closest point.  When you have selected all 
the points - click the Stop button and you will be returned to the Create/Edit Alignment 
by Cogo Points dialog box. The points will be entered in the Alignment Definition: 
Field. 
  
 Alternative method of adding Points to Alignment SV4. 
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Figure L10-20 InRoads Status Bar 

 
 

41.  For Information Only –  
Currently you have a Horizontal Alignment named SV4 which contains a beginning 
point (217), a PI point (1) and an ending point (302). The next step is to add a curve to 
the alignment. In InRoads - the concept of storing a curve and adding it to an alignment 
consists of the following steps: 
 

• Create an Empty Alignment 
• Add points and PI’s to the Alignment 
• Define the Curve information for the PI’s 
• Store the Curve 

 
Information for adding a curve to an alignment 

42.  In the following steps - a 01°00’00” degree curve will be defined for the PI of point 1 in 
Horizontal Alignment SV4. 
 
Select Geometry►Horizontal Curve Set►Define Curve… 
and the Define Horizontal Curve Set dialog box will open. 
 

• In the Point Name: field – enter a 1 
 
     *IMPORTANT: In most situations it is best to use the ‘Next’ and ‘Previous’ 

buttons located at the bottom of the Define Horizontal Curve Set 
dialog to identify the PI and ensure the ahead and back tangents are 
highlighted in MicroStation. 

 
Leave all entries as Default at this time! 
 
The current inputs should correspond to the screen capture depicted in  
Figure L10-21 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Define Horizontal Curve Set dialog box. 

 
 

The selected points are shown in the 
lower left corner of the InRoads window.  
At this time - the selected point is 
tentative and you may right mouse click 
to select a different point that may be in 
the immediate vicinity. 
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Figure L10-21 Define Horizontal Curve Set 

 
 

43.  Point 1 is the PI in the current SV4 Active Alignment. (See Figure L10-21 depicted 
above). 
 
 
In order to define the curve – Click the Curve Calc… button  
This will open the Curve Calculator dialog box. 
 
 
 
 
 
 
 
Opens the Curve Calculator dialog box. 
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44.  In order to calculate a curve in InRoads - two known curve parameters are required. 
 
To define the curve - input the Deflection Angle and the Degree of Curve.   
 
Ensure that a Check Mark      and data is placed as inputs into the entry fields shown 
below:  
 

•     DOC: = 01 00 00.0    
•     Angle  = 09 56 19.3 

 
Ensure that the Compute: Pull-down is set to Simple Curve 
Leave all other fields as default. 
 
Click the Compute button.  
 
(InRoads will automatically compute the remaining curve data). 
 
The current inputs should correspond to the screen capture depicted in  
Figure L10-22 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets the entries in the Curve Calculator dialog box. 

 
 
 

   
Figure L10-22 Curve Calculator 
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45.   Click OK to accept the entries and to close out of the Curve Calculator dialog box. 
 
 
Accepts the entries in the Curve Calculator dialog box. 

46.   Click Apply and Close to close out of the Define Horizontal Curve Set dialog box.  
 
Horizontal Alignment SV4 now contains a 01°00’00” degree curve and should appear as 
depicted in Figure L10-23. 
 
Stores the curve for Alignment SV4 and closes out of the Define Horizontal Curve Set 
dialog box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure L10-23 MicroStation Window depicting Curve 
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47.   The next step is to review Horizontal Alignment SV4.  
 
Click on the Geometry Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the 
Geometry Tab (see screen capture shown below - left).  
 
Then double click on the Geometry Project named 1234567_SDE (ONLY if it is not 
already open in InRoads Explorer).  This will allow you to view all of the project data 
(see screen capture shown below - right). 
 
 

                
 
 
 
 
 
In the InRoads Explorer Interface -- Right mouse click on alignment SV4. 
In the list that appears – select Review.  
 
Take a moment to review alignment SV4 in the Review Horizontal Alignment window 
as depicted below in Figure L10-24. 
 
 
   
Opens the Review Horizontal Alignment window.    

 
 
 
 
 
 
 
 
 
 
 
 

Geometry TAB Scroll Bars 

InRoads Explorer 
Window 

1234567_SDE 
Geometry File 

Alignment SV4 with red 
square indicating it is the 
active alignment. 
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Figure L10-24 Review Horizontal Alignment window. 

 
 

48.  During the review - notice that the PC, PT, and CC do NOT have point numbers 
associated with them at this time.   
 

***IMPORTANT DISCUSSION*** 
It is very important at this time to discuss some differences between InRoads and what 
you are familiar with in CAiCE.  InRoads has different kinds of points.  Alignment points 
and COGO points are two types of points to be aware of when working with alignments-
-- (whether it is a centerline alignment, a R/W alignment or a property alignment).   
Alignment points are nothing more than names assigned to coordinates in an alignment 
and do not exist in the COGO points buffer.  In order to satisfy GDOT plan presentation 
requirements and prepare R/W tables and properly deliver enhanced survey data to the 
designer -- Surveyors and Designers alike must ensure that all alignments have a 
corresponding COGO point stored.  At some point this may cause you problems as you 
branch out and experiment with other InRoads commands because not all InRoads 
commands store COGO points.  Some only assign Alignment Point names and must be 
converted to COGO points. Some don’t assign alignment point names or store COGO 
points and must be assigned Alignment point names and then be converted to COGO 
points. As such we recommend that you adhere closely to the methods presented in the 
tutorials concerning centerlines, R/W and property. 

 
Click Close to close the Review Horizontal Alignment window. 
 
Review Alignment SV4.    
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49.  As noted during the review of Horizontal Alignment SV4 – the PC, PT and CC do NOT 
have point numbers associated with them.  The next steps depict the process to assign 
names to the unnamed points in Horizontal Alignment SV4. 
 
Click Geometry►Utilities►Assign Names and the Assign Names dialog box will 
appear. 
 
Ensure that the following information is depicted in the dialog box: 
 

• In the Include: option  - select         Alignments 
• In the Name: field – type SV4 
• Place a  Check Mark         by On-Alignment Points   
• Place a  Check Mark         by Off-Alignment Points   
• In the Method: option – select         Assign 
• Leave the Seed Name: field ________  ( leave blank – see example below)  

 
 

• Place a  Check Mark         by Check for Coincident Points   
 
Leave all other entries as default. 
 
Then Left Click in the Selected Field (so that this field will be populated with 
the Alignment entry). 

 
The inputs should now correspond to the screen capture depicted in  
Figure L10-25 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 

 
 

 
 
 
    

Figure L10-25 Assign Names   
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50.   Click Apply and then click Close to close out of the dialog box.   
 
Assigns names to points in Alignment SV4 and closes the Assign Names dialog box. 

51.  Review Horizontal Alignment SV4 a second time.  
 
Since SV4 is currently the only alignment in the 1234567_SDE project – it should 
already be active (as depicted by the red rectangle).  
 
Double click on the Geometry Project named 1234567_SDE (ONLY if it is not already 
open in InRoads Explorer).  This will allow you to view all of the project data (see 
screen capture shown below - right). 
 

                      
 
 
 
 
 
 
In the InRoads Explorer Interface -- Right mouse click on alignment SV4. 
In the list that appears – select Review.  
 
Take a moment to review alignment SV4 in the Review Horizontal Alignment window 
as depicted below in Figure L10-26. 
 
Notice that the PC and PT now have point numbers associated with the point 
coordinates. 
  
Please Note: 
The PI coordinate will not have a point name associated with it.   
   
Opens the Review Horizontal Alignment window.    

 
 
 
 
 
 

Geometry TAB Scroll Bars 

Alignment SV4 
with red rectangle 
indicating it is the 
active alignment. 
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Figure L10-26 Review Horizontal Alignment  

 
 

52.  Click Close to close the Review Horizontal Alignment window. 
 
Closes the Review Horizontal Alignment. 

53.  Although alignment SV4 now has point numbers associated with the coordinates as 
shown in the report in Figure L10-26 the points don’t exist as COGO points in the 
COGO buffer.  These alignment points must now be converted to COGO points. 
 
Select Geometry►Horizontal Curve Set►Events 
In the Horizontal Events dialog: 
 

• Check the Alignment Point to Cogo radio button. 
• Set the style to PROP_E_ACL-PC-PT 

 
Leave all other entries as default. 
 
 
The inputs should now correspond to the screen capture depicted in  
Figure L10-27 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Horizontal Events dialog. 
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Figure L10-27 Horizontal Events Dialog 

 
 
 
 
54.  • Click Apply.  A results report opens showing all points that are now COGO 

points. 
 

• Click Close to close the results box. 
 

• Click Close to close the Horizontal Events Dialog.   
 
 
 
* Note:  Cogo Points are only assigned to Alignment Points for the active alignment.  
The process must be repeated for each alignment. 
 
 
 
 
 
Converts the Alignment points stored earlier to COGO points. 
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55.  Save the InRoads Geometry File 
 
Even though the SV4 Horizontal Alignment has been stored – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. Whenever a change has been made to an InRoads Geometry Project – Save the 
project and its associated modifications or changes. 
 
Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
The Geometry Project (1234567_SDE.alg) will be saved to Lab 10 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab10 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab10  

56.  Important Step:  In order to Start with a CLEAN DGN file for the next Lab (Lab 11): 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
  
 
Deletes the Graphics from the GDOT 3D Working File.dgn to ensure a clean DGN file 
for the next Lab. 

57.                    
                 This concludes Lab 10.  Do not proceed until the Instructor directs you to do  
                  so. 
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Lab 11 
Modifying Centerline Alignments 

 
Objective 
 
Establishing the Existing Centerline Alignment requires editing the curve data, stationing and 
extending the tangent sections in order to match the conditions on the ground. 
 
The objective of Lab 11 is to: 
 

• Learn techniques to extend alignments and change curve data in alignments as well as 
station the alignment.   
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Lab 11A Getting Started 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Load the InRoads Geometry File (1234567_SDE.alg) 
 
Select FileOpen from the InRoads Menu.   
 
Browse to the following path:   
C:\InRoads Data\1234567\SDE Labs\Lab11 
 
Select the file named: 1234567_SDE.alg 
 
Click Open and then click Cancel. 
 
 
 
The 1234567_SDE.alg Geometry file will open. 

Hint:  You may also right 
mouse click over 
‘Geometry Projects’ in the 
Workspace Bar and select 
open. 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Load the InRoads Surface File (1234567_SDE.dtm) 
 
Select FileOpen from the InRoads Menu.   
 
Browse to the following path:   
C:\InRoads Data\1234567\SDE Labs\Lab11 
 
Select the file named: 1234567_SDE.dtm 
 
Click Open and then click Cancel. 
 
The 1234567_SDE.dtm Surface file will open. 

5.  View all Horizontal Alignments 
 
In the [InRoads Software]: 
 

• In the Workspace Bar area - ensure that Geometry is the active tab. 
• Right mouse click over the project 1234567_SDE. 
• A pop-up menu appears. In this menu - Select View All Horizontals. 

 
 
 
 
 
 
 
 
 
 
 
 
 
In the [MicroStation Software]: 
 

• Select the “Fit View” Icon to view the Horizontal Alignments. 
 
 

 
 
 
             

                             
 

• Verify that the MicroStation view window matches that shown in Figure L11-1. 
 

Views all Horizontal Alignments in the Geometry Project 1234567_SDE. 

Geometry TAB 

Fit View 

Hint:  You may also right 
mouse click over ‘Surfaces’ 
in the Workspace Bar and 
select open. 

View All Horizontals 
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Figure L11-1 MicroStation Window 

 
 
6.  Window Area to the intersection of Alignments SV4 & SV6 

 
• In MicroStation select the Window Area button. 

 
 

 
 
 
 
 
 
                               

• Window Area the intersection of SV4 & SV6 as shown below in Figure L11-2. 
• Notice that SV6 does not extend to SV4 as shown below in Figure L11-3. 
 

Zooms into the intersection of alignment SV4 & SV6. 
 

SV6 

SV4 

Window 
Area Button 
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Figure L11-2 MicroStation Window 

 
 
 

 

                     
Figure L11-3 MicroStation Window (Intersection View) 

 
 
 
 
 
 
 
 
 
 
 
 
 

Window Area Here 

SV4 

SV6 

SV4 

SV6 
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Lab 11B Extend Alignment  to Intersection 
 
In the previous Lab, the Horizontal Alignments of SV6 and SV4 were viewed. These alignments 
did not actually intersect. In this lab we will extend alignment SV6 to intersect with alignment 
SV4. 

 
7.  Set Alignment SV6 to be the Active Alignment. 

 
• In the InRoads Workspace Bar (shown on the 

right) expand the project by double-clicking on 
1234567_SDE as shown. 

• Ensure that SV6 has a Red Box around it. This 
indicates that alignment SV6 is the active 
alignment. 

• If it does not have a Red Box - highlight 
alignment SV6, right mouse click over it and 
select Set Active. 

 
Sets alignment SV6 as the active alignment. 

8.  Extend Alignment SV6 to SV4. 
 

• Select Geometry ► Utilities ► Extend Alignment 
• Notice in the bottom left corner of the MicroStation Window the message that 

says    ‘> Identify alignment to extend to’ as shown here: 
 

 
 

• Left Click on alignment SV4. (Alignment SV4 highlights in purple). 
• Notice in the bottom left corner of the MicroStation Window the message that 

says ‘> Identify alignment to extend’ as shown here: 
 

 
 

• Left Click on alignment SV6. (Alignment SV6 extends tentatively to SV4). 
• Notice in the bottom left corner of the MicroStation Window the message that 

says ‘> Accept/Reject’ as shown here. 
 

 
 

• Left Click somewhere in the MicroStation Window to accept the action. (To 
reject the action, Right Mouse click). 

• Verify that your MicroStation window matches that shown in Figure L11-4. 
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Figure L11-4 MicroStation Window 

 
 
 
 
 
 
 
 
 
9.  Review Alignment SV6  

 
• In the InRoads Explorer Workspace Bar -- Right mouse click on Alignment SV6. 

 
 
 
 
 
 
 
 
 
 
 

 
• Click Review. (The Review Horizontal Alignment report window opens). 

 
Opens the Review Horizontal Alignment report window.      

Right Mouse click on 
Alignment SV6 in the 
InRoads Explorer 
Workspace Bar.   

SV4 

SV6 
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10.  For Information Only: 
 
Notice that several PC’s and PT’s have no number associated with them as shown here. 
 

 
 

• Click Close to close the report window. 
 
The Report Window for SV6 is closed. 

11.  Assign names to the PC’s and PT’s 
 
Click Geometry ►Utilities ► Assign Names and the Assign Names dialog box will 
appear. 
 

• Fill in the Assign Names dialog box as depicted here.  
• Ensure that your dialog box entries correspond to the entries shown below. 

 

                
 
 
 

• Click Apply and Close. 
 

Assigns names to unnamed points in alignment SV6. 

Key-in SV6 here and 
then left click in the 
‘Selected:’ field for SV6 
to be populated as 
shown.  
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12.  Review Alignment SV6 
 

• In the InRoads Explorer Workspace Bar– Right mouse click on Alignment SV6. 
 

 
 
 
 
 
 
 
 
 

 
 
 
 

• Click Review. (The Review Horizontal Alignment report window opens). 
• Notice that the PC’s and PT’s now have numbers associated with them as shown 

here. 
 
 

 
 
 

• Click Close to close the report window. 
 
 
A report window for SV6 is opened. 

13.  Information Only: 
 
 
* IMPORTANT: Although point names (Alignment Points) now exist in alignment SV6 
for the PC’s and PT’s -- the points don’t actually exist as COGO Points in the COGO 
Buffer.  In order to properly display the points in MicroStation and for the proper 
delivery of enhancements during the life of the project -- the points must be converted to 
COGO Points and assigned the proper feature style. 
 
 
Information regarding the converting of Alignment Points. 

Right mouse click on 
Alignment SV6 in the 
InRoads Explorer 
Workspace Bar.   
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14.  Create COGO Points for all Alignment Points. 
 
Select Geometry ► Horizontal Curve Set ► Events… and the Horizontal Events 
dialog box will appear. 
 
In the Horizontal Events dialog box: 
 
In the Add As Section: 
 

o Check the Alignment Point to Cogo radio button. 
o Set the Style to PROP_E_ACL-PC-PT 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L11-5 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Horizontal Events dialog. 

 

                          
Figure L11-5  Horizontal Events 
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15.  Horizontal Events: 
 

• Click Apply.  A results report will open listing all points that are now COGO 
points. 

• Click Close to close the Results Box. 
• Click Close to close the Horizontal Events dialog.   

 
* Note:  Cogo Points are only assigned to Alignment Points for the Active 
Alignment.  The process must be repeated for each alignment. 

 
Converts the Alignment points stored earlier to COGO points and Assigns the Feature 
Style PROP_E_ACL-PC-PT 

16.  Review the COGO Buffer for the newly created COGO Points. 
 

• In order to review the alignment-- Right Click in the Workspace Bar over the 
SV6 alignment and select Review. The Review Horizontal Alignment report 
will open. 

• In the InRoads Explorer Interface Workspace Bar -- Left Click on the Cogo 
Buffer (Highlighted in Blue below). 
 

 
 
 
 

• In the InRoads Explorer Interface Feedback Pane use the scroll bar to look for all 
the points in the SV6 alignment.   

• Verify that the proper Feature Style has been applied.  In this exercise 
PROP_E_ACL-PC-PT was used. 

• Click Close to close out of the Review Horizontal Alignment report window. 
 

 
Review of Cogo Buffer. 

Workspace Bar 

Feedback Pane 
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Lab 11C  Re-Station Alignment 
 
In this lab we will re-station Alignment SV6 to begin at Station 10+00.00 instead of 0+00.00. 
 
17.  Open the Stationing dialog box. 

 
• Set alignment SV6 to be the active alignment if it is not already the active 

alignment. (The active alignment will have a red box around it). 
• Select Geometry ►Horizontal Curve Sets ►Stationing 
• The Stationing dialog box opens with the settings depicted as shown in Figure 

L11-6. 
 
Opens the Stationing dialog box   

 

 
Figure L11-6 Stationing Dialog Box 

 
 

18.  Re-Station Alignment SV6 to begin at Station 10+00.00 
 

• In the Stationing dialog box, key-in 10+00.00 in the Starting Station field. 
• Leave all other entries as default. 
• Verify all entries match those shown in Figure L11-7.  

 
Re-Station Alignment SV6. 
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Figure L11-7 Stationing Dialog Box 

 
19.  Click Apply and then click Close. 

 
Alignment SV6 is Re-stationed. 

20.     Review Alignment SV6  
 

• Select Geometry ►Review Horizontal 
• The Review Horizontal Alignment report window opens. 
• Verify that the beginning station is now 10+00.00. 
• Click Close to close out of the Review Horizontal Alignment report window. 

 
Alignment SV6 is Re-Stationed. 
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Lab 11D Edit  Curve Data 
 

In this lab we will edit the Curve in Alignment SV4 from 1○15’00” to 1○00’00” 
 

21.  Set Alignment SV4 to be the Active Alignment. 
 
 

• In the InRoads Workspace Bar (shown on the 
right) expand the project by double-clicking on 
1234567_SDE as shown. 

• Ensure that SV4 has a Red Box around it. This 
indicates that alignment SV4 is the active 
alignment. 

• If it does not have a Red Box - highlight 
alignment SV4, right mouse click over it and 
select Set Active.  

 
Sets alignment SV4 as the active alignment. 

22.  Open the Define Horizontal Curve Set dialog box. 
 

• Select Geometry ► Horizontal Curve Set ► Define Curve 
• The Define Horizontal Curve Set dialog box opens as shown in Figure L11-8. 

 
Opens the Define Horizontal Curve Set dialog box. 
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Figure L11-8 Define Horizontal Curve Set Dialog Box 

 
23.  Use the Curve Calculator to Enter & Compute all information required for a 1 

degree curve. 
 
 
In order to define the curve – Click the Curve Calc… button  
This will open the Curve Calculator dialog box. 
 
 
 
 
 
 
 
Opens the Curve Calculator dialog box. 
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24.  To define the curve - input the Deflection Angle and the Degree of Curve.   
 
Ensure that a Check Mark      and data is placed as inputs into the entry fields shown 
below:  
 

•     DOC: = 01 00 00.0    
•     Angle  = 09 56 19.1 

 
Ensure that the Compute: Pull-down is set to Simple Curve 
Leave all other fields as default. 
 
Click the Compute button.  
 
The current inputs should correspond to the screen capture depicted in  
Figure L11-9 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Sets the entries in the Curve Calculator dialog box. 

 
 

 
Figure L11-9 Curve Calculator 
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25.   Click OK to accept the entries and to close out of the Curve Calculator dialog box. 
 
 
Accepts the entries in the Curve Calculator dialog box. 

26.  Click Apply and Close to close out of the Define Horizontal Curve Set dialog box.  
 
Horizontal Alignment SV4 now contains a 01°00’00” degree curve. 
 
The Curve will be changed from 1○15’00” to 1○00’00”. 

27.  Review Alignment SV4 and Assign Point Names. 
 

• Right Mouse click over alignment SV4 in the InRoads Explorer interface and 
select Review. 

• Verify that the Curve in SV4 is 1○00’00”. 
• Notice also that there are now no point names associated with the PC & PT. 
• Click Close to close out of the Review Horizontal Alignment report window. 

 
Alignment SV4 is reviewed. 

28.  Assign names to the PC’s and PT’s 
 
Click Geometry ►Utilities ► Assign Names and the Assign Names dialog box will 
appear. 
 

• Fill in the Assign Names dialog box as depicted here.  
• Ensure that your dialog box entries correspond to the entries shown below. 

 

               
 

• Click Apply and Close. 
 

Assigns names to unnamed points in alignment SV4. 

Key-in SV4 here and 
then left click in the 
‘Selected:’ field for SV4 
to be populated as 
shown.  
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29.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: As stated previously, although point names (Alignment Points) now 
exist for the PC’s and PT’s in alignment SV4 - the points don’t actually exist as COGO 
Points in the COGO Buffer.  In order to properly display the points in MicroStation and 
for the proper delivery of enhancements during the life of the project, the points must be 
converted to COGO Points and assigned the proper feature style. 
 
Select Geometry ► Horizontal Curve Set ► Events… and the Horizontal Events 
dialog box will appear. 
 
In the Horizontal Events dialog box: 
 
In the Add As Section: 
 

o Check the Alignment Point to Cogo radio button. 
o Set the Style to PROP_E_ACL-PC-PT 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L11-10 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Horizontal Events dialog. 
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Figure L11-10 Horizontal Events 

 
 
30.  Horizontal Events: 

 
• Click Apply.  A results report will open listing all points that are now COGO 

points. 
• Click Close to close the Results Box. 
• Click Close to close the Horizontal Events dialog.   

 
* Note:  Cogo Points are only assigned to Alignment Points for the Active 
Alignment.  The process must be repeated for each alignment. 

 
 Converts the Alignment points stored earlier to COGO points and Assigns the Feature 
Style PROP_E_ACL-PC-PT 
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31.  Clean up the COGO Buffer 
 
 
Now that alignment SV4 has a new curve with new COGO Points defining the PC’s and 
PT’s, the SDE should delete the COGO Points that are no longer being used in the curve.  
These are points 2, 3 & 4. 
 
 

• Select Geometry ► Cogo Points ► Delete… and the Delete Cogo Point dialog 
box will appear. 

• In the Delete: field Key-in 2-4  
• Left click in the ‘Selected:’ field for the points to be deleted.    
• Your inputs should correspond to the screen capture depicted below: 

 
 

 

 
 
 
 
 
 

• Click Apply. 
• Click Yes to the prompt asking ‘Do you want to delete the selected data?’ 
• Close the Results Report. 
• Close the Delete Cogo Point dialog. 
• View the Cogo Buffer to verify that points 2, 3 & 4 are no longer there. 

 
 
 
 
 
 
The Cogo Buffer is cleaned up. 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 11 
 

   
 Lab11-21   

32.  Save the InRoads Geometry File 
 
Even though changes to the geometry file have been made – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. Whenever a change has been made to an InRoads Geometry Project – Save the 
project and its associated modifications or changes. 
 
Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will be saved to Lab 11 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab11 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab11 
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Lab 11E Extend Alignment by Distance and Bearing 
 
In this lab you will learn to extend an alignment by a certain distance and bearing. 
 
 
33.  Begin by Deleting all elements in the MicroStation View window. 

 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
 
  
Deletes all elements in the MicroStation View Window. 

34.  View all Horizontal Alignments 
 
 

• In the InRoads Explorer Interface Workspace Bar, Right Click over 
1234567_SDE and select View All Horizontals. 

• In [MicroStation], click the Fit View button.   
 
 
Views all Horizontal Alignments. 

35.  View Cogo Points with the ‘ACL Cogo Point Feature Styles’ Preference 
 
In the [InRoads Software] 
 
Select GeometryView GeometryHorizontal Annotation from the InRoads Menu. 
 
The View Horizontal Annotation dialog box will open. Select the “Main” Tab.   
 
 
The View Horizontal Annotation dialog box opens. 

36.  In the  View Horizontal Annotation “Main” Tab: 
 
 

• Click the Preferences button and highlight NO BEARING & DISTANCE. 
• Click Load & Close. 
• The inputs should now correspond to the screen capture depicted in   

Figure L11-11 (as shown below).  Verify to ensure that your input matches the 
screen capture.    

 
Sets the Viewing Options for the View Horizontal Annotation dialog box.   
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Figure L11-11 View Horizontal Annotation 

 
 
37.  The Filter button on the dialog box will be grayed out. Place the cursor in the Cogo 

Points Include: field to activate the Filter button.  (See Screen Capture depicted above). 
 
Click the Filter button to open the Geometry Selection Filter dialog box. See Figure 
L11-12 (as shown below).   
 
Activates the Filter button and opens the Geometry Selection Filter dialog box. 

 
 
 
 
 
 
 
 
 
 

Click here to activate 
Filter button. 
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Figure L11-12 Geometry Selection Filter 

 
 
 
38.  View Cogo Points with the ‘ACL Cogo Point Feature Styles’ Preference 

 
The Geometry Selection Filter will be utilized to view the Alignment Feature Styles of 
PROP_E_APOT, PROP_E_APOC, PROP_E_APT, PROP_E_APC and 
PROP_E_API. 
 

• In the Style: pull-down – Select Included 
• Click the Preferences button and highlight the ACL Cogo Point Feature Styles 

Preference. 
• Click Load & Close.  This loads the Feature Styles of 

PROP_E_APOT, PROP_E_APOC, PROP_E_APT, PROP_E_APC and 
PROP_E_API into the Style text entry field. 

• Verify to ensure that your input matches the screen capture depicted in Figure 
L11-13. 

 
Selects the Feature Styles in the Geometry Selection Filter. 

 
 
 
 
 
 
 
 
 
 
 
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 11 
 

   
 Lab11-25   

                 
Figure L11-13 Geometry Selection Filter 

 
 
39.  Once the data has been filtered – it needs to be moved from the Available: field to the 

Selected: field.   
 

• Click the ALL button. The data will be moved and then displayed in the 
Selected: field. 

 
The inputs should now correspond to the screen capture depicted in  
Figure L11-14 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
The filtered data is moved from the Available field to the Selected field. 

 
 

                   
Figure L11-14 Geometry Selection Filter 
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40.  Click OK to close out of the Geometry Selection Filter dialog box and load data into 
the View Horizontal Annotation field.    
 
Closes the Geometry Selection Filter dialog box.   

41.  View Filtered Points 
 
The Alignment Feature Style points have been filtered and are available for viewing.   
The View Horizontal Annotation dialog box should still be active from the previous 
steps.  This dialog box depicts the filtered points in the Cogo Points Area as Selected: 
points. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L11-15 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
The filtered point data is available for viewing. 

 

                                                                  
Figure L11-15 Geometry Selection Filter 
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42.  Click Apply and then click Close to close out of the View Horizontal Annotation 
dialog box. 
 
The View Horizontal Annotation dialog box closes and the filtered Points are viewed in 
MicroStation. 

43.  View the selected Points in the [MicroStation Software] by using the following command 
located under the MicroStation View 1 Window. In the [MicroStation Software] – 
 

• Select the “Fit View” Icon to view the Points. 
 
 

               
 
 
 
           Verify that the MicroStation view window matches that shown in Figure L11-16. 
 
The points are displayed and the view is fit to the MicroStation screen. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure L11-16 MicroStation View depicting PROP_E_APOT, PROP_E_APOC, 
PROP_E_APT, PROP_E_APC and PROP_E_API Points. 

 
 
 
 

Fit View Button 
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44.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the Surfaces 
Tab. 
 
 
 
 
 
 
 
 
 
 

• Next click on the 1234567_SDE Surface Project.  Note that the 1234567_SDE 
Surface Project has a “Red Rectangle” around the icon. This denotes that this is 
the “Active” Surface Project.  Any surface commands will be initiated and 
performed on the current “Active” Surface. 

   
Opens the InRoads Surfaces Tab and displays the 1234567_SDE Surface information in 
the InRoads Explorer Interface. 

45.  IMPORTANT STEP!   Set Proper Locks in InRoads 
 

• Verify that the Feature Filter lock is set to on (checked).  Checking this lock 
enables InRoads to recognize filters. 

• Verify that the Feature Highlight lock is set to off (unchecked).  Unchecking 
this lock will allow the View Surface Features dialog box to open quicker in the 
next step. 

 
Sets the Proper Locks for the next step. 

46.  View the Surface Features:  
 
In the InRoads Software: 
 
Select SurfaceView SurfaceFeatures and the View Features dialog box will 
appear: 
 

• In the Surface: Pulldown – select 1234567_SDE 
 
 Click on the Filter button. 
 
 
 
 
 
 
Opens the View Features dialog box. 

Surfaces TAB 
Scroll Bars 
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47.  View Surface Features using the ‘EXIST_RDWY- ACL+ EOP +RR’ Filter. 
 
The Feature Selection Filter dialog box will open. In the Feature Selection Filter 
dialog box --- input the following: 
 

• In the Filter Name: pulldown – select EXIST_RDWY- ACL+ EOP +RR 
 
This will filter the view to include the following Surface Feature codes:  
         TOPO_E_TAC              TOPO_E_TEST               TOPO_E_ TBCL 
         TOPO_E_TEDR            TOPO_E_THC                TOPO_E_ TRCL 
         TOPO_E_TEAD            TOPO_E_TCGT             TOPO_E_ TRCRE 
         TOPO_E_TECD            TOPO_E_TCGF              TOPO_E_ TEDD 
         TOPO_E_TEAP            TOPO_E_TVG                TOPO_E_ TDR 
         TOPO_E_TEAS            TOPO_E_TBAS              TOPO_E_ TDD 
         TOPO_E_TECP            TOPO_E_ TBGL             TOPO_E_ TRCR 
                                                                                         TOPO_E_ TETL 
 
Leave all other entries as default! 
 
The inputs should now correspond to the screen capture depicted in  
Figure L11-17 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Feature Selection Filter dialog box. 

 

                                            
Figure L11-17    Feature Selection Filter 

Use the pull-down 
arrow to select the Filter 
named EXIST_RDWY- 
ACL + EOP + RR 

When the filter name is 
selected the data will be 
filtered as depicted here. 

**WARNING** - 
Take care not to 
accidentally move your 
scroll wheel on your 
mouse while the Filter 
Name field is active. 
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48.  Click OK and the Feature Selection Filter dialog box will Close.  The View Features 
dialog box should still be open from the previous steps. 
 
The inputs in the View Features dialog box should now correspond to the screen capture 
depicted in Figure L11-18 (as shown below).   
 
Closes the Feature Selection Filter dialog box. 

 

                                         
Figure L11-18    View Features 

 
49.  Click Apply and then click Close and the View Features dialog box will close.  

 
Closes the View Features dialog box. 

50.  View the selected Surface Features in the [MicroStation Software] by using the following 
command located under the MicroStation View 1 Window: 
 
In the [MicroStation Software] – 
 
Select the “Fit View” Icon to view the Surface Features. 
 

            
            
 
 
 
Verify that the MicroStation view window matches that shown in Figure L11-19. 
 
The Surface Features are displayed and the view is fit to the MicroStation screen. 

Fit View 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 11 
 

   
 Lab11-31   

 
Figure L11-19 MicroStation View depicting Surface Features and Alignments 

 
 

51.  Window Area  
 
Window into the area depicted by the “rectangle” as shown below in Figure L11-20.   
 
In the [MicroStation Software] – Select the “Window Area” Icon. 
 
 

               
 
 
            
 
 
 
 
 
 
Zoom into the area depicted by the rectangle. 

Window Area Icon 
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Figure L11-20 MicroStation View  

 
 

52.  Zoom to the Beginning of Alignment SV4 
 
Zoom (window in) to the beginning of the SV4 alignment as shown below in 
 Figure L11-21.  The beginning of the alignment will be around Point 217. 
 
Verify that your view in MicroStation resembles that shown in Figure L11-21 
 
Zoom to the beginning of Alignment SV4. 

 
 
 
 
 
 
 
 
 

Window Area 
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Figure L11-21 MicroStation View  

 
 
 
 
 
 
53.  Make SV4 the Active Alignment 

 
 

• In the InRoads Explorer interface, right mouse click over SV4 and select ‘Set 
Active’. 

•  A Red Box  around the alignment name will reflect that SV4 is the Active 
Alignment. 
 
 
* Hint: Make the Geometry tab the active tab if necessary. 
 

Sets SV4 to be the active alignment. 
54.  Set InRoads Locks: 

 
• Select Tools ► Locks and verify that a Check Mark is next to Point Snap. 
• Select Tools ► Locks and verify that Locate Features is active.  This symbol 

should be depicted.   
 

Begin of 
Alignment SV4 
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55.  Extend alignment SV4 at 600 FT prior to station 10+00.00 
 
In the InRoads Software: 
 

• Select Geometry ► Traverse… and the Traverse dialog box will appear. 
• For Method select the Direction radio button. 
• For the Insert Point Mode select the Before Alignment radio button. 

• In the Occupied Point field - click the Locate Button   (located in the 
Occupied Point frame) and left click on Point 217 to select the point. Left click 
again to accept the Point 217. 

• In the Foresight Point field set the Style to PROP_E_API. 
• In the Course field: Enter the following: 

o In the Pulldown – select Direction – then enter direction N 72 42 40.9 W 
o In the Pulldown – select Horizontal Distance – then enter 600.000 

 
Leave all other entries as Default: 

  
Verify the settings match those shown in Figure L11-22. 
 
Steps to extend Alignment SV4 600’. 
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Figure L11-22 Traverse Dialog Box 

 
 
 

56.  • Click Apply. 
• A Results dialog box opens informing you that Point 2 is stored from Point 217 

a distance of 600’ on a bearing of N 72^42'40.9" W. 
• Click Close to close out of the Results dialog box. 
• Click Close to close out of the Traverse dialog box. 

 
 
Alignment SV4 is extended 600’. 

57.  Review Alignment SV4 
 
 

• In the InRoads Explorer interface Right mouse click over SV4 and select 
Review and the Review Horizontal Alignment dialog box will appear. 

• Notice that Point 2 is now the Beginning Point of the alignment SV4.  This is 
only an Alignment Point and must be converted to a Cogo Point. 

• Click Close to close the Review Horizontal Alignment window. 
 
 
 

Alignment SV4 is reviewed. 
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58.  Create COGO Point from Alignment Point 2 
 
* IMPORTANT: As stated previously, Point 2 is an Alignment Point and must be 
converted to a COGO Point.  In order to properly display the points in MicroStation and 
for the proper delivery of enhancements during the life of the project, the point must be 
converted to a COGO Point and assigned the proper feature style. 
 
Select Geometry ► Horizontal Curve Set ► Events… and the Horizontal Events 
dialog box will appear. 
 
In the Horizontal Events dialog box: 
 
In the Add As Section: 
 

o Check the Alignment Point to Cogo radio button. 
o Set the Style to PROP_E_API 

 
Leave all other entries as default. 
 
The inputs should now correspond to the screen capture depicted in  
Figure L11-23 (as shown below).  Verify to ensure that your input matches the screen 
capture.    
 
Opens the Horizontal Events dialog. 
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Figure L11-23 Horizontal Events Dialog Box 

 
 
59.  Horizontal Events: 

 
• Click Apply.  A results report will open listing all points in the Alignment that 

are COGO points. Point 2 is now a COGO Point. 
• Click Close to close the Results Box. 
• Click Close to close the Horizontal Events dialog.   

 
* Note:  Cogo Points are only assigned to Alignment Points for the Active 
Alignment.    

 
Converts Alignment Point 2 stored earlier to a COGO point and Assigns the Feature 
Style PROP_E_API. 

 
 
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 11 
 
 

   
 Lab11-38   

60.  Re-station SV4 to begin at Station 10+00.00 
 

• Select Geometry ► Horizontal Curve Set ► Stationing… and the Stationing 
dialog box will appear. 

• Select SV4 from the Horizontal Alignment Pull down. 
• In the Starting Station field key-in 10+00.00. 

 
Leave all other entries as Default. 
 

• Verify all entries match those shown in Figure L11-24.  
 
Re-station Alignment SV4 to begin at Station 10+00.00 

 
                         

                                     
Figure L11-24 Stationing Dialog Box 

 
 
 
 
 
61.  Click Apply and then click Close. 

 
Alignment SV4 is Re-stationed. 
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62.     Review Alignment SV4 
 

• Select Geometry ►Review Horizontal 
• The Review Horizontal Alignment report window opens. 
• Verify that the beginning station is now 10+00.00. 
• Click Close to close out of the Review Horizontal Alignment report window. 

 
Alignment SV4 is re-stationed to begin at station 10+00.00. 

63.  Save the InRoads Geometry File 
 
Even though the Horizontal Alignments have been stored – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. Whenever a change has been made to an InRoads Geometry Project – Save the 
project and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will be saved to Lab 11 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab11 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab11 

64.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
 
Deletes the Graphics from the GDOT 3D Working File.dgn to ensure a clean DGN file 
for the next Lab. 

65.                    
                 This concludes Lab 11.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 12 
Store Existing R/W 

 
Objective 
 
Once the existing centerlines of all roadways have been established, the Existing R/W for each 
road must be stored. 
 
The objective of Lab 12 is to: 
 

• Learn techniques to create and store the Existing R/W. 
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Lab 12A Getting Started 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Graphics (This step may be ignored if your MicroStation 
Window is already clear of graphics). 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard.   

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

4.  Verify Project Defaults 
• In InRoads select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_SDE which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L12-1. 
• Click Apply & Close. 

 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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Figure L12-1 Project Defaults 

 
 
 
 
 

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
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5.  Open the .ALG file 
• Select File ► Open. 
• Navigate and open the Folder Lab12. 
• Highlight the file 1234567_SDE.alg. 
• Click Open & Cancel. 
 

Opens the 1234567_SDE.alg file 
6.  Set Survey Default Preferences 

 
• In InRoads  - Select File Project Options. 
• In the Project Options dialog box select the General Tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Survey Default.  Click Load and Close. 
• In the Project Options dialog box - Click Apply and Close. 

 
Sets the Survey Defaults Preference. 

7.  View all Horizontal Alignments 
 

• In the Workspace Bar ensure that Geometry is the active tab. 
• Right mouse click over the project 1234567_SDE. 
• Select View All Horizontals. 
• In MicroStation click the Fit View button. 

 

             
                              
 
 

• Ensure that your view in MicroStation matches that shown in Figure L12-2. 
 

Views all Horizontal Alignments in the geometry project 1234567_SDE. 
 

Hint:  You may also right 
mouse click over ‘Geometry 
Projects’ in the Workspace 
Bar and select open. 

Fit View 
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Figure L12-2 MicroStation Window 

 
 

8.  Open the Parallel Horizontal Alignment dialog box. 
 

• Select Geometry ► Utilities ► Parallel Horizontal Alignment… The Parallel 
Horizontal Alignment dialog box opens. 
 

                        
 

Opens the Parallel Horizontal Alignment dialog box. 

SV4 

SV6 
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9.  Use the Parallel Horizontal Alignment command to store an alignment offset 50’ left of 
SV4. 
 

• For the Mode – select Specify.  
• In the From frame – for Horizontal Alignment use the Locate button ( ) to 

select Alignment SV4. 
• In the Offset field key-in -50.  

*NOTE: A negative value in the Offset field stores an alignment to the left and a 
positive value stores an alignment to the right. 

• In the To frame - leave the Alignment Name key-in field empty.  (When you set 
the Survey Default preferences in Step 6 - it automatically stores the alignment 
with an SV prefix and assigns it the next available number).  

• In the Description field Key-in: EXIST R/W LT US 78.  It is recommended that 
the SDE provide descriptions in this format in order to easily identify alignments 
in the ALG file for future viewing. 

• In the Style pulldown select the Style to be PROP_E_RWE. 
• Verify that your input matches the screen capture below. 

 
 

 
 

Store a Parallel Horizontal Alignment to the Left. 
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10.  • Click Apply & Close.  Alignment SV1 is stored.  
*Note: If an alignment name is not Keyed in, InRoads assigns the next available 
alignment name.  In this case SV1. 

• Your view in MicroStation should match that shown below. 
 

    
 
Stores an alignment 50’ to the left of SV4 and assigns it a feature style of PROP_E_RWE. 

11.  Review Alignment SV1. 
 

• In the InRoads Explorer Interface make sure the Geometry tab is selected and 
expand the 1234567_SDE geometry project. Your InRoads Explorer Interface 
should look similar to this screen capture shown below. 
 

 
 

• Right mouse click over Alignment SV1 and select Review… 
• The Review Horizontal Alignment window opens as shown in Figure L12-3. 
• Notice there are no Point Numbers associated with the coordinates in Alignment 

SV1. 
• Click Close to close the Report dialog when finished reviewing. 

Geometry Tab 
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Figure L12-3 Review Horizontal Alignment window. 

 
12.  As noted during the review of Horizontal Alignment SV1 – point numbers have not been 

associated with it.  The next steps depict the process to assign names to the unnamed 
coordinates in Horizontal Alignment SV1. 
 

• Click Geometry ► Utilities ► Assign Names and the Assign Names dialog 
box will appear. 

 
Ensure that the following information is depicted in the dialog box: 
 

• In the Include: option  - select         Alignments 
• In the Name: field – type SV1 
• Place a  Check Mark         by On-Alignment Points   
• Place a  Check Mark         by Off-Alignment Points   
• In the Method: option – select         Assign 
• Leave the Seed Name: field ________  ( leave blank)  
• Place a  Check Mark         by Check for Coincident Points   
• Leave all other entries as default. 
• Then Left Click in the Selected Field (so that this field will be populated with the 

Alignment entry). 
 

Point numbers show up in 
these fields (between 
parentheses). Notice there 
are none listed at present. 
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13.  The inputs should now correspond to the screen capture depicted below: 
 
Verify to ensure that your input matches the screen capture.    
 

 
 

• Click Apply & Close. 
 
Assigns names to points in Alignment SV1 and closes the Assign Names dialog box. 

14.  Review Horizontal Alignment SV1 a second time.  
 
Double click on the Geometry Project named 1234567_SDE (ONLY if it is not already 
open in InRoads Explorer).  This will allow you to view all of the project data (see 
screen capture shown below - right). 
 

• Set SV1 to be the active alignment by right mouse clicking and selecting ‘Set 
Active’ to place the red block around it. 

 

                             
 
 
 
 
Opens the Review Horizontal Alignment window.     

Alignment SV1 
with red rectangle 
indicating it is the 
active alignment. 
 

Scroll Bars Geometry TAB 

Double Click 
to Expand 
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15.  Review Horizontal Alignment SV1 
 

• In the InRoads Explorer Interface -- Right mouse click on alignment SV1. 
In the list that appears – select Review.  

• Notice the alignment now has point numbers associated with the coordinates. 
• Take a moment to review alignment SV1 in the Review Horizontal Alignment 

window as depicted below in Figure L12-4. 
• Close the Report Dialog box when done reviewing. 

   
Opens the Review Horizontal Alignment window.    

 
 
 
 

 
Figure L12-4 Review Horizontal Alignment window. 

 
 
 
 
 
 
 

Point numbers now exist 
for the coordinates. 
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16.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: Although point names (Alignment Points) now exist in alignment 
SV1 -- points don’t actually exist as COGO Points in the COGO Buffer.  In order to 
properly display the points in MicroStation and for the proper delivery of enhancements 
during the life of the project the points must be converted to COGO Points. 
 

• Ensure SV1 is the active alignment.  A red square  must be around SV1. If it does 
not have a Red Square - highlight alignment SV1, right mouse click over it and 
select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog box: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_RWE 
o Accept all other defaults. 

• Click Apply.  A results report opens showing all points that are converted to 
COGO points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
* NOTE:  Cogo Points are only assigned to Alignment Points for the active 
alignment only.  The process must be repeated for each alignment. 
 

Converts the Alignment points stored earlier to COGO points. 
17.  Review the COGO Buffer for the newly created COGO Points. 

• In the InRoads Explorer Interface Workspace Bar -- Left Click on the Cogo 
Buffer (Highlighted in blue below). 
 

        
     

• Use the scroll bar to look for all the points in the SV1 alignment.  Review 
Alignment SV1 to help.   

• Verify that the Feature Style has been applied.  In this exercise PROP_E_RWE 
was used. 
 

Review of Cogo Buffer. 
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18.  Save the InRoads Geometry File 
 
Even though the SV1 Horizontal Alignment has been stored – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. Whenever a change has been made to an InRoads Geometry Project – Save the 
project and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will be saved to Lab 12 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab12 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab12  

19.  Use the Parallel Horizontal Alignment command to store an alignment offset 50’ right 
of SV4. 
 

• Select Geometry ► Utilities ► Parallel Horizontal Alignment… 
• For the Mode – select Specify.  
• In the From frame use the Locate button ( ) to select alignment SV4. 
• In the Offset field key-in 50.  

*NOTE: A negative value in the Offset field stores an alignment to the left and a 
positive value store an alignment to the right. 

• In the To frame ensure the Alignment Name field is set to SV2.  (Please Note: 
This field can be left blank and the next available alignment number will be 
stored. For this Lab -- input in SV2 in order for the labs to be consistent).  

• In the Description field key-in: EXIST R/W RT US 78.  It is recommended that 
the SDE provide descriptions in this format in order to easily identify alignments 
in the ALG file for future viewing. 

• In the Style pulldown select the Style to be PROP_E_RWE. 
• Verify that your input matches the screen capture below. 
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Store a Parallel Horizontal Alignment to the Right. 

20.  • Click Apply & Close.  Alignment SV2 is stored.  
• Your view in MicroStation should match that shown below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Stores an alignment 50’ to the Right of SV4 and assigns it a feature style of 
PROP_E_RWE. 
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21.  As mentioned previously - point numbers have not been associated with the newly 
created Alignment SV2.  The next steps depict the process to assign names to the 
unnamed coordinates in Horizontal Alignment SV2. 
 

• Click Geometry ► Utilities ► Assign Names and the Assign Names dialog 
box will appear. 

 
Ensure that the following information is depicted in the dialog box: 
 

• In the Include: option  - select         Alignments 
• In the Name: field – type SV2 
• Place a  Check Mark         by On-Alignment Points   
• Place a  Check Mark         by Off-Alignment Points   
• In the Method: option – select         Assign 
• Leave the Seed Name: field ________  ( leave blank)  
• Place a  Check Mark         by Check for Coincident Points   
• Leave all other entries as default. 
• Then Left Click in the Selected Field (so that this field will be populated with 

the Alignment entry). 
 
Opens the Assign Names dialog box. 

22.  The inputs should now correspond to the screen capture depicted below: 
 
Verify to ensure that your input matches the screen capture.    
 

                   
 

• Click Apply & Close. 
 
Assigns names to points in Alignment SV2 and closes the Assign Names dialog box. 
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23.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: Although point names (Alignment Points) now exist in alignment 
SV2 -- the points don’t actually exist as COGO Points in the COGO Buffer.  In order to 
properly display the points in MicroStation and for the proper delivery of enhancements 
during the life of the project the points must be converted to COGO Points and assigned 
the proper feature style. 
 
 

• Ensure SV2 is the active alignment.  A red square  must be around SV2. If it does 
not have a Red Square - highlight alignment SV2, right mouse click over it and 
select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog box: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_RWE 
o Accept all other defaults. 

• Click Apply.  A results report opens showing all points that are converted to 
COGO points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
 

* NOTE:  Cogo Points are only assigned to Alignment Points for the active 
alignment only.  The process must be repeated for each alignment. 
 
 

Opens the Horizontal Events dialog. Converts the Alignment points stored earlier to 
COGO points and Assigns the Feature Style PROP_E_RWE 

24.  Set Alignment SV6 to be the Active Alignment. 
 
 
 

• In the InRoads Workspace Bar (shown on the 
right) expand the project by double-clicking on 
1234567_SDE as shown. 

• Ensure that SV6 has a Red Box around it. This 
indicates that alignment SV6 is the active 
alignment. 

• If it does not have a Red Box - highlight 
alignment SV6, right mouse click over it and 
select Set Active. 

 
 
 
Sets Alignment SV6 as the Active Alignment. 
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25.  Store an Alignment 40’ left and an Alignment 40’ right of Alignment SV6 with the 
features style PROP_E_RWE. 
 

• Select Geometry ► Utilities ► Parallel Horizontal Alignment… 
• Verify and match the following settings: 

 

 
 

• Click Apply only!!   
• Change the settings in the Parallel Horizontal Alignment dialog box to match 

the settings below: 
 
 
 

Enter the following text: 
EXIST R/W LT GOLF COURSE 

 

Important!!  Make sure that SV6 is 
selected in the pulldown!! 

Enter an Offset of   -40.00 

Change Style to PROP_E_RWE 
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26.  • Click Apply & Close. Alignment SV3 and SV5 are stored. 
 

Existing R/W alignments SV3 and SV5 are stored and given the feature code 
PROP_E_RWE. 

27.  As mentioned previously - point numbers have not been associated with the newly 
created Alignment SV3.  The next steps depict the process to assign names to the 
unnamed coordinates in Horizontal Alignment SV3. 
 

• Click Geometry ► Utilities ► Assign Names and the Assign Names dialog 
box will appear. 

 
Ensure that the following information is depicted in the dialog box: 
 

• In the Include: option  - select         Alignments 
• In the Name: field – type SV3 
• Place a  Check Mark         by On-Alignment Points   
• Place a  Check Mark         by Off-Alignment Points   
• In the Method: option – select         Assign 
• Leave the Seed Name: field ________  ( leave blank)  
• Place a  Check Mark         by Check for Coincident Points   
• Leave all other entries as default. 
• Then Left Click in the Selected Field (so that this field will be populated with 

the Alignment entry). 
 
Opens the Assign Names dialog box. 

Enter the following text: 
EXIST R/W RT GOLF COURSE 

 

Important!!  Make sure that SV6 is 
selected in the pulldown!! 

Enter an Offset of    40.00 

Change Style to PROP_E_RWE 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 12 
 
 

   
 Lab12-18   

28.  The inputs should now correspond to the screen capture depicted below: 
Verify to ensure that your input matches the screen capture.    
 

                 
 

• Click Apply & Close. 
 
Assigns names to points in Alignment SV3 and closes the Assign Names dialog box. 

29.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: Although point names (Alignment Points) now exist in alignment 
SV3 -- the points don’t actually exist as COGO Points in the COGO Buffer.  Following 
are the steps to convert the points to COGO Points and assign the proper feature style. 
 

• Ensure SV3 is the active alignment.  A red square  must be around SV3. If it does 
not have a Red Square - highlight alignment SV3, right mouse click over it and 
select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog box: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_RWE 
o Accept all other defaults. 

• Click Apply.  A results report opens showing all points that are converted to 
COGO points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
* NOTE:  Cogo Points are only assigned to Alignment Points for the active 
alignment only.  The process must be repeated for each alignment. 
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30.  As mentioned previously - point numbers have not been associated with the newly 
created Alignment SV5.  The next steps depict the process to assign names to the 
unnamed coordinates in Horizontal Alignment SV5. 
 

• Click Geometry ► Utilities ► Assign Names and the Assign Names dialog 
box will appear. 

 
Ensure that the following information is depicted in the dialog box: 

• In the Include: option  - select         Alignments 
• In the Name: field – type SV5 
• Place a  Check Mark         by On-Alignment Points   
• Place a  Check Mark         by Off-Alignment Points   
• In the Method: option – select         Assign 
• Leave the Seed Name: field ________  ( leave blank)  
• Place a  Check Mark         by Check for Coincident Points   
• Leave all other entries as default. 
• Then Left Click in the Selected Field (so that this field will be populated with 

the Alignment entry). 
 
 

Opens the Assign Names dialog box. 
31.  The inputs should now correspond to the screen capture depicted below: 

Verify to ensure that your input matches the screen capture.    
 

                 
 

• Click Apply & Close. 
 
Assigns names to points in Alignment SV5 and closes the Assign Names dialog box. 
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32.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: Although point names (Alignment Points) now exist in alignment 
SV5 -- the points don’t actually exist as COGO Points in the COGO Buffer.  Following 
are the steps to convert the points to COGO Points and assign the proper feature style. 
 

• Ensure SV5 is the active alignment.  A red square  must be around SV5. If it does 
not have a Red Square - highlight alignment SV5, right mouse click over it and 
select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog box: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_RWE 
o Accept all other defaults. 

• Click Apply.  A results report opens showing all points that are converted to 
COGO points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
* NOTE:  Cogo Points are only assigned to Alignment Points for the active 
alignment only.  The process must be repeated for each alignment. 
 

Opens the Horizontal Events dialog. Converts the Alignment points stored earlier to 
COGO points and Assigns the Feature Style PROP_E_RWE 

33.  Save the InRoads Geometry File 
 
Even though the Horizontal Alignments have been stored – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. Whenever a change has been made to an InRoads Geometry Project – Save the 
project and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will be saved to Lab 12 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab12 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab12  
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34.  In MicroStation, window area the intersection of SV4 and SV6.  
 

• In MicroStation, Window area as shown in Figure L12-5. 
• In MicroStation, Your view should look like that shown in Figure L12-6 (but 

without the yellow highlighted area and the listed alignment names. These have 
been added for user reference only). 

 
Zooms into the intersection of SV4 and SV6.  

 
 
 

   
Figure L12-5 MicroStation View 

Window area as shown here. 
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Figure L12-6 MicroStation View 

 
 

35.  The Partial Delete Alignment command will be used to partially delete alignment SV2 
between SV5 and SV3 as shown highlighted in yellow in Figure L12-6.  Before using 
this command however it is necessary to properly set the locks in InRoads.  The 
following steps guide you through the use of the Partial Delete Command. 
 

• In InRoads, Select Tools ► Locks  
• Ensure Point Snap and Element Snap are unchecked.  This places InRoads in a 

state to recognize the MicroStation snaps. 
 

36.  Use the Geometry Utility Partial Delete Alignment to partially delete alignment SV2 
between SV3 and SV5 as shown highlighted in yellow in Figure L12-6.  
 

• Select Geometry ► Utilities ►Partial Delete Alignment… 
• Notice in the lower left corner of the MicroStation window you are prompted to 

‘> Identify alignment   ’ . 
• Left Click once anywhere on SV2.  You’ll notice a dynamic line attached to SV2 

that moves with your cursor as shown in Figure L12-7. 
• Continue to Step 37. 
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Figure L12-7 MicroStation Window 

 
37.  Identify the first partial delete location. 

 
• Notice, in the lower left corner of the MicroStation window you are prompted to 

‘> Identify first station/Key in station   ’ .  
See Figure L12-7. 

• With the dynamic line from the previous step still active, use the MicroStation 
Intersection snap procedure described here to snap to the intersection identified 
as ‘First Intersection Station’ in Figure L12-8.  
 

                MicroStation Intersection Snap Procedure 
 

1. At the bottom of the MicroStation window left click on the Active 
Snap Mode button.       
                                           
                                 Active Snap Mode button. 
 

2. Select Intersection from the popup menu shown below.  
  

Prompts help the user by 
providing instructions and 
information.  In this case 
you are prompted to 
‘Identify first station/Key-
in station’. 

A dynamic line is drawn 
from SV2 and moves as 
you move the cursor. 
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3. Tentative snap anywhere on SV2 near the location identified as ‘A’ in 
Figure L12-8.   Alignment SV2 will turn purple as shown here. 

 

 
 

4. Tentative snap anywhere on SV3 near the location identified as ‘B’ in 
Figure L12-8.  Alignment SV2 will remain purple, alignment SV3 will 
turn purple and the intersection point will be tentatively identified as 
shown here. 

 

 
 

5. Left Click to accept the intersection location.  The dynamic line 
returns.  Continue to Step 38. 

 

NOTE: The intersection 
snap procedure requires 
two consecutive 
tentative snaps. One on 
the first alignment 
forming the intersection 
and one on the second 
alignment forming the 
intersection.     
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Figure L12-8 MicroStation View 

 
 
38.  Identify the second partial delete location. 

 
• Notice, in the lower left corner of the MicroStation window you are prompted to 

‘> Identify second station/Key in station’ .   
• With the dynamic line from the previous step still active, use the MicroStation 

Intersection snap procedure to snap to the intersection identified as ‘Second 
Intersection Station’ in Figure L12-8.  

 
MicroStation Intersection Snap Procedure 

 
1. At the bottom of the MicroStation window left click on the Active 

Snap Mode button.       
                                                                       
                                                           Active Snap Mode button. 
 

2. Select Intersection from the popup menu shown here.  
  

First 
Intersection Station. 

A 

B 

Second  Intersection 
Station 

C D 
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3. Tentative snap anywhere on SV2 near the location identified as ‘C’ in 
Figure L12-8.   Alignment SV2 will turn purple as shown here. 

 

 
 

4. Tentative snap anywhere on SV5 near the location identified as ‘D’ in 
Figure L12-8.  Alignment SV2 will remain purple, alignment SV5 will 
turn purple and the intersection point will be tentatively identified as 
shown here. 

5.Left click to accept the intersection location. 
 

 
 

6. Notice in the lower left corner of MicroStation you are prompted to 
‘Accept/Reject’    the operation.   

7. Left click again to Accept or Right click to reject and try again.  
Alignment SV2 is partially deleted between alignment SV3 and SV5 as 
shown in Figure L12-9. 

8. Right mouse click to exit the partial delete alignment command. 
 
Alignment SV2 is partially deleted between alignments SV3 and SV5. 

NOTE: The intersection 
snap procedure requires 
two consecutive 
tentative snaps. One on 
the first alignment 
forming the intersection 
and one on the second 
alignment forming the 
intersection.     
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Figure L12-9 MicroStation View. 

 
 
 
 
 
 
 
 
 
 
 
 

39.  Once Alignment SV2 is partially deleted as shown in Figure L12-9, unnamed 
coordinates are created at the breakage points.  Alignment Points must now be created at 
these locations and converted to Cogo Points. 
 
 

• Ensure SV2 is the active alignment.  A red square  must be around SV2. If it does 
not have a Red Square - highlight alignment SV2, right mouse click over it and 
select Set Active. 

 
 
 
 
 
Sets SV2 as the Active Alignment. 
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40.  As mentioned previously - point numbers have not been associated with the breakage 
points for Alignment SV2.  The next steps depict the process to assign names to the 
unnamed coordinates in Horizontal Alignment SV2. 
 

• Click Geometry ► Utilities ► Assign Names and the Assign Names dialog 
box will appear. 

 
Ensure that the following information is depicted in the dialog box: 
 

• In the Include: option  - select         Alignments 
• In the Name: field – type SV2 
• Place a  Check Mark         by On-Alignment Points   
• Place a  Check Mark         by Off-Alignment Points   
• In the Method: option – select         Assign 
• Leave the Seed Name: field ________  ( leave blank)  
• Place a  Check Mark         by Check for Coincident Points   
• Leave all other entries as default. 
• Then Left Click in the Selected Field (so that this field will be populated with 

the Alignment entry). 
 

Opens the Assign Names dialog box. 
41.  The inputs should now correspond to the screen capture depicted below: 

Verify to ensure that your input matches the screen capture.    
 

                  
                      

• Click Apply & Close. 
 

 
Assigns names to points in Alignment SV2 and closes the Assign Names dialog box. 
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42.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: Although point names (Alignment Points) now exist in alignment 
SV2 -- the points don’t actually exist as COGO Points in the COGO Buffer.  Following 
are the steps to convert the points to COGO Points and assign the proper feature style. 
 

• Ensure SV2 is the active alignment.  A red square  must be around SV2. If it does 
not have a Red Square - highlight alignment SV2, right mouse click over it and 
select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog box: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_RWE 
o Accept all other defaults. 

• Click Apply.  A results report opens showing all points that are converted to 
COGO points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
* NOTE:  Cogo Points are only assigned to Alignment Points for the active 
alignment only.  The process must be repeated for each alignment. 
 

Opens the Horizontal Events dialog. Converts the Alignment points. 
43.  View all Cogo Points 

 
• In InRoads, Select Geometry ► View Geometry ► Horizontal Annotation 
• In the View Horizontal Annotation dialog box, place your cursor in the      

Cogo Points entry field to activate the Filter button. 
• Click the Filter button and a Geometry Selection Filter dialog box will appear. 
• Click the All Button to move all points from the Available field to the Selected 

field. 
• Click OK in the Geometry Selection Filter dialog and populate the View 

Horizontal Annotation dialog with the points. 
• Click Apply and Close in the View Horizontal Annotation dialog. 
• Verify your view is similar to that shown in Figure L12-10. 
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Figure L12-10 MicroStation Window 
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44.  Trim Alignment SV3 at SV2.  Refer to Figure L12-11. 
 

• Select Geometry ► Utilities ► Trim Alignment. 
• In the lower left corner of the MicroStation Window you are prompted to > 

Identify first clipping alignment.  
• Click anywhere on Alignment SV2. It will turn purple. 
• In the lower left corner of the MicroStation Window you are prompted to > 

Identify second clipping alignment.  
• Click anywhere on Alignment SV3. It will turn purple. 
• In the lower left corner of the MicroStation Window you are prompted to > 

Identify portion to clip.  
• Click on the portion of SV3 that you want to clip.  See Figure L12-11. 
• In the lower left corner of the MicroStation Window you are prompted to > 

Accept or reject.  
• Left click somewhere in the MicroStation screen to accept the Trim. 
• Repeat the above steps to Trim Alignment SV5 as shown in Figure L12-11. 
• Right mouse click when finished to deactivate the Trim Alignment command. 
• Verify that your view looks like that shown in Figure L12-12. 
• Right mouse click to exit the Trim Alignment command. 

 
Alignment SV3 and SV5 are trimmed.  
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Figure L12-11 MicroStation View. 

SV2 

SV5 SV3 

Portion of 
SV3 to Trim. 

Portion of 
SV5 to Trim. 
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Figure L12-12 MicroStation View. 

 
45.  When alignments SV3 and SV5 were trimmed new coordinates were added to each 

alignment at the trim location.  These coordinates must now have names assigned 
to them and will need to be converted to Cogo Points. 
 

• Click Geometry ► Utilities ► Assign Names and the Assign Names dialog 
box will appear. 

 
Ensure that the following information is depicted in the dialog box: 

• In the Include: option  - select         Alignments 
• In the Name: field – type SV3 
• Place a  Check Mark         by On-Alignment Points   
• Place a  Check Mark         by Off-Alignment Points   
• In the Method: option – select         Assign 
• Leave the Seed Name: field ________  ( leave blank)  
• Place a  Check Mark         by Check for Coincident Points   
• Leave all other entries as default. 
• Then Left Click in the Selected Field (so that this field will be populated with 

the Alignment entry). 
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46.  The inputs should now correspond to the screen capture depicted below: 
Verify to ensure that your input matches the screen capture.    
 

                  
                      

• Click Apply & Close. 
 

47.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: Although point names (Alignment Points) now exist in alignment 
SV3 -- the points don’t actually exist as COGO Points in the COGO Buffer.  Following 
are the steps to convert the points to COGO Points and assign the proper feature style. 
 

• Ensure SV3 is the active alignment.  A red square  must be around SV3. If it does 
not have a Red Square - highlight alignment SV3, right mouse click over it and 
select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog box: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_RWE 
o Accept all other defaults. 

• Click Apply.  A results report opens showing all points that are converted to 
COGO points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
* NOTE:  Cogo Points are only assigned to Alignment Points for the active 
alignment only.  The process must be repeated for each alignment. 
 

Opens the Horizontal Events dialog. Converts the Alignment points stored earlier to 
COGO points and Assigns the Feature Style PROP_E_RWE 
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48.  As mentioned previously - point numbers have not been associated with the newly 
created Alignment SV5.  The next steps depict the process to assign names to the 
unnamed coordinates in Horizontal Alignment SV5. 
 

• Click Geometry ► Utilities ► Assign Names and the Assign Names dialog 
box will appear. 

 
Ensure that the following information is depicted in the dialog box: 

• In the Include: option  - select         Alignments 
• In the Name: field – type SV5 
• Place a  Check Mark         by On-Alignment Points   
• Place a  Check Mark         by Off-Alignment Points   
• In the Method: option – select         Assign 
• Leave the Seed Name: field ________  ( leave blank)  
• Place a  Check Mark         by Check for Coincident Points   
• Leave all other entries as default. 
• Then Left Click in the Selected Field (so that this field will be populated with 

the Alignment entry). 
 
 

Opens the Assign Names dialog box. 
49.  The inputs should now correspond to the screen capture depicted below: 

Verify to ensure that your input matches the screen capture.    
 

                 
 
 

• Click Apply & Close. 
 
Assigns names to points in Alignment SV5 and closes the Assign Names dialog box. 
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50.  Create COGO Points of all Alignment Points. 
 
 
 
* IMPORTANT: Although point names (Alignment Points) now exist in alignment 
SV5 -- the points don’t actually exist as COGO Points in the COGO Buffer.  Following 
are the steps to convert the points to COGO Points and assign the proper feature style. 
 
 
 

• Ensure SV5 is the active alignment.  A red square  must be around SV5. If it does 
not have a Red Square - highlight alignment SV5, right mouse click over it and 
select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog box: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_RWE 
o Accept all other defaults. 

• Click Apply.  A results report opens showing all points that are converted to 
COGO points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
 

* NOTE:  Cogo Points are only assigned to Alignment Points for the active 
alignment only.  The process must be repeated for each alignment. 
 
 

Opens the Horizontal Events dialog. Converts the Alignment points stored earlier to 
COGO points and Assigns the Feature Style PROP_E_RWE 

51.  Once we trimmed alignments SV3 and SV5 we no longer need points 37, 38, 45 and 
46 which were part of the alignment as seen in Figure L12-12.  
 
In order to keep the project database clean it is a good idea to delete these Cogo 
Points from the database. 
 
 
 
 

• Select Tools ► Locks and enable Point Snap by ensuring that a check mark 
exists next to Point Snap. 

• Select Geometry ► Cogo Points ► Delete.  The following dialog opens. 
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• Use the Locate button to select Point 37. 
• In MicroStation, left Click on Point 37.  
• Notice that a Purple Hour glass identifies the point you selected. 
• Notice in the Bottom middle of the MicroStation window the text ‘Selected Point 

37’ is displayed.   
• Notice in the Bottom left of the MicroStation window the text ‘>Accept/Reject’. 

 
• Left click anywhere on a blank part of the MicroStation window to accept Point 

37. 
• The Delete Cogo Point dialog reopens with Point 37 in the Selected field as 

shown here. 
 

 
 

• Click Apply and Yes to delete Point 37. 
• Repeat the above steps for Points 38, 45 & 46. 
• Close the Delete Cogo Point dialog when finished. 

 
      *NOTE: Multiple points may be keyed in rather than using the Locate button if 
desired.  Individual points are separated by a comma (i.e. 37,38,45,46.).  Ranges of 
points are connected by a dash (i.e. 20-25). 
 
The Cogo point 37, 38, 45 & 46 have been deleted from the project. 

Locate Button 
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52.  Save the InRoads Geometry File 
 
Even though the Horizontal Alignments have been stored – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. Whenever a change has been made to an InRoads Geometry Project – Save the 
project and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will be saved to Lab 12 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab12 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab12  

53.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
 
Deletes the Graphics from the GDOT 3D Working File.dgn to ensure a clean DGN file 
for the next Lab. 

54.                    
                 This concludes Lab 12.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 13 
Store Property by Bearing/Distance and 
Create/Edit Alignment by Cogo Points 

 
Objective 
 
Storing property from Deeds. 
 
The objective of Lab 13 is to: 
 

• Learn techniques to store property information from deeds into InRoads. 
• The following deed description will be used to create Property Alignment SV64A. 

 
Beginning at point 218; running thence S 16°50'06.7" E a distance of 188.41 feet to; thence S 
72°58'15.5" W a distance of 212.41 feet; thence N 17°49'15.9" W a distance of 105.74 feet; 
thence northwesterly 217.702 feet along the arc of a curve (said curve having a radius of 
1105.916 feet and a chord distance of 217.351 feet on a bearing of N 12°10'54.1" W); thence S 
72°42'40.9" E a distance of 237.49 feet back to the point of beginning. Containing 1.255 acres 
more or less. 
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Lab 13A Getting Started 
 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Graphics (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard.   

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

4.  Verify Project Defaults 
• In InRoads select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_SDE which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L13-1. 
• Click Apply & Close. 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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Figure L13-1 Project Defaults 

 
 
 
 
 

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
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5.  Open .ALG file 
• Select File ► Open. 
• Navigate and open the Folder Lab13. 
• Highlight the file 1234567_SDE.alg. 
• Click Open & Cancel. 
 

Opens .alg file 
6.  Set Survey Default Preferences 

 
• In InRoads  - Select File Project Options. 
• In the Project Options dialog box select the General Tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Survey Default.  Click Load and Close. 
• In the Project Options dialog box - Click Apply and Close. 

 
Sets the Survey Defaults Preference. 

7.  View all Horizontal Alignments and Cogo Points. 
 

• Select Geometry ► View Geometry ► Horizontal Annotation… 
• The View Horizontal Annotation dialog box will open. Select the “Main” Tab.  
• The Dialog box shown in Figure L13-2 opens. 

 
 
The View Horizontal Annotation dialog box opens. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Hint:  You may also right 
mouse click over ‘Geometry 
Projects’ in the Workspace 
Bar and select open. 
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Figure L13-2 Preferences 

 
8.  • Click the Preferences button. 

• The Dialog box Shown in Figure L13-3 opens. 
 

 

 
Figure L13-3 Preferences 

Filter Button shown 
inactivated. 

To activate the Filter button 
place the cursor in the 
Horizontal Alignments 
Include field or the Cogo 
Points Include field. 

Preferences Button 
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9.  In the  Preferences Dialog Box: 
 

• Highlight NO BEARING & DISTANCE. This preference sets the proper settings 
for viewing of Alignments and Cogo points. 

• Click Load & Close. 
 
Sets the Viewing Preferences for the View Horizontal Annotation dialog box.   

10.  View the Horizontal Alignments: 
 
In the View Horizontal Annotation dialog box place your cursor in the Horizontal 
Alignments Include field to activate the Filter button and then click the Filter button. 
 

• The Dialog box shown in Figure L13-4 opens. 
 
 
Opens the Geometry Selection Filter Dialog Box. 

 
 

 
Figure L13-4 Geometry Selection Filter 

 
 
 

11.  • In the Geometry Selection Filter dialog box click the All button and then click 
OK. 

 
 
Selects the Horizontal Alignments to View. 

All Button 
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12.  View the Cogo Points: 
 

• In the View Horizontal Annotation dialog box place your cursor in the Cogo 
Points Include field to activate the Filter button and then click the Filter button 
and the Geometry Selection Filter dialog box will appear. 

• In the Geometry Selection Filter dialog box click the All button and OK. 
 
 
Selects the Cogo Points to View. 

13.  • Verify that your settings match those shown in Figure L13-5. 
• Then click Apply and Close. 

 
Selects the Horizontal Alignments and Cogo Points to view  

 
 

 
Figure L13-5 View Horizontal Annotation 
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14.  View the selected Horizontal Alignments and Points in the [MicroStation Software] by 
using the following command located under the MicroStation View 1 Window. In the 
[MicroStation Software] – 
 

• Select the “Fit View” Icon to view the Points. 
 

                  
 
 
 
            

• Verify that the MicroStation view window matches that shown in Figure L13-6. 
 

Views all Horizontal Alignments and Points in the Geometry Project 1234567_SDE. 
 
 
 

 
Figure L13-6 MicroStation Window 

 
 
 

Fit View Button 
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15.  Window area the intersection of SV4 and SV6 
 

• In MicroStation, use the Window Area icon to window into the area shown in 
Figure L13-7. 

• Your MicroStation view should look similar to that shown in Figure L13-8.  
 

The intersection of SV4 and SV6 is zoomed into. 
 
 

          
Figure L13-7 MicroStation Window 

 
 

           
Figure L13-8 MicroStation Window 

 

SV4 

Point 218 

Window 
Area here. 

SV6 
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16.  Create alignment SV64A. 
 

• In InRoads, Select File ► New.   
• In the New dialog box that opens, select the Geometry tab. 
• Enter the following information into the dialog box: 

o Type: Horizontal Alignment 
o Name: SV64A 
o Description: PAR 64A TM#49 GABLE 
o Style: PROP_E_PAR 
o Curve Definition: Arc 

• Verify that your settings match those shown in Figure L13-9. 
• Click Apply & Close. 

 
Alignment SV64A  is created. 

 
 

 
Figure L13-9  

 
 
 
 
 
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 13 
 

   
 Lab13-11   

17.  Make alignment SV64A the active alignment 
 

• In the InRoads Explorer click the + sign next to the project 1234567_SDE to 
expand the project.  See the first image below. 

• Verify alignment SV64A has a red block  around it.  See the second image below.  
This indicates which alignment is the active alignment. 

• If alignment SV64A is not the active alignment, make it the active alignment  - 
highlight alignment SV64A, right mouse click over it and select Set Active. 
 
                                    

 
 
                                    
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Alignment SV64A  is set to be the active alignment. 

18.  Open the Traverse command. 
 

• Select Geometry ► Traverse… 
• The Traverse dialog box opens as shown in Figure L13-10. 

 
The Traverse command is opened. 

 

InRoads Explorer Window 

Click the ‘+’ sign to 
expand the 
1234567_SDE 
project. 

InRoads Explorer Window 

Verify that SV64A has a 
red block around it.  This 
indicates that SV64A is 
the active alignment. 
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Figure L13-10 Traverse command 

 
 

19.  Set method in Traverse command to Direction. 
 

• Click the Direction radio button as shown here. 
 

 
 
The Traverse command method is set. 

20.  Set the Insert Point Mode in the Traverse command to After Alignment. 
 

• Click the After Alignment radio button as shown here. 
 

   
 
The Traverse Insert Point Mode method is set. 

After Alignment 
Button 

Direction Button 

*IMPORANT:  Notice 
‘Slope Distance’ and 
‘Horizontal Distance’ 
are both possible 
selections.  Ensure the 
correct selection is 
made before clicking 
Apply. 
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21.  Select Occupied Point in the Traverse Command. 
 

• From the InRoads Menu -- Select Tools ► Locks and verify that Point Snap has 
a check mark next to it.  This lock allows you to Snap to points that are contained 
in InRoads. 

• Click the Locate button in the Traverse command Occupied Point frame. 
 
 

             
 
 
 

• In MicroStation, notice in the bottom left corner you are prompted to > Identify 
point.   

• Single left click on Point 218.  See previous screen capture in Figure L13-8 for 
Location of Point 218. 

• Notice that Point 218 is highlighted with a purple hour glass as shown here:  
and that in the InRoads status bar the text ‘Select point ‘218’ confirms which text 
was selected.   
 

• Also notice, in MicroStation, in the bottom left corner you are prompted to > 
Accept/Reject.   

• In MicroStation, left click on a blank portion of the screen to accept. 
• The Traverse command dialog reopens with Point 218 in the Occupied Point 

field. 
• Verify that yours settings match those shown below. 

 
 

 
   

The Occupied Point is selected. 

Locate Button 
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22.  Define Course in the Traverse Command. 
 

• In the Course frame of the Traverse command dialog box enter the bearing and 
horizontal distance from the deed description on the first page, as shown here. 
 
 

 
 
 
 
 

The course is entered. 
23.  Set the Style in the Foresight Point field. 

 
• In the Foresight Point frame of the Traverse command dialog enter the 

following settings. 
 

 

 
 
 
 
 
 
 
 
 
 

The Foresight Point field is set. 

*NOTE:   If the name field is left blank the 
alignment will store coordinates without a 
point name.  If a point name is entered the 
alignment coordinates will store with that 
point name or the next available point 
name.  Either way is acceptable.  You will 
be adding point names in a later step and 
converting to Cogo points as shown 
previously. 

*NOTE:   Key-in the bearing as 
follows: 
S space 16 space 50 space 6.7 space E 

*NOTE:  Key-in the Horizontal 
Distance as follows: 
188.41 
 

*NOTE:  Ensure ‘Horizontal Distance’ 
is selected from the pull down and not 
Slope Distance. 

*NOTE:  Key in the Style as follows: 
PROP_E_PPC 
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24.  Verify the settings in the Traverse command. 
 

• Refer to Figure L13-11 depicted below and verify your settings match those 
shown. 

• Click Apply but do not close the Traverse command. 
• In the Results box that opens take a moment to review it and then Close the 

Results box only. Leave the Traverse dialog box open. 
• In MicroStation, you should see the first leg of the property alignment as shown 

in Figure L13-12. 
 
The first leg of Parcel SV64A is stored. 

 
 
 

 
Figure L13-11 Traverse Command 
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Figure L13-12 MicroStation Window 

 
 
 

25.  Store the second leg of the Property Alignment SV64A on a bearing of  
S 72 58 15.5 W a distance of 212.41 feet. 
 

• In the Traverse command dialog, enter a Course Direction of S 72 58 15.5 W 
and a Horizontal Distance 212.41 feet. 

• Verify your entries match those shown below.   
 
(*NOTE: The occupied point is now the end of the first leg which was stored in 
the previous steps.  It is ok if your traverse dialog does not contain a point name 
as long as the coordinates match.  A point name will be assigned later and 
converted to a cogo point later as was done in previous labs.) 

 
 
 
 
 
 

  
 
  
 
 
 
 
 

First leg of Property 
Alignment SV64A. 
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• Click Apply. 
• Close the Results dialog box. 
• Click Close to exit the Traverse command dialog box. 
• If done correctly your view should look like that shown in Figure L13-13. 
 

 
The second leg of the property alignement is stored. 
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Figure L13-13 MicroStation Window 

 
 
26.  Examine the intersection of the Existing R/W Alignment SV2 with Property 

Alignment SV64A to verify Intersection. 
 

• In MicroStation, turn Fill OFF by selecting Settings ► View Attributes and then 
click the Fill icon to turn Fill off. 

• Window Area closely to Point 218. See Figure L13-14.   
• Observe that the first leg you stored of Alignment SV64A does not contact the 

existing R/W Alignment SV2. See Figure L13-15. 
 
The Intersection of Property Alignment SV64A and the Existing R/W Alignment SV2 is 
determined not to intersect as it should. 

 

Second leg of Parcel 
SV64A Alignment. 

SV64A 
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Figure L13-14 MicroStation Window 

 
 
 
 

 
Figure L13-15 MicroStation Window 

 
 
 
 
 
 

Window Area Here. 

SV64A Does Not 
Intersect the Existing 
R/W Alignment SV2 
as shown here. 
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27.  Reconcile Property corner of SV64A with Existing R/W of SV2 
 

• Select Geometry ► Utilities ► Extend Alignment. 
• In the lower left corner of MicroStation you are prompted to > Identify alignment 

to extend to.  .  Select the alignment (SV2) shown in 
Figure L13-16 by left clicking on it. 

• In the lower left corner of MicroStation you are now prompted to > Identify 
alignment to extend. . Select the alignment shown in 
Figure L13-16 by left clicking on it. 

• In the lower left corner of MicroStation you are now prompted to > Accept/Reject 
  the operation.  Left click somewhere in a blank part of the 

MicroStation screen to Accept. 
• Right mouse click twice over the MicroStation window to deactivate the Extend 

Alignment command.  Notice the text in the lower left corner of the MicroStation 
window as you do this. 

 
The property corner has been reconciled to the Existing R/W. 

 
 

 
Figure L13-16 MicroStation Window 

 
 
 
 
 
 
 
 
 

Alignment to Extend To. 

Alignment to Extend. 

SV64A 
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28.  Examine the intersection of the Existing R/W Alignment SV5 with Property 
Alignment SV64A to verify Intersection. 

 
• In MicroStation, select to Fit View. 
• In MicroStation, Window Area alignment SV64A as shown in Figure L13-17. 
• Verify your view resembles that shown in Figure L13-18. 
• In MicroStation, Zoom closely into the intersection of Existing R/W Alignment 

SV5 with the second leg of Property Alignment SV64A.  See Figure L13-19.  
You will notice it extends beyond the existing R/W.  
 
*Note: You must Zoom in very close to see that SV64A extends beyond SV5. 

 
The Intersection of Property Alignment SV64A and the Existing R/W Alignment SV5 is 
determined not to intersect as it should. 

 
 

 
Figure L13-17 MicroStation Window. 

 

Window Area Here. 
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Figure L13-18 MicroStation Window. 

 
 
 

 
Figure L13-19 MicroStation Window. 

 
 
 
 
 
 
 
 
 
 

Alignment SV64A extends 
beyond SV5. 

Window Area again 
at this intersection. 
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29.  Reconcile Property corner of Property Alignment SV64A with Existing R/W 
Alignment SV5. 
 

• Select Geometry ► Utilities ► Trim Alignment. 
• In the lower left corner of MicroStation you are prompted to > Identify first 

clipping alignment.  .  Select the alignment identified 
as ‘First Clipping Alignment’ as shown in Figure L13-20 by left clicking on it.  It 
will turn purple. 
*Note: The order the alignments are selected is not important when using the 
Trim command. The alignment identified as first clipping alignment could easily 
have been the second clipping alignment.  

• In the lower left corner of MicroStation you are now prompted to > Identify 
second clipping alignment. . Select the alignment 
identified as ‘Second Clipping Alignment’ as shown in Figure L13-20 by left 
clicking on it.  It will turn purple. 

• In the lower left corner of MicroStation you are now prompted to > Identify 
portion to clip. .  Left click somewhere on the portion of 
SV64A  that extends beyond SV5 as shown here. 
 

 
 

• In the lower left corner of MicroStation you are now prompted to > 
Accept/Reject. .  Left click somewhere in a blank part of the 
MicroStation screen to Accept. 

• Right mouse click over the MicroStation window to deactivate the Trim 
Alignment command.  Notice the text in the lower left corner of the MicroStation 
window as you do this. 

 
The property corner has been reconciled to the Existing R/W. 

 

Portion to clip. 
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Figure L13-20 MicroStation Window 

 
 

30.  At this time you are ready to add Leg 3 to Property Alignment SV64A.  For this leg 
you do not need to create a new point.  Instead you want to make use of the points 
that already exist along Existing R/W Alignment SV5.  In this case Pt. 44. 
 

• In MicroStation, Zoom to the extents shown below. 
 

             
 
 
 
 
 
 
 
 

In the following steps -- when selected -- 
the point will highlight in purple with an 
hourglass shaped figure.  If the purple 
hourglass does not show it is because the 
Point Snap lock is not engaged. 

First clipping Alignment 

Second clipping Alignment 

Zoom to the extents shown here. 

Pt.44 
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• Select Geometry ► Utilities ► Create/Edit Alignment by Cogo Points. 
 
*NOTE: If the error message below appears, Click Yes.  This assigns names to 
the coordinates in the alignment that do not contain names in the same manner 
that using the Assign Name command does which we have used in previous 
lessons.  This command requires Point Names to be associated with the 
coordinates before it will work.  We will convert these alignment points to cogo 
points in a later step. 
 

 
 

• The Create/Edit Alignment by Cogo Points dialog box opens as shown here. 
 

 
 
 
 

Actual Point Numbers 
may differ. 
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• Key-in 44 in the ‘Alignment Definition’ field as shown below. 

 

 
 
 
 

• Click Apply and Close. 
• Leg 3 has been added to Property alignment SV64A. 

          
 
 
 
The third leg of Property Alignment SV64A is stored. 

Key-in 44 here. 
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31.  Define the next leg in the Property Alignment SV64A which is an arc. 
 

• In InRoads, Select Geometry ► Traverse 
• In the Traverse command dialog box set the Method to Curve and the  Insert 

Point Mode to After Alignment. 
• Use the Locate button in the Occupied Point frame to select Point 44 as shown 

here by left clicking once on the point. 

             
 

• In the lower left corner of the MicroStation view window you will be prompted to 
> Accept/Reject  the point.  Left click to Accept the point.  The 
Traverse command dialog will reopen and the Occupied Point frame will be 
populated as shown below.  

 

            
 

• In the Course frame use the pulldown arrow to set the first selection to Chord. 
(This field will be for the bearing of the chord). 

• Use the Locate button ( ) to define the Chord bearing by left clicking once on 
the Point 44 and then Point 48 as shown here. 
 

When selected the point will highlight in 
purple with an hourglass shaped figure. 
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• Verify that the Chord bearing is N 12^10'54.1" W. 
 
*NOTE:  Do not manually key-in the bearing or the computed coordinates of the 
PT. These may not sufficiently match the coordinates of Point 48.  This will 
result in a separate point being stored for the PT.  Always use the locate button to 
define bearings, distances, radius’s, etc.  when matching existing data. 
 

• In the Course frame use the pull down arrow to set the second selection to Chord 
also.  This field will define the length of the Chord. 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

*NOTE: When using the left click button to 
select the points to define the distance  the 
points do not highlight with the purple hour 
glass shape as when using the locate button to 
left click for the Occupied point.  You can tell 
that a point has been selected by moving your 
mouse around after clicking the first point.  
When doing this you will see a line defining 
the distance.  Also, look in the MicroStation 
status bar for information. 

Pt.44 

Pt.48 

Second Selection 

Third Selection 

First Selection 
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• Use the Locate button to define the Chord Length in the same manner as above 
(by using the Locate button to select points 44 and 48). 

• Verify that the Chord Length entry field is populated with the value 217.351. 
• In the Course frame use the pull down arrow to set the third selection to Radius. 
• Before continuing we must change the Snap Lock from Point Snap to Element 

Snap.  
- Select Tools ► Locks and make sure that Element Snap has a check 

mark next to it. 
• Now click the Locate button next to the Radius entry field. 
• In MicroStation, left click on the Curve between points 44 and 48. 
• The Traverse command should re-emerge with the Radius value entered.  Verify 

the value showing is 1105.916. 
*NOTE:  Do not manually key-in the value for the same reason as stated above. 
If the value does not match, continue using the Locate button until the value is 
correct.   

• Verify that the Radius entry field is populated with the value 1105.916. 
• In the Foresight Point frame set the Style to PROP_E_RWE.  We are using 

PROP_E_RWE rather than PROP_E_PPC because Point 48 already exists and 
we want to eventually use that point rather then creating a new point for the same 
location. 

• In the Foresight Point frame clear out (remove) the Name and leave the Name 
field empty. 
 
  *IMPORTANT:  The reason for the above step is to ensure we make use of 
Point 48 and not create a new Point at the same location.  Leaving the Name field 
blank will store coordinates without assigning a name.  This will allow us to make 
use of the ‘Check for Coincedent Point’ option when we use the Assign Names 
command in a later step.  This is an important concept to remember. 
 

• Verify that all settings in the Traverse command dialog match those shown in 
Figure L13-21. 

• In the Traverse command dialog, Click Apply but DO NOT CLOSE  the 
Traverse command. 

• If a Results dialog box appears – review the data and then click Close to close out 
of the Results dialog box. 

• DO NOT CLOSE out of the Traverse command. 
• Verify that the arc highlighted in Yellow in Figure L13-22 was drawn in 

MicroStation. 
 

The arc is added to Property Alignment SV64A. 
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Figure L13-21 Traverse Command Dialog box 

 
 
 

        
Figure L13-22 MicroStation Window 
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32.  Close the Property Alignment SV64A. 
• In the Traverse command window change the ‘Method’ to  Direction .

 
• Click the Close Traverse  button in the bottom right hand corner of 

the dialog box. 
• If a Results Report appears – review the data and then Close the Results 

window that opens. 
• Close the Traverse command.   

 
Closes the property Alignment SV64A. 

33.  Review Alignment SV64A 
 

• Select Geometry ► Review Horizontal… The Review Horizontal Alignment 
results window opens as shown in Figure L13-23. 

• Verify that SV64A is shown in the ‘Horizontal Alignment’ field. 
 

                    
 

• Notice that a point name may be missing from the PT of one of the curves.   If 
yours does that is OK.  Perform the next steps anyway.  In InRoads we need to 
have point names assigned for each of the PC’s and PT’s and also for the stand 
alone PI’s (meaning PI’s not in curves.  PI’s in curves do not need names) and 
POB’s (Point of Beginning) and POE’s (Point of Ending).   

• Click Close to close out of the Review Horizontal Alignment Report. 
 

Alignment SV64A is Reviewed 
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Figure L13-23 Review Horizontal Alignment 

 

Point Names may be 
missing.  If point names 
exist follow the 
remaining steps anyway. 

*NOTE: Individual Point 
Names may differ depending 
on how you performed steps. 
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34.  Assign Names to Points in SV64A 
 

• Select Geometry ► Utilities ► Assign Names… 
• In the Assign Names dialog box that opens set the ‘Include’ option to 

Alignments’.   
 
 
 
Check Assign as the ‘Method’.  
 
 
 
Place a Check Mark next to the Check for Coincident Points. 

 
 

• Key-in SV64A in the Name entry field and then Left Click in the Selected field .  
You may also use the Locate button to populate the field. 

• Leave all other settings as Default and verify the rest of your settings match those 
shown in Figure L13-24. 

• Click Apply & Close. 
 
All coordinates in SV64A are assigned names.  

 
 

 
Figure L13-24 Assign Names 
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35.  Review Alignment SV64A 
 

• Select Geometry ► Review Horizontal… The Review Horizontal Alignment 
results window opens as shown in Figure L13-25. 

• Verify that SV64A is shown in the Horizontal Alignment field. 
 

                    
 

• Notice that all the points now have names associated with them. 
• Notice also that the beginning point and ending point have the same point name.  

This confirms that the alignment is a closed alignment. 
• You should also see points 44 and 48 in the alignment.  This confirms that points 

from SV5 were reused rather than new points stored to represent the same 
location. 

• Click Close to close out of the Review Horizontal Alignment Report. 
 
Alignment SV64A is Reviewed 
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Figure L13-25 Review Horizontal Alignment 
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36.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: Although point names (Alignment Points) and some COGO points 
now exist in alignment SV64A for the PI’s, PC’s and PT’s the Alignment points don’t 
actually exist as COGO Points in the COGO Buffer.  In order to properly display the 
points in MicroStation and for the proper delivery of enhancements during the life of the 
project the Alignment points must be converted to COGO Points and assigned the proper 
feature style. 
 

• Verify that SV64A is the Active alignment. A red square  must be around 
SV64A. If it does not have a Red Square - highlight Alignment SV64A, right 
mouse click over it and select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_PPC 
o Accept all other defaults. 

• Click Apply.  A results report opens showing all points that are now COGO 
points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
* NOTE:  Cogo Points are only assigned to Alignment Points for the active 
alignment.  The process must be repeated for each alignment. 

 
 

37.  Save the InRoads Geometry File 
 
Even though the Alignment has been stored – the data has not yet been saved. Save the 
project and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will be saved to Lab 13 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab13 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab13 
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38.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
 
Deletes the Graphics from the GDOT 3D Working File.dgn to ensure a clean DGN file 
for the next Lab. 

39.                    
                 This concludes Lab 13.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 14 
Store Property by Angle and Create/Edit 

Alignment by Cogo Points  
 
Objective 
 
Storing property from Deeds. 
 
The objective of Lab 14 is to: 
 

• Learn techniques to store property information from deeds into InRoads using the 
Traverse by Angles command and the Create/Edit Alignment by Cogo Points command. 

• The following deed and information will be used. 
 

Beginning at point 236; running thence S 17°09'55.8" W a distance of 199.80 feet; thence N 72°50'04.2" 
W a distance of 225.00 feet; thence N 16°50'09.9" W a distance of 53.53 feet; thence N 16°50'06.7" W a 
distance of 188.41 feet; thence S 72°42'40.9" E a distance of 360.30 feet back to the point of beginning. 
Containing 1.344 acres more or less. 
 

 
 
 

 
 
  

Parcel 62 

Parcel 64A 
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Lab 14A Getting Started 
 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Graphics (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard.   

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

4.  Verify Project Defaults 
• In InRoads select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_SDE which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L14-1. 
• Click Apply & Close. 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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Figure L14-1 Project Defaults 

 
 
 
 
 
 

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
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5.  Load the InRoads Geometry file (1234567_SDE.alg file) 
• Select File ► Open from the InRoads Menu. 

 
• Browse to the following path: 

C:\InRoads Data\1234567\SDE Labs\Lab14 
 
Select the file named: 1234567_SDE.alg 
 

• Click Open and then click Cancel. 
 

Opens the 1234567_SDE.alg file 
6.  Set Survey Default Preferences 

 
• In InRoads  - Select File Project Options. 
• In the Project Options dialog box select the General Tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Survey Default.  Click Load and Close. 
• In the Project Options dialog box - Click Apply and Close. 

 
Sets the Survey Defaults Preference. 

7.  Set the View Horizontal Annotation and Cogo Points view settings. 
 

• Select Geometry ► View Geometry ► Horizontal Annotation.  The View 
Horizontal Annotation dialog opens as shown in Figure L14-2. 

• Click the Preferences Button.  The Preferences dialog opens as shown in Figure 
L14-3. 

• In the Preferences dialog highlight NO BEARING & DISTANCE. 
• Click Load and Close.  This loads the viewing preference settings into the View 

Horizontal Annotation dialog box. 
• The inputs should now correspond to the screen capture depicted in Figure L14-4. 

 
The settings in the View Horizontal Annotation are set.  This will ensure that the proper 
symbology is applied to the Cogo points and alignments in MicroStation. 

 
 

Hint:  You may also right mouse 
click over ‘Geometry Projects’ in 
the Workspace Bar and select 
open. 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 14 
 

   
 Lab14-5   

                                                     
Figure L14-3   Preferences       

Figure L14-2 View Horizontal Alignments 
 
 

Preferences Button 
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Figure L14-4 View Horizontal Alignments 

 
8.  Now that we have set the proper view settings in the View Horizontal Annotation 

dialog we will select the Alignments and Cogo Points to view. 
 

• Notice in the View Horizontal Annotation dialog that the Filter button is grayed 
out.  

• Activate the Filter button by placing your cursor in the ‘Horizontal Alignments’ 
“Include” field and click the Filter button.  The Geometry Selection Filter opens 
as shown here. 

                     
 

Filter button 
Shown 
grayed out. 

Place cursor here to 
activate the Filter 
button for the Cogo 
Points. 

Place cursor here to 
activate the Filter button 
for the Horizontal 
Alignments. 
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•  Click the All button in the Geometry Selection Filter to move all Alignments 

from the Available field to the Selected field as shown here. 

                            
• Click OK. 
• The Selected Alignments are entered into the View Horizontal Annotation 

dialog as shown here. 

                                   
• Place your cursor in the Cogo Points ‘Include’ field to activate the Filter button 

for the Cogo points and click the Filter button.  The Geometry Selection Filter 
dialog opens again.  This time with the Cogo Points in the ‘Available’ field as 
shown here. 
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• For this Lab we are only going to view Cogo Points with the Feature Style 
PROP_E_PCF,PROP_E_PPC, & PROP_E_RWE. 

• Set the Style to Included by using the pull down menu.  This activates the Style 
key-in field. 

• In the Style key-in field enter PROP_E_PCF, PROP_E_PPC, PROP_E_RWE 
and Left click in the ‘Available’ field to recognize the entry. (This filters the 
points in the ‘Available’ field to only show those points with the Feature Styles 
PROP_E_PCF, PROP_E_PPC and PROP_E_RWE). 
        
 

        
 
 

• Click the All button to move the Filtered points from the ‘Available’ field to the 
‘Selected’ field. 

• Take a moment to scroll through the points listed in the ‘Selected’ field to verify 
only those points with either a PROP_E_PCF,PROP_E_PPC or 
PROP_E_RWE Feature Style are listed. 

• Click OK.  The Filtered points are entered in the View Horizontal Annotation 
dialog Cogo Points ‘Include’ field as shown below. 
 

 

Key-in: 
PROP_E_PCF,PROP_E_PPC,
PROP_E_RWE 
 
*REMEMBER: InRoads is 
Case sensitive. 
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• Click Apply and Close in the View Horizontal Annotation dialog.  Please be 
patient while the alignments and points are viewed. 

• In MicroStation, click the Fit View Icon. 
            

                                         
                                                                       Fit View Icon 
 

• Ensure that your view in MicroStation resembles that shown in Figure L14-5. 
 

9.  Zoom into Parcel Alignment SV64A and the general area where the next Parcel 
Alignment, SV62, will be stored. 
 

• In MicroStation, select the Window Area Icon and zoom into the area shown in 
Figure L14-5 by using the Window Area Icon.            
 

               
                                                      Window Area Icon        

• Verify that your view resembles that shown in Figure L14-6.  (*NOTE: Pt.236 is 
identified for use in a future step.) 

 
Zooms into the MicroStation Window. 
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Figure L14-5 MicroStation View Window 

 
 

 
Figure L14-6 MicroStation View Window 

 
 
 
 

Window area as 
shown here. 

Pt.236 
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10.  Create Parcel Alignment SV62. 
 

• Select File ► New. ( The New dialog box opens.) 
• Select the Geometry tab. 
• In the New dialog, enter: 

o Type: Horizontal Alignment 
o Name: SV62 (*REMEMBER: All alignments stored by the Surveyor or SDE 

shall begin with the prefix SV as opposed to COGO Points 
which shall not be given a prefix.) 

o Description: PAR 62 TM #49 PARTRIDGE 
o Style: PROP_E_PAR 
o Curve Definition: Arc 

• Click Apply and Close. 
• Parcel SV62 is added to the InRoads Explorer window 

and made the Active Alignment as shown  
here. 
 

 
 
 
 
 
Alignment SV62 is created and made the Active Alignment. 

11.  Open the Traverse command. 
 

• Select Geometry ► Traverse… ( The Traverse dialog box opens). 
 

 
 
The Traverse command dialog box opens. 

InRoads Explorer Window 

Alignment SV62 shown as 
the active alignment.  (i.e. 
with a red box around it.) 
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12.  Set the Method in the Traverse command to Angle. 
 

• Click the Angle radio button as shown here. 
 

                                              
 
 
 
The Traverse command Method is set to ‘Angle’. 

13.  Set the Insert Point Mode in the Traverse command to After Alignment. 
 

• Click the After Alignment radio button as shown here. 
 

  
 
The Traverse command Insert Point Mode is set to ‘After Alignment’. 

14.  Change Lock to Element Snap. 
 

• Before continuing, we must change the Lock setting to Element Snap.  This will 
allow the user to use the Locate button to determine the direction/bearing by 
clicking on the element. 

• Select Tools ► Locks ► Element Snap.  Verify that a check mark now displays 
next to Element Snap as shown here. 

 
 
 
 
 
 
 
 

• You should also see this icon ( )   in the InRoads Toolbar indicating that 
Element Snap is the active InRoads snap setting.   

 

 
InRoads Toolbar 

 
The Lock setting is changed to Element Snap. 

Angle Button 

After Alignment 
Button 

Verify that a check mark 
displays next to Element 
Snap. 
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15.  Set the Backsight mode to Direction and define the Backsight Direction to be the 
direction of the existing R/W. 
 

• Click the Direction radio button as shown here. 
 

  
 

• Now Left Click the Locate button next to the ‘Direction’ field.  (The Traverse 
command will disappear.) 

• You are now prompted in the lower left corner of the MicroStation Window to      
‘ > Identify element’  .  Look for the prompt in 
MicroStation.   

• Left Click on the line shown in Figure L14-7. 
• The Traverse command will reappear with the bearing entered into the 

‘Direction’ Field.  Verify your bearing matches that shown here. 
 

 
 

The required Backsight information is entered. 
 
 

 
Figure L14-7 MicroStation Window. 

 

Direction Button 

Locate Button 

Left Click on this line 
to obtain its Direction. 

Left Click on Pt.236 to 
set the occupied point. 
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16.  Select the Occupied Point to be Point 236. 
 

• Before continuing, the InRoads Lock setting must be changed to Point Snap. 
This will allow the user to use the Locate button to graphically select InRoads 
points viewed in the MicroStation window. 

• Select Tools ► Locks ► Point Snap.  Verify that a Check mark now 
displays next to Point Snap as shown here.   

 
 
 
 
 
 
 
 

You should also see this symbol ( )   in the InRoads Toolbar indicating that 
Point Snap is the active InRoads snap setting.   
 

 
InRoads Toolbar 

 
• Click the Locate button in the ‘Occupied Point’ frame and left click on Point 

236. The point highlights with a purple hourglass as shown here.   
• Notice in the Bottom Left corner of the MicroStation window that when you 

click on a point, the point name is shown and you are prompted to accept or 
reject as shown below.  If the point shown is not the point you want, right 
mouse click and the next closest point will be selected or you will be 
prompted to identify another point if there is no other point in the vicinity. 
 

                              
 

• Left click anywhere on a blank part of the MicroStation view when Point 236 
is selected to accept the entry. 

• The Traverse command dialog box reopens. 
• Verify the settings in the ‘Occupied Point’ frame of the dialog box match 

those shown here. 
 
 

 
 
 
 
 
 
The required Occupied Point information is entered. 

Verify that a check mark 
displays next to Point 
Snap. 
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17.  Set the style in the Foresight Point to be PROP_E_PPC (Property Point Computed). 
 

• In the ‘Foresight Point’ frame (this is the point that will be stored) notice that a 
Point Name is entered for you.  You may either accept this entry or leave the 
field blank. 

• In the ‘Style’ field use the Pulldown arrow to select PROP_E_PPC as the style. 
• Verify your settings match those shown here. (Your point name may not be the 

same.  This is OK.) 
 

 
 

The Foresight Point style is set. 
18.  Enter Course information 

 
• In the ‘Course’ frame enter the information as shown here.  This information 

comes from the deed and drawing on the 1st page of this Lab. 
 

           
 
You have entered the Course information from the deed and drawing depicted on pg.14-1 

19.  Click Apply in the Traverse command. 
 

• Click Apply.  
• Take a moment to review the data in the Results box that opens and then Close it. 
• Verify that the first leg of Alignment SV62 was drawn in MicroStation as shown 

in Figure L14-8. 
• Click Close to exit the Traverse command. 

 
You have added the first leg of the Parcel to Alignment SV62. 

 

*IMPORTANT:  The Angle 
is always measured from the 
foresight point to the backsight 
point.  (Enter it as 89 52 36.68) 

*IMPORTANT:  Ensure 
Horizontal Distance is selected 
from the pull down menu and 
not Slope Distance. 
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Figure L14-8 MicroStation Window. 

 
 
 
 
 
 
20.  Review Alignment SV62 

 
• Select Geometry ► Review Horizontal… The Review Horizontal Alignment 

results window opens as shown here. 
 

 
 

• Notice that the Alignment at this point contains two points -- 236 and 46.  Point 
236 is a Cogo point picked up during field survey and Point 46 is an alignment 
point that will have to be converted to a Cogo point in a later step. 

• Click Close to close the Review Horizontal Alignment Report. 
 

Review Alignment SV62. 

First leg of 
parcel SV62. 
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21.  Even though the first leg of the parcel you just added to the alignment appears to 
intersect with the Existing R/W line it does not.  If you were to zoom in very close 
you would find that they don’t actually intersect.  This must be reconciled by 
extending or triming to the Existing R/W. 
 

• In MicroStation, turn Fill OFF by selecting Settings ► View Attributes and then 
click the Fill icon to turn Fill off. 

• In MicroStation, Zoom in closely to Point 236 and you will see that the first leg 
you stored of alignment SV62 extends beyond the existing R/W as shown in 
Figure L14-9.  We will trim this alignment. 

• Select Geometry ► Utilities ► Trim Alignment.  
• In the lower left corner of MicroStation you are prompted to > Identify first 

clipping alignment.  .  Select the alignment shown in 
Figure L14-9  by left clicking on it.  It will turn purple. 

• In the lower left corner of MicroStation you are now prompted to > Identify 
second clipping alignment. . Select the alignment 
shown in Figure L14-9  by left clicking on it.  It will turn purple. 

• In the lower left corner of MicroStation you are now prompted to > Identify 
portion to clip. .  Left click on the portion to clip 
identified in Figure L14-9. 

• In the lower left corner of MicroStation you are now prompted to > 
Accept/Reject.  .  Left click in a blank portion of the 
MicroStation Window to accept the operation. 

• Right mouse click once over the MicroStation window to deactivate the Trim 
Alignment command.   
 

Alignment SV62 has been extended or trimmed at the existing R/W. 
 

 
Figure L14-9 MicroStation Window 

Parcel Alignment SV62 extends beyond 
the existing R/W alignment SV2. 

Second clipping alignment. 
 
First clipping alignment. 

Portion to clip. 
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22.  Review Alignment SV62 Again. 
 

• Select Geometry ► Review Horizontal… The Review Horizontal Alignment 
results window opens as shown here. 
 
 

 
 

• Notice that the alignment no longer begins with Point 236 and that it now has a 
POB with coordinates but no Point Number.  This is because the Alignment has 
been trimmed. 

• Click Close to close the Review Horizontal Alignment Report. 
 

 
Review Alignment SV62. 

23.  Assign Names to Alignment SV62. 
 

• Select Geometry ► Utilities ► Assign Names…   
• In the Assign Names dialog box that opens set the Include radio button to 

‘Alignments’.   
 
 
 
 
Check the Assign radio button  
as the ‘Method’.  
 
 
Check the option to ‘Check for Coincident Points’.  
 
 

• Key-in SV62 in the ‘Name’ entry field.  You may also use the Locate button to 
populate the field. 

• Verify the rest of your settings match those shown in Figure L14-10. 
• Click Apply & Close. 

 
 

Assign Names to to Alignment SV62. 
 

Notice no Point number 
exists for the POB. 
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Figure L14-10 Assign Names Dialog 

 
 
 
 
 
 
 
 
 
 
 
24.  Review Alignment SV62 Again. 

 
• Select Geometry ► Review Horizontal… The Review Horizontal Alignment 

results window opens as shown here. 

 
 

• Notice that Alignment SV62 now begins with a Point named 49. 
• Click Close to close the Review Horizontal Alignment Report. 

 
 
Review Alignment SV62. 
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25.  View New Points 
 

• Select Geometry ► View Geometry ► Horizontal Annotation… to open the 
View Horizontal Annotation dialog box. 

• Notice in the View Horizontal Annotation dialog box that the Filter button is 
grayed out.  

• Activate the Filter button by placing your cursor in the ‘Horizontal Alignments’ 
“Include” field and click the Filter button.  The Geometry Selection Filter opens 
as shown here. 

                       

                  
 

•  Click the Swap button in the Geometry Selection Filter to move all Alignments 
from the Selected field to the Available field AND to move the Alignment of 
SV62 from the ‘Available’ field to the ‘Selected’ field as shown below. 

 
 
 
 
 
 
 
             
 
 
 
 
 
                
 

 
 
 
 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 14 
 

   
 Lab14-21   

C 
 
 
 
 
 
 
 
 
 
 
 
 

• Click OK. 
• The Selected Alignment of SV62 is entered into the View Horizontal 

Annotation dialog as shown here. 
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• Place your cursor in the Cogo Points ‘Include’ field to activate the Filter button 

for the Cogo points and click the Filter button.  The Geometry Selection Filter 
dialog opens again with the Cogo Points in the ‘Available’ and ‘Selected’ field as 
shown here. 
 

                   
   
                             

• Click the None button to move the Filtered points from the ‘Selected’ field back 
to the ‘Available’ field as depicted below. 

 

                   
 
 

• Click OK.  The Filtered points are now removed from the View Horizontal 
Annotation dialog Cogo Points ‘Include’ field. 
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• Important Step – Ensure to place a check mark in the Display frame to include 

On-Alignment points 
• Verify your dialog matches that shown in Figure L14-11.           
• Click Apply & Close. 
• Verify your MicroStation View matches that shown in Figure L14-12.           

 
*IMPORTANT:  Viewing alignments with the ‘On-Alignment’ check button 
checked views the points in the alignment (49 & 46 in this case) on the active level 
in MicroStation and not the points correct symbology (level, font, text size, line 
weight, line style, color, etc).  To view the point’s correct symbology the ‘On-
Alignment’ check button must be unchecked and the Cogo points must be selected 
and viewed.  Since we have not yet converted the Alignment Points to Cogo Points 
at this stage we cannot do this at this time.  This is an adequate method of 
temporarily viewing the point names during the SDE’s input of alignments.  During 
the creation of the final MicroStation DGN file for delivery to the designer the ‘On-
Alignment’ check button must be unchecked and the Cogo Points must be selected 
and viewed. 

 
 

 
Figure L14-11 View Horizontal Annotation 

*IMPORTANT:  Viewing alignments with the 
‘On-Alignment’ check button checked views the 
points on the active level in MicroStation and not 
the points correct symbology (level, font, text size, 
line weight, line style, color, etc).  To view the 
point’s correct symbology the ‘On-Alignment’ 
check button must be unchecked and the Cogo 
points must be selected and viewed.  Since we 
have not yet converted the Alignment Points to 
Cogo Points at this stage we cannot do this at this 
time.  This is an adequate method of temporarily 
viewing the point names during the SDE’s input of 
alignments.  During the creation of the final 
MicroStation DGN file for delivery to the designer 
the ‘On-Alignment’ check button must be 
unchecked and the Cogo Points must be selected 
and viewed. 
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Figure L14-12 MicroStation Window 

 
 
 
26.  Continue storing the rest of Parcel SV62. 

 
• Begin by returning to the MicroStation view shown in Figure L14-12 (depicted 

above).  This may be accomplished in MicroStation by using the Fit View icon 
and the Window Area icon or by using the View Previous icon until the view 
returns. 
 

             
            
                    Window Area       Fit View                View Previous 

 
• In InRoads -- Select Geometry ►Traverse.. 
• Check the radio button to set the Method to Angle. 

 

             
 
The Traverse Method is set. 

Pt.49 

Pt.46 
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27.  Set Insert Point Mode. 
 

• Check the radio button under Insert Point Mode to After Alignment. 
 

 
 

The Traverse Insert Point Mode is set. 
28.  Set the Backsight point 

 
• Set the Backsight frame to Point. 

 

 
 

• Set the InRoads Snap funtion to Point Snap by selecting Tools ► Locks and 
ensuring a check mark exists next to Point Snap. 

• Click the Locate button next to the Backsight entry field. 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

> Identify Point.   
• Left Click on Point 49 located where SV62 intersects the existing R/W as shown 

in Figure L14-13 and identified as Backsight Point = Pt 49.  It highlights with a 
purple hour glass.  . 

• Notice in the bottom left corner of the MicroStation window you are prompted to 
>Accept /Reject      Selected Point’49’.  
 

 
 

 *DISCUSSION:  If we had not run the Assign Names command in Step 23 
we would not have been able to properly identify Point 49 for this step. 
 

• Left Click on a blank part of the screen to Accept the point.  The Backsight point 
is set as shown here. (Please Note: Your greyed out Direction bearing may be 
different from the screen capture below. This is OK). 

            
The Backsight Point is set. 

Locate Button 
 

Set Backsight 
method to Point. 
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Figure L14-13 MicroStation Window 

 
 
 
 

29.  Set Foresight Point Style. 
 

• In the Forsight Point Style frame use the pulldown to select PROP_E_PPC as 
shown here. 
 

 
 
*IMPORTANT: When the Traverse commands ‘Insert Point Mode’ is set to 
‘Before Alignment’, ‘After Alignment’ or ‘Radial’,  InRoads only adds the 
required coordinates to the alignment.  An Alignment Point name is assigned to 
the coordinates in the alignment if the ‘Foresight Point Name’ field has a 
number entered. If no number is entered, a name is not assigned to the coordinate 
and must be added later using the ‘Assign Name’ command.    
 

 

Backsight 
Point = Pt 49

 
  

 

Occupied 
Point = Pt 46
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30.  Select the Occupied Point. 
 

• In the ‘Occupied Point’ frame -- left click on the Locate button. 
 

 
 

• Notice in the bottom left corner of the MicroStation window you are prompted to 
> Identify Point.  . 

• Left Click on the point identified in Figure L14-13 as Occupied Point = Pt 46.  It 
will highlight with a purple hourglass.  . 

• Notice in the bottom left corner of the MicroStation window you are prompted to 
> Accept/Reject   Selected point ‘46’.  
 

 
 

• Left Click on a blank part of the screen to accept the entry. 
 
The Occupied Point is set. 

31.  Enter the Course Angle and Horizontal Distance 
 

• In the Course frame enter the information as shown here.  This information 
comes from the Deed and Drawing on the 1st page of the Lab. 
 

 
 

• Click Apply and a Results Report will appear. Close the Results Report. 
• Verify the leg you stored matches that shown below. 

Locate Button 

Note: Course Angles are 
measured clockwise. 
(Enter it as 270 00 00) 
 

Ensure Horizontal Distance is 
selected from the pulldown menu. 
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• Do not click the Close Traverse button but do Click Close to close the Traverse 
command.  If you inadvertently click the Close Traverse button you may click 
the Undo button to undo the action you performed by mistake. 

 
You have added the second leg of the Parcel Alignment. 

32.  View New Points 
 

• Select Geometry ► View Geometry ► Horizontal Annotation… 
• Type in SV62 in the ‘Horizontal Alignments’ “Include” field and then select the 

<TAB> key on the computer keyboard.   
• Match the settings shown in Figure L14-14. 
• Click Apply & Close. 
• Verify your MicroStation view matches that shown in Figure L14-15. 

 
 

 
Figure L14-14 View Horizontal Annotation 

This leg should have been 
stored. 

*IMPORTANT:  As stated earlier…Viewing 
alignments with the ‘On-Alignment’ check button 
checked views the points on the active level in 
MicroStation and not the points correct symbology 
(level, font, text size, line weight, line style, color, 
etc).  To view the point’s correct symbology the 
‘On-Alignment’ check button must be unchecked 
and the Cogo points must be selected and viewed.  
Since we have not yet converted the Alignment 
Points to Cogo Points at this stage we cannot do 
this at this time.  This is an adequate method of 
temporarily viewing the point names during the 
SDE’s input of alignments.  During the creation of 
the final MicroStation DGN file for delivery to the 
designer the ‘On-Alignment’ check button must be 
unchecked and the Cogo Points must be selected 
and viewed. 
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Figure L14-15 MicroStation Window 

 
 
33.  To complete Alignment SV62 we will employ the command Create/Edit Alignment 

by Cogo Points.  Although this command’s name implies that it only works for Cogo 
Points it actually works for Alignment Points as well. 
 

• Select Geometry ► Utilities ► Create/Edit Alignment by Cogo Points… 
If the message shown here pops up, click Yes.  If not continue on with Step 33. 
 

 
 
This message may pop up because there is a coordinate in the alignment that does 
not have a point name associated with it.  This message can be avoided by 
assigning a name to the point prior to running this command using the  
Geometry ► Utilities ► Assign Names command. 
 
 
 
 

Pt. 50 

Pt. 38 

Pt. 37 
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• The Create/Edit Alignment by Cogo Points dialog box opens as shown here. 
 

  
 

• Verify that Alignment SV62 is in the Name: field. 
• In the Alignment Definition:  field Key-in the remaining points 38, 37 and 49 in 

the correct order to complete the Alignment. Points 37 and 38 were stored in the 
previous lab when Parcel Alignment SV64A was created and point 49 was 
created earlier in this lab during Step 23 when we assigned names. 

• Verify that your entry matches that shown below. 
 

  
 

• Click Apply and Close. 

The alignment is populated 
with the current points 
composing the alignment. 

Use the Pull Down arrow if 
necessary to make SV62 the 
alignment. 

Key-in the remaining points 
38 37 49 
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• Verify that your view in MicroStation matches that shown here with the new 
Alignment SV62 complete. 
               

 
 

• Select Geometry ► Review Horizontal. Take a moment to review Alignment 
SV62. 

 
 

• Click Close to close the report. 
 
You have completed storing Parcel Alignment SV62. 

Parcel Alignment SV62 
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34.  Create COGO Points of all Alignment Points. 
 
 
* IMPORTANT: Although point names (Alignment Points) and some COGO points 
now exist in Alignment SV62 for the PI’s POB’s and POE’s the Alignment points don’t 
actually exist as COGO Points in the COGO Buffer.  In order to properly display the 
points in MicroStation and for the proper delivery of enhancements during the life of the 
project the Alignment points must be converted to COGO Points and assigned the proper 
feature style. 
 
 
 

• Verify that SV62 is the Active Alignment. A red square  must be around SV62. If 
it does not have a Red Square - highlight alignment SV62, right mouse click over 
it and select Set Active. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog: 

o Check the Alignment Point to Cogo radio button. 
o Set the style to PROP_E_PPC 
o Accept all other defaults. 

• Click Apply.  A Results Report opens showing all points that are now COGO 
points. 

• Click Close to close the results box. 
• Click Close to close the Horizontal Events Dialog.  

 
 
 

* Note:  Cogo Points are only assigned to Alignment Points for the active 
alignment.  The process must be repeated for each Alignment. 
 
 
 

Opens the Horizontal Events dialog. Converts the Alignment points stored earlier to 
COGO points and Assigns the Feature Style PROP_E_PPC 

35.  For Information Only: 
 
 
The Geometry ► Horizontal Curve Set ► Events… command used in Step 34 applies 
the same Feature Style to all Alignment Points in the Active Alignment.  To selectively 
assign a Feature Style to an individual Cogo Point -- use the Geometry ► Cogo Points 
► Edit command. 
 
 
 
Information regarding the Feature Style of Cogo Points. 
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36.  Save the InRoads Geometry File 
 
Even though the Alignments have been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will be saved to Lab 14 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab14 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
 
C:\InRoads Data\1234567\SDE Labs\Lab14 

37.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
 
Deletes the Graphics from the GDOT 3D Working File.dgn to ensure a clean DGN file 
for the next Lab. 

38.                    
                 This concludes Lab 14.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 15 
Additional Property Alignment Creation and 

Editing Commands 
 
Objective 
 
For this lab all of the Existing Centerlines, Existing R/W and Land Lot Lines have been stored 
and properly named.  Additional property information still needs to be added to the database. 
 
The objective of Lab 15 is to: 
 

• Learn techniques to store property information from deeds into InRoads continuing to use 
the ‘Traverse’ command and the ‘Create/Edit Alignment by Cogo Points’ command as 
well as the ‘Traverse Edit’ command and ‘Check Integrity’ command. 

• The deed and drawings on the next page will be used.   
 

Beginning at point 430; running thence south" 107.68 feet along the arc of a curve (said curve having a 
radius of 252.64 feet and a chord distance of 106.87 feet on a bearing of S 64^18'33.3" W) to the point 
40.00 feet left of and opposite station 29+91.54 on said construction centerline laid out for Stoffel Rd.; 
thence S 75^41'12.8 W a distance of 9.65 feet to a point 40.00 feet left of and opposite station 39+82.17 
on said construction centerline laid out for Stoffel Rd.; thence north" 237.80 feet along the arc of a curve 
(said curve having a radius of 362.08 feet and a chord distance of 233.55 feet on a bearing of N 
85^29'52.5" W) to the point 40.00 feet left of and opposite station 37+18.09 on said construction 
centerline laid out for Stoffel Rd.; thence N 66^40'57.90” W a distance of 314.16 feet to a point 40.00 feet 
left of and opposite station 34+03.93 on said construction centerline laid out for Stoffel Rd.; thence north 
118.22 feet along the arc of a curve (said curve having a radius of 1185.92 feet and a chord distance of 
118.17 feet on a bearing of N 69^32'18.5" W) to the point 40.00 feet left of and opposite station 32+89.70 
on said construction centerline laid out for Stoffel Rd.; thence N 2^34'27.6" E a distance of 392.60 feet to 
a point 422.48 feet left of and opposite station 32+15.25 on said construction centerline laid out for Stoffel 
Rd.; thence S 29^21'28.8” E a distance of 9.00 feet to a point 415.93 feet left of and opposite station 
32+19.78 on said construction centerline laid out for Stoffel Rd.; thence S 31^50'32.5” E a distance of 
50.97 feet to a point 380.94 feet left of and opposite station 32+47.28 on said construction centerline laid 
out for Stoffel Rd.; thence N 59^02'27.5” E a distance of 345.60 feet to a point 647.27 feet left of and 
opposite station 33+99.91 on said construction centerline laid out for Stoffel Rd.; thence S 30^57'32.4” E 
a distance of 762.80 feet back to the point of beginning. 
Containing 7.134 acres more or less. 
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Lab 15 Getting Started 
 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear MicroStation Screen 
 

• In MicroStation, Select Edit ► Select All.  This selects all elements in the 
MicroStation Window. 

• In MicroStation, Click the Delete icon (  ). 
 
The MicroStation Workspace is cleared of all Elements from previous labs. 

4.  Verify Project Defaults 
• In InRoads select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_SDE which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L15-1. 
• Click Apply & Close. 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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Figure L15-1 Project Defaults 

 
5.  Load the InRoads Geometry file (1234567_SDE.alg file) 

• Select File ► Open from the InRoads Menu. 
 

• Browse to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab15 
 
Select the file named: 1234567_SDE.alg 
 

• Click Open and then click Cancel. 

Hint:  You may also right mouse 
click over ‘Geometry Projects’ 
in the Workspace Bar and select 
open. 

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
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6.  Set Survey Default Preferences 
 

• In InRoads  - Select File Project Options. 
• In the Project Options dialog box select the General Tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Survey Default.  Click Load and Close. 
• In the Project Options dialog box - Click Apply and Close. 

 
Sets the Survey Defaults Preference. 

7.  Set the View Horizontal Alignments and Cogo Points view settings. 
 

• Select Geometry ► View Geometry ► Horizontal Annotation.  The View 
Horizontal Annotation dialog opens as shown in Figure L15-2. 

• Click the Preferences Button.  The Preferences dialog opens as shown in Figure 
L15-3. 

• In the Preferences dialog highlight NO BEARING & DISTANCE. 
• Click Load and Close.  This loads the viewing preference settings into the View 

Horizontal Annotation Dialog. 
• Verify your settings match those shown in Figure L15-4. 

 
The settings in the ‘View Horizontal Annotation’ are set.  This will ensure that the proper 
symbology is applied to the Cogo points and alignments in MicroStation. 

                                                                                

 
Figure L15-3     Preferences 

 
 
 
 
 
 
 
 
Figure L15-2   View Horizontal Annotation 

Preferences Button 
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Figure L15-4  View Horizontal Alignments 

 
8.  Select All Horizontal Alignments 

 
• In the View Horizontal Annotation dialog box, left click in the ‘Horizontal 

Alignments’ Include field to activate the Filter button.  See Figure L15-4. 
• Click the Filter button.  The Geometry Selection Filter dialog opens as shown 

here. 

 
 

• Click the All button to move the Available alignments to the Selected field, as 
shown below. 

Filter button. 
Shown 
grayed out. 

Place cursor here to 
activate the Filter 
button for the Cogo 
Points. 

Place cursor here to 
activate the Filter button 
for the Horizontal 
Alignments. 
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• Click OK.  You are returned to the View Horizontal Annotation dialog and the 
selected Alignments are entered in the ‘Horizontal Alignments’ Selected field as 
shown in Figure L15-5. 

 
The Horizontal Alignments are selected and populated in the View Horizontal 
Alignments dialog. 

 

  
Figure L15-5 View Horizontal Annotation 

All alignments are 
moved to the selected 
field as shown here. 

The View Horizontal 
Annotation dialog is 
populated with the selected 
Horizontal Alignments. 
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9.  Select all Cogo Points with the Feature Styles PROP_E_PCF and PROP_E_RWE. 
 

• In the View Horizontal Annotation dialog, left click in the ‘Cogo Points’ 
Include field to activate the Filter button. 

• Click the Filter button.  The Geometry Selection Filter dialog opens as shown 
here. 

 

 
 

• Using the Pull down arrow, change the Style selection from Ignore to Included.  
The Style entry field changes from grayed out to active as shown here. 

 

  
 

• In the Style entry field, Key-in PROP_E_PCF,PROP_E_RWE.   
*NOTE: Do not place a space after the comma or InRoads will not recognize the 
second Feature Style. 

 
*REMEMBER: InRoads is case sensitive. 
 

• Once you key-in the above Feature Styles, left click in the Available field to 
accept the entry and filter the data. 

• Verify your dialog box matches that shown below. 

When the Style field is 
changed to Included the 
entry field activates to 
allow key-ins. 
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• Click All to move the filtered data from the Available field to the Selected field as 
shown here. 

 

  
 

• Click OK.  You are returned to the View Horizontal Annotation dialog and the 
selected Cogo Points are entered in the Cogo Points Selected field as shown in 
Figure L15-6. 

 
The Cogo Points are selected and populated in the View Horizontal Annotation dialog. 

 
 

Scroll through the points and 
verify that only PROP_E_PCF 
and PROP_E_RWE Feature 
Styles exists. 

All alignments are 
moved to the selected 
field as shown here. 
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Figure L15-6 View Horizontal Annotation 

 
 
 
10.  View Horizontal Annotation 

 
• Verify your entries match those shown in Figure L15-6. 
• Click Apply & Close.  Be patient for the viewing operation to complete. 
• In MicroStation, click the Fit View button. 
• Verify your MicroStation view matches that shown in Figure L15-7. 

 
The selected Horizontal Alignments and Cogo Points are viewed in MicroStation. 
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Figure L15-7 MicroStation Window 

 
11.  Zoom into the area where the Alignment for Parcel 74 will be created. 

 
• For Information:  InRoads uses the term Alignment to refer to centerlines as 

well as Parcels and for any other item constructed of points or points and curves. 
• In MicroStation, use the Window Area command to zoom into the area shown in 

Figure L15-8. 
• Verify your view matches that shown in Figure L15-9. 

 
Zooms into the area where the Alignment for Parcel 74 will be created. 

 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 15 
 
 

   
 Lab15-12   

 
Figure L15-8 MicroStation Window 

 
 
 

 
Figure L15-9 MicroStation Window 

 
 
 
 
 
 
 
 
 

Window the area 
shown here. 
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12.  Create a New Alignment for Parcel 74 and call it SV51. 
 

• Select File ► New and select the Geometry tab as the active tab. 
• Enter the following information for: 

o Type: Horizontal Alignment 
o Name: SV51 
o Description: PAR 74 TM #49 US CAN 
o Style: PROP_E_PAR 

• Verify your entries match those shown here. 
 

 
 

• Click Apply and Close. 
 
Alignment SV51 is created for Parcel 74. 

13.  Important Step! Make Parcel Alignment SV51 the Active Alignment. 
 

• Right mouse click over SV51 in the InRoads Explorer Interface and click Set 
Active. 

• Ensure a Red Box is displayed indicating SV51 is the Active Alignment. 
  

 
 
Alignment SV51 is set as the Active Alignment. 

Ensure a Red Box is displayed 
next to SV51 indicating it is the 
Active Alignment. 
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14.  Set the InRoads Snap Lock to Point Snap. 
 

• In InRoads, select Tools ► Locks and ensure a check mark exists next to Point 
Snap. 

• Ensure the Point Snap button, , is showing in the InRoads Toolbar as shown 
here. 

 
 

  
 

                                                               Point Snap Icon 
 
Sets the InRoads Snap Lock to Point Snap. 

15.  Open the Create/Edit Alignment by Cogo Points command. 
 

• Select Geometry ► Utilities ► Create/Edit Alignment by Cogo Points… 
• The Create/Edit Alignment by Cogo Points dialog opens as shown here. 

 
 

   
 
 
 

The Create/Edit Alignment by Cogo Points dialog opens. 
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16.  Add Point 430 to the Create/Edit Alignment by Cogo Points dialog. 
 

• In the Create/Edit Alignment by Cogo Points dialog click the Start button.  
• Notice in the bottom left corner of the MicroStation window you are prompted to 

Identify Point, .  This allows you to left click on points to add to 
the alignment definition field. 

• Left Click once on Point 430 (shown here). 
 

 
 

• Notice in the bottom left corner of the InRoads window and also in the bottom 
middle of the MicroStation window you are told which point was selected as 
shown here.   

• Notice in the bottom left of the MicroStation window you are told to Identify 
Point.  .  We can continue adding points until we have selected all 
the points we want to add to the Create/Edit Alignment by Cogo Points dialog 
but since we are now at a curve we need to return to the Create/Edit Alignment 
by Cogo Points dialog to select the Center Point Right button to add a curve 
that curves to the right. 

• Right mouse click.  You are returned to the Create/Edit Alignment by Cogo 
Points dialog. 

• Click Stop.  The Create/Edit Alignment by Cogo Points dialog is populated 
with point 430 as shown below. 

 

 
 
 
 
Point 430 is added to the Create/Edit Alignment by Cogo Points dialog. 

Pt. 430 
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17.  Set up the Create/Edit Alignment by Cogo Points Dialog to allow a Curve to be 
added. 
 

• Read this Step through to completion before taking action. 
• At this point we want to add a curve to the Parcel Alignment from Point 430 to 

point 278. Notice in the Create/Edit Alignment by Cogo Points dialog that the 
Graphical Input buttons are grayed out except the Start button.   As shown here, 
below left. 

 
 

       
 
 

• Click Start to continue adding data.   
• Immediately Right mouse click over the MicroStation window to reopen the 

Create/Edit Alignment by Cogo Points dialog.  The Create/Edit Alignment by 
Cogo Points dialog reappears. 

• Notice the Graphical Input buttons are all active, except the Start button, 
allowing you to select an input option other than Point. 

 
 
 
 
 
 
The Create/Edit Alignment by Cogo Points Dialog is now configured to allow curve 
inputs. 

Only the Start 
button is active. 

Only the Start button 
is deactivated. 
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18.  Add the Curve from Point 430 to Point 278 to the Create/Edit Alignment by Cogo 
Points Dialog. 
 

• Read this Step through to completion before taking action. 
• To add the right hand curve between points 430 and 278, shown below, click the 

Center Point Right button.  The Center Point Right button is used to select the 
center point of a curve that curves clockwise to the right.  Doing this requires you 
to change the snap mode in MicroStation from Keypoint to Center.   

 

 
 

• In MicroStation, click the active snap mode button, , located at the bottom 
middle of the MicroStation window and select Center.  The symbol will change 
to this: .  

• Now, use the MicroStation snap process (typically a combination of the left & 
right mouse keys at the same time) to tentative snap on the curve between points 
430 and 278 as shown below.  Doing this will place a cross hair at the center 
point of the curve and also highlight the curve in purple as shown here. 

 

                      
 

•  Now, left click to accept the point.  Notice in the bottom left of the InRoads 
window and also in the bottom middle of the MicroStation window you are told 
which point was selected as shown here.  .   

• Right mouse click over the MicroStation window to return to the Create/Edit 
Alignment by Cogo Points dialog.   

• Click Stop in the Create/Edit Alignment by Cogo Points dialog.  It is now 
populated with the curve. 

 

MicroStation snap on the curve 
between Points 430 and 278.  The 
curve highlights purple to indicate 
which curve was selected. 
 

A cross hair is placed to identify the 
location of the center of the curve 
that was snapped on. 

Pt. 430 

Pt. 278 
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• Verify your Create/Edit Alignment by Cogo Points dialog matches that shown 
below.  If it does not, remove the incorrect data and try again. 

 

 
 

• At this point the data is entered in the Create/Edit Alignment by Cogo Points 
dialog but not yet applied to Alignment SV51. 

• Click Apply to save the data to Alignment SV51.   
• Notice in the bottom left of the InRoads window or the bottom middle of the 

MicroStation window the message ‘Invalid cogo description’ 
 may appear.  If this appears it is because we have not yet 

defined an ending point. 
• Click Start in the Create/Edit Alignment by Cogo Points dialog. 
• Notice in the bottom left of the MicroStation window you are prompted to 

>Identify Point.  . 
• Left click on Point 278 shown on the preceding page. 
• Ensure Point 278 is selected by referring to the bottom left of the InRoads 

window or the bottom middle of the MicroStation window. 
• Right mouse click over the MicroStation window to return to the Create/Edit 

Alignment by Cogo Points dialog. 
• Click Stop.  Point 278 is now populated in the Create/Edit Alignment by Cogo 

Points dialog. 
• Click Apply but do not close out of the Create/Edit Alignment by Cogo Points 

dialog. 
• The message, ‘Successful completion’, is displayed in the bottom left of the 

InRoads window and the bottom middle of MicroStation. . 
 
 
The Curve between points 430 and 278 is now added to the Create/Edit Alignment by 
Cogo Points dialog. 
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19.  Continue using the Create/Edit Alignment by Cogo Points command to add point 
277 to alignment SV51. 
 

 
 

• Click Start in the Create/Edit Alignment by Cogo Points dialog. 
• Left click once on point 277. Be sure and notice the prompt at the bottom of the 

MicroStation view indicating which point was selected.   
• Right mouse click over the MicroStation window.  The Create/Edit Alignment 

by Cogo Points dialog reopens. 
• Click Stop.  The Create/Edit Alignment by Cogo Points dialog is populated 

with point 277. 
• Verify your Create/Edit Alignment by Cogo Points dialog matches that shown 

below.  If it does not, remove the incorrect data and try again. 
 
 

                    
 
 

• At this point the data is entered in the Create/Edit Alignment by Cogo Points 
dialog but not yet applied to Alignment SV51. 

• Click Apply to save the data to Alignment SV51 but do not close out of the 
Create/Edit Alignment by Cogo Points dialog. 

 
 
 
 
 
 
Point 277 is added to alignment SV51. 

Pt. 277 
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20.  Continue using the Create/Edit Alignment by Cogo Points command to add the 
right hand curve between points 277 and 276 to Alignment SV51. 
 

• Click Start in the Create/Edit Alignment by Cogo Points dialog. 
• Right mouse click over the MicroStation window to return to the Create/Edit 

Alignment by Cogo Points dialog. 
• To add the right hand curve between points 277 and 276, shown below, click the 

Center Point Right button.  The Center Point Right button is used to select the 
center point of a curve that curves clockwise to the right.  Doing this requires you 
to change the snap mode in MicroStation from Keypoint to Center.   

 

 
 

• In MicroStation, click the active snap mode button, , located at the bottom 
middle of the MicroStation window and select Center.  The symbol will change 
to this: .  

• Now, use the MicroStation snap process (typically a combination of the left & 
right mouse keys at the same time) to tentative snap on the curve between points 
277 and 276 as shown below.  Doing this will place a cross hair at the center 
point of the curve and also highlight the curve in purple as shown here. 

 

 
 

• Left click to accept the point.  Notice in the bottom left of the InRoads window 
and also in the bottom middle of the MicroStation window you are told which 
point was selected.  .   

• Right mouse click over the MicroStation window to return to the Create/Edit 
Alignment by Cogo Points dialog.   

A cross hair is placed to 
identify the location of the 
center of the curve that was 
snapped on. 
 

MicroStation snaps on the 
curve between points 277 and 
276.  The curve highlights 
purple to indicate which curve 
was selected. 
 

Pt. 277 Pt. 276 
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• Click Stop.  The Create/Edit Alignment by Cogo Points dialog is populated 
with the curve between points 277 and 276. 

• Click Start and left click on point 276 which is the end of the curve. 
• Right mouse click in the MicroStation window to return to the Create/Edit 

Alignment by Cogo Points dialog.   
• Click Stop. 
• Verify that your Create/Edit Alignment by Cogo Points dialog matches that 

shown below.  If it does not, remove the incorrect data and try again. 
 

 
 

• At this point the data is entered in the Create/Edit Alignment by Cogo Points 
dialog but not yet applied to Alignment SV51. 

• Click Apply to save the data to Alignment SV51 but do not close out of the 
Create/Edit Alignment by Cogo Points dialog. 

 
The Curve between Points 277 and 276 and the Point 276 are now added to the 
Create/Edit Alignment by Cogo Points dialog. 

21.  Continue using the Create/Edit Alignment by Cogo Points command to add point 
275 to Alignment SV51. 
 

 
 

• Click Start. 
• Left click once on Point 275.  Be sure and notice the prompt at the bottom of the 

MicroStation view indicating which point was selected. 
• Right mouse click over the MicroStation window to return to the Create/Edit 

Alignment by Cogo Points dialog.   

Pt. 276 

Pt. 275 
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• Click the Stop button.  The Create/Edit Alignment by Cogo Points dialog is 

populated with the Point 275. 
• Verify that your Create/Edit Alignment by Cogo Points dialog matches that 

shown below.  If it does not, remove the incorrect data and try again. 
 
 

                 
 
 
 

• Click Apply and Close.   
 

Point 275 is added to Alignment SV51. 
22.  Open the Traverse Edit Command. 

 
• For Information:  The Create/Edit Alignment by Cogo Points is the best tool 

to use for making use of existing curves.  When curves do not yet exist, the 
Traverse or Traverse Edit Command must be used. 

 
 

             
 
 

• Select Geometry ► Utilities ► Traverse Edit…  The Traverse Edit dialog 
opens as shown below. 

• Notice Alignment SV51 contains the Points and Curves that were added using the 
Create/Edit Alignment by Cogo Points. 

 
 
 
 
 

Existing R/W 

Pt. 275 
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• Notice in MicroStation that the Highlighted element in the Traverse Edit dialog 
is also highlighted in MicroStation as shown here. 

 

 
 

• Left click on the last linear element in the Traverse Edit dialog to make it the 
active element. 

• Verify the linear element highlighted in the Traverse Edit dialog matches that 
shown here. 

 
 

• Do not close the Traverse Edit dialog. 

Highlighted element in 
Traverse Edit dialog is 
also highlighted in 
MicroStation. 
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23.  Before Continuing -- set the InRoads Snap Lock to Element Snap. 
 

• In InRoads, select Tools ► Locks and ensure a check mark exists next to 
Element Snap. 

• Ensure the Element Snap button, , is showing in the InRoads Toolbar as 
shown here. 

 

 
                                    
                                                               Element Snap Icon 
 
Sets the InRoads Snap Lock to Element Snap. 

24.  Open the Add Element After Dialog. 
 

• In the Traverse Edit dialog which should still be open from the previous step, 
click the Add After… button.  The Add Element After dialog opens as shown 
here. 

 
 

Opens the Add Element After dialog box. 
25.  Change the Add Element After Type to Circular. 

 
• In the Add Element After dialog, change the Type from Linear to Circular. 
• Use the pull down menu to change the Circular Parameter from Chord 

Direction to Tangent Direction. 
 

 
 

• Do not close the Add Element After dialog 
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26.  Select Tangent direction 
 

• While still in the Add Element After dialog, use the Locate button, , to fill the 
entry field for the Tangent Direction.  This is done by left clicking on the 
Tangent element prior to the curve as shown below. 

 

 
 
 

• Verify the value returned is S 66^40’57.9” E. 
• Verify your entries at this point match those shown here. 

 
 

 
 
 
 

• Do not close the Add Element After dialog box. 
 
Selects the Tangent Direction. 

Left click on the 
highlighted line to define 
the tangent. 
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27.  Select Radius 
 

• While still in the Add Element After dialog use the Locate button, , to fill the 
entry field for the Radius. This is done by left clicking on the curve as shown 
below. 
**REMEMBER:  Curves to the left are negative while curves to the right are 
positive.  This will require you to manually place a negative sign in front of the 
radius value. 
 

 
 

• Verify your entries match those shown here. 
 

 
 
 
 

• Do not close the Add Element After dialog. 
 

Selects the Radius. 

Left Click on this 
curve to define the 
radius. 

*IMPORTANT: 
Don’t forget to 
place a negative 
sign, -, in front of 
the radius value to 
indicate a curve to 
the left. 
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28.  Enter Curve Length 
 

• Key-in 118.22 for the Length. 
• Verify your entries match those shown here. 

 

 
 

• Click Apply & Cancel.  You are returned to the Traverse Edit dialog. 
• Do not close the Traverse Edit dialog. 
• Your view in MicroStation should look like this below which is obviously 

incorrect.  The reason for this is because the existing R/W was stored by copying 
parallel from the centerline which is stored from west to east or left to right.  
Currently you are storing a parcel clockwise which for this element is right to left 
or east to west. 

 
 

Enters the Curve Length. 
29.  Remove Incorrect Data from Traverse Edit Dialog 

 
• In the Traverse Edit dialog, still open from the previous step, highlight the 

incorrect circular element as shown here. 
 

 
 

• Click Delete and click Yes to delete the selected element in the Alert dialog. 
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30.  Open the Add Element After Dialog Again 
 

• Highlight the last linear element in the Traverse Edit dialog as shown here. 
 

 
 

• Click the Add After… button.  The Add Element After dialog opens as shown 
here. 

 

 
 

• In the Add Element After dialog, change the Type from Linear to Circular. 
• Using the pull down menu change the Circular Parameter from Chord 

Direction to Tangent Direction. 
• Verify your entries match those shown here. 

 

 
 

• Do not close the Add Element After dialog. 
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31.  Select Tangent direction 
 

• While still in the Add Element After dialog, use the Locate button, , to fill the 
entry field for the Tangent Direction.  This is done by left clicking on the 
Tangent element prior to the curve as shown below. 

 

 
 
 

• Verify the value returned is S 66^40’57.9” E. 
• Verify your entries at this point match those shown here. 

 
 

 
 
 
 
 

• Do not close the Add Element After dialog. 
 
Selects the Tangent Direction. 

Left click on the 
highlighted line to define 
the tangent. 
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32.  Select Radius 
 

• While still in the Add Element After dialog use the Locate button, , to fill the 
entry field for the Radius. This is done by left clicking on the curve as shown 
below. 
**REMEMBER:  Curves to the left are negative while curves to the right are 
positive.  This will require you to manually place a negative sign in front of the 
radius value. 
 

 
 

• Verify your entries match those shown here. 
 

 

 
 
 

• Do not close the Add Element After dialog. 
 

Selects the Radius. 

Left Click on this 
curve to define the 
radius. 

*IMPORTANT: 
Don’t forget to 
place a negative 
sign, -, in front of 
the radius value to 
indicate a curve to 
the left. 
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33.  Enter Curve Length 
 

• Key-in 118.22 for the Length. 
• Verify your entries match those shown here. 

 

 
 

• Do Not click Apply. 
• At this point we are back to where we were before we created the error.  Since we 

are storing our parcel in the clockwise or North Westerly direction for this 
element rather than in the South Easterly direction we can manually make the 
following edit.    

• Change the ‘Tangent Direction’ value from S to N and from E to W as shown 
here. 

 

 
 

• Click Apply and Cancel.  You are returned to the Traverse Edit dialog. 
• Verify your MicroStation view matches that shown here and that the circular 

element was drawn. 

                                               
  

• Do not close the Traverse Edit dialog. 

The S was changed to N and the E 
was changed to W.  This is the 
correct direction of the linear 
element. 
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34.  Complete the Traverse Edit Command and add the Curve to Alignment SV51 
 

• At this point we have added a circular element to the Traverse Edit dialog using 
the Add After button, as shown here. 

 

 
 

• In the Traverse Edit dialog click Apply but do not click Cancel.  The curve is 
permanently added to Alignment SV51 and drawn in MicroStation. 

 
35.  Continue using the Traverse Edit command to add a linear element from the PT of 

the last curve added on a bearing of N 02^34’27.5” W with a distance of 392.60 feet. 
 

• Make sure the last Circular element in the Traverse Edit dialog is highlighted as 
shown here. 
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• Click the Add After… button. 
• Match the entries in the Add Element After dialog shown here. 

 

 
 
 

• Click Apply and Cancel. 
• Verify your MicroStation view matches that shown here and contains the new 

linear element.   
 
 

 
 
 
 
 

• In the Traverse Edit dialog click Apply and Cancel.  This completes the addition 
of the curve and linear element described in the previous steps to Alignment 
SV51 using the Traverse Edit command. 

 
 

Linear Element 

Enter in a Direction:  
N 02 34 27.5 W 
 
Enter in a Distance: 
392.60 
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36.  At this point the changes and additions you’ve made to Alignment SV51 have only been 
stored in temporary memory but have not been permanently stored in the InRoads .ALG 
file.  In order not to lose data it is important to periodically save your .ALG geometry 
file. 
 

• In InRoads, Select File ►Save ► Geometry Project. 
 

37.  Let’s Suppose for a moment… That you’ve just realized you incorrectly entered the 
bearing for your last entry and it should have been N 2^34’27.5”E and not  
N 2^34’27.5”W.  The following steps demonstrate the use of the Traverse Edit 
command to edit the incorrectly stored element. 
 

• Select Geometry ► Utilities ► Traverse Edit… 
• In the Traverse Edit dialog highlight the incorrectly stored linear element, shown 

here.  Notice in MicroStation that the element is also highlighted in purple. 
 
 

 
 
 

• Click the Edit button. 
• In the Edit Element dialog change the Direction from N 02^34’27.6” W to        

N 02^34’27.6” E. 
• Verify your entry matches that shown below. 
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• Notice the linear element change in MicroStation as you click Apply and Cancel.  
Go ahead and click Apply and Cancel if you haven’t already done so. 

• In the Traverse Edit dialog click Apply and Cancel. 
• Verify your MicroStation view matches that shown here. 

 

 
 
 

  

Notice the direction 
has changed. 
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38.  At this point the changes and additions you’ve made to Alignment SV51 have only been 
stored in temporary memory but have not been permanently stored in the InRoads .ALG 
file.  In order not to lose data it is important to periodically save your .ALG geometry 
file. 
 

• In InRoads, Select File ►Save ► Geometry Project. 
 

39.  Store the leg from point 430 on a bearing of N 30^57'32.4" W and a distance of 
762.80 feet using the Traverse command. 
 

• Select Geometry ► Traverse 
• Set the Method to Direction. 
• Set the Insert Point Mode to Before Alignment. (Before Alignment MUST be 

selected FIRST before selecting the Occupied Point in order for the command to 
function correctly). 

• Use the locate button in the Occupied Point frame to select point 430. 
* Hint: Remember to change the InRoads snap lock to Point Snap. 

• Use the Locate Button under the Course frame to define the Direction identified 
below. 
* Hint: Change the InRoads snap lock to Element Snap. 

 

 
 

• Under Course, key-in a horizontal distance of 762.80 feet. 
*REMEMBER: Ensure Horizontal Distance is selected. 

• Select a Style of PROP_E_PPC from the Pull down menu in the Foresight Point 
frame. 

• Verify your settings match those shown below. 
 
 

 
 

Use the locate button to 
enter the direction by left 
clicking on this line. 
N 30 57 32.4 W 

Pt. 430 
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• Click Apply but do not close out of the Traverse command. 
• If a Results dialog box appears – click the Close button to close the dialog. 
• Verify your view matches that shown in Figure L15-10 and that the leg was 

drawn correctly. 
 

 
 
 

 
Figure L15-10 MicroStation Window 

It is difficult to see but a 
leg should have been 
drawn from point 430 to 
here. 

Ensure Horizontal 
Distance is selected. 
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40.  Continue using the Traverse command from the previous step to store the leg from 
the last point stored on a bearing of S 59^02’27.5” W and a distance of 345.60 feet. 
 

• Set the Method to Direction. 
• Set the Insert Point Mode to Before Alignment. (Before Alignment MUST be 

selected FIRST before selecting the Occupied Point in order for the command to 
function correctly). 

• Enter Point 265 in the Occupied Point frame or snap to it using the Locate 
Button. 
* Hint: If Snapping - Remember to change the InRoads snap lock to Point Snap. 

• Under the Course frame - enter in a Direction of S 59 02 27.5 W to define the 
Direction identified below. 

• Under Course, key-in a horizontal distance of 345.60 feet. 
*REMEMBER: Ensure Horizontal Distance is selected. 

• Select a Style of PROP_E_PPC from the Pull down menu in the Foresight Point 
frame. 

 
 

• Match the settings in the Traverse dialog shown here. 
 
 
 

 
 

• Click Apply, but do not close out of the Traverse command. 
• Review and Close the Results dialog that opens. 
• Verify your MicroStation view matches that shown in Figure L15-11. 
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Figure L15-11 MicroStation Window 

 
 
 

41.  At this point the changes and additions you’ve made to Alignment SV51 have only been 
stored in temporary memory but have not been permanently stored in the InRoads .ALG 
file.  In order not to lose data it is important to periodically save your .ALG geometry 
file. 
 

• In InRoads, Select File ►Save ► Geometry Project. 
 

42.  Continue using the Traverse command to close the Alignment. 
 

• Click the Close Traverse button and a Results Report should appear.  
• Click Close to close out of the Results Report. 
• Notice the Alignment was not closed.  This is because the occupied point must be 

the last point in the Alignment for the Close Traverse button to work. 
In the Traverse dialog, use the Locate Button to select the Occupied Point  
identified in Figure L15-12.  

      * Hint: When Snapping - Remember to change the InRoads snap lock to Point Snap. 
 
*NOTE:  Notice when using the locate button to select the occupied point the 

purple hour glass ID’s the point (See Figure L15-12) but that no point 
number is identified in the bottom middle of the MicroStation window 
as in previous assignments.  Only Selected point “is shown (See Figure 
L15-12).  This is because the Assign Names command has not yet been 
run.  The coordinates, however, are still entered correctly into the 
Occupied Point fields as shown here. 

 
 
 
 
 

Verify this leg was drawn. 
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• Click the Close Traverse button. 
• Close the Results report. 
• Verify your view matches that shown in Figure L15-13. 
• Click Close to close the Traverse dialog. 

 
 

 

 
Figure L15-12 MicroStation Window 

 

Use the locate button to 
select this point as the 
occupied point. 

Notice when using the locate button to select 
the occupied point the purple hour glass ID’s 
the point but that no point number is identified 
in the bottom middle of the MicroStation 
window as in previous steps.  Only “Selected 
point “is shown.  This is because the Assign 
Names command has not yet been run. 
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Figure L15-13 MicroStation Window 

 
 
43.  Let’s Suppose for a Moment…That at this point you have realized there was an 

additional leg that needed to be placed and that you should not have closed the 
Alignment.  The following steps will guide you through the use of the Check Integrity 
command to remove the last leg placed. 
 

• Make the Geometry tab the active tab in the InRoads Explorer Interface as 
shown here. 

 
 

• Expand the 1234567_SDE project by left clicking on the + symbol as shown 
here. 

 

 
 

• Scroll to alignment SV51.  Right mouse click over it and click Set Active to 
ensure it is the Active Alignment.  There should be a Red Square around it. 

 

Verify this link was drawn 
and the Alignment was 
closed. 

Verify the Geometry tab is the 
active tab in the InRoads Explorer 
Interface as shown here by left 
clicking on it.  This may also be 
accomplished by right mouse 
clicking over any tab and selecting 
Geometry. 

Expand the 1234567_SDE project by 
clicking on the + symbol. 
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• Right mouse click over SV51 again and click Check Integrity.   
• If the following Alert box appears, click OK. 

 

               
 
 

• The Check Horizontal Integrity dialog opens as shown below. 
 

    
 

• Notice the Zero Length linear element highlighted in the screen capture below.  
This element was placed when we attempted to close the element previously in 
the first part of Step 42 without success.  Let’s take a moment to delete this 
element. 

• Highlight the Linear element shown below. 
• Next Right Click on the Highlighted Linear element and click Delete. 
• Elements can be edited/deleted at any time using the Check Integrity command. 

 
 
 
 

SV51 should have a red square 
around it as shown here indicating it 
is the active alignment. 
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• Highlight the last Linear element in the Check Horizontal Integrity dialog as 
shown below. 

 

     
 

• In MicroStation, notice the element is highlighted in purple shown below. 
 
 

 
 
 
 

Notice the highlighted element in the Check 
Integrity dialog is also highlighted in 
MicroStation. 
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• In the Check Horizontal Integrity dialog, Right Click on the Highlighted 
Linear element and click Delete. 

• Notice the element disappears in both the Check Horizontal Integrity dialog and 
in MicroStation. 

• Click Close to close the Check Horizontal Integrity dialog. 
 

44.  At this point the changes and additions you’ve made to alignment SV51 have only been 
stored in temporary memory but have not been permanently stored in the InRoads .ALG 
file.  In order not to lose data it is important to periodically save your .ALG geometry 
file. 
 

• In InRoads, Select File ►Save ► Geometry Project. 
 

45.  Use the Traverse command to add the next leg of Parcel Alignment SV51 with a 
bearing of N 31^ 50’ 32.45” W and distance of 50.97 as shown here. 
 

     
 

• Select Geometry ►Traverse  
• Set the Method to Direction. (See Figure L15-15). 
• Set the Insert Point Mode to Before Alignment. 
• Use the Locate Button to select Point 266 to be the occupied point.  (See Figure 

L15-14).  
 

     * Hint: When Snapping - Remember to change the InRoads Snap lock to Point Snap. 
 

• In the Course - Direction field key-in N31^50’32.5”W. 
• In the Course – Horizontal Distance field key-in 50.97. 
• Verify your settings match those shown in Figure L15-15. 
• Click Apply but Do Not close the Traverse dialog. 
• The Results report may be closed. 
• In MicroStation, Verify your view matches that shown in Figure L15-16. 

Leg to be added. 
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Figure L15-14 MicroStation Window 

 
 

 
Figure L15-15 Traverse Dialog. 

Point 266 
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Figure L15-16 MicroStation Window 

 
 
 
 
 
 
 
 
 
 
 
 
46.  At this point the changes and additions you’ve made to Alignment SV51 have only been 

stored in temporary memory but have not been permanently stored in the InRoads .ALG 
file.  In order not to lose data it is important to periodically save your .ALG geometry 
file. 
 

• In InRoads, Select File ►Save ► Geometry Project. 
 

47.  Close the alignment. 
 

• In MicroStation, Window area as shown below. 
 

 
 
 
 

INSET 
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• The Alignment is not yet closed as can be seen here. 
 

 
 

• In the Traverse command use the Locate Button to select the Occupied Point as 
shown below. 

 
 
 
 
 
 
 
 
 

Window Area here. 

The alignment is not closed. 
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• *NOTE:  As stated previously, notice when using the locate button to select the 
occupied point the purple hour glass ID’s  the point but that no point number is 
identified in the bottom middle of the MicroStation window as in previous 
assignments.  Only “Selected point” is shown. This is because the assign names 
command has not yet been run.  The coordinates will be entered correctly into the 
Occupied Point fields as shown here. 

 

 
 

• Click the Close Traverse button. 
• In MicroStation, verify your view matches that shown below. 

 
 
 
 
 
 
 
 

Use the locate button to 
select the Occupied Point 
here.  This is the last 
point in the alignment. 

As stated previously, notice when using 
the locate button to select the occupied 
point above the purple hour glass ID’s 
the point but that no point number is 
identified in the bottom middle of the 
MicroStation window as in previous 
assignments.  Only “Selected point “is 
shown.  This is because the Assign 
Names command has not yet been run. 
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• Click Close to close the Traverse dialog. 
• Click Close to close the Results report. 

48.  At this point the changes and additions you’ve made to Alignment SV51 have only been 
stored in temporary memory but have not been permanently stored in the InRoads .ALG 
file.  In order not to lose data it is important to periodically save your .ALG geometry 
file. 
 

• In InRoads, Select File ►Save ► Geometry Project. 
 

49.  As we have done in previous labs we must Assign Names to all the coordinates in the 
Alignment SV51 that do not have names and we must convert all these named 
points to Cogo Points. 
 

• Select Geometry ► Utilities ► Assign Names…  The Assign Names dialog 
opens as shown below. 
 

                   
 

Alignment SV51 has 
been closed. 
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• Check the Alignments radio button in the Points/Alignments frame. 
• Check the Assign radio button in the Method frame. 
• Ensure ‘Check for Coincident Points’ is checked. 
• Use the Locate Button next to the Name field to select Alignment SV51. 
• Verify your settings match those shown here. 

 

          
 

• Click Apply and Close.  Names are now assigned to all the coordinates in 
Alignment SV51. 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog that opens match the following settings. 
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• Click Apply and Close.  All of the Alignment Points created in the previous step 
have now been converted to Cogo Points. 

• Close the Results dialog. 
 
 

50.  View all Cogo Points 
 

• Select Geometry ►View Geometry ►Horizontal Annotation… 
• In the ‘Horizontal Alignments’ Include field.  Key in a space and click the tab 

button.  This will clear the Alignment entries. 
• Place your cursor in the ‘Cogo Points’ Include field to activate the Filter button. 
• Click the Filter button. 
• In the Geometry Selection Filter dialog click the All button to move all the 

points from the Available field to the Selected field. 
• Click OK. 
• Click Apply & Close in the View Horizontal Annotation dialog. 

 
 

Ensure ‘Alignment 
Point to Cogo’ is 
checked. 

Ensure PROP_E_PPC 
is selected as the Style. 
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51.  Review Alignment SV51. 
 

• Select Geometry ► Review Horizontal. 
• Take a moment to review your alignment and compare it to that shown in Figure 

L15-17 below. 
• Close the Review Horizontal Alignment dialog when finished reviewing 

Alignment SV51. 
 

 

 
Figure L15-17 Review Horizontal Dialog. 
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52.  Save the InRoads Geometry File 
 
Even though the Alignments have been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
Please Note:  (The “Save As” dialog box may not appear because the Geometry Project 
has already been saved initially). 
 
 The Geometry Project (1234567_SDE.alg) will be saved to Lab 15 in the following 
path: 
C:\InRoads Data\1234567\SDE Labs\Lab15 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_SDE Geometry Project has now been saved to the following path: 
 
C:\InRoads Data\1234567\SDE Labs\Lab15 

53.  VERY Important Step:  In order to Start with a CLEAN DGN file for the next Lab: 
 
In the [MicroStation Software] – 
 
Select Edit Select All 
 
Then select the <DELETE> key on the computer keyboard.  All of the DGN Graphics 
will then be deleted from the GDOT 3D Working File.dgn. 
 
Deletes the Graphics from the GDOT 3D Working File.dgn to ensure a clean DGN file 
for the next Lab. 

54.                    
This concludes Lab 15.  Do not proceed until the Instructor directs you to do 
so. 
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Lab 16 
Preparing the 1234567_PROP.dgn for 

Delivery to the Designer 
 
Objective 
 
The objective of Lab 16 is to: 
 

• Learn the process to follow to create the 1234567_PROP.dgn file for Delivery to the 
Designer containing only the Feature Styles listed on this page.  

 
 
Points 
PROP_E_APC 
PROP_E_API 
PROP_E_APOC 
PROP_E_APOT 
PROP_E_APT 
PROP_E_BCOL 
PROP_E_BCTL 
PROP_E_BGMD 
PROP_E_BLDL 
PROP_E_BLLL 
PROP_E_BMISC 
PROP_E_BSL 

 
PROP_E_POEL 
PROP_E_PPC 
PROP_E_PPOL 
PROP_E_RWC 
PROP_E_RWE 
PROP_E_RWM 
PROP_E_RWRR 
PROP_E_RWU 
PROP_E_ACL 
PROP_E_ACL-PC-PT 
PROP_E_PCF 

PROP_E_PAR 
 
 
 
 
 
Alignments 
PROP_E_ACL 
PROP_E_BCOL 
PROP_E_BCTL 
PROP_E_BGMD 
PROP_E_BLDL 
PROP_E_BLLL 
 

 
PROP_E_BMISC 
PROP_E_BSL 
PROP_E_PAR 
PROP_E_POEL 
PROP_E_RWE 
PROP_E_RWRR 
PROP_E_RWU 
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Lab 16A Getting Started 
 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Verify Project Defaults 
• In InRoads select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_SDE which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L16-1. 
• Click Apply & Close. 

 
Sets project defaults. 

 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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Figure L16-1 Project Defaults 

 
 
4.  Open the .alg file 

• Select File ► Open. 
• Navigate and open the Folder Lab16. 
• Highlight the file 1234567_SDE.alg. 
• Click Open & Cancel. 
 

Opens the 1234567_SDE .alg file 

Hint:  You may also right mouse 
click over ‘Geometry Projects’ in 
the Workspace Bar and select 
open. 

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
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5.  Set Survey Default Preferences 
 

• In InRoads  - Select File Project Options. 
• In the Project Options dialog box select the General Tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Survey Default.  Click Load and Close. 
• In the Project Options dialog box - Click Apply and Close. 

 
Sets the Survey Defaults Preference. 

6.  Set the View Horizontal Alignments and Cogo Points view settings. 
 

• Select Geometry ► View Geometry ► Horizontal Annotation.  The View 
Horizontal Annotation dialog opens as shown in Figure L16-2. 

• Click the Preferences Button.  The Preferences dialog opens as shown in Figure 
L16-3. 

• In the Preferences dialog highlight NO BEARING & DISTANCE. 
• Click Load and Close.  This loads the viewing preference settings into the View 

Horizontal Annotation dialog. 
• Verify your settings match those shown in Figure L16-4. 

 
The settings in the View Horizontal Annotation dialog are set.  This will ensure that the 
proper symbology is applied to the Cogo points and alignments in MicroStation. 

 
 

                                                                                   
Figure L16-3 Preferences 

 
 
 
 
 
 
 
Figure L16-2 View Horizontal Alignments 

Preferences Button 
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Figure L16-4 View Horizontal Alignments 
 
7.  Apply the Geometry Selection Filter ‘PROP.dgn Alignments’ Preference to the 

View Horizontal Alignments dialog. 
 

• In the View Horizontal Alignments dialog in Figure L16-4 notice that the Filter 
button is grayed out. 

• Activate the Filter button for the Horizontal Alignments by left clicking in the 
Horizontal Alignments key-in field. 

• Click the Filter button.  The Geometry Selection Filter dialog opens as shown 
here. 

 
 

Filter button 
Shown 
grayed out. 

Place cursor here to 
activate the Filter 
button for the Cogo 
Points. 

Place cursor here to 
activate the Filter button 
for the Horizontal 
Alignments. 
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• Click the Preferences button.  This opens the Preferences dialog as shown here. 
 

 
 

• Highlight the Prop.dgn Alignments Preference. 
• Click Load & Close.  This filters the Alignments to only include the 13 Feature 

Styles listed here and returns you to the Geometry Selection Filter dialog box.   
 

PROP_E_ACL, PROP_E_BCOL, PROP_E_BCTL, PROP_E_BGMD, 
PROP_E_BLDL, PROP_E_BLLL, PROP_E_BMISC, PROP_E_BSL, 
PROP_E_PAR, PROP_E_POEL, PROP_E_RWE, PROP_E_RWRR, 
PROP_E_RWU. 
 

• Notice in the Geometry Selection Filter dialog below that the Style has changed 
from Ignore to Included and the key-in entry field for the Style is populated with 
the correct Feature Styles and the Available field is populated with the filtered 
Feature Styles. 

 

 
 

• Click All to move the filtered alignments from the Available field to the Selected 
field as shown below. 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 16 
 

   
 Lab16-7   

 

 
 

• Click OK to return selected data to the View Horizontal Annotation dialog. 
• The Filtered Alignments have been added to the View Horizontal Annotation 

dialog selected field as shown in Figure L16-5. 
 
You have applied the ‘Prop.dgn Alignment’ Preference to the View Horizontal 
Annotation dialog and are ready to apply the ‘Prop.dgn Points’ Preference. 

 

 
Figure L16-5 View Horizontal Alignments 
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8.  Apply the Geometry Selection Filter ‘Prop.dgn Points’ Preference to the View 
Horizontal Alignments dialog. 
 

• In the View Horizontal Annotation dialog activate the Filter button for the 
Cogo Points by left clicking in the Cogo Points key-in field. 

• Click the Filter button.  The Geometry Selection Filter dialog opens as shown 
here. 

 
 

• Click the Preferences button.  This opens the Preferences dialog as shown here. 
 

 
 

• Highlight the Prop.dgn Points preference. 
• Click Load & Close.  This filters the Cogo points to include only the 22 Feature 

Styles listed here and returns you to the Geometry Selection Filter dialog.   
 

PROP_E_APC, PROP_E_API, PROP_E_APOC, PROP_E_APOT, 
PROP_E_APT, PROP_E_BCOL, PROP_E_BCTL, PROP_E_BGMD, 
PROP_E_BLDL, PROP_E_BLLL, PROP_E_BMISC, PROP_E_BSL, 
PROP_E_PAR, PROP_E_POEL, PROP_E_PPC, PROP_E_PPOL, 
PROP_E_RWC, PROP_E_RWE, PROP_E_RWM, PROP_E_RWRR, 
PROP_E_RWU, PROP_E_ACL, PROP_E_ACL-PC-PT, PROP_E_PCF. 
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• Notice in the Geometry Selection Filter dialog below that the Style has changed 
from Ignore to Included and the key-in entry field for the Style is populated with 
the correct Feature Styles and the Available field is populated with the filtered 
Feature Styles. 

 

 
 

• Click All to move the Filtered Cogo points from the Available field to the 
Selected field as shown here. 

 

 
 

• Click OK to return to the View Horizontal Annotation dialog. 
• The filtered Cogo points have been added to the View Horizontal Annotation 

dialog selected field as shown in Figure L16-6. 
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Figure L16-6 View Horizontal Alignments 

 
 

9. Now that we have the proper settings set and the proper Horizontal Alignments and the 
Cogo Points added to the Selected field in the View Horizontal Annotation dialog its 
time to view them. 
 

• Click Apply.  Please be patient this may take a few minutes to complete 
depending on the size of the file. 

• Click Close to exit the View Horizontal Annotation dialog. 
• In Microstation, Click the Fit View button. 
• Verify that your Microstation View matches that shown in Figure L16-7 and that 

the proper symbology has been applied by comparing to the current version of the 
EDG (Electronic Data Guidelines). 

 
You have viewed the correct information to create the 1234567_PROP.dgn file. 

 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 16 
 

   
 Lab16-11   

 
Figure L16-7 MicroStation View Window 

 
 
10. For Information Only: 

 
During the field survey collection, the PROP_E_PCF (Property Corner Found) 
Feature Style/Code may be collected with an attribute description.  
 
For Example:  
26255,1373204.493,2120519.127,1045.688,PCF,ATTRNAME,3/8 OPEN PIPE 
 
If this attribute has been collected for the PCF, the following steps will provide the 
process to ensure that this attribute description annotation is represented in the 
PI#_PROP.dgn file. 
 
Information for the viewing of the annotation description for inclusion in the 
PI#_PROP.dgn file. 
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11.  In InRoads, Make the Survey Tab located along the bottom of the InRoads Explorer 
Interface the active tab as shown here: 
 

                                           
      

12.  In InRoads, open the file 1234567_XO.fwd which is located in C:\InRoads 
Data\1234567\SDE Labs\Lab16.  Click Open and then click Cancel. The InRoads 
Explorer Interface should now appear as shown here:           

                                          
 

13.  In MicroStation, notice the view changed when the .FWD file was opened.  The reason 
for this is that in InRoads the default operation is to automatically view planimetrics 
whenever a new .FWD file is opened and automatically fits the view.  It is good practice 
to turn off planimetrics. 
 

• In InRoads, select Survey ► View Survey Data.  Uncheck Planimetrics. 
• In MicroStation, click the View Previous icon.  This returns the view to that 

shown in Figure L16-7. 
 

              
                                                     
                                                  View Previous 
 

14.  In InRoads, set the Survey Scale Factor.  
 
     *NOTE: This is not the same as the Global Scale Factor set earlier in this lab.  The 

Global Scale Factor controls scaling of elements in the Surface and 
Geometry modules but not the Survey module. 

 
• Select Survey ► Fieldbook Data…  The Fieldbook Data dialog opens as 

shown in Figure L16-8. 
• In the Fieldbook Data dialog click the Survey Options button (      ) as shown in 

Figure L16-8.  The Survey Options dialog opens as shown in Figure L16-9. 

Make the Survey tab 
the active tab. 

1234567_XO is now open 
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Figure L16-8 Fieldbook Data 

 

                            
Figure L16-9 Survey Options 

 

Survey Options button 
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15.  • In the Survey Options dialog click the Preferences button. The Preferences 
dialog opens as shown here.   

 

 
 

• Select the 50 Scale Preference.   
• Click Load and Close. 
• Verify your entries match those shown in Figure L16-10. 
• Click OK. 

 
 

                                
Figure L16-10 Survey Options 
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16.  • Close the Fieldbook Data dialog by clicking the red X (       ) in the top right 
corner. 

 
17.  • Select Survey ► View Survey Data ► Write Survey Data to Graphics.  The 

Write Survey Data to Graphics dialog opens. 
18.  • In the Write Survey Data to Graphics dialog, click the Filter button.  The 

Survey Style Filter dialog opens. 
• In the Survey Style Filter dialog, select Prop Annotation from the Filter Name 

pull down. 
• The Prop Annotation filter views the annotation for the following Feature. 

 
o PROP_E_PCF 

 
• Verify the Survey Style Filter dialog matches that shown in Figure L16-11. 
• Click OK to close the Survey Style Filter dialog and return to the Write Survey 

Data to Graphics dialog. 
 

 
 

                           
Figure L16-11 Survey Style Filter 
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19.  • In the Write Survey Data to Graphics dialog, place a check mark in the box 
next to Planimetrics as shown in Figure L16-12. 

• Click Apply and Close. 
 

 

                                              
Figure L16-12 Write Survey Data Dialog 

 
 
20.  • Verify your view in MicroStation matches that shown in Figure L16-13. 

 
 
 

 
Figure L16-13 MicroStation Window 
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21. Create the 1234567_PROP.dgn file. 
 

• In MicroStation, click the Fit View icon. 
 

                     
                                             
                                                                Fit View 

 
• In Microstation, Select File ► Compress ► Design.  This reduces the file size of 

the Microstation file. 
• In Microstation, Select File ► Save As.  The Save As dialog opens as shown 

here. 
 

 
 
 

• Navigate to the folder C:\InRoads Data\1234567\SDE Labs\Lab16 
• For the File name: key-in 1234567_PROP.dgn as shown here. 
• In the Save as type: pull-down select MicroStation V8 DGN Files (*.dgn) 
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• Click Save. 
 
You have now completed creating the 1234567_PROP.dgn file. 

22. The 1234567_PROP.dgn and the 1234567_SDE.alg are now complete and copies are 
ready to be provided to the designer.  When all files are ready, the SDE is instructed to 
contact the Engineering Management / Operations Manager and make copies 
available on SDEcommon.  The  Engineering Management / Operations Manager 
will keep all orignal copies and inform the designer where they may be acquired.  The 
SDE is also instructed to obtain original copies from the Engineering Management / 
Operations Manager whenever enhancements are to be performed during the life of the 
project. 
 

                   
                 This concludes Lab 16.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 17 
Preparing the DTM Surface, TOPO and 

UTLE Files for Initial Delivery   
 
Objective 
 
At this point the DTM Surface data has been verified and any errors have been resolved in the 
previous Labs. The final processing of the DTM Surface has been completed and the DTM 
database has been compressed. In this Lab – One final step must be performed to the DTM 
Surface to prepare it for delivery to the ‘Engineering Management / Operations Manager’. In 
Lab 16 – the 1234567_PROP.dgn file was created which contains all of the Existing Property 
information.  In this Lab - the 1234567_TOPO.dgn and the 1234567_ UTLE.dgn files will be 
created as initial deliverables for submission to the ‘Engineering Management / Operations 
Manager’. 
 
The Initial Deliverables will include the following: 
 

• PI#_SDE.alg (InRoads Geometry file) 
• PI#_SDE.dtm (InRoads Digital Terrain Model) 
• PI#_TOPO.dgn (Existing Topo features) 
• PI#_PROP.dgn (Existing Property Information) 
• PI#_UTLE.dgn  (Existing Utility features) 
• PI#_PSR.xls or .psr or .mdb (Property Statistics Report) 
•  PI#_Misc.txt (Miscellaneous information SDE deems important.  This file may not be 

included.) 
 

 
The objective of Lab 17 is to: 

• Create a 1234567_TOPO.dgn File for delivery 
• Create a 1234567_UTLE.dgn File for delivery 
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Lab 17A Final Processing of the DTM Surface 
 
In this section of the Lab, you will be setting the Surface Preferences in the DTM. 
 
1.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\SDE Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  Click Open. 

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear MicroStation Screen Graphics 
 

• In MicroStation, Select Edit ► Select All.   
• In MicroStation, click the Delete icon ( ). 

 
4.  Verify Project Defaults 

 
• In InRoads select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_SDE which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L17-1. 
• Click Apply & Close. 

 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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Figure L17-1 Project Defaults 

 
 
 
 
 
 
 
 
 
 

Ensure that the 
“Preferred Preference” 
is set to “Survey 
Default”. 
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5.  Set Survey Default Preferences 
 

• In InRoads  - Select File Project Options. 
• In the Project Options dialog box select the General Tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Survey Default.  Click Load and Close. 
• In the Project Options dialog box - Click Apply and Close. 

 
Sets the Survey Defaults Preference. 

6.  Open each of the following files which are located in C:\InRoads Data\1234567\SDE 
Labs\Lab17. 
 

• 1234567_SDE.alg  
• 1234567_SDE.dtm  
• 1234567_XO.dtm  

 
The 1234567_SDE.alg, 1234567_SDE.dtm, and 1234567_XO.dtm are opened. 

7.  Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 
Explorer Interface).  If this tab is not visible – use the scroll bars to scroll to the Surfaces 
Tab. 
 
 
 
 
 
 
 
 
 
 
 
 
Opens the Surface Tab in the InRoads Explorer Interface. 

8.  In the [InRoads Software] –  
 
We will now ensure that the Active Surface is the 1234567_SDE surface (has a red 
rectangle) next to the 1234567_SDE name by performing the following steps: 

 
• Click on the Surfaces Tab (Located at the bottom – left hand side of the InRoads 

Explorer Interface).   
• Select the 1234567_SDE surface (by Left clicking) and the Name will highlight 

in blue. 
• Then (Right click) over the surface and a pop-up dialog will appear. 

 
 
 

Surfaces TAB 
Scroll Bars 
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• Click Set Active and a red rectangle will appear beside the 1234567_SDE 
Surface Name.      

 
 
Sets the “Active Surface” of 1234567_SDE.dtm. 

9.  Setting the Surface Properties: 
 
The SDE will need to set the default Surface Properties before submitting the DTM.  
The Surface Properties are settings that determine how the Existing ground will display 
in the Cross Sections and Profiles. 
 
In InRoads, Select SurfaceSurface Properties from the InRoads Menu and the 
Surface Properties dialog box will appear.  
 

• Click on the Advanced Tab (at the top of the Surface Properties dialog box.). 
• In the Surface: Pull-down – Ensure 1234567_SDE is selected. 

 
In the Cross Sections frame: 

• In the Symbology: Pull-down – select EXISTING 
 
In the Profiles frame: 

• In the Symbology: Pull-down – select EXISTING 
 
Leave all other entries as Default. 
 
The inputs should now correspond to the screen capture depicted in Figure L17-2.    
 
Opens the Surface Properties dialog box. 

 

Select “Set 
Active” 
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Figure L17-2 Surface Properties 

 
 

10.  Click Apply and then click Close to set the Surface Properties for the 1234567_SDE 
Surface.   
 
The 1234567_SDE Surface Properties are set. 

11.  Save the InRoads Surface Project: 
 
 Select FileSave Surface from the InRoads Menu.   
 
 The Surface Project (1234567_SDE.dtm) will be saved to Lab 17 in the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 17 
 
The 1234567_SDE Surface Project has now been saved to the following path: 
C:\InRoads Data\1234567\SDE Labs\Lab 17   
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Lab 17B Create 1234567_XO.dgn from the 1234567_XO.dtm and 
1234567_XO.fwd 

 
In this section of the lab you will learn how to create individual MicroStation files 
(1234567_XO.dgn, 1234567_XA.dgn, 1234567_XB.dgn, etc.) from the field enhanced DTM’s.  
You will also learn how to use the 1234567_XO.fwd to annotate Features such as pipe size, 
material, flow lines, Control Deltas, etc.  In later labs, you will be shown how to merge these 
individual MicroStation files into a 1234567_TOPO.dgn for submission to the ‘Engineering 
Management / Operations Manager’. 
 
 
 
12.  In the [InRoads Software] –  

 
We will now ensure that the Active Surface is the 1234567_XO surface. 
 

• Click on the Surfaces Tab (Located in the bottom – left hand side of the InRoads 
Explorer Interface).   

• Select the 1234567_XO surface (by Left clicking on it) and the Name will 
highlight in blue. 

• Then (Right click) over the surface 1234567_XO and a pop-up dialog will 
appear. 

 
 
 
 

                   
 
 
 
 
 

• Click Set Active and a red rectangle will appear beside the 1234567_XO Surface 
Name.      

 
Sets the “Active Surface” of 1234567_XO.dtm. 

Select “Set 
Active” 
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13.  Before proceeding, ensure that the Feature Filter lock is on. 
 

*HINT:  Go to Tools ► Locks.  Ensure a check mark exists next to Feature 
Filter. 

 
*WARNING: Failure to engage the Feature Filter lock will result in incorrect 

data being viewed in the 1234567_XO.dgn file. 
 

14.  • In InRoads, Select Surface ► View Surface ► Features.  The View Features 
dialog opens.  

• Verify that 1234567_XO is showing in the Surface: pull down window as shown 
in Figure L17-3. 

 
 
 

 
Figure L17-3 View Features 

 
 
 
 

Verify 1234567_XO  is 
displayed in the Surface 
pull down window. 
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15.  Apply the Filter TOPO.DGN.   
 

• In the View Features dialog, click the Filter button.  The Feature Selection 
Filter opens. 

• In the Feature Selection Filter dialog, use the pull down arrow next to Filter 
Name to select TOPO.DGN. 

• Verify your Feature Selection Filter dialog matches that shown in Figure L17-4. 
• Click OK. You are returned to the View Features dialog. 
• Click Apply and Close in the View Features dialog. 

  
 

 
Figure L17-4 Feature Selection Filter 

 
 
16.  Information Only: 

 
The Feature Filter named TOPO.DGN has been created in order to filter out just the 
required TOPO data for inclusion into 1234567_XO.dgn (or _XA, XB, XC, etc.). The 
118 Codes on the following pages will be viewed: 
 
Information regarding the codes which will be viewed in the 1234567_XO.dgn file. 
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Feature Filter Styles included in the Filter Named TOPO.DGN 
1  TOPO_E_DADB Drainage – Dam Toe 
2  TOPO_E_DCB Drainage – Catch Basin 
3  TOPO_E_DCWE Drainage – Culvert Wingwall End 
4  TOPO_E_DDCB Drainage – Double Catch Basin 
5  TOPO_E_DDI Drainage – Drop Inlet Top 
6  TOPO_E_DDL Drainage – Drain Lines 
7  TOPO_E_DDT Drainage – Dam Top 
8  TOPO_E_DEW Drainage – Edge of Water 
9  TOPO_E_DHWE Drainage – Headwall  End 
10  TOPO_E_DJB Drainage – Junction Box Top 
11  TOPO_E_DMISC Drainage – Miscellaneous 
12  TOPO_E_DOBSC Drainage – Obscured Area (Field) 
13  TOPO_E_DPD Drainage – Paved Ditch 
14  TOPO_E_DSB Drainage – Stream Bank Top 
15  TOPO_E_DSC Drainage – Stream Center F/L 
16  TOPO_E_DSE Drainage – Stream Edge of Water 
17  TOPO_E_DSPURDK Drainage – Spur Dike 
18  TOPO_E_DSTC Drainage – Septic Tank Center 
19  TOPO_E_DSWE Drainage – Swamp Edge 
20  TOPO_E_DWB Drainage – Wetland Boundary 
21  TOPO_E_MDITCHFL Drainage – Ditch Flow Line (Mapping) 
22  TOPO_E_MOBSC Drainage – Obscured (Mapping) 
23  TOPO_E_TAC Topography – Asphalt Curb 
24  TOPO_E_TBAS Topography – Approach Slab 
25  TOPO_E_TBC Topography – Brick Column 
26  TOPO_E_TBCL Topography – Bridge Centerline 
27  TOPO_E_TBGL Topography – Bridge Gutterline 
28  TOPO_E_TBLD Topography – Building corner 
29  TOPO_E_TBLDRL Topography – Building Roof Line 
30  TOPO_E_TBRDGCEN Topography – Bridge End, Center 
31  TOPO_E_TBRDGCOR Topography – Bridge End, Corner 
32  TOPO_E_TCAN Topography – Canopy 
33  TOPO_E_TCBA Topography – Construction Boundary Active 
34  TOPO_E_TCBF Topography – Construction Boundary Finished 
35  TOPO_E_TCEM Topography – Cemetery 
36  TOPO_E_TCGF Topography – Curb & Gutter F/L 
37  TOPO_E_TCGT Topography – Curb & Gutter Top 
38  TOPO_E_TCUL Topography – Cultivation Line 
39  TOPO_E_TEAD Topography – Edge Asphalt Drive 
40  TOPO_E_TEAP Topography – Edge Asphalt Pavement 
41  TOPO_E_TEAS Topography – Edge Asphalt Shoulder 
42  TOPO_E_TECD Topography – Edge Concrete Drive 
43  TOPO_E_TECP Topography – Edge Concrete Pavement 
44  TOPO_E_TEDD Topography – Edge Dirt Drive 
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45  TOPO_E_TEDR Topography – Edge Dirt Road 
46  TOPO_E_TENDROLL Topography – Bridge Endroll 
47  TOPO_E_TEST Topography -  Edge Surface Treatment Road 
48  TOPO_E_TETL Topography -  Existing Topo Edge Travel Lane 
49  TOPO_E_TFBW Topography – Fence Barbed Wired 
50  TOPO_E_TFFW Topography – Fence Field Wire 
51  TOPO_E_TFP Topography – Flag Pole 
52  TOPO_E_TFT Topography – Fuel Tank 
53  TOPO_E_TFW Topography – Fence Wood 
54  TOPO_E_TG Topography – Gate 
55  TOPO_E_TGFV Topography – Gas Filler Valve 
56  TOPO_E_TGMW Topography – Gasoline Monitoring Well 
57  TOPO_E_TGP Topography – Gasoline Pump 
58  TOPO_E_TGPI Topography – Gasoline Pump Island 
59  TOPO_E_TGR Topography – Guardrail 
60  TOPO_E_TGRV Topography – Grave 
61  TOPO_E_TGST Topography – Gasoline Storage Tank 
62  TOPO_E_TGVP Topography – Gasoline Vent Pipe 
63  TOPO_E_THC Topography – Header Curb 
64  TOPO_E_THCR Topography – House Corner 
65  TOPO_E_THM Topography – Historical Monument 
66  TOPO_E_THRL Topography – House Roof Line 
67  TOPO_E_TIRRLMT Topography – Irrigation Limits 
68  TOPO_E_TIRRPVTP Topography – Irrigation Pump Turning Point 
69  TOPO_E_TMAR Topography – Marker 
70  TOPO_E_TMHCR Topography – Mobile Home Corner 
71  TOPO_E_TMHRL Topography – Mobile Home Roof Line 
72  TOPO_E_TMISC Topography – Miscellaneous 
73  TOPO_E_TMPR Topography – Mile Post Railroad 
74  TOPO_E_TPBL Topography – Point on Break Line 
75  TOPO_E_TRCL Topography – Railroad Centerline 
76  TOPO_E_TRCR Topography – Railroad Top of Rail 
77  TOPO_E_TRCRE Topography – Railroad Top of Rail 
78  TOPO_E_TS Topography – Steps 
79  TOPO_E_TSATDSH Topography – Satellite Dish 
80  TOPO_E_TSC Topography – Sign Center 
81  TOPO_E_TSE Topography – Sign End 
82  TOPO_E_TTRE Topography – Tree Center 
83  TOPO_E_TUD Topography – Uncovered Deck 
84  TOPO_E_TVF Topography – Vinyl (PVC) Fence 
85  TOPO_E_TVG Topography – Valley Gutter 
86  TOPO_E_TWF Topography – Wall Face 
87  TOPO_E_TWFB Topography – Wall Face Bottom 
88  TOPO_E_TWFT Topography – Wall Face Top 
89  TOPO_E_TWL Topography – Woods Line 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 17 
 
 

   
 Lab17-12   

90  TOPO_E_XXA Surveyor Defined Value 
91  TOPO_E_XXB Surveyor Defined Value 
92  TOPO_E_XXC Surveyor Defined Value 
93  TOPO_E_XXC Surveyor Defined Value 
94  TOPO_E_XXE Surveyor Defined Value 
95  TOPO_E_XXF Surveyor Defined Value 
96  TOPO_E_XXG Surveyor Defined Value 
97  TOPO_E_XXI Surveyor Defined Value 
98  TOPO_E_XXH Surveyor Defined Value 
99  TOPO_E_XXJ Surveyor Defined Value 
100  TOPO_E_XXK Surveyor Defined Value 
101  TOPO_E_XXL Surveyor Defined Value 
102  TOPO_E_XXM Surveyor Defined Value 
103  TOPO_E_XXN Surveyor Defined Value 
104  TOPO_E_XXO Surveyor Defined Value 
105  TOPO_E_XXP Surveyor Defined Value 
106  TOPO_E_XXQ Surveyor Defined Value 
107  TOPO_E_XXR Surveyor Defined Value 
108  TOPO_E_XXS Surveyor Defined Value 
109  TOPO_E_XXT Surveyor Defined Value 
110  TOPO_E_XXU Surveyor Defined Value 
111  TOPO_E_XXV Surveyor Defined Value 
112  TOPO_E_XXW Surveyor Defined Value 
113  TOPO_E_XXX Surveyor Defined Value 
114  TOPO_E_XXY Surveyor Defined Value 
115  TOPO_E_XXZ Surveyor Defined Value 
116  TOPO_E_XXZA Surveyor Defined Value 
117  TOPO_E_XXZB Surveyor Defined Value 
118  TOPO_E_XXZC Surveyor Defined Value 
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17.  In MicroStation, Click the Fit View button. 
 

18.  Verify your view, in MicroStation, matches that shown in Figure L17-5 below. 

 
 
 

 
Figure L17-5 MicroStation  

 
 
 
 
 

 
19.  For Information Only: 

 
Surveyors and SDE’s may be accustomed to seeing point numbers when viewing points, 
lines and chains in CAiCE.  The designers often used CAiCE to obtain more information 
by viewing the details of the points and lines such as pipe sizes, materials flow lines, 
culvert sizes and other information.  In InRoads, when data is exported from the Survey 
Module to the Surface Model this information is lost.  Steps 20 through 33 provide 
instructions for annotating this information in the 1234567_XO.dgn (XA, XB, etc.) file 
from the 1234567_XO.fwd (XA, XB, etc.) file. 
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20.  In InRoads, Make the Survey Tab located along the bottom of the InRoads Explorer 
Interface the active tab as shown here: 
 

                                           
      

21.  In InRoads, open the file 1234567_XO.fwd which is located in C:\InRoads 
Data\1234567\SDE Labs\Lab17.  Click Open and then click Cancel. The InRoads 
Explorer Interface should now appear as shown here:           

                                          
 

22.  In MicroStation, notice the view changed when the .FWD file was opened.  The reason 
for this is that in InRoads the default operation is to automatically view planimetrics 
whenever a new .FWD file is opened and automatically fits the view.  It is good practice 
to turn off planimetrics. 
 

• In InRoads, select Survey ► View Survey Data.  Uncheck Planimetrics. 
• In MicroStation, click the View Previous icon.  This returns the view to that 

shown in Figure L17-5. 
 

              
                                                     
                                                  View Previous 
 

23.  In InRoads, set the Survey Scale Factor.  
 
     *NOTE: This is not the same as the Global Scale Factor set earlier in this lab.  The 

Global Scale Factor controls scaling of elements in the Surface and 
Geometry modules but not the Survey module. 

 
• Select Survey ► Fieldbook Data…  The Fieldbook Data dialog opens as 

shown in Figure L17-6. 
• In the Fieldbook Data dialog click the Survey Options button (      ) as shown in 

Figure L17-6.  The Survey Options dialog opens as shown in Figure L17-7. 

Make the Survey tab 
the active tab. 

1234567_XO is now open 



 Introduction to InRoads - SDE  InRoads SS2 – Lab 17 
 

   
 Lab17-15   

 
Figure L17-6 Fieldbook Data  

 
 

 
Figure L17-7 Survey Options 

Survey Options button 
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24.  • In the Survey Options dialog click the Preferences button. The Preferences 
dialog opens as shown here.   

 

 
 

• Select the 50 Scale Preference.   
• Click Load and Close. 
• Verify your entries match those shown in Figure L17-8. 
• Click OK. 

 
 

 
Figure L17-8 Survey Options 
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25.  • Close the Fieldbook Data dialog by clicking the red X (       ) in the top right 

corner. 
 

26.  • Select Survey ► View Survey Data ► Write Survey Data to Graphics.  The 
Write Survey Data to Graphics dialog opens. 

 
27.  • In the Write Survey Data to Graphics dialog, click the Filter button.  The 

Survey Style Filter dialog opens. 
• In the Survey Style Filter dialog, select Topo Annotation from the Filter Name 

pull down. 
• The Topo Annotation filter views the annotation for the following 17 Features. 

 
o TOPO_E_DCEF o TOPO_E_TDR 
o TOPO_E_DPC o TOPO_E_TFCL 
o TOPO_E_DPM o TOPO_E_TKMP 
o TOPO_E_DPP o TOPO_E_TMPH 
o TOPO_E_SDCD o TOPO_E_TMPR 
o TOPO_E_SLCD o TOPO_E_TSW 
o TOPO_E_SLCM o TOPO_E_TTRE 
o TOPO_E_SNGSCM o TOPO_E_TWELL 
o TOPO_E_TDD  

 
• Verify the Survey Style Filter dialog matches that shown in Figure L17-9. 
• Click OK to close the Survey Style Filter dialog and return to the Write Survey 

Data to Graphics dialog. 
 

 

 
Figure L17-9     Survey Style Filter 
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28.  • In the Write Survey Data to Graphics dialog, place a check mark in the box 
next to Planimetrics as shown in Figure L17-10 

• Click Apply and Close. 
 

 
 

 
Figure L17-10 Write Survey Data Dialog 

 
 
29.  • The Features listed in Step 27 have now been annotated.  Verify your view in 

MicroStation matches that shown in Figure L17-11. 
• If your view does not match that shown in Figure L17-11  -- perform the 

following step: 
• In MicroStation, click the View Previous icon.  This returns the view to that 

shown in Figure L17-11. 
 

                              
                                                           
                                                               View Previous 
 

 

Ensure the Planimetrics 
box is checked. 
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Figure L17-11 MicroStation Window 

 
30.   

• In MicroStation, click the Fit View icon. 
 

 
                                             
                                             Fit View 
 
 

• In MicroStation, select File ► Compress ► Design.  This reduces the 
MicroStation file size. 

• In MicroStation, Select File ► Save As.  The Save As dialog opens as shown in 
Figure L17-12. 
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Figure L17-12 Save As Dialog 

 
 

31.   
• In the Save As dialog, Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 

17. 
• In the File name: field key-in 1234567_XO.dgn. 
• In the Save as type: pull-down select MicroStation V8 DGN Files (*.dgn) 
• Verify your entries match those shown in Figure L17-13. 
• Click Save.   
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Figure L17-13 Save As Dialog 

 
 
 
 
 
32.   

• In MicroStation, Look at the Title bar located at the top of the MicroStation 
window.  It reads C:\InRoads Data\1234567\SDE Labs\Lab 
17\1234567_XO.dgn as shown here and not GDOT _3D_Working File.dgn.  It 
is important to know that when you saved the file, you were automatically exited 
from your current file and opened into the new file. 

 
                                 MicroStation Title Bar        
 

 
 

• We are finished creating the 1234567_XO.dgn file and do not want to make any 
changes to it.   

• Close MicroStation and InRoads. 
 

To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
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33.  For Information Only: 
At this point you have finished creating the 1234567_XO.dgn which includes the 
topographical information picked up during the field survey enhancement process and the 
annotation of certain items.  This same process is used to create a 1234567_XA.dgn, 
1234567_XB.dgn, etc.  In Lab 17C you will learn how to merge these .dgn’s into the 
final 1234567_TOPO.dgn for submission to the ‘Engineering Management / Operations 
Manager’. 
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Lab 17C  Create 1234567_TOPO.dgn for Delivery to the Designer 
 
At this time you now have two MicroStation .dgn files.  One called 1234567_XO.dgn, 
created in the previous section and one called 1234567_Map.dgn.  In practice the 
1234567_Map.dgn file will be created by the Photogrammetry Office and replaces the 
TOPO.dgn file the SDE is accustomed to receiving.  For this lab - the 1234567_Map.dgn file 
has been provided.  In this section of the Lab you will be creating the 1234567_TOPO.dgn 
file for submission to the ‘Engineering Management / Operations Manager’.  The following 
workflow is used to create and prepare the 1234567_TOPO.dgn file.  
 
 

1. Create 1234567_XO.dgn from the 1234567_XO.dtm field enhanced survey.  
(Performed in Lab 17B) 

2. Copy and rename 1234567_Map.dgn to 1234567_TOPO.dgn  (The 
1234567_MAP.dgn file is the initial Planimetrics file provided by the Photogrammetry 
Office) 

3. Merge the 1234567_XO.dgn file into the 1234567_TOPO.dgn file. 
4. Apply the MicroStation TOPO filter to 1234567_TOPO.dgn file. 

 
 
 

34.  Copy the 1234567_Map.dgn--- 
 

• From the desktop, double-click on the My Computer icon, shown here. 
 

                     
 
This will open the My Computer window.  This is your computer’s file manager.  Via this 
dialog box, you may view the content of your computer’s hard drive, CD drive, Network 
drives and flash drives. 

35.  Navigate to C:\InRoads Data\1234567\SDE Labs\Lab 17.   The 1234567_Map.dgn file 
will be located in this folder.   

     *NOTE: In a real world project the 1234567_Map.dgn file will be located in the       
C:\InRoads Data\1234567\Photogrammetry folder. 

 
36.  Make a Copy of C:\InRoads Data\1234567\SDE Labs\Lab 17\1234567_Map.dgn and 

Name it 1234567_TOPO.dgn.  This may be accomplished by Right Mouse clicking over 
the file and selecting Copy then Paste then Rename. 
 
Makes a copy of 1234567_Map.dgn and renames it to 1234567_TOPO.dgn 

37.  Verify that you have successfully copied and renamed 1234567_Map.dgn to 
1234567_TOPO.dgn.  Your Explorer window should now match that shown in Figure 
17-14. 
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Figure L17-14 My Computer  

 
 
 

38.  • Close the My Computer window. 
 
 

39.  • Double click the MicroStation Icon to open MicroStation: 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears -- navigate to 
 C:\InRoads Data\1234567\SDE Labs\Lab 17. 

• Select 1234567_TOPO.dgn and click Open.  It is not necessary to enter InRoads 
for this step. 

• Click the Fit View button. 
 

                           
                                         
                                         Fit View  
 
 
 

• Verify your view in MicroStation matches that shown in Figure L17-15. 
 

You should now have a file 
listed that is named 
1234567_TOPO.dgn.  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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40.  Information Only: 
 
At this time the 1234567_TOPO.dgn file currently contains only mapping information in 
it and is incomplete.  It is necessary to merge the 1234567_XO.dgn into the 
1234567_TOPO.dgn to complete the 1234567_TOPO.dgn.   Steps 41 through 47 
describes the process to merge a reference file into an Active Design file. 
 

 

 
Figure L17-15 MicroStation Window 

 
 
41.  In MicroStation, select File ► References.  The References dialog box opens as shown 

in Figure L17-16. 
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Figure L17-16 References 

 
 
 

42.  For Information Only: 
 
A Reference File is defined as a Design File that is attached to and viewed simultaneously 
with the Active Design File.  Once a Design File has been attached as a Reference File to 
an Active Design File, tools are available that allow the attached Reference File to be 
merged into the Active Design file.  The following steps describe merging a Reference 
File into an Active Design File. 
 

43.  • In the References dialog box, select Tools ► Attach.  The Attach Reference 
dialog opens. 

• Navigate to C:\InRoads Data\1234567\SDE Labs\Lab17\ 
• Change the Attachment Method (located on the right side of the box) to 

Coincident World by using the pull-down arrow.   
 
*IMPORTANT:  Failure to properly set the attachment mode may result in the 

Reference File being attached in the wrong coordinate system. 
 

• Select 1234567_XO.dgn 
• Verify your settings look similar to those shown in Figure L17-17. 
• Click Open.  You are returned to the References dialog box. 
• Notice in Figure L17-18 that the file 1234567_XO.dgn is now listed in the 

References dialog indicating it has been attached as a Reference File. 
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Figure L17-17 Attach Reference 

 
   

 
Figure L17-18 References 

 
 
 
 
 
 

1234567_XO.dgn is attached 
as a Reference File to 
1234567_Topo.dgn and is 
listed in the References dialog. 
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44.  • In the References dialog box left click on 1234567_XO.dgn to ensure it is 
highlighted and has the two check marks listed as shown in Figure L17-18 above.   

 
*NOTE: If the file is not highlighted, the Merge Into Master command in the next 
step will not be available to use. 

 
45.  • In the References dialog box select Tools ► Merge Into Master. 

• Notice in the bottom left corner of the MicroStation window you are prompted to: 
Merge References < Select View For Merge… as shown here 
                        
 

• Left Click anywhere in the MicroStation view window. 
• If an Alert Message appears that reads ‘You Have Selected 1 References To 

Merge Into The Current Design’, Click OK. 
• Notice in the bottom middle of the MicroStation window the message: 1 

references merged into active model. 
                      

 
• Close the References dialog by clicking the Red X in the top Right Corner of the 

References dialog box. 
• In MicroStation, Select File ► Compress ► Design. 

 
The file 1234567_XO.dgn has been successfully merged into 1234567_TOPO.dgn 

46.  For Information Only: 
 
You have now completed creating the 1234567_TOPO.dgn file.  The 
1234567_TOPO.dgn file at this point is considered the original 1234567_TOPO.dgn file.  
Survey enhancements picked up during the life of the project shall be included in this file 
following the steps described in Labs 17B and 17C. 
 

47.  The 1234567_TOPO.dgn is now complete and ready to be provided to the designer.  
When all associated DGN files are ready, the SDE is instructed to contact the 
Engineering Management / Operations Manager and make copies available on 
SDEcommon.  The  Engineering Management / Operations Manager will keep all 
orignal copies and inform the designer where they may be acquired.  The SDE is also 
instructed to obtain original copies from the Engineering Management / Operations 
Manager whenever enhancements are to be performed during the life of the project. 
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Lab 17D  Create 1234567_UTLE.dgn for Delivery to the Designer 
 
In this section of the Lab you will learn how to create the 1234567_UTLE.dgn file for 
submission to the Engineering Management / Operations Manager.  The 1234567_UTLE.dgn 
file replaces the UTIL.dgn file produced in the past by the DGN.CMD program. 
 
 
48.   

• In MicroStation, Select File ► Open.  
• Navigate to C:\InRoads Data\1234567\SDE Labs\Standards\ and Open the file 

GDOT 3D Working File.dgn 
 

49.  In MicroStation, 
• Select Edit ► Select All. 
• Click the Delete button as shown here.   

 
This ensures the MicroStation working file is clear of all elements and is ready to proceed. 

50.  Now open InRoads from within MicroStation by selecting InRoads  InRoads Suite 
(SELECTseries 2) V8i 08.11.07.566 from the [MicroStation Menu]. 
 

51.  • In InRoads, Click File ► Open and browse to the Surface File 1234567_SDE.dtm 
located in C:\InRoads Data\1234567\SDE Labs\Lab 17. 

• Select the 1234567_SDE.dtm file and then click Open and then click Cancel. 
 

52.  In InRoads, Ensure the Feature Filter lock is turned on.  This may be accomplished by 
selecting Tools ► Locks and ensuring a check mark exists next to Feature Filter.  
 
     *NOTE:  As stated previously, failure to have the correct lock setting will result in 

incorrect information being viewed. 
 

53.  Select Surface ► View Surface ► Features.  The View Features dialog box opens. 
 

54.  Click the Filter button.  The Feature Selection Filter dialog opens. 

55.  Select the Filter Name UTLE.DGN from the pull down arrow and click OK. 

56.  Information Only: 
 
The Feature Filter named UTLE.DGN has been created in order to filter out just the 
required existing utility data for inclusion into 1234567_UTLE.dgn.   
 
Information regarding the codes which will be viewed in the 1234567_UTLE.dgn file. 
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Feature Filter Styles included in the Filter Named UTLE.DGN 

1  TOPO_E_TMPR TOPO – Mile Post Railroad 
2  TOPO_E_TRCL TOPO – Railroad Centerline 
3  TOPO_E_TRCR TOPO – Railroad Centerline 
4  TOPO_E_UELBOX UTILITY – Electrical Box 
5  TOPO_E_UFH UTILITY – Fire Hydrant center 
6  TOPO_E_UGM UTILITY – Gas Meter 
7  TOPO_E_UGP UTILITY – Guy Pole 
8  TOPO_E_ULP UTILITY – Light Pole 
9  TOPO_E_UMHE UTILITY – Manhole Electrical 
10  TOPO_E_UMHSS UTILITY – Manhole Sanitary Sewer Top 
11  TOPO_E-UMHSSF UTILITY – Manhole Sanitary Sewer Flow line 
12  TOPO_E_UMHST UTILITY – Storm Sewer 
13  TOPO_E_UMHSTF UTILITY – Storm Sewer Flow line 
14  TOPO_E_UMHT UTILITY – Manhole Telephone 
15  TOPO_E_UNGLM UTILITY – Gas Line Marker 
16  TOPO_E_UNGV UTILITY – Gas Valve 
17  TOPO_E_UNGVP UTILITY – Gas Vent Pipe 
18  TOPO_E_UOEL UTILITY – Overhead Electrical Line 
19  TOPO_E_UOTL UTILITY – Overhead Telephone Line 
20  TOPO_E_UPGA UTILITY – Pole Anchor 
21  TOPO_E_UPP UTILITY – Power Pole center 
22  TOPO_E_USSL UTILITY – Sanitary Sewer Line center 
23  TOPO_E_USTRPOL UTILITY – Strain Pole 
24  TOPO_E_UTCM UTILITY – Cable Marker 
25  TOPO_E_UTP UTILITY – Telephone Pole center 
26  TOPO_E_UTPD UTILITY – Telephone Pedestal 
27  TOPO_E_UWM UTILITY – Water Meter 
28  TOPO_E_UWV UTILITY – Water Valve 
29  TOPO_E_UYLE UTILITY – Yard Light Electric 
30  TOPO_E_UYLG UTILITY – Yard  
 

 
57.  You are returned to the View Features dialog box with only the filtered Features 

displayed as shown in Figure L17-19. 
 

• Notice the Features are all highlighted in blue.  This indicates they are all 
selected for viewing. 

• If the Features are not selected for viewing (highlighted in Blue) select them by 
Right mouse clicking over them and clicking Select All in the pop up box. 

• Click Apply and Close. 
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Figure L17-19 View Features 

 
58.  In MicroStation, click the Fit View button.   

 
59.  Verify your view matches that shown in Figure L17-20. 

 
 
 

 
Figure L17-20 MicroStation Window 

 

Verify all the Features are 
highlighted in Blue.  This 
indicates they are selected 
for viewing. 
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60.  Create the 1234567_UTLE.dgn file. 
 

• In Microstation, Select File ► Compress ► Design.  This reduces the file size of 
the Microstation file. 

• In Microstation, Select File ► Save As.  The Save As dialog opens. 
                   

61.  In the Save As dialog, navigate to C:\InRoads Data\1234567\SDE Labs\Lab 17\ 

62.  • In the File Name: entry field key in 1234567_UTLE.dgn  
• In the Save as type: pull-down select MicroStation V8 DGN Files (*.dgn) 

 
63.  Verify your entry matches that shown in Figure L17-21 and click Save. 

 
 

 
Figure L17-21 Save As  

 
 

64.  For Information Only: 
 
When the Save As command is used to save the ‘GDOT 3D Working File.dgn’ as 
1234567_UTLE.dgn (or any other file name)  you are no longer in the ‘GDOT 3D 
Working File.dgn’ you are in the 1234567_UTLE.dgn.  It is very important to be aware 
of this so you don’t continue using the file for viewing operations.  It is important to 
reopen the ‘GDOT 3D Working File.dgn’ workspace to continue working.  The user may 
determine which file is open by looking at the title bar as shown in Figure L17-22.  The 
Title Bar is across the top of the MicroStation Window that contains path and file 
information. 
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Figure L17-22 MicroStation 

 
 
 

65.  For Information Only: 
 
You have now completed creating the 1234567_UTLE.dgn file.  The 
1234567_UTLE.dgn file at this point is considered the original 1234567_UTLE.dgn file.  
Survey enhancements picked up during the life of the project shall be included in this file 
following the steps described in Labs 17B and 17D. 
 

66.  The 1234567_UTLE.dgn is now complete and ready to be provided to the designer.  
When all associated DGN files are ready, the SDE is instructed to contact the 
Engineering Management / Operations Manager and make copies available on 
SDEcommon.  The  Engineering Management / Operations Manager will keep all 
orignal copies and inform the designer where they may be acquired.  The SDE is also 
instructed to obtain original copies from the Engineering Management / Operations 
Manager whenever enhancements are to be performed during the life of the project. 
 

67.  You may now Exit MicroStation and InRoads. 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
 
This closes BOTH the MicroStation and InRoads Software(s).   

68.                    
                  This concludes Lab 17 and the Survey Processing Tutorials. 
 
 

 

The title bar tells you the path 
and filename of the file you are 
currently in. Be certain of the 
file you are in before working. 


	SDE_Revisions.pdf
	Revisions

	SDE_Blank.pdf
	This Page Left Intentionally Blank

	SDE_LabIntro.pdf
	Introduction

	SDE_Lab1.pdf
	Lab 1
	Lab1B Start InRoads
	Figure L1-3 Starting MicroStation V8i and InRoads Suite

	SDE_Lab2.pdf
	Lab 2

	SDE_Lab3.pdf
	Lab 3

	SDE_Lab4.pdf
	Lab 4

	SDE_Lab5.pdf
	Lab 5

	SDE_Lab6.pdf
	Lab 6

	SDE_Lab7.pdf
	Lab 7

	SDE_Section Two.pdf
	2

	SDE_Lab8.pdf
	Lab 8

	SDE_Lab9.pdf
	Lab 9

	SDE_Section Three.pdf
	3

	SDE_Lab10.pdf
	Lab 10

	SDE_Lab11.pdf
	Lab 11

	SDE_Lab12.pdf
	Lab 12

	SDE_Lab13.pdf
	Lab 13

	SDE_Lab14.pdf
	Lab 14

	SDE_Lab15.pdf
	Lab 15

	SDE_Section Four.pdf
	4

	SDE_Lab16.pdf
	Lab 16

	SDE_Lab17.pdf
	Lab 17

	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	SDE_Lab16.pdf
	Lab 16

	SDE_Lab17.pdf
	Lab 17


