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Course Overview 
 

 

COURSE DESCRIPTION  
This course teaches a workflow to use InRoads and the Bentley Quantity Manager to assign pay items 
to DTM and graphic elements, extract and calculate the design quantities from those elements, and 
report on the calculated quantity values.  

COURSE OBJECTIVES  
After completing this course, you will be able to:  

• Assign pay items to DTM and graphic elements.  
• Compute quantities from the assigned pay items.  
• Create reports on the computed pay item quantities.  
• Export computed pay items to AASHTO Trns•port software.  
• Maintain pay item database.  

TARGET AUDIENCE  
This course is recommended for the following audience(s):  

• Engineers and designers who need to calculate design quantities from engineering 
designs and drawings.  
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PREREQUISITES  
• Working knowledge of Microsoft Windows operating system.  
• Experience in road design.  
• Working knowledge of MicroStation functionality equivalent to the topics taught in 

the Bentley Institute Essential MicroStation or Moving to MicroStation courses.  
• Working knowledge of InRoads functionality equivalent to the topics taught in the 

Bentley Institute InRoads Fundamentals course.  

EXPECTATIONS  

WHAT THIS COURSE PROVIDES  
This course provides a workflow to use the Quantity Manager tools to gather pay item quantities and 
export them to a separate software application such as the AASHTO Trns•port software for processing 
and preparing bid estimates.  

The workflow taught in this course covers how to assign pay items to InRoads and MicroStation 
elements, compute quantities and extract them to a quantity database, produce reports on the 
quantities, and export the quantities to the AASHTO Trns•port software.  

The training also includes an overview to managing the Pay Item database including how to add, 
delete, and modify pay item definitions.  

WHAT THIS COURSE DOES NOT PROVIDE  
This course does not provide a comprehensive review or instruction of the Quantity Manager tools 
such as payer and funding participation, and funding rules.  

This course is not an administration course and therefore does not cover installation and 
administration topics.  
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MODULES INCLUDED  
The following modules are included in this course:  

• Assigning Quantities  
• Computing and Extracting Quantities  
• Reporting and Exporting  
• Managing the Pay Item Database  

COURSE EXERCISES  
The Exercises for each chapter are independent of one another and can be used without having to 
complete the exercises in previous chapters. Most exercises use an InRoads project file (*.rwk). When 
you load the project file, other supporting files such as surfaces, geometry databases, etc. are loaded.  

 

The folder structure used during the exercises are as follows:  

• For practice during the lesson:  

C:\InRoads Training\ Quantity Manager Lab\Practice\Practice Lesson #  

 
Where # is the chapter number.  
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Assigning Quantities  
 

 

OVERVIEW  
This module teaches how to assign pay items and quantities to InRoads DTM and MicroStation graphic 
elements. Assigning the pay items is the first step in being able to report on, or export, those 
quantities to external applications such as the AASHTO Trns•port Estimator software.  

 

PREREQUISITES  
• Pay Item Database  
• InRoads DTM elements and/or MicroStation graphics  

OBJECTIVES  
After completing this module, you will be able to:  

• Understand general workflow for computing quantities  
• Understand basic principles for how quantities are computed  
• Assign pay items to InRoads DTM elements  
• Assign pay items to MicroStation graphic elements  
• Edit and review assigned pay items  
• Create shapes for pay item assignments  
• Customize formula used to compute quantities  
• Override computed quantities with input values  
• Assign “supplemental descriptions” to pay items  

 

  

 



9  Nov - 12 

Copyright © 2012 Bentley Systems, Incorporated 

INTRODUCTION TO QUANTITY MANAGER  
Quantity Manager is a standalone database application that receives pay item quantity values from 
Bentley Civil design software such as InRoads and GEOPAK. While the Quantity Manager application 
has many features, the most important are reporting on the pay item quantities and exporting the 
quantities to external applications such as the AASHTO Trns•port software. The external applications 
are commonly used to assign costs to the pay items quantities, prepare bid packages, and more. The 
Quantity Manager application has similar capabilities to these external applications but those will not 
be covered during this training.  

Two independent software applications make up the quantity calculation and reporting process 
sometimes referred to as “Quantity Manager”. The first application is the InRoads software which 
includes an add-in application for quantities. The quantity tools in InRoads are used to:  

• Define pay items  
• Define pay item formulas  
• Assign pay items to InRoads DTM features  
• Assign pay items to MicroStation graphics  
• Review/Edit pay item assignments  
• Create DTM feature shapes from graphics  
• Compute quantities from DTM features and graphics  
• Create quantity database  

The second application is the Quantity Manager application. This software runs independent of 
InRoads. Although this application has many advanced capabilities, the workflow introduced in this 
course will focus on the following core tasks with the Quantity Manager application.  

• Read quantity database created by InRoads  
• Export quantity information to external applications such as Trns•port  
• Create reports on quantity information  
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WORKFLOW OVERVIEW  
The following workflow is recommended for using the InRoads Quantity add-in application and the 
Quantity Manager application to compute and report on project pay item quantities.  

The underlined, bold text in each box in the workflow diagram indicates which software (MicroStation, 
InRoads, or Quantity Manager) is used for that task of the workflow.  

 
 

• Define InRoads DTM features and/or create MicroStation graphics for each element 
in the project that needs to be quantified.  

• Assign pay items to InRoads DTM or MicroStation graphic elements.  
• Compute and extract quantities from MicroStation and InRoads. The results are 

written to a Quantity Manager database.  
• Use Quantity Manager application to review, report, and export pay item quantities 

to external applications such as the AASHTO Trns•port software.  
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OPEN MICROSTATION AND INROADS 
 

 Open the GDOT MicroStation workspace 
1. Open the GDOT MicroStation workspace by clicking on the yellow icon shown here. 

   
2. Navigate to C:\InRoads Training\Quantity Manager Lab\Practice\Practice Lesson 02\.  
3. Open the file Assigning Quantities.dgn.  

 Start InRoads 

1. Open InRoads from the MicroStation menu bar. 
2. The Quantities option should appear in the InRoads menu.  
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LOADING PROJECT FILES  
Before any work can be done, the project files need to be loaded into InRoads. The most common 
project files required include:  

• CAD (.dgn) – Required  
• Preference (.xin) – Required  
• Pay Item Database (.mdb) – Required  
• Geometry (.alg) – Required  
• Surface (.dtm) – Optional  

 Open Project File  
1. Select File > Open from the InRoads menu. 
2. Open the Project File C:\InRoads Training\Quantity Manger Lab\RWK\Practice Lesson 

02.rwk.  

This will open the preference file: GDOT_Standard V8i_SS2.xin 

And the geometry file: Assigning Quantities.alg  

And the design surface: Assigning Quantities.dtm  

3. Close the Open dialog.  

 Loading the Pay Item Database  
1. Select Quantities > Pay Item Manager from the InRoads menu.  

The Pay Item Manager dialog appears. 

2. From the Pay Item Manager, select File > Open. 
3. Open the pay item database file C:\InRoads Training\Quantity Manger Lab\Standards\Pay 

Items\GDOT(PI#) Quantity Manager Pay Item Database.mdb. 
 

Because changes will be required to the pay item definitions on a project by project basis, it is 
necessary that each project have a copy of the master pay item database that is modified to 
satisfy project specific requirements.  The recommended naming scheme for the pay item 
database is PI# Quantity Manager Pay Item Database.mdb (i.e. 1234567 Quantity Manager 
Pay Item Database.mdb).  GDOT’s master pay item database is extracted to C:\InRoads 
Data\Standards when the InRoadsALL.exe is run. 

 
4. Click Exit to Exit the Pay Item Manager dialog.  

It is not necessary to have the Pay Item Manager dialog visible to use the pay items.  
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UNDERSTANDING PAY ITEM CALCULATIONS  
Pay items can be assigned to both MicroStation graphics and InRoads DTM features. This flexibility is 
important because some elements of the project plans will be engineered and designed in InRoads 
while others will be simple graphics drawn in the plan files. Although the same tools are used to 
assign, review, and edit pay items on graphic and DTM features, there are a few small differences in 
how they behave.  

Multiple pay items can be assigned to each element. Assigning multiple pay items to a single element 
allows comprehensive construction quantities to be calculated. For example, a section of guardrail 
may be constructed from the rail section and an end treatment on each end of the rail section. It 
might even be required to construct a curb along the rail and pave the area around the end treatment. 
In this example, multiple pay items are required for the rail section, end treatment, curb, and paving.  

This training does not cover how to setup and administer the pay item database. However, having a 
general understanding of some of the options each pay item can have will help you understand how 
the quantities are computed. Please refer to the online help for additional assistance with the pay 
item definitions.  

MEASUREMENT BASIS OF PAY ITEMS  
InRoads and the Quantity Manager compute pay items using an each, linear, or area measurement 
basis.  

• Each – The each measurement basis can be applied to any element such as a cell or a 
line. No additional variables are needed for an each computation since each element 
is counted.  

Note There are options within the Pay Item definition that control how multiple 
vertices are counted. For example, if an Each measurement basis is assigned to a 
line string with 5 vertices, is it computed as a quantity of one (element) or five 
(vertices)?  

• Linear – A linear measurement basis is most commonly applied to elements such as 
curb, paint strip, guardrail, pipe, and such where a linear quantity is desired. A linear 
quantity can be calculated from one or more elements. To compute a quantity from a 
string of multiple elements, the elements must be grouped together as a complex 
chain. If the elements are not grouped, quantities will be reported individually for 
each element instead of the sum of all elements being reported as a single quantity.  

 
In some situations it may be desirable to setup a pay item that reports a linear quantity 
from an individual element such as a point or a cell. For example, assume a standard 18 
feet of curb needs to be computed at each guardrail terminator location. The guardrail 
terminator is defined with a cell and computed as an each element. The curb pay item will 
be setup as a linear measurement method with a variable that defines the length. A 
formula associated with the pay item defines that the pay item quantity is calculated by 
multiplying the variable (assigned a value of 18) by the number of elements (computed 
from the each measurement basis). The result is a quantity of 18 feet no matter the size of 
the guardrail terminator.  
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• Area – The linear measurement basis is used to calculate an area quantity. Area 

quantities can be calculated from closed elements or from a series of individual 
elements that form a closed area. To compute an area quantity from multiple 
elements, the elements must be grouped together as a complex shape. If the 
elements are not grouped, an error will result and no quantity will be calculated.  

Note InRoads includes a Shapes Tool to create DTM feature shapes from multiple 
graphic elements that are not grouped together as a complex shape. This tool 
will be discussed later in this training. The MicroStation Create Region tool can 
also be used to create graphic complex shapes from multiple graphic elements.  

• Volume – There is no direct method to measure volumes with the Quantity Manager 
tools. However, by including a variable in the computation formula that specifies the 
depth of an area, the volume can be computed based on the calculated area 
multiplied by the specified depth. Likewise, a volume could be computed from a 
linear element if the pay item formula included variables for the width and depth.  

For example, the formula for computing a volume in cubic yards from a linear element 
would be  

(LINEAR * Width * Thickness)/27  

LINEAR represents the value computed by InRoads. Width and Thickness are user 

defined variables. To compute the volume of concrete in a 4 foot wide, 6 inch deep 

sidewalk the Width is defined as 4 and the Thickness as 0.5.  

ROUNDING, QUANTITY FACTOR, AND DEDUCTIONS  
InRoads computes the pay item quantity by reading the precise count (each), length, or area from the 
MicroStation graphics and InRoads DTM features. These quantities will be computed to the maximum 
number of decimal places the computer is capable of processing. However, in most situations it is 
more desirable to report quantities to a known and expected number of decimal places. Each pay item 
definition includes an option to apply rounding to the computed quantities. If enabled, the computed 
quantities will be rounded to the specified number of decimal places. There are also controls to define 
if the quantities are rounded up or down.  

Each pay item can optionally be multiplied by an “estimate” or quantity factor. When this option is 
enabled, the calculated pay item will be multiplied by the specified quantity factor. The reported 
quantity will thus be larger or smaller than the calculated quantity based on the specified value. For 
example, assume the acceptable practice is to increase the pounds of seed needed to cover an area by 
5%. The quantity factor for the seed pay item would be set to 1.05.  

InRoads would then calculate the seed area from the elements, apply the quantity formula to the area 
to determine the pounds of seed required, and then multiply that result by 1.05 to increase it by 5%.  

Quantity Manager also includes the ability to subtract a specified quantity from one pay item any time 
another specific pay item is found within a minimum distance. For example, assume the requirement 
is to subtract 10 feet from the curb and gutter quantity each time a catch basin is placed in the curb. 
Two pay items would need to be defined; the catch basin pay item and the curb and gutter pay item. 
In addition to its other definitions, the curb and gutter pay item would include a deduction of 10 feet 
each time the catch basin pay item is encountered. The distance for how close the two pay items need 
to be to each other before the deduction occurs is defined when using the Compute Quantities tool. 
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The following figure shows the curb and gutter pay item. Notice the pay item 668-1100 in the Deduct 
from Pay Item area. This is the definition that 10 feet will be deducted from the curb and gutter 
quantity each time the catch basin is encountered.  

 
 
Each pay item also has the option of setting the measurement mode.  The measurement mode can be 
set to either planarized or slope.  In the figure above the measurement mode of the curb and gutter is 
set to planarized.  This has the effect of deriving a quantity based on its horizontal position without 
regard to elevation.   
 
  



16  Nov - 12 

Copyright © 2012 Bentley Systems, Incorporated 

PAY ITEMS ON INROADS DTM FEATURES  
When pay items are assigned to DTM features, the pay item definition is stored in the InRoads *.dtm 
files.  

Advantages  
• DTM features are less likely to be accidentally modified than MicroStation elements 

might be.  
• DTM features can be redisplayed to the graphics file if the graphics is modified or 

otherwise lost.  

Disadvantages  
• The DTM surface (*.dtm) file that contains the feature definitions must be loaded to 

compute quantities. Graphics representing the features from the DTM surface can be 
displayed in the CAD file but the graphics cannot be used to compute the quantities.  

• Pay item assignments are lost if the DTM surface is recreated such as might occur if 
the Roadway Designer is run again.  

Note There is a technique where pay item assignments can be made to InRoads styles. 
If this technique is used, the features in the DTM surface would have their 
associated pay items even after recreating the surface so long as the proper 
styles are used for each feature. However, it is not recommended to use this 
technique in most situations because it would require a 1:1 relationship 
between styles and pay item definitions. For example, a common configuration 
is to have a single style for concrete pipe even though there are many different 
sizes of pipe. There would be a pay item definition for each size of pipe that is 
then manually assigned to the feature as necessary. The other option is to 
create a style for each size of pipe and associate each style with one pay item.  

• Quantity overrides cannot be used. Quantity overrides are the ability to manually 
specify a quantity value to override the computed value.  
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PAY ITEMS ON MICROSTATION GRAPHICS  
When pay items are assigned to graphics, the pay item definition is stored in the MicroStation DGN 
file.  

Advantages  
• DTM surface file does not need to be loaded to compute quantities.  
• Quantity overrides can be used to manually specify a quantity value to override the 

computed value.  

Disadvantages  
• MicroStation graphics can be easily modified, copied, and deleted without the user 

understanding that they are affecting the project pay quantities.  
• If a MicroStation element that contains a pay item definition is copied, the new 

element also contains the pay item definition.  
• MicroStation elements may not be drawn to the same level of engineering accuracy 

as InRoads data and thus the computed quantities may not be as accurate as 
necessary.  
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ASSIGNING PAY ITEMS  
The Assign Pay Item tool from the InRoads > Quantity menu is used to assign pay items to graphic and 
feature elements.  

Remember that before a pay item can be assigned to an element the pay item database that contains 
the pay item definitions must be loaded. In addition, if any DTM features will have pay items assigned 
to them the DTM surface containing those features must be loaded and the features displayed in the 
CAD file.  

 Locate Elements for Assigning Quantities  

1. Select Utilities > Saved Views from the MicroStation menu. 
2. Double click on Area A in the Saved View dialog box and then left click in the MicroStation 

window to apply the view. 
The CAD view is zoomed to an area showing the roadways, storm drain pipes and inlets, and 
some guardrail.  
The roadway elements are displayed features from the Finished DTM. All of the other elements 
are MicroStation graphics.  

3. Close the Saved Views dialogs. 

 Display DTM Features  

1. Select Surface > View Surface > Features from the InRoads menu. 
2. Set the Surface to Finished. 
3. Select the feature named Culvert2. Be sure that no other features are selected. 
4. Click Apply.  Culvert 2 is displayed near the bottom of the screen. 
5. Close the View Features dialog.  

 Assign Pay Item to DTM Feature 
1. Select Quantities > Assign Pay Items from the InRoads menu. 

2. Click the Pay Item Browse button.   

The currently loaded Pay Item Database is displayed.  

The database provided for this training is organized into hierarchical 

categories to make it easier to locate the desired pay item.  
3. Browse to and select the pay item 550-1360 (Storm Drain Pipe, 36 IN, H 1-10) from the 544-

577 Minor Drainage Structures > Section 550 – Storm Drain Pipe, Pipe-Arch Culverts, and Side Drain 
Pipe> folder. 

4. Click Add. The pay item 550-1360 is now listed on the Assign Pay Items dialog. 
5. Click Close on the Pay Items dialog.  
6. Click Apply on the Assign Pay Items dialog  
7. Locate and click on Culvert2 displayed earlier (blue line) in the lower portion of the view to 

assign the pay item to this element.  
The element highlights to indicate which element the pay item will be assigned to.  

8. Click anywhere in the CAD view to accept the highlighted element and assign the pay item.  
9. Right Click to return to the Assign Pay Items dialog. 
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Sometimes it is desirable and necessary to assign more than one pay item to a single element. The 
pipe culvert that was just assigned a pay item should also have a flared end section at each end of the 
pipe culvert.  

 Add Additional Pay Items to an Element  
1. Select the Assign Pay Items tool.  
2. Add the pay item 550-4236 (Flared End Section 36 IN, Storm Drain) from the 544-577 Minor 

Drainage Structures > Section 550 – Storm Drain Pipe, Pipe-Arch Culverts, and Side Drain Pipe> folder. 
3. Add a second 550-4236 pay item. It is necessary to add the flared end section pay item twice 

because one is needed on each end of the pipe. 
4. Close the Pay Items dialog.  

There are currently three pay items active in the Assign Pay Items tool. If this definition is 
applied to the culvert processed above, the result would be a duplication of the 550-1360 pay 
item. One definition from the original assignment and a second from this assignment. Therefore, 
it is necessary to remove the 550-1360 pay item prior to making the assignment. 

5. Highlight the 550-1360 pay item. 

6. Click the Delete Pay Item button.  
7. Click Apply to assign the pay items to the same pipe culvert as in the previous exercise.  
8. Remember to click on the element and then click again to accept the highlighted element.  

 Assign Pay Item to MicroStation Graphic Element  
1. Delete all active pay items from the Assign Pay Items tool. 
2. Add the following pay items that will be used for the guardrail.  

581-725 Miscellaneous items > Section 641 – Guardrail > 641-1200 Guardrail, TP W  

581-725 Miscellaneous items > Section 641 – Guardrail > 641-5012 Guardrail Anchorage, TP 12 

3. Click Apply and assign the pay items to the two sections of guardrail in the view. The 
guardrail is displayed in cyan (light blue).  

4. Close the Assign Pay Items dialog. 

Notice that there is virtually no difference in applying pay items to DTM features and to MicroStation 
graphics.  
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EDITING AND REVIEWING ASSIGNED PAY ITEMS  
A pay item assignment can be reviewed or edited using the Review/Edit Pay Items tool. The 
Review/Edit Pay Items dialog displays all elements that have pay items attached (graphic and DTM 
features) in the current MicroStation drawing and all attached MicroStation references.  

The top portion of the dialog displays all of the elements that have pay items attached.  The element 
information display is made up of four columns.  

• ID/Name – Displays the name of the feature for DTM elements or an ID for graphic 
elements. By default, the ID of a graphic element is a unique number assigned by 
MicroStation to the element. This number is of little value to most users. However, 
the ID can also be a user specified “name” that identifies the element. The user 
specified “name” is defined with either the Assign Pay Items or the Review/Edit Pay 
item tool by entering the desired name in the respective field before assigning the 
pay item.  

• Level/Style – Displays the level for MicroStation graphic elements and the style for 
InRoads DTM features.  

• Cell Name – Displays the name of the cell if the pay item is assigned to a cell.  
• Type – Displays the MicroStation element type (line, line string, etc.) for graphic 

elements and the DTM feature type (random, breakline, etc.) for InRoads DTM 
features.  

When an element is highlighted in the upper portion of the dialog, the pay items assigned to the 
element are shown in the lower portion of the dialog. The pay items assigned to the element can be 
modified by adding or deleting pay items from the list. The name assigned to graphic elements can 
also be modified.  

 Review Assigned Pay Items  
1. Select Quantities > Review/Edit Pay Items. 
2. Highlight the first of the Guardrail elements in the top portion of the dialog. 
3. Enter Guardrail in the Name field to assign a name to this element. 
4. Add the following pay item to the guardrail elements. Once complete, there should be three 

pay items assigned to each of the two guardrail elements.  

581-725 Miscellaneous items > Section 641 – Guardrail > 641-5001 Guardrail Anchorage, TP 1 

5. Click Apply to update the elements.  
6. Repeat the previous steps for the other guardrail element.  

Note Another method to review the pay items assigned to a graphic element is with 
AccuSnap Pop-up information. With the MicroStation Element Selection tool 
active, hover over an element. A pop-up appears displaying element information 
including the quantity name and assigned pay item(s). InRoads must be running 
for the quantity information to be included in the pop-up.  
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PAY ITEMS AND SELECTION SETS  
Pay items can be assigned to multiple elements at the same time using the Assign Pay Items tool by 
placing the elements in a MicroStation selection set before activating the Assign Pay Items tool.  

Similarly, a MicroStation selection set can be used to limit the scope of elements that are included in 
the display when using the Review/Edit Pay Items tool. Only those elements in the selection set that 
contain pay item assignments are displayed in the Review/Edit Pay Items dialog.  

Note Be careful when using selection sets with the Review/Edit Pay Items tool. All 
elements in the selection set are listed in the dialog even if they do not have a 
pay item assigned. This allows you to use this tool to assign pay items to 
previously unassigned elements.  

 Review Pay Item Assignments in Selection Set  
1. Close the Review/Edit Pay Items dialog if it is currently open. 
2. Create a MicroStation selection set that includes the two guardrail elements but does not 

include the pipe element. Other elements can be in the selection set, just not the pipe 
element. 

3. Select the Review/Edit Pay Items tool. 
4. Review the dialog and see that the guardrail elements are listed but not the pipe element. 
5. Close the Review/Edit Pay Items dialog.  
6. Cancel the selection set by selecting the element selection tool and then clicking in an 

empty part of the CAD drawing. 
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CREATING SHAPES FOR PAY ITEMS  
A closed element is required to assign a pay item with an “area” measurement basis. Either 
MicroStation or InRoads Quantity tools can be used to create a closed element if one does not already 
exist.  

The MicroStation Create Complex Shape or Create Region tools are used to create a graphic element 
defining a closed area. Once created, a pay item can be assigned to the graphic element as described 
previously.  

The InRoads Quantities > Shapes Tool is used to create a closed DTM feature from graphic elements. 
The closed feature will be stored in a DTM, not as a graphic element. Although this closed feature is 
created with a quantity tool, no pay item is immediately assigned to the feature. The pay item is 
assigned to the feature by displaying the feature and then using the Assign Pay Item tool described 
previously.  

Both of these methods can be used to create a closed shape using a fill/flood method (multiple non-
closed linear elements that together define a closed region) and a union method (multiple closed 
elements that are joined together to create a single larger closed element). Which method you choose 
depends on where the pay items assignment will be stored: the DTM or graphics.  

 Locate Elements for Assigning Quantities 

1. Select Utilities > Saved Views from the MicroStation menu. 
2. Double click on Area B in the Saved View dialog box and then left click in the MicroStation 

window to apply the view. 
The CAD view is zoomed to an area showing the front and back of a sidewalk. The level display 
for all other graphics have been turned off so that the graphics do not interfere with the area to 
be flooded.  

Note When using the fill/flood method it is important that no graphic elements pass 
through the area to be flooded. These graphics would define an undesirable end 
or closure to the area.  

3. Close the Saved Views dialogs.  
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 Create Sidewalk Feature  

1. The graphics for the new shape need to be defined. In this example, the edges of the 
sidewalk are already drawn using a yellow line. The ends, or beginning and ending station, of 
the shape have also been drawn using yellow lines. The lines defining the ends of the shape 
must close the shape. The lines must snap to the end of the existing lines or overlap the 
existing lines. It is important that no gap exists between the lines.  
The result is not a true closed shape but instead a set of linear elements that together 
appear as a closed shape.  

Note The Shapes Tool has an option to specify beginning and ending station limits to 
define the boundaries instead of drawing graphic lines. Using the station limits 
works well if the features follow an alignment. In this situation, the sidewalk 
does not follow an alignment and is actually almost perpendicular to the main 
roadway alignment. Therefore, using the station options is not appropriate in 
this situation.  

2. Select Quantities > Shapes Tool from the InRoads menu.  
3. Select the Fill option.  

This option specifies that a new closed shape will be constructed from an area defined from 
existing non-closed elements. The Union option is used to create a new shape by joining together 
two existing closed elements.  

4. Select Finished in the Surfaces combo box to define the surface where the new closed 
feature will be stored.  

5. Key in Sidewalk in the Feature Name box to define the name of the new feature.  
6. Select MAIN_P_Sidewalk from the Feature Style combo box to define the style assigned to 

the new feature.  
7. Enable the Use Dynamics option.  

When Use Dynamics is enabled, InRoads will highlight closed areas as the cursor moves over 
them. This option is very useful when defining closed shapes. However, if extensive graphics 
exist in the view which results in a large number of possible closed shapes this option can make 
the tool slow so its use should be limited in these situations.  

8. Enable the Exclude from Triangulation option so that the new feature will not affect the 
DTM surface triangulation process.  

9. Ensure that the Station option is disabled.  
10. Click Apply.  
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11. Move the cursor over sidewalk area.  

The closed area will highlight showing the new shape that will be created.  

12. Click (left mouse button) to select the highlighted shape.  
13. Click again to accept the highlighted shape. The new shape is written to the DTM and 

displayed in the graphics file.  
14. Reset (right mouse button) to end the shape selection process. Additional shapes could be 

selected using the same definitions if desired.  
15. Close the Shapes Tool dialog.  
16. Use the Assign Pay Items tool to assign the following pay item to the new Sidewalk Feature.  

400-461 Pavements > Section 441 – Miscellaneous Concrete > 441-0104 Conc Sidewalk, 4 IN 

Note Be careful to select the sidewalk shape created in the previous step, not the 
graphic lines that the shape was created from. If the incorrect element highlights 
when selected, click Reset (right mouse button) to select an alternate element.  
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ASSIGNING LUMP SUM QUANTITIES  
Virtually all projects have some pay items that are quantified as a lump sum value. Sometimes the 
lump sum is assigned to a physical element. For example, the pay item for Traffic Signal Installation (a 
lump sum quantity) could be assigned to the traffic signal element. In other situations, there may not 
be an element to assign the pay item to, such as would be the case for a Clearing & Grubbing pay item.  

Lump sum pay items could be added directly to the quantity database using the Quantity Manager 
application. However, the workflow described in this course avoids that method because those 
manually input quantities cannot be easily regenerated from the core project files (DGN and DTM). 
Instead, the workflow recommends that all pay items be assigned to either graphic or feature 
elements so they can be re-extracted whenever necessary.  

For lump sum pay items that do not have an existing graphic element such as Clearing & Grubbing, it is 
recommended that a “dummy” graphic element be created on a non-plotting level. The graphic can be 
any single element such as a point, line, circle, cell or text. Since the element is not to be drawn on the 
plan sheet a non-plotting level should be used or the text should be placed outside the plotting limits. 
The lump sum pay item is assigned to this “dummy” graphic just like any other pay item.  

 Locate Element for Assigning Quantities 

1. Select Utilities > Saved Views from the MicroStation menu. 
2. Double click on Area C in the Saved View dialog box and then left click in the MicroStation 

window to apply the view. 
3.  The CAD view is zoomed to an area showing the text ‘Clearing & Grubbing Pay Item’. 
4.  Close the Saved Views dialog.  

 Assign Pay Item to Text 

1. Select Quantities > Assign Pay Items from the InRoads menu. 
2. Enter Clearing & Grubbing in the Name field. 
3. Delete all active pay items from the Assign Pay Items tool. 
4. Add the following pay item that will be used for Clearing.  

201-221 Earthwork > Section 201 –Clearing and Grubbing Right of Way > 201-1500 Clearing & 
Grubbing-  LS 

5. Click Apply and assign the pay item to the text ‘Clearing & Grubbing Pay Item’.  
6. Click anywhere in the CAD view to accept the highlighted element and assign the pay item.  



26  Nov - 12 

Copyright © 2012 Bentley Systems, Incorporated 

 Edit Pay Item Quantity 

1. Select Quantities > Pay Item Manager from the InRoads menu. 
2. Browse to and double click on the pay item  

201-221 Earthwork > Section 201 – Clearing & Grubbing Right of Way > 201-1500 Clearing_Grubbing - 

3. Select the variable LumpSum by clicking on it to highlight it. 
4. Enter 1.0 in the Value field to change the LumpSum value from 0 to 1. Be sure to click the 

TAB key after entering the value to ensure that InRoads reads the new value.    

Even though it is a lump sum item it must have a value of 1 in order to compute and report on 
it. 

5. Add {STP-000(00)} to the end of the description such that the description reads CLEARING & 
GRUBBING –{STP-000(00)}. 

There should be no space between the description and the opening curly brace {.  Pay Item 
descriptions that end in a dash require a supplemental description.  Supplemental description will 
be covered in more detail in a later section. 

6. Click Apply to save the changes and then Close the dialog. 
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VARIABLE VALUES IN PAY ITEM QUANTITY FORMULA  
All pay items quantities are computed by applying a formula to a value measure by InRoads. The 
measured value could be a count of the number of elements, the length of one or more elements, or 
the area of one or more elements. The quantity formula allows more complex quantity calculations 
than the simple each, linear, and area measurements. For example, when computing the amount 
(tons) of fertilizer required the following formula could be used.  

(AREA * Application Rate) / 2000  

Here the measured area is multiplied by the Application Rate of fertilizer. The application rate is how 
many pounds of fertilizer are required per square foot. The result of that calculation is divided by 2000 
to convert from pounds to tons.  

In this example, the Application Rate is a variable that will likely be different on each project and thus 
needs to be defined on a project by project basis. The variables are defined as part of the pay item 
definition in the pay item database.  

Note Each pay items formula should be viewed and understood prior to assigning the 
pay item in order to understand how the item will be quantified.  Formulas are 
viewed and added using the Quantity Formula Manager under the quantity 
menu in InRoads.   

 Locate Elements for Assigning Quantities 

1. Select Utilities > Saved Views from the MicroStation menu. 
2. Double click on Area B in the Saved View dialog box and then left click in the MicroStation 

window to apply the view. 
The CAD view is zoomed to an area showing the sidewalk feature defined previously. 

3. Close the Saved Views dialog.  

 Define Variables for Base Pay Item 

1. Select Quantities > Pay Item Manager from the InRoads menu. 
2. Browse to and double click on the pay item  

201-221 Earthwork > Section 209 – Subgrade Construction > 209-0203 Stabilizer Matl, TP III  

Notice the variable definitions for Thickness and WeightCFT in the left portion of the Edit Pay 
Item dialog.  

3. Select the Thickness variable.  
4. Enter 0.5 in the Value field to change the thickness of the base to 6 inches or 0.5 feet. Be 

sure to click the TAB key after entering the value to ensure that InRoads reads the new 
value.  

5. Select the WeightCFT variable. 
6. Enter 145 in the Value field to change the weight per cubic foot of the stabilizer material.  

Again, be sure to click the TAB key.  
 

***Important: Stabilizer Matl may not be required for construction of Sidewalks.  It is included 
here to demonstrate the use of variable values. 

7. Click Apply to save the changes and then close the dialog.  
8. Close the Pay Item Manager dialog.  
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9. Use the Assign Pay Item tool to assign the 209-0203 pay item to the sidewalk feature 
created in a previous exercise.  
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OVERRIDE COMPUTED QUANTITIES WITH INPUT VALUES  
If an element is not drawn at its proper size the resulting quantity from that element will be incorrect. 
As a general rule all elements should be created or drafted at their actual size so that InRoads can 
accurately measure the appropriate quantities. There will be some situations where it may not be 
practical to draw an element to the proper size. For these situations, InRoads allows a quantity 
override where the desired quantity can be manually input. InRoads will use that quantity value 
regardless of the elements actual size.  

Note Quantity overrides can only be done on graphic elements. DTM feature 
elements are always measured at their actual size.  

 Locate Elements for Assigning Quantities 

1. Select Utilities > Saved Views from the MicroStation menu. 
2. Double click on Area A in the Saved View dialog box and then left click in the MicroStation 

window to apply the view. 

The CAD view is zoomed to an area showing the roadways, a culvert, storm sewer pipes and 
inlets, and some guardrail. 

3. Close the Attach saved view and Saved Views dialogs. 
 

 Assign Paving Pay Item to Guardrail  

For this project, each section of guardrail will have a nominal 10 SY of asphalt pavement to be used 
around the terminal sections. It would be unnecessarily time consuming to draw each of these shapes. 
Therefore, the quantity will be applied to the guardrail element and an override value of 10 will be 
entered to ensure the correct quantity is calculated no matter the length of the guardrail.  

1. Select the Review/Edit Pay Items tool.  
2. Select one of the two guardrail elements in the dialog.  

Since a name was assigned to these elements previously they are easily located in the list.  
3. Add the following pay item to the Pay Items assigned to these elements.  

400-461 Pavements > Section 402 – Hot Mix Recycled Asphaltic Concrete > 402-3113 (Quantity 
Override) Recycled Asph Conc 12.5 MM Superpave, GP 1 or 2, incl Bitum Matl_H Lime 

Notice that there are two pay items numbered 402-3113 in this database. While both of these pay 
items compute a TN value, there is a difference in the formula used by each to compute that 
value. The standard pay item uses the square foot area calculated by InRoads from the element 
and multiplies it by the Thickness and Weight then divides it by 2000 to determine the tons. The 
pay item with (Quantity Override) in its name is designed to be used only when manually 
overriding the quantities. The formula for this pay item multiplies a manually input quantity by 
1.0 to determine the tons. The result is that the keyed in value is the computed TN’s. This pay 
item was created by copying and editing the original 402-3113 pay item and formula and 
renaming it. 
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The reason a special formula was needed for this situation is that the guardrail is a linear 
element, not an area. Therefore, to compute/report a weight value it is necessary to multiply a 
length times a depth and width to determine the weight. The formula assumes the input value is 
the length and the width and depth is always 1.0.  

4. Select the 402-3113 (Quantity Override) pay item in the Review/Edit Pay Item dialog.  
5. Enable the Override Measurement option.  
6. Key 10.0 into the Override Measurement text box.  
7. Click Apply to complete the assignment.  
8. Select the other Guardrail element in the top portion of the dialog.  
9. Assign the 402-3113 (Quantity Override) pay item with the 10.0 override measurement to 

this element.  
10. Click Apply and then Close the Review/Edit Pay Item dialog.  
 

Note When a pay item’s formula set up in the master Pay Item database does not 
satisfy a specific requirement, the pay item can be copied and renamed and 
assigned a new formula.  Formulas are made in the Quantity Formula Manager. 
Only the pay item name should change, the pay item code must not be changed. 
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ASSIGNING “SUPPLEMENTAL DESCRIPTIONS” TO PAY ITEMS  
The AASHTO Trns•port software has a special functionality called Supplemental Descriptions. This 
functionality allows one pay item number to be used for different purposes on different projects. 
Without supplemental descriptions more unique pay items must be defined.  

For example, consider the removal of guardrail. There are many different types of guardrail in 
existence that could need to be removed. For this discussion we will assume there are ten. The cost to 
remove each type of guardrail is different and therefore a separate bid quantity is needed for each. 
However, on any one project there is not likely to be more than two or three types of guardrail.  

If a unique pay item is setup for each of the ten types of guardrail no supplemental descriptions are 
needed because each pay item has a unique description. However, some owner/operators choose to 
setup only two or three pay items and use supplemental descriptions to define what the pay item 
represents on each project.  

In this example three pay items for removal of guardrail have been set up. All three have the same 
base pay item number and have exactly the same description. The only difference is the last character 
of the pay item number. This numbering scheme is just one example of how pay items can be setup.  

• 610-1055A – REM GUARDRAIL  
• 610-1055B – REM GUARDRAIL  
• 610-1055C – REM GUARDRAIL  

 

If only one style of guardrail needs to be removed on the project, only pay item 610-1055 is used and 
no supplemental description is required. However, if two styles of guardrail (metal and concrete) 
needed to be removed, both pay item 610-1055A and 610-1055B are required. If they were both left 
with the same description it would be difficult for someone viewing the resulting quantities to 
determine which type of guardrail removal belongs to which pay item.  

One solution for this would be to edit the description of the pay item to include specific information 
such as shown below.  

• 610-1055A – REM OF METAL GUARDRAIL  
• 610-1055B – REM OF CONCRETE GUARDRAIL  

 

The problem with this approach occurs when the quantity data is exported to the AASHTO Trns•port 
software. The Trns•port software requires that both the pay item number and the pay item 
description be identical to the master definition of those pay items within its database. Therefore, 
altering the description as shown will not work.  

Instead, the description is altered as shown below. Enclosing the modified or “supplemental” portion 
of the description in curly braces {} tells the Quantity Manager software how to process this data.  

• 610-1055A – REM OF GUARDRAIL{Metal}  
• 610-1055B – REM OF GUARDRAIL{Concrete}  

Quantity Manger will break the description into two items when it passes the data to Trns•port. The 
first is the standard, unaltered description. The second is the supplemental description enclosed in the 
curly braces. This data is now in exactly the format the Trns•port software expects.  
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Note Adding supplemental descriptions to pay items is a project specific requirement. 
Therefore it is necessary that each project have a copy of the master pay item 
database that is modified to satisfy project specific requirements.  All pay items 
whose descriptions end in a dash (-) require a supplemental description.  
Without the supplemental description, the pay item will not import into 
Trns*port / CES. 

 Adding Supplemental Descriptions 

1. Select Quantities > Pay Item Manager to open the pay item database. 
2. Locate the following pay item  

581-725 Miscellaneous items > Section 610 – removal of Miscellaneous Roadway Items > 610-9000A REM 
SIGN, STA - 

3. Double click on the pay item to open the Edit Pay Item dialog. 
4. Click in the Description field. 
5. Add {200+00 LT} to the end of the description.  

Remember: There should be no space between the description and the opening curly brace {. 

6. Click Apply to save the change. 

7. Click the Next button, , in the Edit Pay Item dialog box to move to pay item 610-9000B.      
8. Click in the Description field. 
9. Add {250+00 RT} to the end of the description.  
10. Click Apply to save the change.  
11. Close the Edit Pay Item dialog.  
12. Review the updated descriptions in the Pay Item Manager dialog. 
13. Close the Pay Item Manager dialog. 
14. Close MicroStation and InRoads.  

Note Since the pay item number is not being changed, supplemental descriptions can 
be added to the pay item description at any time before or after assigning the 
pay item to elements. It may be easier to assign the supplemental descriptions 
to the pay items prior to assigning the pay item to the elements to ensure that 
the proper pay item is assigned to the element.  
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MODULE SUMMARY AND REVIEW  

SUMMARY  
You are now able to:  

• Understand general workflow for computing quantities  
• Understand basic principles for how quantities are computed  
• Assign pay item(s) to InRoads DTM elements  
• Assign pay item(s) to MicroStation graphic elements  
• Edit and Review assigned pay items  
• Create shapes for pay item assignments  
• Customize formula used to compute quantities  
• Override computed quantities with input values  
• Assign “supplemental descriptions” to pay items  

QUESTIONS  
Before beginning the next Section, let’s evaluate what you have learned. 

1. How many pay items can be assigned to a single element? 
2. Which tool or tools can be used to assign pay items? (Select all that apply)  

A - Pay Item Manager 

B - Shapes Tool  

C - Assign Pay Items  

D - Review/Edit Pay Items  

E - Quantity Manager  
3. Can a quantity override value be assigned to all pay items?  

• True  
• False  
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ANSWERS  
1. How many pay items can be assigned to a single element?  

Multiple - A large number of pay items can be assigned to each element.  

2. Which tool or tools can be used to assign pay items? (Select all that apply)  
C and D -The Assign Pay Items and Review/Edit Pay Items tools are used to assign pay items 
to graphic and DTM elements. The Pay Item Manager is used to edit the pay items definitions 
but they cannot be assigned directly from the manager. The Shapes tool is used to create DTM 
shape features that could have pay items assigned to them but it cannot directly assign the pay 
item. The Quantity Manager application is used to create reports and export quantities but not to 
assign the pay items.  

3. Can a quantity override value be assigned to all pay items?  
No - Quantity overrides can only be applied to pay items assigned to graphic elements. Pay 
items assigned to DTM elements cannot include quantity overrides.  
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Computing and Extracting 
Quantities  
 

OVERVIEW  
This module teaches how to compute and extract quantities from InRoads DTM elements and 
MicroStation graphics. The elements are extracted to a database which can be reviewed using the 
Quantity Manager application.  

PREREQUISITES  
• Pay Item Database  
• InRoads Alignment  
• InRoads DTM elements or MicroStation graphics that have assigned pay items  

OBJECTIVES  
After completing this module, you will be able to:  

• Extract quantities from elements that have pay items assigned  
• Extract quantities for the entire project or select areas  
• Review extracted quantities in Quantity Manager application  
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COMPUTE ALL QUANTITIES  
Quantities are calculated and extracted using the Compute Quantities tool in InRoads. This tool will 
extract quantities from all visible graphics (master file and attached reference files) and all loaded 
DTM surfaces.  

Quantities for the entire project can be extracted all at once, or you can selectively compute quantities 
for specific areas defined by a MicroStation Fence. 

The results of the quantity calculation are written to a database file. The database can be reviewed, 
edited, and reports generated for the data using the Quantity Manager application.  

Before calculating any quantities the project files must be loaded. Quantities can only be computed 
from graphic elements that are visible in the current DGN file or attached reference files. Quantities 
from DTM feature elements can only be computed when the DTM surface is loaded in InRoads. An 
active alignment is required from which the quantity location (station and offset) is computed. The 
Pay Item database must also be loaded.  

 Start InRoads  
1. Close MicroStation and InRoads if they are still running from the previous session.  
2. Start InRoads and MicroStation.  
3. Set the directory to C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 03\.  
4. Open the file Compute Quantities.dgn.  

1. Open Project File  
1. Select File > Open from the InRoads menu. 
2. Open the Project File C:\InRoads Training\Quantity Manger Lab\RWK\Practice Lesson 

03.rwk.  

This will open the preference file: GDOT_Standard V8i_SS2.xin 

And the geometry file: Compute Quantities.alg  

And the design surface: Compute Quantities.dtm  

2. Loading the Pay Item Database  
1. Select Quantities > Pay Item Manager from the InRoads menu.  

The Pay Item Manager dialog appears. 

2. From the Pay Item Manager, select File > Open. 
3.  Open the pay item database file C:\InRoads Training\Quantity Manger Lab\Standards\Pay Items\ 

GDOT(PI#) Quantity Manager Pay Item Database.. 
4. Click Exit to Exit the Pay Item Manager dialog.  
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The Compute Quantities tool extracts and computes quantities from MicroStation elements and 
InRoads features. The Include parameters on the dialog define which of the pay items are calculated. 
There are three Include parameters: Pay Items, Features, and Graphic Elements.  

• Pay Items – When set to All, pay quantities are computed for all pay items. When set 
to Selected, pay quantities are only computed for the pay items enabled on the Pay 
Item tab.  

• Features – When set to All, pay quantities are computed for all DTM features. When 
set to Selected, pay quantities are only computed for the DTM features enabled on 
the Features tab  

• Graphic Elements – When set to All, pay quantities are computed for all graphic 
elements. When set to Selection Set, pay quantities are only computed for the 
graphic elements in the active MicroStation selection set. The selection set must be 
defined before activating the Compute Quantities tool.  

If your Pay Item database has deduction pay items setup, enable the Deduction Tolerance option and 
define the maximum distance between the pay items for a deduction to be calculated.  

 

 

3. Compute quantities for entire project 
1. Select Quantities > Compute Quantities from the InRoads menu. 
2. Set the Alignment name to I-598 EB.  

The beginning and end station of each quantity are computed from this alignment. 
3. Set the Mode to All.  

The All mode will compute all quantities in the current DGN and DTM files. 

4. Click the Browse button to the right of the Database field. 
5. Browse to the folder C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 03\ 

and enter the filename Quantity Output.mdb. 
6. Click Save. 
7. Click Apply.  

The quantities are calculated and written to the database. 
8. Close the Compute Quantities dialog.  

A copy of each element from which a pay quantity is calculated is written to the graphic file when the 
Highlight Element option is enabled on the Compute Quantities dialog. These items will be depicted on 
the Level:   QTYS_P_Quantities-Line.  The highlighted elements are an easy, visual method to review 
which elements are quantified. The highlighted elements are all written to a single MicroStation level 
so they will be easy to cleanup. We will cover the cleanup process later in this training.  
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REVIEWING QUANTITIES IN THE QUANTITY MANAGER  
The quantity database output from InRoads is reviewable using the Quantity Manager application.  

4. Open the Quantity Database  

1. Select Quantities > Quantity Manager from the InRoads menu.  
The Quantity Manager application is started. Be patient because it takes some time for the 
Quantity Manager application to start.  

Quantity Manager is an independent application from MicroStation and InRoads. Watch in the 
Windows task bar (typically at the bottom of the screen) for a Quantity Manager Application 
icon.  

2. Once Quantity Manager has started, make it the active application by clicking the Quantity 
Manager icon in the Windows task bar. When Quantity Manager is first opened, the dialog is 
essentially blank.  
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3. Click the Open button on the Quantity Manager dialog.  
The Connect to Database dialog appears.  

 
4. Click the Browse button or the Connect to Database dialog.  
5. Browse to and select the file C:\InRoads Training\Quantity Manger Lab\Practice\Practice 

Lesson 03\Quantity Output.mdb.  
6. Click Open to open the Quantity Output.mdb. 
7. Click Connect.  

There is not a User Name or Password on the database files created by InRoads.  
The Quantity Manager dialog updates to show the quantity data.  

For each pay item, the database has multiple records of quantities, and for each quantity, there are 
multiple records of elements. This relationship is depicted graphically below.  
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This hierarchical relationship is also represented in the user interface of the Quantity Manager 
application, which is organized into three tables, allowing the user to examine data at any level - by 
pay item, by quantity or by element.  

 

 

 
 

 

The Pay Items pane on the left displays the same hierarchical list of pay items as existed in the Pay 
Item database. The only difference is that this list is limited to only those pay items that exist in the 
computed data. Browse through the list and select one or more pay items to review the quantity 
calculations in the Quantity pane.  

The Pay Item pane can also be displayed as a flat list by selecting the Pay Item Table tab.  

  

Pay Items 
Elements 

Quantity 
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Once one or more pay items is selected (highlighted), the quantity assignments appear in the Quantity 
pane in the upper right. A few of the columns of data that might be useful to review include:  

• Pay Item – Pay item number.  
• Net Value – This is the final quantity reported for the pay item. The net value is 

calculated by subtracting the Deduction Value from the Rounded Value.  
• Measurement Value – The actual measurement with no formulas, adjustments, or 

rounding applied. For example, when doing pavement computations, the 
measurement is the square feet (or square meters) of the closed shape representing 
pavement.  

• Computed Value – If a formula was utilized, this field is the result of the computation. 
Using the pavement example, a formula utilizing the square feet and computing tons 
could be utilized. In this case, the tonnage is the computed value.  

• Rounded Value – Rounded quantity based on the computed value. This is also 
sometimes referred to as the gross quantity.  

• Deduction Value – Quantity to be deducted from the rounded quantity when a 
deduction pay item is located within a minimum distance of the pay item being 
computed.  

 Review the Quantity Data  

1. Expand the pay item tree to view the 544-577 Minor Drainage Structures > Section 550 – 
Storm Drain Pipe, Pipe-Arch Culverts, and Side Drain Pipe section.  

2. Select all of the pipe culvert pay items.  
3. Review the Quantity pane. 

Notice that there are five pipe quantities assigned to four different pay items. The 36” pay items 
has two pipe definitions.  

4. Exit the Quantity Manager.  
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CLEARING HIGHLIGHTED GRAPHIC ELEMENTS  
When quantities are calculated in InRoads, a graphic representation of them can optionally be 
created. This graphic is very helpful in identifying which elements have quantities assigned to them 
and ensuring that the quantities are being computed from the desired elements.  

Before processing the quantity calculation again, the highlighted elements should be deleted from the 
MicroStation DGN file. Since all of the graphics are written to a single level, it is easy to delete them.  

There are many different techniques in MicroStation that could be used to delete the highlighted 
elements. The procedure below is just one procedure that can be used.  

 Clearing Highlighted Element Graphics  
1. Return to the MicroStation session. 
2. Select the MicroStation Element Selection tool.  
3. Click the down arrow in the lower right corner of the Element Selection dialog to expand the 

dialog options if they are not already expanded.  

 
4. Select the Level tab in the Element Selection dialog.  
5. Browse to and select the level where the highlighted element graphics are displayed. For 

this lab, select the level QTYS_P_Quantities-Line.  
All of the elements are put into a selection set.  

6. Click the Delete tool in MicroStation to delete the graphics. 
7. Close MicroStation and InRoads.  
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MODULE REVIEW  

SUMMARY  
You are now able to:  

• Extract quantities from elements that have pay items assigned  
• Review extracted quantities in Quantity Manager application  

QUESTIONS  
Before beginning the project task, let’s evaluate what you have learned. 

1. What user name and password must be used to open a quantity database from InRoads in 
the Quantity Manager application? 

2. True or False - you can review the quantity calculation for an element inside InRoads using 
the Review/Edit Pay Items tool?  
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ANSWERS  
1. What user name and password must be used to open a quantity database from InRoads in 

the Quantity Manager application?  
None - The user name and password fields should be left blank when opening a quantity 
database generated from InRoads.  

2. True or False - you can review the quantity calculation for an element inside InRoads using 
the Review/Edit Pay items tool?  
False - Quantity calculations are written to the quantity database by InRoads but there is no 
way to review those quantities from within the InRoads product. The quantity values are 
reviewed from the Quantity Manager application.  
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Reporting and Exporting  
 

 

 

OVERVIEW  
This module teaches how to produce reports on the pay items in the Quantity Manager database and 
optionally export that data to an external application such as the AASHTO Trns•port Estimator 
software suite.  

PREREQUISITES  
• Quantity Manager database populated with extracted pay items.  

OBJECTIVES  
After completing this module, you will be able to:  

• Create standard reports from Quantity Manager.  
• Export Quantity Manager data to XML format required by the AASHTO Trns•port 

software suite.  
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QUANTITY REPORTS  
Quantity Manager includes a variety of standard report formats for creating output to review quantity 
information. Depending on the report format, it can be output for printing or into a comma separated 
(CSV) file that can be subsequently loaded into a spreadsheet for further analysis and processing.  

The data included in a Quantity Manager report is based on the quantity items displayed in the 
Quantity pane (upper right) of the Quantity Manager window. Therefore, to create a report on all 
quantities, they must all be displayed in the Quantity pane. This is accomplished by selecting all of the 
pay items in the Pay Item pane on the left. The View > Expand Category Quantities option makes 
selecting all quantities easier. When this option is enabled and a pay item category or folder is 
selected in the Pay Item pane, all sub categories and all pay items below the selected folder are 
automatically selected. This means that when the Expand Category Quantities option is enabled, all 
you need to do is select the top pay item category named root and all pay items and thus all quantities 
below it will be selected.  

Quantity reports are created by selecting Tools > Reports > Create. The Create Report dialog appears 
from which you can select the desired Report Style and specify the name of the report file. There are 
many Report Styles delivered with the Quantity Manager application. Some that you might find most 
useful are described below.  

• Sample Pay Item Summary Report – This report is a summary listing of each pay item 
and the total quantity of that pay item. The report is available for both a CSV and an 
HTML output. Use the CSV output to send the report to a spreadsheet and the HTML 
output for a quick on screen review and print report.  

• Sample Pay Item Summary Sorted by Chain - Station – This CSV formatted report is a 
summary listing of each quantity sorted by its station location along the chain. The 
quantity values are broken down by their respective pay item.  

These are only a couple of the standard reports delivered with the Quantity Manager but they are 
representative of the type of data that can be generated. In addition, custom reports can be defined 
as necessary. Creating custom reports will not be discussed in this training.  

 

 Start Quantity Manager  

1. Close MicroStation, InRoads and the Quantity Manager if they are still running from the 
previous session.  

2. Start Quantity Manager from the InRoads section of the Start menu.  
Quantity Manager can be started from within InRoads (Quantity > Quantity Manager) or directly 
from the Windows Start menu by selecting Start>All Programs>Bentley>InRoads Group V8i 
(Select Series 2) > Quantity Manager. 
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 Open the Quantity Database 
1. Click the Open button on the Quantity Manager dialog.  

The Connect to Database dialog appears. 

2. Click the Browse button or the Connect to Database dialog. 
3. Browse to and select the file C:\InRoads Training\Quantity Manger Lab\Practice\Practice 

Lesson 04\Quantity Output.mdb.  
4. Click Open. 
5. Click Connect.  

 Select Quantities to be Included in Report  
1. Select Design from the Phase pick list at the top of the Quantity Manager dialog.  

The Phase named Design was specified when the quantities were calculated in InRoads and thus 
all of the quantities are associated with this phase of work. If an alternate phase is selected, no 
quantities will exist. Some reports do not allow the use of the ALL PHASES option so it is best 
to select the Design phase.  

2. Verify that the Expand Category Quantities option is enabled by selecting the View menu. 
When enabled, a check mark will appear next to the Expand Category Quantities option. If 
not enabled, select Expand Category Quantities to enable it.  

3. Select root in the Pay Item pane on the left portion of the dialog box.  
The Quantity pane (upper right) should list all of the quantities in the project.  

 Create Quantity Report  
1. Select Tools > Reports > Create.  

The Create Report dialog appears. 

2. Select Sample Pay Item Summary Report (HTML) from the Report Style pick list. 
3. Click the Browse button next to the Report File Name field.  
4. Browse to the folder C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 04\ 

and enter the file name Quantity Summary.html.  
5. Click Open. 
6. Click Create.  

The report file is generated and automatically displayed on screen. 
7. Review the report.  
8. Close the Internet Explorer dialog displaying the report.  
9. Close the Create Report dialog.  
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Quantity information can be easily exported to the AASHTO Trns•port software suite for additional 
processing.  

The quantity data is exported into a XML formatted file that can be subsequently imported by the 
AASHTO Trns•port software.  

TRNS•PORT SOFTWARE REQUIREMENTS  
Quantity Manager allows the user to develop his own naming conventions for phases, funding rules, 
etc. However, if the data is to be eventually imported into AASHTO Trns•port, it will not import if the 
rules of Trns•port are not followed. These restrictions are detailed in the table below.  

 
  

EXPORTING QUANTITY MANAGER DATA TO AASHTO TRNS•PORT 
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Note Similar to reports, the data included in an export from Quantity Manager is 
based on the quantity items displayed in the Quantity pane (upper right) of the 
Quantity Manager dialog. Therefore, to export all quantities, they must all be 
displayed in the Quantity pane. This is accomplished by selecting all of the pay 
items in the Pay Item pane on the left. To make selecting all quantities easier 
enable the View > Expand Category Quantities option. When this option is 
enabled and a pay item category or folder is selected in the Pay Item pane, all 
sub categories and all pay items below the selected folder are automatically 
selected. This means that when the Expand Category Quantities option is 
enabled, all you need to do is select the top pay item category named root and 
all pay items and thus all quantities below it will be selected.  

Prior to exporting data for Trns•port, the project properties need to be defined. These properties are 
part of the data Trns•port expects to receive. The project properties are defined by selecting Project > 
Properties.  

 Define Project Properties 
1. Select Project > Properties. 
2. Complete the dialog with the following information  

Project Number: 1234567  

Description: I-598 Reconstruction  

Unit System: English  

Spec Year: 01  

The spec year must be two digits to import into Trns*port/CES  

Project Chain: I-598 EB  

Begin Station: 154+24.74  

End Station: 471+20.38  

Begin Mile Post: Leave Blank  

End Mile Post: Leave Blank  

Latitude: Leave Blank  

Longitude: Leave Blank  
3. Click OK.  
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 Export Quantity Data 
1. Verify that the View > Expand Category Quantities option is enabled. 
2.  Select root in the Pay Item pane.  
3. Select Project > Export > Export.  

The Export dialog appears. 
4.  Select aecXML from the Export Style pick list.  

The aecXML format is the correct format for transferring data to the AASHTO Trns•port 
software.  

5. Ensure that the Rename Phase As option is enabled and set to DesignEstimate.  

The Trns•port software expects the phase to be named DesignEstimate.  

6. Click the Browse button next to the Document File Name field.  
7. Browse to the folder C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 04\ 

and enter the file name 1234567.xml.  
8. Click Open.  
9. Click Export.  

A file formatted in the proper XML syntax for importing into the AASHTO Trns•port suite of 
software is created.  

10. Click OK to the following message. 

        

11. Close the Export dialog. 
12. Close the Quantity Manager.  
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IMPORTING QUANTITY MANAGER DATA INTO AASHTO TRNS•PORT 
This section provides basic instruction to import a Quantity Manager XML file into Trns*port/CES.  It is 
not a comprehensive review or instruction of the Trns*port/CES tools.  For further information or to 
troubleshoot Trns*port/CES problems please refer to the Trns*port help menu or contact solutions 
center for Trns*port/CES support.  

 

1. Open Trns*port /CES 
2. Select Utilities > Upload File > Process I/O File. 
3. Browse to the Quantity Manager XML file and click Open. 
4. In the Save Process I/O File As dialog, select the QPJIPORTDIR folder.   

 
Trns*port/CES requires the file to be in the QPJIPORTDIR folder in order to import. 
 

5. Select File > Run Process… 
6. Click on ‘Import Job from XML’ and click OK. 
7. Match the setting shown below. 

 
8. Click Submit. 
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9. Once the import process has completed you may open the job in Trns*port/CES and 
review the imported items.  

10. If subsequent Quantity Manager Projects with the same project number are to be 
exported, it is best to add a character to the project number, i.e. project number 
1234567 should be 1234567D for Drainage items, or 12345667L for Landscape items. 

11. For the second project 1234567D, import the project into CES using steps 2-8 above.  
When both projects are to be combined into one project, highlight the original or base 
project by clicking on the job number and then click the File Menu and then Import “Job 
Items from CES Job.”  Highlight the appropriate job to combine into the original (base) 
project and click OK.  For the next popup, click Do Not Combine Items Quantities and click 
OK.  A popup window that indicates the job imported successfully will appear – click the 
OK button. 

12. Once the import process has completed you may open the base job in Trns*port/CES and 
review the imported items. 

13. Repeat with as many subsequent projects as needed. 
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MODULE REVIEW  

SUMMARY  
You are now able to:  

• Create standard reports from Quantity Manager  
• Export Quantity Manager data to XML format required by the AASHTO Trns•port 

software suite.  

 

QUESTIONS  
Before continuing, let’s evaluate what you have learned.  

1. Which tool should be used to transfer quantity data from Quantity Manager to the AASHTO 
Trns•port software suite?  
A - File > Export  
B - Tools > Reports  
C - Either of the above  

2. What is the benefit of using the Enable Quantity Categories option?  
3. Can quantity data be edited directly in the Quantity Manager application?  
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ANSWERS  
1. Which tool should be used to transfer quantity data from Quantity Manager to the AASHTO 

Trns•port software suite?  
A - The File > Export tool is used to transfer data to other applications such as Trns•port. 
The File > Reports tool is used to generate printable reports or spreadsheet data from the 
quantity database.  

2. What is the benefit of using the Enable Quantity Categories option?  
The Enable Quantity Categories option automatically selects all sub-categories and pay items in 
the Pay Item pane. When this option is disabled, you would need to select each and every pay 
item in the list before creating reports or exporting the data.  

3. Can quantity data be edited directly in the Quantity Manager application?  
Yes, but it is not recommended. Technically pay items and quantities can be added, deleted, and 
modified directly in the Quantity Manager application. However, doing so does not update the 
source data in InRoads from which the quantities were originally generated. The workflow 
described in this training recommends that quantity data only be defined and edited in InRoads. 
The Quantity Manager application should be used only to create reports and export the data to 
the Trns•port software.  
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Managing Pay Item 
Database  
 

OVERVIEW  
This module teaches how to add, modify, and delete pay item definitions in the Pay Item Database.  

PREREQUISITES  
• Pay Item Database  

OBJECTIVES  
After completing this module, you will be able to:  

• Add new pay items to the Pay Item database  
• Remove obsolete pay items from the Pay Item database  
• Edit existing pay items in the Pay Item database  
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ADDING NEW PAY ITEMS  
The following procedure is used to add a new pay item to the database.  

1. Select Quantities > Pay Item Manager from the InRoads menu. 
2. Select File > Open from the Pay Item Manager dialog. 
3. Browse to and open the proper Pay Item Manager database. 
4.  Locate and select the category where the new item will be placed. For example, if you are 

adding a new Granite Curb item, select the category 400-461 Pavements>Section 437 – Granite Curb.  
5. Select File > New > Pay Item from the Pay Item Manager dialog. The Edit Pay Item dialog 

appears.  
6. Enter the pay item number in both the Pay Item Name and the Pay Item Code fields.  

If your master pay item database is stored in the Trns•port software suite, the Item number must 
be entered exactly the same as it is defined in Trns•port.  

7. Enter the description in the Description field.  
If your master pay item database is stored in the Trns•port software suite, the description must 
be entered exactly the same as it is defined in Trns•port.  

8. Enter the unit name in the Unit Name field.  
If your master pay item database is stored in the Trns•port software suite, the unit name must be 
entered exactly the same as it is defined in Trns•port. 

9. Select the matching unit from the Formula pick list.  
InRoads uses this formula to calculate the quantity from the InRoads or MicroStation elements.  

10. Click Apply to save the changes to the Pay Item Manager database.  
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EDITING EXISTING PAY ITEMS  
1. Select Quantities > Pay Item Manager from the InRoads menu.  
2. Select File > Open from the Pay Item Manager dialog.  
3. Browse to and open the proper Pay Item Manager database.  
4. Locate and select an existing item in the database.  
5. Right click on the item and select Edit from the pop up menu.  

The Edit Pay Item dialog appears. 
6. Make the necessary changes to the Pay Item definition.  

If your master pay item database is stored in the Trns•port software suite, the pay item code, 
description, and unit name must be entered exactly the same as it is defined in Trns•port  
The description can be modified with a supplemental description as described earlier in this 
course and still satisfy the requirements of the Trns•port software. 

7. Click Apply to save the changes to the Pay Item Manager database.  

  



58  Nov - 12 

Copyright © 2012 Bentley Systems, Incorporated 

REMOVING PAY ITEMS  
1. Select Quantities > Pay Item Manager from the InRoads menu.  
2. Select File > Open from the Pay Item Manager dialog. 
3. Browse to and open the proper Pay Item Manager database.  
4. Locate and select an existing item in the database.  
5. Right click on the item and select Delete from the pop up menu. 
6. When prompted, select OK to confirm the deletion of the pay item.  
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	3. Add the following pay item to the Pay Items assigned to these elements.
	4. Select the 402-3113 (Quantity Override) pay item in the Review/Edit Pay Item dialog.
	5. Enable the Override Measurement option.
	6. Key 10.0 into the Override Measurement text box.
	7. Click Apply to complete the assignment.
	8. Select the other Guardrail element in the top portion of the dialog.
	9. Assign the 402-3113 (Quantity Override) pay item with the 10.0 override measurement to this element.
	10. Click Apply and then Close the Review/Edit Pay Item dialog.

	Assigning “Supplemental Descriptions” to Pay Items
	1. Select Quantities > Pay Item Manager to open the pay item database.
	2. Locate the following pay item
	3. Double click on the pay item to open the Edit Pay Item dialog.
	4. Click in the Description field.
	5. Add {200+00 LT} to the end of the description.
	6. Click Apply to save the change.
	7. Click the Next button, , in the Edit Pay Item dialog box to move to pay item 610-9000B.
	8. Click in the Description field.
	9. Add {250+00 RT} to the end of the description.
	10. Click Apply to save the change.
	11. Close the Edit Pay Item dialog.
	12. Review the updated descriptions in the Pay Item Manager dialog.
	13. Close the Pay Item Manager dialog.
	14. Close MicroStation and InRoads.

	Module Summary and Review
	Summary
	Questions
	1. How many pay items can be assigned to a single element?
	2. Which tool or tools can be used to assign pay items? (Select all that apply)
	3. Can a quantity override value be assigned to all pay items?

	Answers
	1. How many pay items can be assigned to a single element?
	2. Which tool or tools can be used to assign pay items? (Select all that apply)
	3. Can a quantity override value be assigned to all pay items?



	Computing and Extracting Quantities
	Overview
	Prerequisites
	Objectives
	Compute All Quantities
	1. Close MicroStation and InRoads if they are still running from the previous session.
	2. Start InRoads and MicroStation.
	3. Set the directory to C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 03\.
	4. Open the file Compute Quantities.dgn.
	1. Select File > Open from the InRoads menu.
	2. Open the Project File C:\InRoads Training\Quantity Manger Lab\RWK\Practice Lesson 03.rwk.
	1. Select Quantities > Pay Item Manager from the InRoads menu.
	2. From the Pay Item Manager, select File > Open.
	3.  Open the pay item database file C:\InRoads Training\Quantity Manger Lab\Standards\Pay Items\ GDOT(PI#) Quantity Manager Pay Item Database..
	4. Click Exit to Exit the Pay Item Manager dialog.
	1. Select Quantities > Compute Quantities from the InRoads menu.
	2. Set the Alignment name to I-598 EB.
	3. Set the Mode to All.
	4. Click the Browse button to the right of the Database field.
	5. Browse to the folder C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 03\ and enter the filename Quantity Output.mdb.
	6. Click Save.
	7. Click Apply.
	The quantities are calculated and written to the database.
	8. Close the Compute Quantities dialog.

	Reviewing Quantities in the Quantity Manager
	1. Select Quantities > Quantity Manager from the InRoads menu.
	2. Once Quantity Manager has started, make it the active application by clicking the Quantity Manager icon in the Windows task bar. When Quantity Manager is first opened, the dialog is essentially blank.
	3. Click the Open button on the Quantity Manager dialog.
	The Connect to Database dialog appears.
	4. Click the Browse button or the Connect to Database dialog.
	5. Browse to and select the file C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 03\Quantity Output.mdb.
	6. Click Open to open the Quantity Output.mdb.
	7. Click Connect.
	There is not a User Name or Password on the database files created by InRoads.
	The Quantity Manager dialog updates to show the quantity data.
	1. Expand the pay item tree to view the 544-577 Minor Drainage Structures > Section 550 – Storm Drain Pipe, Pipe-Arch Culverts, and Side Drain Pipe section.
	2. Select all of the pipe culvert pay items.
	3. Review the Quantity pane.
	Notice that there are five pipe quantities assigned to four different pay items. The 36” pay items has two pipe definitions.
	4. Exit the Quantity Manager.

	Clearing Highlighted Graphic Elements
	1. Return to the MicroStation session.
	2. Select the MicroStation Element Selection tool.
	3. Click the down arrow in the lower right corner of the Element Selection dialog to expand the dialog options if they are not already expanded.
	4. Select the Level tab in the Element Selection dialog.
	5. Browse to and select the level where the highlighted element graphics are displayed. For this lab, select the level QTYS_P_Quantities-Line.
	All of the elements are put into a selection set.
	6. Click the Delete tool in MicroStation to delete the graphics.
	7. Close MicroStation and InRoads.

	Module Review
	Summary
	Questions
	1. What user name and password must be used to open a quantity database from InRoads in the Quantity Manager application?
	2. True or False - you can review the quantity calculation for an element inside InRoads using the Review/Edit Pay Items tool?

	Answers
	1. What user name and password must be used to open a quantity database from InRoads in the Quantity Manager application?
	2. True or False - you can review the quantity calculation for an element inside InRoads using the Review/Edit Pay items tool?



	Reporting and Exporting
	Overview
	Prerequisites
	Objectives
	Quantity Reports
	1. Close MicroStation, InRoads and the Quantity Manager if they are still running from the previous session.
	2. Start Quantity Manager from the InRoads section of the Start menu.
	1. Click the Open button on the Quantity Manager dialog.
	2. Click the Browse button or the Connect to Database dialog.
	3. Browse to and select the file C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 04\Quantity Output.mdb.
	4. Click Open.
	5. Click Connect.
	1. Select Design from the Phase pick list at the top of the Quantity Manager dialog.
	2. Verify that the Expand Category Quantities option is enabled by selecting the View menu. When enabled, a check mark will appear next to the Expand Category Quantities option. If not enabled, select Expand Category Quantities to enable it.
	3. Select root in the Pay Item pane on the left portion of the dialog box.
	1. Select Tools > Reports > Create.
	2. Select Sample Pay Item Summary Report (HTML) from the Report Style pick list.
	3. Click the Browse button next to the Report File Name field.
	4. Browse to the folder C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 04\ and enter the file name Quantity Summary.html.
	5. Click Open.
	6. Click Create.
	7. Review the report.
	8. Close the Internet Explorer dialog displaying the report.
	9. Close the Create Report dialog.

	Exporting Quantity Manager Data to AASHTO Trns•port
	Trns•port Software Requirements
	1. Select Project > Properties.
	2. Complete the dialog with the following information
	3. Click OK.
	1. Verify that the View > Expand Category Quantities option is enabled.
	2.  Select root in the Pay Item pane.
	3. Select Project > Export > Export.
	4.  Select aecXML from the Export Style pick list.
	The aecXML format is the correct format for transferring data to the AASHTO Trns•port software.
	5. Ensure that the Rename Phase As option is enabled and set to DesignEstimate.
	6. Click the Browse button next to the Document File Name field.
	7. Browse to the folder C:\InRoads Training\Quantity Manger Lab\Practice\Practice Lesson 04\ and enter the file name 1234567.xml.
	8. Click Open.
	9. Click Export.
	A file formatted in the proper XML syntax for importing into the AASHTO Trns•port suite of software is created.
	10. Click OK to the following message.
	11. Close the Export dialog.
	12. Close the Quantity Manager.


	Importing Quantity Manager Data into AASHTO Trns•port
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	Module Review
	Summary
	Questions
	1. Which tool should be used to transfer quantity data from Quantity Manager to the AASHTO Trns•port software suite?
	A - File > Export
	B - Tools > Reports
	C - Either of the above
	2. What is the benefit of using the Enable Quantity Categories option?
	3. Can quantity data be edited directly in the Quantity Manager application?

	Answers
	1. Which tool should be used to transfer quantity data from Quantity Manager to the AASHTO Trns•port software suite?
	2. What is the benefit of using the Enable Quantity Categories option?
	3. Can quantity data be edited directly in the Quantity Manager application?



	Managing Pay Item Database
	Overview
	Prerequisites
	Objectives
	Adding New Pay Items
	1. Select Quantities > Pay Item Manager from the InRoads menu.
	2. Select File > Open from the Pay Item Manager dialog.
	3. Browse to and open the proper Pay Item Manager database.
	4.  Locate and select the category where the new item will be placed. For example, if you are adding a new Granite Curb item, select the category 400-461 Pavements>Section 437 – Granite Curb.
	5. Select File > New > Pay Item from the Pay Item Manager dialog. The Edit Pay Item dialog appears.
	6. Enter the pay item number in both the Pay Item Name and the Pay Item Code fields.
	If your master pay item database is stored in the Trns•port software suite, the Item number must be entered exactly the same as it is defined in Trns•port.
	7. Enter the description in the Description field.
	If your master pay item database is stored in the Trns•port software suite, the description must be entered exactly the same as it is defined in Trns•port.
	8. Enter the unit name in the Unit Name field.
	If your master pay item database is stored in the Trns•port software suite, the unit name must be entered exactly the same as it is defined in Trns•port.
	9. Select the matching unit from the Formula pick list.
	InRoads uses this formula to calculate the quantity from the InRoads or MicroStation elements.
	10. Click Apply to save the changes to the Pay Item Manager database.

	Editing Existing Pay Items
	1. Select Quantities > Pay Item Manager from the InRoads menu.
	2. Select File > Open from the Pay Item Manager dialog.
	3. Browse to and open the proper Pay Item Manager database.
	4. Locate and select an existing item in the database.
	5. Right click on the item and select Edit from the pop up menu.
	6. Make the necessary changes to the Pay Item definition.
	If your master pay item database is stored in the Trns•port software suite, the pay item code, description, and unit name must be entered exactly the same as it is defined in Trns•port
	The description can be modified with a supplemental description as described earlier in this course and still satisfy the requirements of the Trns•port software.
	7. Click Apply to save the changes to the Pay Item Manager database.

	Removing Pay Items
	1. Select Quantities > Pay Item Manager from the InRoads menu.
	2. Select File > Open from the Pay Item Manager dialog.
	3. Browse to and open the proper Pay Item Manager database.
	4. Locate and select an existing item in the database.
	5. Right click on the item and select Delete from the pop up menu.
	6. When prompted, select OK to confirm the deletion of the pay item.



