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EXERCISES 
 
 

 

You can consult the ARCADY 8 help system at any time by pressing F1. 
 
Ensure that you have specified your chosen, local preferences. 
 
 
General Graphical User Interface (GUI) Operation 
 

 Most program operations can be performed either by clicking on icons or by using the 
menus on the main toolbar.  Menus are shown here as, e.g., File>New, which would 
mean clicking on the File main menu and then clicking the New menu option.  (This 
operation could also be performed by clicking the New icon on the main toolbar.) 
 

 Many items can be selected ‘long-hand’ via the Data Outline. These are shown as, 
e.g. Data Outline>Roundabout Network>Roundabout 1>Arms>Arm 1, which means 
you should open the Data Outline, find the Roundabout Network section and then 
expand it until you reach the relevant Leg. 

 

 It is common to have many windows open at once.  Editing data on one window will 
automatically update any dependent windows.  You can rapidly close all windows 
down by clicking Window>Close All Windows. 

 
 

Performance 
 

 Depending on the specification of the PCs being used, you may find that the program 
responds quicker if you close down screens that you are not using.  This is because 
all screens are always updated and synchronized, even if they are behind other 
windows. 

 
 
 

Saving the File 
 

 You can save the file at any point.  A temporary folder for saving files may be 
provided, or you can use your own disk or just use the desktop.  Ask the course tutor 
if in doubt. 

 

 ARCADY 8 files have an .ARC7 extension. 
 

 
Output Files 
 

There is not a separate output file in ARCADY 8.  Instead, the results are saved within 
the file, and are also re-generated every time you load in the data file and run it. 
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Main Horizontal toolbar 

 
 
 

 
 
 
 
 
From left to right, the buttons on the horizontal toolbar are: 
 
 

New File 

Open File 

Save File 

Copy to Clipboard  

Paste 

Print 

Print Preview 

Undo 

Redo 

Show Data Outline 

Show Data Editor 

Show a new Data Grid 

Show Task List 

Windows Manager 

Back 

Forwards 

Previous Item 

Next Item 

Previous 

Toggle Auto-Run 

Run File 

Generate Report 

User Guide 

Glossary 
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Main Vertical toolbar 

 
 

From top to bottom, the buttons on the vertical toolbar are (note that in Basic Mode 
you will see less buttons): 
 

 
 
 
 
 

Show a new Intersection Diagram window 

Jump to the general Intersection options 

Jump to the Geometric Parameters 

Jump to Pedestrian Crossing options 

Show/hide/enter Turning Counts 

Show/hide/enter Flows 

Show/hide/enter Truck and Heavy Vehicle data 

Enter Lane Simulation Mode 

Jump to Geometric Delay options   

Jump to Safety Prediction options 

Jump to individual Time Segment Results 

Show/hide the Summary Results screen 

Show/hide the Analyzer screen 
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Figure 1 – Exercise Roundabout 
MAIN ST 

Range Rd 

HIGH ST 

Grove Rd 
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Exercise 1.  
Creating a simple roundabout 
 
 
 

 
 

1. Launch ARCADY 8.  If you already have it running, either close it down and start 
again, or, click New File.   
 

 
 
In a new file the screen will be blank apart from the Data Outline screen, which 
shows a tree style view of the current file.  Click on the + and – signs to 
expand/collapse sections.   
 
You can view most ARCADY data via the Data Outline, but there are lots of shortcuts 
and buttons to make the most common data easier to access, which we will explore 
throughout these exercises. 
 

2. Press the Run button  on the main toolbar.  This runs the file (i.e. analyzes the 
roundabout) and will show the Summary Results screen.  We’ll return to this later but, 
for now, note that the default file contains three legs and will run without error.  In 
other words, the skeleton file used when you start a new file is ‘ready to run’.  
Building an ARCADY 8 file is a matter of overwriting, and adding to, the default data. 
 
Close the Summary Results screen. 
 
 

3. Press the Diagram button to show the Intersection Diagram.  Don’t worry about trying 
to organize windows; they will get on top of each other but you can easily bring 
windows to the top by either clicking on them or by just re-selecting them from the 
main toolbars.  (See the User Guide for details of the window organizing features 
available.) 
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You don’t need to use the Intersection Diagram, but it’s useful for confirming the 
layout and for selecting legs etc. 
 
The layout of the roundabout in the diagram does not affect the model. 
 
The default roundabout in ARCADY 8 consists of three legs with arbitrary flows and 
geometries. 
 
Hover the mouse over the icons at the top of this screen to check the name of each 
icon. 
 
 

4. Click on any leg in the Intersection Diagram and you should see it highlighted in 
orange.  The Data Outline will automatically jump to the relevant item, and you can 
then use various tools to edit that item.   Double-clicking will usually launch (or switch 
to) an appropriate data screen, and right-clicking will show a more detailed menu. 
 
The whole of ARCADY 8 works using this system; i.e.,  click on something to make it 
the ‘active item’, and all appropriate screens will update and synchronize to show 
data for that item.   
 
If at any time you make a mistake, simply click on the Undo button on the main 
toolbar.  You will probably also want to save the file every now and again whilst 
working on these exercises. 
 
 

5. In the diagram, each leg has a separate entry and exit section, although the leg is still 
considered to be a single entity.  Experiment with clicking, double clicking and 
dragging on different parts of legs.  
 
 

6. Experiment briefly with zooming and panning in the Intersection Diagram. 
 

 Zoom in/out by clicking on the Zoom icon on the NetCon toolbar and then 
dragging the mouse up/down in NetCon.  The other modes work in a similar 
way. 

 You can also zoom in/out using the mouse wheel. 

 If you are zoomed in, pan around by clicking on the Pan icon and then dragging 
the mouse.  
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 You can also pan by moving the mouse with the middle button held down. 

 To cancel zoom/pan mode, either click on the arrow icon, or right-click anywhere 
in the diagram. 
 

 To show the whole roundabout, click the Fit To Window icon.  
 

 
 

7. The roundabout currently only has three legs.  Referring to the picture at the start of 
this document, the roundabout we’re modeling has four legs.   
 
Click on any leg so that it is highlighted.  In the Data Outline, click the Add a copy of 
Arm… button to add the fourth leg. 
 

 
 
If the key in the bottom left of the diagram obscures the diagram, right-click in a blank 
area and then toggle View>Show Key. 
 
 

8. The new leg will be inserted in an arbitrary position.  So far we haven’t named or 
properly allocated legs, so this doesn’t really matter.  To ‘tidy’ the positions of the 
legs, click the Auto-Arrange icon in the Intersection Diagram. 
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9. Like all previous versions of ARCADY, ARCADY 8 needs to know the order of legs, 
so that it can calculate circulating flows. 
 
If the current order is not what you want, you can change it graphically via the 
diagram and then click Tools>Set Leg Order From Intersection Diagram. 
 
Alternatively, click the Intersection button on the main vertical toolbar to show 
properties for the roundabout in the Data Editor, one of the properties is Leg Order. 
 
 

10. Rather than refer to legs by their IDs (Arm 1 etc), it’s sometimes easier to view their 
actual names. In ARCADY 8 there are various modes and options for data display, 
ordering, and so on. 
 
Using the Data Outline, select Data Outline>Options>Sorting and Display.  Double 
click to show the Data Editor.  Click the Show Arm Names option.  The diagram and 
Data Outline will now show ‘untitled’ for each item, and the next step will be to enter 
the real names. 
 

 
 

11. Referring to the roundabout picture at the start of these notes, enter the name of 
each leg by double clicking on each leg and entering it in the Name field. 
 
 
 
You can also enter a name for the roundabout itself (click on the Intersection button, 
or use the Data Outline to access the roundabout properties). 
 

 
 



An Introduction to ARCADY 8 

 

 

© TRL Limited 2012  www.trlsoftware.co.uk           
11 

12. The next step is to enter the geometries for each leg.  There are several ways to do 
this. 
 
Click on the Geometry button on the main vertical toolbar.  Note that this expands 
the Data Outline to the currently selected leg, or you can navigate here manually if 
you prefer. 
 
The Data Grid will show the familiar roundabout geometries each leg. 
 

 
 

13. Click on a different leg, and note that the Data Grid changes to show the leg name, 
etc, rather than the geometries. Press the Geometry button to show the geometries 
again. 
 
Now click on the Padlock icon on the Data Grid.  This will LOCK the Data Grid to 
show only data of the current type.  Clicking on other legs will then highlight the 
geometry of those legs.  
 
Note: You can move any window and re-position any screen without losing data to 
make working easier, or try using the Windows Manager tool for alternative layouts 
by clicking Windows > Windows Layouts > Windows Manager. 
 

14. To view specific information for a single Leg such as geometry in this case, go to the 
relevant leg in the Data Outline and double click on Geometry 
 

15. Double click any item and the glossary screen will appear. This will update to show 
information about the currently active item.  E.g. clicking on Entry Width in the Data 
Editor will show information about entry width, and so on. 
 

 
 
 



An Introduction to ARCADY 8 

 

 

© TRL Limited 2012  www.trlsoftware.co.uk           
12 

Click on different items in the Data Outline and note how both the Data Editor and 
data grids change. 
 
Experiment with the Rotate Grid and Full-size mode options in the data grid; these 
are for your personal preference. 
 
 

16. Make sure that the data grid is showing geometries, and enter the following data: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

17. If you wish, press the Run button and observe that even though we haven’t yet 
entered any flows, the results already show how the legs perform. 
 
 

18. If you haven’t done so already, save the file. 
 
 

19. Optional:  return to the Roundabout properties and change the Intersection Type to 
Mini-roundabout or Crossroads.  Pressing the Geometry button will now show mini-
roundabout or crossroad geometries rather than the standard roundabout 
geometries.  Change the intersection type back to Roundabout and note that your 
data values are still there. 
 
Unlike some early versions, ARCADY 8 lets you change options at any time 
without loss of data. 
 
 

20. Optional:  edit one of the legs so that its flare length is 100m.  Press the Task List 
button on the main toolbar.  The task list shows any errors or warnings, and in this 
case will warn you about the long flare length. 
 
Press Undo to revert this change. 
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Exercise 2.  
Entering traffic flows 
 

1. There are various ways of entering flows in ARCADY 8, but we’ll assume that you 
have a set of turning counts for one hour. 
 
Press the Turning button on the main vertical toolbar to show the turning counts 
screen. Then, in the Options select By Exit for Data Matrix Style. 
 

 
 
Note that, like most other screens, the units (in this case PCE/hour) are clearly 
displayed. 
 
Briefly click on the Proportions tab and note that the proportions are calculated 
automatically and shown for reference (read-only). 
 
(If you wish to enter proportions, enter them on the Counts tab.) 
 

2. Briefly look back at the Options tab.  This is where you can set up options similar to 
those in the Principal Options screen of ARCADY 6. 
 
In particular, change the Data Matrix Style to By Exit and enter the data shown below 
(or if your course notes are electronic, paste them directly into ARCADY). 
 
Turning Counts (PCE/hour) 

 

From \ To 1st 2nd 3rd U-Turn Total 

Main ST 10.000 385.000 135.000 0.000 530.00 

Grove RD 90.000 55.000 15.000 0.000 160.00 

High ST 20.000 770.000 0.000 0.000 790.00 

Range RD 90.000 10.000 10.000 0.000 110.00 

Total 210.00 1220.00 160.00 0.00 - 

 
 

3. Although the turning counts have been entered in PCE/hr, ARCADY 8 still needs to 
know how many heavy vehicles are involved.  (This is necessary for some internal 
calculations that work only in vehicles.  In many cases, the heavy vehicle 
percentages will make little difference, but, you should always enter them.) 
 
Press the Veh Mix button on the main vertical toolbar. 
 
The quickest way for now is to go to the Options tab of the Vehicle Mix screen and 
click Default Vehicle Mix.  The HV Percentages tab will then show 10% HV for every 
turning movement. 
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If you have Heavy Vehicle Percentages then enter them now. 
 

4. All data entry is now complete (we’ll return to pedestrian crossings later), so save the 
file again. 
 

Remember, in ARCADY 8 you can enter data in any order; you don’t have to 
stick to the order presented in these exercises. 
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Exercise 3.  
Running files and checking results 
 
In ARCADY 8, you are encouraged to run the model frequently, so that you develop a ‘feel’ 
for the roundabouts performance as you vary input items. 
 
 
 

1. Load in the completed file from the previous exercise (or any other working file). 
 

2. Press the Run button on the main program toolbar. 
 

3. If there are any errors, the Task List will be highlighted in red and you won’t be able to 
run the file.  If this happens, check with the course tutor. 
 

4. If all is well, the Summary Results screen will appear.  You can leave this screen 
visible all the time and should think of running the file as simply refreshing this screen 
and all other results. 
 
The results shown here represent the ‘worst’ values for each leg over the whole 
modeled period.  Click on Columns and select all options as below. 
 

 
 

5. The results show that Grove Rd suffers from the longest queue and delay as well as 
the worst LOS. 
 

6. The Delay column is based on Average Delay per Arriving Vehicle – i.e., takes into 
account the fact that vehicles arriving during this time segment may be delayed in 
other time segments if they join a long queue. 
 

7. LOS (Level of Service) is based on the Delay value.  LOS varies from A-F and is 
color coded, with F representing unacceptable delay.  See the User Guide for full 
details. 
 

8. As an experiment, show the geometries for Grove Rd and alter the entry width to a 
larger value.  Run the file and see what happens to the summary results. 
 

9. Press the Auto-run button on the main program toolbar (next to the Run button).  
Changing entry width or any other value will automatically re-run the file, so that you 
can immediately see the effect of changing any data. 
 
 

10. Turn off Auto-run and set the entry width back to its original value (or use the Undo 
button) 
 
 

11. More detailed results are available via the Data Outline or by clicking on the Results 
button on the main vertical toolbar.  These can be viewed with the Data Editor and 
Data Grids, as with any other data type.   
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For full details of the data available, try running a report.  
 
The data covers multiple outputs. In particular, the entry, exit and circulating flows are 
explicitly shown, these are also displayed by default in the Intersection Diagram. 
 
 

12. This data is per time segment.  At any time there is a current time segment, which 
you can view and change via the drop-down in the top-right of the main screen.  
Currently this will be set to 08:00-08:15, but you can change it to any other segment 
and see how the results change. 
 
Generally the ‘worst’ results will be in the middle of the modeled period. 
 
 

13. The Data Outline shows that there are several sets of results.  The Results button on 
the main toolbar is a shortcut to Time Segment Results, which you can expand to see 
more advanced results.  You can also use the Data Outline to select Whole Period 
Results, which forms the basis of the Summary Results screen. 
 

 
 
 
Optional: Show a data grid of results and then click on the Copy button on the main 
program toolbar.  Launch Excel, or any other editor, and paste the clipboard contents.  
You should find that the relevant results appear as a table. 
 
This is a convenient way to generate your own reports if you only want specific 
information. 
 
 

14. To generate a report that includes ALL data, click the Generate Report  button 
on the main program toolbar as before.   
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This will generate a HTML report and show it in the built-in Report Viewer.  The 
viewer contains various options at the top of the screen which control the contents of 
the report. 
 
Experiment with the options here and use the Refresh button to re-generate the 
report. 
 

  
 

15. To save the current report as a PDF file, click Convert>Save as PDF document, or to 
convert to a Microsoft Word document click Convert > Convert to Word Document. 
 

16. You can also create your own custom grids and save these for future use, by using 
the Custom Grids option in any Data Grid.  See the User Guide or the course tutor for 
full details. 
 
 

17. It’s possible to visualize how a given output value – such as LOS for a leg – varies 
over time, as follows:  
 
Click the Analyzer button on the main vertical toolbar. 
 
Select Time Graph mode. 
 
Use the Data Outline/Editor/Grid to navigate to an item of interest – for example, the 
End Queue for Grove Rd. Click on this item in the Data Editor/Grid. 
 
The Analyzer Screen’s Output Variables section will show an option above the grid to 
add this item as a ‘variable of interest’.  Clicking this option will add the data item to 
the grid. 
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The same system applies to nearly ANY other data item. 
 
Below the Time Graph button, press Line, Bar or Table.  This will illustrate in various 
ways how the data item (End Queue) varies over time.  (The resolution depends on 
Demand Set Definition>Time Segment Length). 
 

     
 
 
In the Analyzer screen, above the lower grid, press the Add all Legs and then the 
Auto-color options.  This is a convenient way to add in the same data item for all legs 
in the roundabout and assign a color to each, which leads to a graph like this:  
 

 
 
This graph quickly shows how the queue builds up and then decays again, and how 
Grove Rd (the dark blue line) has a higher queue than the other legs. 
 
You can also try out one of the pre-loaded Common X-Y Graphs and it’s also 
possible to visualize results through the Intersection Diagram, which we’ll come onto 
later. 
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Exercise 4.  
Intersection Diagram – more features 
 

 
 

1. Continue with the file from the previous exercise or load a completed file.  Show the 
Intersection Diagram. 
 
 

2. By default, the diagram shows the flow in and out of each leg, along with the turning 
and circulating flows.  These are ACTUAL calculated flows, i.e. what ARCADY 8 
calculates when the file is run.  Therefore they only exist once the file has been run, 
and they may or may not match the entered turning counts. 
 
The values are shown for the current time segment. 
 
Choose different time segments (drop-down menu at top–right of program) and see 
how the flows show in the diagram change. 
 

 

Try out the options through the  button in the Intersection Diagram, here’s an 
example of a customized diagram (we will show you how to achieve this shortly): 
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3. Compare the entry flows shown as default in the diagram to the turning counts in the 
Turning Counts screen. 
 
The numbers will not match exactly; this is due to the small amount of random 
queuing that can occur even when an entry is within capacity. 
 
 

4. Increase some of the turning counts and run the file until one or more of the legs are 
over-capacity.   The entry flows shown in the diagram should now represent the 
capacity of the legs – i.e., the maximum flows that the Intersection can cope with. 
 
 

5. There are many options that you can customize in the diagram. 
 
For example, you can show the entered turning counts on the diagram instead of the 
calculated entry flows, as follows:  
 
Press the Options button in the Intersection Diagram toolbar. 
 
Select Text Overlays 
 
In the Per Leg screen, press Select Field for Text A and B.  The diagram will change 
accordingly.  Entering different values in the Turning Counts screen will now update the 
diagram immediately. 

 
Note, you may have to change the Numeric Overlay setting in the Intersection Diagram to 

Custom . 
 
In the options screen, switch to Arms>Turn Boxes, and repeat the process as above.   

 
To restore defaults, use the Defaults button in both parts of the screen. 
 

 
 

6. To visualize queues, use the menu as shown below and then choose different time 
segments.   
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7. Use the menu as shown below to visualize the relative flows around the roundabout:  
(You can go to the Options screen and adjust Overlay Boxes>Overlay Box Width). 
 
This should show that most traffic (the widest boxes) travel around the roundabout on 
Grove Rd. 
 

 
 
 

8. Locate the ruler on the diagram and note that you can drag it with the mouse to help 
with measurements. 
 
If the roundabout has an ICD of 150ft.  Position the ruler so that it stretches across 
the inside of the roundabout, then right-click on it, select Adjust Scale and enter 150. 
If you now try to use the ruler to ‘measure’ other parts of the roundabout, they should 
be realistic, depending on how you’ve positioned the legs. 
 
If, however, you have a background image, the ruler can be more useful, as 
we’ll see next. 
 
 

9. Show the Intersection Diagram Options screen and select the Background tab.  
Click Add and browse to the exercise files and find the exercise background 
image.gif file. 
 
You can add any number of images and overlap them as needed. 
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10. Make sure that the file is selected in the options screen, then use the red handles in 
the diagram to manipulate the size and position of the picture. 
 
Use the Opacity slider to fade the picture relative to the rest of the diagram. 
 
You can then try to move the legs so that they more closely match the real layout. 
 
To add ‘bends’ to a leg, right-click on it and select Add new Section.  This will add a 
new control point that you can drag. 
 
You can also adjust the relative size of labels and text using the Options screen. 
 

  
 

11. If you have calibrated the ruler, try turning on the queue display again.  The size of 
the red queues should roughly match the real length of the queues in meters; based 
on an average, default PCE length of 5.75m (this is adjustable: Data Outline > 
Options > Analysis Options). 
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12. For any leg, use the Data Outline to show its Capacity>Queue Options properties.  

The Flare Storage and Lanes on Approach only affect the diagram – they don’t 
affect the model. 
 
If you set Lanes on Approach to 2, then the length of the queue in the diagram will 
halve, on the assumption that the queue is evenly spread across two lanes. 
 
The Flare Storage option works in a similar way. 
 
(See the User Guide for full details.) 
 

  
 

13. If you want to store a location to a map, web site, etc, you can do this as follows:  
 
Use the Data Outline to select File Description>Web Links.  Add a new Web Link and 
show the Data Editor.  You can then edit the URL to any web address or local file 
address, and can add as many web links as needed. 
 
Clicking the link will then open the link in your browser. 
 
Generating a report will include the links as hyperlinks towards the top of the project 
report. 
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Exercise 5.  
Pedestrian Crossings 
 
Let’s say that the roundabout has pedestrian crossings on some of the legs.  
 
In ARCADY 8 if you add a crossing to a leg, it will be visualized in the diagram but its position 
and orientation do NOT affect the model.   As with all other data, the only data that affects the 
model results is entered via the Data Outline and Editor. 
 

1. Press the Crossings button on the main vertical toolbar.  This will take you to the 
Pedestrian Crossing section of the currently selected leg. 
 
To add a crossing, change the Crossing Type (default=’None’). 
 

2. To edit details of each crossing, use the Data Outline to select the Unsignalled 
Details section. 
 

3. Also, in ARCADY 8 you can enter the crossing length separately for the entry and 
exit side of the crossing and can choose to enter a crossing time instead of 
length. 
 
The data for the exercise file is shown below: 
 

 
  

4. To enter pedestrian flows, use the main Flows screen on the vertical toolbar.  If 
there are any crossings present, an additional Pedestrian Flows button will 
show. 
 
In ARCADY 8, ped flows are entered in the same way as traffic flows, and most 
of the same options are available. 
 
As an example, choose keep the ONE HOUR profile for the pedestrian flows.  In 
this mode, a single number is entered for each crossing and this flow is then 
distributed to time segments in a similar way to the traffic profile (I.e. the central 
time segment is the busiest). 
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5. Does the presence of the pedestrian crossing make much different to the overall 
results (ensure that you have entered some pedestrian flow!!)? 
 
Click File>Copy Into New File.  This will create a clone of the file which you can 
then switch between by using the blue file bars at the bottom of the screen. 
 
You can load as many files as you like and switch between them in this way. 
 
Run both files and experiment with increasing the pedestrian flows until you see 
an obvious difference in the Summary Results. 
 
There are various other ways that results can be compared - see the next 
exercise. 
 
 

6. ARCADY 8 includes a Signalled crossing model.  The data requirements are 
very similar to the existing Unsignalled crossing model. 
 
Optional: Investigate the difference in performance between an unsignalled, 
signalled and adaptive signalled crossing (Tip: The x-y graph generator may be 
useful here). 
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Exercise 6.  
Comparing and analyzing results 
 
 

1. Close all files, and then load in a working file and run it. 
 
 

2. Click File>Copy Into New File.  This will create a clone of the file which you can then 
switch between by using the blue file bars at the bottom of the screen. 
 
 

3. Run both files and flick between them and confirm that the results are identical. 
 
 

4. Now make an obvious change to one of the files.  For example, change one of the 
geometries or flows by a large amount.  A good one to try is one or more of the Flow 
Scaling Factors in the Flows screen. 
 
Run the file; flicking between the files should show clearly the difference in the 
results. 
 
 

5. Optionally, make a third copy (or as many as you like), with other changes. 
 
 

6. Select Tools>Compare Files from the main menu.  Make sure both files are ticked 
and choose a color for each file by double clicking the color. 
 

 
 

7. When you press OK, a report will be generated using whatever options you have 
previously set up for reports. 
 
The report will contain various colors corresponding to the files being compared. 

 

 
 

 
8. Changing options in the report and pressing Refresh will update the report as usual 

and you can use all other features such as creating a PDF or converting to Word. 
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9. In some cases, a small difference in an input item has a cascading effect on more 
output items than you might expect.  What is the effect of the change you made? 
 
 

10. It’s also possible to investigate within one file the effects on any output of any change 
to any input variable, leading to powerful sensitivity analysis.   
 
As an example, consider a graph of showing how the RFC on Arm 1 varies as the 
flow scaling factor on Arm 1 is varied.  To set this up, follow these steps:  
 
Close all files except one and make sure that it still runs without error. 
 
 

11. Show the Analyzer Screen and select X-Y Graph mode, select Common X-Y Graphs 
> Max Delay vs Flow Scaling Factor. 
 
The Analyzer screen should now look like the below: 
 
 

 
12. Press either the Line or Bar button under the X-Y Graph mode button to generate the 

graph.  This will perform a set of ARCADY 8 runs and plot the results.  As might be 
expected, the Delay increases steadily as the flow scaling is increased and Grove Rd 
suffers the most. 
 

 
 

13. In the Analyzer screen, try de-selecting the other Legs and generating a more 
detailed graph for Grove Rd.   
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14. The same system can be used to set up almost any combination of inputs and 
outputs.  Different outputs can be shown together, as in this example: 
 

 
 
 

15. Set up and run a graph that shows how V/C Ratio (RFC) varies with flow scaling 
factor. 
 
The steepness of this graph indicates how sensitive each leg is to small variations in 
flow. 
 
 

16. Find a way to investigate the sensitivity of each leg to variations in capacity. 
 
 
What about variations in geometry? 
 
 

17. Returning to the previous exercise about Pedestrian Crossings:  use the x-y graph to 
show at which level of flow the crossing begins to have a major effect on the capacity. 
 
 

18. The Analyzer screen has various other modes, one of which (Time Graph) we 
covered briefly in a previous exercise. 
 
For full details of the other modes, see the User Guide or ask the course tutor. 

 
 
 
 
 
 
 



An Introduction to ARCADY 8 

 

 

© TRL Limited 2012  www.trlsoftware.co.uk           
29 

Exercise 7.  
Analysis Sets and Demand Sets  
 

 Analysis Sets (e.g. A1, A2…) allow you to store multiple sets of geometric layout data 
within the same file (ie. both proposed and conceptual layouts), or to compare different 
options such as overall flow scaling or lighting/surface conditions   
 

 Demand Sets (e.g. D1, D2…) allow you to store different sets of flow data, which can be 
combined together, within the same file.  Each Demand Set is associated with a time of day 
(e.g. AM, PM, etc) and also a flow type, such as base or development flows. This allows you 
to model AM, PM, Saturday and Design Years in one single file. 
 
 
 

1. Close any open files and re-open your project file (complete with geometries and 
turning counts). 
 

2. By default, there is a single Analysis Set.  Analysis Sets are set up via the Data 
Outline.  Browse in the Data Outline to Analysis Sets>Analysis Set 1 and view its 
details in the Data Editor. 
 

 
 

3. Enter the name for Analysis Set 1 as “Conceptual Layout”. 
 

4. Use the Data Outline to add a new Analysis Set (Add a copy of Analysis Set...) and 
name it ‘Proposed Layout’.  (If you wish, add some further analysis sets.) 
 

5. To choose which Analysis Set is in use, select between them via the drop-down on 
the main toolbar.   
 

 
 

6. Throughout ARCADY 8, certain items can be entered separately for each analysis 
set. These items are identified by a ‘card stack’ icon in the Data Editor screen and 
some other data editing screens.   
This includes all geometric delays. If an entire group of items can be entered 
separately for each analysis set, the icon is shown at the top of the Data Editor.   
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7. Make sure that Proposed Layout is selected as the current analysis set, then make 
some changes to geometries and run the file and check in the Summary Results that 
the results differ. 
 
 

8. Switch between Conceptual Layout and Proposed Layout and check that the values 
in the geometry screens vary as expected (as you are switching between two sets of 
data.) 
 
 

9. You can continue to switch between the two sets and by default ARCADY will show 
all results together. 
 
Show the Summary Results screen and select Mode>Show All Sets (notice the 
differences). 
 

 
 

10. Demand Sets work in a similar way, but only affect flows. Use the Data Outline to 
access and add/delete Demand Sets. Each Demand Set has properties such as its 
start and end time, time segment length etc, similar to those in ARCADY 6. 
 
In ARCADY 8, the Scenario Name is used for the year, or type of flows (e.g. 
base/development/etc), and the Time Period Name is used to indicate the time of 
day. 
 
Edit Demand Set 1 so that Scenario Name = “2012” and Time Period Name=”AM”. 

 
This system is not compulsory but the Summary Results screens etc. are designed to 
use this naming convention. 
 

11. Add a second demand set, and change its Time Period Name to “PM”.  (Optionally, 
add a third or more for low demand periods such as the middle of the day or 
weekends). 
 
 

12. Go to the Flows or Turning Counts screen and notice the green demand set icon, 
which indicates that data can be entered for each Demand Set. 
 
 

13. Select the active Demand Set from the drop-down at the top of the screen, as with 
Analysis Sets. 
 
 
Enter different flows or turning counts for the AM and PM peak, and run the file.  The 
Summary Results screen shows the main results for each time period for each layout 
option. 
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You can explore detailed results as usual, remembering to select the active Analysis 
and Demand Sets using the main drop-downs at the top of the screen. 
 

 
 
 

14. If you generate a report at this point, you can use options in the Report Viewer 
(Report Viewer>Time  Segments>Show full details for all sets) to generate a long 
report that shows full details for ALL analysis and demand sets. 
 
 

15. Use the Analysis and Demand set system to add further sets for future years. 
 
 

16. Explore the other options in the analysis and demand set definition screens.  See the 
User Guide for details or ask the course tutor.  Some more examples are shown 
below – see if you can replicate the Demand Sets and Analysis Sets below. 
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Exercise 8.  
Linked roundabouts 
 
ARCADY 8 models systems of linked roundabout by feeding the exit flow from one 
roundabout as the entry flow of the next roundabout, and so on, and converging a solution for 
the system as a whole. This can be extended by using the concept of automatic exit 
restrictions. 
 
The system outlined above is a mathematical one only.  You should apply caution when 
modeling very closed spaced roundabouts, such as double mini-roundabouts in 
particular.  The interactions at such intersections are not well studied and are not explicitly 
modeled. If a separated turn lane is present, the loss of this traffic before the next roundabout 
should be taken into account. 
 

1. Close all files and load the main exercise file and check that it runs. 
 

2. Assume that there is three-leg roundabout to the south of the roundabout, which 
connects with Range Rd.   This can be added to the file as a second roundabout, and 
can then be joined to the first roundabout. 
 
Note:  You can add roundabouts at any time, but normally, it’s easier to add the 
necessary roundabouts as the very first step when creating a file. 
 

3. In the Data Outline, select Intersection Network, right-click and select Add a new 
roundabout.  This will add a new roundabout, but by default it will only have two legs 
and will be located somewhere on top of the existing roundabout(s).  
 
(You can also create a clone of the current roundabout although in this case it’s 
easier to start with a new roundabout.) 
 

 
 

4. Click on each leg of the new roundabout and drag them to the corner of the diagram, 
zooming out as necessary. 
 
 

5. Click on either leg of the new roundabout, and use the Data Outline to add a third leg.  
Edit the name of each leg and position the legs as in the example below: 
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6. Confirm that the Data Outline now lists two roundabouts, each of which you can 
expand on work on independently.  As well as a name, each roundabout has an ID, 
(Roundabout 1, Roundabout 2 etc) which you will need to know for some data entry.  
You can check the ID of each roundabout by clicking on a leg and then selecting the 
Roundabout icon from the main toolbar to show that roundabout’s properties. For 
reference set the name of the new roundabout to New and the Arm Names to West, 
East and North. 
 

7. Show a data grid of geometries: you should see the geometries for both roundabouts 
listed.  For now, leave the geometries of New at their default values, but change the 
approach and entry width to, say, 17ft, to provide a reasonable capacity. 
 

8. Open the Flows screen.  This only shows data for one roundabout at a time, as 
confirmed at the top of the screen.  To change to the other roundabout, click in the 
diagram on any leg. 
 
 

9. Show the Turning Counts screen.  Again, this shows the counts for one roundabout 
at a time.  For the new roundabout, enter the following data: 
 

 
 

10. Run the file. 
 
The summary results screen will show results for both roundabouts, and you can 
explore the individual results using data grids as usual.  All other screens such as the 
Analyzer screen, reports, and visualizations in the Intersection Diagram and so on will 
work as usual. 
 
You can add more roundabouts in exactly the same way or a quick and easy way to 
create a copy of an existing intersection is to simply select a roundabout in the 
Data Outline and select Add a copy of.... 



An Introduction to ARCADY 8 

 

 

© TRL Limited 2012  www.trlsoftware.co.uk           
34 

 
Currently however the roundabouts are not linked – they are completely separate.  . 
Sometimes this can be useful because you can simply store several roundabouts in 
the same file, whether or not they are in reality linked. 
 
The next step in this example, however, is to link the roundabouts. 
 
 

11. In the Intersection Diagram click on the Connect Items Icon  and connect the two 
roundabouts from Range Rd to West or vice versa. The Intersection Diagram will 
display the connection 
 

 
 

12. Now click on the flows screen and then the Linked Arm tab. It should show that the 
legs are now connected and the Profile Type should be set to Linked Arm as below. 
 

 
 
 

13. Run the file. 
 
 

14. In the Intersection Diagram, turn on the flow overlays.  The colors are separate for 
each roundabout – i.e. the colors do NOT follow through between the roundabouts.  
However, by positioning the linked legs next to each other, you should be able to 
prove to yourself that the total width of the bars (i.e. the total flow) is the same. 
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15. Turn on the queue overlays and position the legs to confirm that, so far, there’s no 
risk of the queues in the busiest time segment reaching as far as the other 
roundabout. 
 

16. Increase all flows (using the flow scaling factor will be the quickest method) by 150% 
for example, to see what could happen in future years. 
 

17. Run the file.  Leaving aside the enormous queues that may occur elsewhere, look at 
the queues on West.  Are they longer than the space between the roundabouts?  (If 
not, keep increasing the flow scaling).   
 
Note: depending on how you position linked legs in the diagram, it may be possible to 
visualize the queue explicitly between the two roundabouts.   
 

18. The queue may be longer than the space between the roundabouts.  This is similar to 
the ‘vertical queues’ used in TRANSYT and intuitively indicates that the roundabout 
system may have a problem.   
 

19. It is also possible to model simple blocking back.  This uses a special mode where 
the model is constrained such that the ‘internal queue’ can never be longer than the 
space between the roundabouts.  Instead, upstream legs suffer a capacity reduction 
to represent blocking back. 
 
To switch this on, return to the Flows screen.  For BOTH roundabouts, in the Linked 
Arm tab, tick Queue Limited and enter the Internal Storage Space as, say, 10 PCE. 
See the example on the following page. 
 

 
 

20. Run the file again.  You should find that the queue between the roundabouts is no 
more than 10 PCE, but that the queues on other legs have increased. 
 

21. Increase the flow scaling further and check what happens. 
 

22. Use the x-y graph generator to check how the queues on various legs are affected by 
the increase in flows, and compare the situation with and without the automatic exit 
restriction mode. 
 
The exit restriction mode models blocking back, but you are limited to one exit 
restriction per roundabout. This is an easy way to check for blocking along a 
roundabout interchange or corridor. 

 
 
 



An Introduction to ARCADY 8 

 

 

© TRL Limited 2012  www.trlsoftware.co.uk           
36 

Exercise 9.  
Flow, Slope, Intercept and Capacity Adjustments 
 
This section assumes that you are familiar with the concept of slope and intercept. 
 

1. Close all files and load the main exercise file (WITHOUT the linked roundabout). 
 

2. Run the file and use the Data Outline to browse to 
Arm>Capacity>Slope/Intercept/Capacity Adjustments.   The slope and intercept are 
shown directly, and will update as soon as you change any geometry. 
 

3. We’ve already seen that you can scale flows and capacities by setting scaling factors 
on Analysis Set properties and also for each leg within the Flows screen.  Some of 
these factors, and others, are brought together in a special screen accessed via 
Data>Slope/Intercept/Capacity Adjustments from the main toolbar. 
 

 
 
Some items on this screen apply to a single leg only.  To show data for other legs, 
click on the leg in the Intersection Diagram or any other screen. 
 
Enter values at the bottom of the screen for Network Flow/CapacityScaling, and 
check that these do what you’d expect when you run the file. 
 
 

4. Reset the scaling factors back to 100%. 
 

5. The National and Custom slope/intercept adjustments are designed for use in North 
America. 
 

6. If you happen to know the slope and intercept, and want to overwrite ARCADY’s 
calculated values, you can enter them directly.  Try doing this and see what happens 
to the summary results. 
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7. You can enter Intercept Adjustments one at a time for each leg.  (Click on an item in 
this screen and then click ‘Go to data outline’ to jump straight to the relevant section.) 
 
As an example, enter an intercept adjustment of -100 PCE/hr for Range Rd. 
 

  
 
 

8. Run the file.  The intercept represents the maximum capacity for the leg, so reducing 
it by 100 PCE/hr will have a negative impact on the performance.   
 

9. Plot an x-y graph of capacity for a given time segment against intercept adjustment.  
This should show the capacity varying exactly in line with the adjustment. 
 

10. It may be that you don’t know what the adjustment should be, but you’ve measured 
entry and circulating flows at the roundabout.  The adjustment can be calculated from 
these.  In the Intercept Adjustments section of the screen, press Calculate. 
 

11. The screen that appears works for each leg, one at a time.  Change leg by selecting 
other legs via any screen. 
 
For now, let’s assume that for Range Rd, only, we measured on-site an entry flow of 
800 PCE/hr and a circulating flow of 500 PCE/hr. 
 
Enter this data in the top of this screen and then press Calculate. 
 

  
 
The program calculates that the observed performance is WORSE than that 
predicted by ARCADY, equivalent to an intercept adjustment of -234.85 PCE/hr.  
 
Press Store to actually use the adjustment (otherwise it will be thrown away 
when you close the screen).   
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12. Run the file.  As expected, the overall performance should be worse. 
 
 

13. Look at the individual time segments and find one where the circulating flow happens 
to be close to 500 PCE/hr.  For this time segment, the entry flow should be close to 
800 PCE/hr. 
 

14. Optional:  Use a Time Graph to look at the entry and circulating flow for all time 
segments.  The relationship will depend on the value of the intercept adjustment. 
 
The graphs on the following page show increasingly negative intercept adjustments, 
which has the effect of pushing the entry flow lower and lower, and also affects the 
shape of the graph.   
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15. Turn off the intercept adjustments, or close and re-load the file. 
 
 

16. In ARCADY 8 it’s also possible to use capacity adjustments.  
 
You can enter these directly as a direct or percentage value:  
 
  
 
Altering the capacity of a single leg in this way allows you to check how sensitive the 
leg is to small changes in capacity. 
 
 
 
Capacity adjustments are more generalized than intercept corrections, because 
they are applied towards the end of the modeling process rather than at the 
beginning. 
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Exercise 10.  
Units and other options  
 
 

1. Close any open files and load the main example file. 
 

2. Look at the flows screen, any results screen, and a generated report, and observe 
that, wherever possible, numerical values are always shown with an associate 
UNIT. 
 
What is the default value of flow?  Capacity?  Queue?  Distance?  Speed? 
 
 

3. PCE (Passenger Car Equivalent) is generally recommended, because it 
automatically takes into account vehicle composition.   A queue quoted as 10 
PCE, for example, is less ambiguous than 10 Veh. 
 
In ARCADY 8, spaces are usually measured in PCE.  E.g. the space between a 
crossing and a roundabout is expressed as a number of PCE. 
 
 

4. Close all windows but show main geometries (entry width etc) and note that these 
are shown in feet. 
 

5. Click Data>Units. 
 

 
 

6. Change the Distance units to meters and note that the geometry screen 
automatically updates. 
 

7. Enter geometry in meters and then switch the units back to feet and note that 
again the geometry screen automatically takes this into account. 
 

8. Show the flows and turning counts screen, and use the Units screen to switch the 
traffic flow unit between per hour, per minute and per time segment.    Note that 
the values automatically update. Because you can switch at any time, this allows 
you to quickly compare different items in different units. 
 

9. The Summary Results screen will update to show different units, but you will 
need to re-run the file for this to take effect. 
 
 
 

10. Choose different units and save the file.  Close the file and re-open it.  Are the 
units the same or have they reset to defaults? 
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ARCADY 8 saves the units in the file. 
 
Therefore, when checking someone else’s ARCADY 8 file, pay attention to the 
choice of units. 
 

11. Show the Vehicle Mix screen and check that there are 10% Heavy Vehicles. 
 

12. Use the Units screen to toggle the Traffic Unit Results between PCE and Veh.  
Look at time segment results:  flows and queues in Vehicles will be higher than in 
PCE.  Again, ARCADY 8 automatically allows for this. 
 

13. Delays and other results can also be expressed in different units.  For full details, 
see the User Guide. 
 

14. Click Tools>Measurement Converter.   This utility screen allows you to convert a 
quantity in one unit to the current file units, you can apply a scale conversion at 
the same time. 
 

 
 

15. Experiment with the Copy and Paste buttons on the main toolbar and their 
application to various screens such as the Flows and Turning Counts screen.  Try 
transferring data between ARCADY 8 and Excel or Word (or other ARCADY and 
TRANSYT files). 
 
Add several demand sets, and use Edit>Copy/Paste All Demand Sets.  Can you 
use Excel to manage the data for several demand sets, and then paste it into 
ARCADY 8 in one go? 
 

16. The following options can all be changed easily at any time - can you locate 
them?  (TIP:  Try using Help > Data Field Finder or press F3) 
 

 drive-on-the-left/right 
 

 lighting conditions (mini-roundabout only) 
 

 road surface conditions (mini-roundabout only) 
 

 description of each analysis and demand set 
 

 demand set relationships 
 

 grade separated roundabout type 
 

 queue variations and queue markers  (this is not covered in the upgrade 
course but see the User Guide or ask the course tutor if you would like 
details) 
 

 RFC/ LOS threshold 
 

 Vehicle length (used for queue length calculations) 
 

 Options to control the sorting and grouping of legs 
 

 Options to control the font size 
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Finally, if you haven’t already done so, please notice the hyperlink shown at the very 
bottom of the screen.  This changes from time to time and is a link to latest news 
about the product.  If you notice that the headline has changed, please take the 
time to read the full story.  We will use this system to alert you to new versions, 
upgrades, maintenance releases and any other useful information. 
 

Notes: 
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Geometric Measurement Reference 

 
Approach Road Half-Width - V 

The approach road half-width, v, is measured at a point in the approach upstream from any 
entry flare, from the median line to the nearside kerb. 

 

Point A is the point of maximum entry deflection at the offside end of the yield line where it 
meets the median island (or marking). 

Range: 6.56168 ft - 39.37008 ft 
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Entry Width – E 

The entry width is measured from the point A along a straight line at right angle to the 
nearside kerb.   

 

Point A is the point of maximum entry deflection at the offside end of the yield line where it 
meets the median island (or marking). 

Range: 9.84252 ft - 52.49344 ft 
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Effective Flare Length – I’ 

The effective flare length is recorded as zero if there is no flare. Note that if a zero flare length 
is entered then ARCADY will check that E = V and show an error otherwise.  Conversely, if E 
is greater than or less than V a non-zero flare length must be entered. 

The construction to be used to obtain the average effective length, over which the flare is 
developed, l´, is illustrated below. 

 

Note:  the shape of the line CF mirrors that of the nearside kerb line.  Similarly, the shape of 
line DG mirrors that of the centre line or kerb of the central island if one exists. 

AB = E (the point A is as in Figure 23‑1). 

                GH = V (the point G is the best estimate of the start of the flare). 

                GD is parallel to AH and distance v from it. 

                CF´ is parallel to BG and distance ½ BD from it. 

The simplest way to obtain the measurements is as follows: 

1.     If not already done so, draw the projection line AB as used to measure the entry width 
(see above).  

2.     Draw ‘tram lines’ parallel to the centre of the road, towards the yield line, from the point 
G at the start of the flare. 

3.     This line (GD) intersects the line AB, which is the line along which the entry width (e) is 
measured, at point D. The flare length (l’) is measured from the point C, which bisects BD 
along a line parallel to the kerb and distance ½ BD from it, to a point F´ where it intersects line 
GD. 

The effective flare length is then defined as l´ = CF´ (The line over which l´ is measured is 
often curved as it matches the curve of the nearside kerb).   
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Effective Flare Length Continued - I’ 

NOTE: The point G can often be chosen by identifying the first point upstream of the yield line 
where the nearside kerb and centre line of the road are parallel to each other. 

Also note that on occasions when the line A-B is NOT perpendicular to the island kerb (or 
centre line) the line D-A is not always (v) wide. 

TIP: Measurement of Median Line: 

In order to measure some parameters, it is first necessary to define a line “midway” between 
the kerb line and centre line (or centre island) on the entry to the roundabout. It is sometimes 
also necessary to define a midway line on the roundabout exits. 

Naturally, the midway line (or centre line, or median line) passes through all the centre points. 
Each centre point is defined as the centre of a line drawn from kerb to centre line (or island) at 
right angles to the kerb line. 

Range: 0 ft - 3277.55906 ft 
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Entry Radius - R 

The entry radius is measured as the minimum radius of curvature of the nearside kerb line at 
entry.  For some designs the arc of minimum radius may extend into the following exit, but 
this is not important provided that a half or more of the arc length is within the entry region. 

When the radius of the kerb line is continuously changing (i.e. it is a transitional curve) TRL 
recommend measuring the entry radius as follows: 

1.                   De-lineate a length of kerb line which extends from a point 25 metres 
upstream of the yield line to 10 metres downstream of the yield line 
(measured along the curved path of the nearside kerb line). 

2.                   Within the length of kerb line defined above, choose a 20 metre length with 
the maximum average curvature (i.e. this 20 metre length has a greater 
average curvature than any other 20 metre length you could have chosen). 
This process will have to be done by eye and is therefore somewhat 
subjective. (If the length of kerb line in (1.) is less than 20 metres long, 
then use whatever length is available for defining (2.)). 

3.                   Measure the average radius of the 20-metre length defined in (2.). This 
measurement becomes “r”. 

 

Point A is the point of maximum entry deflection at the offside end of the yield line where it 
meets the median island (or marking). 

Range: 9.84252 ft - 3277.55906 ft 
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Inscribed Circle Diameter – ICD 

The inscribed circle diameter, D, is the diameter of the largest circle that can be inscribed 
within the junction outline. 

In cases where the roundabout is asymmetric, the local value in the region of the entry 
(Leg) being considered is used. 

 

Point A is the point of maximum entry deflection at the offside end of the yield line where it 
meets the median island (or marking). 
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Conflict (Entry) Angle – PHI 

The conflict angle, or entry angle, serves as a geometric proxy for the conflict angle between 
entering and circulating streams. Two constructions are used for the conflict angle:  the first 
applies to well-defined conventional roundabouts, and the second to all other types. 

For conventional roundabouts (i.e. those with identifiably parallel-sided weaving 
sections, where the arms are well separated), the angle measured is in effect that between 
the projected path of an entering vehicle and the path of a circulating vehicle. 

 

A´D´ is a line parallel to the path taken by the circulating flow, along the centre of the 
circulating carriageway. 

EF is a line midway (along its entire length) between the nearside kerb line and the median 
line or nearside edge of any median island. 

BC is a tangent to EF at the point where EF intersects the yield line. 

PHI is then measured as the angle between BC and the tangent to A´D´ at the point of 
intersection of the two lines. 

For other cases the construction is different as below. This construction is used when 
there is insufficient separation between entry and adjacent exit to be able to define the path of 
the circulating vehicle clearly.  In this case, circulating traffic which leaves at the following exit 
will be influenced by the angle at which that arm joins the roundabout.  The angle between 
the projected entry and exit paths is measured and then halved to find PHI, as on the 
following page. 
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EF is a line midway (along its entire length) between the nearside kerb line and the median 
line or nearside edge of any median island. 

BC is a tangent to EF at the point where EF intersects the yield line. 

JK is as EF but for the following exit. 

GH is a tangent to JK at the point where JK intersects the boundary of the roundabout 
circulation. 

PHI is then defined as [angle HLB] / 2. 

Note that if angle GLB exceeds 180 degrees, then PHI is defined as zero. 

If it is not clear which of the two methods should be used, the following should clarify the 
situation. All three vehicle paths (entry, exit and circulatory carriageway medians) should be 
constructed, and the entry and exit paths projected towards the roundabout centre. The 
choice of construction for PHI depends on where these projections meet: if the meeting point 
is closer to the centre of the roundabout than the arc of the circulatory carriageway median, 
then the first construction for conventional roundabouts should be used; if they meet outside 
that area, then the construction for small roundabouts be used. In the limiting case where all 
three medians intersect at a point, it is common for the circulatory carriageway median to 
bisect the angle between the other two medians, so that the two methods become equivalent. 


