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Course Overview
Course Description

This course is for individuals who need to manage documents throughout a 
project cycle. It presents many aspects of document management using 
ProjectWise.

Target Audience

This course is recommended for the following audience(s):

• Those who will use ProjectWise Explorer in a managed environment

Prerequisites
• Familiarity with Windows Explorer

• Familiarity with Microsoft Office applications

• A basic understanding of MicroStation

Course Objectives

After completing this course, you will be able to:

• Log in from the desktop and work with integrated applications

• Navigate using ProjectWise Explorer and use its features

• Use workflows

• Search for documents
Aug-12 8 Course Overview
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Course Objectives
• Scan for References and Link Sets and use other utilities

• Navigate ProjectWise Web Parts

Note: This course update for (SELECTseries 4) contains information about new 
features available in the release. Obviously not all new features added to the 
ProjectWise suite of products are pertinent to this course, but those that are 
will be indicated by the tag New for (SELECTseries 4):
Course Overview 9 Aug-12
Copyright © 2012 Bentley Systems, Incorporated
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The Managed Environment
Module Overview

This module discusses a managed environment in which documents can be 
shared among team members.

Module Prerequisites
• Knowledge of the Windows operating system

Module Objectives

After completing this module, you will be able to:

• Understand the concept of the ProjectWise managed environment

Document Concepts and Creation Methods

When a file is uploaded from a file system into ProjectWise, it becomes a 
“document”. The ProjectWise definition for a document is, essentially, a record in 
the database. Documents contain metadata about the file, such as document 
description, associated application, document status, the date the file was 
imported, and custom attributes. The files themselves are stored on a file server, 
whereas document metadata is stored in the ProjectWise database.

The database record may or may not be associated with an actual file, so you can 
create something called a placeholder document. This is simply a container of 
metadata with no electronic file attached. Placeholder documents can be used to 
Aug-12 10 The Managed Environment
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Document Concepts and Creation Methods
represent electronic files you are planning to import into ProjectWise, or hard 
copy documents or drawings that remain in a file cabinet.

This concept is unique to the managed environment and is extremely powerful 
when managing documents with ProjectWise. You never need to know where the 
file is physically located. In fact, you do not have direct access to a file. It can only 
be accessed through ProjectWise using the security assigned in the datasource.

When you create a document its name and file name are often the same, but the 
property fields are independent of each other so you can give a document a 
different name than its attached file. A cryptic file name can actually have a 
descriptive name.

New for (SELECTseries 4):

You can lock the document name and file name properties together, so that 
whatever you set for the document name is automatically set for the file name. 
This can make naming and renaming documents and their attached files easier as 
you move forward.
The Managed Environment 11 Aug-12
Copyright © 2012 Bentley Systems, Incorporated
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Document Access
Document Access

Documents are generally passed from their creator to the necessary members of 
a team during the life of a project. This involves making copies of the original 
document and giving a copy to each of the team members.

This creates many individual copies of the same document, which increases the 
potential for inconsistency. Someone must keep track of the file that contains the 
most up to date information and coordinate all changes.

Using ProjectWise, documents exist in a managed environment. During projects, a 
single instance of a document is available to members of the project team.

The document is stored in a location accessible to all team members. It can be 
viewed by all members, but it can be checked out for use by one team member at 
any time. 
Aug-12 12 The Managed Environment
Copyright © 2012 Bentley Systems, Incorporated
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Document Access
Check out and check in

When a team member wants to edit a document, they can check it out. Checking 
out a document downloads a copy of the document to your working directory. 
When you perform a check out the database record for the document is marked 
accordingly.

When another team member needs access to the file, or when all work is 
completed, the document is checked in. A team member can always refresh the 
server’s copy using tools in ProjectWise Explorer or an integrated application so 
that other team members can view or reference the latest version.

Controlled access

ProjectWise is a controlled access system. Project team members are assigned 
rights to various documents and these rights can change at various stages 
throughout the project.

There are five broad levels of access when using the ProjectWise Explorer client.

• No access: The folder structure or documents will not be seen.

• Viewing access: The folder structure or document file names and properties 
can be seen in ProjectWise, but document content cannot be viewed.

• Read access: A document may be opened read-only. No changes can be made 
to the document.

• Commenting or redlining access: A document can be opened read-only. 
Comments can be made about the document, but no changes can be made to 
the content.

• Editing access: A document can be opened and edited.
The Managed Environment  13 Aug-12
Copyright © 2012 Bentley Systems, Incorporated
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Document Access
User settings and access controls are an administrative function of ProjectWise. 
The administrator defines these settings in advance.

Workflow and life cycle

Your rights to a document may change as the document passes through the 
various stages that are the life cycle of the project. In ProjectWise, this concept is 
known as a workflow. 

An administrator defines workflows appropriate for a project. The workflow can 
be as detailed or as simple as the project requires. Workflows consist of a number 
of states, such as Draft, Pending Approval, Approved and Obsolete. Access 
controls are typically implemented on each state to ensure that project 
participants have access to documents at appropriate states in the workflow. They 
are two directional. Documents can move forward and backward.

Example states in a document life cycle:

• Draft: A document has been created, but it is not complete. Most edits are 
done in this state.

• Pending Approval: A document is available for review. Most redlining is done 
in this state.

If there are modifications to be made, the document’s state is changed back 
to Draft.

• Approved: A document has been approved and is available for distribution. 
This state is typically read-only.

• Obsolete: A document is no longer valid, but is kept for reference. This state is 
typically read-only.

Document versions

ProjectWise handles the document life cycle by having a single document with as 
many versions as required. All previous versions are locked as read only, and the 
current version is the only version that can be edited.

New for (SELECTseries 4):

The Version field in the New Document Version dialog is editable, allowing you to 
change the current active version’s label when you are creating a new version.
Aug-12  14 The Managed Environment
Copyright © 2012 Bentley Systems, Incorporated
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Integrated Applications
Integrated Applications

ProjectWise can track documents in any file format and can track abstract 
documents. Abstract documents are documents that do not have an associated 
electronic file, such as paper drawings.

Although MicroStation design files and Microsoft Office files are common, 
ProjectWise will track any other type of file and can display many without the 
native application installed. 

Once the correct connections between software applications and ProjectWise are 
configured, double clicking on a document of a specified type will automatically 
activate the linked application.

Information Structure

ProjectWise Explorer is the primary interface for the document repository. This 
interface is similar to the Windows Explorer, and provides a hierarchical view of 
the file system.

Folders and projects

In ProjectWise Explorer, documents are associated with individual folders or 
projects in a datasource.

In its simplest form, each datasource represents a working area. When 
ProjectWise is launched, the available working areas, or datasources, will be listed 
in ProjectWise Explorer’s datasource list, which is on the left side of the 
application window. Each datasource is associated with a separate database and 
one or more storage locations.

Two datasources are visible
The Managed Environment  15 Aug-12
Copyright © 2012 Bentley Systems, Incorporated
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Information Structure
A key difference between ProjectWise and Windows folders is that ProjectWise 
folders and sub-folders are records in the ProjectWise database, not an actual 
directory structure. Projects are folders that have added intelligence.

The Building and Civil projects and Civil sub-folders

Sub-folders are not required, but just as in the Windows operating system, the 
best browsing performance results when each folder further describes the 
documents and sub-folders that it contains. Each folder contains a relatively 
limited number of documents.

Any document to which you have access can be located by browsing the 
document hierarchy or by using a query based on a variety of search criteria.

Results of a search for Acrobat PDF documents

Editing

Once the desired document is located, you can edit it without knowing its exact 
location in the ProjectWise hierarchy or the actual storage area. The document 
may actually reside on a server on a different continent.

Hint: When you perform a check out, documents go to a folder in your working 
directory. When you perform an Export, you can select a destination folder for 
documents.

Attributes

Because ProjectWise is a database system, it is able to store information, or 
attributes, for each document. There are standard or built-in attributes, which are 
stored by default such as document name, filename, document creator, file 
Aug-12 16 The Managed Environment
Copyright © 2012 Bentley Systems, Incorporated
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Module Assessment
creator, last update time or version. ProjectWise can track file properties defined 
at the operating system level, and even index common files types and CAD files 
for full text search if configured by the ProjectWise administrator.

It can track information defined in advance by the ProjectWise administrator. This 
is information such as a project number, project specific information, paper 
document location or the even the organization receiving exported files. 

Document Audit Trail

Document audit trail provides you with a list of all activities that have taken place 
for the selected document. Your administrator enables or disables this feature 
and determines the type of information that will be tracked. They also determine 
whether you have permission to see the audit trail.

An audit trail record is created as an action takes place. You can view a 
document's audit trail report by selecting the Audit Trail tab in a document’s 
properties dialog. You can customize the report, print it, or save it to a file.

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. 
Assessment is used to determine what an individual knows or can do. 

Complete the assessment to see what you have gained from reviewing this 
module.

Managed Environment Assessment
The Managed Environment 17 Aug-12
Copyright © 2012 Bentley Systems, Incorporated
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The Integrated Environment
Module Overview

When an application is integrated with ProjectWise, you can search for, open, 
check out and check in documents directly from the application. You open the 
integrated application directly from the desktop and log in to a datasource. 
Integration is accomplished using iDesktop integration, which is part of the 
ProjectWise Explorer client installation.

Module Prerequisites
• Familiarity with opening, creating, and editing files in MicroStation

• Familiarity with MicroStation tools and procedures

• Familiarity with MicroStation view controls

• Knowledge about MicroStation reference files

• Some knowledge about MicroStation cells

• Some knowledge about MicroStation tags

Module Objectives

After completing this module, you will be able to:

• Work with integrated MicroStation

• Work with integrated Microsoft Office applications

• Work with integrated Microsoft Outlook
Aug-12 18 The Integrated Environment
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Module Glossary
Module Glossary

Access control: The method for controlling which users have access to documents 
and folders.

Attribute: A custom supplemental property for a document. You enter the values 
for a document's custom properties on the Attributes and More Attributes tabs of 
the document’s properties dialog.

Audit trail: The mechanism for recording document and folder activity in the 
datasource. The items tracked by an audit trail are specified in ProjectWise 
Administrator. The audit trail itself is viewed in ProjectWise Explorer.

Check in: To upload your modified document.

Check out: To lock a document and download a copy of it to your working 
directory. No other user can check out or edit the document until you complete 
your work and check it back in.

Copy out: To download a copy of a document into your working directory without 
checking out the document.

Environment: An environment is a collection of custom supplemental document 
properties established by a ProjectWise administrator. They apply to folders and 
projects. Once applied, the documents therein inherit the attributes of that 
environment, and can be seen in the document’s properties dialog. Environments 
are optional in a datasource and are not required for your folders and projects.

Export: To check out a document and download it to a folder outside of your 
working directory, and therefore outside of ProjectWise. The document can then 
be used by those not using ProjectWise. Exporting a document locks the 
document so that no other user can check out and edit it until you import it back 
into ProjectWise or free it.

Free: To remove a lock on a document. Freeing a document undoes a check out or 
export. This is a good option when you have opened a document, or checked it 
out, but have made no changes.

Local copy: A copy of a document that has been downloaded from the server, 
whether by check out, copy out, or export.

Logical set: A DGN document that has other documents referenced into 
it.
The Integrated Environment 19 Aug-12
Copyright © 2012 Bentley Systems, Incorporated



DO
 N

O
T 

DI
ST

RI
BU

TE
 - 

Pr
in

tin
g 

fo
r S

tu
de

nt
 U

se
 is

 P
er

m
itt

ed
   

   
Co

m
pa

ny
: G

eo
rg

ia
 D

O
T 

   
  C

la
ss

 D
at

e:
 1

7-
Ju

l-2
01

3

Introductory Knowledge
ProjectWise Explorer: The main client interface for ProjectWise, from which you 
can check out, open, modify, and otherwise manage ProjectWise documents, 
folders, and projects.

Update server copy: To replace the server copy of a document with your modified 
local copy of the document without changing the document's checked out status 
on the server.

Introductory Knowledge

Before you begin this module, let's define what you already know.

Questions

1 How do you attach a reference file (or Xref)?

2 How do you manipulate references once they are attached?

3 What is a nested reference attachment?

4 What is a tag (or attribute)?

5 What is a cell (or block)? A cell library (block definition table)?

6 What is a model (or modelspace/paperspace)?

Answers

1 Open the References dialog (or EXTERNALREFERENCES) and select File > 
Attach (or XATTACH).

2 Use the tools in the References dialog, or the References toolbox to move, 
copy, clip etc. (or Refedit tools).

3 You can see the contents of files that are attached to other references. 
Changes to reference attachments in designs that are referenced to other 
designs are reflected the next time either the active model's views are 
updated or the file is reopened.

4 Non-graphical attributes that may be attached to elements drawn in 
designs.

5  A cell is a complex element composed of a group of primitive or other 
complex elements that is stored in a cell library for repeated placement. 
Aug-12 20 The Integrated Environment
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Supported Applications
They are stored in library files (.cel) or in DGN libraries (.dgnlib) (or an 
invisible data area called the block definition table).

6 An independent container within a file that stores graphical information 
and specific settings.

Supported Applications

The ProjectWise readme lists the primary applications and versions known to be 
supported with ProjectWise V8i at the time of release.
The Integrated Environment 21 Aug-12
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Logging in to Integrated Applications
Logging in to Integrated Applications

When opening integrated applications from the desktop, you select the 
datasource to which to log in from the Log in dialog. Then you enter your user 
name and password. This can be a logical account, which is a ProjectWise user 
account created for logging in to a ProjectWise datasource and used only for that 
purpose, or it can be a Windows-based account.

If the option is there, you can enable “Use Windows Single Sign-On for 
authentication”, which lets you use your Windows user credentials to log in to 
ProjectWise. This option displays only if an administrator enabled single sign on 
for the datasource. Using this option disables the User Name and Password fields. 
When you click the Log in button, ProjectWise attempts to log you in to the 
datasource using the same Windows user name and password that you used to 
log in to the operating system. 

If you want to automatically log in to the same datasource using the same user 
name and password the next time you open an application from the desktop, 
enable “Auto-login to this datasource the next time I work with this application”. 

Changing the log in preference

If you have permission to do so, you can change your auto-login settings for an 
integrated application.

 How to change your auto-login settings:

First, open the ProjectWise V8i Network Configuration Settings dialog by 
selecting Tools > Network Configuration Settings in ProjectWise Explorer. 
Select the iDesktop Auto-Login tab. Then, select the integrated application for 
which you want to change the auto-login settings and click Modify. 

• Use the “Use computer setting” or “Do not login automatically” options to 
force a manual log in. 

• Use “Auto-login to datasource” and “Use Single Sign-On” to take advantage of 
those options. 
Aug-12 22 The Integrated Environment
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Integrated MicroStation
When you are done, click OK, and then Apply.

Integrated MicroStation

When launching integrated MicroStation from the desktop or Windows Start 
menu the ProjectWise Log in dialog opens first.

 Exercise: Launch MicroStation and log in to the integrated environment

1 Double click the MicroStation icon on the desktop, or launch MicroStation 
from the Start menu.

2 Select the class datasource from the datasource list.

3 Supply your user name and password. 

For example, student01/student01, or student02/student02. The 
instructor will provide your login name and password.

4 Enable “The Auto-login to this datasource the next time I work with this 
application” and click Log in.

You see a message that indicates that you will be saving your credentials 
on the computer. 

5 Click Yes.

If you want to auto-login, ProjectWise needs to store your login credentials for 
later reuse. ProjectWise takes the login credentials, encrypts them and stores the 
encrypted values in the Windows registry. This means that only the user that is 
logged in will be able to use the saved credentials to auto-login, and all other 
users can’t see what the saved credentials are. ProjectWise shows a warning 
dialog to remind them that they are storing encrypted passwords on the system.
The Integrated Environment  23 Aug-12
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Integrated MicroStation
Integrated dialogs

In integrated MicroStation, the file open dialogs are replaced by ProjectWise 
dialogs, enabling you to check out and open documents from inside MicroStation. 
The dialogs show you the datasource location of the file, its description, and file 
name. 

Use the Application list to limit the available files to those of the selected 
application and the extension list to filter by extension.

Choosing to see only MicroStation files listed

Searching using integrated dialogs

The Quick Search bar in the File Open, Select Document, and Open dialogs lets 
you perform quick searches for documents, folders, and projects. The search 
returns all documents, folders and projects that match the entered text. Searches 
run from the Quick Search bar are not case sensitive.

 How to use quick searches:

First, enter the criteria by which you want to search and click the Start Search 
arrow at the right of the Search field. The Quick Search bar supports wildcards 
(*) and the use of AND, OR, and NOT.

Searching for files containing the string AE9
Aug-12  24 The Integrated Environment
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Integrated MicroStation
Then, click the downward arrow next to the magnifying glass to change the 
type of search.

- Select All Content to search document names, descriptions, file names and 
extensions, the text inside documents, folder and project names and 
descriptions, custom project properties and environment attributes. An 
environment is a collection of custom supplemental document properties that 
an administrator establishes. Once specified for documents, you can search on 
them.

- Select Full Text Search to search for the same criteria as All Content, 
excluding environment attributes.

- Select Document and Folder Properties to search for the same criteria as All 
Content, excluding the text inside documents, environment attributes, or 
custom project properties.

Integrated commands

Several commands on the File menu are integrated with ProjectWise.

 Exercise: navigate to the project and open a file

1 In the File Open dialog, navigate to the folder with the latest version of the 
MicroStation example files to see the example projects.

The instructor will provide the exact location.

Delivered example projects

2 Double click the Building project.
The Integrated Environment 25 Aug-12
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Integrated MicroStation
3 Double click the \seed folder, select sheetseed-##.dgn, where ## 
corresponds to your student identification, and click Open.

The file is now checked out to you.

When other team members navigate to this folder they will see a lock icon 
preceding the file name.

Note: Once you have opened a DGN document, that document is added to the 
Address bar in ProjectWise’s Select Document dialogs for quick access in the 
future.

File > Update Server Copy

Use this command to update the server copy of a file that is stored in the 
ProjectWise storage area without checking the file in. Using this command, the 
file is still checked out to you, but others will be able to see the changes you have 
made if they open the file read-only or attach it as a reference.

File > Refresh Local Copy

If another user checks in a document that you have copied out, you can update 
your local copy with the newer server copy by using Document > Refresh Local 
Copy.

File > Save As

When you create documents in ProjectWise, you can use a wizard to help you 
define its properties or you can create documents without using the wizard.
Aug-12 26 The Integrated Environment
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Integrated MicroStation
When you select File > Save As the Select a Wizard dialog will appear if no 
Document Creation wizard is yet set as the default. 

These options specify how you want to create a new document.

If you click the No Wizard icon, no document creation wizard will be used when 
you create a new document. Selecting No Wizard here ensures that, if you 
attempt to create a new document in an integrated application, the application 
will open whatever ProjectWise dialog it normally uses to create new ProjectWise 
documents.

If you click the Advanced Wizard icon, the Advanced Document Creation Wizard 
presents the steps. You will store a document record in the ProjectWise database 
as well as saving the file in MicroStation. You can change the document name and 
description, or the file name, as well as assigning other attributes or changing the 
application used to open the file.

 Exercise: Save a DGN to another folder

1 In MicroStation, select File > Save As from the main menu bar.

2 Click No Wizard and click OK.

You will create a document without using a wizard to guide you through 
the process. The Advanced Wizard is discussed in the ProjectWise Explorer 
module.

3 In the Save Document As dialog, click Select.

4 Select the Building project’s \out folder and click OK.

5 Add the following in the Save Document As dialog:

Name: <your name>seed.dgn

Description: <your name>seed

File Name: <your name>seed.dgn
The Integrated Environment 27 Aug-12
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Integrated MicroStation
Department: Proposals - Proposals

6 Click Save.

In the Check In dialog you see the check mark indicating that, when you 
opened the DGN file in integrated MicroStation, the file was checked out 
to you.

7 Click Check In.

You are checking in the first file you opened, sheetseed-##.dgn, from the 
\Seed folder. The copy you made using Save As is still open.

Attaching ProjectWise documents as references

Using the References dialog you can attach DGN documents stored in 
ProjectWise to the open document. You can also attach ESRI shapefiles. Similarly, 
you can attach raster image documents stored in ProjectWise using the Raster 
Manager.

In ProjectWise, this is referred to as creating a logical set. Once the attachment is 
made, ProjectWise stores the reference information in the ProjectWise database, 
as well as inside the master DGN file. This lets you perform searches in 
ProjectWise Explorer that look for all of the master documents to which a 
particular reference is attached.

 Exercise: Attach a file managed by ProjectWise as a reference

1 Continuing in <your name>seed.dgn, select File > References to open the 
References dialog.

2 in the References dialog, click Attach Reference.

The ProjectWise Attach Reference dialog appears.

3 Open the Building project’s \Dgn folder.

4 Select BSI300AE101-Plan.dgn, click Add, and then click OK.
Aug-12 28 The Integrated Environment
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Integrated MicroStation
You now attach the file using normal MicroStation procedures. Note the 
attachment settings.

5 Set the following in the Reference Attachment Settings dialog:

Model: Ground Floor Plan

Detail Scale: 1:100

Nested Attachments: Live Nesting     Depth: 2

6 Click OK.

7 Fit View.

Best Practice: To detach references from a logical set, use MicroStation’s 
References dialog so that MicroStation is aware of the transaction.

Checking out references

When you open a file with references, the references are copied out by default. If 
you want to edit those files, they must be checked out. There is an option in the 
Select Reference Documents dialog that lets you check the files out.

References and versions     

In ProjectWise you can create many versions of a document. The latest version is 
the only one that’s active, the others are read-only. However, you may want to 
view information from another version as a reference. 

(New for SELECTseries 4)

You can update a master document to use a different version of the same 
reference document. The version that you choose will be copied out when the 
master document is opened and used instead of the active version. This version of 
the reference will be used by the master document until you select another 
version to lock to the master document.
The Integrated Environment 29 Aug-12
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Integrated MicroStation
Reference exchange

Use this option to switch into a referenced model.

 Exercise: Exchange to a reference file, checking it out

1 Continuing in <your name>seed.dgn, in the References dialog, right click 
on the reference BSI300AE101-Plan.dgn, and select Exchange.

Exchange opens the reference file and closes the file you were in. You are 
prompted to check the file out. If you click No, the file will open, but it will 
be read-only. 

2 Click Yes.

3 Check in <your name>seed.dgn and the referenced file opens.

Missing references

 Exercise: Reference documents

1 Continuing in BSI300AE101-Plan.dgn, you can see that there are 
referenced files. 

If this information is red for any file, it means that the file cannot be 
located.

This can be resolved two ways. You could run the delivered reference 
scanning utility, which will search ProjectWise and resolve missing 
references automatically. This is discussed in the ProjectWise Explorer 
module. You can also resolve the problem manually. For a single file, you 
will most likely resolve the problem manually.

2 In the References dialog, right click a missing reference and select Settings 
from the pop-up menu. 

The full path to a file is listed at the top of the dialog. It indicates that it 
cannot be found.

3 Click the Browse button at the top of the dialog. 

4 In the Reattach Reference dialog, navigate to the location of the missing 
file, select it, and then click Open.

BSI300G-0-Border.dgn is in the Building project \seed folder. 

5 In the Attachment Settings dialog, click OK.

Attachment settings will be the same as for the originally attached 
reference. Once the correct file is identified, the problem is resolved.
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Integrated MicroStation
Note: If the reference has a file referenced to it, the Select Reference 
Documents dialog appears so you can choose to locate all references. 
Live nesting is respected. 

6 Click Previous Model in the View Groups dialog at the bottom left of the 
application window to return to <your name>seed.dgn, checking that file 
out and checking BSI300AE101-Plan.dgn in.

In place reference activation

In place reference activation lets you make edits to a reference without leaving 
the file you are in; the master file. The master file is not checked in; you retain a 
check out on the file. Activating a reference checks it out. 

To use this, open a master file with references from ProjectWise. Right click on an 
element that is in the reference you want to activate, or right click the file name in 
the References dialog, and select Activate. 

Once a reference is activated, the position of the graphics on the screen don’t 
change. The graphics that are not part of the activated reference turn grey so you 
can see the editable elements. There is also a mark in the Activate column in the 
References dialog. If you mouse over the check mark you will see that the file is 
write locked. In ProjectWise Explorer, you can see that both files are still checked 
out.

Use Deactivate, on the References dialog’s right click menu to return focus to the 
master file. Deactivating the reference does not check the document back in. It 
remains checked out, but it is editable. The reason that deactivate does not 
automatically release the lock is that once the lock is relinquished, it is not 
possible to undo changes. If you are actively working on 3 files, moving from one 
to another using activation, it makes sense to hold the locks until you decide you 
are ready to release them. 

To check in an activated reference, check it in when you exit the master file. An 
Alert indicates that you will no longer be able to make changes. When the Check 
In dialog appears, click Check In.

If you right click on an activated file in ProjectWise Explorer and select Check In, 
an Alert indicates that the file is already open any further modifications you make 
from MicroStation will be lost. Use one of the other methods to release the lock.
The Integrated Environment 31 Aug-12
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Integrated MicroStation
Important: References that have been activated are not available for editing in 
another session. This also applies to references that have been deactivated. To 
make a reference available for editing in another session, you must release the 
lock on it. If you use activation, remember to release the locks in the References 
dialog or by checking in all documents when you exit the master file.

Modifying reference properties

You modify reference properties the same way you do when using MicroStation 
without ProjectWise.

 Exercise: Modifying reference properties

1 Continuing in <your name>seed.dgn, in the References dialog, click the 
Show hierarchy icon.

2 Expand <your name>seed.dgn by clicking the +, and then expand 
BSI300AE101-Plan.dgn.

The attached models are listed. The file PlanClip is expandable, indicating 
second depth nesting.

3 Right click on BSI300AE101-Plan.dgn in the right frame of the References 
dialog and select Settings from the pop-up menu.

4 In the Attachment Settings dialog, change Nested Attachments to a Depth 
of 1 and click OK.

The files at second depth nesting disappear.

5 Leave the References dialog open.

6 Select File > Save Settings.

Attaching shapefiles

ESRI shapefiles can be attached as vector references in integrated MicroStation 
V8i. When you are in integrated MicroStation and you attach a shapefile to a 
DGN, ProjectWise creates two sets of files when you check in the master DGN. 

• One set describes the relationship between the master DGN and the attached 
shapefile.

• One set describes the relationship between the shapefile and its own related 
files. 

Also, when you attach a raster file to a DGN, and that raster file has its own 
related files, ProjectWise again creates two sets on check in of the master DGN. 
Aug-12 32 The Integrated Environment
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Integrated MicroStation
There is one for the relationship between the master DGN and the attached raster 
file, and one for the relationship between the raster file and its own related files.

Design History

MicroStation design history lets you track what has been changed in a file. 
Changes are tracked, and periodically you commit them. This saves the changes 
into a history log and lets you view what has changed in the file over time.

When you open a file that has uncommitted changes in it you are asked to take 
ownership of those changes. If you refuse, the file is opened read-only.

Make and record changes in the integrated environment using normal 
MicroStation procedures.

 Exercise: Open a file and view changes

1 Continuing in <your name>seed.dgn, select Utilities > Design History > 
Initialize, type Initialized DH in the Initialize History dialog, and click OK.

The status bar icon indicates that the Design History has been initialized 
for the file you created. 

2 Select Tools > Tool Boxes > Design History to open the Design History 
toolbox.

3 Select Show design history.

Show Revisions in Reference Files is enabled in the Design History dialog, 
so you can see the revisions that have occurred in the reference you 
attached, BSI300AE101-Plan.dgn.

4 Right click on BSI300AE101-Plan.dgn in the right frame of the References 
dialog and select Settings from the pop-up menu.

5 In the Attachment Settings dialog, change Nested Attachments to a Depth 
of 2 and click OK.

The files at second depth nesting reappear.

6 Click the Commit Changes tool in the Design History toolbox and type:

Changed nest depth

7 Click OK.

This revision is added.

8 Select File > Close, checking the documents in.
The Integrated Environment  33 Aug-12
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Integrated MicroStation
Now the lock is removed from BSI300AE101-Plan.dgn.

9 Note the icon preceding the file name in the Select Document dialog.

The icon shows a sheet of paper indicating that the file has references; it is 
a set.

ProjectWise-managed cell libraries

You can attach a cell library from ProjectWise using its’ Attach Cell Library dialog 
and normal MicroStation procedures. 

When you select File > Attach, or Attach folder, in the Cell Library dialog, the 
ProjectWise Attach Cell Library dialog appears. When you attach a cell library 
through ProjectWise, the cell library is always read-only.

To attach a cell library that is not ProjectWise-managed, meaning directly from 
MicroStation, click Cancel in the ProjectWise Attach Cell Library dialog. The 
MicroStation Attach Cell Library dialog will appear.

Creating ProjectWise-managed cell libraries

You can create a ProjectWise-managed cell library directly in MicroStation.

 How to create a ProjectWise-managed cell library:

First, in the MicroStation (Element > Cells) Cell Library dialog, select File > 
New. The Select a Wizard dialog will appear if no Document Creation wizard is 
set as the default. This is the same as creating any other new ProjectWise 
document. 

If you select No Wizard, the ProjectWise Create Cell Library dialog appears. 
Otherwise, you must enter the necessary data in the Advanced Wizard and 
then the Create Cell Library dialog will appear. Then, select the folder in which 
you want to store the library. Supply a name, description and file name, and 
then click Save.
Aug-12  34 The Integrated Environment
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Integrated MicroStation
Title Block integration

Title block integration allows ProjectWise to populate title block information in 
MicroStation. Once the administrator has set up title block integration, tag 
elements contained within files are automatically populated with data from the 
DGN file or from within ProjectWise.

Updating ProjectWise attributes from MicroStation

You may have information in an existing title block that you want to use to update 
the ProjectWise database, rather than updating the title block from the 
ProjectWise database.

 Exercise: Update an attribute from MicroStation

1 In the Select Document dialog, move up one level, and then open the 
\Dgn folder.

2 Open BSI300AE101-Plan.dgn.

A message in the status bar informs you that title blocks were updated 
successfully.

3 Use the view controls to zoom in on the border’s title block.

4 Select the Edit Tags tool from the Tasks dialog.

5 Click on the text AE101 in the Rev. box.

6 In the Edit Tags dialog, click in the Value column for the DRG. NO. tag and 
change it to AE101-1.

7 Click OK.

8 Select Utilities > Key-in.

9 Type the following in the Key-in browser:
The Integrated Environment39  35 Aug-12
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Integrated MicroStation
titleblock updatedms

10 Press Enter.

A message in the status bar informs you that the update is successful.

11 Select File > Save Settings.

12 Exit MicroStation, checking the document in.

Note: There is more on this feature in the ProjectWise Explorer Client module.

Titleblock key-ins

TITLEBLOCK PLACE is used to place the cell that contains the attribute tag set in 
the DGN. When the cell is placed, the attribute values are automatically updated 
with the current values from the ProjectWise database.

TITLEBLOCK MODIFY opens the ProjectWise Document Properties dialog for the 
open document. Attribute values edited through the Document Properties dialog 
are saved directly to the ProjectWise database and appear in the active model 
when you click Save on the dialog.

TITLEBLOCK UPDATEDMS is used to save title block attribute values edited from 
the active model to the ProjectWise database, after editing the values using 
MicroStation's Edit Tags tool.

TITLEBLOCK UPDATENOW is used to refresh the active model to show the current 
title block attribute values in the ProjectWise database. TITLEBLOCK UPDATENOW 
is useful when you have open a master DGN with references, and another user 
updates the attribute values in any of those references.

Printing

• In integrated MicroStation, you can select File > Print and use MicroStation’s 
printing system to print files.

• If you use InterPlot Utilities, there are two additions to MicroStation’s File 
menu; IPLOT and Print Organizer. 

Select Print Organizer to open that utility for printing and reprinting sets of 
models stored in a print set (.pset) file. A print set is a collection of print 
definitions and folders. After composing a print set, you can print the set or 
publish the prints to a PDF document. 
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Integrated ProjectWise Navigator
The IPLOT item opens the IPLOT dialog, which lets you submit prints from 
within MicroStation. You can publish prints to a PDF document or add them to 
an Organizer Plot Set (.ips) file. 

• You can also run .PSET print jobs from the Batch Print menu in ProjectWise 
Explorer.

Integrated ProjectWise Navigator

When launching integrated ProjectWise Navigator from the desktop or Windows 
Start menu, the ProjectWise Log in dialog opens first. Within integrated 
ProjectWise Navigator, you use the ProjectWise File Open dialog to open files 
from the datasource and, when you save, you see the ProjectWise Save As dialog 
so you can save back into the datasource.

When you launch ProjectWise Navigator from the desktop, integration with 
ProjectWise Explorer is turned off by default. To turn on desktop integration, your 
administrator must modify the PW.CFG file delivered with ProjectWise Navigator.

When ProjectWise Navigator is integrated with ProjectWise you can use it to 
markup DGN documents stored in a datasource. When you markup a 
DGN document, ProjectWise Navigator creates an overlay document to 
contain the markup.

Marking up documents with ProjectWise Navigator

When you markup a document, the mark up is stored in a new document, called 
the overlay document. This lets you add comments without altering the original 
document content. Once you create an overlay document, the original document 
is referred to as the reviewed document.

To markup a DGN document, select the document and then select 
Document > Markup. This downloads a copy of the document to your working 
directory. At the same time, ProjectWise Navigator creates a copy of this 
document in a temporary local folder that is outside your working directory. It is 
given the extension .overlay.dgn. 

The new overlay document is opened in ProjectWise Navigator, and the reviewed 
document is attached as a reference to the overlay document. (You can verify this 
by opening the References dialog in ProjectWise Navigator.) Note that when the 
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Integrated ProjectWise Navigator
overlay document first opens in ProjectWise Navigator, it is not yet stored in 
ProjectWise, it only exists in the temporary local folder. To save it to ProjectWise, 
you need to select File > Save or File > Save As in ProjectWise Navigator.

 Exercise: Markup a DGN document

If ProjectWise Navigator is installed and integrated on your system, you 
can complete the following exercise.

1 In ProjectWise Explorer, click BSI400-W01-Contours.dgn in the Civil 
project’s \Dgn folder.

2 Select Document > Markup.

A new overlay document is created for the selected document and is 
opened in ProjectWise Navigator. The reviewed document is attached as a 
reference to the overlay document so you can see the content.

3 Click the Create Markup task.

4 In the tool settings, add the Description Color change and assign it to 
drafter1.

5 Enter a data point in the file.

6 From the Redline task, click Place Text.

7 Type the following:

Change color of contours on level Plan Prop Contour Minor to 2

8 Place the text in the file and reset.

9 Select File > Save to save the new overlay document.

If the Save Document As dialog opens, change any information as 
necessary, then click Save. 
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Integrated ProjectWise Navigator
If the Advanced Document Creation wizard opens, follow the steps in the 
wizard to completion.

10 Exit ProjectWise Navigator and click Check In when the Check In dialog 
opens.

By default, the overlay document will be stored in the same folder as the 
reviewed document, and the document name and file name for the overlay 
document are the same as that of the reviewed document, except that the 
overlay document name and file name now both have the extension .overlay.dgn.

Note: There is an option on ProjectWise Explorer’s right click menu, Set > Show 
Markups that works the same as the Set > Show References command.

To save the new overlay document to a location outside of ProjectWise, select File 
> Save As, then click Cancel in whichever ProjectWise dialog opens, or press the 
<Esc> key on the keyboard. This returns you to ProjectWise Navigator’s Save As 
dialog.

Related document markups

You can create multiple overlay documents from the same reviewed document if 
necessary. To do this, you can either select File > Save As again while the overlay 
document is still open in ProjectWise Navigator, or if you are back in ProjectWise 
Explorer, you can select the reviewed document again and select Document > 
Markup.

You can search for and find all the overlay documents that were created from a 
single reviewed document.

 How to find overlays created from the same document:

First, select a reviewed DGN document in ProjectWise Explorer, and 
select Document > Set > Show Markups. 

A window opens listing all the overlay documents that exist for the selected 
DGN document.

If the selected DGN document does not have any overlay documents, 
a message appears stating “No Documents Found.” 
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Integrated i-model Composer
You can also find the reviewed document from which a particular overlay 
document was created.

 How to find a reviewed document:

First, select an overlay document and select Document > Set > Show 
References. A window opens displaying the selected overlay document. Below 
it, you see the reviewed DGN document. To see details, select View > 
Details.

Integrated i-model Composer

An i-model is a format used for project information exchange, such as when 
project information needs to be reviewed at a milestone. An i-model is a copy 
meant for information exchange. It is not the source content that users create and 
modify. 

An i-model is read-only and is always saved with an .i.dgn extension. It converts 
information to a simpler representation, with smaller file size and easy navigation. 
No matter what format the input data is in, the i-model unifies it in a simple form. 
The process of converting the .DGN file into an I.DGN file is called 
publishing. It publishes the master file and each of its (displayed) references, 
resulting in a corresponding i.dgn file for each.

All design files that can be opened in MicroStation can be published to an i-model. 
You can also combine several published i.dgn files into a single, protected file. 

When launching integrated i-model Composer from the desktop or Windows 
Start menu, the ProjectWise Log in dialog opens first. Within integrated i-model 
Composer, you use the ProjectWise File Open dialog to open files form the 
datasource and, when you save, you see the ProjectWise Save As dialog so you 
can save back into the datasource.

The ProjectWise Browser utility in ProjectWise i-model Composer lets you browse 
and review the documents and component data managed in a ProjectWise 
repository. You browse and review from within ProjectWise i-model Composer. 
Before you can use the utility, an administrator must configure it to work with 
ProjectWise.
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Integrated i-model Composer
 Exercise: Create an i-model

If i-model Composer is installed and configured on your system, you can 
complete the following exercise.

1 Note the icon preceding the file BSI300AE301-Sections.dgn in the Building 
project’s \Dgn folder.

It is a logical set, meaning that it has references attached.

2 Double click it to open it in MicroStation, copying the references out.

3 Open the References dialog and note the attached .dgn references.

4 Exit MicroStation, freeing the file.

5 Launch i-model Composer from the desktop, logging in to the class 
datasource.

6 Navigate to \Building\Dgn\BSI300AE301-Sections.dgn in the File Open 
dialog and click Open.

7 Make sure all references are selected, and then click OK in the Select 
Reference Documents dialog.

8 Select File > Publish i-model and just click OK to create the i-model.

Note the message Center. The references are being stored in your working 
directory. The .i.dgn will be placed in the same folder as the original file in 
ProjectWise.

9 When you see the message in the Message Center stating that it has 
finished building a ProjectWise logical set, exit i-model Composer.

10 Open BSI300AE301-Sections.dgn.i.dgn in MicroStation.

11 Open the References dialog and note the .i.dgn references.

Even though they are not in the ProjectWise folder, they are visible in the 
i-model file.

12 Exit MicroStation, freeing the file.
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Integrated Microsoft Office Applications
Integrated Microsoft Office Applications

Microsoft office applications can be integrated with ProjectWise. When they are, 
a ProjectWise menu is added to the application.

Logging in from the desktop

If automatic login is configured for integrated Microsoft Office applications and 
you launch one of those applications from the desktop, when you select (File >) 
New or (File >) Open you will be automatically logged in to the selected 
datasource using the specified user name and password. Once you are logged in, 
ProjectWise’s Open Document dialog opens.
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Integrated Microsoft Office Applications
If automatic login is not configured, when you select (File >) New or (File >) Open 
the ProjectWise Log in dialog appears.

As with other integrated applications, you can enable “Use Windows Single Sign-
On for authentication”, and “Auto-login to this datasource the next time I work 
with this application”. 

Working with documents

Once you have opened an Office document stored in ProjectWise, it is added to 
the Address bar in the Open Document dialog.

To browse for and open Office files that are not stored in ProjectWise, click the 
Open from Disk button. Even if you open a file that is not stored in ProjectWise, 
your Microsoft Office session remains integrated with ProjectWise. You can later 
save the document into ProjectWise using the (File >) Save As command.

Saving and creating documents

Selecting (File >) Save saves your changes to the current file location. For example, 
if the open document came from ProjectWise, selecting (File >) Save saves the 
changes to the file in your ProjectWise working directory. 

Changes are only saved to ProjectWise when you Check In or Update Server Copy 
of the document.

Selecting (File >) Save As lets you save the open document with a different name 
or to another location inside or outside of ProjectWise, or you can use it to save 
the open document into ProjectWise for the first time.

 How to save the open document under a different name or to another 
location:

First select (File >) Save. Any changes are saved locally. 

- If the open document is a ProjectWise document and you want to check it in, 
select (File >) Close, or (File >) Exit. 
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Integrated Microsoft Office Applications
- If the open document is not yet stored in ProjectWise but you would like it to 
be, select (File >) Save As. The Select a Wizard dialog will appear if no 
Document Creation wizard is set as the default. Then, select the Folder in 
which to store the document and provide the document information.

Closing and checking in from Microsoft Office

You must close a document open in any Office application to check it in. 

 How to close and check in:

First, if you have made any changes to the document, first select (File >) Save 
to save your changes locally. Then, select (File >) Close, or (File >) Exit to close 
the ProjectWise document. In the Check In dialog, enter any comments if 
required by your administrator, and click Check in.

If you select (File >) Close or (File >) Exit before (File >) Save, you will be prompted 
to save your changes locally first. If this happens, click Yes to save your changes 
locally. You must click Yes if you want your changes to be saved to ProjectWise.

Your administrator can configure simple or automatic check in for Office 
Applications.

• When simple check-in is enabled and you close a checked out document, the 
standard ProjectWise Check In dialog is replaced with a simple confirmation 
dialog that prompts you, “Check in closed document?” You can then click Yes 
or No.
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Integrated Microsoft Office Applications
• When automatic check-in is enabled and you close a checked out document, 
the document is automatically checked in without any prompting.

Inserting pictures

ProjectWise lets you insert an image stored in ProjectWise into another Office 
document stored in ProjectWise.

 How to insert a picture:

First, place the cursor at the point in the document where you want the image 
to be placed. Then, select ProjectWise > Insert > Picture.

In the Insert Picture dialog, select the image document from ProjectWise and 
click Open. The image is placed in the document. Note that this image is not 
linked to the original document, it is simply a copy of that image, and is now 
entirely an object of the Word document.

Linking documents

ProjectWise integration also supports the pasting of one Microsoft Office 
document into another as a link. You can open linked documents from their 
container documents by double clicking the document's link icon in the container 
document. When you open a container document from ProjectWise, its linked 
documents are copied out.

When linking documents you can use a local document, external to ProjectWise, 
as the linked document.

 How to link documents:

You must open the documents from inside ProjectWise Explorer client to do 
this. To do so, select Start menu > Programs > Bentley > ProjectWise V8i > 
ProjectWise Explorer, and open the two Office documents.

A link to Document B will be pasted into Document A. So, from Document B, 
copy some text to use as the link. This is the spot where the document will 
open when the link is clicked. Then, In Document A, place the cursor at the 
point where the link will reside and select Home > Paste Special.
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Integrated Microsoft Office Applications
In the Paste Special dialog, select Microsoft Word Document Object from the 
list, enable the Paste Link radio button and Display as icon, and click OK.

Note: If Display as icon is off, the copied text will display as the link in the 
container document. 

Save Document A and save and close Document B, but don’t check it in. To 
test the link, in Document A, double click the link icon. The linked document 
opens directly to the text you used to create the link.

Microsoft Outlook

You can save messages into ProjectWise. 

 How to save messages into ProjectWise:

In Microsoft Outlook 2007, select a message from the message list and select 
File > Save As, or open the message and select File > Save As. In Microsoft 
Outlook 2003 or earlier, select a message from the message list and select File 
> Save to ProjectWise, or open the message and select File > Save to 
ProjectWise.

The Select a Wizard dialog will appear if no Document Creation wizard is set as 
the default. Select the wizard your organization uses, entering the necessary 
data in the Advanced Wizard if used. In the Save Document As dialog, select 
the folder in which you want to store the message and provide the name, 
description and file name.

You can save Outlook messages to ProjectWise by dragging messages from 
Outlook and dropping them into the appropriate folder in ProjectWise Explorer.
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Integrated Microsoft Office Applications
Saving attachments to ProjectWise

You can save attachments to Outlook messages to ProjectWise by selecting a 
message with a file attached and then selecting File > Save Attachments > Save 
Attachments to ProjectWise, or by opening the message and selecting File > Save 
Attachments to ProjectWise.

Inserting images and documents

ProjectWise is integrated with Outlook’s Insert > Picture > From File command. 
This integration lets you insert an image stored in ProjectWise into the open 
message.

ProjectWise integration also supports the insertion of a ProjectWise document 
into the open message, using Insert > Object. Once the link is inserted, you can 
double click the link to open the document.

Inserting ProjectWise properties through attribute exchange

The attribute exchange feature of ProjectWise lets you insert ProjectWise 
properties as text fields inside your Microsoft Office Word and Excel documents. 
The text fields are linked to ProjectWise, so that if the value of the property 
changes in ProjectWise, the text field will be updated accordingly in the 
document. Likewise, you can update property values in ProjectWise by modifying 
the value of the property from the document itself.

Before you can use attribute exchange 

To use attribute exchange, your administrator first must set up Attribute Exchange 
Rules for Microsoft Office in ProjectWise Administrator. By default, Attribute 
Exchange Rules for Microsoft Office contain a set of custom properties, attributes, 
that you can insert into your Word and Excel documents. These custom properties 
all relate to ProjectWise properties of the document. For example, you can insert 
the Folder_Name property into your document, so that the current location of 
the document in ProjectWise is always displayed inside the document.
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Integrated Microsoft Office Applications
Initializing documents for attribute exchange 

Before you can insert a ProjectWise custom property into a document, you must 
initialize the document so that the ProjectWise custom properties defined in the 
delivered Attribute Exchange Rules template are available for insertion.

 How to initialize a Word or Excel document for attribute exchange:

Open a Word or Excel document stored in ProjectWise. On the ProjectWise 
tab, click Update Document. You can now insert any of the available custom 
properties into the document.

Inserting custom properties 

Inserting a ProjectWise custom property as a text field will insert the current 
value of the selected property into a document. If there is no current value, then 
the text field will be blank. For example, if you insert the Folder_Description 
property and the document's folder has no description. 

However, since that text field is linked to the Folder_Description property, once a 
value is defined for that property in ProjectWise, then the field will be updated in 
the document next time you click Update Document.

 How to insert a ProjectWise custom property into a Word document: 

In an open Word document that has been initialized, place the cursor at the 
point you would like to insert a ProjectWise custom property. On the Insert 
tab, select Quick Parts > Field. In the Field dialog, Field names list, select 
DocProperty. In the Property list, select the ProjectWise document property 
you want to insert. For example, Folder_Name. Click OK. The value of the 
selected property is inserted into the document.

Inserting the Folder_Name attribute
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Integrated Microsoft Office Applications
 How to modify the value of a custom property from Word or Excel:

Click the Office Button and select Prepare > Properties. When the Document 
Properties section appears across the top of the page, click Document 
Properties > Advanced Properties.

In the Properties dialog, select the Custom tab. All of the ProjectWise custom 
properties defined in Attribute Exchange Rules for Microsoft Office display on 
this tab. If they do not display, close this dialog, select the ProjectWise tab, 
click Update Document, and then open the dialog again. 

From the Properties list, select a custom property. Change the Value field as 
necessary and click Modify. Click OK when finished. On the ProjectWise tab, 
click Update ProjectWise. This updates the ProjectWise datasource with the 
new value. Now click Update Document on the ProjectWise tab to update the 
document with the new value.

Important: When you are modifying custom property values from inside the 
document, make sure you do not click Update Document before you click Update 
ProjectWise. If you do, any changes you made through the Custom tab will be 
overwritten with the current values from the datasource.

 How to insert a ProjectWise custom property into a cell in an Excel 
document:

In an open Excel document that has been initialized, select the cell in which 
you would like to insert a ProjectWise custom property. Then, in the Formula 
field, type =GetDocumentProperty("PROPERTY_NAME") where 
PROPERTY_NAME is the custom property you want to insert.

The document resides in the \data folder

Updating custom properties 

After you insert a custom property into a document, the value of that property 
can be updated manually after you open the document, or automatically 
whenever the document is opened, checked out, copied out, or exported. 
Whether the property values are updated automatically is determined by the 
administrator. 

The steps for manually updating ProjectWise custom properties in the document 
when the values have been changed in ProjectWise are the same as the steps for 
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Integrated Microsoft Office Applications
initializing the document to insert custom properties. Select the ProjectWise tab, 
and then click Update Document.

You can modify the value of any of the custom properties from inside the 
document, without returning to ProjectWise Explorer.

Adding new custom properties 

If you want to insert ProjectWise properties that are not in the default list of 
custom properties, you can add them. There are two parts to this process.

One part involves creating a new attribute under Microsoft Office Attribute 
Exchange Rules in ProjectWise Administrator, which is done by your administrator. 
The other part is creating a custom property of the same name from inside the 
integrated Word or Excel application. 

Once the property exists in both ProjectWise Administrator and the integrated 
application, you can insert the custom property and update it.

 How to create a new custom property from Word or Excel: 

Click the Office Button and select Prepare > Properties. When the Document 
Properties section appears across the top of the page, click Document 
Properties > Advanced Properties.

In the Properties dialog, select the Custom tab. In the Name field, type the 
attribute name which must be identical to the name of the custom property 
the administrator created. For example, if the property is named 
Document_Workflow_State in ProjectWise Administrator, then you name the 
property that here. In the Value field, enter a text string as a placeholder 
value. Word or Excel will not let you add the property without specifying a 
value.

Click Add, and then OK. Now click Update Document on the ProjectWise tab. 
This updates the value of all the custom properties with their current values 
from ProjectWise, and the placeholder value is overwritten with the correct 
value from ProjectWise.
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Module Assessment
Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. 
Assessment is used to determine what an individual knows or can do. 

Complete the assessment to see what you have gained from reviewing this 
module.

Integrated Environment Assessment
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The ProjectWise Explorer 
Client
Module Overview

ProjectWise Explorer is the main user interface for ProjectWise, from which you 
access the datasources that contain your projects, folders and documents. This 
module discusses the interface and its use.

Module Prerequisites
• Familiarity with Windows Explorer

• Familiarity with Microsoft Office applications

• Familiarity with MicroStation 

• Knowledge about References (Xrefs) and models (paperspace)

Module Objectives

After completing this module, you will be able to:

• Log in to ProjectWise Explorer and create a Working Directory

• Navigate the interface, create Projects and Folders

• Set document properties

• Define and change Attributes

• Set and work with interfaces
Aug-12  52 The ProjectWise Explorer Client
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Module Glossary
Module Glossary

Background map: A background map is a backdrop, a key map that lets you locate a 
spatial location in a geographical environment.

Copy out: To download a copy of a document into your working directory, without 
checking out the document.

Datasource list: The left side of the application window, which lists all of the 
datasources whose servers are detected and running.

Document list: The right side of the application window in which the selected 
folder's documents are displayed.

Environment: An environment is a collection of custom supplemental document 
attributes established by a ProjectWise Administrator. They are applied to folders 
and projects. Once applied, the documents therein inherit the attributes of that 
environment. The attributes can be seen by opening the document’s properties 
dialog. Environments are optional in a datasource, and are not required for your 
folders and projects.

Export: To check out a document and download it to a folder outside of your 
working directory, and therefore outside of ProjectWise. It can be sent out for edit 
by those who do not use ProjectWise. 

You can choose to lock a file when it is exported (Export options) or you can save a 
copy without locking the file (Sen to folder option).

Final status: A state in which a document can no longer be modified.

Link set: A set of links to files, models, and supporting documents. Create and 
open link sets using MicroStation’s Project Explorer dialog (File > Project Explorer). 
Link Sets are stored in DGN Libraries and make the data contained in them 
available to the entire project.

Placeholder document: A ProjectWise document that does not have an electronic 
file assigned to it.

Reference: A model attached to, and displayed with, the active model for printing 
or construction purposes. A reference cannot be modified. You can attach a 
model that resides in either the open DGN file or some other DGN file. 
When files that have references are imported into ProjectWise, ProjectWise is not 
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Introductory Knowledge
aware of the references until you run the Scan References and Link Sets utility on 
the folder in which they reside.

Introductory Knowledge

Before you begin this module, let's define what you already know.

Questions

1 In ProjectWise, what is a document?

2 What is a simple definition for a datasource?

Answers

1 The ProjectWise definition for a document is, essentially, a record in the 
database. It is an item This can be an electronic file in a ProjectWise folder, 
or a placeholder for an electronic or hard copy file not stored in 
ProjectWise.

2 Each datasource represents a working area. When ProjectWise is 
launched, the available working areas, or datasources, will be displayed. 
Each datasource is associated with a separate database and one or more 
storage locations.

Logging in to a Datasource

Before you can use ProjectWise Explorer, you must log into a datasource. At log in 
time, ProjectWise verifies your user name and password and determines your 
access rights. These access rights depend on your user group assignment, the user 
settings assigned to you by the administrator, the security on a particular folder or 
document, and other settings.

If single sign in is not enabled for your datasource you will log in to the datasource 
by entering your user name and password. When a datasource has single sign on 
enabled by an administrator, and the Windows account you used to log in to the 
operating system matches a user account in the datasource, you will be logged in 
automatically using the same credentials. 
Aug-12    54 The ProjectWise Explorer Client
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ProjectWise Explorer Window
Note: Single sign on is enabled by your administrator on a server system.

The first time you log in to a datasource under a particular user name on any 
system, you are prompted to create a working directory. This working directory is 
a folder somewhere on your system to which documents will be automatically 
downloaded whenever you open, check out, or copy out documents from 
ProjectWise. You will not be prompted about the working directory again when 
logging in to the same datasource with the same user name, on the same system, 
unless you rename, move, or delete the working directory.

 Exercise: Log in to the datasource

1 Click the ProjectWise Explorer icon on the desktop or select Start > 
Programs > Bentley > ProjectWise V8i SELECTseries > ProjectWise 
Explorer.

Available datasources are listed in the datasource list on the left.

2 Right click on the class datasource and select Log in from the pop-up 
menu.

The first time you log in to a datasource using the ProjectWise Explorer 
Log in dialog, you need to enter your user name. After that, it will default 
to the last used user name entered for that datasource.

3 Enter your user name and password.

Note: Windows domain users must first enter the domain followed by a 
backslash character “\” and then your user name; 
DOMAIN\myusername.

4 Press Enter or click Log in.

Note: ProjectWise user names and passwords are case sensitive.

Once you are logged in, the icon to the left of the datasource name changes and 
the root level nodes available to you are displayed in the datasource list. If you log 
in to more than one datasource, the datasource icons will indicate which 
datasource is active by adding a check mark to the icon.

ProjectWise Explorer Window

The ProjectWise Explorer window has two main sections, the datasource list on 
the left and the document list on the right. 
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ProjectWise Explorer Window
• The datasource list lists all of the datasources whose servers are detected and 
running. Once logged in to a datasource, a Documents and a Saved Searches 
folder displays under that datasource. Depending on your user settings, a 
folder with your user name may also display under the datasource so you can 
create custom folders. If there are engineering components stored in your 
datasource, you will also see a Components project in the datasource.

Click the + symbol to the left of the Documents root folder to expand the list 
of folders in the selected datasource. 

• When you select a folder, the folder's documents display in the document list. 
When View > Preview Pane is enabled, a preview pane displays in the lower 
portion of the document list when a document, folder, or project is selected. It 
shows properties of the selected item.

The tasks you can perform in ProjectWise Explorer can be initiated from an item 
on the menu bar, or through the standard toolbar. For quick access, you can right 
click any item in the datasource list (left pane) or document list (right pane) and 
select items from the pop-up menu that appears.

Refreshing the datasource list

You can refresh the datasource list by right clicking the ProjectWise Explorer 
Datasources label at the top and selecting Refresh. This will not be something you 
do often, but you may need to do it occasionally to accomplish one of the 
following things.

• To display new datasources that were created after you opened ProjectWise 
Explorer.

• To display datasources based on changes in your access after you opened 
ProjectWise Explorer.

• To display remote datasources after pointing your system to a remote server 
using the ProjectWise V8i Network Configuration Settings dialog. Check with 
an administrator.

• To display only local or only remote datasources if configured using the 
ProjectWise V8i Network Configuration Settings dialog. Check with an 
administrator.

• To display datasources based on whether they have been started or stopped 
after you opened ProjectWise Explorer.
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ProjectWise Explorer Window
Logging out

You can log out of a datasource when you complete a session.

 How to log out of a datasource:

Select Datasource > Log out from the menu bar, or right click on a datasource 
icon and select Log out. Click Yes in the prompt.

Working directory

Your working directory is a location that contains temporary copies of the files 
that you check or copy out from a ProjectWise server. It can be on your local hard 
drive or a network drive so administrators can back up files. Applications launched 
from ProjectWise Explorer will use these files automatically. 

If a working directory was not defined by your administrator you will see a browse 
dialog when you first log in to a datasource. You then browse to the location in 
which you want to store the local files. Or, if a defined working directory does not 
yet exist, you will see a dialog asking you to confirm its creation. The option to 
change your working directory is set by the administrator.

Note: Always check documents out from ProjectWise. Working on local copies stored 
in your working directory may result in data loss. This is because other team 
members may make changes to the document within the ProjectWise 
environment, and those changes are not added to a local copy. They also will 
not be able to see your changes.

Warning: Users must never share a working directory, as it can cause problems with check 
outs and exports.

Purging the working directory

Every time you check or copy out a document, a copy of it is placed in your 
working directory. Depending upon how your user settings are configured, local 
copies of documents may remain in your working directory when you check in or 
free documents. This improves performance, because delta file transfer will 
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The Datasource List
compare the local file to the one on the server and only transfer the changes. 
However, over time, a very large working directory can result. 

To make sure there is not wasted space on your system, you may want to clean up 
your working directory occasionally. You perform this clean up task in ProjectWise 
Explorer. 

 How to purge the working directory:

First select a document, or documents, and select Document > Purge Local 
Copy from the menu bar. If your working directory contains a copy of the 
document, the copy is removed.

To remove all local copies of documents for a folder, right click on it and select 
Purge Copies. If the folder contains sub-folders, click Yes when prompted to 
confirm that you want to purge them.

Note: A document cannot be purged from the working directory if the document is 
open.

Warning: Never delete the directories or files created by ProjectWise directly from Windows 
Explorer. Deleting these folders or files can cause data loss. To maintain your 
working directory, use the Local Document Organizer (a dialog accessible from 
ProjectWise Explorer that is used to manage documents), or the check in and 
purge commands. 

Warning: Purge only copies of files whose changes have already been sent back to the 
ProjectWise server.

The Datasource List

The datasource list lists all of the datasources whose servers are detected and 
running.
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The Datasource List
Default datasource list icons

Datasource: Indicates an individual datasource.

Active datasource: The check mark indicates that the datasource is open and in 
use.

Open datasource: An open icon indicates that the datasource is open but not in 
use.

Folder: Indicates folders and sub-folders.

Saved Searches parent folder.

Saved Searches folder: Each user also has a Personal folder.

Custom Folders 

This folder only displays if your administrator gives you access to this option.

Custom folders can be thought of as favorites where you keep the documents you 
are working on most often. These folders serve as an alternative to the standard 
folder hierarchy, so you can quickly locate frequently used documents. You can 
create your own personal custom folders, or if you are an administrator, you can 
create global custom folders that all users can see and use.

When you place documents in a custom folders, it is only a link to the file. 
ProjectWise doesn't move or make a copy of the file when it is placed in a custom 
folder. If you delete the file in the custom folder, it actually deletes from the file 
from the location where it was originally linked. If you check a file out from a 
custom folder it is also marked as checked out from the original location so no one 
else can modify it.

Message Folders 

Message folders allow you to view the contents of messages sent and received 
using ProjectWise Messenger. Message folders appear in ProjectWise Messenger 
and in ProjectWise Explorer, if your user settings permit their display. 

Each user has their own message folder, which is represented by a message icon 
and your user name. By default, your message folder contains an Inbox folder, a 
Sent Items folder, and a Global Folders folder.
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The Document List
The Document List

If ProjectWise Explorer is installed with the Spatial option enabled the document 
list has two tabs, one to list documents and information about them and one for 
spatial functionality.

Document information

When you select a folder, its contents are listed in the document list. If you do not 
have the necessary permissions for a document or sub-folder, the document or 
sub-folder will not appear in the document list.

The bottom of the document list has tabs that contain information about the 
selected folder and/or project, or when a document is selected, tabs provide 
information about it.

Each document listed in the document list has two icons associated with it. The 
first icon indicates the general permissions and status for the document. The 
second icon indicates the document’s type and its associated application.

You can select the icons that represent the applications associated with a 
document, such as the MicroStation “M” or the Microsoft Word “W” icon. If no 
icon has been linked to an application, you see a default icon.

If icons have not already been selected, complete the exercise to do so.

 Exercise: Select icons

1 Select Tools > Associations > Icons. 

The dialog has different categories, Default Datasource Icons, Default 
Icons used in the ProjectWise interface, and icons for each defined 
application. You want to assign familiar icons for the applications you use.

2 Double click on Acrobat PDF.
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The Document List
3 In the Select Image dialog, navigate to \Program Files\Adobe\Acrobat 
9.0\Acrobat, and click Acrobat.exe.

Available icons display in the Select Icon section of the dialog. To select, 
double click or select and click OK.

4 Click the icon and then click OK.

5 Scroll to Microsoft Excel.

Hint: You can press M on the keyboard to skip to the applications with names 
beginning with M.

6 In the Select Image dialog, navigate to \Program Files\Microsoft 
Office\Office12, select EXCEL.EXE, choose and icon and click OK.

7 Select Microsoft Word.

8 In the Select Image dialog, navigate to \Program Files\Microsoft 
Office\Office12, select WINWORD.EXE, choose and icon and click OK.

You can easily assign all the Microsoft Office icons here.

9 Scroll to MicroStation.

10 Double click on MicroStation, navigate to the local install and assign an 
icon.

Typically, \Program Files\Bentley\MicroStation\ustation.exe.

11 Click OK when you are done to close the Icon Associations dialog.

Note: It is recommended that you not change the Default Datasource Icons as this 
may confuse other users or hinder troubleshooting.

Default document list icons

The first icon indicates the general permissions and status for the document.

Pencil: The document is checked in and you have permission to modify the 
document or the document's properties 
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Working with ProjectWise Explorer
Open book: You have read-only access to this document.

Lock: Document either is checked out exclusively or has been exported exclusively 
by another user. You can still open this document as read-only.

Disk: Document has been exported exclusively by you. Other users will see a lock.

Check mark: Document is checked out exclusively to you. Other users will see a 
lock.

Final: Document is in Final Status.

The second icon indicates the document’s type and its associated application.

The Default icon indicates a document is associated to an application, but the 
application itself has no associated icon. 

The Unassociated icon indicates a document not associated to any application, or 
to one that has no file attached.

A ProjectWise markup document.

The Flat Set icon indicates a document group; several documents grouped 
together.

Represents a logical set for MicroStation. A logical set is a master file with 
references attached.

Note: Select View > Thumbnails to change the icons in the document list to display 
thumbnail images. (If there is no thumbnail image, a default image displays in 
its place.)

Working with ProjectWise Explorer

You can change the ProjectWise Explorer window to suit your preferences. This 
makes it easy to manage documents and to view and edit their properties. When 
the details view is selected, the columns in the document list are customizable. 
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Working with ProjectWise Explorer
You can create your own tool bars to hold tools that you use frequently. As with 
any Windows application, you can maximize, minimize or resize the window, as 
well as move the bars between the datasource list, the document list, and the 
preview pane.

Showing information about what is in the datasource

You can choose the types of general information you want to see about 
documents or folders, such as who created the item, its size, or the owner name 
and store them in a personal “view”. When it is active, the columns you selected 
will be seen in the document view.

 Exercise: Select information columns to display in the document view

1 Select View > Manage Views from the ProjectWise Explorer main menu 
bar.

2 Click New.

3 In the Create View dialog, expand the Select an Environment options.

This is a list of all the environments in the datasource. An environment is a 
collection of custom supplemental document attributes that can be 
defined by a ProjectWise administrator. They can be used to track 
additional project, user or file information. The environment options in 
the Create View dialog let you add columns to view this custom 
information for documents assigned to a specific environment.

4 Set the environment to Titleblock.

5 In the View name field, type your student identification (student01, etc.).

This is the name of the view you are creating.

Hint: It is helpful to use a descriptive name such as “Date and User 
Information” or “Folder Information”. There can be spaces in the name.

6 In the left frame, expand Basic Columns by clicking the +.
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Working with ProjectWise Explorer
To add a column, double click the column name or highlight the column 
name and then click the green arrow pointing to the right frame. Or, drag 
and drop the column into the Show Columns of frame.

You want to add columns that provide the information that you, 
personally, want to see.

7 Add the following columns: Application, Created, Created By, File Size, File 
Updated, File Updated By, State, Version, and Workflow. 

8 Expand Titleblock by clicking the +.

9 Add the Checked By column.

10 When the desired columns have been added, click OK.

11 Leave the Manage Views dialog open.

To change the order in which the columns will be displayed, use the up and down 
arrows or drag and drop. To remove a column, highlight it in the right frame and 
click the arrow pointing to the Available Columns frame, or drag and drop back to 
the left frame. You can set a column’s width using the Width field at the bottom 
right of the dialog. Once established, you can resize the columns by dragging the 
column headers’ edges.

Global and personal views

You can create your own personal views in ProjectWise Explorer and these views 
are saved in the ProjectWise database, making them available no matter what 
system you use to log in to a datasource. 
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Working with ProjectWise Explorer
In addition, administrators can create global views from either ProjectWise 
Explorer or ProjectWise Administrator. These are for all users to use in a given 
datasource.

Views for a datasource created in ProjectWise Administrator

 Exercise: Create a second view

1 In the Manage Views dialog, click New.

2 In the View name field, type:

Folder Information

3 Expand Folder Columns in the left frame.

The Folder Columns options list information you can display about folders.

4 Add the Environment, Folder Name, Folder State, and Folder Workflow 
columns.

5 Make Folder Name the first column to display and click OK.

6 Click Close.

You click on the View option list at the upper left of ProjectWise Explorer 
to select a view you have created or one that was created by your 
administrator.

7 Select the latest delivered MicroStation example files folder in the 
datasource list, and then select the Folder Information view.
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Working with ProjectWise Explorer
Note: You many need to select View > Toolbar > View to add the toolbar where 
you change the view.

Note the change in the information displayed in the document list.

8 Select your student identification view.

Sorting documents in the document list

You can sort documents by an individual attribute by clicking on the column 
heading. Clicking a second time will reverse the order. There is also a menu option 
that lets you sort the document list based on as many of the displayed columns as 
you like. For example, you could sort first by document name in ascending order, 
and then by document version in descending order.

 How to sort based on several columns:

First, select View > Sort. In the Sort dialog, the Sort option is set to the last 
attribute by which you sorted. Then, select the attribute you want to sort by 
from the Sort by options. Enable the ascending or descending radio button 
and click OK.

When you click Add, “Then by” options appear. Select the next attribute by 
which you want to sort.

Copying paths to documents and folders

You can right click in the address bar when a document, folder, or component is 
selected to copy and paste the location as a shortcut somewhere outside of 
ProjectWise.

Once you select Copy URL or Copy URN, you can paste the item as plain text or as 
a link into a document or file outside of ProjectWise. Perhaps inside the body of a 
Microsoft Outlook E-mail message or Microsoft Word document. You can paste 
the link into the Windows Explorer or Internet Explorer address bar, as well as the 
Run dialog (Windows Start menu > Run).
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Working with ProjectWise Explorer
Pasting as a link

If pasted as a link (Edit > Paste), clicking on the link opens the ProjectWise 
Explorer client on your system, prompts you to log in if you are not already logged 
in to the datasource containing the item, and then takes you to the item. 

Pasting as plain text

If you paste a URL as plain text (Edit > Paste Special > Text), you will see the entire 
datasource path to the item, just as it appears in the address bar in ProjectWise 
Explorer. 

When you paste a URN as plain text, you will see the item’s ID instead of the full 
datasource path to the item.

Drainage.doc copied as URL and Vegetation.doc copied as URN
pasted as links and as unformatted text

Custom tool bars

You can create additional tool bars for easy access to the commands that you use 
often.

 Exercise: Create a custom tool bar

1 Continuing in ProjectWise Explorer, select Tools > Customize.

2 In the Customize dialog, select the Toolbars tab and click New.

3 Type Document tools in the Toolbar Name field and click OK.

An empty tool bar appears.

4 Select the Commands tab.

5 Select the All Commands category.

6 Scroll down the list of commands to Free and click on it. 

7 Drag it to the new tool bar, and drop it and the tool is added to the tool 
bar.
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The Preview Pane
8 Add the Check In, Check Out, and exclusive (second) Copy Out commands 
and click Close.

9 Dock the new tool bar at the top of the ProjectWise Explorer.

10 Close the Customize dialog.

Once a tool bar is created you can edit it by opening the customize dialog and 
adding or removing commands. You can add menus and command buttons to tool 
bars.

 How to add menus and command buttons to tool bars:

To add a menu to a toolbar, on the Commands tab of the Customize dialog, 
select the New Menu category.

Drag the New Menu command from the Commands list into a ProjectWise 
Explorer toolbar, such as the Standard toolbar.

To customize the appearance of a new menu item on a toolbar, right click the 
new menu button in the toolbar and select Button Appearance.

Note: Note that the right click customization menu is only available when the 
Customize dialog is also open.

To add command buttons, on the Commands tab of the Customize dialog, 
select a category, and then select a command from that category. Drag the 
command either to a new menu on a toolbar, or to an existing toolbar.

The Preview Pane

The preview pane at the bottom of the document view is similar to the 
AutoPreview in Microsoft Outlook. This pane gives you attribute information 
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The Preview Pane
about a file or folder without having to open a properties dialog. To toggle its 
display, select View > Preview Pane.

When you select a project, folder or document, the preview pane has tabs that 
show various properties. 

Folder and Project properties tabs

The Folder and Project Properties tabs display the project specific properties, 
general properties, and statistics of the selected project, or of the project in which 
a selected document exists. 

These properties are the same ones you would see if you opened the properties 
dialog, only they are not editable from this location.

Document Properties tab

When a document is selected, this tab displays general properties of the selected 
document.

When a document is selected, extracted thumbnail images display in the preview 
pane and in integrated applications’ document selection dialogs. Thumbnails can 
make it easier to identify a document you are looking for without opening files. If 
thumbnails are enabled in your datasource, they are created in the background 
on a schedule created by your ProjectWise administrator. It may take a while 
before you will see one for a new or updated document.

Extracted file properties data also displays. Text extracted from files is stored in 
ProjectWise's database and can be searched on just like any other property.
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The Preview Pane
To enable these features, select Tools > Options and select the Settings tab of the 
properties dialog. Under User Interface, you can toggle the settings for file 
properties and document thumbnails.

Photo Preview tab 

The Photo Preview tab is designed to let you preview image documents, such as 
digital photographs, without opening the document itself. When you select an 
image document and then select the Photo Preview tab, a copy of the document 
is downloaded to your working directory and a preview of the image displays. You 
can open the document properties dialog and use the forward and backward 
arrows to move through a slideshow.

Photo Preview supports standard image file formats, including BMP, JPEG, GIF, 
TIFF, and PNG. You can add additional plug-ins to your browser to view other file 
types. Photo Preview uses Internet Explorer controls to display content, which lets 
these additional file types be displayed either natively or through an Internet 
Explorer plug-in

You can use the Photo Preview tab to display the contents of non-image files, such 
as text files, PDFs, HTML files, and Word, Excel, and PowerPoint documents. To 
display Microsoft Word, Excel, and PowerPoint files in the Photo Preview tab, the 
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The Preview Pane
respective application must also be installed. To display PDF files, Acrobat Reader 
must be installed. When you select an Office document, a read-only view of the 
document is displayed.

Note: Office documents are disabled from displaying in the Photo Preview tab by 
default. An administrator must enable viewing.

If the document you are trying to preview is opening inside the native application 
instead of the Photo Preview tab, do the following. In Windows Explorer select 
Tools > Options. In the Folder Options dialog, select the File Types tab. In the 
Extensions list, select the file type of the document you are trying to preview, and 
click Advanced. In the dialog that opens, enable the “Browse in same window” 
option.

Note: Photo Preview is not intended for the display or management of large image 
files, such as aerial photography, satellite imagery, or high-resolution scans. 
Attempting to preview such a file will likely result in extremely poor 
performance.
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Folders
Creating Folders

There are two ways to create folders. You can create an empty new folder, or 
create a folder containing documents and sub-folders using drag and drop.

Create a folder using Folder > New Folder

 How to create a folder using Folder > New Folder:

Select the Documents root folder, or any project or folder below it and then 
select Folder > New Folder. The Name is limited to 63 characters. The 
Description is limited to 127 characters.

Important: Whenever a folder description exists and the user setting “User 
Interface -> Display descriptions” is enabled for a user, the description will 
display next to the folder instead of the folder's name.
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               Folders
- To change the location where the folder will be created, click Change in the 
Parent section.

- From the Storage list, select a storage area.

- When the Create Folder dialog first opens, you are assigned as the owner of 
the folder. You can leave this as is, or assign someone else.

 Exercise: Create two folders

1 In the delivered MicroStation examples, right click the Civil Project and 
select New Folder.

This creates the folder under the Civil project without having to change 
the location. 

2 Name the folder with your student identification (student01, etc.) and 
click OK.

3 Right click your student<#> folder and, under this folder, create a sub-
folder named specifications.

Creating folders using drag and drop

Using this method creates the documents contained in the folders and sub-
folders.
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Folders
 Exercise: Create a folder using drag and drop

1 In Windows Explorer, navigate to the 
\Bentley\MicroStation\WorkSpace\Projects\Examples\Civil\dgn\folder, 
drag the \Designs folder to your student<#> folder, and drop it. Do not 
click OK yet.

(By default, C:\Documents and Settings\All Users\Bentley\MicroStation...)

Note: The destination can be any project or folder in the datasource, but not 
the Documents root folder itself.

2 In the Import Directories dialog, make sure the Import Files Only check 
box is disabled.

If this option is enabled, the files in the folder will be imported, but the 
folder that contains them will not be created.

3 Click OK.

In the Import Directories dialog, if the folder you are importing has sub-folders 
and you want to retain the directory structure in ProjectWise, enable the Include 
Subdirectories check box. 

Important: If Import Files Only and Include Subdirectories are both enabled, 
ProjectWise will import the files from all of the sub-folders, but none of the sub-
folders themselves will be created in ProjectWise.

Enable Import and rename duplicates to rename duplicate files if they are found 
during the import.

Copying out and exporting Folders

When you select a  folder and select Folder > Copy Out, copies of the 
documents in that folder are downloaded to your working directory. 
Note that you cannot Copy Out folders that have sub-folders.

When you select a folder and select Folder > Export, the Folder Export 
Wizard opens, allowing you to download copies of the documents in the selected 
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Documents
or folder. In ProjectWise Explorer, these documents will be marked as 
exported and locked to other users until you re-import them.

To import them, on the system on which they were exported (the copies reside in 
that system’s working directory), right click and select Import.

Documents

When a file is uploaded from a file system into ProjectWise, it becomes a 
document. Documents contain metadata about the file in the form of general 
properties, such as a description, the associated application, the date the file was 
imported, and custom supplemental environment attributes. The files themselves 
are stored on a file server, whereas document metadata is stored in the 
ProjectWise database.

You can create something called a placeholder document, which is simply a 
container of metadata that does not have an electronic file assigned to it. 
Placeholder documents can be used to represent electronic files you are planning 
to import into ProjectWise, or hard copy documents or drawings that are stored 
in a file cabinet.

Creating documents

You can create documents by dragging files from Windows Explorer into 
ProjectWise Explorer, or by using the various Document > New commands in 
ProjectWise Explorer. You can create your documents with or without the 
assistance of ProjectWise's Advanced Document Creation Wizard. It presents the 
steps necessary to create one or more documents. You can set this as the default 
method for creating documents, or you can decide on a case-by-case basis which 
method you want to use.

When creating documents, the document name and file name must be unique to 
a folder. If you attempt to create a document in a folder that already contains a 
document with the same document or file name, ProjectWise will resolve the 
conflict for you, or you will be prompted to resolve the conflict yourself.
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Documents
When you create documents using Document > New, before you associate a file 
documents are named automatically. The first file will be given the lowest number 
available, for example, doc00001, and the remaining document names will each 
increment by 1, for example, doc0002, and so on. So, if a folder already contains a 
document named doc00001, the next document you create in that folder will be 
named doc00002. When you associate a file to the document, the number is 
replaced by the name of the imported file.

 Exercise: Create new documents

1 Select the \specifications folder below your student<#> folder.

This is the folder in which to create the document.

2 Select Document > New > Document from the menu bar.

3 Select No Wizard and click OK.

4 In the Create Document dialog, in the File section, click the Advanced 
button and then select Import.

You will associate an existing file to the document.

5 Navigate to the class data set \specifications folder, select Vegetation.doc, 
and click Open.

The Document section is populated with information about the imported 
file. You can change this if necessary.

6 Click Save, and then click Close.

7 Continuing in your specifications folder in ProjectWise Explorer, select 
Document > New > Multiple Documents.

The destination folder in the Create Multiple dialog is set to the current 
folder.

8 Change Number of documents to create to 2 and click OK.

9 Select No Wizard and click OK.

These documents do not have any files associated to them. They are 
placeholders.

Document Creation wizard

This wizard presents the steps necessary to create a ProjectWise document. 
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Documents
Using this wizard, you can select the folder in which to create documents, and 
specify custom attributes.

 Exercise: Create documents using the Advanced wizard

1 In Windows Explorer, navigate to the class data set \dgn folder.

2 Drag the two files into your \student<#>\Designs folder, selecting the 
Advanced wizard and clicking OK.

3 On the Welcome page, click Next.

Your \student<#>\Designs folder is selected.

4 Click Next.

5 Leave the use external file as a template radio button enabled. Note the 
name of the file being used as the template.

“Use ProjectWise document as a template” creates a new document 
based on an existing ProjectWise document. “Select from recent used 
templates” creates a new document using a file or document that has 
already been used by the wizard to create a new document.

6 Click Next.

7 Set the following information on the Attributes tab:

Title: BSI400-W01-I9NB.dgn

DWG_No: I9NB

Revision: 2

Drawn By: your student identification

These are extra attributes for this file.

8 Click Next.

The Document Properties page is used to edit the document name, 
description, file name and version.

9 Click Next.

The Create a document page gives you the option to open the file in its 
associated application when the document is created. Do not check this 
now.

10 Click Next, and then click Finish.
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Documents
The wizard will restart so you can enter information for the second 
document. 

11 Use the same settings as before, except enter the following on the Define 
Document Attributes page for BSI400-W01-I9SB.dgn:

Title: BSI400-W01-I9SB.dgn

DWG_No: I9SB

Revision: 3

Drawn By: your student identification

 Exercise: Review the data

1 Right click BSI400-W01-I9NB.dgn and select Properties.

2 Examine the Attributes tab in the properties dialog.

The information you entered appears.

3 Close the dialog.

Resolving document creation conflicts

Document names and file names can only be used once in a folder. If you attempt 
to create a document in a folder that already contains a document with the same 
document or file name, ProjectWise will flag the document in conflict and either 
resolve the conflict for you, or prompt you to resolve the conflict yourself. 

What happens when a document creation conflict occurs depends on your 
Document Creation Conflicts user settings.

 How to resolve conflicts:

When there is a conflict and your user settings are configured so that you are 
prompted to resolve the conflict yourself, there are options.
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Documents
- To ignore just the first document that is creating the conflict, enable “Skip 
this item” and click OK.

The document in conflict will not be copied or moved, but all other 
documents involved in the operation will be successfully copied or moved to 
the target folder.

- To create a new document when a document creation conflict occurs, enable 
“Create a new document” and click OK.

- To create a new version of a document when a document creation conflict 
occurs, enable “Create a new version of existing document” and click OK.

Warning: Always check with an administrator regarding versioning. The version 
identifier and other options may be pre-determined or may need to 
be confirmed.

If you think there might be multiple documents in conflict, after you select an 
option, enable the “Apply this choice for all succeeding items” check box, and 
then click OK.

Document properties

The document properties dialog is used to view or modify properties of 
documents one at a time. The dialog shows all properties of a document, which 
include general properties, environment attributes, file properties, the 
document's history (audit trail), any related components, associated workspace 
settings, and which users have which permissions to the document. When using 
the Create Document dialog, the moment you save the new document for the 
first time, the Create Document dialog becomes the document properties dialog. 
The name and description of the currently selected document displays in the title 
bar of the dialog. You can step through all the documents in the current folder by 
using the forward and backward arrows at the bottom of the dialog.
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Documents
 Exercise: Accessing and changing document properties

1 Continuing in ProjectWise Explorer, open your specifications folder, right 
click on Vegetation_doc and select Properties.

The properties dialog for the document appears.

Hint: You can select the document and press the space bar to open the 
properties dialog.

2 On the General tab, change Department to Planning - Planning.

An asterisk appears in the dialog’s title bar indicating that properties have 
been changed but not saved.

3 Click Save.

4 Do not close the dialog.

The General tab contains information about system attributes. These attributes 
are related to the management of the document. Some of these are editable and 
some are not.

Warning: If you change the Application, the selected application will be used when you 
attempt to open the file. Make sure the application is compatible.

 Exercise: Modify other document properties

1 Continuing in the properties dialog, click the back button.

The preceding document’s properties are displayed.

2 Set the following:

Name: Soil.doc

Description: Specifications

Department: Planning - Planning

3 In the File section, click the Advanced button, and then select Import.

4 Navigate to the class data set \specifications folder, select Soil.doc, click 
Open, and then click Save.

5 Click the back button, and set the following:

Name: Drainage.doc
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Documents
Description: Specifications

Department: Planning - Planning

6 Import Drainage.doc and click Save.

7 Do not close the dialog.

You can import, replace, rename, or remove files using the document properties 
dialog.

Document security properties

The document security type and properties can be viewed or changed on the 
Security tab of the properties dialog. If no security is set, everyone has complete 
access to the document. If there is at least one access control set on the 
document, any individual or group that is not given explicit access is denied 
access. Permissions are assigned as follows.

• Full control: You can perform every document function

• Change permissions: You can change document permissions

• Delete: You can delete documents.

• Read: The document is visible in document list, you can view the document's 
properties and attributes

• Write: You can modify document properties and attributes

• File Read: You can open the document's file in Read-only mode. You can copy 
out the document, but not check it out

• File Write: You can modify the document's file. You can check out the 
document, make changes, and then check it back in

• No access: You have no access to the document

Whether you can change these settings depends on the rights granted by your 
administrator, and possibly by the owner of the document.
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Documents
Document Attributes

Document attributes are supplemental to the general document properties that 
all documents have, such as file name, size, and date and time last updated. They 
exist so that an organization can tailor document attributes to the requirements 
of their projects.

Attributes are used to track document information, to search for documents, or to 
enter information in the title blocks of designs. Selecting the Attributes tab in the 
properties dialog displays any custom attributes in a form that is created by the 
administrator. Additional custom attributes can be shown on the More Attributes 
tab.

You can edit any value that is not grayed out by selecting it, entering a new value, 
and then saving the change. The new attributes are applied to the document.

 Exercise: Assign attributes

1 Continuing in ProjectWise Explorer, in the properties dialog for 
Drainage.doc, click the Attributes tab.

2 Enter the following:

Title: Drainage specifications

Drawn By: your student identification

3 Click Save.

4 Click the Forward button and enter the following:

Title: Soil specifications

Drawn By: your student identification

5 Click Save.

6 Click the Forward button and enter the following for Vegetation.doc:

Title: Vegetation survey

Drawn By: your student identification

7 Click Save.

Leave the dialog open.
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Attribute sheets

When editing a document’s properties on the Attribute and More Attributes tab 
pages, there may be times when you want to enter multiple values for the same 
attribute. You do this by creating more attribute sheets for the selected 
document.

Attribute sheets let you refer to particular areas of a document separately. For 
example, many documents contain details of more than one item. A drawing of a 
site might contain a number of elevations or several large scale details of 
construction features. Since each sheet contains its own attribute data, each 
sheet can be directed towards a particular part of the document. For example, 
you might add a sheet for each of the elevations and details.

 How to add an attribute sheet:

First, select a document in the document list, right click and select Attributes > 
Add Sheet. You can right click inside the properties dialog. The Document 
properties dialog opens to the Attributes tab. Then, enter values on the 
Attributes tab and the More Attributes tab, click Save, and then Close. The 
new sheet is created and appears below the selected document in the 
document list.

Repeat the procedure to create additional sheets. Multiple sheets are listed in the 
order in which they are created.

Note: In order to add an attribute sheet, the document must have space for it created 
by your administrator.
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Audit Trail

This is the mechanism for recording document and folder activity in the 
datasource. The items tracked by an audit trail are specified in ProjectWise 
Administrator. The audit trail itself is viewed in ProjectWise Explorer.

A document’s audit trail provides you with a list of all activities that have taken 
place regarding the document. An audit trail record is created as an action or 
activity takes place. Your administrator determines which document activity is 
recorded, and whether you have permission to see the audit trail. If enabled, 
select the Audit Trail tab in the properties dialog to see the audit trail.
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Creating new versions of documents

Version control is the ability to store and manage multiple versions of the same 
document. 

You can create new documents based on existing documents, while preserving 
the original document.

If the “Create new version during Check In” check box is enabled in the Check In 
dialog, a Check In will create a new version of this document. Any changes you 
made while the document was checked out are saved to the new version. The 
version field lets you enter a custom version identifier, which displays in the 
document properties dialog. If you leave this field blank, a default version 
identifier is appended to the new document.

When you create a new version of a document, the original document 
automatically becomes read-only, maintaining the condition it was last in before 
versioning. This protects it from further modification. The new version is now the 
active version of the document and you can edit that document as necessary.

Since creating new versions retains the original document, you can always go back 
and review previous versions of a document, or if necessary, you can restore an 
older version to become the current, active, version of the document.

Note: Check with your administrator regarding versioning.

Exporting and importing documents

When documents must be edited by someone who is not using ProjectWise, you 
can export those documents outside ProjectWise.

To export a document exclusively, the document must be checked in and you 
must have Read, File Read, and File Write privileges for that document. An export 
is similar to a check out, only it downloads the selected documents to a folder you 
specify that is outside your working directory, therefore outside of ProjectWise. 
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You can export documents individually, or you can export an entire folder or 
project. Once outside of ProjectWise, you can zip the files up and send them out 
for editing. After exporting a document, you see a diskette icon next to the name. 
Other users will see a lock icon. Other users can copy out locked documents, or 
open them as read-only.

Document Export wizard

The document export wizard presents the steps necessary to export documents.

 How to export documents:

First, select the documents and select Document > Export. Then, click Next in 
the Document Export wizard. 

On the Define the export settings page, enable the Export radio button, click 
Browse to select the export location, or type the location to which to export 
the documents. If the folder name you enter does not exist, it will be created 
on export. 

Click Next and the documents eligible for export are exported to the export 
location. The results are displayed in the wizard. Click Finish. You can select a 
folder or project and select Folder > Export.

Working with references and logical sets

A logical set is a DGN document that references other documents. It has 
other documents attached to it. The DGN document to which other 
documents are attached is referred to as the master document of a logical set. 
The document icon for a master document will have a hierarchical tree symbol in 
the lower right corner of the icon.

Creating logical sets 

The actual referencing of one file into another is performed in MicroStation
When you open a DGN document from ProjectWise and then 
attach other ProjectWise documents to it in MicroStation, saving 
changes to the master document automatically creates the logical set in 
ProjectWise.

If you are importing DGN files and their references into ProjectWise, 
those master documents will not become logical sets and their icons will not have 
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the hierarchical icon until you, or your administrator, runs a reference scanning 
tool on them.

Scanning for references and link sets

There are two main parts to setting up the Scan for Reference Files and Link Sets 
wizard. First, identify folders or documents containing master documents and link 
sets, and then setting up a method for searching. The utility finds DGN, 
raster and shapefile references and available link sets, depending on the options 
you set. 

                       When you attach a reference to an open file using the References dialog, the
                       ProjectWise Attach Reference dialog will appear. Select the file you wish to attach
                       as a reference, click Add and then click OK when you are done. The standard
                       Reference Attachment Settings dialog will open and you can attach the reference.
                       ProjectWise will now recognize the logical set. 
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Viewing documents in a logical set 

You can find out which documents are referenced in a logical set.

 How to find out which documents are referenced in a logical set:

First, select the master document of a logical set. Then, select Document > Set 
> Show References or right click on a document and select Set > Show 
References. The set contents window opens displaying the master document, 
and under it, all the documents referenced into the master document. 
If the references are not indented under the master document, right click in 
the set contents window and select View > Details.

Note: You can check the references in ProjectWise Explorer. However, if they are in 
different folders it is easy using the logical sets dialog.

Opening logical sets 

For each master MicroStation document you check out, an XML file is 
created in your working directory (it may be in a sub-folder of the dmsxxxxx 
folder). This file lists all the master document's references, and records all 
reference-related changes to the master document. When you select Check In or 
Update Server Copy, the changes documented in the XML file are saved to the 
logical set in the database. If you free the master document, changes documented 
in the XML file are discarded and not saved to the database. Each XML file will 
have the name of the master file prepended to the file name. For example, 
master1.dgn.fileinfo.xml.
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Reference check out

When you open a file with references, the references are copied out. If you need 
to edit those files, they must be checked out. 

If you double click on a DGN file with references, you see the Select Reference 
Documents dialog if the option to show it is enabled in your user settings. This 
dialog offers the option to set the reference file to a checked out state. When you 
check the master file in, references and their changes will be checked in.

 Exercise: Checking references in and out

1 Continuing in ProjectWise Explorer, select Tools > Options.

2 On the Settings tab of your user Properties dialog, expand the User 
Interface category.

3 Enable the check box for Show Selective Set Open dialog, click Apply, and 
then click OK.

4 In your student<#> \Designs folder, double click on BSI400-W01-
Survey.dgn.

You see the reference, BSI400-W01-Contours.dgn, listed in the Select 
Reference Documents dialog. The Copy Out radio button is enabled by 
default.

5 Enable the Check Out radio button and click OK.

The master document opens, and the selected reference documents are 
downloaded accordingly. If you do not have access to some of the 
documents referenced by the master document, only the documents to 
which you have access will be downloaded.

6 Return to ProjectWise Explorer.

BSI400-W01-Contours.dgn is checked out, along with the master file.

7 In MicroStation, select File > Exit.

8 Check BSI400-W01-Survey.dgn in.

In ProjectWise Explorer, you can see that the Reference is still checked 
out.

9 To release the check out on the reference in, right click on it and select 
Free.
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If no changes have been made, you may want to Free the reference. 
Freeing will not be logged if your administrator is keeping an audit trail. If 
you made no changes, freeing the document is less confusing.

Hint: If reference is in another folder, you can open the logical sets dialog, right click 
on any checked out files and check them in from there.

Notes about raster references

When working with raster references and ProjectWise, you need to make sure the 
raster references are always copied out instead of checked out. Otherwise, a copy 
of the entire raster will be downloaded when you open the master document. 
Therefore, when you initially attach the raster file, you need to set the attachment 
as read-only in the Raster Manager dialog. Also, when opening master documents 
that have raster references, make sure you always select to copy out the rasters 
rather than checking them out. 

When copy out occurs, a small copy, the header file, of the raster is downloaded 
to your working directory. As you pan and zoom in MicroStation, the portions of 
the raster document necessary to complete the view are downloaded to a special 
cache file on your system. 

When you open a document from ProjectWise Explorer, if the document has a 
raster attached and there is no local copy of the raster in your working directory, 
ProjectWise will download a full size copy of the attached raster, rather than the 
small header file that is downloaded when performing the same action from 
MicroStation.

 How to attach a raster image to the open document:

First, in MicroStation, select File > Raster Manager. Then, in the Raster 
Manager dialog, select File > Attach. Next, from the Folder list in the 
ProjectWise's Attach Raster Reference File dialog, select the folder in which 
the document to attach is located. Select the document and click Add. They 
are set to be read-only by default. When finished adding documents, click OK. 
If you only added one document, MicroStation's Reference Attachment 
Settings dialog opens.

Working with flat sets

A flat set is a group of documents that are placed into a container for some 
purpose, such as for printing, or to simplify the check out of multiple documents 
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across folders. When you right click a flat set, you will see all of the options 
available to you for working with the flat set. When you have a flat set open, you 
can select and right click the documents in the set and perform actions on them 
just as you would from any folder in ProjectWise Explorer. 

You can place a single document into as many sets as you want. The document is 
not physically copied into the set, but a record of the document is added to the 
set. Because of this, removing a document from a set does not remove the 
document from the folder in ProjectWise in which it exists. However, deleting a 
document that is in a set will permanently delete that document from 
ProjectWise.

When you add a document to a flat set, you can specify the following.

• Whether the set will always include the active version of that document if 
additional versions of it are created after the original document is added to 
the set.

• Whether the set is always going to include the version of the document that 
was active at the time it was added to the set. 

New for (SELECTseries 4):

Note: Turn on Lock to Version if you want the version of the document that was active 
at the time it was added to always be the version included in the set.

Turn off Lock to Version if you want the active version of the document to 
always be included in the set.

Note the following when adding documents to flat sets:

The Always Use Active Version check box will be enabled if you add a 
document that has no versions, or if you add the active version of a 
document.

If the Always Use Active Version check box is enabled, the check box will be on 
or off depending on how your administrator has configured it.

The Always Use Active Version check box will automatically be disabled (and 
off) if you add an inactive version of a document.

Whenever you have a document for which the Always Use Active Version 
check box is enabled and off, the check box automatically becomes disabled 
then the next time you create a version of that document. This is because the 
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version of the document included in the set (which was formerly either a 
document with no versions, or the active version) is now an inactive version.

When you check out a flat set, all documents in the set are checked out. When 
you check in a flat set, and if you are required to enter change comments upon 
check in, you are only presented with one Check In dialog.

 How to create a flat set:

First, select Document > Set > New. Then, type a name for and description for 
the set and click OK. An empty set window opens so you can add documents. 
The title bar of the set window shows the name of the folder followed by the 
name of the set. Next, select documents from any folder in the datasource 
and drag them into the set window.

Once the first document is added, the flat set displays in the document list of 
the originally selected folder. Each document's name and status icon appear in 
the flat set's window.

Note that if you have a document selected when you create the set, the 
document is added to the set. Select Document > Set > Remove from set to 
remove documents.

Note: If you close a flat set before adding documents to it, the empty flat set will not 
be saved to ProjectWise. Further, once the last document is removed from a 
flat set, the empty set is automatically deleted.

Find a set containing a document

Opening a document set shows you which documents are in the set. You can 
reverse the process and determine which document sets, logical or flat, contain or 
reference a particular document.

 How to find all sets which reference a particular document:

First, select a document, and then select Document > Set > Referenced By. If 
the document is a member of any set, those sets are found and displayed in a 
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new window. If the document is not a member of any set, a message appears 
stating “No Documents Found.”

Working with link sets

As the name implies, the Scan for Reference Files and Link Sets wizard can be used 
to scan newly imported DGN documents for the presence of link sets. Just enable 
the option on the Specify Scan Options page. The rest of the wizard pages work 
the same as they do when scanning for references.

MicroStation link sets are supported in ProjectWise. A link set is a group of links to 
other files, models, references, and/or saved views that can be stored in a DGN 
file or a DGN library. In MicroStation, the Link Set dialog is used to create and 
manage link sets, and the Project Explorer dialog is used to create the actual links. 
In ProjectWise Explorer, link sets and their links display in the Link Sets tree under 
the project in which the link set exists. Any link sets that exist in folders that are 
not in any project are displayed in the main Link Sets tree, which is a sub-folder of 
the Documents root folder.

Using the Link Sets tree

Link sets are created in ProjectWise automatically when you create link sets in 
MicroStation in existing ProjectWise documents, or when you run the Scan for 
References Files and Link Sets wizard on newly imported DGN files that contain 
link sets. In ProjectWise Explorer, link sets and their links display in the Link Sets 
tree under the project in which the link set exists. Any link sets that exist in 
documents that are not in any project are displayed in the main Link Sets tree, 
under the Documents root folder.
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If ProjectWise is not aware of link sets in a project, then that project will not have 
a Link Sets tree. If there is no awareness of link sets existing in folders outside of 
any projects, the main Link Sets tree will not display.

You can expand any Link Sets tree to display all the link sets in that ProjectWise 
project, and the specific links in each set. Since link sets are stored in ProjectWise 
documents and contain links to other ProjectWise documents, right clicking an 
item in the Link Set tree is the same as right clicking a document in the document 
list and therefore opens the same right click menu. The options enabled on this 
menu depend on what your user settings and what your permissions are for the 
selected link set or linked document.

Note: Links sets and links cannot be created, changed, or deleted in ProjectWise 
Explorer. You must use MicroStation to perform these tasks. However, if you 
use ProjectWise Explorer to delete a DGN document that contains a link set, 
the link set also will be deleted.

Selecting the correct link set source

Link sets come from one of three sources. When you are using ProjectWise 
Explorer to check out link sets and DGN files containing link sets, it is important 
that you select the correct source in the Link Sets dialog.

• If you plan to change a link set, it is easiest to use the Selected File option as 
the source of your link set. After you select a DGN file and check it out, the 
Check In icon in the Link Sets dialog is available. You can check in changes to 
the link set, or update the server copy at any time.

• Select the Active File option if you want to check out a link set but do not need 
to save any changes to it until you check in the DGN file or update the server 
copy, you can use Active File as the source of your link set. Note that the 
Check In icon in the Link Sets dialog is gray and is unavailable. When you are 
using link sets in the active file, you cannot check in changes to the link set at 
this point because the link set resides in the open DGN file, which is not being 
Aug-12 94 The ProjectWise Explorer Client
Copyright © 2012 Bentley Systems, Incorporated



DO
 N

O
T 

DI
ST

RI
BU

TE
 - 

Pr
in

tin
g 

fo
r S

tu
de

nt
 U

se
 is

 P
er

m
itt

ed
   

   
Co

m
pa

ny
: G

eo
rg

ia
 D

O
T 

   
  C

la
ss

 D
at

e:
 1

7-
Ju

l-2
01

3

Documents
checked in yet. If you make changes to a link set in the active file, they cannot 
be saved until you select File > Update Server Copy or check in the DGN file.

• If the Configured Libraries option is the source of your link set, you will be 
unable to modify the link set at this point. This functionality is the same as if 
you were using only MicroStation to open the link set.

Checking link sets in and out in MicroStation

When you are in an integrated session of MicroStation, a Check In / Check Out 
icon appears on the Link Sets dialog. When the icon displays a blue upward arrow, 
you can either check in or update the server copy of the link set document when 
you have made changes to it. When the icon displays a green downward arrow, 
you can either check out or refresh the local copy of the link set document. The 
following are situations that cause this icon to display and activate.

• If you have the link set's DGN document checked out, a blue upward arrow, 
the Check In icon appears. Clicking the small arrow to the right of this icon lets 
you select whether to check in the DGN document or to just update the server 
copy and keep the document checked out.

• If you have the link set's DGN file open but it is not available to be checked in, 
the Check In icon is gray and is unavailable.

• If you have the link set's DGN document open and someone else has checked 
it out and made changes to it, a green downward arrow, the Check Out icon, 
appears. Clicking the small arrow on the right side of this icon lets you check 
out the DGN file or refresh the local copy.

If you have the link set's DGN file open in read-only mode, the Check Out icon is 
gray and is unavailable. All other icons on the icon bar are unavailable as well.

Note: If the link set is stored in the configured DGN libraries, an additional icon does 
not appear in the icon bar. All other icons on the icon bar are unavailable.
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 How to check out a link set or a linked document:

First, expand the Link Sets tree containing the link set or linked document you 
want to check out. Then, right click the item you want to check out and select 
Check Out. 

Once you have made changes to a link set document in MicroStation, you can 
check it in from MicroStation or you can check it in from ProjectWise Explorer. 
When you check in a link set document, you can see the changes it produces in 
the Link Sets tree in ProjectWise Explorer by refreshing the view. 

Titleblock integration

Titleblock integration allows ProjectWise to populate title block information in 
MicroStation. Once the administrator has set up title block integration, tag 
elements contained within files are automatically populated with data drawn 
from tables in the ProjectWise database.

 Exercise: Populate a title block

1 In ProjectWise Explorer, make sure you are using the Default interface.

2 In Windows Explorer, navigate to the class data set \borders folder.

3 Drag C-border.dgn to your \Designs folder, using the Advanced Wizard.

4 Enter the following on the Define Document Attributes page:

Title: Project border

DWG_No.: BSI400

Drawn By: Your student identification

5 Click Next until the final page, and then click Finish.

 Exercise: Review the data

1 Double click on C-border.dgn to open the file in MicroStation.

A message in the status bar informs you that title blocks were updated 
successfully. The title block is populated with information from 
ProjectWise.

2 Select Element > Tags > Define.

The tag set named TitleBlock contains the tags that hold the title block 
information. The individual tags hold the values.

3 Close the dialog.
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Renditions in ProjectWise Explorer
 Exercise: Update Attributes from MicroStation

1 Continuing in MicroStation, select Edit Tags from the Tasks dialog.

2 Click on the text BSI400 in the DWG NO. box. 

3 In the Edit Tags dialog, click in the Value column for the projectno tag and 
change it to BSI400-1.

4 Click OK.

5 Select Utilities > Key-in.

6 Type the following in the Key-in browser:

titleblock updatedms

7 Press Enter.

A message in the status bar informs you that the DMS value is successful. 

8 Open the Properties dialog for the file in ProjectWise Explorer.

You see that the DWG_No attribute has updated.

9 Exit MicroStation, checking the file in.

Note: Only attributes that you have write access to can be changed from ProjectWise 
or from MicroStation.

New for (SELECTseries 4):

Renditions in ProjectWise Explorer

A rendition is a visual representation of a document. When ProjectWise Dynamic 
Composition Server for PDF is installed and configured you can publish renditions 
from documents you select in ProjectWise Explorer. You can also publish 
renditions by selecting a flat set or by selecting a folder or project. All documents 
in the selected item will be processed.

When configuring jobs in ProjectWise Explorer, you will simply select an available 
rendition profile you want to use, and then select the proper destination folder. 
The ProjectWise Explorer Client 97 Aug-12
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Renditions in ProjectWise Explorer
Select Document > Create Renditions, or right click a project, folder, or flat set and 
select Create Renditions to open the dialog.

Click the More button in the dialog to set additional options. 

• Presentation specifies the presentation component that will be used when 
creating renditions. The presentation component specifies which InterPlot 
Settings file(s) to use (if any) to create renditions. InterPlot Settings files can 
define such things as the plot area, size/scale, pen table, design script, and so 
on.

• Format specifies the format component that will be used when creating 
renditions. The format component specifies the file type or types that will be 
created from the selected source files. 

• File name specifies the file name component that will be used when creating 
renditions. The file name component specifies how the newly created 
rendition documents will be named.

New for (SELECTseries 4):
Aug-12 98 The ProjectWise Explorer Client
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 Note
nting
   
     You can print documents while you have them open in their associated 
     application, or you can print them from ProjectWise Explorer.

ting from ProjectWise Explorer
 

      The type of document you select determines the way it is printed. Right click the
      document, and select Send To > Printer.

      • If you select one or more Microsoft Office documents, the documents are
         automatically printed to your default system printer.
                 

                                                

        • If you select a MicroStation and it is installed on your system, you will print
          directly from MicroStation. For AutoCAD or other document types, the Print
          Document With dialog lets you select the application. Then the document
          opens in the associated application, allowing you to adjust print settings
          specific to the files.  

      Batch Printing

         The Batch Print menu in ProjectWise Explorer is used when you want to print the 
         documents of a print set file (.pset) created in MicroStation V8i, or the documents 
         of a job set file (.job) created from earlier versions of MicroStation. 

         Just select a print set file (.pset) or a job set file (.job) and select Batch Print > 
         Print. The documents in the print set or job set are sent to the printer and printed
         according to the print set's or job set's specifications. 

: The only option on the Batch Print menu related to .pset files, is Batch Print >
 Print.
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Printing
Using ProjectWise InterPlot Organizer

ProjectWise InterPlot Organizer is an application for composing plot sets from 
DGN files, as well as a variety of raster format files. After composing a 
plot set, you can print the plot set or publish the plots to a PDF document. It lets 
you use design scripts, color tables, rendering attributes files, and settings files to 
resymbolize when creating a plot.

Files from multiple ProjectWise datasources cannot be referenced in a single plot 
set file.

Adding and creating plot sets

When ProjectWise InterPlot Organizer is integrated with ProjectWise Explorer 
Document > New > Plot Set and Document > Add To Plot Set are added to 
ProjectWise Explorer's Document menu.

Note: If you are using MicroStation V8 XM Edition with ProjectWise Explorer V8i 
SELECTseries1, you will not be able to work with plot sets.

 How to create and populate a plot set from ProjectWise Explorer:

First, use Document > New > Plot Set to create a plot set. Then, use Document 
> Add To Plot Set to add documents to the plot set. Next, use the tools in 
ProjectWise InterPlot Organizer to set up your printing parameters and 
preferences.

 How to add a ProjectWise InterPlot Organizer Plot Set File to ProjectWise 
Explorer:

There are several ways to add a ProjectWise InterPlot Organizer Plot Set file to 
ProjectWise Explorer.

• Select Document > New > Plot Set in ProjectWise Explorer

• Use ProjectWise InterPlot Organizer outside the ProjectWise 
environment to create an empty plot set file, then drag and drop it into 
ProjectWise Explorer

• Invoke ProjectWise InterPlot Organizer outside the ProjectWise 
environment and select File > ProjectWise Login to login to a 
ProjectWise datasource. You can then save the plot set file to a 
ProjectWise datasource
The ProjectWise Explorer Client 100 Aug-12
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Printing
Invoking ProjectWise InterPlot Organizer in ProjectWise 
Explorer

There are two ways to invoke ProjectWise InterPlot Organizer in the 
ProjectWise environment.

• Double click a ProjectWise InterPlot Organizer Plot Set file inside ProjectWise 
Explorer. MicroStation launches, just as if you had double clicked a DGN file, 
and the print set opens in Organizer.

• Launch ProjectWise InterPlot Organizer from the desktop and select File > 
ProjectWise Login.

Both methods let you find files in ProjectWise using ProjectWise InterPlot 
Organizer’s File > Open and File > Save dialogs. When finding files in 
ProjectWise, Browse rather than using the key-in fields. If you need to access 
files outside of ProjectWise, click the Cancel button in the dialogs. 

When you open a ProjectWise InterPlot Organizer Plot Set file in ProjectWise, 
the default behavior is that the file is checked out. It can also be copied out. 
This is controlled in Explorer by selecting Tools > Options, Settings tab, and 
setting the Document List –> Double Click Action –> Default setting. 

Files that are referenced in a ProjectWise InterPlot Organizer Plot Set file are 
copied out from the ProjectWise datasource on demand. If you are modifying 
or printing a job, only the files referenced by that job are copied out.

 ProjectWise InterPlot Organizer can detect if a ProjectWise file has been 
renamed, moved, or deleted and replaced with the same file name. In each 
case, ProjectWise InterPlot Organizer displays a dialog informing you that files 
have changed or files have been removed. ProjectWise InterPlot Organizer will 
optionally attempt to correct the problem. 

 

When you exit a ProjectWise InterPlot Organizer Plot Set file in the 
ProjectWise environment, ProjectWise checks in the plot set file but leaves 
the copied-out files in the working directory. If the user settings are set to 
Leave local copy on free, a copy of the plot set file will remain in the working 
directory along with the files that were copied out. 

Hint: A useful user setting in ProjectWise Explorer is Use up-to-date copy on copy out. 
If you double click a plot set file from ProjectWise Explorer to invoke 
Aug-12 101 The ProjectWise Explorer Client
Copyright © 2012 Bentley Systems, Incorporated



DO
 N

O
T 

DI
ST

RI
BU

TE
 - 

Pr
in

tin
g 

fo
r S

tu
de

nt
 U

se
 is

 P
er

m
itt

ed
   

   
Co

m
pa

ny
: G

eo
rg

ia
 D

O
T 

   
  C

la
ss

 D
at

e:
 1

7-
Ju

l-2
01

3

Module Assessment
ProjectWise InterPlot Organizer, files that were previously copied out to the 
working directory on a client machine will not be copied out again if they are 
up-to-date. 

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. 
Assessment is used to determine what an individual knows or can do. 

Complete the assessment to see what you have gained from reviewing this 
module.

Explorer Client Assessment
The ProjectWise Explorer Client 102 Aug-12
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Workflows, States, and 
Messaging
Module Overview

Workflows are created in ProjectWise Administrator and are assigned to folders 
and projects in ProjectWise Explorer. They guide documents through different 
milestones, known as states.

ProjectWise Messenger is used to manage email messages between ProjectWise 
users. This lets you communicate with other ProjectWise users without leaving 
the ProjectWise environment. 

This module discusses these features.

Module Prerequisites
• Familiarity with Windows Explorer

• Familiarity with the ProjectWise Explorer interface

Module Objectives

After completing this module, you will be able to:

• Assign workflows and states

• Work with ProjectWise messaging
Aug-12 103 Workflows, States, and Messaging
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Module Glossary
Module Glossary

Messaging Service: The feature which allows messages to be sent and received in 
ProjectWise Messenger

ProjectWise Messenger: The optional mechanism available on each ProjectWise 
Explorer installation for sending and receiving messages between other 
ProjectWise users, and for receiving messages generated by messaging agents in 
ProjectWise Administrator.

State: A milestone within a workflow.

Workflow: An ordered group of milestones through which a document passes on 
its way to completion.

Introductory Knowledge

Before you begin this module, let's define what you already know.

Questions

1 How do you log in to a datasource in ProjectWise Explorer?

2 How do you navigate the datasource list?

Answers

1 Launch the ProjectWise Explorer client, right click on the datasource 
name, and select Log in or Log in as. Supply your user name as password. 

2 Click the + to expand Documents. Click the + or - symbol to expand or 
collapse folders and projects.
Workflows, States, and Messaging 104 Aug-12
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Workflow Overview
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Workflow Overview

Workflows are created in ProjectWise Administrator, and are assigned to folders 
and projects in ProjectWise Explorer. They are a way to guide documents through 
various milestones, or states. States are points in a workflow such as Draft, 
Review, Approval, and so on to completion.

States in the Default Workflow

As you work on a document, you can declare when you have reached certain 
milestones by changing the state of the document. When a document has 
reached the final state in the workflow and you want to prevent any further edits 
on this document, you can place the document in final status.

   Assigning Workflows to Folders and Projects
 

en you assign a workflow to a folder or project, all documents at the root of
 folder or project inherit the assigned workflow and are automatically placed
he first state defined for that workflow. Existing sub-folders or sub-projects do

t inherit the workflow assigned to their parent folder or project. You have to
licitly assign it. New folders or projects you create will automatically be
igned the same workflow as its parent folder or project.

rcise: Assign a workflow to a folder

 In ProjectWise Explorer, right click on your \student<#>\Designs folder 
 and select Properties.

 In the Properties dialog, select the Workflow & State tab.
 The Workflow list at the top lists all the workflows defined in the 
 datasource. You see <none> because there is no workflow assigned to this
 folder. If a workflow is assigned, its name displays and the list below will 
 contain all of the states in the workflow. 

 From the Workflow list, select the Default Workflow. A message appears, asking 
 you to confirm that you want to change the workflow, setting all documents to the
Aug-12 105 Workflows, States, and Messaging
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Assigning Workflows to Folders and Projects
Changing document state

To change states of a document, its parent folder or project must have a workflow 
assigned. You must have write permissions to the document and your user 
setting, Document -> Change State, must be enabled.

While documents at the root of any given folder or project can be in different 
states, they must all share the same workflow. To change a document’s workflow, 
you must change the document’s parent folder or project workflow.

Changing a document's state can result in an email notification being sent to 
designated users if the workflow has a messaging agent assigned to it in 
ProjectWise Administrator.

 Exercise: Change state from the Folder Properties dialog

1 Continuing in the Folder Properties dialog, the Workflow & State tab, 
expand the Draft state by clicking the +.

2 Select the first file and then click the down arrow on the right side of the 
dialog to move it to the Pending Approval state of the workflow.

You can also drag and drop documents into another state.

If the audit trail Comments dialog opens because it was configured by your 
administrator, you will enter comments and click OK.

3 Click OK in the Folder Properties dialog.
Workflows, States, and Messaging 106 Aug-12
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Sending ProjectWise Messages
 Exercise: Change state from the Change Workflow State dialog

1 Select BSI400-W01-Design.dgn.

2 Select Document > Change State > Change.

The Change Workflow State dialog opens, with the selected document 
highlighted in its current state in the workflow. You can select additional 
documents, or you can select different documents to move.

3 Click the down arrow to move it to the next state of the workflow and click 
Close.

Note: You can use Document > Change State > Next and > Previous to change 
document state too.

Final status

If your user setting ‘Set final status’ is on, you can place a document in final status 
to prevent further modifications by any user, regardless of their privileges. When 
a document is in final status, the document's read/write or read-only icon is 
replaced by the final status icon. If your user setting ‘Remove final status’ is on, 
you can take a document out of final status.

 Exercise: Set a document to final status

1 Select BSI400-W01-I9NB.dgn.

2 Select Document > Change State > Set Final Status.

The document moves into final status and the final status icon replaces its 
current icon.

To take documents out of final status, first select one or more documents that are 
in final status. Select Document > Change State > Remove Final Status. When 
prompted to confirm removal of final status, click Yes. You cannot change the 
state of a document that is in final status.

Sending ProjectWise Messages 

ProjectWise Messenger is used to manage the sending and receiving of messages 
between ProjectWise users. This lets you communicate with other ProjectWise 
users without leaving the ProjectWise environment, and without the need for any 
other email application on your computer. You can attach documents and 
Aug-12 107 Workflows, States, and Messaging
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Sending ProjectWise Messages
distribute them with your message. You may want to use this feature to send your 
comments along with a document to another reviewer.

Note: ProjectWise Messenger is an optional feature of the ProjectWise Explorer 
installation.

Document links

When you receive messages with document link attachments, you can double 
click the link attachments to open the document. This checks out the document if 
you have appropriate rights and permissions on the document. You can right click 
the attachments and then work on them as you normally would from a 
ProjectWise folder.

 Exercise: Send a message with a document link

1 Continuing in ProjectWise Explorer, in your \student<#>\Designs folder, 
right click on BSI400-W01-Survey.dgn, and select Send To > Messenger. 

2 Click the To button, select another student, click To->, and then click OK.

3 In the Subject field, type Please review.

4 Click the Send button.

5 When you see the message “You have received new messages, do you 
want to read them?” click Yes.

Your Inbox opens. You can also check it by expanding your Student<#> 
folder at the root of the Documents folders and click Inbox.

6 Double click the message to open it, and then right click on the document 
and select Open to open it in MicroStation.
Workflows, States, and Messaging 108 Aug-12
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Sending ProjectWise Messages
In ProjectWise Explorer, others will see that the document is locked.

7 Exit MicroStation, freeing the document.

8 Close the message and your Inbox.

Note: You can remove a message attachment selecting it in the message and pressing 
the Delete key on the keyboard.

Sending email messages 

You can send email messages with ProjectWise documents attached, or you can 
send email messages containing links to ProjectWise documents. When you send 
a link to a user who has the same version of ProjectWise Explorer installed, 
clicking on that link will launch ProjectWise Explorer, navigate to, and select the 
appropriate document.

Microsoft Outlook’s Tools > E-mail Accounts, Use Cached Exchange Mode setting 
must be enabled for ProjectWise Explorer's Document > Send To > Mail Recipient 
As Link command to function properly. When this is not set, any text added to an 
email will not be sent by Microsoft Outlook. 

Note: See Microsoft Outlook's documentation for instructions about how to enable 
Use Cached Exchange Mode.

 How to send email messages:

First, in ProjectWise Explorer, select one or more documents and select 
Document > Send To > Mail Recipient. Your standard email client opens a new, 
untitled message with the selected document(s) attached.

You can also open your email client, create a new message, and on the 
ProjectWise tab, select Attach Document (in the case of Microsoft Outlook). In 
the dialog that opens, select the ProjectWise document(s) to attach to the 
email.

Then, select the recipient(s) for the message, type the accompanying message 
and send the message.

Using message folders

Message folders allow you to view the contents of messages sent and received 
using ProjectWise Messenger. Message folders appear in ProjectWise Messenger, 
and in ProjectWise Explorer if your user settings permit their display. 
Aug-12 109 Workflows, States, and Messaging
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Module Assessment
Each user has their own message folder, which is represented by a message icon 
and your user name. By default, your message folder contains an Inbox folder, a 
Sent Items folder, and a Global Folders folder.

When you receive a new message in your Inbox, you are notified “You have 
received new messages, do you want to read them?” Copies of messages you 
have sent through ProjectWise Messenger are saved to your Sent Items folder. 
Global folders are message folders that all users can see. Under Global Folders, if 
your user settings allow, you can create folders that all users can access, and in 
which all users can store existing messages for all to access. At the root of the 
parent message folder, you can also create private message folders for your own 
use.

You can open, reply to, forward, or delete any of these messages. You can move 
messages into any private message folders you have created, and if your user 
settings allow, into existing global folders. If a message has a link to a document 
attached, you can right click the attachment from inside the message and perform 
actions on it as you normally would on documents in a ProjectWise folder.

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. 
Assessment is used to determine what an individual knows or can do. 

Complete the assessment to see what you have gained from reviewing this 
module.

Workflows, States, and Messaging Assessment
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Executing Searches
Module Overview

The Quick Search bar lets you perform quick and easy searches for documents, 
folders, and projects. For advanced searches, the Search by Form and the Search 
Builder (Define Search) dialogs let you construct queries that are more complex. 
This module describes how to use these tools.

Module Prerequisites
• Familiarity with the ProjectWise Explorer interface

Module Objectives

After completing this module, you will be able to:

• Execute quick, general, and advanced searches

Introductory Knowledge

Before you begin this module, let's define what you already know.

Question

1 How can you tell which interface you are using and how can you change 
the interface?
Aug-12 111 Executing Searches
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Locating Documents
Answer

1 Select Tools > Interface or check the Interface options at the top of 
ProjectWise Explorer. Use the option list in either place to switch 
interfaces.

Locating Documents

You can locate documents by navigating through ProjectWise Explorer’s 
hierarchical folder structure. However, as documents can be stored in any folder 
or sub-folder, this process could be tedious.

If you do not know where a document is stored, or you need to find a document 
with a combination of attributes, you can use a search. You can search on system 
attributes, on custom attributes, or both. Note that if you search on custom 
attributes, the results of the search will only be as accurate as the data entered by 
other users.

Quick Searches

The Quick Search bar lets you perform quick and easy searches by typing the text 
you want to search by and clicking the Go arrow. The search returns all 
documents, folders and projects that match the typed text. 

Note: The Quick Search bar is also available in file selection dialogs for integrated 
applications.

Searches run from the Quick Search bar are not case sensitive, therefore they are 
not affected by the datasource setting ‘Force case-insensitive search’. This setting 
only affects advanced searches run using the Search by Form and Define Search 
dialogs.

Quick Search Settings 

Through Search Settings, you can set the extent of the search you want to run 
from the Quick Search bar. 
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Quick Searches
To open the Search Settings dialog, click the search icon in the quick search field 
and select Settings from the menu.

On the General tab, you can opt to search the entire datasource or just in the 
current folder and its sub-folders.

You can change this setting quickly by right clicking in the quick search field and 
selecting different extents from the pop-up menu. There is an option to restrict 
the search by environment here.

The History option on the General tab lets you set the number of searches you 
want to keep in history. Click the downward arrow on the right side of the Quick 
Search bar to access these.

On the Search Types tab, there are search types from which to choose. When you 
select one of the options (All Content, Full Text or Document and Folder 
Properties), you can see the parameters of the search in the right pane.
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Quick Searches
• All Content searches document names and descriptions, file names and 
extensions, the text inside documents, environment attributes, folder and 
project names and descriptions, and custom project properties.

• Full Text Search is the same as All Content, except it does not search 
environment attributes.

• Document and Folder Properties is the same as All Content, except does not 
search the text inside documents, environment attributes, or custom project 
properties.

Whenever one of these types is set, searches run from the Quick Search bar will 
search only those items specified in the search type. You can set any one of these 
to be the default search type by right clicking on it in the Search Settings dialog 
and select set as default.

Search expressions

* and %

These can be used to replace multiple characters in a text string. To use, place 
either the * or % character in front of, at the end of, or both in front of and at the 
end of your text string in the Quick Search bar.

• *.dgn finds all documents that have the extension DGN.

• overview.* finds all documents that have the file name OVERVIEW, regardless 
of file type.

• plan* finds all documents, folders and projects that begin with PLAN.

• *plan finds all documents, folders and projects that end with PLAN.

? and _
Executing Searches 114 Aug-12
Copyright © 2012 Bentley Systems, Incorporated



DO
 N

O
T 

DI
ST

RI
BU

TE
 - 

Pr
in

tin
g 

fo
r S

tu
de

nt
 U

se
 is

 P
er

m
itt

ed
   

   
Co

m
pa

ny
: G

eo
rg

ia
 D

O
T 

   
  C

la
ss

 D
at

e:
 1

7-
Ju

l-2
01

3

Quick Searches
These can be used to replace any one character in a text string.

• ?ast can produce last, past, fast, mast, cast.

and

Two separate expressions can be combined with AND in one field.

or

Two separate expressions can be combined with OR in one field.

not

Can be used with all criteria.

• NOT *pump

• NOT P01

Note: The Search by Form or Define Search dialogs are still available for advanced 
searches.

 Exercise: Run a quick search

1 In ProjectWise Explorer, click on the folder with the latest version of the 
MicroStation example files and then type the following in the Quick Search 
bar:

*seed*

2 Click the Start Quick Search arrow.

This returns all the files and folders that have seed in the name.

3 Type the following and execute for the selected folder to find only
seed files:

*seed* 

If your search was restricted to a folder, you will be prompted about 
whether you want to search it again, or search the whole datasource.
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Advanced Searches
Note: The option to ignore case sensitivity for searches is enabled or disabled by your 
administrator.

Advanced Searches

For advanced searches, the search dialog you use is mostly a matter of 
preference. The Search by Form dialog has the same interface as the Document 
properties dialog, whereas the Search Builder (Define Search dialog) may be a 
more familiar interface for users of Microsoft Office applications. 

Hint: The Define Search dialog can be used to search for documents, as well as for 
projects or folders. The Search by Form dialog can only be used to search for 
documents.

If you decide that you prefer one dialog to the other, you can set that dialog as the 
default search dialog. It will then open when you select Folder > Advanced Search, 
when you click the Advanced Search icon, or when you right click on a project or 
folder and select Advanced Search. If you do not set a default search dialog, you 
will always be prompted to select one of the two dialogs.

The search form

Search criteria can be based on any general property or environment attribute of 
a document. The general tab of the Search by Form contains system attributes. 
Each attribute has its own section.

• Document: This section sets the search criteria for a document record. You 
can search by document name and description, document version as well as 
many other system attributes.

• File: This section sets the search criteria for a physical file. The name entered 
here should be the actual file name, not the document name.

• Folder: This section will allow you to limit your search to a specific folder or 
sub-folder by name or description. You can search by the environment applied 
to the folder.

 Exercise: Use a search to find a document

1 Click Find Documents, the binoculars, next to the quick search field.

As you will use the Search Form several times, you will make it the default 
wizard.
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Advanced Searches
2 In the Select Search Definition Dialog, select Search Form, Enable the 
Make this wizard the default check box, and then click OK.

3 In the Document section, type *sheet* in the Name field.

4 In the Folder section, click the Change button to the right of “Look in”, 
select the latest MicroStation example files folder, and click OK.

5 Enable the Include subfolders check box to search them.

6 Make sure all other options are blank or display <none>.

Note: You can ensure that all the options on the General tab are blank or 
display the option <none> by clicking the Clear button.

7 Click Apply.

The system searches for documents that match the defined attributes. 
Results are displayed in the Search Results window.

Clicking Apply leaves the form in search mode. This lets you easily modify 
the search criteria if you want to refine your search. 

8 In the Document section, set the Application option to MicroStation.

If you click OK, the search is executed and the attributes of the first 
returned document are displayed in the document properties dialog 
format. You can use the arrows to page through the results.

Hint: File details can be reviewed using this method. 

9 Click OK to display results in the properties dialog format.

Use the arrows at the bottom to page through results.

10 Click Close when you are done reviewing properties.

Open folder

Once you obtain search results, it may be difficult to tell where the files are 
located. You can check the address bar for the location or you can use the Open 
Folder command.
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Advanced Searches
 Exercise: Using the Open Folder command

1 Right click one of the documents that were found in the search and select 
Open Folder from the pop-up menu.

Focus moves to the folder that contains the document. The contents of 
the folder containing the selected document are displayed in the 
document list.

The Search by Form has different tabs listing attributes on which you can base a 
search. Available fields are white. Gray fields are unavailable to the search.

When you select an attribute to search on and right click, you will be presented 
with different options depending on what type of field you have selected. 

When you select a field that is not an option list, you can open a Format Criteria 
dialog. This dialog lets you enter more complex search criteria using comparison 
operators. 

 Exercise: Use format criteria to find documents and the refine the search

1 Click Advanced Search.

In the Folder area of the General tab, the “Look in” field is blank and the 
Include subfolders check box is grayed out. This is because the form has no 
starting point for this search.

2 Click Cancel, and then click Close.

3 Right click the latest MicroStation folder and select Advanced Search.

Now the Folder area contains the path to the MicroStation folder and the 
Include subfolders check box is enabled.

Hint: When you want to search a branch of the folder hierarchy, it is easier if 
you right click the top folder and use the Advanced Search menu option. 
This automatically enters the starting point for you. If you have not 
selected a default search dialog, the Select Search Definition dialog will 
open so you can select one 

4 On the General tab in the File section, place the cursor in the File Name 
field.

5 Right click and select Format Criteria.

You can click on the browse button next to a field, too.

6 Expand the Relation option list.
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Advanced Searches
The comparison operators you can use to compare values are noted in the 
following table.

7 Select LIKE.

8 Click in the Value text box, enter the string *survey*, and then click OK.

9 Make sure all other options are blank or display <none>.

10 Click Apply.

The search will return all documents with names like survey.

11 On the General tab, in the Document section, set Updated By to your 
student<#>.

12 Click Apply.

You updated a file that has survey in its name.

13 Click OK, and then click Close.

 Exercise: Execute a relational search

1 Right click your student<#> folder and select Advanced Search.

2 In the Document section, select your student<#> from the Created By 
options.

3 Right click in the On input field that is next to the Created By options and 
select Format Criteria.

4 Set the following:

Relation: <

Expression  Comments

*, ?, %, _  Either * or % can be used for multiple wildcards. Either ? or _ 
(underscore) can be used for a single wildcard

>, >=, <, <=  > Greater than
>= Greater than or equal to
< Less than
<= Less than or equal to

NULL/
NOT NULL

 Returns Null value or excludes null values

AND  Two separate expressions can be combined with AND in one edit box

OR  Two separate expressions can be combined with OR in one edit box

NOT, <>  Can be used with all criteria

BETWEEN/
NOT BETWEEN
LIKE/NOT LIKE
IN/NOT IN

 
>= AND <= can also be used to find a range
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Advanced Searches
Value: tomorrow’s date

Specify: enable the Hours radio button

Set the Hours field to 12 AM

5 Click OK.

6 Click Apply.

The result is a list of the files that you created prior to that date and time.

7 Close the Search by Form.

If a search does not return any documents, click browse again, modify the search 
criteria to something appropriate, and execute the search again.

Printing search results

You can print documents while you have them open in their associated 
application, or you can print them from ProjectWise Explorer. By printing search 
results, you can create reports. The contents of the Search Results window can be 
printed.

 How to print the contents of the Search Results window:

First, select all of the files displayed as search results in the Search Results 
window. Then, right click and select Copy List To > Printer.
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Advanced Searches
The type of document you select determines how it is printed. If you select 
one or more Microsoft Office documents, the documents are automatically 
printed to your default system printer. If you select a MicroStation document, 
you can open it in the associated Bentley application, allowing you to adjust 
print settings specific to design files.

Hint: Before executing your search, set the View so that the columns for the attributes 
that you want to include are displayed. You may want to create a document 
view for this purpose.

Copy data to Excel

 Exercise: Create a report

1 Launch Excel.

2 Select the documents displayed as search results in the Search Results 
window.

3 Right click and select Copy List To > Clipboard Tab Separated.

4 In Excel, select the uppermost cell on the left side of the sheet.

5 Select Paste, to paste the clipboard contents into the spreadsheet.

Format or otherwise modify the data as desired. You can either print the 
results or even save into ProjectWise using the File > Save As in Excel.

6 Exit Excel.

Attributes and More Attributes tabs

These pages of the Search Form give you access to the custom attribute fields in 
your environment so you can search based on these values. Their appearance is 
controlled by the active interface.

 Exercise: Custom attribute search

1 Continuing in ProjectWise Explorer, make sure the active interface is 
Default.
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Advanced Searches
2 Right click your student<#> folder and select Advanced Search.

3 On the Attributes tab, type *BSI400* in the Title field.

4 Click Apply.

Documents fitting the criteria are listed in the document list. These are the 
documents for which you specified attributes using the Advanced 
document creation wizard.

5 Leave the Search by Form open.

It is possible to further refine your queries by using the joining expressions And 
and Or. When you link two parameters with And, your search will result in all of 
the files that meet both conditions. When you use Or, your search will result in all 
of the files that meet either of the conditions. You can use the Format Criteria 
dialog to employ operators such as Between or Like.

 Exercise: Using an or search

1 Continuing on the Attributes tab of the Search by Form, click Add OR 
Group at the bottom.

A fresh page appears for each tab.

2 On the General tab, Document section, set the Application to Microsoft 
Word.

3 Click Apply.

How many documents were found this time?

4 Click Cancel and then click Close.

Any time you add AddOrGroup pages, you can specify any attribute on any tab.

Range searches

When searching on a date or numeric field, it is possible to find all of the 
documents that fit within a range of dates or numbers.

 Exercise: Create a complex search

1 Create a search that will find all documents in your student<#> folder that 
are:

In the Pending Approval state of the Default Workflow

Where the file size is greater than 250
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Advanced Searches
2 Run the search

3 Leave the Search by Form open.

Saving searches

If you will be using a search frequently, you can save it in your personal saved 
search folder. You can then reuse it when needed by clicking on it. You may also 
find that there are global searches set up by the ProjectWise Administrator that 
all users can use. If you need additional global searches, request them from the 
administrator.

 Exercise: Save a search

1 In the Search by Form, click Saved Search at the bottom of the dialog, and 
select Save As from the menu.

2 In the Save Search dialog, select the Personal folder.

3 Enable the Saved Search Name check box and type the Saved Search 
Name:

Pending Approval

You can also select a View to use when the search results are presented.

4 Select Folder Information as the default view.

5 Click Save.

6 Click Cancel, and then click Close.

The search is saved under Saved Searches > Personal in the current folder.

 Exercise: Run a saved search

1 Under Saved Searches, expand Global.

2 Click on the global search Architecture Department documents.

A saved search runs every time you select it.

Hint: To review a saved search, select the search, right click and select Show in Search 
Form.
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Advanced Searches
The Search Builder

The Search Builder (or Define Search dialog) lets you build a search based on any 
system or custom attribute. This tool is makes it easy to create complex queries. 

 Exercise: Switch wizards

1 Open the Wizard Manager by selecting Tools > Wizard Manager. 

Since you made the Search Form the default search wizard, you need to 
change that.

2 Select the Search Definition tab.

3 Click Search Builder, click Set as Default, and then click Close.

Hint: Regardless which wizard is the default, you can access the other tool by clicking 
on the arrow next to the Advanced Search icon on the Quick Search bar and 
selecting it.

Use the Define criteria section of the Define Search dialog to add boolean 
statements to the Find documents that match these criteria section.

• Criterion Type: Select general properties, full text, file properties, or 
environment attribute.

• Property: Select the property to be used in a statement.

• Environment: Select the environment from which to select custom attributes. 
Options vary depending upon the criteria type selection.

• Attribute: This selection is available when selecting Environment Attribute > 
Environment. It lets you select a custom attribute.

 Exercise: Search for a similarly named files

1 Right click on your student<#> folder and select Advanced Search.

The first criteria are already entered. “In folder student<#> or in any 
subfolder.”

2 In the Define Search dialog, set the following:

Look for: Documents

Criterion Type: Environment Attribute

Environment: Titleblock

Attribute: Drawn By

Value: your student<##>
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Advanced Searches
3 Click Add Criteria.

4 Click OK.

You can double click on a criterion that has been added and the Define Criteria 
area will populate. You can then modify as desired and click Add Criteria to update 
the search criteria.

 Exercise: Create a complex search

1 Right click on your student<#> folder and select Advanced Search.

2 Set the following:

Look for: Documents

Criterion Type: General Properties

Property: Created By

Value: select your login from the list

3 Click Add Criteria.

This searches for documents created by you.

4 Now set the following:

Property: Application

Value: MicroStation

5 Click Add Criteria.

This narrows the search to MicroStation files that were created by you.

6 Click Add OR Group.

This is where you add an Or condition.

7 Now set the following:

Criterion Type: Environment Attribute

Environment: standard 

Attribute: revno

Value: 2

8 Click Add Criteria.

9 Click Apply.

How many documents were found?
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Project Searches
Project Searches

You can search projects and every project contains its own Saved Searches folder. 
Using the Define Search dialog, you can create a search that specifically looks for 
projects, as opposed to a search the looks for documents. When searching for 
projects, you can search based on any general property of the project, any custom 
project property, or any project type.

Create project-aware saved searches using either the Search by Form dialog or the 
Define Search dialog. These searches are defined to search for documents, 
starting from the project in which the search itself is saved. When you copy a 
project-aware saved search to another project, the search path of the new saved 
search is updated to reflect the project to which it was copied.

You can create searches from anywhere in the datasource and save them to the 
Global or Personal folder under any project’s Saved Searches folder. You can copy 
saved searches from one project to another, or from a project to the main Saved 
Searches folder.

You can set up a search that looks for all projects associated to a particular project 
type in the Define Search dialog by setting the Look for option to Projects and 
Folders. Set the Criterion Type to Project Type and select a project type. The Type 
list contains all of the project types currently defined in the datasource in 
ProjectWise Administrator.

When you run the search, any projects that have the selected project type 
associated to them are returned.
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Notes About All Searches
Finally, click the Add Criteria button, and click OK to launch the search 
operation.

If the Use MicroStation Fence option is always disabled when defining spatial 
search criteria, it is because either the active MicroStation document does not 
have a spatial location in ProjectWise, or there is no fence defined in 
MicroStation. If there is no fence defined, adding a fence in MicroStation 
should fix the problem. If a fence is defined and the toggle is still disabled, a 
spatial location should be assigned to the document in ProjectWise to enable 
this feature.

Notes About All Searches

Warning: All documents, folders, and projects that match your search criteria are returned, 
with no regard for their hierarchy in the datasource. These are the actual items, 
not just links to them, so be careful not to accidentally delete something from the 
Search Results window.

Documents, folders or projects that match your search criteria, but to which you 
do not have access, will not appear in the Search Results window when you run a 
search.

The text you type in search fields may or may not be case sensitive, depending on 
whether or not your administrator enabled the option in the datasource to 
enforce case sensitivity for searches.

Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. 
Assessment is used to determine what an individual knows or can do. 

Complete the assessment to see what you have gained from reviewing this 
module.

Executing Searches Assessment
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Settings and Utilities
Module Overview

This module explains how to use priority and proximity searches when scanning 
for references and how to scan for and use link sets. It also discusses scanning for 
spatial locations.

The Local Document Organizer and parallel installations are also discussed.

Module Prerequisites
• Familiarity with Windows Explorer

• Familiarity Microsoft Office applications

• Familiarity with the ProjectWise Explorer interface

Module Objectives

After completing this module, you will be able to:

• Use the Local Document Organizer
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The Local Document Organizer
.

The Local Document Organizer

This utility is used to list and manage the documents that you currently have 
checked out, copied out, or exported. You can configure Local Document 
Organizer to open automatically when you log out of a datasource if there are still 
documents checked out or exported, using the user setting, User Interface -> 
Show Organizer on log out. This lets you see the status of the files you have been 
working with at the end of a day.

The Local Document Organizer dialog always opens with the View set to display 
Checked Out Documents. The actions you can perform depend on the view icon 
that is active.

In the first image the Checked Out icon is active, in the second the Copies icon is active
The third icon is the Exported icon

When the organizer opens, the default display shows the files that you have 
checked out. This is indicated in the tool bar at the top.

You can select multiple documents in the Local Document Organizer's file list and 
apply a command to all of them simultaneously.

 Exercise: Open the Local Document Organizer

1 Open your \student<#>\Designs folder.
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The Local Document Organizer
2 Select all documents in the document list except the Final Status 
document.

3 Right click and select Check out.

4 Select the Local Document Organizer tool on the Standard tool bar at the 
top of ProjectWise Explorer.

You can sort the contents by Datasource or by the system on which documents 
reside. The body of the dialog has columns that provide information about the 
documents. You can right click on a document and select Open Containing Folder 
to move to the folder containing the document.

Applying commands

You can select multiple documents in the organizer window and apply a command 
to all of them simultaneously. You can filter the list of documents by the 
datasource from which they are checked out, exported, or copied. When a file is 
selected, additional tools are available.

• Update Server Copy updates the copy of the document in the storage area on 
the server with the copy currently on your local system. The status of the 
document does not change, it remains checked out.

• Check In Leave Copy copies the document back to the central storage area and 
makes it available to other users. This option retains the local copy. This is the 
best choice for using delta file transfer which only transfers changes that have 
been made to documents, rather than the whole document. It begins working 
when it sees a file with the same name in your working folder.

• Free Leave Copy changes the status of the document to checked in without 
copying it back to the server. This option retains the local copy. 

• Free changes the status of the document to checked in, without copying it 
back to the server. This option deletes the local copy.

 Exercise: Check in and free documents

1 Select some of the documents in the Organizer.

2 Click Check In - Leave Copy.

3 Enter an appropriate comment.
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The Local Document Organizer
4 Click OK.

The files are checked in. 

5 Select the remaining documents in the Organizer.

6 Click Free.

The remaining documents are freed.

Copies

When Copies is selected and a copied out file is selected, the Copy options are 
activated.

• Check out changes the status of a copied out document to checked out 
without copying the document from the central storage area.

You can use this while the document is open in an application, as no files are 
transferred and the status of the document is only altered in the database. 
Use this function if you have accidentally made changes to a document that is 
not checked out. You will not be able to lock a document which is currently 
checked out to another user, or one which has been checked in by another 
user since you copied the document out (if the server copy is more recent 
than the local copy).

• Refresh Copy means refresh the local copy with the copy of the document 
held in the central storage area on the server.

• Purge Copy removes the copy of the file from the working directory.

 How to remove copies of documents from your hard drive:

First, click the Copies icon so that the list of documents copied out to your 
working directory displays. Then, select all the document copies. Next, click 
Purge and the copies are removed.

Working with exported files

When the Exports icon is selected, a list of any files that have been exported 
outside of ProjectWise will display. Select an exported file and the available 
options display.
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Error Descriptions
• Import imports the files from the location where they were exported and 
releases the lock.

• Import From lets you browse to another location in case you have moved the 
file.

Note: When you import it is important that you keep track of the directory that you 
used for export, and make sure that you put the updated files back into that 
directory.

Warning: Always use the Local Document Organizer. Never clean up your hard drive by 
deleting files directly from your working directories. ProjectWise keeps track of 
which files have been copied out or exported. Deleting these files directly may 
cause the loss of data.

Workspace copies

If you click the Workspace Copies icon, you can see all workspace documents that 
are currently copied out due to opening a document that has a managed 
workspace associated.

Error Descriptions

Enter a ProjectWise Error code into the Display Error Descriptions dialog to 
generate a description of an error. It will be a brief description of the error, so for 
more information, contact your ProjectWise administrator.

 How to generate a description of an error code:

First, select Start > Programs > Bentley > ProjectWise V8i > Tools > User Tools 
to open the ProjectWise Tools dialog. Then, select the Error Descriptions tool 
and click Execute. Next, enter the error code generated in ProjectWise 
Administrator or Explorer and click Show.

You can directly copy error messages and paste them into documents or e-mails 
for troubleshooting.
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Module Assessment
Module Assessment

Assessment is often equated with evaluation, but the two concepts are different. 
Assessment is used to determine what an individual knows or can do. 

Complete the assessment to see what you have gained from reviewing this 
module.

Settings and Utilities Assessment
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