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Introduction 
 
Objective 
 
Introduction to InRoads for Design consists of 14 labs with the following objectives. 
 

Lab Objectives 
 
 Lab 1:  Start InRoads and Set Project Defaults 
 Lab 2:  Starting a Project 
 Lab 3:  Horizontal Alignments 
 Lab 4:  Vertical Alignments 
 Lab 5:  Importing MicroStation Graphics and Placing Curve Tables 
 Lab 6:  Profile Sheets 
 Lab 7:  Component and Template Creation 
 Lab 8:  Introduction to the Roadway Designer 
 Lab 9:  Cross Section Sheets and Annotation 
 Lab 10:  Construction Limits 
 Lab 11:  Earthwork 
 Lab 12:  Required R/W 
 Lab 13:  Survey Enhancements 
 Lab 14:  InRoads Style Sheets 
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 Lab Format Standards 
 
In the following labs, user input and action will be displayed in bold type.  You will be 
instructed to either type-in information, click on a command or button, or press a particular key 
or function button.  When instructed to click on something, you will need to press on the left 
mouse button and then release it.  When instructed to double-click, you will need to quickly 
press the left mouse button twice in rapid succession and then release it.  Additionally, the  
symbol is used to designate successive pull down menus.  ie. FileSave.  If the lab asks you to 
press a particular key on the keyboard -- Key strokes will be displayed in < > brackets (ie.  
<CTRL> or <F4>). 
 
The lab format will be as follows: 
 
Step 
Number 

The top line will display the instructions or the user input.  The user actions will be 
displayed in the format described above. 
 
The bottom line will be in italics and will indicate the system response.  It will also 
display some additional information regarding the process you have just performed. 

 
 

         Note: 

    Each step of the lab depends on a previous step, so please read   
    everything carefully and DO NOT skip any steps. 

 
 
 
 
InRoads and MicroStation Delineation 
 
In the following labs, the user will be working in both the InRoads Design Software and the 
MicroStation CADD Software.  The InRoads Software is the database in which the surveying 
data is created and processed.  The MicroStation CADD Software is used for the viewing and 
manipulation of graphics derived from InRoads.  
 
In order to differentiate between the two software(s) the following symbolization will be utilized: 
 

InRoads Software  User performs steps in InRoads 
MicroStation Software  User performs steps in MicroStation 
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Lab 1 
Start InRoads and Set Project Defaults 

 
Objective 
 
The recommended File Structure for InRoads is a Project Folder (which is named for the PI # of 
the Project – Example: 1234567) located as a sub-folder under C:\InRoads Data – Example: 
C:\InRoads Data\1234567).  This Project Folder will contain the individual InRoads Data Files.  
Some Examples of InRoads Data Files are: 
 
1. PI#.DTM ------ (Digital Terrain Model File) – contains Surface data 
2. PI#.FWD ------ (Survey File) – contains Field Survey data 
3. PI#.ALG------- (Geometry File) – contains Geometric Point, Horizontal and Vertical data 
4. PI#.IRD ------- (Roadway Design File) – contains the Design Surface data 
5. PI#.RWK------ (Project File) – contains project data for InRoads files in ASCII format 
6. PI#.ITL-------- (InRoads Template File) – contains InRoads Templates for cross-sections 
7. PI#.SDB------- (Drainage File) – contains the InRoads Storm and Sanitary data   
 

 
  
 
 
 
 
The objective of Lab 1 is to: 
 

• Create a Project Folder 
• Start InRoads 
• Set the InRoads Project Defaults 
• Set Design Default Preferences 
• Set the InRoads “Locks” 
• Add the Application and Variable Manager Add-Ins 

 

 
 
 
 
 

It is highly recommended to backup the Project Folder (which contains these individual 
data files) after each work session to your Group Account on the GDOT Server if you are a 
GDOT Employee (or to an appropriate Business Server if you are a GDOT Consultant).  
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Lab1A Create a Project Folder & Copy Lab Project Files 
 
In this section of the lab you will be creating a folder or directory.  This folder is where your 
projects and all of your InRoads project data files will be located.  The newly created InRoads 
project directory will be (C:\InRoads Data\PI#).  This is the recommended file structure for 
InRoads projects.  (For this tutorial only -- you will also copy the “Design Lab” Files to this 
folder in order to access the InRoads “1234567” Lab Files.)  
 
1.  From the desktop, double-click on the My Computer icon.  

 
This will open the My Computer dialog box.  This is your computer’s file manager.  Via 
this dialog box, you may view the content of your computer’s various hard-drives.   

2.  Double-click on the C: directory (also referred to as folder or drive). 
 
This will open the C: directory box, listing the contents of the C: drive. 

3.  If the C: directory does not contain a folder named InRoads Data -- create the folder. 
 
Creates folder InRoads Data under the C: drive. 

 

 
Figure L1-1 InRoads Project Folder In C:\ directory 

 
4.  Using Windows Explorer, create a new folder under InRoads Data and name it 

1234567. This is the project folder you will use for the Lab Lessons (C:\InRoads 
Data\1234567).   
 
Creates folder 1234567 under C:\InRoads Data. 

5.  Using Windows Explorer, copy the folder Design Labs from C:\ to (C:\InRoads 
Data\1234567).   
 
Places the Design Labs in C:\InRoads Data\1234567 
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Figure L1-2 Folder Design Labs in the C:\InRoads Data\1234567 folder 
 
 

6.  Close the Explorer window by clicking on the          in the upper right-hand corner of the 
window. 
 
This will close the Explorer window. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 Introduction to InRoads- Design  InRoads SS2- Lab 1 

   
 Lab1-4   

Lab1B Start InRoads 
 
In this section of the lab you will be opening MicroStation V8i Select Series 2 in the ‘GDOT 
Corporate Workspace’ and InRoads Suite V8i Select Series 2. You will also select a “seed” file 
to use for the “Working” DGN file.  This “Working” DGN file is used to display the temporary 
and/or permanent graphics in InRoads.  MicroStation is opened first and then InRoads is 
opened from the MicroStation Menu bar. 
 
7.  From the desktop, double-click on the GDOT MicroStation V8i SS2 (x86) icon.   

 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open. 
 

• Now open InRoads from within MicroStation by selecting:  
InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
After the MicroStation Splash Screen appears, the MicroStation Manager dialog (See 
Figure L1-3) will open so that you can select a “Working” DGN file.   Once InRoads 
and MicroStation are up and running, your desktop should look similar to that of Figure 
L1-4 and Figure L1-5. 

  

 
Figure L1-3 Starting MicroStation V8i and InRoads Suite 

 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86)  
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Figure L1-4 Main MicroStation V8i Window 

 
  
 
 
 
 
 
 
 
 
 

Figure L1-5 Main InRoads V8i Window 
 
 
 
8.  As mentioned previously - you will be working in both the InRoads Design Software 

and the MicroStation CADD Software.  The InRoads Software is the database in 
which the Design data is created and processed.  The MicroStation CADD Software is 
used for the viewing and manipulation of graphics derived from InRoads.  
 
Please review the diagram depicted below for a brief overview of the InRoads Explorer 
Interface: 
 
Details the components of the InRoads Explorer Interface. 
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• Workspace Bar – Contains all of the InRoads Project Data information   
• Menu Bar – Contains the pull-down menus to access InRoads commands  
• Toolbars – Contains default and customized toolbars to access InRoads commands 
• Feedback Pane – Contains details of selected Project Data from the Workspace Bar 
• Scroll Bar – Enables the user to view more of the InRoads Explorer Interface. (The 

Scroll Bar may not be visible if the InRoads Interface is already viewed to extents). 
• Status Bar – Contains InRoads messages and prompts (Please note:  InRoads may direct 

you to locate something graphically in MicroStation -- some of these prompts may 
display in the MicroStation Status Bar instead).  It is very important that the user review 
both the InRoads and the MicroStation Status Bar for prompts and information. 

  

Menu Bar 
Workspace 

Bar Toolbars 
Feedback 

Pane 

Status Bar Scroll Bar 
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Lab1C Set InRoads Project Defaults 
 
The InRoads Project Defaults setting allows you to define the “default folder locations” for 
projects.  A Project Default configuration can then be saved for each project so that multiple 
projects can be accessed.  This configuration allows you to easily navigate between projects. 
Once the Project Folder locations are saved in the Configuration, the projects can be accessed by 
selecting the appropriate Project Configuration Name.  The Project Defaults also contains the 
location for selecting the standard GDOT InRoads Preference File (GDOT_Standard 
V8i_SS2.xin). 
 
 
 
 
 
 
9.  Click FileProject Defaults from the InRoads pull-down menu.   

 
 
The Set Project Defaults dialog box appears.  Each Project will require an individual 
setup as detailed in the following steps.  

10.  Click New and enter 1234567_Design in the New Configuration dialog box.  
Then click OK. 
 
 
The New Configuration dialog box will appear.  After entering in the Project Name and 
clicking OK – a new configuration will be created that is named 1234567_Design. 

11.  Under the Default Preferences section - Click in the Preferences (*.xin): field and then 
click the Browse button to navigate to the following file:  
 
 
C:\InRoads Data\1234567\Design Labs\Standards\GDOT_Standard V8i_SS2.xin.  
Select the GDOT_Standard V8i_SS2.xin file and click Open.  
 
 
The GDOT_Standard V8i_SS2.xin file is added as the Project Preference File. 

12.  Under the Default Directory Paths Section - Click in the Project Default Directory: 
field and then click the Browse button to navigate to the folder:  
 
 
C:\InRoads Data\1234567\Design Labs\.  Next - click Open. 
 
 
 
 
The Current Configuration for the 1234567 project will now default to the following 
path: C:\InRoads Data\1234567\Design Labs.   
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13.  Under the Default Directory Paths Section – copy and paste the following text into each 
entry field shown below: C:\InRoads Data\1234567\Design Labs\  
 
• Report Directory:  

C:\InRoads Data\1234567\ Design Labs \ 
• Projects (*.rwk):  

C:\InRoads Data\1234567\ Design Labs \ 
• Surfaces(*.dtm):  

C:\InRoads Data\1234567\ Design Labs \ 
• Geometry Projects:(*.alg): 

C:\InRoads Data\1234567\ Design Labs \  
• Template Libraries:(*.itl):  

C:\InRoads Data\1234567\ Design Labs \ 
• Roadway Design: (*.ird):   

C:\InRoads Data\1234567\ Design Labs \ 
• Survey Data: (*.fwd):  

C:\InRoads Data\1234567\ Design Labs \ 
• Drainage: (*.sdb):  

C:\InRoads Data\1234567\ Design Labs \ 
• Quantity Manager: (*.mdb):  

C:\InRoads Data\1234567\ Design Labs \ 
• Site Modeler Projects: (*.gsf):  

C:\InRoads Data\1234567\ Design Labs \ 
 

The Configuration for the 1234567 project will now default to the path listed above. 
14.  Under the Default Directory Paths Section - Click in the Style Sheet (*.xsl): field and 

then click the Browse button to navigate to the folder:  
 
C:\InRoads Data\Style Sheets\GDOT\.  Next - click Open. 
 
The Current Configuration for the Style Sheets will now default to the following path: 
C:\InRoads Data\Style Sheets\GDOT\.   

15.  The Project Defaults should now correspond to the screen capture depicted in  
Figure L1-6 (as shown below).  Verify to ensure that your 1234567 Project Defaults 
match the inputs in the screen capture.   
 
The Project Default Fields are verified for accuracy.    
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Figure L1-6 Set Project Defaults 

 
 
 

16.  Click Apply and then click Close. 
 
The Set Project Defaults dialog box will close and the settings for this configuration of 
Project 1234567_Design will be the default settings until the configuration is changed to 
another Project.  This folder location will also be the default folder when FileSave and 
FileClose are used.   

Ensure that the 
“Preferred Preference” 
is set to “Design 
Default”. 
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Lab1D Set Design Default Preferences 
 
 The Design Default Preferences must be loaded in InRoads in order to conform to standards for 
the processing of Design Projects.  This is a very important step to ensure that standards are 
followed for any Design data that will be processed. The Design Default Preference loads the 
Precision Settings, Tolerances, Units and Formats, etc.  Once the Design Default Preference is 
loaded – the project will retain these settings each time the project is accessed.  
 
17.  Click File Project Options from the InRoads pull-down menu to access the Project 

Options dialog box.   
 
The Project Options dialog box appears.    

18.  In the Project Options dialog box - click on the General Tab.   
 

      
  
 
 
 
The General Tab dialog box appears.   

19.  In the General Tab dialog box click the command button named Preferences… 
(Located at the bottom of the dialog box). 
                            

         
 
 
 
 
 
 
 
 
The Preferences dialog box will open. 

20.  In the Preferences dialog box – select Design Default.  Then click Load and then click 
Close.  
 
The Design Default Preference will be loaded. This will load the appropriate data for 
ALL of the tabs in the Options dialog box. The individual tabs (Tolerances, Geometry, 
Units and Format, etc.) will automatically be configured for use in Design. These 
individual tab options will NOT need to change. Once the Design Default Preference is 
loaded – the project will retain these settings each time the project is accessed.    

General Tab 
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21.  Important Information: 
 
In the Project Options dialog box - click on the Geometry Tab.   

 
Notice in the image at right, the 
Seed Alignment Name: and Seed 
Point Name: 
default settings of DE1 and 
DE10000.  These  
values were set when the Design 
Default Preference was loaded in 
the preceding step. 

 
These settings are of particular importance 
to the Designer.  Alignments must have a DE 
prefix.  Points must also have a DE prefix  
as well as numbering starting at 10000.  In order for  
survey enhancements to be properly added during  
the design phase of a project, it is essential that  
Designers pay particular attention to this setting.  
DE stands for design. 
 

22.  Click back to the General Tab.   
 
 
The Design Default Preference should now correspond to the screen capture depicted in  
Figure L1-7 (as shown below).  Verify to ensure that the Project Options dialog box for 
Project 1234567 matches the inputs in the screen capture.   
 
The Project Options are verified for accuracy.    
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Figure L1-7 Design Default Settings 

 
 

23.  Click Apply and then click Close. 
 
The Project Options dialog box will close and the Design Default Preference for this 
configuration of Project 1234567 will be the default settings until the configuration is 
changed to another Project.   

  

Ensure that the  
“Refresh Command 
Settings on Preference 
Change” is checked: 
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Lab1E  Set InRoads “Locks” 
 
 InRoads contains several “Locks” which are used by many InRoads commands to control 
different aspects of the selection and viewing of data as well as the reporting of data.  There are 
basically two types of “Locks” – On/Off “Locks” and Switch “Locks”. (Switch “Locks” contain 
different modes but one mode is always active and the user can switch between modes). Both 
types of “Locks” can be changed by the user as the situation dictates during the course of the 
database generation.  These locks affect many commands – so it is very important that the user 
understand the use of these locks.    
 
The following Lab contains a brief overview of some of the InRoads “Locks”.  These “Locks” 
must be set according to the following Lab --- (Lab1E) ---- for the use in upcoming Labs. This is 
a very important step to ensure that the “Locks” are set accordingly.     
 
24.  Click ToolsLocks from the InRoads pull-down menu.   

 
This command accesses the available InRoads “Locks”. Each time a “Lock” is changed 
– the pull-down menu will close and the user must click on ToolsLocks again to access 
the Locks pull-down. 

25.  Ensure that the following locks are selected/unselected as appropriate: 
 
Feature Filter        _____ Unchecked   
 
Feature Highlight         __ Unchecked 
 
Style         ____________ Unchecked 
 
Pencil/Pen        ________ Set to Pencil 
 
Delete Ink    ________ Unchecked 
 
Locate         ___________Set to Features 
 
Point Snap        ________ Checked 
 
Element Snap        ______Unchecked 
 
Station        ___________ Unchecked 
 
Report          __________ Checked 
 
Cogo Audit Trail         __ Unchecked 
                             
Toolbar            ________ Checked 
 
The InRoads “Locks” are set accordingly. 
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26.  Following is a brief overview of the “Locks”: 
 
 Feature Filter   
 displays or obscures Surface Features based on a filter (also controls Survey Style Filter) 
 
Feature Highlight 
 highlights the feature in plan view when selected from a list 
 
Style 
 determines if a dialog box is displayed for a surface command or cross sections 
 
Pencil/Pen   
controls the redisplaying of Graphics 
 
Delete Ink  
allows redisplayed graphics to replace graphics in pen mode 
 
Locate    
controls if Locate Buttons snaps to Graphics or Features 
 
Point Snap   
 controls the ability to snap to points in Geometry Project 
 
Element Snap 
controls the ability to snap to elements in Geometry Project 
 
Station   
controls the Stationing as it pertains to Cross Sections 
 
Report  
controls if Report is displayed or not displayed in a dialog box    
 
Cogo Audit Trail  
controls the reporting of coordinate geometry results to a text file 
                          
Toolbar 
displays or turns off the Locks Toolbar 
 
Describes a “brief” overview of the InRoads “Locks”. 

 
 
  
 
 
 
 



Introduction to InRoads- Design  InRoads SS2- Lab 1 

   
 Lab1-15   

Lab1F Add Application and Variable Manager Add-Ins 
 
InRoads contains several Application and Variable Manager “Add-Ins” which must be selected 
and added to the InRoads Program in order to access the standard GDOT customized menu 
applications/translators for Survey.  Once the Application and Variable Manager Add-Ins are 
selected – the settings are written to registry keys in the user’s profile.  This ensures that each 
time InRoads is accessed in the user profile -- these settings will already be available. These add-
ins will only need to be added once and will then be accessible in all of the InRoads Modules and 
InRoads Projects.   
 
The following Lab contains a brief overview of the InRoads “Application and Variable Manager 
Add-Ins”.   These “Application and Variable Manager Add-Ins” must be set according to the 
following Lab --- (Lab1F) ---- for their use in upcoming Labs. This is a very important step to 
ensure that the “Add-Ins” are set accordingly.     
 
 
27.  The Application Add-Ins will be selected: 

 
Click ToolsApplication Add-Ins from the InRoads pull-down menu and the following 
dialog box will appear:   
 

 
 
 Select the following Application Add-Ins by clicking an         by the appropriate Add-In:  

        
 
 
The InRoads “Application Add-Ins” are selected accordingly.   



 Introduction to InRoads- Design  InRoads SS2- Lab 1 

   
 Lab1-16   

28.  Click OK to accept the settings and to close out of the dialog box. 
 
The Application Add-Ins dialog box will close and the selected Application Add-Ins will 
be available for use.  

29.  Next the Variable Manager Add-Ins will be selected: 
 
Click ToolsVariable Manager from the InRoads pull-down menu and the following 
dialog box will appear:   
 

 
 
Select the following Variable Manager Add-Ins by clicking an         by the appropriate 
Variable:  
 

 
 
The InRoads “Variables” are selected accordingly.   

30.  Click Apply to accept the settings and then click Close to close out of the dialog box. 
 
The Variable Manager dialog box will close and the selected Variables will be available 
for use. 

31.                    
                 This concludes Lab 1.  Do not proceed until the Instructor directs you to do so. 
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Lab 2 
Starting a Project 

 
Objective 
 
The Designer will receive from the SDE (Survey Data Engineer) some or all of the following 
eight electronic files. These files will be made available for copying from SDECommon. 
 

1. PI#_SDE.alg (InRoads Geometry file) 
2. PI#_SDE.dtm (InRoads Digital Terrain Model) 
3. PI#_TOPO.dgn (Existing Topo features) 
4. PI#_PROP.dgn (Existing Property Information) 
5. PI#_UTLE.dgn  (Existing Utility features) 
6. PI#_PSR.xls or .psr or .mdb (Property Statistics Report) 
7. PI#_Hydraulics.docx (Hydraulics report) 
8. PI#_Misc.txt (Miscellaneous information SDE deems important.  This file may not be 

included.) 
 
The Designer will create a folder called ‘SDE’ under the PI# folder on the group account and 
copy these files to it for backup.  The Designer is not to work directly from these files but from 
copies of them. 
  
The objective of Lab 2 is to: 
 

• Copy and rename the PI#_SDE.alg to PI#_Design.alg externally and internally. 
• Copy and rename the PI#_SDE.dtm to PI#_Exist.dtm externally and internally. 
• Copy and rename the DGN files from the SDE folder. 
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Lab 2A Copy the Survey Files from the SDE folder to the InRoads 
Data folder and rename Externally 

 
In Lab 2A you will copy 1234567_SDE.alg, 1234567_SDE.dtm, 1234567_TOPO.dgn, 
1234567_PROP.dgn, & 1234567_UTLE from the Survey Data (SDE) folder to the proper 
InRoads Data folder for use in this Lab. 
 
1.  From the desktop, double-click on the My Computer icon. 

 
This will open the My Computer dialog box.  This is your computer’s file manager.  Via 
this dialog box, you may view the content of your computer’s various hard-drives.   

2.  Navigate to C:\InRoads Data\1234567\Design Labs\Lab 2\SDE\.  The 1234567_SDE.alg 
and 1234567_SDE.dtm files (as well as the associated DGN Files) which are provided by 
survey will be in this folder for use in this Lab. 
 
The 1234567_SDE.alg and 1234567_SDE .dtm files as well as the associated DGN files 
will normally be copied from SDECommon by the Designer to the group account SDE 
folder first for backup.  The SDE folder in this step is to mimic the SDE folder on the 
designers’ group account. 

3.  Copy 1234567_SDE.alg & 1234567_SDE.dtm (and) 
Copy the DGN files -- 1234567_TOPO.dgn, 1234567_PROP.dgn, & 
1234567_UTLE.dgn 
 
     From: C:\InRoads Data\1234567\Design Labs\Lab 2\SDE 
     To:     C:\InRoads Data\1234567\Design Labs\Lab 2\ 
 
After Copying the DGN files– Rename the DGN Files in Windows Explorer: 
 

• Rename 1234567_TOPO.dgn to 1234567TOPO.dgn 
• Rename 1234567_PROP.dgn to 1234567PROP.dgn 
• Rename 1234567_UTLE.dgn to 1234567UTLE.dgn 

 
For Information Only: 
The DGN Files received from the SDE contain an underbar (_) in the file name. The reason 
for this is to assist in differentiating DGN data received from the SDE from the Design 
DGN files.  This will assist in organization of data during the enhancement processes. 
 
The Designer must rename the DGN files from the SDE naming convention to the Design 
naming convention in order for the MicroStation customized Macros to function correctly 
and to conform to the current EDG (Electronic Data Guidelines). If the Designer does not 
rename the DGN files (and remove the underbars) as depicted above – the GDOT 
MicroStation Macros may not function.  

 
The recommended folder path for the Designer to follow when working in InRoads is 
C:\InRoads Data\PI#.   This is documented in the InRoads Design Guidelines. 
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4.  In Windows Explorer -- Rename the file called 1234567_SDE.alg which is located in 
C:\InRoads Data\1234567\Design Labs\Lab 2\1234567_SDE.alg to the following: 
 
1234567_Design.alg   
 
In Windows Explorer -- Rename the file called 1234567_SDE.dtm which is located in 
C:\InRoads Data\1234567\Design Labs\Lab 2\1234567_SDE.dtm to the following: 
 
 1234567_Exist.dtm.   
 
This may be accomplished by right mouse clicking over the file(s) and selecting Rename. 
 
*NOTE: Although you have now renamed the file it is only renamed Externally.  It must 
still be renamed internally to InRoads as will be demonstrated later.   
 
The file naming convention for the InRoads Geometry Project and the InRoads Surface 
when in the design phase of a project is 1234567_Design.alg and 1234567_Exist.dtm. This 
is documented in the InRoads Design Guidelines. 
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Lab 2B Open the 1234567_Design.alg and rename Internally 
 
In Lab 2B you will open InRoads, open 1234567_Design.alg and rename the internal 
1234567_SDE project name to 1234567_Design. 
 
5.  Starting Clean  

 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

6.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the “GDOT 
3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ is 
documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

7.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Click Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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8.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design which 

you created in Lab 1. 
• Verify Settings match those shown in Figure L2-1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

 

 
Figure L2-1 Project Defaults 

 
9.  Open the 1234567_Design.alg Geometry file. 

 
• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 2\ 
• Highlight 1234567_Design.alg 
• Click Open and then click Cancel. 

 
The 1234567_Design.alg file is opened. 
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10.  Make the InRoads Geometry tab the active tab 
 

• In InRoads, Right mouse click  
over any of the tabs in the  
Workspace Bar and select  
Geometry. 

• Verify your view matches that 
shown in Figure L2-2 and that 
the Geometry tab is the active 
tab showing the Geometry  
Projects. 
 
 
** NOTE: Even though you opened 1234567_Design.alg, 1234567_SDE is 
showing as the active geometry project.  Even though we changed the Name of the 
file externally, InRoads retains the project name internally and must also be 
changed internally to match. 

 

 
Figure L2-2 Main InRoads Window 

 
11.  Change the Internal Project Name from 1234567_SDE to 1234567_Design. 

 
• Select Geometry ► Rename Geometry.  The Rename Geometry dialog opens.  

The Rename Geometry command may be used to rename a Geometry Project, 
Horizontal Alignment or Vertical Alignment. 

• In the Rename Geometry dialog make the entries as shown in Figure L2-3. 
• Click Apply and answer Yes to rename the Geometry Project. 
• Click Close to exit the Rename Geometry dialog. 
• In the InRoads workspace bar verify that the Geometry Project is now renamed 

1234567_Design as shown in Figure L2-4. 
 

The internal file is renamed to 1234567_Design.alg. 

Workspace 
Bar 

Right mouse 
click over any 
of these tabs to 
easily switch 
to any of the 
other tabs. 
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Figure L2-3 Rename Geometry 

 
 

 
Figure L2-4 Main InRoads Window 

 
 
 

  

The 1234567_SDE.alg is 
now named 1234567_Design 
internally as well as 
externally. 



Introduction to InRoads - Design  InRoads SS2 – Lab 2 
 

   
 Lab2-8   

12.  Save the InRoads Geometry File 
 
Even though the project has been renamed – the data has not yet been saved.  InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
 The Geometry Project (1234567_Design.alg) will be saved to Lab 2 in the following 
path: 
C:\InRoads Data\1234567\Design Labs\Lab 2 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The 1234567_Design Geometry Project has now been saved to the following path: 
C:\InRoads Data\1234567\Design Labs\Lab 2 
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Lab 2C Open the 1234567_Exist.dtm and rename internally 
 
In Lab 2C you will open 1234567_Exist.dtm and rename the internal 1234567_SDE project 
name to 1234567_Exist.  
 
 
13.  Open the 1234567_Exist.dtm Surface. 

 
• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 2\ 
• Highlight 1234567_Exist.dtm 
• Click Open and Cancel. 

 
14.  Make the InRoads Surface tab the active tab 

 
• In InRoads, Right mouse click  

over any of the tabs in the  
Workspace Bar and select  
Surfaces. 

• Verify your view matches that 
shown in Figure L2-5 and that 
the Surfaces tab is the active 
tab showing the Surface(s) listed.  
  
 
 
** NOTE: Even though you opened 1234567_Exist.dtm, 1234567_SDE is 
showing as the active Surface.  Even though we changed the Name of the file 
externally, InRoads retains the project name internally and must also be changed 
internally to match. 

 
 

 
Figure L2-5 Main InRoads Window 

Workspace 
Bar 

Right mouse 
click over any 
of these tabs to 
easily switch 
to any of the 
other tabs. 
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15.  Change the Internal Project Name from 1234567_SDE to 1234567_Exist. 
 

• Select Surface ► Rename Surface.  The Rename Surface dialog opens. 
• In the Rename Surface dialog make the entries shown in Figure L2-6. 
• Click Apply. 
• Click Close to exit the Rename Surface dialog. 
• In the InRoads workspace bar verify that the Surface is now renamed 

1234567_Exist as shown in Figure L2-7. 
 

The internal file is renamed to 1234567_Exist.dtm. 
 
 

 
Figure L2-6 Rename Surface 

 
 
 

 
Figure L2-7 Main InRoads Window 

 
 

The 1234567_SDE.dtm is 
now named 
1234567_Exist internally 
as well as externally. 
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16.  Save the InRoads Surface File 
 
Even though the Surface has been renamed – the data has not yet been saved.  InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Surface – Save the project and its associated 
modifications or changes. 
 

• Select FileSave Surface from the InRoads Menu.   
 
 The Surface Project (1234567_Exist.dtm) will be saved to Lab 2 in the following path: 
C:\InRoads Data\1234567\Design Labs\Lab 2 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Surface Project has 
been saved.              
 
The 1234567_Exist.dtm Surface has now been saved to the following path: 
C:\InRoads Data\1234567\Design Labs\Lab 2 
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Lab 2D Setting the Active Project 
 
When working with more than one project it is important that the Designer keep in mind which 
project is the Active Project.  This Lab will discuss setting the Active Project and how to 
determine which project is the Active Project. 
 
17.  In the InRoads Workspace Bar the Active Project has a red square next to it as shown 

here. 
 

 
 

18.  Make the Default Project the Active Project 
 

• In InRoads, Select Geometry ► Active Geometry.  The Active Geometry dialog 
opens. 

• Highlight Default in the Active Geometry dialog as shown in Figure L2-8. 
• Click Apply & Close. 

 
A Default Project will always exist in the InRoads Workspace Bar.  This is internal to 
InRoads and is required.  The Designer should NEVER use the Default project to design a 
project. 

 

 
Figure L2-8 Active Geometry 

The red square next to a project 
name indicates the Active Project. 

Highlight ‘Default’ as 
shown here by left clicking 
on it. 
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19.  Look in the InRoads Workspace Bar.  The Default Project should now be the Active 
Project as demonstrated by the red square as shown here. 
 

     
** HINT:  You may right mouse click over the 

project name and click ‘Set Active’ to 
set the Active Project also. 

 
 
 
Either the Active Geometry command or right mouse clicking may be used to set the 
active Horizontal and Vertical Alignments as well. 

20.                    
                 This concludes Lab 2.  Do not proceed until the Instructor directs you to do 
                  so. 
 

 

The red square next to a project 
name indicates the Active Project. 
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Lab 3 
Horizontal Alignments 

 
Objective 
 
In InRoads the term Horizontal Alignment refers to all linear elements, open or closed, such as 
centerlines, right of way parcels, edge of pavements, etc.  This lab will focus on several common 
methods typically used by GDOT for storing and editing centerline alignments. 

 
1. Copying an existing survey alignment for use as proposed alignment. 
2. Creating a new location alignment. 
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Lab 3A Open 1234567_Design.ALG 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 Scale Project.  Enter 50 in each line for the Text, Cell & Line 

Style Scale Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously, the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference. 

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 3\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 
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Lab 3B Viewing Alignments and Points 
 

7.  Open the View Horizontal Annotation Command 
 

• In InRoads, select Geometry ►View Geometry ► Horizontal Annotation.  
The View Horizontal Annotation dialog opens as shown in Figure L3-1. 

 
 
 

                                            
Figure L3-1 View Horizontal Annotation 

 
8.  Set the Viewing Preferences for Design Information.   

 
• In the View Horizontal Annotation dialog click the Preferences button. 
• In the Preferences dialog that opens, select BEARING & DISTANCE.  This 

Preference loads the settings for the typical viewing of Existing Centerlines. 
• Click Load & Close. 
• Verify the View Horizontal Annotation dialog settings match those shown in 

Figure L3-2. 
 

‘Preferences’ are used throughout InRoads for storing data for later retrieval related to 
viewing settings, dialog box settings, options and standards settings.  ‘Preferences’ are 
stored in a Preference file.  The name of the Preference file GDOT uses is 
GDOT_StandardV8i_SS2.xin and is available for download from the ROADS Webpage. 
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Figure L3-2 View Horizontal Annotation 

 
9.  In Figure L3-2 above, under the Annotate frame, uncheck the Elements check box.   

 
The Annotate Elements check box annotates the bearing and distance on Alignments.  
This information is not needed for this Lab.   

10.  In Figure L3-2, notice the Filter button is Grayed out. 
 

• Click in the Horizontal Alignments ‘Include:’ key-in field. 
• Notice the Filter button is now active. 
• Click the Filter button.  The Geometry Selection Filter dialog opens as shown in 

Figure L3-3. 
• Click the All button to move all the Horizontal Alignments to the ‘Selected’ field. 
• Click OK to return to the View Horizontal Annotation dialog. 
• Notice the Alignments are now populated in the View Horizontal Annotation 

frame’s Horizontal Alignments ‘Selected’ field as shown in Figure L3-4. 
 
The Geometry Selection Filter lists all the Horizontal Alignments in the Available field 
and allows the user to Filter data for viewing by several methods. 

 



Introduction to InRoads - Design  InRoads SS2 – Lab 3 
 

   
 Lab3-6   

  
Figure L3-3 Geometry Selection Filter 

 
 
 

  
Figure L3-4 View Horizontal Annotation 
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11.  • Click in the Cogo Points ‘Include’ field to activate the Filter button for the Cogo 
Points. 

• Click the Filter button to open the Geometry Selection Filter for the Cogo 
Points. 

• Click the All button to move all the points in the ‘Available’ field to the 
‘Selected’ field. 

• Click OK to close the Geometry Selection Filter dialog and populate the View 
Horizontal Annotation frame’s Cogo Points ‘Selected’ field. 

• Verify your view matches that shown in Figure L3-5. 
 

The Geometry Selection Filter lists all the Cogo Points in the Available field and allows 
the user to Filter data for viewing by several methods. 

 

  
Figure L3-5 View Horizontal Annotation 

 
12.  • In the View Horizontal Annotation dialog click Apply and then click Close.  

(Please be patient -- viewing may take time.) 
• In MicroStation, Click the Fit View button.                          Fit View 

                                               

                                      
                                                                                      

• Verify your MicroStation view resembles that shown in Figure L3-6. 



Introduction to InRoads - Design  InRoads SS2 – Lab 3 
 

   
 Lab3-8   

  
Figure L3-6 MicroStation Window 

 
 
 

13.   
***IMPORTANT DISCUSSION*** 

It is very important at this time to discuss some differences between InRoads and what 
you are familiar with in CAiCE.  InRoads has different kinds of points.  Alignment points 
and COGO points are two types of points to be aware of.  Alignment points are nothing 
more than names assigned to coordinates in an alignment and do not exist in the COGO 
points buffer.  In order to satisfy GDOT plan presentation requirements, prepare R/W 
tables and properly add enhanced survey data to your project. -- Surveyors and 
Designers alike must ensure that all alignments have a corresponding COGO point 
stored.  At some point this may cause you problems as you branch out and experiment 
with other InRoads commands because not all InRoads commands store COGO points.  
Some only assign Alignment Point names and must be converted to COGO points. Some 
don’t assign Alignment Point names or store COGO points and must be assigned 
Alignment Point names and then be converted to COGO points. As such we recommend 
that you adhere closely to the methods presented in the tutorials concerning centerlines, 
R/W and property.  We bring this up at this point because it is possible to view points at 
the same time as viewing Alignments without having to populate the Cogo Points in the 
View Horizontal Annotation command.  Viewing points in this manner would not apply 
the correct attributes to the points -- therefore you must view the Cogo points separately. 
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14.  InRoads contains a function called Pop-up that is similar to ‘Data Tips’ in CAiCE 
 

• In the [MicroStation Menu] -- Select SettingsSnapsAccuSnap 
• The AccuSnap Settings dialog box will appear. Ensure that your settings contain 

the same check marks to correspond to the screen capture depicted below: 
 

                                            
                                                   

• Close the AccuSnap Settings dialog box by clicking the       in the upper right-
hand corner of the window. 

• In MicroStation, Left Click on the Element Selection tool ( ). 
• Move your mouse over any object in the MicroStation Window and the Pop-up 

will provide information concerning the element as shown in Figure L3-7. 
 
Pop-up provides useful information such as element Name, Level and Style. 
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Figure L3-7 MicroStation Window 

 
 
 
  
 
 
 
 
 
 
  

Moving the mouse over the 
Land Lot Line produces the 
Pop-up shown here. 
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Lab 3C Create a Design Alignment from an Existing Centerline 
Alignment  

 
Designers should not use the Existing Centerline Alignment provided by Survey as their Design 
Alignment but should instead work from a copy of the Existing Centerline.  The copy may then 
be assigned the correct Feature Style and Description as well as any other modifications seen fit.  
This Lab will show you how to copy an Alignment, apply the correct DE prefix, assign the 
correct Feature Style and enter the correct Description. 
 
 
15.  In MicroStation, use the Window Area tool to zoom into US78 (Alignment SV4) as 

shown in Figure L3-8. 
 

 
       
                                                                              Window Area Tool 
 
After windowing in - your view should be similar to that shown in Figure L3-9. 

 

 
Figure L3-8 MicroStation Window 

Window Area 
as shown here. 

US 78 
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Figure L3-9 MicroStation Window 

 
16.  In InRoads, Select Geometry ► Utilities ► Parallel Horizontal Alignment.  The 

Parallel Horizontal Alignment dialog opens as shown in Figure L3-10. 
 
The Parallel Horizontal Alignment dialog is opened. 

 
 

 
Figure L3-10 Parallel Horizontal Alignment 

 

Existing Centerline 
of  US 78 
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17.  The Parallel Horizontal Alignment tool will be used to copy Existing US78 (SV4), 
name it DE7 and give it the Feature Style of MAIN_P_SIDECL and Description of 
‘C/L US 78’. 

•  
• In the From frame of the dialog box - click the Locate button next to Horizontal 

Alignment:.  The Locate button allows you to graphically select information. 
                                                                                                         LOCATE BUTTON 

                                               
 

• After clicking the locate button the Parallel Horizontal Alignment command 
disappears and you are prompted in the lower left corner of the MicroStation 
Window to > Identify alignment.  Look for the prompt     

                                                                                               
• Left click on US78 (SV4).  SV4 will highlight in Purple as shown here. 

 

                        
 

• Notice the prompts in the bottom of the MicroStation window.  In the bottom 
middle of the MicroStation Window you are prompted which Alignment was 
selected with the message ‘Selected alignment ‘SV4’’.  In the bottom left of the 
MicroStation window you are prompted to ‘>Accept/Reject’ the alignment as 
shown here. 

             
 

• Left Click on a blank part of the MicroStation window to Accept the selection or 
Right mouse click to Reject the selection and try again. 

• The Parallel Horizontal Alignment dialog returns and the Horizontal 
Alignment: entry field is populated with SV4.  Enter the following information in 
the To frame. 

                       Alignment Name: DE7 
                       Description:  C/L US 78 
                       Style: MAIN_P_SIDECL 

• Verify your entries match those shown in Figure L3-11.  Click Apply & Close. 
• Verify Alignment DE7 was drawn in MicroStation as shown in Figure L3-12. 

Selected 
Alignment 
Highlights in 
Purple 
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Figure L3-11 Parallel Horizontal Alignment 

 
 

 
Figure L3-12 MicroStation Window 

 
 
 
 
 

Alignment DE7 is drawn in 
MicroStation with the attributes 
for the Feature Style 
MAIN_P_SIDECL. 
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18.  Review Alignment DE7. 
 

• In InRoads, Select Geometry ► Review Horizontal.  The Review Horizontal 
Alignment Report window opens as shown in Figure L3-13. 

• Notice that there are no Point Names or Numbers associated with the Alignment. 
• Click Close to close the Report window. 

 
From this window a text file may be saved by clicking the Save As.. button. 

 

 
Figure L3-13 Review Horizontal Alignment 

 
 
 

Point Numbers, when 
they exist, are shown in 
the parenthesis. 
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19.  Assign Point Names to Alignment DE7. 
 

• In InRoads, Select Geometry ► Utilities ► Assign Names.  The Assign Names 
dialog opens. 

• Check the Alignments radio button. 
• Use the Locate button to select Alignment DE7.   

Hint:  During this process – watch/follow the prompts at the bottom of the 
MicroStation Window to identify the element, accept/reject, etc. (Left click to 
accept Alignment DE7 and the dialog box will return.) 

• Uncheck ‘Check for Coincident Points’.  
Please Note” In this case, a new Proposed Alignment is created from an Existing 
Survey Alignment, therefore, new points need to be created instead of using 
Coincident Points. 

• Verify your entries match those shown in Figure L3-14. 
• Click Apply & Close. 

 
Point Names are assigned to Alignment DE7. 

 

                            
Figure L3-14 Assign Names 

 
20.  Review Alignment DE7. 

 
• In InRoads, Select Geometry ► Review Horizontal.  The Review Horizontal 

Alignment Report window opens as shown in Figure L3-15. 
• Notice that Point Names now exist and that they have a DE prefix. 
• Click Close to exit the Review Horizontal Alignment Report. 

 
Alignment DE7 is reviewed and depicts the Point Names and the DE prefixes of the 
points. 
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Figure L3-15 Review Horizontal Alignment 
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21.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: Although Point Names (Alignment Points) now exist in Alignment 
DE7 for the PI’s, PC’s and PT’s -- the Alignment Points don’t actually exist as COGO 
Points in the COGO Buffer.  In order to properly display the points in MicroStation and 
for the proper delivery of Enhancements during the life of the project, the Alignment 
Points must be converted to COGO Points and assigned the proper Feature Style. 
 
 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog: 

o Check the ‘Alignment Point to Cogo’ radio button. 
o Set the Style: to MAIN_P_SIDECL 
o Accept all other defaults. 

• Click Apply.  A Results Report opens showing all points that are now COGO 
Points. 

• Click Close to close the Results box. 
• Click Close to close the Horizontal Events Dialog.  

 
* Note:  Cogo Points are only assigned to Alignment Points for the active 
Alignment.  The process must be repeated for each Alignment. 
 
 

Cogo Points are created from the Alignment Points and are stored in the Cogo Buffer. 
22.  Save the InRoads Geometry File 

 
 
Even though the Alignment has been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the Project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 3 in the following 
path: 
C:\InRoads Data\1234567\Design Labs\Lab 3 
 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
 
The Geometry File is saved to the following path:  
C:\InRoads Data\1234567\Design Labs\Lab 3  
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23.  Station Alignment DE7 to Begin at Station 1+00.00 
 

• Select Geometry ► Horizontal Curve Set ► Stationing.  The Stationing 
dialog opens as shown in Figure L3-16. 

 
Opens the Stationing dialog box. 

 

 
Figure L3-16 Stationing 

 
24.   

• In the Stationing dialog, enter 1+00.00 in the ‘Starting Station:’ entry field. 
• Verify your entries match those shown in Figure L3-17. 
• Click Apply & Close. 

 
The beginning Alignment Stationing is entered as 1+00.00. 
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Figure L3-17 Stationing 

 
25.  Review Alignment DE7. 

 
• In InRoads, Select Geometry ► Review Horizontal.  The Review Horizontal 

Alignment Report window opens as shown in Figure L3-18. 
• Notice that the Alignment now begins at Sta.1+00.00 
• Click Close to exit the Review Horizontal Alignment Report. 

 
The Alignment now depicts a starting Station of 1+00.00. 
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Figure L3-18 Review Horizontal Alignment 
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26.  View the Stationing for Alignment DE7 
 

• In InRoads, Select Geometry ► View Geometry ► Stationing.  The View 
Stationing dialog opens. 

• Click the Preferences button. 
• In the Preferences dialog Highlight SIDECL. 
• Click Load and Close. 
• In the View Stationing dialog Click Apply & Close. 
• Zoom into Alignment DE7 and verify it matches that shown in Figure L3-19. 

 
The Stationing for Alignment DE7 is depicted. 

 
 

 
Figure L3-19 MicroStation Window 

 
 
 

 In MicroStation, Click the Fit View button. 
 

 
                                                                                            
                                                                       Fit View  
 
The MicroStation View of the Geometry Project is fit to the screen. 

The view stationing command 
applies the tick marks, station 
numbering, cardinal stationing 
and leader lines. 
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Lab 3D Create a New Location Alignment 
 
This Lab will depict how to create a New Location Alignment. 
 
27.  • In InRoads, Select File ► New.  The New dialog opens.  

• Select the Geometry tab. 
• Make the following entries: 

o Type:  Horizontal Alignment 
o Name:  DE31 
o Description:  C/L SR100 SPUR 
o Style:  MAIN_P_CONSTCL 

• Verify your entries match those shown in Figure L3-20. 
• Click Apply & Close. 

 
Creates a new empty alignment named DE31. 

 

 
Figure L3-20 New Dialog 

 
28.  DE31 will begin at the Intersection of Alignments SV2 (EXIST C/L HWY 100) and 

SV1 (EXIST C/L PEQUANOC DR as shown in Figure L3-21. 
 

• In MicroStation, Use the Window Area command to zoom into the Intersection 
of SV2 and SV1 as shown in Figure L3-21 and Figure L3-22. 

 

 
                                                                   
                                                                     Window Area 
Zooms to the intersection of SV2 and SV1. 
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Figure L3-21 MicroStation Window 

 

 
Figure L3-22 MicroStation Window 

 
29.  Store a Point at the Intersection of SV1 and SV2. 

 
• In InRoads, Select Geometry ► Locate ► Intersection. The Intersection 

dialog opens. 
• Change the Type: to Alignment/Alignment. 
• Use the Locate button to select SV1 for Alignment 1.  Notice the prompts in the 

lower left corner of the MicroStation Window as you do this. 
• Use the Locate button to select SV2 for Alignment 2.  Notice the prompts in the 

lower left corner of the MicroStation Window as you do this. 
• Verify your entries match those shown in Figure L3-23. 

The Locate Button is used to select SV1 and SV2. 

SV2 

SV1 

Window Area here 

SV2 

SV1 
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Figure L3-23 Intersection 

 
30.  • In the Intersection dialog, click Apply.  The Locate Results dialog opens and 

the Point is highlighted in MicroStation in purple. 
• In the Locate Results dialog, change the Style: to MAIN_P_CONSTCL. 
• Verify your entries match those shown in Figure L3-24. 

 
 

 
Figure L3-24 Locate Results 

 
31.  • Click Accept.  The Results dialog opens as shown in Figure L3-25. 

• Review the Results dialog and then click Close. 
• Click Close to close the Intersection dialog. 

 
Cogo Point DE10006 is stored. 
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Figure L3-25 Results 

 
 
 
32.  The next two PI’s for Alignment DE31 will be stored by entering Northing and 

Easting Coordinates. 
 

• In InRoads, Select Geometry ► Cogo Points ► New.  The New Cogo Point 
dialog opens. 

• Enter the following information: 
o Define By:  Northing/Easting 
o Northing:  1359414.761 
o Easting:   1957665.615 
o Style:   MAIN_P_CONSTCL 

• Verify your entries match those shown in Figure L3-26. 
• Click Apply.  The Results dialog opens and Cogo Point DE10007 is stored and 

viewed in MicroStation as shown in Figure L3-27. 
• Close the Results dialog but do not close the New Cogo Point dialog. 

 
Cogo Point DE10007 is stored. 

 

 
Figure L3-26 New Cogo Point 

When a name is not entered in 
the Name: Field the next 
available seed point is chosen as 
set up in the FILE – PROJECT 
OPTIONS – GEOMETRY tab.  
In this case DE10007 was the 
next available name. 
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Figure L3-27 MicroStation Window. 

 
 
 
 

33.   
• Continuing with the New Cogo Point dialog, enter the following information: 

o Define By:   Northing/Easting 
o Northing:   1361173.558 
o Easting:   1960277.964 
o Style:   MAIN_P_CONSTCL 

• Verify your entries match those shown in Figure L3-28. 
• Click Apply.  The Results dialog opens showing that Cogo Point DE10008 was 

stored and DE10008 is drawn in MicroStation as shown in Figure L3-29.  You 
may have to zoom out in MicroStation to see the point. 

• Close the Results dialog and Close the New Cogo Point dialog. 
• In MicroStation, click the Fit View button to see the entire project. 

 
Cogo Point DE10008 is stored. 

 

Cogo Point DE10007 
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Figure L3-28 New Cogo Point 

 
 

 
Figure L3-29 MicroStation Window 

 
 
 
 
 
 
 
 
 

DE10008 is the next available 
point name and was 
automatically entered when we 
clicked Apply in Step 33. 

Cogo Point DE10008 



Introduction to InRoads - Design  InRoads SS2 – Lab 3 

   
 Lab3-29   

34.  The Final PI of Alignment DE31 will be Stored at STA.20+60.00 on Alignment DE7. 
 

• In InRoads, Select Geometry ► Cogo Points ► New 
• In the New Cogo Point dialog, change the Define By: entry to Station/Offset. 
• Make the following entries: 

o Horizontal Alignment:  DE7 
o Station:   20+60.00 
o Style:   MAIN_P_CONSTCL 

• Verify your entries match those shown in Figure L3-30. 
• Click Apply.  The Results dialog opens showing Cogo Point DE10009 was 

stored and drawn in MicroStation. 
• In MicroStation, Window Area as shown in Figure L3-31 
• Verify Cogo Point DE10009 was drawn as shown in Figure L3-32. 
• Close the Results Dialog and the New Cogo Point dialog. 
• In MicroStation, click the Fit View button. 

 
Cogo Point DE10009 is stored. 

 

 
Figure L3-30 New Cogo Point 
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Figure L3-31 MicroStation Window 

 

 
Figure L3-32 MicroStation Window 

 
 
 
 
 
 

Cogo Point DE1009 was stored 
at Sta.20+60.00 on Alignment 
DE7.  Window Area in 
MicroStation here to see it. 
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35.  Save the InRoads Geometry File 
 
Even though the Cogo Points have been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 3 in the following 
path: 
C:\InRoads Data\1234567\Design Labs\Lab 3 
 
The Geometry File is saved to the following path:  
C:\InRoads Data\1234567\Design Labs\Lab 3  

36.  Set DE31 to be the Active Alignment 
 

• In the InRoads workspace bar, left click on 
Alignment DE31 to highlight it as shown at right.  
*HINT:  You may have to scroll to the bottom 
of the workspace bar to find DE31. 

• Now, Right mouse click over DE31 and select ‘Set 
Active’. 

• DE31 should now have a red box around it 
indicating that it is the Active Alignment. 

• Verify that DE31 has a red box around it as shown 
below right. 

 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The Active Alignment is set to DE31.  

Red Box indicates the active 
alignment. 
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37.  Use the ‘Create/Edit Alignment by Cogo Points’ Command to Add Points to an 
Alignment. 
 

• In InRoads, Select Geometry ► Utilities ► Create/Edit Alignment by Cogo 
Points.  The Create/Edit Alignment by Cogo Points dialog opens. 

• In the ‘Alignment Definition:’ field, Key-in DE10006 DE10007. 
• Verify your entries match those shown here: 

  

                                    
 

Click Apply and Close to close out of the Create/Edit Alignment… dialog. 
 

• In Microstation, notice that a line was drawn from point DE10006 to DE10007 as 
shown in Figure L3-33. 

 
 
 
 

 
Figure L3-33 MicroStation Window 

 
 

Line drawn between 
points DE10006 and 
DE10007. 
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38.  INFORMATION: InRoads snaps are separate than snaps in MicroStation.  InRoads uses 
locks to determine what snap mode is utilized.  ‘Point Snap’ is used to snap to InRoads 
Points, ‘Element Snap’ is used to snap to InRoads elements such as Alignments and ‘No 
Snap’ allows graphic elements in MicroStation to be snapped using the common 
MicroStation snap options. 
 

• In InRoads, Select Tools ► Locks and verify that a Check Mark is next to Point 
Snap as shown here. 

• Point Snap is now the active snap mode  
in InRoads.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The Active InRoads Snap is set to Point Snap. 

39.  Use the Create/Edit Alignment by Cogo Points to continue adding the rest of the 
PI’s to Alignment DE31.  
 

• Select Geometry ► Utilities ► Create/Edit Alignment by Cogo Points.  The 
Create/Edit Alignment… dialog opens as shown in Figure L3-34. 

 
The Create/Edit Alignment by Cogo Points dialog opens. 

 

A check mark next to 
‘Point Snap’ indicates that 
it is the active snap lock. 
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Figure L3-34 Create/Edit Alignment by Cogo Points 

 
40.  In Addition to Manually Keying in Point Names into the ‘Alignment Definition’ 

Field, Points may be Graphically Selected by using the Buttons at the Bottom of the 
Command. 
 

• Click the Start button. 
• Look in the bottom left corner of the MicroStation Window.  You are prompted to 

‘> Identify Point’.   . 
• In MicroStation, left click on point DE10008 as shown in Figure L3-35. (You 

may have to zoom in close to select it.) 
• Look in the bottom middle of the MicroStation Window.  You are prompted with 

the message. ‘Point DE10008 selected’. . 
• Look in the bottom left corner of the MicroStation Window.  You are prompted to 

‘> Identify Point’.  . 
• At this point you can identify another point or you can right mouse click to return 

to the Create/Edit Alignment… command.  Right Mouse click somewhere over 
the MicroStation Window to return to the Create/Edit Alignment… command.  
The Create/Edit Alignment… command returns as shown in Figure L3-36. 
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Figure L3-35 MicroStation Window 

 
 

 
Figure L3-36 Create/Edit Alignment by Cogo Points 

 

DE10008 
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41.  Notice that the Create/Edit Alignment… Dialog is Grayed out Except for the buttons.  
At this point you are at an Intermediary Step in the command.  Clicking Stop will return 
the selected data to the ‘Alignment Definition’ Field.  Clicking any other Button will 
allow you to Continue Selecting Data for inclusion into the ‘Alignment Definition’ 
Field.   
 

• Click the Stop button. 
• Verify your entries match those shown in Figure L3-37. 
• Click Apply.  A line from DE10007 to DE10008 was drawn in MicroStation as 

shown in Figure L3-38. 
• Do not close the Create/Edit Alignment… dialog. 

 
Adds Point DE10008 to Alignment DE31. 

 
 

 
Figure L3-37 Create/Edit Alignment by Cogo Points 
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Figure L3-38 MicroStation Window 

 
42.  • In MicroStation, Window Area as shown above in Figure L3-38 to zoom into 

Point DE10009 stored earlier. 
• Verify your MicroStation View matches that shown in Figure L3-39. 

 
Zooms to Point DE10009. 

 

 
Figure L3-39 MicroStation Window 

Line DE10007 to 
DE10008 

Window Area 

DE10009 
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43.  The Create/Edit Alignment by Cogo Points Dialog should still be Open. 

 
• In the Create/Edit Alignment by Cogo Points dialog, click Start. 
• Notice the Prompt in the lower left corner of the MicroStation Window. 

. 
• Left click on Point DE10009 as shown in Figure L3-39. 
• Notice the Prompt in the lower middle of the MicroStation Window.  

. 
• Right mouse click to return the Create/Edit Alignment… dialog. 
• Click Stop to populate the ‘Alignment Definition’ field with DE10009. 
• Verify your view matches that shown in Figure L3-40. 
• Click Apply and Close.  A line was drawn from DE10008 to DE10009. 
• In MicroStation, Click Fit View.  Verify a line was drawn from DE10008 to 

DE10009 as shown in Figure L3-41. 
 
Adds Point DE10009 to Alignment DE31. 

 
 
 

 
Figure L3-40 Create/Edit Alignment by Cogo Points 

 



Introduction to InRoads - Design  InRoads SS2 – Lab 3 

   
 Lab3-39   

 
Figure L3-41 MicroStation Window 

 
 
 

44.  Save the InRoads Geometry File 
 
Even though the Cogo Points have been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 3 in the following 
path: 
C:\InRoads Data\1234567\Design Labs\Lab 3 
 
The Geometry File is saved to the following path:  
C:\InRoads Data\1234567\Design Labs\Lab 3 

 
  

Line DE10008 to 
DE10009 
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Lab 3E Add Curves to Alignment DE31 
 
45.  • Verify DE31 is the Active Alignment.  In the InRoads Workspace Bar it should 

have a red box next to it as shown here. 

                                                                      
Verifies that DE31 is the Active Alignment.  

46.  • In InRoads, Select Geometry ► Horizontal Curve Set ► Define Curve.   The 
Define Horizontal Curve Set dialog opens. 

• In the MicroStation screen, notice the Back Tangent and Ahead Tangent for the 
first PI in Alignment DE31 are highlighted in Purple. 

• In the Define Horizontal Curve Set dialog click the ‘Curve Calc…’ button.  
The Curve Calculator dialog opens. 

• Place a Check Mark in the Angle: check box and the DOC: (Degree of Curve) 
check box. 

• In the DOC: entry field, enter a Degree of Curve of 6◦00’00”.   
*NOTE:  InRoads angle entries take the form of degrees, space, minutes, space, 

seconds (i.e. 6 00 00) 
• Click Compute. 
• Verify your entries match those shown in Figure L3-42. 
• Click OK.  You are returned to the Define Horizontal Curve Set dialog. 
• Click Apply in the Define Horizontal Curve Set dialog. 
• Do not close the Define Horizontal Curve Set dialog box yet. 
• In MicroStation, notice that the Curve was applied to DE31. 

 
Defines the First Curve in Alignment DE31.  

 

 
Figure L3-42 Curve Calculator 
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47.  The Next PI will be assigned a 5◦45’00” Curve. 
 

• In the Define Horizontal Curve Set dialog, click Next >. 
• In the MicroStation screen, notice the Back Tangent and Ahead Tangent for the 

next PI in Alignment DE31 are highlighted in Purple. 
• In the Define Horizontal Curve Set dialog click the ‘Curve Calc…’ button.  

The Curve Calculator dialog opens. 
• Place a Check Mark in the Angle: check box and the DOC: (Degree of Curve) 

check box. 
• In the DOC: entry field, enter a Degree of Curve of 5◦45’00”.   

*NOTE:  InRoads angle entries take the form of degrees, space, minutes, space, 
seconds (i.e. 5 45 00) 

• Click Compute. 
• Verify your entries match those shown in Figure L3-43. 
• Click OK.  You are returned to the Define Horizontal Curve Set dialog. 
• Click Apply in the Define Horizontal Curve Set dialog. 
• In MicroStation, notice that the Curve was applied to DE31. 
• Click Close to close the Define Horizontal Curve Set dialog. 
• Verify that your view in MicroStation matches that shown in Figure L3-44. 

 
Defines the Second Curve in Alignment DE31. 

 

 
Figure L3-43 Curve Calculator 
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Figure L3-44 MicroStation Window 

 
48.  Station the Alignment to Begin at Sta.10+00. 

 
• In InRoads, select Geometry ► Horizontal Curve Set ► Stationing.  The 

Stationing dialog opens. 
• Change the starting Station to 10+00.00. 
• Verify your entries match those shown in Figure L3-45. 
• Click Apply and Close. 

 
Begins Alignment Stationing for DE31 at 10+00.00. 
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Figure L3-45 Stationing 

 
49.  Review Alignment DE31 

 
• In InRoads, Select Geometry ► Review Horizontal… 
• Take a moment to review Figure L3-46.  Notice that the PC’s and PT’s do not 

have Names assigned to them. 
• Close the Review Horizontal Alignment dialog. 

 
Reviews Alignment DE31. 
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Figure L3-46 Review Horizontal Alignment 
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50.  Assign Names to the Points in Alignment DE31. 
 

• In InRoads, Select Geometry ► Utilities ► Assign Names.  The Assign Names 
dialog opens. 

• Check the Alignments radio button. 
• Use the Locate button to select Alignment DE31.  During this process watch the 

prompts at the bottom of the MicroStation Window. 
Hint:  During this process – watch/follow the prompts at the bottom of the 
MicroStation Window to identify the element, accept/reject, etc. (Left click to 
accept Alignment DE31 and the dialog box will return.) 

• This time place a check in the Checkbox for ‘Check for Coincident Points’.  We 
did not enter a check previously because we were working with an existing 
Alignment and did not want to use existing survey points. 

• Verify your entries match those shown in Figure L3-47. 
• Click Apply & Close. 

 
Point Names are assigned to Alignment DE31. 

 

 
Figure L3-47 Assign Names 

 
51.  Review Alignment DE31. 

 
• In InRoads, Select Geometry ► Review Horizontal.  The Review Horizontal 

Alignment Report window opens as shown in Figure L3-48. 
• Notice that Point Names now exist and that they have a DE prefix. 
• Click Close to exit the Review Horizontal Alignment report. 

Reviews Alignment DE31. 
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Figure L3-48 Review Horizontal Alignment 
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52.  Create COGO Points of all Alignment Points. 
 
* IMPORTANT: As stated earlier, although Point Names (Alignment Points) now exist 
in Alignment DE31 for the PI’s, PC’s and PT’s -- the Alignment Points don’t actually 
exist as COGO Points in the COGO Buffer.  In order to properly display the points in 
MicroStation and for the proper delivery of Enhancements during the life of the project --
the Alignment Points must be converted to COGO Points and assigned the proper Feature 
Style. 
 

• Select Geometry ► Horizontal Curve Set ► Events… 
• In the Horizontal Events dialog: 

o Check the ‘Alignment Point to Cogo’ radio button. 
o Set the Style: to MAIN_P_CONSTCL 
o Accept all other defaults. 

• Click Apply.  A Results Report opens showing all points that are now COGO 
Points. 

• Click Close to close the Results box. 
• Click Close to close the Horizontal Events Dialog.  

 
Cogo Points are created from Alignment Points. 

53.  View the Stationing for Alignment DE31 
 

• In InRoads, Select File ► Project Options. 
• Select the Factors tab and verify the Text, Cell and Line Style Scale Factor(s) 

are all set to 50 and click Apply and Close. 
• In InRoads, Select Geometry ► View Geometry ► Stationing.  The View 

Stationing dialog opens. 
• Click the Preferences button. 
• In the Preferences dialog Highlight CONSTCL. 
• Click Load and Close. 
• In the View Stationing dialog click Apply & Close. 
• In MicroStation, zoom into Alignment DE31 and verify that Stationing is viewed. 

 
The Stationing for Alignment DE31 is viewed. 

54.  View the Curve Set Annotation for Alignment DE31. 
 

• In InRoads, Select Geometry ► View Geometry ► Curve Set Annotation.  
The Curve Set Annotation dialog opens. 

• Click the Preferences button. 
• In the Preferences dialog, highlight CONSTCL and Click Load & Close. 
• In the Curve Set Annotation dialog click Apply & Close. 

*Note: Curve Set Annotation is viewed in MicroStation as Graphic Groups and 
can be rotated and moved as a single element. 

• In MicroStation, Take a moment to zoom into one of the Curve Set Annotations 
and review it. 
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55.  Save the InRoads Geometry File 
 
Even though the Alignment has been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 3 in the following 
path: 
C:\InRoads Data\1234567\Design Labs\Lab 3 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Geometry Project 
has been saved.              
 
The Geometry File is saved to the following path:  
C:\InRoads Data\1234567\Design Labs\Lab 3 

56.                    
                 This concludes Lab 3.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 4 
Vertical Alignments 

 
Objective 
 
The objective of this Lab is to learn how to create, edit and annotate Existing Ground Profiles 
(Terrain Profiles) and Design Vertical Alignments.   
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Lab 4A Open 1234567_Design.ALG and 1234567_Exist.DTM 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 Scale Project.  Enter 50 in each line for the Text, Cell & Line 

Style Scale Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design.  These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference.   

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 4\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 
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7.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 4\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface Project 1234567_Exist is opened. 
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Lab 4B Create a New Vertical Alignment 
 
In Lab4B a Vertical Alignment named DE7 will be created for the Horizontal Alignment DE7 
(US 78).  A parent/child relationship exists in InRoads between the Horizontal and Vertical 
Alignments.  A Vertical Alignment is a child of the Horizontal Alignment.  Multiple Vertical 
Alignments may exist for a single Horizontal Alignment -- therefore it is important to have the 
correct Vertical Alignment active along with the active Horizontal Alignment before doing any 
work. 
 

8.  Ensure Alignment DE7 is the Active Alignment 
 

• Click the Geometry Tab at the bottom of the InRoads Workspace Bar. 
• Click the + sign next to the 1234567_Design project to expand the project. 
• Scroll to DE7 and left click on Alignment DE7 to highlight it. 
• Now, Right mouse click over it and select ‘Set Active’. 
• DE7 should now have a red box around it indicating that it is the Active 

Alignment. 
 

The Active Alignment is set to DE7. 
9.  • In InRoads, Select File ► New. The New dialog opens. 

• Select the Geometry Tab. 
• Enter the following information: 

o Type:  Vertical Alignment 
o Name:  DE7 
o Description:  US 78 
o Style:  MAIN_P_SIDECL 
o Curve Definition:  Parabolic 

• Verify your entries match those shown in Figure L4-1. 
• Click Apply & Close. 

 
Creates a new empty vertical alignment named DE7. 
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Figure L4-1 New 

 
10.   

• In the InRoads Workspace Bar, Notice there is a plus (+) sign next to the 
Horizontal Alignment DE7 as shown here.  This indicates a Vertical Alignment is 
associated with it. 

 
 

 
 
 

• Left Click on the plus (+) sign next to DE7.  The Vertical Alignment DE7 is 
shown as a child of the Horizontal Alignment as shown here.  Horizontal 
Alignments can have more than one Vertical Alignment associated with it but 
must have different names.  We named our Vertical Alignment DE7 just so it 
would match the Horizontal Alignment. 

 

 
 
Lists the Vertical Alignment DE7. 

  

Vertical Alignment 
DE7 is shown as a 
child of Horizontal 
Alignment DE7. 

Horizontal Alignment 
DE7 is shown with a 
plus sign next to it 
indicating that it has a 
Vertical Alignment 
associated with it. 
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Lab 4C Create an Existing Ground Profile (aka Terrain Profile) and 
a Profile Window 

 
Before PVI’s can be added to the Vertical Alignment, a Profile Window must be created.  This is 
also how the Terrain Profile is created.  In InRoads, the Terrain Profile is not stored as a 
permanent object as in CAiCE.  The Terrain Profile is created ‘on the fly’ from the DTM and 
must be recreated each time you want to view it.  
 
11.  Ensure Alignment DE7 is the Active Alignment 

 
• Click the Geometry Tab at the bottom of the InRoads Workspace Bar. 
• Click the + sign next to the 1234567_Design project to expand the project. 
• Scroll to DE7 and make sure it is the Active Alignment by Right mouse clicking 

over it and selecting ‘Set Active’. 
 

Ensures the Active Alignment is set to DE7. 
12.  • In InRoads, Select Evaluation ► Profile ► Create Profile.  The Create Profile 

dialog opens as shown in Figure L4-2. 
 

 

  
Figure L4-2 Create Profile 

 
13.  • In the Create Profile dialog click the Preferences button.  The Preferences 

dialog opens as shown in Figure L4-3. 
• Under the Name: field -- Select the Preference 50h_10v_SHEETS.  The 

50h_10v_SHEETS Preference sets up the Create Profile dialog for temporary 
viewing of the Profile. 
*NOTE: The _SHEETS preferences differ from the _WORKING preferences only 
in that the grid is also viewed in the _WORKING preferences. 

• Click Load & Close. 
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Figure L4-3 Preferences 

 
14.  • In the Create Profile dialog ensure the Check Box next to 1234567_Exist is 

checked as shown in Figure L4-4. 
• Click Apply 
• Notice in the bottom left corner of the MicroStation window the prompt 

>Identify Location.  . 
• Left Click anywhere in the MicroStation View Window.  The Create Profile 

dialog is returned and the existing ground profile is drawn for the Horizontal 
Alignment DE7. 

• In the Create Profile dialog, click Close. 
• In MicroStation, Click the Fit View button. 

  
                                                                                        
                                                                Fit View  

• In MicroStation, verify that your view matches that shown in Figure L4-5. 
 
The Terrain Profile is created and viewed. 

 

  
Figure L4-4 Create Profile 

Verify that the surface 
123456_Exist is checked. 
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Figure L4-5 MicroStation Window 

 
15.  For Information Only:   

 
The Screen Capture in Figure L4-6 shows the results of selecting the Preference 
50h_10v_WORKING.  The 50h_10v_WORKING Preference views all the same 
information as the 50h_10v_SHEETS Preference -- yet adds a grid.  This is for the 
temporary viewing of the profile during the design of the project.  Permanent viewing of 
the Profile and Vertical Alignment for plan generation and plotting will be covered in 
Lab 6 which depicts the use of the Plan and Profile Generator in InRoads. 
 
Information regarding the viewing of selected Profile Preferences. 
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Figure L4-6 MicroStation Window 
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Lab 4D Add PVI’s to the Vertical Alignment  DE7 
 
Adding PVI’s to a Vertical Alignment requires that you have an active Horizontal Alignment, 
Vertical Alignment and a Profile window in the MicroStation drawing file. 
 
 
16.  In MicroStation – Ensure that the Key-in Window is open and available in the 

MicroStation Interface: 
 

 
 
                                                                            MicroStation Key-in Window 
 
The Key-in Window must be available in order to input in the Vertical Alignment data 
in InRoads. 
 
If the Key-in Window is not open – perform the following steps: 
 

• In MicroStation, select Utilities ► Key-in  
• The Key-in Window will open. You can then “dock” the Key-in Window at the 

top of the MicroStation Interface tool bars (See screen capture above). 
 
Ensures that the MicroStation Key-in Window is available. 

17.  Dynamics Settings Dialog Box 
 

• In InRoads, Select Geometry ► Vertical Curve Set ► Dynamics Settings. 
The Dynamics Settings dialog box appears as shown in Figure L4-7. 
 This dialog box will be utilized in the following steps for the Add PI, Insert PI 
and Move PI commands and inputs.   
 

The Dynamics Settings dialog is opened. 
 

                                        
Figure L4-7 Add Vertical PI 
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18.  Add Vertical PI 
 
If None of the Dynamics options in the Dynamics Settings dialog are checked -- their 
values are determined by the position of the cursor or by key-ins in the 
MicroStation Key-in Window. 
 

• In InRoads, Select Geometry ► Vertical Curve Set ► Add PI.  Notice the 
prompt in the MicroStation Status bar (bottom left corner of the MicroStation 
window) prompting you to >Identify first point.   

• Left click in the MicroStation Key-in Window to activate the cursor. 
 

              
                                                                              MicroStation Key-in Window 
 

• Key-in se=1050.00, 1106.60 (for Station 10+50.00 and Elevation 1106.60). 
• If you have not already done so, press the Enter button on your key board. 
• Move your cursor around the MicroStation window.  The first PVI was placed 

and a dynamic line follows your cursor. 
• As you move the cursor, look at the InRoads Status bar and the MicroStation 

Status bar. The Station, Elevation, Grade Back and Grade Ahead are 
displayed. 

• Also, notice in the MicroStation Status bar the prompt >Identify Point/Reject. 
• At this point you may enter another key-in, graphically select another PVI or 

right mouse click to end the Add Vertical PI command.   
• In the MicroStation Key-in field, enter dg=350,-.0315 (for distance of 350 ft and 

downward grade of 3.15%) and press Enter. 
• Next, Right mouse click to end the Add Vertical PI command. 

 
Adds Vertical PVI (Point of Vertical Intersection). 

19.  • In the Dynamics Settings dialog, check the Station: and Elevation: check boxes. 
• In the Station: entry field key-in 3000.00 (for Station 30+00.00). 
• In the Elevation: entry field key-in 1077.67 (for Elevation 1077.67 ft). 
• Click Apply. 
• In the MicroStation Status bar you are prompted to >Identify alignment end.  

Left click on the end of the orange vertical alignment as shown in Figure L4-8. 
 

*NOTE: You may use the MicroStation view manipulation tools in the middle of 
an InRoads command.  Right mouse click to return to the last step you 
were on in InRoads prior to using the view manipulation tool. 

 
• In the MicroStation Status bar you are prompted to >Identify Point/Reject.  Left 

Click on the end of the orange line that is drawn for you as shown in Figure L4-9. 
• Next, Right mouse click to end the Add Vertical PI command. 
• Click Close to close out of the Dynamics Settings dialog box. 
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Figure L4-8 MicroStation Window 

 
 

 
Figure L4-9 MicroStation Window 

Left click the end of the 
existing Vertical Alignment 
(the orange line). 

Left click on the end of the 
orange line that is drawn for 
you.  This is the location of 
the Station and Elevation 
you entered in the Add 
Vertical PI dialog. 
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20.  The Add Vertical PI command is used to begin a Vertical Alignment and to add 
PVI’s to the end of a Vertical Alignment.  Use the Insert Vertical PI command to 
add PVI’s between two existing PVI’s. 
 

• In InRoads, Select Geometry ► Vertical Curve Set ► Dynamics Settings. The 
Dynamics Settings dialog opens as shown in Figure L4-10. 

• In InRoads, Select Geometry ► Vertical Curve Set ► Insert PI.   
 

 

  
Figure L4-10 Dynamics Settings 

 
21.  • In the Dynamics Settings dialog, check the Station: and Elevation: check boxes. 

• Enter 2069.11 (for Station 20+69.11) and 1062.54 (for elevation 1062.54 ft) 
• Click Apply. 
• In the MicroStation Status bar you are prompted to >Identify Element.  Left 

Click on the Vertical Alignment (orange line). 
• In the MicroStation Status bar you are prompted to >Identify Point/Reject.  Left 

Click on the new point.   
• In the MicroStation Status bar you are prompted to >Accept overall 

solution/Reject.  Left mouse click in MicroStation to accept.   
• Right mouse click twice to end the Insert PI command. 
• Do not close the Dynamics Settings dialog. 

 
22.  • In InRoads, Select Geometry ► Vertical Curve Set ► Insert PI.   

• In the Dynamics Settings dialog, enter 2500.00 (for Station 25+00.00) and 
1051.45 (for elevation 1051.45 ft) 

• Click Apply. 
• In the MicroStation Status bar you are prompted to >Identify Element.  Left 

Click on the Vertical Alignment (orange line). 
• In the MicroStation Status bar you are prompted to >Identify Point/Reject.  Left 

Click on the new point. 
• In the MicroStation Status bar you are prompted to >Accept overall 

solution/Reject.  Left mouse click in MicroStation to accept.   
• Right mouse click twice to end the Insert PI command. 
• Do not close the Dynamics Settings dialog. 
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23.  • In InRoads, Select Geometry ► Vertical Curve Set ► Insert PI.   
• In the Dynamics Settings dialog, enter 2941.77 (for Station 29+41.77) and 

1074.45 (for elevation 1074.45 ft) 
• Click Apply. 
• In the MicroStation Status bar you are prompted to >Identify Element.  Left 

Click on the Vertical Alignment (orange line). 
• In the MicroStation Status bar you are prompted to >Identify Point/Reject.  Left 

Click on the new point. 
• In the MicroStation Status bar you are prompted to >Accept overall 

solution/Reject.  Left mouse click in MicroStation to accept.   
• Right mouse click twice to end the Insert PI command. 
• Click Close to close the Dynamics Settings dialog. 

 
You have now added 6 PVI’s to the Vertical Alignment DE7. 

24.  Using the Move PI command we will move the PVI at Station 25+00 to Station 
25+96.77 and leave the Elevation unchanged. 
 

• In InRoads, Select Geometry ► Vertical Curve Set ► Dynamics Settings. The 
Dynamics Settings dialog opens as shown in Figure L4-11. 

• In InRoads, Select Geometry ► Vertical Curve Set ►Move PI.   
 

 

 
Figure L4-11 Dynamics Settings 

 
 
 
 
 
 
 
 
 
 
 
 



Introduction to InRoads - Design  InRoads SS2 – Lab 4 
 

   
 Lab4-16   

25.  • In the Dynamics Settings dialog, place a Check in the Station check box and 
uncheck the Elevation check box. 

• In the Station: entry field key-in 2596.77 (for Station 25+96.77). 
• Click Apply. 
• In the MicroStation Status bar you are prompted to >Identify Element.  Left 

click on the PVI at Station 25+00.00.  In MicroStation, the PVI at Station 
25+00.00 is moved to Station 25+96.77.  At this point it is not a permanent move. 

• In the MicroStation Status bar you are prompted to >Identify Point/Reject.  Left 
click on the new point. 

• Left mouse click to <Accept overall solution. 
• Right mouse click twice to return to the Dynamics Settings dialog. 
• Click Close to close the Dynamics Settings dialog. 

 
The PVI at Station 25+00.00 and Elevation 1051.45 has been moved to Station 25+96.77 
and Elevation 1051.45. 

26.  Save the InRoads Geometry File 
 
Even though the Vertical Alignment has been stored – the data has not yet been saved. 
InRoads retains the data in temporary memory but does not save the data on the fly. 
Whenever a change has been made to an InRoads Geometry Project – Save the project 
and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 4  in the following 
path:  C:\InRoads Data\1234567\Design Labs\Lab 4 
 
The Geometry File is saved to the following path:  
C:\InRoads Data\1234567\Design Labs\Lab 4 
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Lab 4E Define Vertical Curves for the Vertical Alignment  DE7 
  
Defining Vertical Curves requires that you have an active Horizontal Alignment, Vertical 
Alignment and a Profile window in the MicroStation drawing file. 
 
27.  • In InRoads, Select Geometry ► Vertical Curve Set ► Define Curve.  The 

Define Vertical Curve Set dialog opens as shown in Figure L4-12 (with the first 
PVI active). 

 

 
Figure L4-12 Define Vertical Curve Set 

 
28.  The Define Vertical Curve Set may also be used to Move a PVI. 

 
• In the Define PVI By:  entry field select Station and Elevation. 
• In the Station: entry field key-in 15+00.00. 
• In the Elevation: entry field key-in 1092.41. 
• Click Apply but do not close the Define Vertical Curve Set dialog.  The PVI 

that was at Station 14+00.00 and Elevation 1095.575 was moved to Station 
15+00.00 and Elevation 1092.41. 
 

The PVI is moved to Station 15+00.00 and Elevation 1092.41.  
29.  • In the Vertical Curve frame - click the pull down arrow next to Calculate By: as 

shown in Figure L4-13.  Take a moment to review the options that are available --
then select Length of Curve. 

• Enter a length of 500 in the Vertical Curve – Length: entry field as shown in 
Figure L4-13. 

• Click Apply but do not close the Define Vertical Curve Set dialog.   
 
The Length of Curve of 500 is entered.  
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Figure L4-13 Define Vertical Curve Set 

 
30.  • Click Next in the Define Vertical Curve Set to advance to the next PVI at 

Station 20+69.11. 
• Enter a length of 360 in the Vertical Curve – Length: entry field. 
• Click Apply but do not close the Define Vertical Curve Set dialog. 

 
The Length of Curve of 360 is entered. 

31.  • Click Next in the Define Vertical Curve Set to advance to the next PVI at 
Station 25+96.77. 

• Enter a length of 690 in the Vertical Curve – Length: entry field. 
• Click Apply & Close to exit the Define Vertical Curve Set dialog. 

 
The curves for Vertical Alignment DE7 have been defined. 

32.  Save the InRoads Geometry File 
 
Even though the Vertical Alignment has been stored – the data has not yet been saved. 
InRoads retains the data in temporary memory but does not save the data on the fly. 
Whenever a change has been made to an InRoads Geometry Project – Save the project 
and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 4  in the following 
path:  C:\InRoads Data\1234567\Design Labs\Lab 4 
 
The Geometry File is saved to the following path:  
C:\InRoads Data\1234567\Design Labs\Lab 4 

Enter 500 in the 
Vertical Curve Length 
entry field. 

Use the pull down 
arrow to select different 
options for calculating 
the vertical curve. 
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Lab 4F Annotate Vertical Alignment , Terrain Profile & Elevations          
for  DE7 

 
 InRoads requires three steps to view the Annotation for the Terrain Profile, the annotation for 
the Vertical Alignment and the Elevations of Terrain Profile and Vertical Alignment.  
 
33.  Clear the MicroStation Working Drawing. 

 
• In MicroStation, Select Edit ► Select All. 
• Select Delete Element from the Main tab, as     

shown here OR select the <DELETE> key on the 
computer keyboard. 
 
 

                                           
 
 
 
 
The Working Drawing graphics are deleted.  

34.  Create Profile Window and Terrain Profile. 
 

• In InRoads, Select Evaluation ► Profile ► Create Profile. 
• In the Create Profile dialog -- click the Preferences button. 
• Under the Name: field -- Select the Preference 50h_10v_SHEETS.  The 

50h_10v_SHEETS Preference sets up the Create Profile dialog for viewing of 
the Profile. 

• Click Load & Close. 
 

The 50h_10v_SHEETS Preference is selected. 
35.  • In the Create Profile dialog ensure the Check Box next to 1234567_Exist is 

checked.  
• Click Apply 
• Notice in the bottom left corner of the MicroStation window the prompt 

>Identify Location.  . 
• Left Click anywhere in the MicroStation View Window.  The Create Profile 

dialog is returned and the existing ground profile is drawn for the Horizontal 
Alignment DE7. 

• In the Create Profile dialog, click Close. 
• In MicroStation, Click the Fit View button. 

 

   
                                                            Fit View  
 
The Terrain Profile is created and viewed. 

Delete Element 
Tool. 
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36.  Verify Scale Factor 
 

• In InRoads, Select File ► Project Options. 
• Select the Factors tab and verify that 50 is entered for the Text, Cell and Line 

Style Scale Factor(s). 
• Click Apply and Close. 

 
The Scale Factor is verified. 

37.  Annotate Profile Window and Terrain Profile 
 

• Select Evaluation ► Profile ► Annotate Profile.  If the following message 
pops up: 
 

                      
 

• Click No.  The Annotate Profile dialog opens as shown in Figure L4-14. 
 
The Annotate Profile dialog opens. 

 

 
Figure L4-14 Annotate Profile 
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38.  View Terrain Profile and Vertical Alignment Elevations 
 
A Profile Preference will be selected – once the Preference is selected the settings for 
Alignment DE7 will be entered into the dialog box. 
 

• Click the Preferences button. 
• Under the Name: field -- Select the Preference 50h_10v_Profile.  The 

50h_10v_Profile Preference sets up the Annotate Profile dialog for viewing of 
the Terrain Profile and Vertical Alignment Elevations. 

• Click Load and Close. 
• Click Apply & click Close in the Annotate Profile dialog. 
• The Elevations for the Terrain (Green) and Vertical Alignment (Red) are now 

viewed in the MicroStation Window as shown in Figure L4-15. 
 
The Elevations are viewed. 

 
 

 
Figure L4-15 MicroStation Window 

 
 
 
 

39.  Annotate Vertical Alignment 
 

• In InRoads, Select Geometry ► View Geometry ► Vertical Annotation.  The 
View Vertical Annotation dialog opens as shown in Figure L4-16. 
 

The View Vertical Annotation dialog opens. 
 
 

Terrain Profile and 
Vertical Alignment 
Elevations 



Introduction to InRoads - Design  InRoads SS2 – Lab 4 
 

   
 Lab4-22   

                                            
Figure L4-16 View Vertical Annotation 

 
 
40.  Annotate Vertical Alignment 

 
• Click the Preferences button. 
• Under the Name: field -- Select the Preference GDOT Profiles.  The GDOT 

Profiles Preference sets up the View Vertical Annotation dialog for viewing of 
the Vertical Alignment Annotation. 

• Click Load and Close. 
• Click Apply & Close in the View Vertical Annotation dialog. 
• Verify your view in MicroStation matches that shown in Figure L4-17. 

 
The Vertical Alignment and associated Vertical Annotation is viewed. 
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Figure L4-17 MicroStation Window 

 
 
41.  For Information Only.   

 
The Screen Capture in Figure L4-17 shows the results of selecting the various commands 
and preferences for the temporary viewing of the profile during the design of the project.  
Permanent viewing of the Profile and Vertical Alignment for plan generation and plotting 
will be covered in Lab 6 which covers the use of the Plan and Profile Generator in 
InRoads. 
 
Information regarding the generation of the Profile Sheets. 

42.  Review Vertical Alignment DE7. 
 

• In InRoads, Select Geometry ► Review Vertical.  The Review Vertical 
Alignment Report window opens as shown in Figure L4-18. 

• Review the Vertical Alignment and ensure that your Report corresponds to the 
partial Report as depicted in Figure L4-18 

• Click Close to exit the Review Vertical Alignment Report. 
 
Vertical Alignment DE7 is reviewed.    
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Figure L4-18 Review Vertical Alignment 
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43.  Save the InRoads Geometry File 
 
Whenever a change has been made to an InRoads Geometry Project – Save the project 
and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 4  in the following 
path:  C:\InRoads Data\1234567\Design Labs\Lab 4 
 
The Geometry File is saved to the following path:  
C:\InRoads Data\1234567\Design Labs\Lab 4 

44.                    
                 This concludes Lab 4.  Do not proceed until the Instructor directs you to do 
                  so. 
 

 





Introduction to InRoads - Design  InRoads SS2 – Lab 5 

   
 Lab5-1   

Lab 5 
Importing MicroStation Graphics and 

Placing Curve Tables 
 
Objective 
 
Objects drawn in MicroStation can be imported into the InRoads ALG file.  In this lab you will 
learn how to import MicroStation elements into Inroads by importing the alignment ‘Golf Course 
Rd Tie-in’ as DE60.  Golf Course Rd Tie-in is identified below by the white alignment. 
 
 

 
 

                                                                            
  

Golf Course Rd Tie-in 
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Lab 5A Open 1234567_Design.ALG 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 Scale Project.  Enter 50 in each line for the Text, Cell & Line 

Style Scale Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design.  These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference.   

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 5\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 
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Lab 5B Open Lab5_Import Graphics.dgn and Import Golf Course 
Rd Tie-in into InRoads 

 
In Lab5B you will open the MicroStation File Lab5_Import Graphics.dgn and import into 
InRoads, as DE60 (Golf Course Rd Tie-in), the MicroStation elements that have been provided.  
 
 

7.  Open Lab5_Import Graphics.dgn 
 

• In MicroStation, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 5\ 
• Highlight Lab5_Import Graphics.dgn 
• Click Open. 
• Verify your view in MicroStation matches that shown in Figure L5-1.  The 

elements showing represent alignment DE60 and will be imported into InRoads. 
 
The MicroStation File Lab5_Import Graphics.dgn is opened. 

 
 

 
Figure L5-1   MicroStation View 
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8.  Open the Import Geometry dialog. 
 

• In InRoads, select File ► Import ► Geometry.  The Import Geometry dialog 
opens as shown in Figure L5-2. 

 
 
 

  
Figure L5-2   Import Graphics 
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9.  Enter the Import Geometry dialog settings to import Golf Course Rd Tie-in 
 

• Select the From Graphics tab if it is not already the active tab. 
• Set the Type: to Horizontal Alignment. 
• In the Geometry Frame: enter the following: 

o Name: DE60 
o Description: C/L Golf Course Rd Tie-in 
o Style: MAIN_P_SIDECL 
o Curve Definition: Arc 

• In the Target field set the Geometry Project: to 1234567_Design from the pull 
down menu. 

• Make sure only the following check boxes contain a check mark: 
o       Join Elements 
o       All Selected Elements Added to Single Alignment 

• Verify your entries match those shown in Figure L5-3. 
 

 

  
Figure L5-3   Import Geometry 
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10.  Import the MicroStation Graphics into the InRoads ALG file. 
 

• In the Import Geometry dialog, click Apply.   
• Notice in the bottom right left corner of the MicroStation window you are 

prompted to > Identify element.   
• Left click on the tangent section of the alignment.  It will turn purple (as shown 

below) and you will be prompted to left click in the bottom left of the 
MicroStation window to > Accept/Reject. 

 

 
 
 

• Left click anywhere in the MicroStation window to Accept. 
• Notice in the bottom left corner of the MicroStation window you are now 

prompted again to > Identify element. 
• Left click on the curve.  The curve will turn purple (as shown below) and you are 

prompted in the bottom left corner of the MicroStation window to                        
> Accept/Reject. 

 

 
 
 

• Left click anywhere in the MicroStation window to Accept. 
• Notice in the bottom left corner of the MicroStation window you are now 

prompted again to > Identify element. 
• Right mouse click to end importing graphics and return to the Import Graphics 

dialog. 
• Click Close to exit the Import Geometry dialog. 
• The MicroStation Graphics have now been imported into the InRoads ALG file as 

a horizontal alignment. 
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11.  Verify Alignment DE60 has been imported into the InRoads ALG. 
 

• In the InRoads workspace bar, click the Geometry tab to make it the active tab.  
• Verify alignment DE60 is present and also that it is the active alignment.  It 

should have a red square around it as shown here. 
 

 
 

12.  Review Alignment DE60. 
 

• In InRoads, select Geometry ► Review Horizontal.  The Review Horizontal 
Alignment window opens as shown in Figure L5-4.   

• Notice in the Review Horizontal Alignment window none of the coordinates 
have names assigned to them.   

• Close the Review Horizontal Alignments window. 
 

  
Figure L5-4   Review Horizontal Alignment 
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13.  Assign Names to the Coordinates in Alignment DE60. 
 

• In InRoads, select Geometry ► Utilities ► Assign Names.  The Assign Names 
dialog opens. 

• Match the settings in the Assign Names dialog to those shown in Figure L5-5. 
• Click Apply and Close. 

 
 

 

  
Figure L5-5   Assign Names 

 
14.  Review Alignment DE60. 

 
• In InRoads, select Geometry ► Review Horizontal.  The Review Horizontal 

Alignment window opens as shown in Figure L5-6.   
• Notice in the Review Horizontal Alignment window the coordinates now have 

names assigned to them.   
• Close the Review Horizontal Alignments window. 
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Figure L5-6   Review Horizontal Alignment 

 
 
15.  Create COGO Points of all Alignment Points. 

 
* IMPORTANT: Although Point Names (Alignment Points) now exist in Alignment 
DE60 for the PI’s, PC’s and PT’s -- the Alignment Points don’t actually exist as COGO 
Points in the COGO Buffer.  In order to properly display the points in MicroStation with 
the proper symbology and for the proper delivery of Enhancements during the life of the 
project, the Alignment Points must be converted to COGO Points and assigned the proper 
Feature Style. 
 

• In InRoads, select Geometry ► Horizontal Curve Set ► Events.  The 
Horizontal Events dialog opens. 

• Match the settings in the Horizontal Events dialog to those shown in         
Figure L5-7. 

• Click Apply and Close. 
• Close the Results window. 

 
* NOTE:  Cogo Points are only assigned to Alignment Points for the active 

Alignment.  The process must be repeated for each Alignment. 
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Figure L5-7   Horizontal Event Points 

 
 

16.  Save the InRoads Geometry File 
 
Even though the Alignment has been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the Project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
  

17.  Station Alignment DE60 to Begin at Station 15+55.76 
 

• Select Geometry ► Horizontal Curve Set ► Stationing.  The Stationing 
dialog opens. 

• Match the settings shown in Figure L5-8. 
• Click Apply & Close. 
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Figure L5-8   Stationing 

 
 

18.  Review Alignment DE60. 
 

• In InRoads, select Geometry ► Review Horizontal.  The Review Horizontal 
Alignment window opens as shown in Figure L5-9.   

• Notice in the Review Horizontal Alignment the Stationing now begins at Station 
15+55.76.   

• Close the Review Horizontal Alignments window. 
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Figure L5-9   Review Horizontal Alignment 

 
19.  Save the InRoads Geometry File 

 
• Select FileSave Geometry Project from the InRoads Menu.   

  
20.  Open the GDOT 3D Working File.dgn 

 
• In MicroStation, select File ► Open.  The Open dialog opens. 
• Navigate to c:\InRoads Data\1234567\Design Labs\Standards\ 
• Highlight the File GDOT 3d Working File.dgn. 
• Click Open. 
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21.  View Alignment DE60 in MicroStation. 
 

• In InRoads, select Geometry ► View Geometry ► Horizontal Annotation.  
The View Horizontal Annotation dialog opens. 

• Load the Preference ‘NO BEARING & DISTANCE’.  This may be 
accomplished by clicking the Preferences button, highlighting the preference 
‘NO BEARING & DISTANCE’ and clicking Load and Close in the 
Preferences dialog. 

• In the Horizontal Alignments – Include: field, key-in DE60 and hit the Tab key 
on your keyboard. 

• Verify your entries match those shown in Figure L5-10. 
• Click Apply & Close. 
• Verify alignment DE60 was drawn in MicroStation with the correct attributes as 

shown in Figure L5-11. 
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Figure L5-10   View Horizontal Annotation 

 



Introduction to InRoads - Design  InRoads SS2 – Lab 5 
 

   
 Lab5-16   

  
Figure L5-11   MicroStation View 

 
 
22.  Station the Alignment. 

 
• In InRoads, select Geometry ► View Geometry ► Stationing.  The View 

Stationing dialog opens. 
• Load the SIDECL preference.  This may be accomplished by clicking the 

Preferences button, highlighting the preference SIDECL and clicking Load and 
Close in the Preferences window. 

• In the View Stationing dialog, ensure DE60 is shown in the Horizontal 
Alignment: entry field as shown in Figure L5-12. 

• Click Apply and Close. 
• Verify your view in MicroStation matches that shown in Figure L5-13. 
 
*NOTE: At this point MicroStation is used to clean up overlapping text. 
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Figure L5-12   View Stationing 

 
 

  
Figure L5-13   MicroStation View 
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Lab 5C Placing Curve Data Tables 
 
In Lab5C you will place Curve tables in MicroStation for Alignment DE60.  The following 
information is required per the GDOT Plan Presentation Guide. 
 

Curve Data Table Required Information 
o CURVE Number 
o P.I. Station 
o P.I. Coordinates 
o  or “DELTA” (Deflection angle) 
o D   (Degree of Curve) 
o T   (Tangent Length) 
o L   (Length of Curve) 
o R   (Radius) 
o E   (External distance) 
o e   (Superelevation in percent) 
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23.  Open the Curve Set Annotation dialog. 
 

• In InRoads, select Geometry ► View Geometry ► Curve Set Annotation.  
The Curve Set Annotation dialog opens as shown in Figure L5-14. 

• Click the Annotation folder.  The Annotation folder is where settings are entered 
to control what and how Curve data is annotated as shown in Figure L5-15. 

 

   
Figure L5-14   Curve Set Annotation 

 

  
Figure L5-15   Curve Set Annotation 

The Horizontal Alignment entry 
field defaults to the current active 
alignment. 

Annotation folder. 
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24.  Load the SIDECL Preference. 
 

• In the Curve Set Annotation dialog, click the Preferences button. The 
Preferences selection window opens. 

• In the Preferences selection window, highlight SIDECL as shown in Figure L5-
16. 

• Click Load & Close.  This loads the settings into the Curve Set Annotation 
dialog for viewing Curve Data Tables in MicroStation. 

  
 

  
Figure L5-16   Preferences 

 
 

25.  View the Curve Data Table for Alignment DE60 in MicroStation. 
 

• In the Curve Set Annotation dialog, click Apply and Close. 

• In MicroStation, click the Fit View button ( ). 
• Verify your view in MicroStation matches that shown in Figure L5-17. 

 
*NOTE: At this point MicroStation may be used to Move or Rotate the Curve Table 

as necessary for plan presentation. 
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Figure L5-17   MicroStation View 

 
 

26.                    
                 This concludes Lab 5.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 6 
Profile Sheets 

 
Objective 
 
The objective of this Lab is to learn the procedures for creating Profile Sheets by using the Plan 
and Profile Generator command.  
 
Important Discussion: 
The generation of Profile Sheets is accomplished by using the Plan and Profile Generator 
command in InRoads. This command uses DGN and Host files to generate the Profile Sheets. In 
order to understand the process -- the following information regarding the creation of Profile 
Sheets will be discussed in Lab 6. 
 
 

• “Master” DGN File - a new MicroStation DGN file that is created which will contain 
the actual Terrain Profile, Vertical Alignment and Annotation.   
 

o The recommended File Naming Structure is PI#PR##.dgn.  
o (PI# = the Project Number, PR## = the Profile Alignment Name). 

 
• “Host File” – a MicroStation DGN file which is used to create the Profile Sheet. This file 

contains the grid cell and the clipping elements. It is the actual Profile Sheet which uses 
the “Master” DGN file as a Reference File.   

 
o The recommended File Naming Structure is PI#_Section Number.dgn. The 

Section Number is depicted in the Electronic Data Guidelines (EDG). The Section 
for Mainline Roadway Profile is 15. The Section for Crossroad Profile is 16.  

o (PI# = the Project Number, Separator = _, Section Name = 15 or 16). 
 

• “Seed Host File” – a MicroStation DGN file which is used as the seed file to create the 
“Host File”. This is the GDOT_V8_3D.dgn file which contains the standard GDOT 
DGN Library, cell libraries, etc.   

o (Note: In this Lab the “Seed Host File” is named GDOT 3D Working File.dgn). 
 
 
RECAP: 
 

o PI#PR##.dgn = DGN File which contains the Terrain Profile, Vertical Alignment and 
Annotation 

o PI#_Section Number.dgn = DGN File which contains the Profile Sheets. 
o GDOT 3D Working File.dgn = DGN File which is the standard GDOT Seed File. 
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Lab 6A Open 1234567_Design.ALG and 1234567_Exist.DTM 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86).  
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 Scale Project.  Enter 50 in each line for the Text, Cell & Line 

Style Scale Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference.   

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 6\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 

7.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 6\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface Project 1234567_Exist is opened. 
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Lab 6B Create Profile Sheets 
 
In Lab 6B, Profile Sheets will be created which depict the Terrain Profile, Vertical Alignment, 
Annotation and Profile Grid.  
 

8.  Set DE7 to be the Active Alignment 
 

• Click the Geometry Tab at the bottom of the InRoads Workspace Bar. 
• Click the + sign next to the 1234567_Design Project to expand the project. 
• Scroll to DE7 and left click on Alignment DE7 to highlight it. 
• Now, Right mouse click over it and select ‘Set Active’. 
• DE7 should now have a red box around it indicating that it is the Active 

Alignment. 
 

The Active Alignment is set to DE7. 
9.  Create a new MicroStation DGN file named 1234567PR07.dgn.  (This is the File that 

will contain the Terrain Profile, Vertical Alignment and Annotation).   
 
The recommended MicroStation File Naming Convention is PI#PR##.dgn.  
(PI# = the Project Number, PR## = the Profile Name). 
 

• In MicroStation, Select File ► Save As. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 6 
• In the File name:  field -- Enter the File name 1234567PR07.dgn 
• Click Save.    

 
The MicroStation DGN File named 1234567PR07.dgn is created and is made the current 
active DGN File. 

10.  In InRoads, Select Drafting ► Plan and Profile Generator.  The Plan and Profile 
Generator dialog opens. 
 
The Plan and Profile Generator dialog is opened. 

11.  In the Plan and Profile Generator: 
 

• Click the Main tab to be the active tab.  
• Click the Preferences button. 
• In the Preferences dialog select 50 Scale Double Profile. 
• Click Load and Close. 
• Verify your entries match those shown in Figure L6-1. 

 
Please Note: In a “real world” project the user may select the type of Profile Sheet that is 
applicable (EX: 50 Scale Single Profile) and the correct settings will be selected/loaded.   
 
The Standard GDOT Settings for a 50 Scale Double Profile is selected and loaded. 
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Figure L6-1 Plan and Profile Generator 

 
 
12.  In the Plan and Profile Generator: 

 
• Click the Profile Controls tab to be the active tab. 
• Use the pull down arrow next to Vertical Alignment: to select DE7. 
• Leave all other Entries as the default. 
• Verify your entries match those shown in Figure L6-2. 

 
The Vertical Alignment of DE7 is selected. 
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Figure L6-2 Plan and Profile Generator 

 
13.  • Click the Sheet Layout tab to be the active tab. 

• Click the Locate button (  )   next to the Host File: entry field. 
o Navigate to C:\InRoads Data\1234567\Design Labs\Lab 6 
o In the File name:  field -- Enter the File name 1234567_16.dgn  
o Click Save. 

• Click the Locate button (  )   next to the Seed Host File: entry field. 
o Navigate to C:\InRoads Data\1234567\Design Labs\Lab 6 
o Select the GDOT 3D Working File.dgn.  (This is the Seed File used to 

create the Host DGN File.) 
o Click Open. 

• Verify your entries match those shown in Figure L6-3. 
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Figure L6-3      Plan and Profile Generator 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

**IMPORTANT:  
Profile Sheets are 
created in One DGN file 
through the use of the 
‘All Sheets in One’ 
button shown here.  The 
purpose of this is to 
facilitate the plotting 
process. 
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14.  In the Plan and Profile Generator: 
 

• Click Apply. 
• You are prompted in the lower left corner of the MicroStation Window to 

>Identify Location.    
• Left Click anywhere in the MicroStation View window.  Your Profile Sheets will 

be built and you will be left in the last MicroStation file created (in this case the 
DGN File named 1234567_16.dgn).  

• The Plan and Profile Generator dialog is returned and the Profile Sheets are 
built. 

• Click Close to exit the Plan and Profile Generator dialog.  You will be 
prompted to ‘Save Current VDF File?’ 

• Click No. 
 
The individual Profile DGN is generated. 

15.  • In MicroStation -- Verify you are currently in the DGN File named 
1234567_16.dgn. 

• Ensure that your view in MicroStation matches that shown in Figure L6-4. 
 

Views the Profile in MicroStation. 
  
 

 
Figure L6-4 MicroStation Window 
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16.  For Information Only: 
 
At this point the Profile Sheets have been created and the Existing and Proposed Profiles 
have been plotted.  The Vertical Alignment curve data still needs to be viewed and the 
Annotation applied.  The remaining steps will instruct you on viewing the Vertical 
Alignment curve data and Annotating the Elevations. 
 
Information regarding the viewing of Profile Sheets. 

17.  All viewing of Vertical Alignments and Annotation must be performed in the 
1234567PR07.dgn file and not the individual Sheet File. 

• In MicroStation, Select File ► Open. 
• Navigate to Lab 6 – then Select and Open --- 1234567PR07.dgn. 
• In MicroStation, Click the Fit View button. 

 

 
 
                                           Fit View  
 
The 1234567PR07 DGN file is opened. 

18.  Open the View Vertical Annotation Dialog. 
 

• In InRoads, Select Geometry ► View Geometry ► Vertical Annotation. The 
View Vertical Annotation dialog opens as shown in Figure L6-5. 
 

The View Vertical Annotation dialog opens. 
   

                                          
Figure L6-5 MicroStation Window 
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19.  View and Annotate Vertical Alignment 
 

• Click the Preferences button. 
• Under the Name: field -- Select the Preference GDOT Profiles.  The GDOT 

Profiles Preference sets up the View Vertical Annotation dialog for viewing of 
the Vertical Alignment Annotation. 

• Click Load and Close. 
• Click Apply & Close in the View Vertical Annotation dialog. 
• Verify your view in MicroStation matches that shown in Figure L6-6. 

 
The Vertical Annotation is viewed. 

 
 
 
 

 
Figure L6-6 MicroStation Window 

 
 
 

20.  View the Profile and Vertical Alignment Elevations  
 
In InRoads, Select Evaluation ► Profile ► Annotate Profile.  The Annotate Profile 
dialog opens. 
 
The Annotate Profile dialog opens. 

Verify the Vertical 
Alignment has 
been annotated. 
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21.  View the Profile and Vertical Alignment Elevations  
 
A Profile Preference will be selected – once the Preference is selected the settings for 
Alignment DE7 will be entered into the dialog box. 
 

• Click the Preferences button. 
• Under the Name: field -- Select the Preference 50h_10v_Profile.  The 

50h_10v_Profile Preference sets up the Annotate Profile dialog for viewing of 
the Terrain Profile and Vertical Alignment Elevations. 

• Click Load and Close. 
• In the Annotate Profile dialog select the Profiles as shown in Figure L6-7. 

 
The 50h_10v_Profile Preference is selected. 

 

 
Figure L6-7 Annotate Profile 

 
22.  • Click Apply & click Close in the Annotate Profile dialog. 

• The Elevations for the Terrain (Green) and Vertical Alignment (Orange) are now 
viewed in the MicroStation Window.  

• Verify your view matches that shown in Figure L6-8 and that the Elevations have 
been annotated. 

 
The Elevations are viewed. 

 
 
 

Select the Profiles as shown 
here.  When selected they 
will appear highlighted in 
blue. 
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Figure L6-8 MicroStation Window 

 
23.  Open the Individual Profile Sheet DGN 

 
• In MicroStation, Select File ► Open. 
• Navigate to Lab 6  - then Select and Open --- 1234567_16.dgn  

      
**Remember: 1234567_16.dgn refers to the following: 
 
    PI# = 1234567 
    Section#  = 16 
     
Please Note: You may need to manually renumber the DGN files as needed if 
there are multiple Side Road or Cross Road Profiles. 

 
• Verify your view matches that shown in Figure L6-9. 

 
The Profile Sheet File 1234567_16.dgn is opened. 

24.  For Information Only: 
 
At this point the Profile Sheets have been created and all the Profile and Vertical 
Alignment information has been viewed.  From here the Designer should refer to the 
EDG and GDOT MicroStation Documentation to properly set the Level(s) and for 
additional documentation pertaining to Plotting Automation.  
 

Verify the Profile and 
Vertical Alignment 
Elevations have been 
viewed.  You may have to 
Zoom in to see them. 
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Figure L6-9 MicroStation Window 

 
25.  Save the InRoads Geometry File 

 
Whenever a change has been made to an InRoads Geometry Project – Save the project 
and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 6  in the following 
path:  C:\InRoads Data\1234567\Design Labs\Lab 6 
 
The Geometry File is saved to the following path:  
C:\InRoads Data\1234567\Design Labs\Lab 6 

26.                    
                 This concludes Lab 6.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 7 
Component and Template Creation 

 
Objective 
 
The objective of Lab 7 is to provide an overview of the InRoads Template Library and 
familiarize the Designer with the following: 
 
 Components  
 Constraints 
 Dynamic Settings   
 Display Rules 
 Preview Window 
 End Conditions   
 Template Library Organizer 
 Parametric Constraints 
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Lab 7A Set  Project Defaults and Open Files 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -   
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 scale project.  Enter 50 for the Text, Cell & Line Style Scale 

Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference. 

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 7\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 

7.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 7\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface Project 1234567_Exist is opened. 
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Lab 7B Create an InRoads Template Library (.ITL) 
 
In Lab7B, an InRoads Template Library will be created.  The InRoads Template Library is 
where the Designer will create all the Components necessary to generate a complete Template 
such as shoulders, travel lanes, barriers, medians and end conditions.  Component is the term 
InRoads uses to describe such pieces.  A completed Template is technically referred to as a 
Component also but for the sake of clarity the term Template will be used to describe a 
completed Template and Component will be used only to describe pieces of a Template.  A 
Component may be thought of as a CAiCE Fragment with some very important distinctions.  
CAiCE Fragments are created by Programmers using either GML (Geometric Modeling 
Language – a variation of C++) or VBA (Visual Basic for Applications) and the Designers are 
limited to the Fragments provided and the functionality they provide.  In InRoads, no 
programming is used in the creation of components and it becomes the responsibility of the 
Designer to learn the idea of Constraints and create the Component and the functionality required 
through the use of the Create Template window.  Constraints and Component creation will be 
covered in further detail in Labs 7C through 7H. 
 

8.  Open the Create Template Window 
 

• In InRoads, select Modeler ► Create Template.  The Create Template 
Window opens as shown in Figure L7-1. 

 
The Create Template Window opens. 

 
 

                     
Figure L7-1   Create Template Window 
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9.  Create an InRoads Template Library (.ITL) and name it GDOT_Lab7.itl 
 

• In the Create Template window, select File ► New ► Template Library… 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab7 
• Enter a File name: of GDOT_Lab7.itl. 
• Click Save. 
• Verify that the Template Library was created and that C:\InRoads 

Data\1234567\Design Labs\GDOT_Lab7.itl appears in the Create Template 
Window as shown in Figure L7-2. 

 
A new Template Library called GDOT_Lab7.itl has been created. 

 
 

 
Figure L7-2  Create Template Window 

 
 
 
 
10.  Save the Template Library 

 
• In the Create Template window, select File ► Save. 

 
The GDOT_Lab7.itl has been created and saved. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Verify the new Template Library 
has been created and is listed here. 
*HINT:  The window can be 
stretched open. 
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Lab 7C Components and Constraints 
 
Lab 7C will introduce you to Components and Constraints.  In this Lab a simple Travel Lane 
component will be created with 4 pavement layers, a Surface Layer (1.5” thick), an Intermediate 
Layer (2” thick), a Base Layer (3” thick) and a Graded Aggregate Base Layer (8” thick).   
 
For Information Only: 
 
The Diagram depicted below is a Guide for Designers to utilize in storing Components based on 
Slope and Distance. The Slope (Positive or Negative) is dependent on the direction the Point is 
located from the Parent Point. 
 
 

 
 
The Designer may use the Dynamic Settings dialog (see below) to assist in the creation of 
components/templates. The following is a brief overview of the available Precision Input Key-
In’s which may be used: 
 

o XY =  “Absolute coordinates” 
o DL =  “Delta coordinates from the last point placed” 
o HS =  “Horizontal delta distance and slope from last point placed” 
o VS =  “Vertical delta distance and slope from last point placed” 
o OL =  “Delta coordinates from the dynamic origin” 
o OS =  “Horizontal delta distance and slope from the dynamic origin” 

 
 
 
 
 
 
 
 
 
 
 
 

 

Positive Slope 
  

Negative Slope 

Positive Distance 

Negative Distance 
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11.  If not open from Lab 7B, Open the Create Template Window and the 
GDOT_Lab7.itl Template Library. (This step may be ignored if the Template Library 
is already open). 
 

• In InRoads, select Modeler ► Create Template.  The Create Template 
Window opens. 

• In the Create Template Window, select File ► Open. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 7\ 
• Highlight GDOT_Lab7.itl and click Open. 

 
Opens the GDOT_Lab7.itl Template Library. 

12.  Create a New Template 
 

• In the Create Template Window, select File ► New ► Template.  The new 
Template (Component) is created with the Dynamic Origin (purple box) of the 
component defaulted to 0,0 as shown in Figure L7-3.  The Dynamic Origin of a 
component is the reference location of the component. 

 
A new Template (Component) is created. 

13.  Rename the New Template to ‘Asphalt Lane’ 
 

• Right mouse click over New Template in the Template Library: Window and 
select Rename. 

• Key-in Asphalt Lane. 
 

Renames the Template to ‘Asphalt Lane’. 
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Figure L7-3   Create Template Window 

 
 
14.  Open the Dynamic Settings dialog. 

 
• In the Create Template Window, select Tools ► Dynamic Settings.  The 

Dynamic Settings dialog opens as shown here.  
 

 
The Dynamic Settings dialog is where Point Names 
and Point Styles can be applied to components during 
their construction.  The Dynamic Settings dialog can 
also be used to create components of varying shapes 
such as curb & gutter by utilization of key-ins or 
selections from the pull down menu.  It is also used to 
set the Dynamic Origin which is the reference point 
for the step values and the OL= and OS= key-ins. 
                                                                                                     
(NOTE:  Make sure that the Apply Affixes check box 
is Unchecked).  

 
 

New Template is created 
in the Template Library 
window. 

Dynamic Origin 
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15.  Set the Dynamic Settings X: and Y: Step Values 
 

• In the Dynamic Settings dialog, set the X: and Y: Step values to 1.0 as shown 
here. 

The Step values effect how the Create Template grid responds when 
placing a component.  This will be demonstrated in the next step.               
 
 

16.  Add a Simple Component to represent the Surface Layer of the Pavement Structure 
 

• In the Create Template Window, select Add ►Simple.  A Simple Component 
is selected and ready to be placed in the Create Template grid. 

• Move your cursor slowly around the grid and notice how your cursor locks on the 
grid points divisible by 1, 1.  This is the effect of setting the Step: values in the 
previous step. 

• Find the location X: = -1, Y: = -2 and place the component at this location. 
• Use the View Buttons (located at the bottom left of the Create Template grid) 

and experiment with viewing using these buttons and the wheel on your mouse 
until the view is similar to that shown in Figure L7-4. (Hint: You can also use a 
combination of the mouse wheel and Control or Shift keys to stretch/zoom).  

 

 
Figure L7-4   Create Template Window 

Point Identified for 
next step. 

View Buttons 
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17.  Move the Component to X =0, Y =0 

 
• Place your cursor over the Point identified in Figure L7-4. 
• Right mouse click and select Move Point. 

 

             
 

• With the Simple Component still dynamically attached to the cursor, place the 
cursor in the Dynamic Settings Precision Input Field and key-in xy=0,0 as shown 
here and press the Enter key on your keyboard. 

 

            
 

• Click the Fit button,  (located at the bottom left of the Create Template grid). 
 
 
 
 
 

• Ensure the component has moved as shown in Figure L7-5. 
 

  

**HINT: Many commands 
can be accessed by Right 
mouse clicking over the 
points or components or the 
grid itself. 

Dynamic Settings Precision 
Input Field.  Key-in xy=0,0 
and press the Enter key on 
your keyboard or use the 
pulldown and select xy= 
then key-in 0,0 in the key-in 
field.   

Fit button 
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Figure L7-5   Create Template Window 

 
 

18.  Open the Component Properties Dialog 
 

• Double click on the Component (not the points).   
• The Component Properties dialog opens as shown in Figure L7-6.   

 
 
 

 
Figure L7-6   Component Properties Dialog 

Ensure the Component has 
moved and this Point is at 0,0. 
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19.  Rename the Component from ‘BRDG_E_Hydraulics’ to ‘Surface’ and Apply the 
Style MAIN_P_EOP. 
 

• In the Component Properties dialog enter the following information: 
o Name:   Surface 
o Style:    MAIN_P_EOP 

• Verify your entries match those shown in Figure L7-7. 
• Click Apply & Close. 
• Note: When creating a component, the Name and Style default to the first 

alphabetical name in the Feature Style list. In this case, BRDG_E_Hydraulics 
happens to be the first alphabetical Feature Style and is changed to 
MAIN_E_EOP as shown below.        

• Make sure your view matches that shown in Figure L7-8. 
 

 
Figure L7-7   Component Properties Dialog 

 

 
Figure L7-8    Create Template Window 
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20.  Open the Point Properties Dialog 
 

• Double click on the upper leftmost Point shown with a purple square around it in 
Figure L7-8.   

• The Point Properties dialog opens as shown in Figure L7-9.   
 

The Point Properties dialog appears. (Note: your Screen Capture may have a different 
Feature Style listed instead of Default).    

 
 

 
Figure L7-9   Point Properties  

 
21.  Assign the Point the Name PGL and the Feature Style MAIN_P_EOP 

 
• In the Point Properties dialog enter the following information. 

o Name:  PGL (Point names are used in annotating the cross sections so it is 
important to keep up with the Point names you assign and choose a logical 
naming scheme.) 

o Surface Feature Style:  MAIN_P_EOP (The Feature Styles of Points 
control attributes of the point and can also be used to annotate cross 
sections so it is important to keep up with and select logical Feature 
Styles.) 

o Verify your entries match those shown in Figure L7-10. 
o Click Apply but do not close the Point Properties dialog. 
o Verify the Point has been named PGL as shown in Figure L7-11. 
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Figure L7-10    Point Properties 

 
 

 
Figure L7-11    Create Template Grid 

 
 
 
 

Verify the Point Name, PGL, has 
been assigned to this point. 
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22.  Assign Point 3 the Name PGLB and the Feature Style MAIN_P_EOP. 
 

• In the Point Properties dialog click the Next > button. 
• Verify Point 3 appears in the Name: field. 
• Change Point 3 to PGLB (Profile Grade Line Bottom). 
• Change the Surface Feature Style: to MAIN_P_EOP 
• Notice the Constraints entries.  Constraint 1 is Horizontal 0.000 feet from PGL.  

Constraint 2 is Vertical and -0.400 feet from PGL. 
• Change the Vertical Constraint from -0.400 to -0.125 and press the Tab key.  

This value represents 1.5” of pavement depth and is a common depth for the 
surface.  
*NOTE: InRoads rounds to three decimal places in the Constraints field but 

keeps the entire amount in memory.  In addition to keying in -0.125 
InRoads also accepts mathematical operations.  You could have keyed in 
-1.5/12 to represent 1.5 inches of depth divided by 12 to convert to feet. 

• Verify your entries match those shown in Figure L7-12. 
• Click Apply but do not close the Point Properties dialog. 

 
 

 
Figure L7-12   Point Properties 
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23.  Assign Point 1 the Name LANE and the Feature Style MAIN_P_EOP. 
 

• In the Point Properties dialog click the Next >button. 
• Verify Point 1 appears in the Name: field. 
• Change Point 1 to LANE. 
• Change the Surface Feature Style: to MAIN_P_EOP  
• Notice the Constraints entries.  Constraint 1 is Slope -2.000% feet from PGL.  

Constraint 2 is Horizontal and 12.000 feet from PGL.  Accept these 
Constraints. 

• Verify your entries match those shown in Figure L7-13. 
• Click Apply but do not close the Point Properties dialog. 

 
 
 
 

 
Figure L7-13   Point Properties 
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24.  Assign Point 2 the Name LANEB and the Feature Style MAIN_P_EOP. 
 

• In the Point Properties dialog click the Next > button. 
• Verify Point 2 appears in the Name: field. 
• Change Point 2 to LANEB (LANE Bottom). 
• Change the Surface Feature Style: to MAIN_P_EOP 
• Notice the Constraints entries.  Constraint 1 is Horizontal and 0.000 feet from 

LANE.  Constraint 2 is Vertical and -0.400 feet from LANE. 
• Change the Vertical Constraint by keying in -1.5/12 and pressing the Tab key to 

accept the entry. This value represents 1.5” of pavement depth and is a common 
depth for the surface.  

• Verify your entries match those shown in Figure L7-14. 
• Click Apply and Close to exit the Point Properties dialog. 
• Click the Fit button in the Create Template Window and verify your Surface 

Component matches that shown in Figure L7-15. 
 
                           
                                                                  Fit Button 
 
This completes the creation of the Surface Component of the Travel Lane. 

 
 

 
Figure L7-14   Point Properties 
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Figure L7-15    Create Template Grid 

 
25.  For Information Only: 

 
In the previous Steps, we created a 1.5” Surface Pavement layer by adding a Simple 
Component and making the appropriate edits.  InRoads has 6 types of Components that 
can be placed as described here: 
 

1. Simple: A Simple Component is a simple prefabricated closed rectangular shape.  
This is useful for the quick setup of rectangular shapes like a travel lane as was 
demonstrated in the previous steps. 

2. Constrained: A Constrained Component is placed one point at a time and can be 
either a closed or open shape. It is useful for making objects of differing shapes 
such as curb and gutter.  The points in Constrained Components can be set to 
behave in a particular manner by the selection of the differing constraint options.  
The default constraint is set to be Horizontal and Vertical to the previous point 
placed.  

3. Unconstrained: An Unconstrained Component is placed one point at a time, the 
same as a Constrained Component, but is placed with no constraint defaults 
applied.  The constraints of points composing both Constrained and 
Unconstrained Components can be edited after placement to apply whatever 
constraints the user desires. 

4. Null Point:  Null Point Components are placed unconstrained to other 
components and are typically edited to control the behavior of other points.  Null 
Points can be edited to behave as ‘Display Switches’ in order to display different 
components under differing conditions such as Type S Barrier switching between 
the S1, S2 or S3 variations. 

5. End Condition: End Condition Components are used to tie to a surface - 
typically the existing surface.  Cut/Fill slopes are the typical type components 
created with End Condition Components.  End Condition Components can be 
designed with ditches incorporated and that widen for guardrail when certain 
conditions are met. 

6. Overlay/Stripping: Components used for milling/stripping and overlay 
operations. 
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26.  The next Pavement layer, a 2” Intermediate Pavement Layer, will be constructed by 
placing a Constrained Component.  Begin by opening the Dynamic Settings dialog. 
 

• The Dynamic Settings dialog should still be open from the previous Lab. If it is 
not still open from the previous Lab, then select it in the Create Template 
Window, by selecting Tools ► Dynamic Settings.   

• Set the Step: Values to 0.000 as shown in Figure L7-16. 
 

 

  
Figure L7-16  Dynamic Settings 

 
27.  The Step: Values Control the X and Y Cursor Movement Increments on the Grid.  

A Value of 1, 1 Moves the Cursor in Increments of 1’ Horizontally and 1’ Vertically. 
 

• In the Create Template Window, select Add ►Simple.   
• Move your cursor and the Simple Component around the grid.  Notice how it 

moves smoothly and doesn’t ‘snap’ to any location on the grid. 
• Right mouse click and select Cancel. 
• Enter X and Y Step: values of 1.000 and 1.000.  
• In the Create Template Window, select Add ► Simple. 
• Move your cursor and the Simple Component around the grid.  Notice how the 

cursor locks onto grid points located in increments of 1’ Horizontally and 1’ 
Vertically as measured from the Dynamic Origin. 

• Right mouse click and select Cancel. 
• Return the X and Y Step: values to 0.000 and 0.000 as shown in Figure L7-17. 

Step: values will not be required for this exercise.  This has simply been a further 
demonstration of the Step: functionality. 

• Left click on the X: Y: button, .  Notice this toggles to X: Slope:, .  The 
grid can be incremented using either method. 

• Left click on the X: Slope: button to toggle back to an X: Y: entry. 
 
 

 

The Dynamic Settings dialog is 
useful when adding Constrained 
Components.  The Point Name, 
Point Style, and location can all 
be performed in one step 
minimizing the number of steps 
in creating a component. 



Introduction to InRoads - Design  InRoads SS2 – Lab 7 
 

   
 Lab7-20   

 
Figure L7-17    Dynamic Settings 

 
 
28.  Begin Constructing the 2” Intermediate Pavement Layer. 

 
• In the Create Template Window, select Add ► Constrained. 
• Hover your cursor over the Point PGLB.  Notice the Red Point changes to White.  

This indicates this Point and its exact location will be selected if you were to Left 
click. 

• Left click on the Point PGLB.  Notice when you move your cursor a line is 
dynamically moved with the cursor as shown in Figure L7-18. 

 
 
 
 

 

 
Figure L7-18    Create Template 

Enter 0.000 in these two 
fields. 

Dynamic line follows 
cursor when placing a 
Constrained Component. 
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29.  
   
Label the Component ‘Intermediate’ and Give the Component a Feature Style of 
‘MAIN_P_EOP’. 
 

• With the Dynamic line still attached, move the cursor to the Current Component 
entry field and Left click in the field as shown in Figure L7-19. 

• In the Name:  field key-in Intermediate as shown in Figure L7-19. 
• In the Style:  field use the pull down arrow to select MAIN_P_EOP as shown in 

Figure L7-19.   
 
 

 
 
  
 
 

 
Figure L7-19   Create Template 

 
 
 
 
 
 

Place cursor here 
and key-in 
Intermediate 

Use the pull down arrow 
to select 
MAIN_P_EOP 
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30.  Continue Constructing the 2” Intermediate Pavement Layer. 
 

• Move your cursor into the Dynamic Settings dialog and click in the Point Name: 
field. 

• Key-in PGLIB (Profile Grade Line Intermediate Base). 
• In the Point Style: field use the pull down arrow to select MAIN_P_EOP. 
• Under the Apply Affixes check button use the pull down arrow to select dl =  
• Key-in 0,-2/12 in the Precision Input Field.   
• Verify your entries match those shown in Figure L7-20. 
• With your cursor in the Precision Input Field, press the Enter key on your 

keyboard. 
• Verify a .166’ vertical link and Point PGLIB were drawn as shown in  

Figure L7-21.  
 

Note:  
 If your Dynamic Line appears different than the screen capture depicted below in 
 Figure L7-21 – the Closed Shape Setting may be turned on. This may be determined by 
right mouse clicking over the component.  If this is the case – leave the Closed Shape 
turned on. This setting is required to be on in the following Steps. 

 

                                                    
Figure L7-20 Dynamic Settings 

 

    
Figure L7-21    Create Template 
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31.  If not on - Turn on the Closed Shape Setting. 
 

• Right mouse click in the Create Template Grid.  Ensure a check mark exists next 
to Closed Shape as shown here.   

 
 
 
 
 
 

• Move your cursor around the Create Template Grid.  Notice the Component is 
now a Closed Shape rather than a line as shown in Figure L7-22. 

 
 

 
Figure L7-22   Create Template Grid 

 
 

32.  Continue Constructing the 2” Intermediate Pavement Layer. 
 

• In the Dynamic Settings dialog enter the following information: 
o Point Name:  LANEIB 
o Point Style:  MAIN_P_EOP 
o hs =  12, -.02 (hs= horizontal distance, slope) 

• Verify your entries match those shown in Figure L7-23. 
• With your cursor in the Precision Input Field, press the Enter key on your 

keyboard. 
• Click the Fit button. 

                                
                                                                       Fit Button 

• Verify your view is similar to that shown in Figure L7-24 and that Point 
LANEIB has been created 12’ from PGLIB at a Slope of - 2.00%.  Notice the 
shape is still dynamically attached to your cursor. 

Notice the Component 
is now a Closed Shape. 
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Figure L7-23 Dynamic Settings 

 

 
Figure L7-24 Create Template Grid 

 
33.  Complete the 2” Intermediate Pavement Layer shape. 

 
• Left click on Point LANEB. 
• Right mouse click and select Finish. 
• Verify your Component matches that shown in Figure L7-25. 

 
This completes the addition of the 2” Intermediate Pavement Layer. 

Precision Input Field 

LANEIB 
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Figure L7-25   Create Template Grid 

 
34.  Even though the Intermediate Pavement Layer appears complete, the constraints 

are such that it will not superelevate correctly when Superelevation is applied.  
Superelevation is most easily applied to the Points across the Pavement Surface. All 
Points below the Surface must be constrained so they will adjust accordingly.  This 
should become clearer as we make the constraint changes. 
 

• Double click on Point LANEIB.  The Point Properties dialog opens as shown in 
Figure L7-26.  Notice the two constraints are Slope and Horizontal. This follows 
the input we used in the Dynamic Settings dialog in Step 32 (hs=12,-.02).  With 
LANEIB constrained as a slope to PGLIB it will not superelevate when the 
Surface superelevates but will remain constrained at a 2.00% slope to PGLIB. 

• Change the Slope constraint to Vertical by using the pull down arrow. 
• Change the Parent 1:  for the Vertical constraint to LANEB, either by key-in or 

using the Locate button. 
• Change the Parent 1:  for the Horizontal constraint to LANEB, either by key-in 

or using the Locate button. 
 

**NOTE - Parent/Child Relationships:                                                                                                                                                                     
Parent/Child is the terminology InRoads uses to describe the constraint 
relationship between two points.  In Figure L7-26 LANEIB is the 
Child and PGLIB is the Parent.  This means LANEIB will behave in 
response to the movements of PGLIB according to the constraints 
applied to it. 

 
• Verify your entries match those shown in Figure L7-27. 
• Click Apply & Close.  LANEIB is now constrained Vertically and Horizontally 

to LANEB and will move in response to LANEB.  Since LANEB is constrained 
vertically/horizontally to LANE the Superelevation of all pavement layers 
superelevate appropriately. 

 
This completes the construction of the 2” Intermediate Pavement Layer. 

 

LANEB 
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Figure L7-26     Point Properties            

 
 

Figure L7-27         Point Properties            
 
          

35.  At this point you have created a 1.5” Surface Pavement Layer by placing a Simple 
Component and a 2” Intermediate Pavement Layer by placing a Constrained 
Component.  Now let’s create the 3” Base Layer by placing an Unconstrained 
Component and editing the Points to assign the proper constraints. 
 

• Clear the Point Name: field in the Dynamic Settings dialog and set the Point 
Style: to Default.  It should look like this:  
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36.   
• In the Create Template Window, select Add ► Unconstrained. 
• Change the Current Component Style: to Default  as shown here: 

 

 
 
 

• Left click on Point PGLIB. 
• Continue placing Points counter-clockwise as shown in Figure L7-28 to create a 

‘rough’ Pavement Layer shape.  Remember to Right mouse click and select 
‘Finish’ to finish creating the shape.   

 
*HINT:  Ensure a check mark exists next to ‘Closed Shape’ during construction.  

This may be accomplished by right mouse clicking in the grid during 
placement of the component. 

 
 
 
 

                
Figure L7-28   Create Template Grid 
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37.  Name the Component ‘Base’ and Apply a Feature Style of ‘MAIN_P_EOP’. 
 

• Double click on the newly created Component. The Component Properties 
dialog will open. 

• Enter the following information: 
o Name:  Base 
o Style:    MAIN_P_EOP 

• Verify your entries match those shown in Figure L7-29. 
• Click Apply and Close.  Notice the ‘Base’ Component turns Green. 

 
 
 
 
 

 
Figure L7-29      Component Properties 
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38.  Begin Editing the Points to Complete the ‘Base’ Pavement Layer. 

 
• Double click on the Unlabeled Point identified in Figure L7-30.  The Point 

Properties dialog will open.  Notice in the Point Properties dialog, the 
Constraints section contains no constraints.  This is the result of placing the 
Component as an Unconstrained Component.  Constraints can still be added to 
make the Component look or behave as you need. 

• Key-in a Name: of PGLBB (Profile Grade Line Base Bottom). 
• Select a Surface Feature Style: of MAIN_P_EOP. 
• Define Constraint 1  

o Type:  Horizontal 
o Parent 1:  PGLIB 
o Value:  0.00 

• Define Constraint 2  
o Type:  Vertical 
o Parent 1:  PGLIB 
o Value:  -0.25  (3” Pavement Depth) 

• Verify your entries match those shown in Figure L7-31. 
• Click Apply and Close. 
• Verify point PGLBB and the Constraints were applied.  The View will have also 

automatically adjusted to fit the Grid as shown in Figure L7-32.  If not click the 
Fit button. The Base Pavement Layer looks strange at this point but will take 
shape once all the Constraints are defined and applied. 

 
 
                 
 
 
 
 
 
 
 
 
 
 
 

 
 

Figure L7-30   Create Template Grid 
 

Step 38 – Double click 
on Unlabeled Point. 
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Figure L7-31    Point Properties Dialog 

 
 

 
Figure L7-32    Create Template Grid 

 
 
  
 
 
 
 
 
 
 

Important: 
A common occurrence in 
InRoads when entering Values 
for Constraint 2 is for the 
Constraint 1 value to change in 
response.  ALWAYS double 
check your entries to ensure 
they are correct prior to 
accepting the entry. 
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39.  Edit the Unconstrained Point 1. 
 

• Double click on the Point labeled 1. 
• Key-in a Name: of LANEBB (LANE Base Bottom). 
• Select a Surface Feature Style: of MAIN_P_EOP. 
• Define Constraint 1  

o Type:  Horizontal 
o Parent 1:  LANEIB 
o Value:  0.00 

• Define Constraint 2  
o Type:  Vertical 
o Parent 1:  LANEIB 
o Value:  -0.25  (3” Pavement Depth) 

• Verify your entries match those shown in Figure L7-33. 
• Click Apply and Close. 
• Verify point LANEBB and the constraints were applied as shown in  

Figure L7-34.   
 
This completes the addition of the Base Pavement Layer Component. 

 

  
Figure L7-33   Point Properties Dialog 

Important: 
A common occurrence in 
InRoads when entering Values 
for Constraint 2 is for the 
Constraint 1 value to change in 
response.  ALWAYS double 
check your entries to ensure 
they are correct prior to 
accepting the entry. 
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Figure L7-34   Create Template Grid 

 
40.  At this point you have completed the 1.5” Surface Layer utilizing a Simple 

component, the 2” Intermediate Layer utilizing a Constrained component and the 3” 
Base Layer utilizing an Unconstrained component.  Let’s complete the 4th and Final 
Pavement layer utilizing a Simple component again.    This Layer will be called 
GAB and be 8” thick. 
 

• In the Create Template Window, select Add ► Simple. ‘Drop’ the Simple 
component on the Base Layer by Left clicking on the Point PGLBB. 

• Click Fit to fit the view. 
 

41.  Name the Component GAB and give it a Feature Style of MAIN_P_EOP. 
 

• Double click on the Component. The Component Properties dialog will open. 
• Enter the following information: 

o Name:  GAB 
o Style:    MAIN_P_EOP 

• Verify your entries match that shown in Figure L7-35. 
• Click Apply and Close. 

 
 
 

 
Figure L7-35   Component Properties 
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42.  Rename Point 3 to PGLGAB, Apply the Surface Feature Style: MAIN_P_EOP and 
edit Constraints to create an 8” pavement. 
 

• Double click Point 3. 
• Match the entries shown in Figure L7-36. 
• Click Apply & Close. 

 
 
 

                                
Figure L7-36    Point Properties Dialog 
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43.  Rename Point 2 to LANEGAB, Apply the Surface Feature Style: MAIN_P_EOP 
and edit Constraints to create an 8” pavement. 
 

• Double click Point 2. 
• Match the entries shown below in the Point Properties dialog. 
• Click Apply & Close. 
• Click Fit to fit the view. 
• Verify your View matches that shown in Figure L7-37. 
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Figure L7-37   Create Template Grid 

 
 

44.  Save the Component. 
 

• In the Create Template Window, click File ► Save.  This completes the 
construction of a 12’ Travel Lane with 4 Pavement Layers. 

 
This construction of the 12’ Travel Lane with 4 Pavement Layers is now complete. 

45.  For Information Only: 
 
For the Travel Lane we just created in Lab 7C, we used several different types of 
components.  This was used in order to demonstrate the various ones available.  We 
could easily have created the Travel Lane using only one type of component.  There are 
many ways to create any desired component and the way a component is created will 
vary from Designer to Designer.  The same holds true for constraints.  Several different 
combinations of constraints can result in components with the same behavior.  The 
constraints used to define the behavior of a component will vary from Designer to 
Designer. Thus it is very important that all InRoads users become very familiar with the 
different types of components and constraints.  
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Lab 7D Display Rules 
 
In addition to constraints to control the behavior of components - the user may also employ 
Display Rules to further the capability of a component.  Display Rules are used to turn on and 
off different parts of the same component.  To demonstrate the use of Display Rules, in this Lab 
we will create a simple 3.5’ by 2’ wide wall (Wall Type 1) that will switch to a 6’ tall by 4’ wide 
wall (Wall Type 2) when the vertical distance from the existing ground to a certain point exceeds 
3.5’.  The walls and the Point names we will employ are shown in Figure L7-38.  One workflow 
that works well for constructing this component is to build two separate components first and 
then drop one component on top of the other component and then define the Display Rules.  
This is how we will approach building this component. 
 

 
Figure L7-38   Wall Shapes 

 
 
 
 
 
 
 
 
 
 
 
 
 

WTL WTR 

WBR WBL WBR
 

WBL 

WTR WTL 

3.5’ X 2.0’ 6.0’ X 4.0’ 

Wall Type 1 Wall Type 2 
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46.  If not open from Lab 7C, Open the Create Template Window and the 
GDOT_Lab7.itl Template Library. (This step may be ignored if the Template Library 
is already open). 
 

• In InRoads, select Modeler ► Create Template.  The Create Template 
Window opens. 

• In the Create Template window, select File ► Open. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 7\ 
• Highlight GDOT_Lab7.itl and click Open. 

 
47.  Create a new Template and call it Wall 1. 

 
• In the Create Template window, select File ► New ► Template. 
• Right mouse click over New Template in the Template Library: Window and 

select Rename. 
• Key-in Wall 1. 

 
48.  Draw an Unconstrained ‘Rough’ Wall shape approximately 3.5’ high by 2.0’ wide.   

 
• In the Create Template window, select Add ► Unconstrained. 
• Draw the shape Clockwise beginning at the bottom Left Point as shown in  

Figure L7-39. 
 
*HINT: Right click to ensure ‘Closed Shape’ is checked. 
 
•  Right click to check ‘Finish’ when Shape is completed. 
 
*NOTE: The Color/Smbology of the wall you draw 
 may vary from the color depicted in the screen captures 
 shown below. 
                                                    
                           

 

 
Figure L7-39     Create Template Dialog Grid 

Bottom Left 
Point 



Introduction to InRoads - Design  InRoads SS2 – Lab 7 
 

   
 Lab7-38   

49.  Open the Dynamic Settings Dialog 
 

• Open the Dynamic Settings dialog box. Select Tools ► Dynamic Settings. 
 

50.  Add a Null Point at X,Y = 0,0. 
 

• In the Create Template window, select Add ► Null Point. 
• In the Dynamic Settings dialog enter the following information: 

o Point Name:  NP 
o Point Style:  Default 
o Key-in:  xy=0,0 

• Verify your entries match those shown here. 
 

                                     
 

• With the Cursor in the Precision Input Field – press the Enter button on your 
keyboard. 
 
*NOTE: Null Points are generally used as reference points for defining 
constraints in other components.  In this case the wall will be constrained 
horizontally to the Null Point.  When this wall is used in a cross section design 
the Null Point would be inserted so as to follow a horizontal alignment or another 
component as will be discussed in more detail in the lab on the Roadway 
Designer.  This will allow us to constrain the wall to move vertically to the 
ground yet also constrained horizontally to an alignment or another component. 

 
• Verify a Null Point labeled NP was placed at 0,0 as shown in Figure L7-40. 

 
 
 

Precision input key-in 
entry field 
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Figure L7-40     Create Template Dialog Grid 

 
 
 

51.  Edit Point 3. 
 

• Double click on Point 3 as shown in Figure L7-40 above. 
• In the Point Properties dialog that opens, match the entries shown in  

Figure L7-41. 
• Click Apply & Close. 
• Ensure Point 3 was renamed WBR (Wall Bottom Right). 

 
*NOTE: The ‘Project To Surface’ constraint used in this step behaves as its name 
implies and projects the point to a defined surface in the direction assigned.  The 
effects of this constraint are not immediately realized but can be seen by clicking the 
Test button just below the bottom right hand side of the Create Template Grid.  A 
Surface must be open and active for testing to work. 

 
 
 

Ensure NP was 
stored at 0,0. 

1 

3 
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Figure L7-41   Point Properties 

 
 
52.  Edit Point 2. 

 
• Double click on Point 2. 
• In the Point Properties dialog that opens, match the entries shown in 

 Figure L7-42. 
• Click Apply & Close. 
• Ensure Point 2 was renamed WTR (Wall Top Right). 
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Figure L7-42    Point Properties 

 
 
 
 
 
53.  Edit Point 1. 

 
• Double click on Point 1. 
• In the Point Properties dialog that opens, match the entries shown in  

Figure L7-43. 
• Click Apply & Close. 
• Ensure Point 1 was renamed WTL (Wall Top Left). 

 
 

 
 

Important: 
A common 
occurrence in 
InRoads when 
entering Values for 
Constraint 2 is for 
the Constraint 1 
value to change in 
response.  ALWAYS 
double check your 
entries to ensure they 
are correct prior to 
accepting the entry. 
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Figure L7-43   Point Properties 

 
 
 
 
 
54.  Edit the Remaining Unnamed Point. 

 
• Double click on the Unnamed Point. 
• In the Point Properties dialog that opens, match the entries shown in  

Figure L7-44. 
• Click Apply & Close. 
• Ensure the Point was renamed WBL (Wall Bottom Left). 

 
 

 
 

Important: 
A common 
occurrence in 
InRoads when 
entering Values for 
Constraint 2 is for 
the Constraint 1 
value to change in 
response.  ALWAYS 
double check your 
entries to ensure they 
are correct prior to 
accepting the entry. 
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Figure L7-44    Point Properties 

 
 
 
 
55.  Rename the Component to Wall 1. 

 
• Double click on the Component (not the Points). 
• Match the entries shown in Figure L7-45. 
• Click Apply & Close. 
• Verify your Wall 1 matches that shown in Figure L7-46. ((Note:  the screen 

capture is zoomed in– so your view may be slightly different).). 
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Figure L7-45   Component Properties 

 

 
Figure L7-46    Create Template Dialog Grid 

 
 

56.  Open the Test End Conditions Window  
 

• Click the Test button in the lower right corner of the Create Template window.  
The Test End Conditions window opens as shown in Figure L7-47. 

• Zoom Out by using the wheel on your mouse.  If your mouse does not have a 
wheel - click the Zoom Out button until your screen is similar to that shown in 
Figure L7-48. 
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Figure L7-47   Test End Conditions 

 

 
Figure L7-48    Test End Conditions 
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57.  Test the Wall. 
 

• In the Test End Conditions window, click the Draw button.  The Draw button 
draws a line representative of the Active Surface at the Slope defined in the Use 
Surface Slope: entry field. 

• Move your cursor up and down in the Test End Condition window.  Notice the 
Wall moves up and down staying on the existing ground.  This is in response to 
the Project To Surface constraint we placed on Point WBR.  A view of the Wall 
in its original location remains in the grid as shown in Figure L7-49.  This is 
normal. 

• Click Close to close the Test End Conditions window.  Testing will be covered 
in more detail in the section on End Conditions. 

 
 
 
 

 
Figure L7-49    Test End Conditions 

 
 
 
 
 

Wall shown in its 
original location. 

Wall shown 
following active 
surface. 
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58.  Save Your Work 
 

• In the Create Template Window, click File ► Save. 
 

59.  Copy Wall 1 to Wall 2 
 

• In the Create Template window - Right mouse click over Wall 1 and select 
Copy as shown here. 

                                                               
• In the Create Template Window - Right mouse click over the Directory Path 

and select Paste as shown here. 
 

                                                   
 
 

 
 
 
 
 
 
 
 
 
 
 

Right mouse click 
over Wall 1. 

Select Copy. 

Right mouse click 
over Directory Path. 

Select Paste. 
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60.  Rename Wall11 to Wall 2. 
 

• You should now have a component called Wall11.   
• Right mouse click over Wall11 in the Template Library: Window and select 

Rename. 
• Rename it to Wall 2 and make it the Active Component (by double clicking it) 

ensuring a Red Square is around it as shown here. 
 

                                                           
 
 
 
 

61.  Edit Point WTL in Wall 2 to make it 6’ High. 
 

• With Wall 2 active, double click Point WTL. 
• In the Point Properties dialog - change the Vertical constraint from 3.50 to 6.00. 
• Click Apply & Close. 
• Fit the view. 
• Ensure your Component corresponds to that shown in Figure L7-50. (Note:  the 

screen capture below is zoomed out – so your view may be slightly different). 
 

 

 
Figure L7-50    Create Template Grid 

 
 

Ensure Wall 2 is the 
Active Component by 
double clicking it.  A 
Red Square indicates it 
is the active component. 
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62.  Edit Point WTR in Wall 2 to make it 4’ Wide and 6’ High. 
 

• With Wall 2 active, double click Point WTR. 
• Change the Horizontal constraint from 2.00 to 4.00. 
• Change the Vertical constraint from 3.50 to 6.00. 
• Click Apply & Close. 
• Fit the view. 
• Ensure your Component matches that shown in Figure L7-51. 

 

 
Figure L7-51   Create Template Grid 

 
63.  Edit Point WBR in Wall 2 to make it 4’ Wide. 

 
• With Wall 2 active, double click Point WBR. 
• Change the Horizontal constraint from 2.00 to 4.00. 
• Click Apply & Close. 
• Fit the view. 
• Ensure your Component matches that shown in Figure L7-52. 

 
 
 

 
Figure L7-52   Create Template Grid 
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64.  Rename Component 

 
• Double click on Wall 2 (Double Click the Component – not the Points). 
• Notice in the Component Properties dialog which opens that the Component 

name is still Wall 1. 
• Rename the Component to Wall 2. 
• Click Apply & Close. 

 
 

65.  Save Your Work 
 

• In the Create Template Window, click File ► Save. 
 

 
66.  For Information Only: 

 
At this point we have created two separate components.  One component representing 
Wall 1 and one component representing Wall 2.  Now it is time to drag and drop Wall 2 
on top of Wall 1 creating a single Component with both walls. 
 
 
 

67.  Make Wall 1 the Active Component. 
 

• Double click on Wall 1 (in the Template Library: list) and ensure a Red Square 
exists next to it indicating it is the Active Component. 

 
 
 

68.  Highlight Wall 2 
 

• Left Click once on Wall 2 so that it is highlighted in blue but not the Active 
Component as shown here. 
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69.  Ensure the Insertion Point for Wall 2 is at point WBL. 
 

• When Wall 2 was highlighted in blue, it became visible in the Preview: window.  
See Figure L7-53.   

 
*NOTE: The Preview window is where the Insertion Point of a component can be 
changed and is identified by the light blue square shown in Figure L7-53.  The 
Insertion Point can be changed to any Point in the component and is selected by 
left clicking on any Point in the Preview window. 

 
• In the Preview: window, Left click on the lower left Point (WBL) to ensure it is 

the Insertion Point. 
 
 

 
 

 
Figure L7-53   Create Template Window 

 
 
 

Preview Window 

Insertion Point (WBL) 
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70.  Place Wall 2 on Wall 1 
 

• Left click and hold Wall 2 and drag to WBL in the Grid and place on WBL.  
 

*HINT: Use the wheel on your mouse to zoom in and out as necessary. 
 

• Fit the view and ensure your view matches that shown in Figure L7-54. 
• When one Component is placed on another, matching Point Names are appended 

numerically beginning with 1.  Notice there are now Points named WTL & 
WTL1, WTR & WTR1 and WBR & WBR1 in Figure L7-54. 

• When Points are dropped directly onto one another the default behavior is to 
merge the two Points together.   Zoom into point WBL in the lower left corner 
and you will see there is not a WBL and a WBL1.  Only a WBL.  The two Points 
were merged into one Point. 
 

 
 

 
Figure L7-54   Create Template Window 
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71.  For Information Only: 
 
At this point we have created Wall 1 and Wall 2 and placed them together in Wall 1.  
Currently they are both displaying all the time.  Now it is time to add Display Rules to 
each Component that will limit them to viewing only under certain conditions.  Wall 1 is 
intended to be viewed when the Vertical distance between NP and WBR is less than 3.5’ 
and Wall 2 is intended to be viewed when the Vertical distance between NP and WBR is 
greater than or equal to 3.5’.  Remember WBR is constrained to move to the existing 
surface. 
 

72.  Ensure Wall 1 is the Active Component. 
 

• Ensure Wall 1 is still the Active Component by double clicking on it and ensuring 
a Red Square exists next to it. 

 
73.  Open the Component Properties dialog. 

 
• Double click on the Component Wall 1 (The Smaller Wall).  The Component 

Properties dialog opens. 
 

74.  Open the Component Display Conditional Expression Dialog. 
 

• Click the Edit… button in the Component Properties dialog.  The Component 
Display Conditional Expression dialog then opens as shown in Figure L7-55. 
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Figure L7-55   Component Display Conditional Expression Dialog 

 
 
 

75.  Open the Display Rule Dialog. 
 

• Click on the Add… button.  The Display Rule dialog opens as shown in  
Figure L7-56. 

 
 
 
 

 
Figure L7-56   Display Rule Dialog 
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76.  Create a New Rule called Wall1.  This Rule, when applied, will tell the Component 
Wall 1 to turn off when the Vertical distance between points NP and WBR reach or 
exceed 3.5’ 
 

• Enter the following information: 
o Name:   Wall1 
o Description:  NP < 3.5’ 
o Type:  Absolute Vertical 
o Between:  NP 
o And:  WBR 
o  <    3.500 

• Verify your entries match those shown in Figure L7-57. 
• Click OK.  You are returned to the Component Display Conditional 

Expression dialog as shown in Figure L7-58 with the new Display Rule Wall1 
showing in the Template Display Rules field which makes it available to select 
as a rule to apply to a Component. 

 
 
 
 

 
Figure L7-57   Display Rule Dialog 
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Figure L7-58   Component Display Conditional Expression Dialog 

 
 

77.  Apply the New Rule 
 

• Left click on rule Wall1 (in the Template Display Rules field) to highlight it in 
Blue. 

• Click the Selected Rule button.  This places rule Wall1 in the Conditional 
Expression... field which allows the rule to be applied to the Component. 

 
*NOTE:  The ‘AND’, ‘OR’, and ‘NOT’ buttons allow you to apply multiple 
Display Rules to a single component allowing the user to apply much more 
detailed display control to a component. 
 

• Click the = button.  The result of True tells you the current condition of the rule 
as it is displayed on the Create Template window. 

• Click OK. 
• Click Apply and Close. 
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78.  Test the Component 
 

• Click the Test button. 
 
*NOTE: The Test button is for the sole purpose of testing ‘End Condition’ 
components which we have not covered yet.  Since we have a ‘Project to Surface’ 
constraint defined in this component we can get an idea of how the component 
will behave by using the Test button even though it is not intended to be used for 
this purpose. 
 

• Click the Draw button and move the cursor up and down to see how the 
component behaves.  The smaller component should appear and disappear when 
the distance between NP and WBR is greater than or equal to 3.5’ as we told it to 
do in the Display Rule. 
 
*HINT: Use the mouse wheel to zoom in and out further if necessary. 

 
• Close the Test End Conditions window. 

 
79.  Open the ‘Component Properties’ Dialog. 

 
• Double click on the Component Wall 2 (The Larger Wall).  The Component 

Properties dialog opens. 
 

80.  Open the ‘Component Display Conditional Expression’ Dialog. 
 

• Click the Edit button in the Component Properties dialog.  The Component 
Display Conditional Expression dialog opens. 

• Notice the Display Rule ‘Wall1’, created earlier, is available for use. 
 

81.  Rather than create a new Display Rule to control the display of Wall 2 we can use 
the Display Rule, Wall1, to control the display of Wall 2. 
 

• Click the NOT button. This places the expression NOT in the Conditional 
Expression… for Wall 2 Component field. 

• Highlight the Display Rule Wall1. 
• Click the Selected Rule button.  This places the rule Wall1 in the Conditional 

Expression… for Wall 2 Component field behind the expression NOT. 
• Verify your dialog matches that shown in Figure L7-59. 
• Click OK. 
• In the Component Properties dialog click Apply & Close. 
• Notice the Component Wall 2 disappeared from View.  This is because in its 

current location the Display Rule turns its display off. 
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Figure L7-59   Component Display Conditional Expression 

 
82.  Test the Component 

 
• Click the Test button. 
• Click the Draw button and move the cursor up and down to see how the 

component behaves.  The smaller component should appear and disappear when 
the distance between NP and WBR is greater than or equal to 3.5’ as we told it to 
do in the Display Rule.  The larger component should also appear and disappear 
except only when the distance between NP and WBR is not less 3.5’. 
 
*HINT: Use the mouse wheel to zoom in and out further if necessary. 

 
• Close the Test End Conditions window. 

 
83.  Save Your Work. 

 
• In the Create Template Window, click File ► Save. 

 
84.  Close the Create Template Window. 

 
• In the Create Template Window, select File ► Close. 
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Lab 7E End Conditions 
 
In Lab 7C you learned about components and constraints.  One Component that was not 
discussed was the End Condition.  End Conditions are special components that target a surface 
and are typically used to create Cut/Fill slopes.   
 
In Lab 7E we will build an End Condition component that places a 4:1 Fill slope for 10’ vertical, 
a 2:1 Fill slope over 10’ vertical that widens 5.5’ for guardrail and a cut slope with a 4’ Flat 
bottom ditch with a 12’- 4:1 front slope and a 2:1 back slope as shown in Figure L7-60. 
 

 
Figure L7-60     End Condition 
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85.  If not open from Lab 7D, Open the Create Template Window and the 
GDOT_Lab7.itl Template Library. (This step may be ignored if the Template Library 
is already open). 
 

• In InRoads, select Modeler ► Create Template.  The Create Template 
Window opens. 

• In the Create Template Window, select File ► Open. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 7\ 
• Highlight GDOT_Lab7.itl and click Open. 

 
86.  Create a New Template and call it CUT/FILL 

 
• In the Create Template Window, select File ► New ► Template. 
• Right click and rename the Template CUT/FILL as shown here. 

 

                             
 

87.  Open the Dynamic Settings dialog and set the X and Y Step: Values to .200 and 
.200, the Point Name to OPS, and the Point Style to MAIN_P_SHLDR. 
 

• In the Create Template Window, select Tools ► Dynamic Settings. 
• Enter the following information: 

o X Step:  0.200 
o Y Step:  0.200 
o Point Name:  OPS (Outside Paved Shoulder) 
o Point Style:  MAIN_P_SHLDR 

• Verify your entries match those shown here. 
 

                                                                                                    
• Continue to the next Step. 
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88.  Add the 1:4 Cut Ditch End Condition Component to CUT/FILL. 
 

• In the Create Template Window, select Add ► End Condition. 
• In the Current Component field enter the following information: 

o Name:  1:4 Cut Ditch 
o Style:  LIMT_P_CUT 

• Verify your entries match those shown here: 
 

             
 

• Left Click once on the coordinates 0,0 in the Create Template grid. 
• Notice point OPS was placed at 0,0 and a blue dynamic line extends from it as 

shown here. 

                                       
 

• Notice the Dynamic Settings dialog changes to that shown in Figure L7-61. 
 

 

                                             
Figure L7-61   Dynamic Settings Dialog 
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89.  Create the Front Slope Point of the 1:4 Cut Ditch Component. 
 

• In the Dynamic Settings dialog, uncheck the Check for Interception box. 
• Enter a Point Name: of IDT (Inside Ditch Bottom). 
• Enter a Point Style: of DRNG_P_Ditch. 
• In the Precision Input Field key-in hs=12,-1:4. 
• Ensure your entries match those shown in Figure L7-62. 
• With the cursor still in the Precision Input Field, press the Enter key on your 

keyboard. 
• Fit the view. 
• Ensure the front slope and the point IDT were drawn as shown in Figure L7-63. 

A dynamic line should be extending from IDT. 
 

                                              
Figure L7-62   Dynamic Settings  

 

 
Figure L7-63   Create Template Grid 
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90.  Create the Ditch Bottom for the 1:4 Cut Ditch Component. 
 

• Match the entries shown in Figure L7-64. 
• With the cursor still in the Precision Input Field, press the Enter key on your 

keyboard. 
• Fit the view. 
• Ensure the ditch bottom and the Point ODT (Outside Ditch Bottom) was drawn as 

shown in Figure L7-65. A dynamic line should be extending from ODT. 
 

 

                                              
Figure L7-64   Dynamic Settings 

 
 

 
Figure L7-65   Create Template Grid 
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91.  Create the Back Slope for the 1:4 Cut Ditch Component. 
 

• Match the entries shown in Figure L7-66. 
• With the cursor still in the Precision Input Field, press the Enter key on your 

keyboard. 
• Fit the view. 
• Ensure the ditch bottom and the Point CUT were drawn as shown in  

Figure L7-65. A dynamic line should be extending from CUT. 
• In the Create Template grid, Right mouse click and select Finish.  The dynamic 

line should have disappeared completing the component. 
 

 

                                              
Figure L7-66   Dynamic Settings 

 

 
Figure L7-67   Create Template Grid 

 

LIMT_P_CUT_Const-Limit   - This Feature 
Style should be applied to the final point in a 
CUT End Condition component to ensure the 
construction limits are viewed properly. 

With the End Condition is Infinite box 
checked, the back slope will extend until the 
ground is reached. 



Introduction to InRoads - Design  InRoads SS2 – Lab 7 

   
 Lab7-65   

92.  For Information Only:  Dynamic Settings Information 
 
When placing End Condition components, four new check boxes appear in the Dynamic 
Settings dialog as shown in Figure L7-66 above.  Their function is described here: 
 

• Check for Interception: To intercept a target such as a surface, the Point’s Check 
for Interception property must be set.  Sometimes segments such as Ditch 
Foreslopes are not meant to intercept a target.  They are meant to be placed only if 
a later segment finds the target.  These segments Check for Interception property 
should be unchecked.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Place Point at Interception: In order to place a point at the target, the Place Point 
at Intersection property must be set.  Sometimes a point needs to be placed at the 
end of a segment even if the target is intercepted prior to the end of the segment.  
An example is a minimum depth ditch foreslope 5’ deep.  In this case, clearing the 
Place Point at Interception property will place the 5 foot ditch foreslope even if 
the surface is found at three feet. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

In this example, Check for Interception for 
Segment 1 and Segment 2 should be 
unchecked and Segment 3 should be 
checked.  This will result in Segment 3 
searching for the ground.  If Segment 3 does 
not find the ground the solution fails and the 
whole end condition will not be drawn. 

Segment 1 

Segment 2 

Segment 3 

Segment 1 

Segment 2 

Segment 3 

In this example, Place Point at Interception 
for Segment 1 and Segment 2 should be 
unchecked.  This will result in the full 
length of the segments being drawn and not 
being intercepted at the ground.  Segment 3 
should be checked.  This will result in 
Segment 3 stopping at the ground. 
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• End Condition is Infinite: Very often the constraints of an End Condition Point 
are defined as Slope and Horizontal.  The Horizontal Constraint value represents 
the maximum width within which to check for the target.  For example a 1:6 slope 
may be appropriate for a maximum width of 18 feet.  This would be represented in 
InRoads as a segment with a 1:6 slope constraint and Horizontal Constraint of 18 
feet when the End Condition is Infinite check box is unchecked.  If the End 
Condition is Infinite check box is checked the segment seeks the surface without 
limit.  This check box is generally checked on the final cut or fill alternative.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Do Not Construct: The Do Not Construct check box specifies the point will be 
solved like all other points in the End Condition, but the point will be skipped 
when drawing the component segments.  This is useful in many situations, 
including variable slope solutions. A point with this property checked is like any 
other point in the template but the surface segments are not drawn to it and no 
surface feature is created for that point.  This allows the ability to provide 
Variable Slope solutions, such as Clear Zone and Right of Way tie-ins. 

 
93.  Test the Component. 

 
• Click the Test button. 
• Test the End Condition with a 0% slope. 
• Notice the whole ditch draws and the back slope terminates at the existing 

ground, as shown below, which is what we want.  This is a result of the 
combination of Dynamic Settings (Check for Interception, Place Point at 
Interception and End Condition is Infinite) boxes we checked. 

 

            
 
 

Segment 1 

Segment 2 

Segment 3 

In this example, End Condition is Infinite 
for Segment 1 and Segment 2 should be 
unchecked.  This will result in the 
constrained length of the segments being 
drawn and not being extended to intercept 
the ground.  Segment 3 should be checked.  
This will result in Segment 3 being extended 
or trimmed at the ground regardless of the 
length defined in the segment. 
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• Test the End Condition with a 10% slope. 
• Notice the whole ditch again draws and the back slope terminates at the existing 

ground as shown below. 
 

             
 

• Test the End Condition with a -10% slope. 
• Notice the two conditions shown here:  The top condition provides a solution and 

the bottom condition fails to find a solution. 
 

            
 

            
 

• The desired solution to the failed condition is shown here. 
 
 
 
 
 
 
            
 
 

• Close the Test End Conditions window. 
• As demonstrated during testing– No combination of End Condition Dynamic 

Settings can provide a solution for all possible combinations of existing ground 
situations.  The solution is to build additional End Condition components into the 
first placed end condition component.  Priorities are then set that provide 
appropriate solutions as will be shown in the next steps. 
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94.  Add a 1:4 Cut End Condition Component to CUT/FILL that will solve when the 1:4 
Cut Ditch Component Does not. 
 

• In the Create Template Window, select Add ► End Condition. 
• Enter the following information in the Current Component field. 

 
 

     
 
 

• Enter the following information in the Dynamic Settings dialog. 
 

             
 

• With the cursor in the Precision Input Field, press the Enter key on your 
keyboard. 

• Fit the view. 
• Verify Point OPS1 was placed at the coordinate 0.5,0.5 and that a blue line 

extends dynamically from it as shown in Figure L7-68. 
 

 

*NOTE: Priorities define the 
order in which the End 
Condition components are 
tested.  If the component defined 
as Priority 1 finds a solution, all 
other priorities are ignored. So it 
is important to consider the 
Priority you assign to ensure the 
proper solution is used. 

Precision Input field 

MAIN_P_SHLDR 
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Figure L7-68   Create Template Grid 

 
 

95.  Create the Front Slope of the 1:4 CUT Section. 
 

• Match the entries shown in the Dynamic Settings dialog. 
 

             
 

• With your cursor in the Precision Input Field, press the Enter key on your 
keyboard. 

• Verify Point IDT1 was drawn and your view matches that shown in Figure L7-69 
with a blue line extending dynamically from it. 
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Figure L7-69   Create Template Grid 

 
 
96.  Create the Ditch Bottom of the 1:4 CUT Section. 

 
• Match the entries shown in the Dynamic Settings dialog. 

 

             
 

• With your cursor in the Precision Input Field, press the Enter key on your 
keyboard. 

• Right mouse click over the grid and select Finish. 
• Verify Point ODT1 was drawn and your view matches that shown in 

 Figure L7-70. 
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Figure L7-70   Create Template Grid 

 
 

97.  For Information Only. 
 
Notice in Figure L7-70 that we created the 1:4 CUT component slightly offset from the 
1:4 Cut Ditch component.  The reason for this is because if we had created it directly on 
top of the 1:4 Cut Ditch component the points would have merged with the already 
existing points and not behaved as an independent component as we want.  Now we can 
move the 1:4 CUT component directly onto the 1:4 Cut Ditch component and the points 
will not automatically merge. 
 

98.  Move the 1:4 CUT component on top of the 1:4 Cut Ditch component. 
 

• Right mouse click over Point OPS1 and select Move Point. 
 

*NOTE:  You may have noticed during the process of creating points that points are 
identified with Green, Yellow or Red plus signs.  A green plus sign ( ) 
means the point is unconstrained.  A yellow plus sign ( ) means the 
point has one constraint and the red plus sign ( ) means that a point has 
two constraints. 

 
• Place OPS1 directly on top of OPS. 
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99.  Merge Points OPS1 and OPS. 
 

• Right mouse click over OPS1 and OPS and select Merge Points. 
• In the Delete Point selection box, select OPS1.  This deletes Point OPS1 and 

merges it with OPS. 
 

*NOTE: Earlier we stated we did not want to merge the points.  We didn’t want to 
merge IDT1 with IDT nor ODT1 with ODT but we do want to merge 
OPS1 with OPS.  The reason for this is End Conditions must have a 
common starting point to work properly.  

 
100.  Test the End Condition. 

 
• Click the Test button. 
• Test the component with 0%, 10% and -10% slopes.  The cut section should now 

solve correctly for all cut situations described in Step 93. 
• Close the Test End Conditions dialog. 
• In the Create Template Window, select File ► Save to save your work. 

 
101.  Add a 1:4 Fill End Condition Component to CUT/FILL. 

 
• In the Create Template Window, select Add ► End Condition. 
• Match the entries shown here in the Current Component field. 

 

           
 

• Left click on OPS. 
• Ensure the component begins at OPS and that a yellow dynamic line extends 

from OPS as shown in Figure L7-71.  
 
*NOTE: The color of the line and the line style is determined by the Style.  In this 

case LIMT_P_FILL.  The style also determines what level the 
information will be placed on when it is viewed in MicroStation so it is 
important to properly assign styles to all of your components and 
points. A list of available styles is available in the Design Guidelines. 

 
 

 

Notice the 
Priority changes. 
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Figure L7-71   Create Template Grid 

 
102.  Create a 10’ High Fill Slope for the 1:4 Fill Component. 

 
• Match the entries shown here in the Dynamic Settings dialog. 

 

            
 

• With the cursor in the Precision Input Field, press the Enter key on the keyboard. 
• Right mouse click and select Finish. 
• Fit the view. 
• Ensure the fill slope and the FILL point were drawn as shown in Figure L7-72. 
• Double click on the FILL point. 
• Notice it is constrained vertically -10 ft and at a -1:4 (-25%) slope from OPS. 
•  Close the Point Properties dialog. 

 

LIMT_P_FILL_Const-Limit   - This 
Feature Style should be applied to the final 
point in a FILL End Condition component to 
ensure the construction limits are viewed 
properly. 

Unchecking End Condition is Infinite defines 
the slope to build only to the constraints we 
define.  In this case, -10 feet vertically and at 
a -1:4 slope.  Beyond that the component does 
not find a solution and the next priority is 
tested. 

vs= -10,-1:4.  This constrains the slope 
vertically -10ft. and at a -1:4 slope. 
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Figure L7-72   Create Template Grid 

 
 

103.  Test the End Condition. 
 

• Click the Test button. 
• Test the component with 0%, 10% and -10% slopes.   
• Verify the Fill slope displays when the Cut sections fail to find a solution. 
• Close the Test End Conditions dialog. 

 
104.  Add a 1:2 Fill End Condition Component to CUT/FILL. 

 
• In the Create Template Window, select Add ► End Condition. 
• Match the entries shown here in the Current Component field. 

 

            
 

• Left click on OPS. 
• Ensure the component begins at OPS and that a yellow dynamic line extends 

from it. 
 
 

Notice the 
Priority changes. 
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105.  Add the Guardrail widening portion. 
 

• Match the entries shown here in the Dynamic Settings dialog. 
 

                                                                   
 

• With the cursor in the Precision Input Field, press the Enter key on your 
keyboard. 

• Verify that a 5.5’ shoulder was drawn at 2.0% from OPS as shown in  
Figure L7-73. 

 
 

 

             
Figure L7-73   Create Template Grid 

 
 
 

Ensure the 
shoulder was 
widened 5.5’ at 
2.0%. 

Ensure the check boxes are 
unchecked. 
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106.  Add a 1:2 Fill Slope on the back of the Guardrail Widening Portion. 
 

• Match the entries shown here in the Dynamic Settings dialog. 
 

           
 

• With your cursor in the Precision Input Field, press the Enter key on your 
keyboard. 

• Right mouse click in the grid area and select Finish. 
• Verify your Component matches that shown in Figure L7-74. 

 
 

 
 

             
Figure L7-74     Create Template Grid 

 

LIMT_P_FILL_Const_Limit 
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107.  Test the End Condition. 
 

• Click the Test button. 
• Test the component with 0%, 10% and -10% slopes.   
• Close the Test End Conditions dialog. 

 
108.  For Information Only: 

 
• As mentioned previously – the Designer may use the Dynamic Settings dialog to 

assist in the creation of components/templates. The following is a brief overview 
of the available Precision Input Key-Ins which may be used: 

 
o XY =  “absolute coordinates” 
o DL =  “delta coordinates from the last point placed” 
o HS =  “horizontal delta distance and slope from last point placed” 
o VS =  “vertical delta distance and slope from last point placed” 
o OL =  “delta coordinates from the dynamic origin” 
o OS =  “horizontal delta distance and slope from the dynamic origin” 

 
109.  This completes Lab 7 Section E.  Save your work and Close the Create Template 

Window. 
 

• In the Create Template Window, select File ► Save. 
• In the Create Template Window, select File ► Close. 
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Lab 7F The Template Library Organizer  
 
In Lab 7F you will learn about the Template Library Organizer.  The Template Library 
Organizer is a tool in InRoads to share components and templates between different InRoads 
Template Library’s (.ITL’s).  This tool is useful when working on multiple projects that use an 
identical template.  Rather than recreate the template, the Template Library Organizer can be 
used to copy the template or templates from one project’s template library to another. 
 
 
 

110.  If not open from Lab 7E, Open the Create Template Window and the 
GDOT_Lab7.itl Template Library. (This step may be ignored if the Template Library 
is already open). 
 

• In InRoads, select Modeler ► Create Template.  The Create Template 
Window opens. 

• In the Create Template window, select File ► Open. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 7\ 
• Highlight GDOT_Lab7.itl and click Open. 

 
 

111.  Open the Template Library Organizer 
 

• Select Tools ► Template Library Organizer…  The Template Library 
Organizer opens as shown in Figure L7-75. 
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Figure L7-75   Template Library Organizer 

 
 

112.  Open the Template Library ‘GDOT_StandardV8i.itl’ in the Template Library 
Organizer. 

• Left click on the Locate button ( ). 
• Navigate to C:\InRoads Data\1234567\Design Labs\Standards\ 
• Select GDOT_Standard V8i_SS2.itl and Click Open. 

 
113.  For Information Only: 

 
The GDOT_Standard V8i_SS2.itl is a GDOT provided Template Library available on 
the ROADS webpage. It is obtained by downloading the InRoadsALL.exe and 
extracting the files to the default location.  More information about the InRoadsALL.exe 
is available in the GDOT Design Guidelines.  The GDOT_Standard V8i_SS2.itl 
Template Library is provided as a starting point for template creation and is in no way 
intended to supply the Designer with all the components necessary to design project cross 
sections.  Many users may be accustomed to the GDOT supplied CAiCE Fragment 
library which contains all of the fragments necessary to build a project’s template(s).  In 
InRoads, no such library can be created.  All components provided in the 
GDOT_Standard V8i_SS2.itl, when put together to create a template, must be edited to 
provide the behavior desired by the Designer depending on how they are placed.  This 
will become clearer once the user becomes familiar with InRoads template creation and 
the Roadway Designer. 
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114.  Open each of the Folders in the Template Library Organizer. 
 

• Double click on each of the folders in the Template Library Organizer to open 
them. 

• Drag the Medians, Shoulders, Travel Lanes and End Conditions folders from 
the Right side to the Left side. 
*HINT:  Each of the folders must be dropped onto the Path (highlighted in blue) 
as shown in Figure L7-76. 

• Click OK and Select Yes to save the data to the GDOT_Lab7.itl Template 
Library and return to the Create Template Window. 

• Ensure the Create Template Window contains the new folders as shown in 
Figure L7-77. 
 

 
 

 
Figure L7-76   Template Library Organizer 

 

 
Figure L7-77  Create Template Window 

 
 

115.  The Template Library Organizer has now been used to copy four folders and the 
Templates contained within them from the GDOT_Standard V8i.itl to the 
GDOT_Lab7.itl.  Save Changes. 
 

• In the Create Template window, select File ► Save. 
 

*HINT:  The folder must 
be dropped directly onto 
the path as indicated by 
the arrow. 

Ensure the End Conditions, 
Medians, Shoulders and 
Travel Lanes Folders now 
appear at left. 
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Lab 7G Parametric Constraints  
 
Parametric Constraints are labels applied to values that are changeable.  Parametric Constraints 
allow dimensional changes without having to edit the template.  An example use of a Parametric 
Constraint would be for pavement depths.  By labeling the pavement depth, the depth can be 
changed at anytime by modifying the value assigned to the label without having to edit the 
template.  They are set up during the Create Template phase of cross section design and applied 
or changed during the Roadway Designer phase of cross section design.  In this Lab you will 
learn how to add Parametric Constraints to a component. 
 
 
 

116.  If not open from Lab 7F, Open the Create Template Window and the 
GDOT_Lab7.itl Template Library. (This step may be ignored if the Template Library 
is already open). 
 

• In InRoads, select Modeler ► Create Template.  The Create Template 
Window opens. 

• In the Create Template window, select File ► Open. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 7\ 
• Highlight GDOT_Lab7.itl and click Open. 

 
117.  Make the Component ‘Asphalt Lane PGL to Lane’ the Active Component. 

 
• In the Create Template Window, open the ‘Travel Lanes’ folder and the 

‘Asphalt’ sub-folder as shown here.  
 

                                                   
                                                   
 

• Double click on the component ‘Asphalt Lane PGL to Lane’ to make it the 
active component. 

• Ensure the component is displayed in the Create Template grid as shown in 
Figure L7-78. 
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Figure L7-78   Create Template Grid 

 
 

118.  Open the Point Properties Dialog for the Point PGLB. 
 

• Double click on the Point PGLB (Profile Grade Line Bottom).  The Point 
Properties dialog opens. 

 
119.  Labels for Parametric Constraints are added in the Label Field.  For the Vertical 

Constraint add a Label Named ‘Surface’. 
 

• In the Point Properties dialog, key-in Surface in the Label: field under 
Constraint 1 as shown in Figure L7-79.  If your Vertical Constraint has been 
built under Constraint 2 instead that is Ok.  Make the change to Constraint 2 if 
that is the case. 

• Click Apply & Close. 
• A Parametric Constraint named Surface has been created for the Point PGLB.  

The default value for the Vertical Constraint for PGLB will remain -0.125 until a 
value for Surface is defined.  Values for Parametric Constraints are added during 
the Roadway Designer phase of cross section design and will be covered in Lab 
8. 
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Figure L7-79   Point Properties 

 
 

120.  Open the Point Properties Dialog for Point LANEB. 
 

• Double click on the Point LANEB (Lane Bottom).  The Point Properties dialog 
opens. 

 
121.  Add a Parametric Constraint label named ‘Surface’ to the Vertical Constraint for 

the Point LANEB. 
 

• In the Point Properties dialog for LANEB use the pull down arrow to select the 
Label: Surface for the Vertical Constraint as shown in Figure L7-80. 

 
*NOTE: Once a Parametric Constraint label has been created in a component the 

label becomes available in the pull down menu for all points in the 
component. 

 
• Click Apply & Close.   

 

To create a Parametric 
Constraint label, key-in 
the label name in the 
Label: field.  Key-in 
Surface here. 
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Figure L7-80   Point Properties 

 
 

122.  For Information Only. 
 
The Parametric Constraint Surface has now been created and applied to both Points 
PGLB and LANEB.  Now when a value is defined for the Parametric Constraint Surface 
during the Roadway Designer phase -- the thickness for the surface layer will be reflected 
at both ends of the component. 
 
 

123.  Save Changes. 
 

• In the Create Template Window, select File ► Save. 
 

 
 
 
 

Select Surface from the 
Label:  pull down arrow. 



Introduction to InRoads - Design  InRoads SS2 – Lab 7 

   
 Lab7-85   

Lab 7H Create a Rural Roadway Template 
 
In the preceding sections of Lab 7 you were introduced to Components, Constraints, the 
Dynamic Settings window, Display Rules, the Preview Window, End Conditions, the Template 
Library Organizer and Parametric Constraints.  Now it is time to put all the pieces together and 
create a complete template.  In this section you will create a Rural Roadway Template with a 
depressed grassed median as shown in Figure L7-81. 
 

 
Figure L7-81   Rural Typical Section 

 
124.  If not open from Lab 7G, Open the Create Template Window and the 

GDOT_Lab7.itl Template Library. (This step may be ignored if the Template Library 
is already open). 
 

• In InRoads, Select Modeler ► Create Template.  The Create Template 
Window opens. 

• In the Create Template window select File ► Open. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 7\ 
• Highlight GDOT_Lab7.itl and click Open. 

 
125.  Create a New Template and Name it ‘Rural Typical’. 

 
• In the Template Library: list -- make sure to click on the Path to highlight it in 

blue.  (This is to ensure that the new Rural 
Typical template is created directly under this folder path).  

• In the Create Template Window, select File ► New ► Template. 
• Rename the new template Rural Typical. 

 
126.  Open the Dynamic Settings dialog. 

 
• Select Tools ► Dynamic Settings. 
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127.  Place the ‘Travel Lane’ Component First with the Inside Edge of the ‘Travel Lane’ 
at the PGL.  The PGL is located 22’ Horizontally from the Centerline and 0’ 
Vertically. 
 

• In the Create Template Window, open the Travel Lanes folder. 
• Under the Travel Lanes folder open the Asphalt subfolder. 
• With Rural Typical the active template, left click once on the component 

Asphalt Lane PGL to LANE (Located under the folder \Travel Lanes \Asphalt) 
and drag into the grid area but do not drop in the grid. 

• With the Left mouse button still depressed, right mouse click and then lift up on 
the left mouse button and select Mirror. The Mirror option prepares the 
component to be placed in both orientations at the same time (Left orientation and 
right orientation).  

• (DO NOT place the components on the Create Template grid yet)! 
• In the Dynamic Settings dialog, match the entries shown below: 

 

                                
 

• Place your cursor in the Precision Input Field of the Dynamic Settings dialog and 
press the Enter key on your keyboard. 

• Fit the view and ensure your view matches that shown in Figure L7-82. 
• Notice each Point placed on the Left Travel Lane is a duplicate of the Point 

placed on the Right Travel Lane but is appended with a 1.  As stated earlier in 
Lab 7 -- duplicate point names cannot exist in the same component/template.  
InRoads default behavior is to numerically append to a point each time the point 
is placed. 

 
*NOTE: Under Tools ► Options, in the Create Template Window, additional 

options are available for applying affixes to duplicate point names. 
 

*NOTE:  In the Dynamic Settings dialog, please note the Point Style: pull down has 
no effect on the Style of the Point(s) which have already been established 
in previously completed components.  Point Names and Point Styles are 
only applied during component construction. 

 

Key-in xy=22,0 in the 
Precision Input Field. 
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Figure L7-82   Create Template 

 
 

128.  Change the Right Lane Width from 12’ to 24’. 
 

• Double click on the Point named LANE to open the Point Properties dialog. 
• Edit the Horizontal Constraint from 12.00 to 24.00. 
• Click Apply and Close. 
• Fit the view. 

 
129.  Change the Left Lane Width from 12’ to 24’. 

 
• Double click on the Point named LANE1 to open the Point Properties dialog. 
• Edit the Horizontal Constraint from -12.00 to -24.00. 
• Click Apply and Close. 
• Fit the view. 
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130.  For Information Only: 
 
The InRoadsALL.exe mentioned earlier - which is available for download from the 
GDOT ROADS web page - contains a Component Description Library written for the 
components provided in the GDOT_Standard V8i_SS2.itl.  When InRoadsALL.exe is 
executed, the Component Description Library is placed on the user’s computer in the 
following location: C:\InRoads Data\Component Descriptions\. 
 

131.  The Component Description Files are included in the Path discussed in Step 130.   
 
 Right mouse click over the component ‘GACUTFIL’ and select Template 

Documentation Link… as shown here. 
 

                           
 
 
 In the Template Documentation Link dialog - click Open Link. 

 
 

           
 
 
 Take a moment to review the Component Description. 
 Close the Component Description PDF File. 
 Click Close to close the Template Documentation Link dialog. 

 
 
 
 
 

 
 

Open Link 
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132.  Continue creating the ‘Rural Typical’.  Place the Inside Shoulders. 
 

• In the Create Template Window, open the Shoulders folder. 
• With ‘Rural Typical’ still the active template/component; drag the Inside 

Shoulder component (located in the Shoulders folder) onto the PGL point as 
shown in Figure L7-83.  Notice the Mirror option is still active from the previous 
step.  Leave it active. 

• Notice the Point names for the ‘Inside Shoulder’ component appear when the 
component is placed. 

 
*NOTE: The upper right point, when dropped directly onto PGL, assumes the point 

name PGL and the point’s constraints even though it was created initially with 
the point name IEP (Inside Edge of Pavement).  If you desire to keep the point 
name, IEP, then do not place the component directly on PGL.  Place it 
elsewhere on the grid, than Right mouse click over IEP and select Move Point, 
then drop it onto PGL.  This will result in IEP and PGL occupying the same 
coordinates yet retaining their individual Point names and constraints.  This is 
useful when you do not want the constraints for the component to change.  
Many InRoads users prefer to always drop components away from one another 
then move them together so the point names and constraints do not change.  If 
they determine they do want the points and constraints to be the same, they then 
Right mouse click over the points and select Merge Points. 

 
   

 
 

 
Figure L7-83   Create Template Grid 

 
 
 

Drag the Inside 
Shoulder component 
from the upper right 
Point onto PGL.  With 
the Mirror option 
checked, the Inside 
Shoulder will be placed 
concurrently on the left 
side. 
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133.  Place the Median. 
 

• In the Create Template Window, open the Medians folder. 
• Highlight the MedianFBD-Low component so it becomes visible in the Preview: 

window as shown in Figure L7-84. 
• Change the Insertion Point from the middle to the right side by Left clicking on 

the top right point and ensure a blue box is depicted around the Point as shown 
here. 

 

                     
 

• With ‘Rural Typical’ the active template/component, drag the MedianFBD-
Low’ component into the grid area and Right click to bring up the option menu. 

• Click on Mirror to uncheck it. 
• Drop the median component directly onto point IS (Inside Shoulder). 
• Fit the view. 

   
 

  
Figure L7-84   Create Template 

Preview Window 

Click here to ensure the 
Insertion Point is the upper right 
point as indicated by the blue 
box. 

IS 
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134.  Place the Outside Shoulder. 
 

• In the Create Template Window, open the Shoulders folder. 
• With ‘Rural Typical’ the active component, drag the Outside Shoulder – 

Partial Depth component into the grid area. 
• Right mouse click and select the Mirror option. 
• Drop the shoulder onto Point LANE as shown in Figure L7-85. 

 
*HINT: If the Point Names begin to clutter your view, turn them off by un-checking 

‘Display Point Names’ in the Display field of the Create Template 
Window. 

 

 
• Fit the view. 

   
 

 
Figure L7-85   Create Template Grid 

 
135.  Place the End Condition ‘GACUTFIL’. 

 
• In the Create Template Window, open the End Conditions folder. 
• With ‘Rural Typical’ the active component, drag the GACUTFIL component 

into the grid area. 
• Ensure the Mirror option is selected. 
• Drop the GACUTFIL component directly onto the Point EOS (Edge of Outside 

Shoulder) as shown in Figure L7-86. 
• Fit the view. 
• Ensure your view matches that shown in Figure L7-86.   

LANE 
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Figure L7-86   Create Template Grid. 

 
 

136.  Currently there are two Green Points (PGL and PGL1) which are unconstrained 
and movable.  In InRoads, it is good practice to have only one Green point that is 
unconstrained and allowed to move freely.  The simple reason for this is ‘so you can 
be certain of what InRoads will do’.  When you place a template on an Alignment in 
the Roadway Designer (which you will do in Lab 8), the template is ‘run’ along the 
Green point (unconstrained point).  If you have more than one Green point 
(unconstrained point), InRoads will either not perform or try and assume 
something.  There is no way of knowing what InRoads assumed without 
investigating the cross sections to see what was done.  Constrain PGL1 vertically to 
PGL. 
 

• If Point Names are turned off, check the ‘Display Point Names’ in the Display 
field of the Create Template Window. 

• Window Area or Zoom into the area where the Point PGL1 is located.  PGL1 is 
located on inside edge of the Travel Lanes on the left side of the template as 
shown in Figure L7-86. 

• Double click on the Point PGL1 to open the Point Properties dialog. 
• Change Constraint 1 to Vertical. 
• Use the pull down menu next to Parent 1 to select PGL. 
• Leave the value as 0.000.  This will ensure that the elevation of PGL1 is the same 

as PGL. 
• Ensure your entries match those shown in Figure L7-87. 
• Click Apply & Close. 
• Notice PGL1 changes from a Green plus sign to a Yellow plus sign indicating it 

is singly constrained. 
• Fit the view. 

 

PGL1 – Identified 
for Step 136. 

EOS 
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Figure L7-87   Point Properties dialog 

 
 

137.  Save your Template. 
 

• In the Create Template Window, select File ► Save. 
   

138.  Zoom in the Left Shoulder. 
 

• Select the Window Area button and window as shown in Figure L7-88. 
 

                               
    
                                                                      Window Area  Button   
     

• Ensure your view matches that shown in Figure L7-89. 
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Figure L7-88   Create Template Grid 

 
         

 
Figure L7-89   Create Template Grid 

 
 

139.  In InRoads Template design, Rollover Locks determine how components will 
superelevate in relation to one another.  For instance, a common rotational behavior 
for a GDOT outside paved shoulder is to maintain a 6.0% slope until an algebraic 
difference of 8.0% is reached and then rotate the shoulder so as not to exceed an 
algebraic difference of 8.0%.  The Rollover Locks for the shoulders must be set up 
by the user by editing points.  Set the Rollover Locks for OPS1. 
 

• Double click on Point OPS1 or Right mouse click over the Point and select Edit 
Point to open the Point Properties dialog as shown in Figure L7-90. 

• Place a check mark in the box next to Parent 2 to activate the Rollover Values… 
button. 

• Click the Rollover Values… button.  The Rollover Point Properties dialog 
opens as shown in Figure L7-91. 

 

Window Area to the 
extents shown here. 
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Figure L7-90   Point Properties 

 

 
Figure L7-91   Rollover Point Properties 

Place a check mark 
in the Parent 2 check 
box. 
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140.  As stated previously, the normal rotational behavior for a GDOT outside paved 
shoulder is to maintain a 6.0% slope until an algebraic difference of 8.0% is reached 
and then rotate the shoulder so as not to exceed an algebraic difference of 8.0%.  
Fill in the Rollover Point Properties dialog to achieve this behavior. 
 

• Define the Reference Point to be PGL1 by use of either the Locate button or the 
Pull Down Menu. 

• Enter 8.00% in the Entry field for High Side. 
• Enter 0.00% in the Entry field for the Low Side. 
• Ensure your entries match those shown in Figure L7-92. 
• Click OK in the Rollover Point Properties dialog. 
• Click Apply & Close in the Point Properties dialog. 
• This completes the setup of the Shoulder Rollover Locks for the Left side 

outside paved shoulder. We are not going to do the remaining shoulders but on an 
actual project the inside and outside paved and grass shoulders must also have the 
Rollover Locks set to complete the template. 

 
   

 
 

 
Figure L7-92   Rollover Point Properties 
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141.  Save your Template. 
 

• In the Create Template Window, click File ► Save.  This completes the 
construction of the Rural Roadway Template. 

 
 The GDOT_Lab7.itl is saved to the following path: 
C:\InRoads Data\1234567\Design Labs\Lab 7 

142.                    
                 This concludes Lab 7.  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 8 
Introduction to the Roadway Designer 

 
Objective 
 
The objective of this Lab is to provide a brief workflow overview of the Roadway Designer.  The 
Roadway Designer is located under the InRoads Modeler menu and is where Roadway Design 
Files (.IRD’s), Corridors, Template Drops, Point Controls, End Condition Exceptions, 
Superelevation and Final Surfaces are performed, assigned, created, etc.  
 
Following is the workflow and terminology of the Roadway Designer: 
 

Step 1. Create a Roadway Design File – The Roadway Design File (.IRD) is where 
Corridors are created, Templates are added to Corridors, Point 
Controls and End Condition Exceptions are added and Design 
Surfaces are created. 

Step 2. Create a Corridor – A Corridor is a strip of land defined by a horizontal and 
vertical alignment or alignments.  It can be considered the 
project’s footprint.  Cross section design is performed in the 
Corridor and the Final Surface is created from the corridor. 

Step 3. Add Template Drops – Template Drops are used to add Templates from the .ITL 
(InRoads Template Library) to specified station ranges in the 
Corridor. 

Step 4. Add Point Controls – Point Controls are used in cross section design to override 
a point’s normal constraint.  Example uses of Point Controls in a 
cross section design would be to have the point representing the 
outside edge of a travel lane, follow a horizontal alignment to 
widen for an auxiliary lane (such as a turn lane) or having a point 
follow a different vertical alignment for split grades. 

Step 5. Add End Condition Exceptions – End Condition Exceptions are applied to End 
Conditions during cross section design when the normal behavior 
of an End Condition is not sufficient for actual conditions and it is 
not desirable to create and place new templates.  Examples 
include steepening slopes to stay inside Right-of-Way and 
additional shoulder widening for guardrail anchorage. 

Step 6. Add Superelevation – Superelevation Control Lines are added to control the  
 Roadway cross slope in horizontal curve areas. InRoads utilizes   
 Superelevation Tables based on the current edition of the   
 AASHTO Green Book. 

Step 7. Create Final Surface –   The creation of a Final Surface DTM is necessary in 
InRoads.  The cross sections shown on the cross section sheets are 
generated from the Final Surface. The Construction Limits and 
the Roadway Ditches are also generated from the Final Surface. 
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Lab 8A Set  Project Defaults and Open Files 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 scale project.  Enter 50 for the Text, Cell & Line Style Scale 

Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference. 

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 

7.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface Project 1234567_Exist is opened. 
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8.  Open GDOT_Lab8.itl 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight GDOT_Lab8.itl 
• Click Open & Cancel. 

 
The Template Library GDOT_Lab8 is opened. 
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Lab 8B  Create a  Roadway Design and Corridor 
 
In Lab8B, the Roadway Designer will be opened and a Roadway Design file (.IRD) will be 
created called 1234567.ird. The Roadway Designer will then be used to create a new Corridor 
called SR100 SPUR utilizing the Horizontal Alignment DE31, shown in Figure L8-1 below, and 
the Vertical Alignment DE31.  
 
  
 
 

 
Figure L8-1 MicroStation V8i Window 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

SR100 SPUR 
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9.  Open the Roadway Designer. 
 

• Select Modeler ► Roadway Designer.  The Roadway Designer Window opens 
as shown in Figure L8-2. 

 
 
 

 
Figure L8-2 Roadway Designer 

 
 
10.  Create an InRoads Roadway Design (.IRD) and name it 1234567.ird 

 
• In the Roadway Designer Window, select File ► Save As. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 8. 
• Enter a File name: of 1234567.ird. 
• Ensure your entries match those shown in Figure L8-3. 
• Click Save.   

 
A new Roadway Design called 1234567.ird has been created. 
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Figure L8-3 Save Roadway Design As Dialog 

 
 
11.  Open the Roadway Design file  

 
Even though 1234567.ird was saved in the previous step - it must still be opened.  Open 
the Roadway Design File 1234567.ird saved in the previous step. 
 

• In the Roadway Designer, select File ► Open. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 8 
• Highlight 1234567.ird, created in the previous step. 
• Click Open. 
• Verify the Roadway Designer menu bar reads C:\InRoads 

Data\1234567\Design Labs\Lab 8\1234567.ird as shown in Figure L8-4. 
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Figure L8-4 Roadway Designer 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Ensure 1234567.ird is the 
active Roadway Design file. 
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12.  Open the Corridor Tab in the InRoads Workspace Bar. 
 

• In the InRoads Workspace Bar, right mouse click over any of the tabs and select 
Corridors as shown here. 

 

                                              
 
 
 

• Click on the Plus Sign next to Roadway Designer to expand the list. The 
Roadway Design 1234567 should now be shown in the Workspace bar as 
depicted here. 

 
       

             
 

13.  Create a New Corridor called ‘SR100 SPUR’  
 

• In the Roadway Designer Window, select Corridor ► Corridor Management.  
The Manage Corridors dialog opens similar to that shown in Figure L8-5. 

• Key-in SR100 SPUR in the Name: field. 
• Ensure the Surface Symbology: is set to FINISH 
• Ensure the Type: is set to Alignment and the Horizontal Alignment and Vertical 

Alignments match what is shown in Figure L8-5. 
• Click Add & Close. 

 
 
 

Right mouse click 
over tabs and select 
the Corridors tab. 

The Roadway Design file 
1234567 appears in the 
Corridors tab. 
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Figure L8-5 Manage Corridors 

 
 

14.  Ensure ‘SR100 SPUR’ is The Active Corridor. 
 

• In the InRoads Workspace bar, expand the Roadway Design file 1234567 and 
ensure the Corridor SR100 SPUR is listed and has a Red square around it as 
shown here indicating it is the Active Corridor. 

 

                                                             
 

• In the Roadway Designer Window, use the pull down arrow next to the 
Corridor: field to ensure SR100 SPUR is listed as shown in Figure L8-6. 
 

• In the Roadway Designer Window, select File ► Save. 
 

 
‘SR100 SPUR’ has been created and is now the Active Corridor. 

The Corridor SR100 SPUR 
should now be listed under 
the Roadway Design 
1234567 and have a Red 
square around it indicating 
it is the Active Corridor. 
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Figure L8-6 Roadway Designer 

 
  

Ensure SR100 SPUR is 
shown in the Corridor: field. 
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Lab 8C  Add the Templates ‘Two-Lane’ and ‘Two-Lane w/ Right 
Turn Lane’ To The Corridor and Transition between the 
Two Templates 

 
Once a template has been created with the Create Template tool as was shown in Lab 7, it is then 
placed or ‘dropped’ into a corridor at the desired Stations.  In Lab 8C, you will place a Typical 
Section named ‘Two_Lane’ as shown in Figure L8-7 and a Typical Section named ‘Two-Lane 
w/ Right Turn Lane’ as shown in Figure L8-8 onto the corridor SR100 SPUR.  You will also 
transition between the two templates so that a gradual taper occurs rather than a sudden change. 
 
 

 
Figure L8-7 Two-Lane Typical 

 
 
 
 

 
Figure L8-8 Two-Lane w/ Right Turn Lane Typical 
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15.  Open the Template Drops Window. 
 

• In the Roadway Designer Window, select Corridor ► Template Drops.  
The Template Drops dialog opens as shown in Figure L8-9. 

 
 
 

 
Figure L8-9 Template Drops 

 
16.  Set the Corridor: 

 
• In the Template Drops dialog, use the pull down arrow and ensure the Corridor: 

is set to SR100 SPUR as shown here. 
 

                                                                  
 

17.  Set the Station: 
 

• In the Template Drops dialog, enter the Station: 10+00.00 as shown below.  
This Station is where the template will begin and will be placed at every station 
from there forward until the project ends or another template is dropped. 
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18.  Set the Interval: 
 

• In the Template Drops dialog, enter an Interval: value of 25 as shown here.  The 
Interval:  specifies how often to place the template in feet.  A value of 25 will 
drop the template every 25 feet. 

                                                              
                                  

*IMPORTANT:   When choosing an Interval it is recommended to select a value 
based on how often you intend to show cross sections on the cross section 
sheets.  It is recommended that if 100 foot stationing is desired then a 50’ 
interval be entered, if 50 foot stationing is desired then a 25’ interval be 
entered and if 40 foot stationing is desired then a 20’ interval be entered, etc. 

 
19.  Add the ‘Two Lane’ Typical at Station 10+00.00 

 
• In the Template Drops dialog, open the 1234567 folder and highlight the Two 

Lane Template as shown here. 
 

                              
 

• Click the Add button but do not close the Template Drops dialog.  The Two 
Lane Template is added to the Current Template Drops: field as shown in 
Figure L8-10. 

 

  
Figure L8-10 Template Drops 

The ‘Two-Lane’ Template 
is added to the ‘Current 
Template Drops:’ field. 
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20.  Add the ‘Two Lane’ Template at Station 51+72.00.  This is the Station where the 
‘Two Lane’ Template will end and begin transitioning to the ‘Two Lane w/ Right 
Turn Lane’ Template which we will add in the next step. 
 

• In the Template Drops dialog, key-in a Station: of 51+72.00 
• Highlight the Two Lane Template. 
• Ensure your entries match those shown in Figure L8-11. 
• Click Add but do not close the Template Drops dialog. 
• The Two Lane Template is added to the Current Template Drops: field as 

shown in Figure L8-12. 
 

 
 

 
Figure L8-11 Template Drops 

 
 
 

 
Figure L8-12 Template Drops 

 
 
 

Ensure Two Lane is 
highlighted before 
clicking Add. 

The Two Lane Template 
now shows up at 
10+00.00 and 51+72.00. 
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21.  Add the ‘Two Lane w/ Right Turn Lane’ Template at Station 53+22.00.   
 

• In the Template Drops dialog, key-in a Station: of 53+22.00. 
• Highlight the Two Lane w/ Right Turn Lane Template. 
• Ensure your entries match those shown in Figure L8-13. 
• Click Add but do not close the Template Drops dialog. 
• The Two Lane w/ Right Turn Lane Template is added to the Current Template 

Drops:  field as shown in Figure L8-14. 
• Notice, in Figure L8-14, an ‘X’ is shown in the Enable Transition column next 

to the Two Lane w/ Right Turn Lane Template.  An ‘X’ in the field indicates a 
transition between the two differing templates exists and must be resolved. 

 
 

 
Figure L8-13 Template Drops 

 
 
 
 
 

 
Figure L8-14 Template Drops 

The Two Lane w/ Right 
Turn Lane Template now 
shows up at 53+22.00. 

An ‘X’ in the Enable Transition 
column signifies a transition 
between two differing templates 
must be defined. 
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22.  Before closing the Template Drops dialog to resolve the transitions, let’s look at the 
Template Drops dialog a little further. 
 

• Highlight Station 53+22.00 in the Current Template Drops: field. 
• Notice the Edit button becomes active as shown in Figure L8-15. 
• Click the Edit button.  The Editing Roadway Designer Template Drop 

Window opens as shown in Figure L8-16.   
• Continue to Step 23. 

 
 

 
Figure L8-15 Template Drops 

 

 
Figure L8-16 Editing Roadway Designer Template Drop 

 

When a ‘Template Drop’ is 
highlighted in the ‘Current 
Template Drops:’ field the Edit 
Button becomes active. 

Highlighted ‘Template Drop’. 
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23.  IMPORTANT: 
 
The Editing Roadway Designer Template Drops Window looks and functions the same as 
the Create Template Window.  Editing a Template in the Roadway Designer does NOT, 
however, save Template changes to the Template Library (.ITL).  The change is only 
saved in the Roadway Design file (.IRD). 
 

24.  While still in the Editing Roadway Designer Template Drop Window, edit the Right 
Turn Lane to be 24’ Wide. 
 

• Double click Point LANE2 as shown here to open the Point Properties dialog.  
Zoom in and out as necessary to assist in locating the Point and remember… 
Point names may be turned on and off by checking and un-checking the Display 
Point Names check box as desired. 

 

                   
 
 

• Change the Horizontal Constraint value from 12.000 to 24.000. 
• Ensure your entries match those shown in Figure L8-17. 
• Click Apply and Close. 
• Click the Fit button,   (located at the bottom left of the Editing Roadway 

Designer Template Drop grid) to fit the view. 
• The Right Turn Lane is now 24’ wide as shown here. 

 

                       
 
 

• Click OK to close the Editing Roadway Designer Template Drop Window and 
return to the Template Drops dialog. 

• DO NOT close the Template Drops dialog. 
 

 

LANE2 
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Figure L8-17 Point Properties 

 
 

Change the Horizontal 
Constraint from 12.000 
to 24.000. 
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Figure L8-18 Template Drops 

 
25.  For Information Only: 

 
Notice, in Figure L8-18 above, that the Template Two Lane w/Right Turn Lane has 
turned from black to red.  This indicates the Template has been edited and no longer 
matches the Template in the InRoads Template Library (.ITL). The ‘Revised In’ column 
tells where the edit was made.  In this case the change was made in the InRoads Roadway 
Design file (.IRD).  Template changes made in the Roadway Design file (.IRD) cannot be 
saved back to the Template Library (.ITL) as a new Template.  It is highly 
recommended that all necessary Template changes be made in the InRoads Template 
Library (.ITL) and that new Templates be created rather than editing the Roadway 
Design file (.IRD).  The Synchronize with Library button is often utilized during cross 
section development to return edited Templates to the unedited state in the InRoads 
Template Library (.ITL) which in turn causes all edits made in the Roadway Design file 
(.IRD) to be lost. 
 
Additionally: 
     Red Station text – Geometry has changed and stationing is invalid. 
     Red template library (.ITL) – Template did not come from the active template library.  
     Red template text – Template has been modified from that stored in the ITL.  
     Blue template text – Template does not exist in the active template library. 
 

• This information and more is also available via the Help button.  Click the Help 
button and take a moment to review the information available. 

Red text informs the user the 
Template has been edited and 
no longer matches the 
Template in the InRoads 
Template Library (.ITL). 

The Template was 
edited in the InRoads 
Roadway Design file 
(.IRD). 
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26.  As stated previously, the ‘Synchronize with Library’ button removes all Template 
edits and restores the Template to its original condition found in the Template 
Library (.ITL).  The widening of the turn lane to 24’ in Step 24 will be undone by 
using the ‘Synchronize with Library’ button. 
 

• In the Template Drops dialog, ensure the Template Drop at Station 53+22.00 is 
highlighted as shown in Figure L8-19. 

• Click the Synchronize with Library button.  The following warning message 
appears. 

                                 
 

• Click Yes. 
• Notice the Template is no longer Red and the ‘Revised In’ column returns to 

ITL. 
• Click Close to exit the Template Drops dialog. 

 
 

 
Figure L8-19 Template Drops 

Highlight the Template 
Drop at Station 
53+22.00. 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 
 

   
 Lab8-22   

27.  Process the Template Drops. 
 

• In the Roadway Designer Plan View, click the Fit button ( ) as shown in 
Figure L8-20 to fit the view. 

 
       *NOTE: The Plan, Profile and Cross Section Windows of the Roadway Designer 

can all be resized to your preference by holding your cursor over the edges 
of the windows and dragging.  Try it. 

 
• In the Roadway Designer Cross Section View, click the Fit button ( ) or zoom 

in so that your view appears similar to Figure L8-20. 
• Click the Process All button. 
• If a Results window opens, click Close to close the Results window. 

 
 

 
 

 
Figure L8-20 Roadway Designer 

 
 
 
 
 
 
 

Click the Fit button 
in the Plan View. 

Click the Process 
All button to apply 
Template Drops to 
the cross sections. 
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28.  Review Stations 51+72.00 to 53+22.00. 
 

• In the Roadway Designer, key-in 51+72.00 in the Station: field as shown in 
Figure L8-21. 

• Click the Right Arrow button ( ) to review stations 51+72.00 to 53+22.00. 
• Notice the gap that develops as you get closer to station 53+22.00 as shown here.  

The gap is the result of two different Templates not having the transition between 
the two resolved. 

 

                   
 
 

 
 

 
Figure L8-21 Roadway Designer 

 
 
 
 
 
 

Key-in 51+72.00 

Click the arrow buttons 
to review stations 
51+72.00 to 53+22.00. 

Notice the gap that 
develops as you review 
stations 51+72.00 to 
53+22.00. 
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29.  As stated earlier, when two differing Templates are placed, the transition between 
the two must be defined.  In this case the transition between the ‘Two Lane’ 
Template and the ‘Two Lane w/ Right Turn Lane’ Template must be resolved.  
Open the Edit Transition window. 
 

• Double click the Yellow transition zone in the Plan View as shown here.  
The Edit Transition window opens as shown in Figure L8-22. 

 

            
 
 

 
 

*NOTE on Graphics in Plan View:   
A Yellow transition zone indicates 
no editing to the transition has 
occurred.  A Light Blue transition 
zone indicates some editing has 
occurred.  A Dark Blue transition 
zone indicates all transitioning has 
been accounted for.  The Orange 
lines on either side of the transition 
zone indicate Template Drop 
locations. 
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Figure L8-22 Edit Transitions 
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30.  Move the Template to get a better view. 
 

• Right mouse click over any Red, Green or Yellow plus symbol in the Edit 
Transition window and select Move Template. 

• Move your cursor around the Window to see how the Template can be moved. 
• Left click anywhere in the view to stop moving the Template. 

 
31.  Bold Colored Plus Symbols indicate Connectivity is Undefined.  Connectivity is 

made by Left clicking on a Bold Point and dragging a line to the Point it should 
transition from.  Define Connectivity for the Point LANE2 to the Point LANE. 
 

• Left click on the Bold Point, LANE2, identified here.  A dynamic transition line 
now follows your cursor. 

                       

     
 

• LANE2 is the Outside Surface Point of the Right Turn Lane and will be 
connected to the Point LANE, located on the Outside Surface Point of the right 
side travel lane identified above.  Left click on the Point LANE. 

      
     *HINT: If you make a mistake, Right mouse click over the incorrect placement and 

select Delete then try again. 
 

• Notice the Bold Plus associated with the Point LANE2 is no longer bold 
indicating it now has connectivity. 

 

LANE2 
*HINT: You can hover 
your cursor over any Point 
and the Point name will 
appear. 

LANE 

*HINT: Right mouse click 
over a line to Delete it. 
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32.  Define the Connectivity for the remaining unconnected Points. 
 

• Left click on Point LANEB2 to engage the transition line. 
 

        
 
 

• Left click on Point LANEB to define the transition. 
• Left click on Point LANEIB2 and connect to LANEIB. 
• Left click on Point LANEBB2 and connect to LANEBB. 
• Left click on Point LANEGAB2 and connect to LANEGAB. 
• Click OK.  A Reminder dialog opens.  Read the Reminder. 
• Click OK to close the Reminder.  The Edit Transition Midpoint Window 

opens as shown in Figure L8-23. 
 
 

 

LANEB2 

LANEB 

LANEIB2 

LANEBB2 

LANEGAB2 

LANEIB 
LANEBB 

LANEGAB 

LANEGAB 
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Figure L8-23 Edit Transition Midpoint 

 
 
 

33.  The Edit Transition Midpoint dialog allows you to interactively test the transition 
and to make edits to the Point Constraints as necessary in order for the transition to 
behave properly.  Test the Transition. 
 

• In the Edit Transition Midpoint Window, drag the Slider Bar to view how the 
transition widens and narrows the turn lane from beginning to end. 

• Notice no transition occurred.  This informs you that the transition requires 
additional edits to function properly. 

 

Slider Bar 

*Remember 
from Lab 7: 
Red Plus 
symbols 
indicate Full 
Constrained 
Points,  Yellow 
Plus symbols 
indicate 
partially 
constrained 
Points and 
Green Plus 
symbols 
indicate 
unconstrained 
Points. 

LANE2 
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34.  The Reason the Transition did not occur properly is because the Turn Lane is Fully 
constrained, as can be seen by the Red Plus on the Point LANE2 identified in Figure 
L8-23.  Edit the Point Constraints to allow the Transition to occur. 
 

• In the Edit Transition Midpoint Window, double click the point LANE2 
identified in Figure L8-23. 

• The Transition Point Properties dialog opens as shown here. 
 

            
 

• Remove the Horizontal constraint from Constraint 2 by using the pull down 
arrow to select None as shown here. 

 

           
 

• Click OK.  The Transition Point Properties dialog closes and you are returned 
to the Edit Transition Midpoint Window. 

• Notice Point LANE2 is now shown with a Yellow Plus Symbol meaning it is 
partially constrained.  By removing the Horizontal constraint the component is 
free to transition properly. 

• In the Edit Transition Midpoint Window, drag the Slider Bar to view how the 
transition widens and narrows the turn lane from beginning to end. 

• Click OK to close the Edit Transition Midpoint Window. 
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35.  Even though the transition was defined in the Edit Transition Window it must still 
be processed in the Roadway Designer. 
 

• In the Roadway Designer, click the Process All button.  
• Close the Results Report if it opens. 

 
36.  The Plan View shown in Figure L8-24 now shows a Dark Blue transition zone.  As 

stated earlier a Dark Blue transition zone indicates the transition between the two 
templates has been accounted for.  The long Yellow line in the transition zone 
indicates the current station in the cross section window and can be dragged to any 
station. 
 

• Left click on the Yellow line (in the Plan Window) and drag it to another station.  
Notice the Cross Section Window goes to the Station where the yellow line is. 

• The same function is available with the long Yellow line in the Profile Window.  
Drag the Yellow line in the Profile Window to see how it changes the Station in 
the Cross Section Window. 

• Take a moment to look at Stations 51+72.00 to 53+22.00 and review the 
transition we just defined. 

 
 

      
Figure L8-24   Roadway Designer – Plan View 

 
37.  Save your work. 

 
• In the InRoads Roadway Designer, select File ► Save. 

 
38.  Exit the Roadway Designer 

 
• In the InRoads Roadway Designer, select File ► Close. 

  

Dark Blue transition zone 
indicates the transition 
between the two templates is 
resolved. 

The long Yellow line 
indicates the current station 
shown in the Cross Section 
Window.  It can be used to 
move to different stations. 
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Lab 8D  Point Controls 
 
Point Controls are used to override the horizontal and vertical control of a Point’s normal 
constraints in a component.  They are most often used to make a Point follow a horizontal or 
vertical alignment or both.  In Lab 8D we will use Point Controls to control the Point LANE1, 
identified in Figure L8-25, with a horizontal alignment to follow the edge of travel lane 
Alignment DE32, identified in Figure L8-26, between stations 27+87.00 and 37+43.00. 
 
 
 
 

 
Figure L8-25 Two-Lane Template 

 
 
 
 

 
Figure L8-26 Plan View 

 
 
 
 
 

27+87 37+43 

Alignment 
DE32 

LANE1 
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39.  If not still open from the Previous Section, open MicroStation and InRoads and the 
following files.  Refer to Lab Section 8A for Help. (Omit this step if files are open). 
 

 GDOT 3D Working File.dgn  1234567_Design.alg 
 1234567_Exist.dtm  1234567.ird (Created in Lab 8C). 
 GDOT_Lab8.itl 

 
 

 

40.  If Not Already Clear, clear the MicroStation Window. 
 

• In MicroStation, select Edit ►Select All. 
• Click the Delete Icon ( ). 

 
41.  Open the View Horizontal Annotation Dialog. 

 
• In InRoads, select Geometry ► View Geometry ► Horizontal Annotation.   

 
42.  Load the ‘NO BEARING & DISTANCE’ Preference. 

 
• In the View Horizontal Annotation dialog, click the Preferences button.  

The Preferences dialog opens. 
• Highlight the NO BEARING & DISTANCE Preference.  This Preference loads 

the settings to view the alignments without annotating the bearing and distance. 
• Click Load and Close. 

 
43.  Open the Geometry Selection Filter for Horizontal Alignments to Select All 

Alignments for Viewing. 
 

• In the View Horizontal Annotation dialog, place your cursor in the Horizontal 
Alignments Include: field to activate the Filter button. 

• Click the Filter button.  The Geometry Selection Filter dialog opens. 
• Click the All button. All of the Horizontal Alignments move from the Available: 

field to the Selected: field. 
• Click OK.  You are returned to the View Horizontal Annotation dialog with the 

Horizontal Alignments loaded in the Horizontal Alignments Selected: field. 
• In the View Horizontal Annotation dialog, click Apply and Close. 
• In MicroStation, click the Fit View button (       ). 
• Your view in MicroStation should look like that in Figure L8-27. 

 
44.  Zoom into the Intersection of SR100 SPUR and Stoffel Rd. 

 
• In MicroStation, click the Window Area button. 
• Window the area outlined in Red as shown in Figure L8-27. 
• Ensure your view matches that shown in Figure L8-28.  Road names have been 

added for clarity and will not be present in your view. 
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Figure L8-27 MicroStation View 

 
 

 
Figure L8-28 MicroStation View 

 
 
 
 

Use the Window Area 
view function to zoom in 
as shown here outlined 
in Red. 
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45.  Rotate the MicroStation View Window so that the Alignment SR100 SPUR will be 
horizontal. 
 

• In the MicroStation key-in field, key-in rotate view element as shown here and 
press Enter on your keyboard. 

 

              
 

• Notice in the bottom left corner of the MicroStation window you are told to 
>Identify element, as shown here. 

 
               
 

• Left click on the Orange Alignment representing SR100 SPUR identified in 
Figure L8-28 above. It will turn purple in color to signify it has been selected. 

• Left click again to confirm the selection. 
• Right mouse click to unselect item. 
• Ensure your MicroStation View is similar to that shown in Figure L8-29. 

 
 
 
 

 
Figure L8-29 MicroStation View 
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46.  Open the Roadway Designer. 
 

• In InRoads, select Modeler ► Roadway Designer. 
 

47.  Ensure the Corridor is set to ‘SR100 SPUR’ and the Active Surface is 
1234567_Exist. 
 

• In the InRoads Roadway Designer Window, use the pull down arrow next to 
Corridor:  and select SR100 SPUR as shown in Figure L8-30. 

• In the InRoads Roadway Designer Window, use the pull down arrow next to 
Active Surface:  and select 1234567_Exist as shown in Figure L8-30. 

• In the Roadway Designer, click the Process All button.  
• Close the Results Report if it opens. 

 
 
 

 
Figure L8-30 Roadway Designer 

 
 

48.  Open the Point Controls Dialog. 
 

• Select Corridor ► Point Controls.  The Point Controls dialog opens as shown 
in Figure L8-31. 

 
 

Ensure SR100 SPUR is shown in the 
‘Corridor:’ field and 1234567_Exist is 
shown in the ‘Active Surface:’ field. 
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Figure L8-31 Point Controls 

 
 

49.  Select the Point ‘LANE1’ as the Point to apply a control to. 
 

• Click the Locate button ( ) next to the Point: field as shown in Figure L8-31 
above.  The Point Controls dialog disappears and makes the Roadway Designer 
Window available to graphically select a Point in the Cross Section Window. 

• Left Click on the Point LANE1 identified in Figure L8-32.  You are returned to 
the Point Controls dialog and the Point LANE1 is entered into the Point: field as 
shown here. 

                                                   
 
*HINT: You may also select the Point from the Point: pull down arrow. 

 

Locate button for graphically 
selecting Point. 
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Figure L8-32 Roadway Designer 

 
 
 
50.  Point Controls can be used to control a Point’s Horizontal or Vertical Alignments or 

Both.  In this example a Control will be applied Horizontally.  Set the Mode to 
Horizontal. 
 

• In the Point Controls dialog, check the Horizontal radio button as shown here.  
 

                                  
 

51.  In addition to Horizontal and Vertical modes of Point Controls there are also 
several other types of Point Controls. A control by an Alignment is the most 
common but other types include control by Feature, Style and Corridor Point.  
Refer to the InRoads Help for more information about controlling Points by 
Feature, Style or Corridor Point.  For this example, ensure the Control Type: is set 
to Alignment. 
 

• In the Point Controls dialog, select Alignment from the pull down menu as 
shown here. 

                                         
 

LANE1 
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52.  Select Horizontal Alignment DE32 which represents the Edge of Travel Lane as the 
Horizontal Alignment for Point LANE1 to follow. 
 

• In the Point Controls dialog, click the Locate button ( ) next to the 
Horizontal Alignment: field.  Both the Point Controls dialog and the Roadway 
Designer Window disappear making the MicroStation Window active for 
selecting an Alignment. 

• In MicroStation, Left click on the Horizontal Alignment, DE32, identified in 
Figure L8-33.  It will turn Purple as shown in Figure L8-34. 

• In the lower left corner of MicroStation you are prompted to .  
Left click on a blank part of the MicroStation Window to accept.  The Point 
Controls dialog re-opens with DE32 listed in the Horizontal Alignment: field. 

 
 
 

 
Figure L8-33 MicroStation View 

 

 
Figure L8-34 MicroStation View 
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53.  The Point Control for LANE1 will be applied from Station 27+87 to Station 37+43. 
 

• In the Point Controls dialog, key-in the Station values in the Station Limits: 
field as shown here.      

 
                                         
*IMPORTANT: The Station Limits: field refers to the 
SR100 SPUR centerline alignment DE31 that was used to 
create the SR100 SPUR corridor and not the Edge of 
Pavement alignment DE32 entered in the Horizontal   

                                               Alignment: field. 
 

54.  Add the Point Control for LANE1 to the Horizontal and Vertical Controls Field. 
 

• Ensure your entries match those in the Point Controls dialog shown in Figure 
L8-35. 

• Click Add.  The Point Control is added to the Horizontal and Vertical 
Controls: field as shown in Figure L8-36. 

• Click Close.  The Point Controls dialog closes and you are returned to 
the Roadway Designer Window.  The Point Control has now been applied to the 
SR100 SPUR Corridor. 

 
 

 
Figure L8-35 Point Controls 

*REMINDER: The Station 
Limits field refers to the SR100 
SPUR centerline alignment 
DE31 that was used to create the 
SR100 SPUR corridor and not 
the Edge of Pavement alignment 
DE32 entered in the Horizontal 
Alignment field. 
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Figure L8-36 Point Controls 

 
 
55.  Process the Changes in the Roadway Designer. 

 
• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 

 
 

56.  Inspect the Changes. 
 

• In the Roadway Designer, key-in 27+87 in the Station: key-in field and press 
the Tab key on your keyboard.  The Cross Section at Station 27+87 appears in 
the Cross Section Window. 

• Click the Right arrow button (     ) to cycle through the stations from Station 
27+87 to Station 37+50.  Notice as you do this - the travel lane on the left side of 
the Template widens and narrows.  This is a result of the Point Control for 
LANE1 following the Alignment DE32. 

 
 

The Point Control for LANE1 
is added to the Horizontal and 
Vertical Controls: field. 
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57.  As you cycled through the Stations using the Arrow keys - you may have noticed 
Station 37+43 was not available in the Corridor.  Add Station 37+43 to the 
Corridor. 
 

• In the Roadway Designer, select Corridor ► Key Stations.  The Key Stations 
dialog opens. 

• In the Key Stations dialog, enter 37+43.00 as shown here. 
 
 

             
 
 
 

• Click Add but do not close out of the Key Stations dialog.  Notice the Station 
37+43.00 is also added to the Selected: field. 

• Click Close to exit the Key Stations dialog. 
• In the Roadway Designer, click the Process All button to apply the changes. 
• Close the Results Report if one opens. 
•  In the Roadway Designer, cycle through the Stations using the arrow keys to 

ensure that Station 37+43.00 was added to the Corridor. 
 
 

58.  Save Your Work. 
 

• In the InRoads Roadway Designer, select File ► Save. 
 
 

59.  Exit the Roadway Designer. 
 

• In the InRoads Roadway Designer, select File ► Close. 
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Lab 8E  End Condition Exceptions 
 
End Condition Exceptions provide a means by which a Template’s End Condition cut or fill 
interception with the ground may be controlled for a specified range of stations. End Condition 
Exceptions can be used to satisfy design needs encountered under actual conditions without the 
need to create a new Template.  At times, with the approval of the Office of Materials & 
Research, it is acceptable to steepen the fill slopes to 1.5v:1h to stay inside the available Right of 
Way or to avoid some warranted condition.  In Lab 8E you will add an End Condition Exception 
to the right side of Stations 23+00 to 25+25 to steepen the slopes from 2v:1h to 1.5v:1h. 
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60.  If not still open from the Previous Section, open MicroStation and InRoads and the 
following files.  Refer to Lab Section 8A for Help. (Omit this step if files are open). 
 
 GDOT 3D Working File.dgn 
 1234567_Design.alg 
 1234567_Exist.dtm 
 1234567.ird (Created in Lab8C and appended to in Lab8D) 
 GDOT_Lab8.itl 

 
61.  Open the Roadway Designer. 

 
• In InRoads, select Modeler ► Roadway Designer. 

 
62.  Ensure the Corridor is ‘SR100 SPUR’ and the Active Surface is ‘1234567_Exist’. 

 
• In the Roadway Designer Window, verify the Corridor: and Active Surface: 

fields match those shown here. 
 

            
 

• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 

 
63.  Navigate the Cross Section Window to Station 23+00. 

 
• In the Roadway Designer Station:  key-in field enter 23+00 as shown here, and 

then press the Tab key on your keyboard to accept the entry. 
 

            
 
 

64.  Open the End Condition Exceptions dialog. 
 

• Select Corridor ► End Condition Exceptions.  The End Condition 
Exceptions dialog opens similar to that shown in Figure L8-37. 
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65.  The End Condition Exceptions dialog is where the Station Range and the Exception 
Side to be Applied To is Entered.  Add an End Condition Exception to the Right 
Side from Stations 23+00.00 to 25+25.00 
 

• In the Station Range: fields key-in the following: 
o Start:  23+00.00 
o Stop:  25+25.00 

• In the ‘Apply To’ field, check the Right Override radio button. 
• In the Description:  field enter the following: 

o Description: RT side 1.5v:1h Slopes for Right of Way 
• Ensure your entries match those shown in Figure L8-37. 
• Click Add.  The ‘End Condition Exceptions:’ field is populated with a new End 

Condition Exception as shown here:  
 

 
 

 
 
 
 

  
Figure L8-37 End Condition Exceptions 
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66.  Open the Override Window so the End Condition can be Edited. 
 

• In the End Condition Exceptions dialog, Left click on the new End Condition to 
activate the Edit… button as shown here. 

 

       
 

• Click the Edit… button.  The Right Override Window opens as shown in Figure 
L8-38. 

 
 
 
 

 
Figure L8-38 Right Override Window 

 
 

Highlighting the End 
Condition Exception 
activates the Edit and 
Delete buttons. 
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67.  Open the Point Properties dialog for the Point ‘FILL1’. 
 

• In the Right Override Window, Right mouse click over the Point FILL1 and 
select Edit Point.  The Point Properties dialog opens. 

 
68.  Change the Constraints for ‘FILL1’ to build a 1h:1.5v slope. 

 
• Match the entries for FILL1 to those shown here: 

 

           
 

• Click Apply & Close. 
• The Right Override Window should match that shown in Figure L8-39.   
 
*NOTE: The light blue fill slope represents the end condition as it was prior to the 

change. The yellow fill slope represents the current constraints settings.  Although 
the yellow fill slope is not depicted as intersecting the ground, the settings of the 
End Condition Properties in the Point Properties dialog above will ensure the 
Fill Slope is extended properly in the Roadway Designer. 

 
• Click OK to exit the Right Override Window. 
• Click Close to exit the End Condition Exceptions dialog. 

 

*HINT: The ratio -1v:1.5h is 
-66.666̄ %.  Rather than key-
in -66.667%, key-in the ratio 
-1:1.5 then press the Tab key 
on your keyboard to accept 
the entry.  The format for 
ratio entries is 
Vertical:Horizontal. 
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Figure L8-39 Right Override Window 

 
 

69.  Apply the Change to the Roadway Designer. 
 

• In the Roadway Designer, click the Process All button.  This ensures the End 
Condition Exception is applied to all the Stations affected and the Plan View 
Window is updated appropriately to affect the change as shown in  
Figure L8-40. 

• Close the Results Report if one opens. 
 

 
*NOTE:   The light blue area in Figure L8-40 identifies the location of the End 

Condition Exception.  The End Condition Exceptions dialog may be 
opened by double clicking in the light blue area. 

 
 
 
 

*NOTE:  Although the yellow fill 
slope is not depicted as intersecting 
the ground, the settings of the End 
Condition Properties in the Point 
Properties dialog above will ensure 
the Fill slope is extended properly in 
the Roadway Designer. 
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Figure L8-40 Roadway Designer – Plan View  

 
 
 
 
 
 
 
70.  Verify the Slope Change from 1v:2h to 1v:1.5h. 

 
• In the Cross Section View of the Roadway Designer, hold your mouse cursor 

over the Right side fill slope.  An information pop-up appears as shown here. 
 
 

                  
 
 

71.  Save Your Work and Exit the Roadway Designer. 
 

• In the Roadway Designer, select File ► Save. 
• Click File ► Close to exit the Roadway Designer. 

 

*NOTE: The light blue 
area identifies the location 
of an End Condition 
Exception.  Double 
clicking in the area will 
open the End Condition 
Exceptions dialog. 

*REMEMBER: The 
yellow line identifies the 
current location shown in 
the Cross Section View 
and can be dragged with 
the mouse to any location 
along the Alignment. 

*REMEMBER: The 
dark blue area identifies 
template transition 
areas. 

*NOTE: The Red lines 
identify locations where 
end conditions switch 
between cut and fill 
sections. 

The -66.667% slope shown 
here in the information pop-up 
verifies the fill slope was 
changed from 1v:2h to 1v:1.5h.   
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Lab 8F  Superelevation 
 
Superelevation in InRoads is created by the addition of Vertical Point Controls, the same as you 
were shown in Lab 8D titled: Point Controls, yet with a Superelevation control type.  The 
addition of Superelevation Point Controls is facilitated by the use of the Superelevation Wizard 
and is performed after a corridor is created and templates are dropped.  Once Superelevation has 
been added to the corridor by the Superelevation Wizard, the Superelevation Display is used to 
resolve Superelevation overlaps and to make any necessary edits to the Superelevation.  In Lab 
8F you will use the Superelevation Wizard to add Superelevation to the SR100 SPUR Corridor.  
After the Superelevation Wizard is used to add Superelevation to the Corridor, the 
Superelevation Display will be used to resolve Superelevation overlaps and to edit the 
Superelevation through an intersection.  
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72.  If not still open from the Previous Section, open MicroStation and InRoads and the 
following files.  Refer to Lab Section 8A for Help. (Omit this step if files are open). 
 

 GDOT 3D Working File.dgn  1234567_Design.alg 
 1234567_Exist.dtm  GDOT_Lab8.itl 

  
 

73.  To Ensure your Data Matches during this Section of Lab 8, a Roadway Design File 
(.IRD) has been prepared for you.  Open the Roadway Design File 1234567-8F.ird 
       

• In InRoads, select File ► Open.  The Open dialog appears. 
• Browse to the folder C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight the file 1234567-8F.ird. 
• Click Open and Cancel. 
• In the InRoads Workspace Bar, ensure the Corridors tab is the active tab as 

shown here and that the file 1234567-8F is listed. (You may need to click the Plus 
Symbol to expand the Roadway Designer to see the listed 1234567-8F file.) 

 

           
 

74.  Open the Roadway Designer. 
 

• In InRoads, select Modeler ► Roadway Designer. 
 

75.  Ensure the Corridor: is ‘SR100 SPUR’ and the Active Surface: is ‘1234567_Exist’. 
 

• In the Roadway Designer Window, verify the Corridor: and Active Surface: 
fields match those shown here. 
 

            
 

• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 

76.  Open the Superelevation ‘Table Wizard’. 
 

• In the Roadway Designer, select Superelevation ► Create Superelevation 
Wizard ► Table.  The Superelevation Table Wizard opens as shown in 
 Figure L8-41. 

Ensure the Roadway Design File 1234567-8F 
is listed. 

Ensure Corridors is the active Tab. 
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Figure L8-41 Table Wizard 

 
77.  Select the Superelevation Table for a 65mph design speed and a maximum 

Superelevation rate of 8.0%. 
 

• Click the Browse button ( ) next to the Table: field.  The Open 
Superelevation Table Window opens. 

 
*NOTE: InRoads provides Superelevation Tables based on the 2004 AASHTO 

‘Green Book’ pages 167 to 181.  These tables are located in the folder 
C:\Program Files (x86)\Bentley\InRoads Group V8.11 (SELECTseries) 
\InRoads Group V8.11\Data\AASHTO 2004\imperial\.  The Tables are text 
files that can be easily edited to a Designer’s criteria in a text editor such as 
Microsoft Notepad.  

 
• Navigate to the folder: C:\Program Files (x86)\Bentley\InRoads Group V8.11 

(SELECTseries)\InRoads Group V8.11\Data\AASHTO 2004\imperial\ 
 

• Select the 08_65.sup file and click Open.  You are returned to the Table Wizard 
and the file 08_65.sup is entered into the Table: entry field. 

Browse button 
for Step 77. 
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78.  Define the Percent Runoff to be on the Tangent. 
  

• In the Table Wizard, click the %Runoff on Tangent button shown here. 
 

 
 

• Notice the button changes to % Total on Tangent as shown here. 
 

                                                      
 

• InRoads allows the Designer to specify whether the transition on the tangent 
before and after each curve is a percentage of the Runoff on the tangent or a 
percentage of the total transition on the tangent.  For this example we will use the 
% Runoff on Tangent method.   

• Click the % Total on Tangent button again to return to the % Runoff on 
Tangent. 

• In the % Runoff on Tangent entry field, key-in 2/3 and press the Tab key on 
your keyboard to accept the entry. The entry field changes to 67% but retains 
66.66̄ % in memory. 

 
79.  Set the Runout Length. 

 
• Place a check mark in the Specify Runout: check box as shown below. 

 
*NOTE: Runout, also known as crown removal, is the distance from normal crown 
to zero percent super.  When checked, the Specify Runout entry field activates and 
allows the user to manually define the length of the Runout.  When uchecked the 
runout is extended at the same rate of transition as the runoff.  
 
• In the Specify Runout: entry field, key-in 60.000 as shown here: 

 
             
 
 

80.  The Transition Lengths provided in the table are to be considered Runoff Lengths 
and not Total Transition Lengths.  Ensure the Transition Lengths are defined as 
Runoff Lengths. 
 

• Check the radio button for the Runoff Transition Length as shown here: 
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81.  Load the Superelevation Values from the 08_65.sup table. 
 

• In the Table Wizard, ensure a check mark does not exist next to the Update 
Geometry from Table check box as shown here. 

 
             
 

• Click the Load Values From Table button.  The Superelevation Values are 
entered from the 08_65.sup table as shown in Figure L8-42. 

 
 

 
Figure L8-42 Table Wizard 

 
 

82.  Open the Superelevation Sections Definition Window. 
 

• Ensure your values match those shown in Figure L8-42. 
• Click Next >.  The Superelevation Section Definitions Window opens as shown 

in Figure L8-43. 
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Figure L8-43 Superelevation Section Definitions 

 
83.  Discussion: 

 
The Superelevation Section Definitions Window is where the Crown Point or rotational 
point of the Template and the Left and Right Range Points are added.  The Profile Grade 
Point (PGL) is commonly chosen as the crown point of the Template but does not have to 
be.  Range Points are points on the Template chosen to identify the extents to which the 
Superelevation is to be applied along the Template.  Range Points are almost always 
picked at the outside edge of the travel lanes whereas the shoulder points are controlled 
by Shoulder Rollover Locks.  In the image below, the Points LANE and LANE1 would 
be identified as the Right and Left Range Points while the remaining points would be set 
up with rollover locks defined in either the Template as shown in Lab 7 or in the 
Roadway Designer as will be demonstrated later in Lab 8.  
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84.  Open the Add Superelevation Section Dialog box.  
 

• Click the Add button.  The Add Superelevation Section dialog opens as shown 
in Figure L8-44. 

 
 
 

 
Figure L8-44 Add Superelevation Section 

 
85.  Identify the Crown Point 

 
• Click the Locate button ( ) next to the Crown Point: field.  The Add 

Superelevation Section dialog disappears and the Roadway Designer Window 
becomes the active window. 

• Left click on the PGL Point identified here.  You are returned to the Add 
Superelevation Section dialog and PGL is entered in the Crown Point: field. 

 

                         
 
 

PGL *HINT: Use the mouse 
wheel to zoom in and 
out as necessary in 
order to select the 
correct Point.  Try the 
mouse wheel in 
combination with the 
CTRL and Shift keys 
and see what happens. 
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86.  Identify the Left and Right Range Points and Add the Section to the Superelevation 
Sections Definitions Window. 
 

• Click the Locate button ( ) next to the Left Range Point: field.  The Add 
Superelevation Section dialog disappears and the Roadway Designer Window 
becomes the active window. 

• Left click on the Point LANE1 identified here.  You are returned to the Add 
Superelevation Section dialog and LANE1 is entered in the Left Range Point: 
field. 

 

                             
 
 

• Click the Locate button ( ) next to the Right Range Point: field.  The Add 
Superelevation Section dialog disappears and the Roadway Designer Window 
becomes the active window. 

• Left click on the Point LANE identified here.  You are returned to the Add 
Superelevation Section dialog and LANE is entered in the Right Range Point: 
field. 

 

                                   
 

• Match the remaining entries shown in Figure L8-45. 
• Click OK.  You are returned to the Superelevation Section Definitions Window 

and Section1 is populated in the Sections: area as shown in Figure L8-46. 
 

 
 

LANE1 

LANE 
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Figure L8-45 Add Superelevation Section 

 

 
Figure L8-46 Superelevation Section Definitions 

*HINT: Use the 
InRoads Help button 
to get additional 
information about 
each command. 

The Start and Stop 
Stations refer to the 
start and stop of the 
Runoff Transition.  
Normally the point 
of zero super. 

The Runoff lengths 
were pulled from the 
08_65.sup table 
selected earlier. 

The Superelevation 
Rate was obtained 
from the 08_65.sup 
table selected earlier. 

The maximum 
calculated distance 
from the pivot point 
to the range points. 
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87.  Once a Superelevation Section has been Added, the Superelevation Transition Data 
for Each Curve may be edited if desired.  Change the Runoff Length for the first 
Curve in the list. 
 

• In the Superelevation for Selected Section: field of the Superelevation Section 
Definitions Window, highlight the 11+35.72 to 17+00.67 section as shown here.  
The Edit button becomes active. 

 

         
 
 

• Click the Edit button.   The Superelevation Curve Information dialog opens as 
shown in Figure L8-47. 

• In the Runoff Length:  key-in field for the Start Curve Transition enter 500. 
• Ensure your entries match those shown in Figure L8-48. 
• Click Apply & Close.  You are returned to the Superelevation Section 

Definitions Window. 
• Notice the Runoff value for the Entering Runoff Length has changed to 500.00. 
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Figure L8-47 Superelevation Curve Information 

 
 

  
Figure L8-48 Superelevation Curve Information 

 
 
 

Ensure the Starting 
Runoff Length is changed 
to 500.00 before clicking 
Apply. 
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88.  Before Applying the Superelevation Control Lines that have just been created, 
InRoads Displays them in the Superelevation Controls Window for review.  Review 
the Superelevation Control Lines that were created in the previous steps. 
 

• In the Superelevation Section Definitions Window, click Next >.  
The Superelevation Controls Window opens as shown in Figure L8-49. 

 
*INFORMATION: Two Superelevation Control Lines have been created.  One is 

from the PGL to the Left Range Point, LANE1, and the other is from the 
PGL to the Right Range Point, LANE.  Notice in Figure L8-49 the name 
of the Superelevation Control Section, Section1, which we assigned in 
Step 84, has been used as a prefix to name each of the Superelevation 
Control lines.   

 
 

 
 

 
Figure L8-49 Superelevation Controls 
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89.  InRoads can automatically round the Superelevation Station calculations to a user 
defined value.  Have InRoads automatically round to the nearest 0+01.00 Station. 
 

• In the Superelevation Controls Window, check the Round Station to Nearest: 
check box as shown here. 

 

             
 

• Key-in 0+01.00 in the Round Station to Nearest: entry field as shown here. 
 

             
 

• Click Finish.  The Fix Superelevation Overlap dialog opens as shown in Figure 
L8-50. 

 
*NOTE: The Fix Superelevation Overlap dialog only displays when conflicts exist. 

 
 
 
 
 
 
 

 

 
Figure L8-50 Fix Superelevation Overlap 

 
 

The Fix Superelevation 
Overlap dialog reports 
location and cause of the 
conflict as shown here. 

The value in this field is 
the Runoff Length plus 
the Runout Length. Don’t 
forget that all dialog 
boxes in InRoads have a 
Help button which define 
each entry field. 
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90.  The Fix Superelevation Overlap dialog appears only when Superelevation Conflicts 
are detected in the Superelevation Calculations.  In this case the Superelevation 
starts before the beginning of the Alignment as stated in Figure L8-50 above.  One 
way to resolve this issue is to extend the Alignment but for this case we will use 
the Fix Superelevation Overlap dialog to change the Transition Runoff length from 
500 to 223 (the value originally selected from the 08_65.sup table). 
 

• In the New Length: field currently populated with the value 560.000, change the 
value to 283.000 (223 + 60) and press the Tab key.  

• Notice the overlap value changed from 109.000 to -168.000.   This tells us that we 
are now 168.00 feet from the beginning of the Alignment and that overlap is no 
longer a problem.  The graphics also change.  The White line represents the 
location of the conflict while the Red area illustrates the zone of conflict relative 
to the White line. 

• Ensure your entries match shown in Figure L8-51. 
• Click Apply.  The White conflict line disappears and the Red transition area is 

shown without a conflict. 
• Notice many of the buttons are grayed out and unavailable.  Had additional 

conflict zones existed in the Alignment - these buttons would be available to 
move to the next conflict so they could be resolved. 

• Click Close.  You are returned to the Roadway Designer. 
• Click the Process All button to ensure the Superelevation changes are applied. 
• Close the Results Report if one opens. 

 
 

 

 
Figure L8-51 Fix Superelevation Overlap 
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91.  Generate a Superelevation Report. 
 

• In the Roadway Designer, select Superelevation ► Superelevation Report.  
The Roadway Design Superelevation Report dialog opens as shown in Figure 
L8-52. 

• Click the All button to select all the available Superelevated Points. 
• Click Apply and the Bentley Civil Report Browser will appear.   
• The Name of the Style Sheet is ‘GDOT Superelevation Data Report.xsl’. Click 

on this Style Sheet Name to select it. 
• The Superelevation Data Report opens in the Bentley Civil Report Browser.  

Take a moment to review the Report. 
 

*NOTE:  InRoads generated the report from XML data by using a Style Sheet (XSL 
file). Style Sheets may be saved as HTML files or TXT files.  Style Sheets 
will be discussed in further detail in Lab 14.  

 
• In the Bentley Civil Report Browser, select File ► Exit. 
• This completes the use of the Superelevation Wizard. 
• Click Close to close the Roadway Design Superelevation Report dialog if still 

open. 
 

 
 

 
Figure L8-52 Roadway Design Superelevation Report 

 
 

92.  Save Your Work and Exit the Roadway Designer. 
 

• In the Roadway Designer, select File ► Save. 
• Click File ► Close to exit the Roadway Designer. 
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Lab 8G  Editing Superelevation 
 
Editing or customizing Superelevation in InRoads is performed in the Roadway Designer via an 
interactive Superelevation Diagram similar to that shown in Figure L8-53.  The Superelevation 
Diagram presents, in graphical form, the pavement edge elevations relative to the crown point.  
InRoads refers to these as Point Control Lines. The Superelevation Diagram also identifies 
Superelevation Point Stations.  These Stations, labeled in Figure L8-53 as Begin/End N.C., 
Adverse Crown Removed/Zero Super, Begin/End R.C., PC/PT, and Begin/End F.S.  are also 
identified by a point on the Superelevation Diagram Point Control Lines.  Editing Superelevation 
in InRoads is accomplished in the Superelevation Diagram by right mouse clicking over a Point 
Control Line and selecting from the pop up menu the desired action.  Color coded displays of the 
Cross Section, Plan and Profile views are also provided in InRoads to assist in visually 
evaluating a corridor’s Superelevation.  In Lab 8G you will be introduced to the Superelevation 
Mode of the Roadway Designer, its display in the Roadway Designer and editing in the 
Superelevation Diagram.  

 
 

  
 

 
     

Figure L8-53   Typical Superelevation Diagram 
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93.  If not still open from the Previous Section, open MicroStation and InRoads and the 
following files.  Refer to Lab Section 8A for Help. (Omit this step if files are open). 
 

 GDOT 3D Working File.dgn  GDOT_Lab8.itl 
 1234567_Exist.dtm  1234567_Design.alg 

  
 

94.  To Ensure your Data Matches during this Section of Lab 8, a Roadway Design File 
(.IRD) has been prepared for you.  Open the Roadway Design File 1234567-8G.ird. 
       

• In InRoads, select File ► Open.  The Open dialog appears. 
• Browse to the folder C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight the file 1234567-8G.ird. 
• Click Open and Cancel. 
• In the InRoads workspace bar, ensure the Corridors tab is the active tab as 

shown here and that the file 1234567-8G is listed. (You may need to click the 
Plus Symbol to expand the Roadway Designer to see the listed 1234567-8G 
file.) 

 
        

            
 
 

95.  Open the Roadway Designer and Ensure the Corridor is set to ‘SR100 SPUR’ and 
the Active Surface is set to ‘1234567_Exist’. 
 

• In InRoads, select Modeler ► Roadway Designer. 
• In the Roadway Designer Window, verify the Corridor: and Active Surface: 

fields are set to SR100 SPUR and 1234567_Exist respectively. 
• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 
• The Roadway Designer should look similar to that shown in Figure L8-54. 

 
 
 

Ensure the Roadway Design File 1234567-8G 
is listed. 

Ensure Corridors is the active Tab. 
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Figure L8-54   Roadway Designer   

 
 

96.  Superelevation Editing is accomplished by Switching to the Superelevation Mode in 
the Roadway Designer.  Switch to the Superelevation Mode. 
 

• In the Roadway Designer, click the Display Mode:  Superelevation radio 
button.  The Roadway Designer Window switches from the Normal Mode to the 
Superelevation Mode as shown in Figure L8-55. 
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Figure L8-55   Roadway Designer – Superelevation Mode 

 
 
97.  Each of the Views In Figure L8-55 above are Color Coded to Depict the Cross Slope 

Steepness.  Zoom in to the Superelevation Mode Plan View to see the Color Coding. 
 

• Zoom into the Superelevation Mode Plan View as shown by the white square 
depicted in Figure L8-56. 

• Your view should look similar to that shown in Figure L8-57. 
• Explanation of colors: 

 
             COLOR                SLOPE                  SIDE 

o Green to Blue       0.5% to 10%        Sloping to the Right 
o Dark Blue                > 10%                Sloping to the Right 
o Yellow to Red      0.5% to 10%        Sloping to the Left 
o Dark Red                 > 10%                Sloping to the Left 
o White                       < 0.5%               Sloping to either Left or Right 

 
 

Superelevation 
Mode Plan 

View 

Superelevation  
Mode Cross 
Section View 

Superelevation 
Mode Profile 

View 

Superelevation 
Mode Diagram 

View 
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Figure L8-56 Superelevation Plan View 

 

 
Figure L8-57 Superelevation Plan View 

 
98.  The Superelevation Mode Cross Section View is Color coded the same as the 

Superelevation Plan View.  
 

• Look at the Superelevation Mode Cross Section view shown in Figure L8-58.  
The Cross Section is color coded the same as in the Superelevation Mode Plan 
View represented in Step 97. 

• Right mouse click in the Superelevation Mode Cross Section View.  You are 
presented with the Edit Station and Display Properties options the same as in 
the Normal Mode Plan View.   

• Left Click in a blank part of the View to cancel making a selection. 
 
 

 
 
 

 
Figure L8-58 Superelevation XSEC View 

 

Zoom into the area 
shown here by the 
white square 
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99.  The Superelevation Mode Profile View shows the Profile of all the top Points in the 
Cross Section between the End Conditions. 
 

• Zoom in to any location in the Superelevation Mode Profile View to see the 
individual Profile Lines.  Your view should be similar to that shown in  
Figure L8-59. 

• Place your cursor over any of the lines in the Profile View.  The name of the Point 
in the Cross Section Template is shown. 

• Right mouse click in the Superelevation Mode Profile View.  The Profile Display 
List dialog pops up as shown here: 

 

 
 

• The Profile Display List depicts the Template Points for which Profiles are 
shown in the Superelevation Mode Profile View.  Left click on the Point PGL so 
that only PGL is highlighted in the list. 

• Click Apply and Close.  Now only the Profile for the Point PGL is shown.  The 
color of the Profile Line represents the cross section slope to the right of the point. 

• Right mouse click in the Superelevation Mode Profile View again.  Select All ► 
Apply ► Close to turn all the Profiles back on. 

• In the Roadway Designer Superelevation Mode Profile View, click the Fit 
button ( ). 

 

 
Figure L8-59 Superelevation Profile View 
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100.  The Superelevation Mode Diagram View, shown in Figure L8-60, displays the Point 
Control Lines and Superelevation Points created by the Superelevation Wizard.  
While the colors in the other Views represent the rate of super, the colors in the 
Diagram View only serve to differentiate one line from another.   Information about 
each Point Control Line and Superelevation Point may also be gathered by hovering 
your cursor over the element. 
 

• Place your cursor over the Point Control Line identified in Figure L8-60 by a 
white square.  The information box shown here pops up. 

 

                
 
 

• Place your cursor over the Superelevation Point identified in Figure L8-60 by a 
white triangle.  The information box shown here pops up. 

 

                     
 
 

 
 
 

 
Figure L8-60 Superelevation Diagram View 

 
 
 
 
 
 

Name of Point Control Line. 
 
Length between nearest 
Superelevation Points. 

Name of Point Control Line. 
Superelevation Point Type. 
Cross Slope 
Station 
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101.  Make Station 45+00 the Active Station. 
 

• In the Station: key-in field enter 45+00 and press the Tab key.   
• Verify your view matches that shown in Figure L8-61. 
• Notice the Yellow line at Station 45+00 shown in the Plan, Profile and Diagram 

views.  This line marks the current Station in the Station: key-in field and can be 
dragged to any Station with the mouse. 

 
 
 

 
Figure L8-61 Roadway Designer – Superelevation Mode 

 
 
 
 
 
 
 
 
 

Notice the Yellow line 
in the Plan, Profile and 
Diagram views 
identifying the current 
Station in the Station: 
field. 

Station: key-in field. 
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102.  Zoom into the Cross Section View. 
 

• In the Cross Section View, use the Window Area button to match the view 
shown in Figure L8-62. 

 
*HINT:  Use the mouse wheel in combination with the Ctrl or Shift key to adjust the 

horizontal and vertical exaggeration. 
 

• Notice the Cross Section View shows the surface at Station 45+00 and is color 
coded according to the information provided in Step 97. 

 
 
 

 
Figure L8-62 Superelevation XSEC View 

 
 

103.  Change the Roadway Designer from the Superelevation Mode to the Normal Mode. 
 

• In the Roadway Designer, click the Display Mode:  Normal radio button. 
• Ensure your view matches that shown in Figure L8-63. 
• Notice the Station and Zoom extents in the Cross Section Window match those 

that were showing when in the Superelevation Mode. 
 

104.  Return the Roadway Designer to the Superelevation Mode. 
 

• Click the Display Mode: Superelevation radio button to return the Roadway 
Designer to the Superelevation Mode. 

• Ensure your view matches that shown in Figure L8-64 
 

 
 

*HINT: Use the mouse wheel 
in combination with the Ctrl 
or Shift key to adjust the 
horizontal and vertical 
exaggeration display. 
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Figure L8-63  Roadway Designer – Normal Mode 

 

 
Figure L8-64 Roadway Designer – Superelevation Mode 
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105.  The Superelevation in both Curves in the Alignment is 8.0%.  Change the 
Superelevation in the Second Curve from 8.0% to 5.0% 
 

• Double click the Superelevation Point, Section1 PGL-LANE1, identified by the 
white square shown here.  The Superelevation Point Properties dialog opens as 
shown in Figure L8-65.   

 

                                 
 

• Notice the Cross Slope: field is grayed out and unavailable for editing.  Change 
Constraint 2 from Mirror Cross Slope to None.   

• Click Apply.  The Cross Slope: field becomes active for editing. 
• In the Cross Slope: field key-in -5.0% and press the Tab key on your keyboard. 
• Verify the entries in the Superelevation Point Properties dialog now match 

those shown in Figure L8-66. 
• Click Apply and Close. 
• Your Superelevation Diagram should change to that shown in Figure L8-67. 
• At this time only one of the four Full Super Superelevation Points is changed to 

5.0%.  The remaining three Points may be edited using the same technique but in 
a later step we will edit them using a different method. 

 
 

 
Figure L8-65 Superelevation Point Properties 

Cross Slope: field 

Constraint 2 

*REMEMBER: 
You can hold your mouse 
over any Point and a pop up 
will identify the Point.  The 
white square at left is 
Section1 PGL-LANE1. 
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Figure L8-66 Superelevation Point Properties 

 

 
Figure L8-67 Superelevation Diagram 

 
106.  Generate a Superelevation Report. 

 
• Select Superelevation ► Superelevation Report. The Roadway Design 

Superelevation Report dialog opens. 
• Highlight LANE1 and click Apply.   
• The Bentley Civil Report Browser opens. The Name of the Style Sheet is 

‘GDOT Superelevation Data Report.xsl’. Click on this Style Sheet Name to 
select it. 

• The GDOT Superelevation Data Report opens in the Bentley Civil Report 
Browser as shown in Figure L8-68. 

• Notice the Report reflects the -5.000% change we made.  (See highlighted below 
in blue for clarity). 

• Close the Report by clicking the red (X) in the upper right corner of the Report 
Browser. 

• Close the Roadway Design Superelevation Report dialog. 

The Outside Begin Full 
Super has change from 
8.0% to 5.0%. 

The remaining Full 
Super locations still 
need to be changed. 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 
 

   
 Lab8-76   

 
Figure L8-68 Superelevation Report 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 

   
 Lab8-77   

 
107.  Change the 5.0% slope back to 8.0%. 

 
• Right mouse click over the same Point edited in Step 105 and shown below 

highlighted by a white square. 
• Select Edit Point.  The Superelevation Point Properties dialog opens. 

 

                 
 

• Change the Cross Slope: from -5.000% to -8.000% 
• Use the pull down arrow under Constraint 2 to select Mirror Cross Slope. 
• Ensure Parent 1:  is set to Section1 PGL-LANE-42+19 by using the Locate 

button ( ) and clicking on the Point identified by a white triangle above. 
• Ensure the entries in the Superelevation Point Properties match those shown in 

Figure L8-69. 
• Click Apply.  Notice the Cross Slope: field grays out.  This is because of the 

Mirror Cross Slope constraint we added to Constraint 2. 
• Click Close to exit the Superelevation Point Properties dialog. 
• Verify your Superelvation Diagram matches that shown in Figure L8-70 and that 

the 5.0% Cross Slope has been returned to 8.0%. 
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Figure L8-69 Superelevation Point Properties 

 
 

 
Figure L8-70 Superelevation Diagram 

 
 
 
 
 
 
 
 
 
 
 
 
 

Section1 PGL-LANE-42+19 

The Full Super at this Point 
has changed back to 8.0%. 
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108.  In the previous Superelevation Edit - we changed the Full Super at only one 
Superelevation Point (the Outside Begin Full Super Point).  It is possible to change 
all the Full Super Points in a curve set at one time by editing the Point from which 
all other Points are constrained.  Change the Full Super to 5.0% for all Full 
Superelevation Points in the second curve set. 
 

• Double click the Point identified with a white triangle shown here.  
The Superelevation Point Properties dialog opens. 

 

            
 

• In the Cross Slope: field, key-in 5.000% as shown in Figure L8-71. 
• Click Apply and Close. 
• Notice all four Full Superelevation Points were changed to 5.000% 

simultaneously.  This is because 3 of the Points are constrained to the Point we 
just edited.  The cross slopes may be verified by holding your cursor over the 
other 3 Full Super Points (identified by white circles above) and reading the 
information in the pop up box.    The Superelevation Wizard used earlier in Lab 8 
to add Point Control Lines also adds curve sets with Superelevation Points 
automatically constrained.  The FS Points are always constrained to the Inside 
Begin FS Point. 
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Figure L8-71 Superelevation Point Properties 

 
 

109.  Another Method of making Superelevation Edits is through the use of 
the Superelevation Control Curve Set Station Edit dialog box.  Open 
the Superelevation Control Curve Set Station Edit dialog box. 
 

• Right mouse click over the Point Control Line in the area identified by the white 
square as shown below left. 

                                                

                                                                    
 

• From the Pop-Up menu that opens, shown above right, select Edit Curve Set 
Stations… The Superelevation Control Curve Set Station Edit dialog opens as 
shown in Figure 8-72. 

        

 

Select ‘Edit Curve Set 
Stations…’. 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 

   
 Lab8-81   

 
Figure L8-72 Superelevation Control Curve Set Station Edit 

 
 

110.  Use the ‘Show Curve Set Information’ Button to view additional information about 
Curve Set 2. 
 

• Click the Show Curve Set Information button. Additional information about 
Curve Set 2 is now shown in a preview window located in the bottom right of 
the Superelevation Control Curve Set Station Edit dialog as seen in Figure L8-
73. 

 
 
 

Ensure Curve Set 2 is 
the active Curve set. 

Show Curve Set 
Information button 
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Figure L8-73 Superelevation Control Curve Set Station Edit 

 
 

111.  The Superelevation Control Curve Set Station Edit dialog is defaulted to open 
showing the Superelevation Points for only one curve set (Reverse Crown to Reverse 
Crown) at a time. There are two sets of + / - buttons, identified in Figure L8-73 by 
Red ellipses, for adding and removing the view of Superelevation Points.  Add 
Superelevation Points before and after the current curve set. 
 

• Click the + button ( ) twice in the top set of +/- buttons to add Superelevation 
Points before the currently displayed Superelevation Points. 

• Click the + button ( ) twice in the bottom set of +/- buttons to add 
Superelevation Points after the currently displayed Superelevation Points. 

• Ensure your Superelevation Control Curve Set Station Edit dialog now lists 
the Superelevation Points from Normal Crown to Normal Crown as shown in 
Figure L8-74. 

 
 
 

Curve Set Preview Window 

Click + twice to view 
additional Superelevation 
Points. 

Click + twice to view 
additional Superelevation 
Points. 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 

   
 Lab8-83   

 
Figure L8-74 Superelevation Control Curve Set Station Edit 

 
 

112.  Use the Superelevation Control Curve Set Station Edit dialog box to change the 
Station of the Reverse Crown at Station 40+85.20 to 41+00.00.   
 

• The Reverse Crown at Station 40+85.20 is currently constrained to the Super 
Runoff Point at Station 39+96.00 and the Station cannot be changed.  Remove the 
constraint on the Reverse Crown by un-checking the Constrained box.  This is 
accomplished by Left clicking in the box to remove the X and should appear as 
shown here when done. 

 

                                     
 
 
 
 

Superelevation Points are now listed 
from Normal Crown to Normal Crown. 

Reverse Crown 
shown unconstrained. 
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• In the Reverse Crown Station entry field, change the Station at 40+85.20 to 

41+00.00 by keying-in 41+00.00 and press the Tab key on your keyboard to 
accept the entry. 

• Verify your entry matches that shown below. 
 
 
 

                       
 
 

• Click Apply to make the changes to the Corridor but do not close the dialog box. 
 

113.  Use the Superelevation Control Curve Set Station Edit dialog box to change the Full 
Superelevation in Curve Set two from 5.000% to 8.000%. 
 

• In the Cross Slope field for the Full Super at Station 42+19.00 key-in 8.000% 
and press the Tab key on your keyboard as shown here. 

 

            
 

• Notice the Full Super at Station 48+68.00 was automatically changed to 8.000%.  
This is because it is constrained to the Full Super at 42+19.00 as can be seen by 
the Constrained check box. 

• Click Apply & Close to make the changes to the Corridor and exit the dialog. 
 

114.  For Information Only. 
 
In the Superelevation Control Curve Set Station Edit dialog shown in Figure L8-75, 
notice there is only one column for Cross Slope.  There is no column for Left Cross 
Slope or Right Cross Slope.  If the Left and Right Cross Slopes require different rates as 
may occur, the Superelevation Control Curve Set Station Edit dialog cannot be used.  
When different Left and Right Cross Slopes are required, the Superelevation Points must 
be edited as shown in Steps 105 through 108. 
 
 

 
 

The Reverse Crown 
should now begin at 
station 41+00.00. 

Key-in 8.000% here. 
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Figure L8-75 Superelevation Control Curve Set Station Edit 

 
 
 

115.  Create a Superelevation Report and Review your changes. 
 

• Select Superelevation ► Superelevation Report. The Roadway Design 
Superelevation Report dialog opens. 

• Click the All button to highlight both LANE and LANE1. 
• Click Apply and the Bentley Civil Report Browser opens. The Name of the 

Style Sheet is ‘GDOT Superelevation Data Report.xsl’. Click on this Style 
Sheet Name to select it. 

• The GDOT Superelevation Data Report opens in the Bentley Civil Report 
Browser as shown in Figure L8-76. 

• Review the GDOT Superelevation Data Report as partially shown in Figure 
L8-76. 

• Notice the Reverse Crown at station 41+00.00. 
• Close the Report when you are through reviewing it by clicking the red (X) in the 

upper right corner of the Report Browser. 
• Close the Roadway Design Superelevation Report dialog. 
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116.  Save Your Work and Exit the Roadway Designer. 
 

• In the Roadway Designer, select File ► Save. 
• Click File ► Close to exit the Roadway Designer. 

 
 

 
 

 
Figure L8-76 Superelevation Data Report 
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Lab 8H  Shoulder Rollover Locks 
 
In Lab 7 you were introduced to the InRoads Template Library (.ITL) and Component and 
Template creation.  Part of a template’s function is to Superelevate or ‘roll’ the shoulders in 
response to the Superelevation of the travel lanes. The building of Shoulder Rollover Locks into 
templates was depicted in Lab 7H.  It is preferable to define Shoulder Rollover Locks in the 
Components and Templates but they are not the only place Shoulder Rollover Locks can be 
created.  InRoads provides the ability in the Roadway Designer to add or change Shoulder 
Rollover Lock values after a template or templates have been dropped  and processed through 
the Corridor.  In Lab 8 you will correct Shoulder Rollover Locks that were incorrectly built into 
a Template and do not function properly in response to a Superelevating roadway. 
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117.  If not still open from the Previous Section, open MicroStation and InRoads and the 
following files.  Refer to Lab Section 8A for Help. (Omit this step if files are open). 
 

 GDOT 3D Working File.dgn  1234567_Design.alg 
 1234567_Exist.dtm  
 GDOT_Lab8.itl  

  
 

118.  To Ensure your Data Matches during this Section of Lab 8, a Roadway Design File 
(.IRD) has been prepared for you.  Open the Roadway Design File 1234567-8H.ird. 
       

• In InRoads, select File ► Open.  The Open dialog appears. 
• Browse to the folder C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight the file 1234567-8H.ird. 
• Click Open and Cancel. 
• In the InRoads workspace bar, ensure the Corridors tab is the active tab as 

shown here and that the file 1234567-8H is listed. (You may need to click the 
Plus Symbol to expand the Roadway Designer to see the listed 1234567-8H 
file.) 
 

           
 

119.  Open the Roadway Designer and Ensure the Corridor is set to ‘SR100 SPUR’ and 
the Active Surface is set to ‘1234567_Exist’. 
 

• In InRoads, select Modeler ► Roadway Designer. 
• In the bottom left of the Roadway Designer Window, verify the Corridor: and 

Active Surface: fields are set to SR100 SPUR and 1234567_Exist respectively 
as shown here. 
 

             
 

• In the Roadway Designer, click the Display Mode:  Normal radio button.   
• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 

 
 

Ensure the Roadway Design File 1234567-8H 
is listed. 

Ensure Corridors is the active Tab. 
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120.  Set Station 14+50.00 as the Current Station. 
 

• In the Roadway Designer Station: field, key-in 14+50.00 and press the Tab key 
on your keyboard. 

• Your view should match that shown in Figure L8-77. 
 

 
Figure L8-77 Roadway Designer 

 
121.  Open the Cross Section View Properties dialog. 

 
• Right mouse click in the Cross Section View Window.  In the pop-up menu that 

appears (shown below at left), select Display Properties…  The Cross Section 
View Properties dialog opens as shown below right. 
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122.  Change the Cross Section View Properties to Center the Backbone. 
 

• Click the Center Backbone radio button to make it the active selection. 
 
       *NOTE: Backbone is an InRoads term which refers to that portion of a Template 

between the End Conditions. 
 

• Use the pull down arrow to set the Backbone Screen Width: to 60%. 
• Use the pull down arrow to set the Vertical Exaggeration: at 10.0. 
• Verify your entries match those shown here. 

 

                
 

• Click OK.  The Cross Section View in the Roadway Designer centers the 
backbone with the backbone occupying 60% of the screen width. 

• Verify your Cross Section View is similar to that shown in Figure L8-78.    
(Variations are possible from computer to computer depending on how closely 
the Cross Section View Window is zoomed in or out). 

• The Superelevation at this Station is at 8.00%.  Notice the left shoulder breaks 
from the travel lane and does not extend at the same cross slope as the travel lane.  
This is a sign the Shoulder Rollover Locks are not set correctly in the Template. 

• The Shoulder Rollover Locks can be corrected by editing the Template in the 
Template Library (.ITL) or they can be edited from within the Roadway 
Designer as will be shown in the following steps. 

 
 

 
Figure L8-78 Roadway Designer 

The shoulder should be extending 
at the same slope as the travel 
lanes but does not.  This indicates 
the Shoulder Rollover Locks are 
not set correctly. 
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123.  Open the Apply Shoulder Rollover Lock dialog. 
 

• In the Roadway Designer, select Superelevation ► Apply Shoulder Rollover 
Lock…  The Apply Shoulder Rollover Lock dialog opens as shown in Figure 
L8-79. 

 
 

 

         
Figure L8-79   Apply Shoulder Rollover Lock 

 
 

124.  Select the Left Side Paved Shoulder Point. 
 

• In the Apply Shoulder Rollover Lock dialog, click the Locate button next to the 
Shoulder Point: field and Left click on the Left Paved Shoulder Point identified 
below left with a white square.  The Apply Shoulder Rollover Lock dialog 
reopens with OPS1 selected as shown below right. 

 
 
 

                                                                       
 
 
                                                                         
 
 
 
 

*NOTE:  The Apply Shoulder 
Rollover Lock dialog controls the 
shoulder Superelevation by creating 
Point Controls the same as those 
discussed in Lab 8D.  The Control Line 
Name: field at right refers to the name 
of the Point Control that will be created 
and is always defaulted to match the 
name of the Shoulder Point. 

Note the Control Line Name 
automatically took the name of 
the Shoulder Point.  In this case 
OPS1. 

Locate Button to select 
Shoulder Point. 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 
 

   
 Lab8-92   

125.  Define the Shoulder so as to maintain an 8.0% Algebraic Difference between the 
Shoulder and Travel Lanes when the Shoulder is on the High Side of the Travel 
Lanes through a Curve. 
 

• In the High Side section of the Apply Shoulder Rollover Lock dialog ensure the 
Difference:  is set to 8.000% and the remainder of the entries match those shown 
here. 
 

                            
 
 

126.  Define the Shoulder so as to Match the Cross Slope of the Travel Lanes when the 
Shoulder is on the Low Side of the Travel Lanes through a Curve. 
 

• In the Low Side section of the Apply Shoulder Rollover Lock dialog ensure the 
Difference:  is set to 0.000% and the remainder of the entries match those shown 
here. 
 

                             
 
 

127.  Apply the Shoulder Rollover Lock and Process the Corridor. 
 

• Ensure the entries in the Apply Shoulder Rollover Lock dialog match those 
shown in Figure L8-80. 

• Click Apply & Close.  The Apply Shoulder Rollover Lock dialog closes and 
you are returned to the Roadway Designer Window. 

• In the Roadway Designer Window, click the Process All button. 
• Close the Results Report if one opens. 
• Ensure in the Roadway Designer that the Cross Section View at Station 

14+50.00 matches that shown in Figure L8-81 and that the Left Side Shoulder 
now matches the Cross Slope of the travel lanes. 
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Figure L8-80 Apply Shoulder Rollover Lock 

 
 
 

 
Figure L8-81 Roadway Designer Cross Section View 
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128.  Open the Point Controls dialog and Review the Point Control that was created. 
 

• In the Roadway Designer, select Corridor ► Point Controls…  The Point 
Controls dialog opens as shown in Figure L8-82. 

• Notice the Point Control OPS1 is listed in the Horizontal and Vertical 
Controls: section. 

• Click Close to close the Point Controls dialog when finished reviewing. 
 

 
 

 

 
Figure L8-82 Point Controls 

 
 
 
 
 
 
 
 
 

OPS1 has been added as a Point Control to control 
the Superelevation of the left side paved shoulder. 
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129.  For Information Only: 
 
Once a Point has been added as a Superelevation Control to the Point Controls dialog - 
it is no longer available to edit via the Apply Shoulder Rollover Lock dialog. 
 

For Example:  
Once Apply was clicked in the Apply Shoulder Rollover Lock dialog and OPS1 was  
added as a Point Control - it became unavailable in the Apply Shoulder Rollover  
Lock dialog for further edits.  If it is later determined that the shoulder rollover is still  
not behaving as desired, the Point Control, (in this case OPS1), must first be deleted  
from the Point Controls dialog before it can be redefined in the Apply Shoulder  
Rollover Lock dialog. 

 
130.  Save Your Work and Exit the Roadway Designer. 

 
• In the Roadway Designer, select File ► Save. 
• Click File ► Close to exit the Roadway Designer. 
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Lab 8I  Creating the Final Surface 
 
When Cross Section Plan Sheets are desired, a Final Surface (.DTM) must be created. The cross 
sections shown on the cross section sheets are generated from the Final Surface. The 
Construction Limits and the Roadway Ditches are also generated from the Final Surface.  Lab 8I 
will demonstrate the steps in creating this Final Surface. 
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131.  If not still open from the Previous Section, open MicroStation and InRoads and the 
following files.  Refer to Lab Section 8A for Help. (Omit this step if files are open). 
 

 GDOT 3D Working File.dgn  1234567_Design.alg 
 1234567_Exist.dtm  
 GDOT_Lab8.itl  

  
 

132.  To Ensure your Data Matches during this Section of Lab 8, a Roadway Design File 
(.IRD) has been prepared for you.  Open the Roadway Design File 1234567-8I.ird. 
       

• In InRoads, select File ► Open.  The Open dialog appears. 
• Browse to the folder C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight the file 1234567-8I.ird. 
• Click Open and Cancel. 
• In the InRoads workspace bar, ensure the Corridors tab is the active tab as 

shown here and that the file 1234567-8I is listed.  (You may need to click the 
Plus Symbol to expand the Roadway Designer to see the listed 1234567-8I file.) 

 

             
 
 

133.  Open the Roadway Designer and Ensure the Corridor is set to ‘SR100 SPUR’ and 
the Active Surface is set to ‘1234567_Exist’. 
 

• In InRoads, select Modeler ► Roadway Designer. 
• In the bottom left of the Roadway Designer Window, verify the Corridor: and 

Active Surface: fields are set to SR100 SPUR and 1234567_Exist respectively 
as shown here. 

 

             
 

• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 

 
 
 

Ensure the Roadway Design File 1234567-8I is 
listed. 

Ensure Corridors is the active Tab. 
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134.  Open the Create Surface dialog. 
 

• In the Roadway Designer, select Corridor ► Create Surface…  The Create 
Surface dialog opens as shown in Figure L8-83. 
 

 
 
 

 
Figure L8-83 Create Surface 
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135.  Name the Surface. 
 

• In the Name: field of the Create Surface dialog, key-in 1234567_SR100 SPUR 
as shown here. 
 

                       
 
 

      *IMPORTANT: In order to facilitate file management throughout the life of the 
Project and satisfy the Design Guidelines for GDOT Projects, a consistent 
file naming scheme shall be used.  The finished design surfaces shall follow 
the syntax PI#_Corridor Name (i.e. 1234567_SR100 SPUR).  If a finished 
surface is required that includes the surfaces of all corridors it shall be 
named PI#_Finish (i.e. 1234567_Finish). 

 
 

136.  Open the Create Surface ‘Preferences’ dialog. 
 

• In the Create Surface dialog, click the Preferences button.  The Preferences 
dialog opens as shown here. 

 

             
 
 

• Highlight FINISH as shown above. 
• Click Load and Close. 
• Ensure the settings in the Create Surface dialog match those shown in  

Figure L8-84. 
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Figure L8-84 Create Surface 
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137.    Following is a Brief Overview of the Check Boxes in the Create Surface dialog. 
 

Default Preference  
   Determines the Default Cross Section and Profile Symbology. 
 

New Surface for Each Corridor 
When unchecked, allows you to enter a Surface Name and select the Default Preference 
to be applied to the cross sections and profiles.  When checked the Surface Name and 
Default Preference are given the name of the Corridor.   
 
Empty Design Surface 
When checked, the Surface in the Name: field is emptied and replaced.  When 
unchecked, the Duplicate Names section is activated and you are given the option to 
Append, Replace, Rename or Modify the Surface. 
 
Include Null Points 
When checked, Null Points placed in Templates are added as Features in the Surface. 
 
Add Exterior Boundary – Style: 
When checked, creates an exterior boundary feature with the name ‘Exterior 
Boundary’.  Having an exterior boundary prevents triangulation from occurring beyond 
the construction limits. 
 
Densify Horizontal Curves using Chord Height Tolerance 
When checked, the stationing from which the surface is created (through horizontal 
curves) is increased relative to the Horizontal Chord Height Setting (located under 
Tools > Options > Tolerances > Horizontal Chord Height setting).  When 
unchecked the surface is processed only at the Template Drop stations. 
 
Densify Vertical Curves using Chord Height Tolerance 
When checked, the stationing from which the surface is created (through vertical 
curves) is increased relative to the Vertical Chord Height Setting (located under Tools 
> Options > Tolerances > Vertical Chord Height setting).  When unchecked the 
surface is processed only at the Template Drop stations. 
 
Triangulate 
When checked, the new surface is immediately triangulated when Apply is selected. 
 
Add Transverse Features – Style: 
When checked, Transverse Features are added to the surface at each station processed.  
Transverse Features are breaklines that are not triangulated across.  See Figure L8-85 
for further explanation. 
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Create Alternate Surfaces 
When checked, creates an alternate surface.  An alternate surface will only be created 
from the points in the Template that have been toggled to create an alternate surface.  
See Figure L8-86 for further explanation of alternate surfaces. 
 
Process Visible Range Only 
When checked, only the Corridor showing in the plan view is processed. 
 
Remove Loops 
When checked, will attempt to remove loops in linear features and also will attempt to 
trim transverse feature so they do not cross one another. This can happen in areas with 
tight radii. 
 
Display Features/Components in Plan View 
When checked, all the Features/Components created will be displayed in MicroStation. 

 
 
 

 
Figure L8-85 Transverse Features 

 

CL 
Add Transverse Features NOT checked – InRoads does not 
add Transverse Features and may triangulate poorly to give 
errors on cross sections. 

Add Transverse Features checked – InRoads creates 
Transverse Features that WILL NOT be triangulated across. 

TRANSVERSE FEATURES 
CL 

Without Transverse Features, 
a cross section fill slope may 
appear broken because of the 
location of the triangles that 
are created. 

With Transverse Features on, 
cross section fill slopes will 
be straight because of the 
location of the triangles that 
are created. 
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Figure L8-86 Alternate Surfaces 
 

 
 

138.  Create the Surface 1234567_SR100 SPUR. 
 

• In the Create Surface dialog, click Apply.  The Surface 1234567_SR100 SPUR 
is created and triangulated. 

• Close the Results Report if one opens. 
• Click Close to exit the Create Surface dialog. 
• Ensure the Surface 1234567_SR100 SPUR is populated in the InRoads 

workspace bar as shown here. 
 
 

              
 
 
 
 

Barrier 

Shoulder Travel Lane 

Assume the Template above is in a cut section.  When the earthwork is calculated it is 
calculated from the bottom surface and will follow the points from 1 - 2 - 3 - 4 - 5 - 6 - 7 
- 8.  The earthwork is calculated and paid for from this surface.  Grading of the Project is 
to a different bottom surface.  The grading surface is from 1 - 2 - 7 - 8.  The contractor 
will not attempt to meticulously grade the portion from 2 - 3 - 4 - 5 - 6 - 7. This portion 
will be backfilled later.  If toggled in the Template to create an alternate surface and the 
Create Surface dialog is toggled to create an alternate surface an alternate surface can 
be created that is from 1 – 2 – 7 – 8.  This alternate surface is useful for automated GPS 
Grading. 

2 

3 4 
5 6 

7 
8 

1 

*HINT:  The Surfaces tab must be 
the active tab in order to see the 
Surfaces in the workspace bar. 
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139.  Although the Surface 1234567_SR100 SPUR has been Created and is Visible in the 
InRoads Workspace Bar -- it has not yet been saved as a .DTM.  Save the Surface as 
1234567_SR100 SPUR.dtm. 
 

• Make sure the Surface 1234567_SR100 SPUR is the active surface by Right 
mouse clicking over it in the InRoads workspace bar and selecting Set Active. 

• Ensure the Surface 1234567_SR100 SPUR is the active surface by verifying the 
presence of a Red square around the Surface as shown here. 

 

            
 
 

• *IMPORTANT:  Notice in the bottom left of the Roadway Designer - the 
Active Surface:  is listed as 1234567_SR100 SPUR as shown here.  It is very 
important to be aware of the Active Surface:  when working in the Roadway 
Designer.  Processing a Corridor in the Roadway Designer with the wrong 
active surface will result in the Template’s End Conditions projecting to the 
wrong surface. 

 

            
 
 

• In InRoads, select File ► Save ► Surface. 
• The Save As dialog opens as shown in Figure L8-87. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 8\  
• In the File name: field, enter 1234567_SR100 SPUR.dtm  
• Ensure your entries match those shown in Figure L8-88.   
• Click Save.  Notice 1234567_SR100 SPUR.dtm now appears in the Save As 

dialog. 
• Click Cancel to close the Save As dialog. 

 
 

The Red square verifies 
1234567_SR100 SPUR 
is the active surface. 
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Figure L8-87 Save As 

 

                     
Figure L8-88 Save As 
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140.  This Completes the Creation of the ‘1234567_SR100 SPUR.dtm’.  Close 
the Roadway Designer. 
 

• In the Roadway Designer, select File ► Close. 
 

141.  Clear the MicroStation Window. 
 

• In MicroStation, select Edit ► Select All. 
• Then select the <DELETE> key on the computer keyboard. 

 
142.  Open the View Triangles dialog. 

 
• In InRoads, select Surface ► View Surface ► Triangles.  The View Triangles 

dialog opens as shown here. 
 

             
 

143.  Load the FINISH Preference. 
 

• In the View Triangles dialog, 
click the Preferences button.  
The Preferences  
dialog opens as shown here.          

• Select the Preference FINISH by 
highlighting it in blue. 

• Click Load and Close.  You are 
returned to the View Triangles 
dialog and the viewing symbology 
has been loaded for a Finished 
Surface. 

 
 
 
 
 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 

   
 Lab8-107   

144.  View the Surface ‘1234567_SR100 SPUR’. 
 

• Ensure your entries in the View Triangles dialog match those shown here. 
 

          
 

• Click Apply and Close. 
• In MicroStation, click the Fit View icon (        ). 
• Ensure your view in MicroStation matches that shown in Figure L8-89.  
• Please Note: your MicroStation View Rotation may be different than the one in 

the screen capture depicted below. 
 

 
 

 
Figure L8-89 MicroStation View 

 
 
 

1234567_SR100 SPUR 
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145.  Orient the View in MicroStation so that North is at the top. 
 

• In MicroStation, click and hold the View Rotation icon.  
 

  
 
 
 
 

• The Selection Window shown at the right 
appears.  

• Select Top View.  The view in MicroStation 
orients with North at the Top as shown in Figure 
L8-90. 

 
 
 
 
 

 
 

 
Figure L8-90 MicroStation View 

 
 
 

146.  Clear the MicroStation Window. 
 

• In MicroStation, select Edit ► Select All. 
• Then select the <DELETE> key on the computer keyboard. 

View Rotation Icon 
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Lab 8J  Target Aliasing 
 
When a Template’s End Condition encounters an obscured area or extends beyond the available 
Surface, the End Condition fails to solve and is not placed.  InRoads does not extend the existing 
ground in order to finish the placement of the Template as CAiCE users are accustomed to 
experiencing.  When these situations are encountered, the Designer is instructed to request 
additional DTM coverage from the Office of Design Policy and Support/Location Bureau. 
 The Location Bureau will provide a new DTM to the Designer with the additional coverage.  
Often obscured areas cannot be accurately surveyed; such is the case with bodies of water or 
swampy areas. In order to place a Template through these types of areas and have it solve so that 
construction limits may be computed -- a ‘Bogus Surface’ must be created.   Target Aliasing may 
then be used with the ‘Bogus Surface’.  In Lab 8J you will create a ‘Bogus Surface’ and utilize it 
with the Target Aliasing tool. 
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147.  If not still open from the Previous Section, open MicroStation and InRoads and the 
following files.  Refer to Lab Section 8A for Help. (Omit this step if files are open). 
 

 GDOT 3D Working File.dgn  1234567_Design.alg 
 1234567_Exist.dtm  
 GDOT_Lab8.itl  

  
 

148.  To Ensure your Data Matches during this Section of Lab 8, a Roadway Design File 
(.IRD) has been prepared for you.  Open the Roadway Design File 1234567-8J.ird 
       

• In InRoads, select File ► Open.  The Open dialog appears. 
• Browse to the folder C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight the file 1234567-8J.ird. 
• Click Open and Cancel. 
• In the InRoads workspace bar, ensure the Corridors tab is the active tab as 

shown here and that the file 1234567-8J is listed. (You may need to click the Plus 
Symbol to expand the Roadway Designer to see the listed 1234567-8J file.) 

 

             
 

149.  To Ensure your Data Matches during this Section of Lab 8, a Final Surface (.DTM) 
has been prepared for you.  Open the Surface 1234567_SR100 SPUR_8J.dtm 
       

• In InRoads, select File ► Open.  The Open dialog appears. 
• Browse to the folder C:\InRoads Data\1234567\Design Labs\Lab 8\ 
• Highlight the file 1234567_SR100 SPUR_8J.dtm. 
• Click Open and Cancel. 
• In the InRoads workspace bar, ensure the Surfaces tab is the active tab as shown 

here and that the file 1234567_SR100 SPUR_8J is listed. 
 

        
 

Ensure the Roadway Design File 1234567-8J 
is listed. 

Ensure Corridors is the active Tab. 

Ensure the Surface named 1234567_SR100 
SPUR_J is listed. 

Ensure Surfaces is the active Tab. 
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150.  Open the Roadway Designer and Ensure the Corridor is set to ‘SR100 SPUR’ and 
the Active Surface is set to ‘1234567_Exist’. 
 

• In InRoads, select Modeler ► Roadway Designer. 
• In the bottom left of the Roadway Designer Window, ensure the Corridor: and 

Active Surface: fields are set to SR100 SPUR and 1234567_Exist respectively 
as shown here. 

 

             
 

• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 

 
151.  View Station 46+50.00 in the Roadway Designer 

 
• In the Roadway Designer Station: entry field, key-in 46+50.00 and press Tab. 
• Ensure your view is similar to that shown in Figure L8-91. 
• Notice the left side End Condition has not found a solution and therefore was not 

placed.  This is the result of an obscured area in the 1234567_Exist surface. 
• Click File ►Close to close the Roadway Designer. 

 

  
Figure L8-91 Roadway Designer 

*REMEMBER:  You can right 
mouse click in the Cross Section 
view and select Display Properties 
to change the View Mode.  This 
view mode is set to Fit Solution. 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 
 

   
 Lab8-112   

152.  View the 1234567_Exist Surface. 
 

• In InRoads, Select Surface ► View Surface ► Triangles.  The View Triangles 
dialog opens as shown here. 

 

            
 

• Click the Preferences button.  The Preferences dialog opens as shown here. 
 

            
 

• In the Preferences dialog, highlight EXISTING. 
• Click Load and Close.  The appropriate symbology has been loaded and you are 

returned to the View Triangles dialog. 
• In the View Triangles dialog, click Apply.  Please be patient -- this may take 

several seconds.  
• Close the View Triangles dialog. 
• In MicroStation, click the Fit View icon (       ). 
• Ensure your view in MicroStation matches that shown in Figure L8-92.  The Red 

square in Figure L8-92 identifies the obscured area near the Alignment causing 
the End Condition failures. 

• In MicroStation, click the Window Area (       ) icon and window area as 
identified by the Red square in Figure L8-92. 

• Ensure your view in MicroStation matches that shown in Figure L8-93. 
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Figure L8-92 MicroStation View 

 
 

 
Figure L8-93 MicroStation View 
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153.  View All the Surface Features. 
 

• In InRoads, select Surface ► View Surface ► Features.  The View Features 
dialog opens as shown in Figure L8-94. 

• Ensure all the Features are highlighted in Blue.  This indicates they are selected.  
If they are not all selected they can be selected by Right mouse clicking in the 
window and clicking Select All. 

• Click Apply.  Please be patient, this may take several minutes. 
• Click Close to close the View Features dialog. 
• Ensure your view matches that shown in Figure L8-95 and that both the Surface 

Triangles and Surface Features are depicted. 
 

 
 

 
Figure L8-94 MicroStation View 
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Figure L8-95 MicroStation View 

 
154.  We are going to Copy a Portion of the Surface 1234567_Exist.dtm containing the 

two obscured areas shown in Figure L8-95 above into a new Surface called 
1234567_Bogus1.dtm.  We will then edit 1234567_Bogus1 to triangulate across the 
obscured areas.  1234567_Exist is always to remain un-edited by the Designer.  
Place a fence around the area to be copied. 
 

• In MicroStation,  click the Place Fence Icon ( ). 
• Ensure the Fence Type: and Fence Mode: are set as shown here: 

 

            
 

• Place a Fence to encompass the area identified by the Red square in  
Figure L8-95. 

• When placed the fence should look similar to that shown in Figure L8-96. 
 

155.  For Information Only: 
 
The File Naming scheme for a bogus surface is PI#_Bogus# (i.e. 1234567_Bogus1, 
1234567_Bogus2, etc).  This facilitates the use of data throughout the life of the Project 
and aids in file identification by users who will eventually utilize your data. 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 
 

   
 Lab8-116   

 
Figure L8-96 MicroStation View 

 
156.  Create the Surface 1234567_Bogus1 from the Portion of the Surface 1234567_Exist 

inside the Fence shown in Figure L8-96. 
 

• In InRoads, select Surface ► Edit Surface ► Copy Portion of Surface.  
The Copy Portion of Surface dialog opens as shown in Figure L8-97. 

• In the Copy Portion of Surface dialog enter the following information: 
o Source Surface:             1234567_Exist 
o Destination Surface:     1234567_Bogus1 
o Clip By:                          Fence 
o Fence Mode:                  Inside 

• All Features must be highlighted in Blue.  Remember:  You can Right mouse 
click in the Features: field and click Select All. 

• Ensure your entries match those shown 
in Figure L8-97. 

• Click Apply and Close.  The Surface 
1234567_Bogus1 has been created as 
can be seen in the InRoads workspace 
bar. 

• Ensure the Surface 1234567_Bogus1 is 
visible in the InRoads workspace bar as 
shown at right.  

• In MicroStation, click the Place Fence Icon ( ) to remove the Fence from the 
MicroStation View. 
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Figure L8-97 Copy Portion of Surface 

 
 

157.  Clear the MicroStation View. 
 

• In MicroStation, select Edit ► Select All. 
• Then select the <DELETE> key on the computer keyboard. (Please be patient. It 

may take a while for the screen to clear).   
• The MicroStation view is now cleared. 

 
158.  View the Surface Triangles for 1234567_Bogus1. 

 
• In InRoads, select Surface ► View Surface ► Triangles.  The View Triangles 

dialog opens. 
• In the View Triangles dialog, click the Preferences button.  

The Preferences dialog opens. 
• In the Preferences dialog, highlight BOGUS SURFACE. 
• Click Load & Close.  The symbology for a Bogus Surface is loaded. 
• In the View Triangles dialog, use the pull down arrow to select the Surface 

1234567_Bogus1. 
• Ensure your entries match those shown in Figure L8-98.  
• Click Apply.  An Alert Message appears stating Triangles are out of date as 

shown in Figure L8-99.  Click Yes to triangulate.   
• Close the View Triangles dialog. 
• Ensure your view in MicroStation matches that shown in Figure L8-100. 
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Figure L8-98 View Triangles 

 
 
 
 

 
Figure L8-99 Alert Message 
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Figure L8-100 MicroStation View 

 
 
 

159.  View the Surface Features for 1234567_Bogus1. 
 

• In InRoads, select Surface ► View Surface ► Features.  The View Features 
dialog opens. 

• In the View Features dialog, ensure 1234567_Bogus1 is shown in the Surface: 
field. 

• Ensure All Features are selected and shown highlighted in Blue. 
• Click Apply and Close.   
• Ensure your view in MicroStation matches that shown in Figure L8-101. 

 
 
 

 
Figure L8-101 MicroStation View 
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160.  In Figure L8-101 above, which depicts the Surface 1234567_Bogus1, the obscured 
areas are still shown obscured.  In order to triangulate across the obscured areas 
the Feature Type causing it to be obscured must be changed from ‘Interior 
Boundary’ to ‘Breakline’.  For more information on Feature Types the Designer is 
referred to the Survey Training Material.  Open the Feature Properties Dialog. 
 

• In InRoads, select Surface ► Feature ► Feature Properties.  The Feature 
Properties dialog opens as shown in Figure L8-102. 

  
Please Note: Some of the Features in your view may not correspond with the screen 
capture depicted below in Figure L8-102. The reason for this is because the location of 
the Fence (which was selected in Step 154) to select the Features may be slightly 
different from what you selected. 
  

 

 
Figure L8-102 Feature Properties 

 
 
 
 
 
 
 
 
 

Click the Locate button in order 
to select a Feature graphically 
from the MicroStation View. 
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161.  Select the Feature MOBSC24. 
 

• In the Feature Properties dialog, click the Locate button ( ) identified in 
Figure L8-102.  The Feature Properties dialog disappears and makes the 
MicroStation Window active. 

• Notice in the bottom left corner of the MicroStation Window you are prompted 
to: <Select Feature.  Left Click on the border of the smaller of the obscured areas 
as shown in Figure L8-103. 

• Notice in the bottom left corner of the MicroStation Window you are prompted 
to: <Accept/Reject MOBSC24 indicating MOBSC24 is the selected Feature. 

• Left Click anywhere in a blank part of the MicroStation Window to accept. 
The Feature Properties dialog reappears with MOBSC24 selected as shown 
here. 
 

 
 

  
 
 

           
Figure L8-103 MicroStation 

 
 

162.  Change the Feature Type of MOBSC24 from Interior to Breakline. 
 

• In the Triangulation frame of the Feature Properties dialog, use the pull down 
arrow to change the Feature Type: from Interior to Breakline. 

• Ensure the entries in your Feature Properties dialog match those shown in 
Figure L8-104. 

• Click Apply but do not close the Feature Properties dialog. 
 

 

Left click anywhere on the border 
of the smaller obscured area. 
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Figure L8-104 Feature Properties 

 
 
 

163.  Select the Feature Type of MOBSC25. 
 

• In the Feature Properties dialog, click the Locate button ( ) identified in 
Figure L8-102. 

• Notice in the bottom left corner of the MicroStation Window you are prompted 
to: <Select Feature.  Left Click on the border of the larger of the obscured areas 
as shown in Figure L8-105. 

• Notice in the bottom left corner of the MicroStation Window you are prompted 
to: <Accept/Reject MOBSC25 indicating MOBSC25 is the selected Feature. 

• Left Click anywhere in a blank part of the MicroStation Window to accept. 
The Feature Properties dialog reappears with MOBSC25 selected as shown 
here. 
 

 
 

  
 

Ensure MOBSC24 is highlighted 
and Breakline is selected. 
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Figure L8-105    MicroStation 

 
164.  Change the Feature Type of MOBSC25 from Interior to Breakline. 

 
• In the Triangulation frame of the Feature Properties dialog, use the pull down 

arrow to change the Feature Type: from Interior to Breakline. 
• Ensure the entries in your Feature Properties dialog match those shown in 

Figure L8-106. 
• Click Apply and Close to exit the Feature Properties dialog. 

 
 

 
Figure L8-106 Feature Properties 

Left click anywhere on the border 
of the larger obscured area. 
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165.  Now that the Feature Types for both of the Features MOBSC24 and MOBSC25 

have been changed from Interior to Breakline the obscured areas may be 
triangulated across.  Retriangulate and review the Surface. 
 

• In InRoads, select Surface ► Triangulate Surface. The Triangulate Surface 
dialog opens.  

• Match the entries shown in Figure L8-107. 
• Click Apply and Close. 

 
 

 

              
Figure L8-107 Triangulate Surface 

 
166.  Clear the MicroStation Graphics. 

 
• In MicroStation, select Edit ► Select All. 
• In MicroStation, click the Delete icon ( ). 

 
167.  View the Surface 1234567_Bogus1. 

 
• In InRoads, select Surface ► View Surface ► Triangles.  The View Triangles 

dialog opens as shown here. 
 

Always enter 300 as the maximum 
length when triangulating a surface.  
This value is set by the Office of 
Design Policy and Support/Location 
Bureau. 
 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 

   
 Lab8-125   

             
 

• Click the Preferences button.  The Preferences dialog opens. 
• Select the BOGUS SURFACE so that it is highlighted in blue. 
• Click Load and Close. 
• In the View Triangles dialog ensure the entries match those shown above, then 

click Apply and Close. 
• Ensure your view in MicroStation matches that shown in Figure L8-108. 
• Notice the obscure areas are now triangulated across. 

 
 
 
 

 
Figure L8-108 MicroStation 

 
 

168.  IMPORTANT! 
 
Although the obscured areas have now been triangulated across, as shown in Figure L8-
108, it is important to remember that this data is not accurate and has been generated 
solely for use in the Roadway Designer to ensure that the end conditions solve for all 
Templates and allows construction limits to be generated.  The only existing Surface data 
to be considered accurate comes from the Office of Design Policy and Support/Location 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 
 

   
 Lab8-126   

Bureau. 
 

169.  Now that the Surface 1234567_Bogus1 has been created and the Obscured areas 
triangulated across, it is time to use the Target Aliasing tool to have the Roadway 
Designer search for the Surface 1234567_Bogus1 when the Surface 1234567_Exist 
cannot be found.  Open the Roadway Designer. 
 

• In InRoads, select Modeler ► Roadway Designer.  The Roadway Designer 
Opens. 

 
170.  Set the Corridor to SR100 SPUR. 

 
• In the Roadway Designer Window, use the pull down arrow to select the 

Corridor:  SR100 SPUR as shown in Figure L8-109. 
 

171.  Set the Active Surface to 1234567_Exist. 
 

• In the Roadway Designer Window, use the pull down arrow to select the Active 
Surface: 1234567_Exist as shown in Figure L8-109. 

• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 
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Figure L8-109 Roadway Designer 

 
 
 
 
 
 
 
 
 
 

172.  Open the Target Aliasing Dialog. 
 

• In the Roadway Designer, select Tools ► Target Aliasing.  The Target 
Aliasing dialog opens as shown in Figure L8-110. 

 
 
 
 

Ensure the Corridor: is set to 
SR100 SPUR. 

Ensure the Active Surface:  is set to 
1234567_Exist. 
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Figure L8-110 Target Aliasing 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

173.  The Target Aliasing tool instructs the End Conditions to search the Surfaces listed 
in the ‘Aliases:’ field.  The Surfaces are searched in the order in which they are 
listed in the ‘Aliases:’ field unless the ‘Use Closest’ check box is checked.  Move the 
Surfaces 1234567_Exist and 1234567_Bogus1 from the Surface or Corridor field to 
the ‘Aliases:’ field. 
 

• In the Target Aliasing dialog, highlight the Surface 1234567_Exist as shown 
here. 
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• Click the Add-> button to move the Surface to the Aliases: field as shown here. 
 

       
 

• In the Target Aliasing dialog, highlight the Surface 1234567_Bogus1 as shown 
here. 

              

 
 

• Click the Add-> button to move the Surface to the Aliases: field as shown here. 
            

 
 

• Ensure your Target Aliasing dialog matches that shown in Figure L8-111. 
• Click OK. 
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Figure L8-111 Target Aliasing 

 
 

174.  Process the Changes in the Roadway Designer. 
 

• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 

 
175.  View Station 46+50.00 in the Roadway Designer 

 
• In the Roadway Designer Station: entry field, key-in 46+50.00 and press the 

Tab key. 
• Ensure your view matches that shown in Figure L8-112. 
• Hint: Use the Zoom Out button on the left side of the Cross Section View to 

zoom out to view the Existing/Bogus Surface and Template. 
 
 

                                       
 

• Notice the Left Side End Condition has now found a solution as opposed to Step 
151 and Figure L8-91.  This is the result of the Target Aliasing tool and the 
Bogus Surface we created. 

• Notice also the color of the Bogus Surface in the Cross Section view is white 
rather than pink representing a Bogus Surface.  This is because the Surface 
Properties have not yet been set. 

 

Zoom out button 



Introduction to InRoads - Design  InRoads SS2 – Lab 8 

   
 Lab8-131   

      
Figure L8-112 Roadway Designer 

 
176.  Set the Surface Properties in the Surface 1234567_Bogus1. 

 
• In the InRoads workspace bar, ensure the Surface tab is the active tab as shown 

here. 

               
 

• Right mouse click over the Surface 1234567_Bogus1 and select Properties.  
The Surface Properties dialog opens as shown in Figure L8-113. 

• In the Surface Properties dialog, use the pull down arrow to select the 
Preference: BOGUS SURFACE. 

• Ensure your entries match those shown in Figure L8-114. (Please Note that your 
numbers may not match the screen capture exactly due to differences in the 
creation of the border of the Bogus DTM). 

• In the Surface Properties dialog, click the Advanced tab. 
• Use the pull down arrows to select BOGUS SURFACE for both the Cross 

Sections: Symbology and the Profiles: Symbology. 
• Ensure your entries match those shown in Figure L8-115. 
• Click Apply and Close. 

Notice there are no gaps in the 
Surface now.  Also notice the 
color is white rather than pink 
representing a Bogus Surface. 

Ensure the Surfaces 
tab is the active tab. 
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Figure L8-113 Surface Properties 

 

 
Figure L8-114 Surface Properties 

Ensure the Preference is set 
to BOGUS SURFACE. 
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Figure L8-115 Surface Properties 

 
 

177.  Process the Roadway Designer and View Station 46+50.00 in the Roadway Designer. 
 

• In the Roadway Designer, ensure 1234567_Exist is the Active Surface:. 
• In the Roadway Designer, click the Process All button. 
• Close the Results Report if one opens. 
• In the Roadway Designer Station: entry field, key-in 46+50.00 and press the 

Tab key. 
• Ensure your view matches that shown in Figure L8-116 and that the Bogus 

Surface is now colored Pink. 
• Hint: Use the Zoom Out button on the left side of the Cross Section View to 

zoom out to view the Existing/Bogus Surface and Template. 
 

 
 

Ensure the Cross Section Symbology 
and Profiles Symbology are set to 
BOGUS SURFACE. 
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Figure L8-116 Roadway Designer 

 
 

178.  Although the Surface 1234567_Bogus1 has been Created and is Visible in the 
InRoads workspace bar, it has not yet been saved as a .DTM.  Save the Surface as 
1234567_Bogus1.dtm. 
 

• Make the Surface 1234567_Bogus1 the active surface by Right mouse clicking 
over it in the InRoads workspace bar and selecting Set Active. 

• Ensure the Surface 1234567_Bogus1 is the active surface by verifying the 
presence of a Red square around the Surface as shown here. 

 

                                                          
 
 
 
 

The Red square verifies 
1234567_Bogus1 is the 
active surface. 
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• *IMPORTANT:  Notice in the bottom left of the Roadway Designer, the Active 

Surface: is listed as 1234567_Bogus1 as shown here.  It is very important to be 
aware of the Active Surface: when working in the Roadway Designer.  
Processing a Corridor in the Roadway Designer with the wrong active surface 
will result in the Templates’ End Conditions projecting to the wrong Surface. 

 

            
 

• In InRoads, select File ► Save ► Surface. 
• The Save As dialog opens as shown in Figure L8-117. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 8\  
• In the File name: field, enter 1234567_Bogus1.dtm  
• Ensure your entries match those shown in Figure L8-118.   
• Click Save.  Notice 1234567_Bogus1.dtm now appears in the Save As dialog. 
• Click Cancel to close the Save As dialog. 

 
 

 
Figure L8-117 Save As 
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Lab 9  
Cross Section Sheets and Annotation 

 
Objective 
 
The objective of this Lab is to provide a brief workflow overview to generate Cross Sections on 
Cross Section Sheets and apply Annotation to the Cross Sections. The Create and Annotate 
Cross Sections are located under the InRoads Evaluation menu. 
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Lab 9A Set  Project Defaults and Open Files 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 scale project.  Enter 50 for the Text, Cell & Line Style Scale 

Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 

Sets the Design Default Preference. 
6.  Open 1234567_Design.alg 

 
• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 9\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 

7.  Open GDOT_Lab9.itl 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 9\ 
• Highlight GDOT_Lab9.itl 
• Click Open & Cancel. 

 
The Template Library GDOT_Lab9 is opened. 
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8.  Open 1234567_Lab9.ird 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 9\ 
• Highlight 1234567_Lab9.ird 
• Click Open & Cancel. 

 
The Roadway Design File 1234567_Lab9 is opened. 

9.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 9\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface Project 1234567_Exist is opened. 

10.  Open 1234567_SR100 SPUR_Lab9.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 9\ 
• Highlight 1234567_SR100 SPUR_Lab9.dtm  
• Click Open & Cancel. 

 
The Finish Surface 1234567_ SR100 SPUR_Lab9 is opened. 

11.  Open 1234567_Bogus1_Lab9.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 9\ 
• Highlight 1234567_Bogus1_Lab9.dtm  
• Click Open & Cancel. 

 
The Bogus Surface 1234567_Bogus1_Lab9 is opened. 
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Lab 9B Process to Create Cross Sections 
 
In Lab 9B, you will learn how to view Cross Sections on Cross Section Sheets in MicroStation. 
InRoads refers to this as Creating Cross Sections.  To create Cross Sections depicting the 
Existing Ground and the Roadway Design, a minimum of an Existing Ground Surface .DTM and 
a Final Design Surface .DTM must exist. In this Section of Lab 9 three Surfaces have been 
prepared for you:  an Existing Ground Surface named 1234567_Exist.dtm, a ‘Bogus’ Surface 
named 1234567_Bogus1_Lab9.dtm (for temporary handling of obscured areas) and a Roadway 
Design Surface named 1234567_SR100 SPUR_Lab9.dtm 
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12.  Whenever Cross Sections are to be viewed in MicroStation, the Global Scale Factor 
must be changed from 50.00 to 10.00 for the Text, Cell, and Line Style.  Open the 
‘Global Scale Factors’ dialog. 
 

• In InRoads, select Tools ► Global Scale Factors.  The Scale Factors dialog 
opens as shown here. 

 

             
 
 

13.  Change the Scale Factors of the Text, Cell  and Line Style to 10.00 
 

• Match the entries shown here. 
 

            
 

• Click Apply and Close. 
 
 

14.  Open the Cross Sections dialog. 
 

• In InRoads, select Evaluation ► Cross Section ► Cross Sections.  The Cross 
Section dialog opens as shown in Figure L9-1.  
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Figure L9-1 Create Cross Section 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

*NOTE:  The Set 
Name: defaults to the 
Active Alignment 
name. 
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15.  Open the Preferences Dialog. 
 

• Ensure the Create Cross Section “folder” is highlighted/selected as 
depicted here:  

 
       NOTE: Depending on which folder is selected 
       (either “Create Cross Section, Annotate Cross  
       Section, Update Cross Section or End-Area  
       Volumes), the available Preferences will change. 
 
 
             

 
• In the Cross Sections dialog, click the Preferences button.  The Preferences 

dialog opens as shown here. 
 

       
 

16.  Load the Preference for Wide Cross Sections. 
 

• In the Preferences dialog, highlight the Preference Wide 10h 10v as shown here. 
 
           
 
 
*NOTE: The Wide 10h 10v Preference loads 
the settings into the Cross Sections dialog to 
view Cross Sections in a Wide format on the 
GDOT SUXSEW Cross Section plan sheet 
cell.  Likewise, the Narrow 10h 10v 
Preference loads the settings into the Cross 
Sections dialog to view Cross Sections in a 
Narrow format on the GDOT SUXSEN Cross 
Section plan sheet cell. 

• Click Load and Close.   
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17.  Select the Surfaces to View on the Cross Section Sheets. 
 

• In the Cross Sections dialog, click the General tab to ensure it is the active tab as 
shown in Figure L9-2. 

• Ensure the check boxes for the following Surfaces are checked as shown in 
Figure L9-2. 
 

o 1234567_Exist 
o 1234567_SR100 SPUR_Lab9 
o 1234567_Bogus1_Lab9  

 
 
 

 
Figure L9-2 Create Cross Section 

 
 
 
 
 
 
 

Ensure the General 
tab is the active tab. 

Ensure the check 
boxes for these 3 
Surfaces are checked. 
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18.  View the Cross Sections in MicroStation. 
 

• In the Cross Sections dialog, click Apply. 
• In the bottom left corner of the MicroStation Window you are prompted to 

>Identify Location.  Left click anywhere in the MicroStation Window.  Please 
be patient while the Cross Sections are drawn in MicroStation. 

• When the Cross Sections have completed drawing in MicroStation, the Cross 
Sections dialog reappears.  

• Click Close to close the Cross Sections dialog. 
• In MicroStation, click the Fit View icon (       ). 
• Ensure your view in MicroStation matches that shown in Figure L9-3. 

 
 

 
 

 
Figure L9-3 MicroStation 
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19.  Open the Cross Section Viewer. 
 

• In InRoads, select Evaluation ► Cross Section ► Cross Section Viewer…  
The Cross Section Viewer opens as shown in Figure L9-4. 

 
 

 
Figure L9-4 Cross Section Viewer 

 
20.  Use the Cross Section Viewer to View Station 46+50 in MicroStation. 

 
• In the Cross Section Viewer, use the scroll arrows and scroll to 46+50 and Left 

click on 46+50 to highlight it as shown here. 
 

            
 

• Notice in MicroStation - the View Window now contains the Cross Section at 
Station 46+50 as shown in Figure L9-5. 

• Notice also in MicroStation at Station 46+50 the Pink section of the Existing 
Ground.  This represents the Bogus Ground that was created in Lab 8 to represent 
obscured areas and ensures the End Conditions solve.  

• Click Close to exit the Cross Section Viewer. 
• In MicroStation, click the Fit View icon (       ) to fit the view. 

 



Introduction to InRoads - Design  InRoads SS2 – Lab 9 
 

   
 Lab9-12   

 
Figure L9-5 MicroStation 

 
 
 

21.  Clear the MicroStation View. 
 

• In MicroStation, select Edit ► Select All. 
• In MicroStation, click the Delete icon ( ). 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Station 46+50  

Pink section of Existing 
Ground represents the 
Bogus Surface created in 
Lab 8.  
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22.  Open the Cross Sections dialog again. 
 

• In InRoads, select Evaluation ► Cross Section ► Cross Sections.  The Cross 
Sections dialog opens. 

 
 

23.  Verify the Global Scale Factors are set to 10.00 
 

• In InRoads, select Tools ► Global Scale Factors.  The Scale Factors dialog 
opens. 

• Ensure 10.00 is entered for each of the items as shown here. 
 

             
 

• Click Apply and Close. 
 

24.  Load the Preference ‘Wide 10h 10v’. 
 

• Ensure the Create Cross Section “folder” is highlighted/selected. 
• In the Cross Sections dialog, click the Preferences button. 
• Select the Preference of Wide 10h 10v. 
• Click Load and Close. 

 
25.  Select the Surfaces to View on the Cross Section Sheets. 

 
• In the Cross Sections dialog, click the General tab to ensure it is the active tab as 

shown in Figure L9-6. 
• Ensure the check boxes for the following Surfaces are checked as shown in 

Figure L9-6. 
 

o 1234567_Exist 
o 1234567_SR100 SPUR_Lab9 
o 1234567_Bogus1_Lab9  
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Figure L9-6 Create Cross Section 

 
 

26.  View Only Stations 10+00 to 25+00. 
 

• In the Cross Sections dialog, click the Controls folder identified in  
Figure L9-6. 

• Highlight the Limits tab as shown in Figure L9-7. 
• Place a Check in the Station check box as shown in Figure L9-7. 
• Key-in 10+00 for the Start: station and 25+00 for the Stop: station as shown in 

Figure L9-7. 
• Click Apply. 
• You are prompted in the bottom left corner of the MicroStation Window to 

>Identify Location.  Left click anywhere in the MicroStation Window. 
• Click Close to close the Cross Sections dialog. 
• In MicroStation, click the Fit View icon (       ). 
• Ensure your view in MicroStation matches that shown in Figure L9-8 and that 

only Stations 10+00 to 25+00 were drawn. 
• Do not clear the MicroStation Window.  The Graphics will be needed for Lab 9C. 

 

Ensure the General 
tab is the active tab. 

Ensure the check 
boxes for these 3 
Surfaces are checked. 

Controls 
Folder 
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Figure L9-7 Create Cross Section 

 

 
Figure L9-8 MicroStation View Window 

Place a Check in the Station 
check box. 
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Lab 9C Annotating Cross Sections 
 
Annotation in InRoads is a manual process of identifying the Points, Segments or Features you 
wish to have annotated.  Annotation includes loading the proper Preferences in order for the text 
to be viewed in the desired format (i.e. horizontal, vertical, diagonal, etc.) and symbology. In Lab 
9C you will learn how to annotate the following items according to the GDOT Plan Presentation 
Guide. 
 

• Profile Grade Elevations  (Vertical Elevation Text) 
• Existing Ground Elevations (Diagonal Elevation Text) 
• Ditch Elevations (Horizontal Elevation Text) 
• Roadway Slopes (Percent format) 
• Shoulder Slopes (Percent format) 
• Front Slopes (Ratio format) 
• Back Slopes (Ratio format) 
• Slope Stake Offset Distance (Vertical Offset Distance Text) 
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27.  Zoom into Station 10+00. 
 

• In InRoads, select Evaluation ► Cross Section ► Cross Section Viewer. 
• Change the Zoom Factor: to 0.4000. 
• Highlight Station 10+00. 
• Your view in MicroStation should be similar to that shown in Figure L9-9. 

 
NOTE: At the end of the cursor, the Offset and Elevation text of the current location will 
display. The displayed text attributes (size, color, etc.), uses the following MicroStation 
Place Text settings: Height, Width, Font, and Justification. These settings can be adjusted 
in the MicroStation Place Text dialog if the text size is too large. 
  

• Click Close to exit the Cross Section Viewer dialog box. 
 

 
 

 
Figure L9-9 MicroStation View Window 

 
 
 
 
 
 
 
 
 
 



Introduction to InRoads - Design  InRoads SS2 – Lab 9 
 

   
 Lab9-18   

28.  Before Annotating, the ‘Pencil/Pen Lock’ and the ‘Delete Ink’ Lock must be set 
properly. 
 

• In InRoads, select Tools ► Locks.  Ensure the Pencil/Pen lock is set to Pen.  A 
Blue pen should be shown next to Pencil/Pen as shown here and not a Yellow 
pencil.  The Pen setting ensures successive labeling will not be erased. 
  

 
 

• In InRoads, again select Tools ► Locks.  Ensure a check mark is not shown next 
to Delete Ink as shown here.  This also prevents the labeling from being erased 
with each successive labeling.  

 
 

 
29.  Open the Cross Sections dialog. 

 
• In InRoads, select Evaluation ► Cross Section ► Cross Sections.  The Cross 

Sections dialog opens as shown in Figure L9-10. 
 

 
 

 
Figure L9-10 Annotate Cross Section 

Ensure a Blue pen is shown 

Ensure a Check is not shown 
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30.  Load the Preference ‘XSEC TEXT – CL EL. GROUND’.  This Preference Loads 
the Settings to Label the Existing Ground Elevation at the Centerline. 
 

• Ensure the Annotate Cross Section “folder” is highlighted/selected as 
depicted here:  
 

 
       NOTE: Depending on which folder is selected 
       (either “Create Cross Section, Annotate Cross  
       Section, Update Cross Section or End-Area  
       Volumes), the available Preferences will change. 
 
 
  
  

           
• In the Cross Sections dialog, click the Preferences button.  The Preferences 

dialog opens as shown here. 
 

             
 

• Select the Preference XSEC TEXT – CL EL. GROUND. 
• Click Load and Close.   
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31.  Review the Settings Loaded by the ‘XSEC TEXT – CL EL. GROUND’ Preference. 
 

• In the Annotate Cross Section folder, make the Points folder the active folder as 
shown in Figure L9-11. 

• Notice, in Figure L9-11, that a check mark exists next to the Include Points 
check box.  This makes the Points available for annotating. 

• Notice, in Figure L9-11, that the check box labeled Center is checked.  This turns 
on the Center Point of the Alignment for labeling.   

• Notice, in Figure L9-11, the Name XSEC_E_Ground.  This is the name of the 
Named Symbology that has been set up for this item and ensures that the labeling 
is viewed with the proper attributes in MicroStation and is placed on the proper 
Level in MicroStation for plotting. 

• Make the Segments folder the active folder as shown in Figure L9-12.  Notice the 
Include Segments check box is unchecked.  No Segments are set up to be 
annotated with the XSEC TEXT – CL EL. GROUND Preference. 

• Make the Features folder the active folder as shown in Figure L9-13.  Notice the 
Include Features check box is unchecked.  No features are set up to be annotated 
with the XSEC TEXT – CL EL. GROUND Preference. 

 
 
 
 

  
Figure L9-11 Annotate Cross Sections 

Points folder 

Include Points is 
checked. 
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Figure L9-12 Annotate Cross Section 

 

  
Figure L9-13 Annotate Cross Section 

Segments/General 
folder 

Include Segments 
is unchecked. 

Include Features 
is unchecked. 

Features/General 
folder 
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32.  Even though the Settings have been loaded to Label the Elevation of the Existing 
Ground at the Centerline - the Surface to be labeled must still be selected.  Select 
the Surface 1234567_Exist and Annotate the Cross Sections. 
 

• In the Annotate Cross Section folder, ensure the General tab shown in  
Figure L9-14 is the active tab. 

• Place a check in the check box for the Surface 1234567_Exist as shown in  
Figure L9-14. 

• Click Apply but do not close the Cross Sections dialog. 
• Verify in MicroStation the Existing Ground was annotated at the Centerline as 

shown in Figure L9-15. 
 
     *NOTE: InRoads annotates the Existing Ground on the Existing Ground rather than 

on the pavement surface next to the proposed elevation as has been done in 
the past. 

 
 
 

 

 
Figure L9-14 Annotate Cross Section 

 

Select the Surface 
1234567_Exist by 
placing a check in the 
check box. 

Ensure the General tab 
shown here is selected. 
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Figure L9-15 MicroStation View Window 

 
 

33.  Load the Preference ‘XSEC – EL. VERTICAL’.  This Preference Loads the Settings 
to Label the Proposed Profile Grade Elevations. 
 

• Ensure the Annotate Cross Section folder is selected, and then click the 
Preferences button.  The Preferences dialog opens. 

• Select the preference XSEC – EL. VERTICAL as shown here. 
 

            
 

• Click Load and Close. 
 
 

Verify the Existing 
Ground Elevation was 
annotated. 
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34.  Even though the Settings have been loaded to Label the Proposed Profile Grade 
Elevations, the Surface to be Labeled must still be selected.  Select the Surface 
‘1234567__SR100 SPUR_Lab9’ and Unselect the Surface ‘1234567_Exist’. 
 

• In the Annotate Cross Section folder, ensure the General tab is the active tab. 
• Place a check in the check box for the Surface 1234567_SR100 SPUR_Lab9 as 

shown in Figure L9-16. 
• Ensure the Surface 1234567_Exist does not have an X in the check box as shown 

in Figure L9-16. 
• Do not click Apply.  Proceed to Step 35. 

 
 

 
 

 
Figure L9-16 Annotate Cross Section 
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35.  Review the Settings Loaded by the ‘XSEC TEXT – EL. VERTICAL’ Preference. 
 

• In the Annotate Cross Section folder, make the Points folder the active folder.  
Notice the check box for Include Points is unchecked.  No Points will be 
annotated with the XSEC TEXT – EL. VERTICAL Preference. 

• Make the Segments folder the active folder with General the active tab.  Notice 
the Include Segments check box is also unchecked. No segments will be 
annotated with the XSEC TEXT – EL. VERTICAL Preference. 

• Make the Features folder the active folder with General the active tab.  Notice 
the Include Features check box is checked and Elevation is checked. 

• Click the field identified by three dots ( ) at the end of the Elevation line.  The 
Text Symbology dialog opens as shown in Figure L9-17. 

• The proposed Profile Grade Elevation text is defined to view in MicroStation on 
the Level XSEC_P_Label-Text in order for it to view and plot correctly. The 
remainder of the attributes are also set up to properly view in MicroStation.  

• Click Cancel to exit the Text Symbology dialog. 
 

 
 

 
Figure L9-17 Text Symbology 
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36.  Unselect all the Features in the Feature: Field. 
 

• In the Annotate Cross Section folder, select the Features-Annotate folder as 
shown in Figure L9-18. 

 
*NOTE: When the Roadway Designer was used in Lab 8 to create the Surface 
1234567_SR100 SPUR, a Feature was created from each Point in each Template 
used.  Each Feature is named according to the Point name in the Template pre-
appended with the Surface Name.  Each Feature becomes available for annotating 
and it is these Features that are listed in the Feature: field in Figure L9-18. 
 
• Right mouse click in the Feature: field shown in Figure L9-18.  The pop-up box 

shown at right displays. 
• Left click on Select None.  This unselects 

all selections as shown in Figure L9-19. 
                              

 
 

 
 

 
Figure L9-18 Annotate Cross Section 

Right mouse click 
anywhere in the 
Feature: field area to 
bring up the pop-up 
menu. 

Features/Annotate 
folder 
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Figure L9-19 Annotate Cross Section 

 
 
37.  Select the Feature that will Annotate the Proposed Profile Grade Elevations and 

Annotate the Elevation. 
 

• In the Annotate Cross Section folder, click the Locate button identified in 
Figure L9-19 above next to the Feature: field.  The Cross Sections dialog 
disappears and the MicroStation Window becomes active.   

• Notice in the bottom left corner of the MicroStation Window you are prompted to 
>Select Feature.  Left click on the Crown Point identified as PGL as shown in 
Figure L9-20. 

• Notice in the bottom left corner of the MicroStation Window you are prompted to 
<Accept/Reject the Feature.  Left click again in the MicroStation Window to 
accept.  You are returned to the Cross Sections dialog and the Feature SR100 
SPUR-PGL is selected as shown in Figure L9-21. 

• Verify the Feature SR100 SPUR-PGL is highlight in blue as shown in  
Figure L9-21. 

• Click Apply but do not close the Cross Sections dialog.   
• Verify the Proposed Elevation was annotated as shown in Figure L9-22. 

 

Locate button identified 
for Step 37. 
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Figure L9-20 MicroStation View Window 

 

 
Figure L9-21 Annotate Cross Section 

PGL 
*HINT: Use the mouse wheel to 
zoom in and out as necessary. 
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Figure L9-22 MicroStation View Window 

 
38.  Load the Preference ‘XSEC – EL. HORIZONTAL’.  This Preference Loads the 

Settings to Label the Proposed Ditch Elevations. 
 

• In the Annotate Cross Section folder, click the Preferences button.  The 
Preferences dialog opens. 

• Select the Preference XSEC – EL. HORIZONTAL as shown here. 
 

            
 
 
 
 
 

Verify the Proposed 
elevation was annotated 
as shown here. 
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• Click Load and Close. 
• In the Annotate Cross Section folder, make the Features – General folder the 

active folder as shown in Figure L9-23. 
• Notice the Include Features check box is still checked. 
• Notice also that the Elevation check box is still checked and that the Named 

Symbology is set to XSEC_P_Label.  
• In the Annotate Cross Section folder, make the Features – Annotate folder the 

active folder as shown in Figure L9-24. 
 
 

 
 

 
Figure L9-23 Annotate Cross Section 
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Figure L9-24 Annotate Cross Section 

 
39.  Select the Feature that will Annotate the Roadway Ditch Elevations. 

 
• Right mouse click in the Feature: field.   
• Left click on Select None.  This clears the selections in the Feature: field. 
• In the Cross Sections dialog, click the Locate button.  The Cross Sections dialog 

disappears and the MicroStation Window becomes active.   
• Notice in the bottom left corner of the MicroStation Window you are prompted to 

>Select Feature.   Left click on the Point identified as IDT2 in Figure L9-25. 
• Notice in the bottom left corner of the MicroStation Window you are prompted to 

>Accept/Reject the Feature.  Left click in the MicroStation Window to accept.  
You are returned to the Cross Sections dialog and the Feature SR100 SPUR-
IDT2 has been selected as shown in Figure L9-26. 

• Click the Locate button again. 
• Left click on the Point identified as ODT in Figure L9-25 and accept the Point. 
• Notice in Figure L9-27 two Features are now selected:  SR100 SPUR-IDT2, 

selected in the previous Locate operation, and SR100 SPUR-ODT selected in this 
operation. 

• Click Apply but do not close the Cross Sections dialog. 
• Verify your view in MicroStation matches that shown in Figure L9-28 and the 

Ditch Elevations were annotated. 
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Figure L9-25 Annotate Cross Section 

 
 

 
Figure L9-26 Annotate Cross Section 

IDT2 ODT 
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Figure L9-27 Annotate Cross Section 

 

 
Figure L9-28 MicroStation View Window 

The Left and Right Ditch 
Elevations have been 
annotated. 
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40.  Load the Preference ‘XSEC TEXT – OFFSET’. 
 

• In the Annotate Cross Section folder, click the Preferences button.  The 
Preferences dialog opens. 

• In the Preferences dialog, select the Preference XSEC TEXT – OFFSET. 
• Click Load and Close.  The settings are loaded into the Annotate Cross Section 

folder to annotate the slope stake offset distances on the proper level in 
MicroStation with the correct attributes. 

 
 

41.  Unselect All the Features in the Features-Annotate Folder. 
 

• In the Annotate Cross Section folder, ensure the Features folder and the 
Annotate sub folder are the active folders. 

• In the Features: field, Right mouse click and choose Select None from the pop-
up menu.   

 
42.  Select the Slope Stake Features to Annotate. 

 
• Use the Locate button to select the Left and Right Slope Stake features identified 

in Figure L9-29. 
 

 

 
Figure L9-29 MicroStation View Window 

 
 
 

Left Slope Stake Feature Right Slope Stake Feature 
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43.  Annotate the Slope Stake Features. 
 

• In the Annotate Cross Section folder, ensure your selections match those shown 
in Figure L9-30. 

• Click Apply but do not close the Cross Sections dialog. 
• Verify your view in MicroStation matches that shown in Figure L9-31 and the 

Slope Stake Offset distances were annotated. 
 

 
 

 

 
Figure L9-30 Annotate Cross Section 
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Figure L9-31 MicroStation View Window 

 
 
 

44.  Review Station 17+00.00. 
 

• If not still open, open the Cross Section Viewer.  Select Evaluation ► Cross 
Section ► Cross Section Viewer. The Cross Section Viewer dialog opens. 

• Set the Zoom Factor: to 0.4000. 
• Highlight station 17+00.  
• Verify in MicroStation that Station 17+00 was centered in the MicroStation View 

Window as shown in Figure L9-32. 
• Notice the Slope Stake Offsets are not shown for the Fill Slopes.  This is because 

the Fill Slopes have different Feature Names than the Cut Slopes and must be 
annotated also. 

 
 
 

The Left and Right Slope 
Stake Features have been 
annotated. 
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Figure L9-32 MicroStation View Window 

 
 

45.  Unselect All the Features in the Features-Annotate Folder. 
 

• In the Annotate Cross Section folder, ensure the Features folder and the 
Annotate sub folder are the active folders. 

• In the Features: field, right mouse click and choose Select None from the pop-up 
menu.   

 
46.  Select the Fill Slope Stake Features to Annotate. 

 
• Use the Locate button to select the Left and Right Fill Slope Stake Features 

identified in Figure L9-32. 
 

47.  Annotate the Fill Slope Stake Features. 
 

• In the Annotate Cross Section folder, ensure your selections match those shown 
in Figure L9-33. 

• Click Apply but do not close the Cross Sections dialog. 
• Verify your view in MicroStation matches that shown in Figure L9-34 and the 

Slope Stake Offset distances for the Fill Slopes were annotated. 
 

 
 

Left Slope Stake Feature Right Slope Stake Feature 
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Figure L9-33 Annotate Cross Section 

 

 
Figure L9-34 MicroStation View Window 
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48.  Unselect All the Features in the Features-Annotate Folder. 
 

• In the Annotate Cross Section folder, ensure the Features folder and the 
Annotate sub folder are the active folders. 

• In the Features: field, Right mouse click and choose Select None from the pop-
up menu.   

 
49.  Load the Preference ‘XSEC TEXT- SLOPES %’.  This Preference is setup for 

annotating the Slopes in percentage format for the Travel Lane and Shoulder Cross 
Slopes. 
 

• In the Annotate Cross Section folder, click the Preferences button.  The 
Preferences dialog opens. 

• Select the Preference XSEC TEXT – SLOPES %. 
• Click Load and Close. 

 
50.  The ‘XSEC TEXT – SLOPES %’ Preference enables the Segments for Labeling and 

Disables the Features and Points.  Make the Segments folder the active folder. 
 

• In the Annotate Cross Section folder, left click on the Segments folder.   
• In the Annotate Cross Section folder, left click on the General tab beneath the 

Segments folder. 
• Verify your view matches that shown in Figure L9-35. 
• Notice the Include Segments check box is checked and the Slope check box now 

contains an X. 
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Figure L9-35 Annotate Cross Section 

 
 
51.  Make the Segments / Annotate Folder the Active Folder. 

 
• Left click on Annotate under the Segments folder. 
• Right mouse click in the Crossing field and choose Select None from the pop-up 

menu. 
• Verify your view matches that shown in Figure L9-36. 
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Figure L9-36 Annotate Cross Section 

 
52.  Segments are Annotated by Selecting Features from the Crossing Field that Define 

the Beginning of the Segment and the End of the Segment you want to Annotate.  
Identify the Beginning of the Segment on the Left Side of the Roadway. 
 

• In the Annotate Cross Section folder, click the Locate button.   You are 
prompted in the bottom left of the MicroStation Window to >Select Feature. 

• Identify the beginning of the Segment by Left clicking on the Feature identified 
as LANE1 located between the shoulder pavement and the roadway pavement as 
shown here. 

 

            
             
 

• Left click a second time to accept.  You are returned to the Cross Sections dialog 
and the Feature SR100 SPUR-LANE1 has been selected. 

 

Crossing field 

LANE1 
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53.  Identify the Ending of the Segment on the Left Side of the Roadway and the 
Beginning of the Segment on the Right side of the Roadway. 
 

• In the Annotate Cross Section folder, click the Locate button again.   You are 
prompted in the bottom left of the MicroStation Window to >Select Feature. 

• Identify the end of the first Segment (which is also the beginning of the second 
Segment) by Left clicking on the Feature identified as PGL located at the center 
of the roadway as shown here. 

 

            
 

• Left click a second time to accept.  You are returned to the Cross Sections dialog 
and the Feature SR100 SPUR-PGL has also been selected.   

• Scroll through the Crossing field and ensure that both Features are selected. 
 

54.  Identify the Ending of the Segment on the Right Side of the Roadway. 
 

• In the Annotate Cross Section folder, click the Locate button again.   You are 
prompted in the bottom left of the MicroStation Window to >Select Feature. 

• Identify the end of the second Segment by Left clicking on the Feature identified 
as LANE located between the shoulder pavement and the roadway pavement as 
shown here. 

 

            
 

• Left click a second time to accept.  You are returned to the Cross Sections dialog 
and the Feature SR100 SPUR-LANE has also been selected. 

• Scroll through the Crossing field list to see that all three Features are selected as 
shown in Figure L9-37. 

• Click Apply but do not close the Cross Sections dialog. 
• Verify the roadway slopes were annotated as shown in Figure L9-38. 

 
 

PGL 

LANE 
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Figure L9-37 Annotate Cross Section 

 
 

 
Figure L9-38 MicroStation View Window 

 

The superelevation of the 
roadway was annotated 
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55.  Review Station 10+00.00 
 

• If not still open, open the Cross Section Viewer.  Select Evaluation ► Cross 
Section ► Cross Section Viewer. The Cross Section Viewer dialog opens. 

• Set the Zoom Factor: to 0.4000. 
• Highlight station 10+00.  
• Verify in MicroStation that Station 10+00 was centered in the MicroStation View 

Window as shown in Figure L9-39. 
• Notice the Roadway Cross Slopes have been annotated. 

 
 
 
 

 
Figure L9-39 MicroStation View Window 

 
 
 
 
56.  Load the Preference ‘XSEC TEXT- SLOPES x:y’.  This Preference is setup for 

annotating the Front Slopes and Back Slopes in a Ratio Format. 
 

• In the Annotate Cross Section folder, click the Preferences button.  The 
Preferences dialog opens. 

• Select the Preference XSEC TEXT – SLOPES x:y. 
• Click Load and Close. 
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57.  Unselect All the Features in the Segments-Annotate Folder. 
 

• In the Annotate Cross Section folder, ensure the Segments folder and the 
Annotate sub folder are the active folders. 

• In the Crossing field, Right mouse click and choose Select None from the pop-up 
menu.   

 
58.  Define the Beginning Point of the Back Slope Segment for the Left Side of the Cross 

Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the slope stake point by left clicking on the Feature identified below as 

CUT1. 
  

            
 
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-CUT1 selected. 

 
 

59.  Define the Ending Point of the Back Slope Segment for the Left Side of the Cross 
Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the outside ditch point by Left clicking on the Feature identified below as 

ODT1. 
 

            
 
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-ODT1 selected. 

 
 
 
 
 

CUT1 

ODT1 
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60.  Define the Beginning Point of the Front Slope Segment for the Left Side of the Cross 
Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the inside ditch point by Left clicking on the Feature identified below as 

IDT2. 
 

            
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-IDT2 selected. 

 
61.  Define the Ending Point of the Front Slope Segment for the Left Side of the Cross 

Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the edge of shoulder point by Left clicking on the Feature identified below 

as EOS1. 
 

             
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-EOS1 selected. 

 
62.  Define the Beginning Point of the Front Slope Segment for the Right Side of the 

Cross Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the edge of shoulder point by Left clicking on the Feature EOS. 

            
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-EOS selected. 
 

IDT2 

EOS1 

EOS 
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63.  Define the Ending Point of the Front Slope Segment for the Right Side of the Cross 
Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the inside ditch point by Left clicking on the Point identified as IDT. 

 

            
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-IDT selected. 

 
64.  Define the Beginning Point of the Back Slope Segment for the Right Side of the 

Cross Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the outside ditch point by Left clicking on the Point identified as ODT. 

 

            
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-ODT selected. 

 
65.  Define the Ending Point of the Back Slope Segment for the Right Side of the Cross 

Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the slope stake point by Left clicking on the Point identified as CUT. 

 

            
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-CUT selected. 

 
 

IDT 

ODT 

CUT 
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66.  Annotate the Front and Back Slopes. 
 

• In the Cross Sections dialog, verify the eight Features listed here were selected in 
the previous steps.  They should be highlighted in blue in the Cross Sections 
dialog as shown in Figure L9-40. 

 
 SR100 SPUR-CUT  SR100 SPUR-IDT 
 SR100 SPUR-CUT1  SR100 SPUR-IDT2 
 SR100 SPUR-EOS  SR100 SPUR-ODT 
 SR100 SPUR-EOS1  SR100 SPUR-ODT1 

 
• Click Apply but do not close the Cross Sections dialog. 
• Verify the Front and Back Slopes were annotated as shown in Figure L9-41. 

 
 
 
 
 

 
Figure L9-40 Annotate Cross Section 
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Figure L9-41 MicroStation View Window 

 
67.  Review Station 17+00.00. 

 
• If not still open, open the Cross Section Viewer.  Select Evaluation ► Cross 

Section ► Cross Section Viewer. The Cross Section Viewer dialog opens. 
• Set the Zoom Factor: to 0.4000. 
• Highlight station 17+00.  
• Verify in MicroStation that Station 17+00 was centered in the MicroStation View 

Window as shown in Figure L9-42. 
• Notice the Front Slopes at Station 17+00 have not been annotated.  This is 

because the Fill Slopes have different Feature Names than the Cut Slopes.   
 

*HINT: Careful consideration of the Point naming and use of the Feature Name 
Override during Component creation can help to minimize the number of steps 
required to annotate your Cross Sections. 
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Figure L9-42 MicroStation View Window 

 
68.  Unselect All the Features in the Segments-Annotate Folder. 

 
• In the Annotate Cross Section folder, ensure the Segments folder and the 

Annotate sub folder are the active folders. 
• In the Crossing field, Right mouse click and choose Select None from the pop-up 

menu.   
 

69.  Define the First Point of the Front Slope Segment for the Left Side of the Cross 
Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the slope stake point by Left clicking on the Feature identified below as 

FILL11. 
 

              
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-FILL11 selected. 

 

FILL11 
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70.  Define the Second Point of the Front Slope Segment for the Left Side of the Cross 
Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the shoulder break point by Left clicking on the Feature identified below as 

OS1. 
 
 

             
 
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-OS1 selected. 

 
71.  Define the First Point of the Front Slope Segment for the Right Side of the Cross 

Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the slope stake point by Left clicking on the Feature identified below as 

FILL1. 
 
 

               
 
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-FILL1 selected. 

 
 
 
 
 

OS1 

FILL1 
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72.  Define the Second Point of the Front Slope Segment for the Right Side of the Cross 
Section. 
 

• In the Annotate Cross Section folder, click the Locate button. 
• Select the shoulder break point by Left clicking on the Feature identified below as 

OS. 
 

              
 

• Left click again in the MicroStation Window to accept.  You are returned to the 
Cross Sections dialog with the Feature SR100 SPUR-OS selected. 

 
73.  Annotate the Front Slopes. 

 
• In the Cross Sections dialog, verify the four Features listed here were selected in 

the previous steps.  They should be highlighted in blue in the Cross Sections 
dialog as shown in Figure L9-43. 

 
 SR100 SPUR-FILL1 
 SR100 SPUR-FILL11 
 SR100 SPUR-OS 
 SR100 SPUR-OS1 

 
• Click Apply and click Close to exit the Cross Sections dialog. 
• If still open - click Close to exit the Cross Section Viewer dialog. 
• Verify the Front Slopes were annotated as shown in Figure L9-44. 

 
 
 

OS 



Introduction to InRoads - Design  InRoads SS2 – Lab 9 

   
 Lab9-53   

 
Figure L9-43 Annotate Cross Section 

 

 
Figure L9-44 MicroStation View Window 
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74.  Clear the MicroStation Window. 
 

• In MicroStation, select Edit ► Select All. 
• In MicroStation, click the Delete icon (  ). 

 
75.   

This concludes Lab 9.  Do not proceed until the Instructor directs you to 
do so. 
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Lab 10  
Construction Limits 

 
Objective 
 
The objective of this Lab is to learn how to view construction limits, roadway ditches and ditch 
flow arrows from the InRoads Finish Surface in MicroStation. The process to save this data in 
MicroStation as DGN Reference Files will also be demonstrated.   
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Lab 10A Set  Project Defaults and Open Files 
 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 



Introduction to InRoads - Design  InRoads SS2 – Lab 10 

   
 Lab10-3   

4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 scale project.  Enter 50 for the Text, Cell & Line Style Scale 

Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference. 

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 

7.  Open GDOT_Lab10.itl 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight GDOT_Lab10.itl 
• Click Open & Cancel. 

 
The Template Library GDOT_Lab10 is opened. 
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8.  Open 1234567_Lab10.ird 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight 1234567_Lab10.ird 
• Click Open & Cancel. 

 
The Roadway Design File 1234567_Lab10 is opened. 

9.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface Project 1234567_Exist is opened. 

10.  Open 1234567_SR100 SPUR_Lab10.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight 1234567_SR100 SPUR_Lab10.dtm  
• Click Open & Cancel. 

 
The Finish Surface 1234567_ SR100 SPUR_Lab10 is opened. 

11.  Open 1234567_Bogus1_Lab10.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight 1234567_Bogus1_Lab10.dtm  
• Click Open & Cancel. 

 
The Bogus Surface 1234567_Bogus1_Lab10 is opened. 
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Lab 10B View  Construction Limits and Create 1234567LIMT.dgn 
 
In order to view the Construction Limits, a ‘Final’ Surface must exist. The Final Surface is 
generated in the Roadway Designer from the Roadway Design file as was demonstrated in Lab 8 
and contains the Features representing the construction limits, ditches and ditch flow arrows.  In 
Lab 10B a Final Surface has been provided representing the SR100 SPUR and you will learn 
how to view the Features in the Surface representing the Construction Limits and the process to 
save the Construction Limits to the 1234567LIMT.dgn Reference File.  
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12.  Attach the 1234567MAIN.dgn Reference File. 
 
In order to view the Construction Centerline – the 1234567MAIN.dgn Reference File 
will be attached. 
 

• In MicroStation, select File ► References.  The References Window opens as 
shown in Figure L10-1. 

 
 
 

 
Figure L10-1 References Window 

 
 

13.  In the References Window – attach the File 1234567MAIN.dgn. 
 

• Select Tools ► Attach and the Attach Reference dialog opens.  
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight 1234567MAIN.dgn 
• Click Open. 
• The Reference Attachment Settings dialog opens as shown in Figure L10-2. 
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Figure L10-2   Reference Attachment Settings Dialog 

 
14.  Enter the Logical Name in the Reference Attachment Settings dialog. 

 
• In the Logical Name: field  -- enter the name: MAIN 
• Accept the rest of the Default Settings and click OK. 
• The 1234567MAIN.dgn Reference File is attached. 
• Close the References Window by clicking the Red (X) in the upper right corner 

of the dialog box. 
• In MicroStation, click the Fit View icon (      ) and the Reference File 

(1234567MAIN.dgn) will view as shown in Figure L10-3. 
 



Introduction to InRoads - Design  InRoads SS2 – Lab 10 
 

   
 Lab10-8   

 
Figure L10-3 MicroStation View Window 

 
 
 

15.  Open the View Features dialog and Select the Surface 1234567_SR100 
SPUR_Lab10. 
 

• In InRoads, select Surface ► View Surface ► Features…  The View Features 
dialog opens as shown in Figure L10-4. 

• Use the pull down arrow to select the Surface 1234567_SR100 SPUR_Lab10. 
• Ensure your view matches that shown in Figure L10-4. 

 



Introduction to InRoads - Design  InRoads SS2 – Lab 10 

   
 Lab10-9   

  
Figure L10-4 View Features 

 
16.  Clear the Feature Selection Field. 

 
• In the View Features dialog, Right mouse click in the Features: field.  A pop-up 

menu appears as shown in Figure L10-5. 
• Left click on Select None.  The View Features ‘Features:’ field now contains no 

selections as shown in Figure L10-6. 
 

 

   
Figure L10-5       View Features Figure L10-6     View Features 

Pop-up menu displays after 
Right mouse clicking the 
Features: field. 

Clicking on any of the column 
headings will organize the 
Features according to the heading 

Ensure the active surface 
is set to 1234567_SR100 
SPUR_Lab10. 



Introduction to InRoads - Design  InRoads SS2 – Lab 10 
 

   
 Lab10-10   

17.  Select the Features that represent the Construction Limits. 
 

• In the View Features dialog, click the Style column to organize the Features by 
Style. 

• In the View Features dialog, use the scroll bar to locate the Features 
LIMT_P_FILL_Const-Limit and LIMT_P_CUT_Const-Limit. 

• Select the Features with the Feature Style LIMT_P_FILL_Const-Limit and 
LIMT_P_CUT_Const-Limit by holding down the CTRL key on the keyboard 
and Left clicking each of the Features. 

• Ensure the Six Features with the Feature Styles LIMT_P_FILL_Const-Limit 
and LIMT_P_CUT_Const-Limit were selected as shown in Figure L10-7. 
 

 
 

 
Figure L10-7 View Features 

 
 

18.  View the Features that represent the Construction Limits. 
 

• In the View Features dialog, click Apply and click Close to exit the View 
Features dialog.   

• Verify the Features representing the Construction Limits have been drawn in 
MicroStation as shown in Figure L10-8. 
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Figure L10-8 MicroStation View Window 

 
19.  Detach the 1234567MAIN.dgn Reference File. 

 
The 1234567MAIN.dgn Reference File will be detached in order to create the DGN file 
for the Construction Limits. 
 

• In MicroStation, select File ► References.  The References Window opens as 
shown in Figure L10-9. 
 

 
 

 
Figure L10-9 References Window 
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20.  In the References Window – detach the File 1234567MAIN.dgn. 
 

• In MicroStation, select Tools ► Detach and an Alert dialog will appear.  
• Click the OK button in the Alert dialog. 
• The 1234567MAIN.dgn Reference File is detached. 
• Close the References Window by clicking the Red (X) in the upper right corner 

of the dialog box. 
• In MicroStation, click the Fit View icon (     ).   
• In MicroStation, verify that your view appears similar to Figure L10-10. 

 
 
 

 
Figure L10-10 MicroStation View Window 

 
 
 
21.  Save the Construction Limits DGN File (1234567LIMT.dgn). 

 
• In MicroStation, select File ► Save As. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10 
• In the File name:  field -- Enter the File name 1234567LIMT.dgn 
• Click Save.    

 
The MicroStation DGN File named 1234567LIMT.dgn is created and is made the current 
active DGN File. The DGN File has been saved in the 3D format. 
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Lab 10C View  Ditches & Ditch Flow Arrows and Create     
                   1234567DRNG.dgn 
 
In order to view the Ditches and Ditch Flow Arrows, a ‘Final’ Surface must exist. The Final 
Surface is generated in the Roadway Designer from the Roadway Design file as was 
demonstrated in Lab 8 and contains the Features representing the construction limits, ditches and 
ditch flow arrows.  In Lab 10C a Final Surface has been provided representing the SR100 SPUR 
and you will learn how to view the Features in the Surface representing the Ditches and Ditch 
Flow Arrows and the process to save the Ditches/Ditch Flow Arrows to the 1234567DRNG.dgn 
Reference File.  
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22.  Open the ‘GDOT 3D Working File.dgn”. 
 
In the Previous Lab 10B – the 1234567LIMT.dgn file was created and this became the 
active DGN file. In the following steps – the ‘GDOT 3D Working File.dgn” will need 
to be opened and made the active dgn file.  
 

• In MicroStation, select File ► Open and the Open dialog appears.  
• Navigate to C:\InRoads Data\1234567\Design Labs\Standards\ 
• Highlight GDOT 3D Working File.dgn 
• Click Open. 

 
Make Sure that the DGN file you are in is the correct file by looking at the MicroStation 
Title Bar: 
 

 
 

• In MicroStation, click the Fit View icon (       ).   
• In MicroStation, select Edit ► Select All. 
• In MicroStation, click the Delete icon (  ). 

 
 

The GDOT 3D Working File.dgn is cleared of Graphics and is ready for the next Lab. 
23.  Attach the 1234567MAIN.dgn Reference File. 

 
In order to view the Construction Centerline – the 1234567MAIN.dgn Reference File 
will be attached. 
 

• In MicroStation, select File ► References.  The References Window opens as 
shown in Figure L10-11. 

 
 

 
Figure L10-11 References Window 
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24.  In the References Window – attach the File 1234567MAIN.dgn. 
 

• Select Tools ► Attach and the Attach Reference dialog opens.  
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight 1234567MAIN.dgn 
• Click Open. 
• The Reference Attachment Settings dialog opens as shown in Figure L10-12. 

 
 
 

                                                                  
Figure L10-12  Reference Attachment Settings Dialog 
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25.  Enter the Logical Name in the Reference Attachment Settings dialog. 
 

• In the Logical Name: field  -- enter the name: MAIN 
• Accept the rest of the Default Settings and click OK. 
• The 1234567MAIN.dgn Reference File is attached.  
• In MicroStation, click the Fit View icon (      ) 
• DO NOT close the References Window. 

 
 

26.  In the References Window – attach the File 1234567LIMT.dgn. 
 

• Select Tools ► Attach and the Attach Reference dialog opens.  
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10\ 
• Highlight 1234567LIMT.dgn 
• Click Open. 
• The Reference Attachment Settings dialog opens. 

 
27.  Enter the Logical Name in the Reference Attachment Settings dialog. 

 
• In the Logical Name: field  -- enter the name: LIMT 
• Accept the rest of the Default Settings and click OK. 
• The 1234567LIMT.dgn Reference File is attached. 
• Close the References Window by clicking the Red (X) in the upper right corner 

of the dialog box. 
• In MicroStation, click the Fit View icon (      ) and the Reference Files 

(1234567MAIN.dgn) and (1234567LIMT.dgn) will view as shown in  
Figure L10-13. 
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Figure L10-13 MicroStation View Window 

 
 
28.  Open the View Features dialog and Select the Surface 1234567_SR100 

SPUR_Lab10. 
 

• In InRoads, select Surface ► View Surface ► Features…  The View Features 
dialog opens as shown in Figure L10-14. 

• Use the pull down arrow to select the Surface 1234567_SR100 SPUR_Lab10. 
• Ensure your view matches that shown in Figure L10-14. 
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Figure L10-14 View Features 

 
 
29.  Clear the Feature Selection Field. 

 
• In the View Features dialog, Right mouse click in the Features: field.  In the 

pop-up menu, Left click on Select None. 
 

30.  Select the Features Representing the Roadway Ditches. 
 

• In the View Features dialog, click the Style column to organize the features by 
style. 

• In the View Features dialog, use the scroll bar to locate the Features with the 
Feature Style DRNG_P_Ditch. 

• Select all the Features with the Feature Style DRNG_P_Ditch by holding down 
the CTRL key on the keyboard and Left clicking on each of the Features.  

• Ensure the Six Features with the Feature Style DRNG_P_Ditch were selected as 
shown Figure L10-15. 
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Figure L10-15 View Features 

 
 

31.  View the Features Representing the Roadway Ditches. 
 

• In the View Features dialog, click Apply and click Close to close the View 
Features dialog. 

• Verify the Features representing the Roadway Ditches were drawn in 
MicroStation as shown in Figure L10-16. 
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Figure L10-16 MicroStation View Window 

 
 

32.  Open the Annotate Feature dialog.  The Annotate Feature dialog is how Ditch Flow 
Arrows are Displayed on the Roadway Ditches. 
 

• In InRoads, select Surface ► View Surface ► Annotate Feature…  The 
Annotate Feature dialog opens as shown in Figure L10-17. 

 
 

33.  Set the Active Surface to ‘1234567_SR100 SPUR_Lab10’. 
 

• In the Annotate Feature dialog, use the pull down arrow and select the Surface 
1234567_SR100 SPUR_Lab10 from the list as shown in Figure L10-17. 
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Figure L10-17 Annotate Feature 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Use the pull down to select 
the Surface 
1234567_SR100 
SPUR_Lab10. 
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34.  Load the Preference ‘Ditch Flow Arrows’. 
 

• In the Annotate Feature dialog, click the Preferences button.  The Preferences 
dialog opens as shown below. 

 

              
 

• Select the Preference Ditch Flow Arrows as shown above. 
• Click Load and Close. 

 
35.  Review the Settings Loaded by ‘Ditch Flow Arrows’ Preference in the Previous 

Step. 
 

• Verify only the Slope Direction check box is checked as shown here. 
 

             
 

• In the Annotate Feature dialog, ensure the Slope Direction tab is the active tab. 
(Please be Patient – this tab may take a while to open). 

• Verify the Ditch Flow Arrow is the active cell as shown here. 
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36.  Even though the ‘Ditch Flow Arrow’ Preference was Loaded in the Previous Step, 
the Feature to Annotate must still be selected.  Select the Features with the Feature 
Style ‘DRNG_P_Ditch’ to annotate with the Ditch Flow Arrow Cell. 
 

• In the Annotate Feature dialog, ensure the Main tab is the active tab. 
• In the Annotate Feature dialog, organize the Features by Style by clicking the 

Style column heading. 
• Right mouse click in the Features: field.  In the pop-up menu, Left click on 

Select None. 
• Use the scroll bar to locate and select the Features with the Feature Style 

DRNG_P_Ditch. 
• Verify your entries match those shown in Figure L10-18 and that the Six Features 

with the Feature Style DRNG_P_Ditch were selected. 
• Ensure only the Slope Direction check box is checked as shown in  

Figure L10-18. 
 

 
 

 
Figure L10-18 Annotate Feature 

 

Ensure the Six Features with the 
Feature Style DRNG_P_Ditch 
are selected. 

Click Style to organize the 
Features by their Style. 
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37.  Annotate the Roadway Ditches with Ditch Flow Arrows. 
 

• In the Annotate Feature dialog, click Apply and Close. 
• In MicroStation, verify the Ditch Flow Arrows were drawn as shown in 

 Figure L10-19. 
 

 
 

 
Figure L10-19 MicroStation View Window 

 
 
 

38.  Detach the 1234567MAIN.dgn and 1234567LIMT.dgn Reference Files. 
 
The 1234567MAIN.dgn and 1234567LIMT.dgn Reference Files will be detached in 
order to create the DGN file for the Ditches and Ditch Flow Arrows. 
 

• In MicroStation, select File ► References.  The References Window opens as 
shown in Figure L10-20. 

 
 
 
 
 
 
 

Ditch Flow Arrows 



Introduction to InRoads - Design  InRoads SS2 – Lab 10 

   
 Lab10-25   

 
Figure L10-20 References Window 

 
 
39.  In the References Window – detach the File 1234567MAIN.dgn and 

1234567LIMT.dgn. 
 

• In the MicroStation References Window, select Tools ► Detach All and an 
Alert dialog will appear.  

• Click the OK button in the Alert dialog. 
• The 1234567MAIN.dgn and 1234567LIMT.dgn Reference Files are detached. 
• Close the References Window by clicking the Red (X) in the upper right corner 

of the dialog box. 
• In MicroStation, click the Fit View icon (     ).   
• In MicroStation, verify that your view appears similar to Figure L10-21. 
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Figure L10-21 MicroStation View Window 

 
 
 
40.  Save the Ditches and Ditch Flow Arrows DGN File (1234567DRNG.dgn). 

 
• In MicroStation, select File ► Save As. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 10 
• In the File name:  field -- Enter the File name 1234567DRNG.dgn 
• Click Save.    

 
The MicroStation DGN File named 1234567DRNG.dgn is created and is made the 
current active DGN File. The DGN File has been saved in the 3D format. 
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41.  Open the ‘GDOT 3D Working File.dgn”. 
 
In the previous steps – the 1234567DRNG.dgn file was created and this became the 
active DGN file. In the following steps – the ‘GDOT 3D Working File.dgn” will need 
to be opened and made the active dgn file.  
 

• In MicroStation, select File ► Open and the Open dialog appears.  
• Navigate to C:\InRoads Data\1234567\Design Labs\Standards\ 
• Highlight GDOT 3D Working File.dgn 
• Click Open. 

 
Make Sure that the DGN file you are in is the correct file by looking at the MicroStation 
Title Bar: 
 

 
 

• In MicroStation, click the Fit View icon (       ).   
• In MicroStation, select Edit ► Select All. 
• In MicroStation, click the Delete icon (  ). 

 
 

The GDOT 3D Working File.dgn is cleared of Graphics and is ready for the next Lab. 
42.   

 This concludes Lab 10.  Do not proceed until the Instructor directs you to 
do so. 
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Lab 11  
Earthwork 

 
Objective 
 
The objective of this Lab is to learn how to generate Earthwork Quantities and Earthwork 
Volume Reports from InRoads. 
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Lab 11A Set  Project Defaults and Open Files 
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window.   
 
Make Sure that the DGN file you are in is the correct file by looking at the MicroStation 
Title Bar: 
 

 
 

• In MicroStation, click the Fit View icon (      ).   
• In MicroStation, select Edit ► Select All. 
• In MicroStation, click the Delete icon (  ). 

 
The GDOT 3D Working File.dgn is cleared of Graphics and is ready for this Lab. 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 scale project.  Enter 50 for the Text, Cell & Line Style Scale 

Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference. 

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 11\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design.alg is opened. 

7.  Open GDOT_Lab11.itl 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 11\ 
• Highlight GDOT_Lab11.itl 
• Click Open & Cancel. 

 
The Template Library GDOT_Lab11 is opened. 
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8.  Open 1234567_Lab11.ird 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 11\ 
• Highlight 1234567_Lab11.ird 
• Click Open & Cancel. 

 
The Roadway Design File 1234567_Lab11 is opened. 

9.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 11\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface Project 1234567_Exist.dtm is opened. 

10.  Open 1234567_SR100 SPUR_Lab11.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 11\ 
• Highlight 1234567_SR100 SPUR_Lab11.dtm  
• Click Open & Cancel. 

  
The Finish Surface 1234567_ SR100 SPUR_Lab11 is opened. 

11.  Open 1234567_Bogus1_Lab11.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 11\ 
• Highlight 1234567_Bogus1_Lab11.dtm  
• Click Open & Cancel. 

 
The Bogus Surface 1234567_Bogus1_Lab11 is opened. 
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Lab 11B Generating Earthwork Reports:  End-Area Volumes 
 
InRoads computes Earthwork from the Cross Sections drawn in MicroStation. Before an 
Earthwork Volume Report can be generated in InRoads, a Cross Section Set must be drawn in 
MicroStation.  Lab11B will guide you through viewing Cross Section Sets in MicroStation 
through generation of the GDOT Earthwork Volumes Report. 
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12.  Important! Ensure that the “Fill” Attribute is turned on in MicroStation. 
 

• In MicroStation, select Settings ► View Attributes.  The View Attributes 
dialog opens. Ensure that the Fill Attribute is highlighted and selected. 

 
                                   The Fill Attribute should be highlighted as shown on 
                                   the left. 
 

• The Fill Attribute must be turned on in MicroStation in order for the Volumes to 
view the Cut/Fill areas in the appropriate Fill or Cut Shaded color. 

• Close the View Attributes dialog by clicking the Red (X) in the upper right 
corner of the dialog box. 

 
13.  Open the Cross Sections Dialog. 

 
• In InRoads, select Evaluation ► Cross Section ► Cross Sections.  The Cross 

Sections dialog opens as shown in Figure L11-1. 
 

 
 

 
Figure L11-1 Create Cross Section 
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14.  Open the Preferences Dialog and load ‘50 Scale Work Sec 2x Vert Exg’. 
 

• Ensure the Create Cross Section “folder” is highlighted/selected as 
depicted here:  

 
       NOTE: Depending on which folder is selected 
       (either “Create Cross Section, Annotate Cross  
       Section, Update Cross Section or End-Area  
       Volumes), the available Preferences will change. 
 
 
             
 

• In the Cross Sections dialog, click the Preferences button.  The Preferences 
dialog opens as shown here. 

 

       
 

• Highlight the Preference 50 Scale Work Sec 2x Vert Exg. 
• Click Load and Close.   

 
15.  For Information Only: 

 
The 50 Scale Work Sec 2x Vert Exg Preference as well as the 10 Scale Work Sec 1x 
Vert Exg Preference uses the built in InRoads grid for viewing the cross sections rather 
than the GDOT Cross Section plan sheet cell.  The InRoads grid is set up with fewer grid 
lines to help with the viewing of the cross sections in MicroStation during design.  The 
Preference 50 Scale Work Sec 2x Vert Exg is also setup with larger left and right offsets 
to ensure space is available to draw the entire cross section.  When viewing cross 
sections for generating Earthwork Reports, it is important that the entire cross section is 
drawn at each station as the Earthwork Volumes for end area reports are computed 
directly from the areas of the cross sections in the MicroStation drawings.  When high fill 
or cut slopes exceed the left and right offsets setup by the Preferences - the offsets must 
be increased manually in the Create Cross Section dialog or by manually extending the 
cut/fill lines to the existing ground. 
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16.  Select the Surfaces and View the Surfaces. 
 

• In the Cross Sections dialog, click the General tab to ensure it is the active tab.  
• Verify an X is present in the check boxes for each of the Surfaces: listed here. 

 
 1234567_Exist 
 1234567_SR100 SPUR_Lab11 
 1234567_Bogus1_Lab11 

 
• Verify your settings match those shown in Figure L11-2. 
• Click Apply.  
• Notice in the bottom left corner of the MicroStation Window you are prompted to 

>Identify Location, left click anywhere in the MicroStation Window. 
• The cross sections are drawn in MicroStation and the Cross Sections dialog re-

appears. 
• Do not close the Cross Sections dialog. 

 
 

 

 
Figure L11-2 Create Cross Section 

 

Ensure the check boxes 
for these 3 Surfaces 
contain an ‘X’. 
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17.  Open the Cross Section Viewer and Navigate to Station 10+00.00. 

 
• In InRoads, select Evaluation ► Cross Section ► Cross Section Viewer. 
• Left click on Station 10+00.00 to center Station 10+00.00 in the MicroStation 

View Window. 
• Verify your view in MicroStation matches that shown in Figure L11-3. 

 
 
 

 
Figure L11-3 MicroStation View Window 
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18.  Open the End-Area Volumes Folder in the Cross Sections dialog. 
 

• Ensure the End-Area Volumes “folder” is highlighted/selected as 
depicted here:  
 

       NOTE: Depending on which folder is selected 
       (either “Create Cross Section, Annotate Cross  
       Section, Update Cross Section or End-Area  
       Volumes), the available Preferences will change. 
 
 
 
 
 
 
 
 

 
• In the Cross Sections dialog, click the Preferences button. The Preferences 

dialog opens as shown here. 
 

           
 

• Highlight the Preference GDOT Earthwork Volumes. 
• Click Load and Close. 
• Verify your settings match those as shown in Figure L11-4. 
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Figure L11-4 End-Area Volumes 

 
19.  For Information Only: 

 
The GDOT Earthwork Volumes Preference loads settings into the Cross Sections dialog 
to generate a Volumes Report. The Preference does not load settings to apply cut/fill 
adjustment factors. The Designer is referred to the R.O.A.D.S. webpage for GDOT 
examples of manually applying cut/fill adjustment factors. 
 
 

20.  Generate and Review the Earthwork Volumes Report. 
 

• In the Cross Sections dialog, click Apply but do not click Close.  The Bentley 
Civil Report Browser opens. 

• In the Bentley Civil Report Browser, select the Style Sheet named GDOT 
Earthwork Volumes.xsl by Left clicking on it. 

• The GDOT Earthwork Volumes Report opens in the Bentley Civil Report 
Browser. 

• Verify your Report matches that shown in Figure L11-5. 
• Do not close the Report. 
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Figure L11-5 Bentley Civil Report Browser 

 
 

21.  Save the Earthwork Volumes Report in HTML Format. 
 

• In the Bentley Civil Report Browser, click FileSave As to save the .html file.  
• The Save As dialog box will appear as shown in Figure L11-6. 
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Figure L11-6 Save As 

 
 
22.  Save the Earthwork Volumes Report in HTML Format. 

 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 11\ 
• Enter the File name: as  1234567_SR100 SPUR_Lab11 
• Enter the Save as type:  as HTML File (*.html) 
• Click Save. 

 
 The  HTML File is saved to the following location:  
C:\InRoads Data\1234567\Design Labs\Lab 11\ 
 
The HTML File can also been printed as needed. 
 
Please Note: After the HTML file is created – the file information can also be opened by 
using Microsoft Office Excel to review the End-Area Volume information in a 
spreadsheet format. 
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23.  Set the Style Sheet ‘GDOT Earthwork Volumes.xsl’ to be the Default Style Sheet 
that opens whenever the End-Area Volumes command is processed. 
 

• In the Bentley Civil Report Browser, Right click over the Style Sheet GDOT 
Earthwork Volumes.xsl.  

• In the pop-up menu, Left click on Set as Default End Area Volume and ensure a 
check mark exists next to it as shown in Figure L11-7. 

• In the Bentley Civil Report Browser click File  Exit to close out of the Report 
Browser.  
 

 

 
Figure L11-7 Report Browser 

Ensure a check mark exists next 
to Set as Default End Area 
Volume. 
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24.  Verify the ‘GDOT Earthwork Volumes Report’ was set as the Default End Area 
Volume Report. 
 

• In the Cross Sections dialog, click Apply. 
• The Bentley Civil Report Browser opens and is defaulted to the GDOT 

Earthwork Volumes.xsl. 
• The GDOT Earthwork Volumes.xsl will now be the Default End Area Volume 

Report and will open whenever End Area Volumes are generated. 
 

25.  Information Only: 
 

• Brief Style Sheet Help Information is provided by Right clicking on the GDOT 
Earthwork Volumes.xsl Style Sheet Name and selecting Style Sheet Help.  

• Help information is provided as shown in Figure L11-8. 
• Close the Style Sheet Help dialog by clicking the Red (X) in the upper right 

corner of the dialog box. 
 

 
 

               
Figure L11-8 Style Sheet Help 
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26.  Close the GDOT Earthwork Volumes Report. 
 

• In the Bentley Civil Report Browser click File  Exit to close out of the Report 
Browser.  
 

27.  IMPORTANT: 
 

• The Cross Sections dialog should still be open.  Click Close – to close out of the 
Cross Sections dialog.  

• Click No if a Message appears asking if you want to save the modified parameter 
values. 

 
28.  Review Station 10+00.00 in MicroStation. 

 
• If not still open from previous steps, open the Cross Section Viewer dialog by 

selecting Evaluation ► Cross Section ► Cross Section Viewer. 
• Highlight Station 10+00.00. 
• Verify your view in MicroStation matches that shown in Figure L11-9. 
• Notice the cross section is filled in Green.  The End-Area Volumes command 

executed in previous steps shades all Cut sections Green.   
 

 
 

 
Figure L11-9 MicroStation View Window 
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29.  Review Station 13+50.00 in MicroStation. 
 

• In the Cross Section Viewer, highlight Station 13+50.00. 
• Verify your view in MicroStation matches that shown in Figure L11-10. 
• Notice the cross section is filled in Blue.  The End-Area Volumes command 

executed in previous steps shades all Fill sections Blue.   
 

 
 

 
Figure L11-10 MicroStation View Window 
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30.  Review Station 46+50.00 in MicroStation. 

 
• In the Cross Section Viewer, highlight Station 46+50.00. 
• Verify your view in MicroStation matches that shown in Figure L11-11. 
• Notice there is a Gap (that is not filled in with Cut) that exists in the cross section.   
• Read IMPORTANT! in the next step. 

 
31.  IMPORTANT! 

 
Even though ‘Target Aliasing’ was used in the Roadway Designer in Lab 8 to allow the 
Template to solve correctly, the Earthwork Volumes may only be computed between two 
Surfaces.  An example of this is an ‘Existing’ Surface and a ‘Design’ Surface.  The 
Surfaces 1234567_Exist.dtm and 1234567_Bogus1_Lab11.dtm have both been 
assigned the type ‘Existing’ in the Surface Properties dialog.  When obscured areas 
exist in the Existing Ground DTM, the proper course of action is to request additional 
survey for the obscured areas.  When temporary earthwork volumes are needed while 
waiting for additional survey information to arrive or in areas where lakes or marshy 
areas prevent additional survey from being collected -- the Designer may draw the 
missing Existing Surface and Design Surface in MicroStation for the temporary 
determination of earthwork volumes.  Doing so will provide the areas needed for InRoads 
to calculate the volumes.  It should be restated though that this method of resolving 
obscured areas is not survey quality and is only for the temporary evaluation of 
preliminary earthwork volumes. 
 

 

 
Figure L11-11 MicroStation View Window 

Red Square placed for Step 32. 
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32.  Zoom into the Cross Section. 
 

• In MicroStation, click the Window Area icon and window to the extents 
identified by the Red Square in Figure L11-11.  

• Verify your view in MicroStation matches that shown in Figure L11-12. 
 

33.  Delete the Green Fill Shape and Line representing the Bogus Ground at Station 
46+50.00. 
 

• In MicroStation, click the Delete icon ( ). 
• Left click on the Green Shape to select the Shape and then Left click again to 

delete the Shape as shown in Figure L11-12. 
• In MicroStation, click the Delete icon ( ) again. 
• Left click on the Pink Line to select the Line and then Left click again to delete 

the Line as shown in Figure L11-12. 
• Verify your view in MicroStation matches that shown in Figure L11-13. 

 
 

 
 

 
Figure L11-12 MicroStation View Window 

 
 

Delete the Pink line representing 
the Bogus Surface and the Green 
Fill Shape. 
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Figure L11-13 MicroStation View Window 

 
 

34.  Extend the Green Dashed Line Representing the Existing Ground. 
 

• In MicroStation, click the Modify element icon ( ). 
• Left click on the end of the Existing Ground (dashed green line). 
• The Existing Ground now dynamically follows the mouse as you move it across 

the screen. 
• Snap to the slope stake point at the end of the blue cut line.  If you do not snap to 

the end of the line the fill shape may not draw correctly. 
• Verify in MicroStation that your view matches that shown in Figure L11-14 and 

that the existing ground was drawn correctly. 
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Figure L11-14 MicroStation View Window 

 
 
 

35.  Open the Cross Sections Dialog. 
 

• In InRoads, select Evaluation ► Cross Section ► Cross Sections. 
 
 

36.  Load the Preference ‘GDOT Earthwork Volumes’. 
 

• In the Cross Sections dialog, click on the End-Area Volumes folder. (Make sure 
it is highlighted in Blue). 

• Next, click the Preferences button. 
• In the Preferences dialog, highlight the Preference GDOT Earthwork Volumes. 
• Click Load and Close. 

 
 

37.  Re-compute the End-Area Volumes. 
 

• In the Cross Sections dialog, click Apply. 
• The Bentley Civil Report Browser opens. 
• In the Bentley Civil Report Browser, click File  Exit to close out of the 

Report Browser.  
• Click Close to exit the Cross Sections dialog. 

 
 

Extend Existing Ground 
(green dashed line) to the 
end of the cut line (blue 
line). 
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38.  Review Station 46+50.00 in MicroStation. 
 

• If not still open, open the Cross Section Viewer by selecting Evaluation ► 
Cross Section ► Cross Section Viewer. 

• Highlight Station 46+50.00. 
• Verify your view in MicroStation matches that shown in Figure L11-15. 
• Notice the cross section is filled and no gap exists.  

 
 
 

 
Figure L11-15 MicroStation View Window 

 
 

39.  Review Station 47+00.00 in MicroStation. 
 

• In the Cross Section Viewer, highlight Station 47+00.00. 
• Verify your view in MicroStation matches that shown in Figure L11-16. 
• Notice the cross section contains a gap in the upper left corner.  
• Click Close to exit the Cross Section Viewer dialog. 
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Figure L11-16 MicroStation View Window 

 
 
40.  For Information Only: 

 
Even though Station 46+50.00 was revised in order to calculate earthwork volumes, the 
changes made don’t affect any of the other Stations with the same or similar situations.  
Each Station must be individually edited.  Those of you who are transitioning from 
CAiCE to InRoads are currently accustomed to CAiCE’s ability to extend the Existing 
Ground and cut or fill slope to intersect one another in order to generate preliminary 
earthwork and/or construction limits.  Unfortunately InRoads does not currently have 
this ability.  The Designer is reminded to make no edits to the Existing DTM provided by 
the Office of Design Policy and Support/Location Bureau.  All edits required to the 
Existing DTM are only to be made by the Survey Data Engineer (SDE). 
  

41.  Prepare MicroStation and InRoads for the Next lab. 
 

• In MicroStation, select Edit ► Select All. 
• In MicroStation, click the Delete icon ( ). 

 
42.                  

This concludes Lab 11.  Do not proceed until the Instructor directs you to 
do so. 
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Lab 12  
Required R/W 

 
Objective 
 
The objective of this Lab is to learn the process of storing Required R/W Parcels and generating 
Right of Way Tables. 
 
 
 
 
  



Introduction to InRoads - Design  InRoads SS2 – Lab 12 
 

   
 Lab12-2   

Lab 12A Set  Project Defaults and Open Files 
 
The objective of Lab 12A is to ensure that the proper settings are in place before attempting to 
store a Required Right of Way Alignment.  It is very important to remember that all Points a 
Designer stores must use the prefix ‘DE’ and start numbering at ‘10000’ (i.e. DE10000).  It is 
also very important that all Required Right of Way Alignments stored by a Designer uses the 
prefix ‘DE’.  The Required Right-of-Way Alignments may begin numbering at ‘1’ (i.e. DE1).  
Surveyors and/or SDE’s store Alignments using the prefix ‘SV’ (i.e. SV1).  The original field 
survey Points are imported into InRoads without prefixes and Surveyors/SDE’s store all 
additional Points with no prefixes. The Surveyor/SDE is instructed not to store Cogo Points 
beyond Point 9999.   The Surveyor/SDE has been instructed to contact the Designer when 
additional Points beyond 9999 are required.  The Designer then sets aside a range of Points for 
the Surveyor to use and which they (the Designer) will not use.  Failure by the Designer to 
follow the correct Point and Alignment naming convention may cause problems with Survey 
Enhancements during the life of the project and with Stakeout Report generation. 
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1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86).  
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 scale project.  Enter 50 for the Text, Cell & Line Style Scale 

Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference. 

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 12\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design.alg is opened. 

7.  Open GDOT_Lab12.itl 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 12\ 
• Highlight GDOT_Lab12.itl 
• Click Open & Cancel. 

 
The Template Library GDOT_Lab12 is opened. 
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8.  Open 1234567_Lab12.ird 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 12\ 
• Highlight 1234567_Lab12.ird 
• Click Open & Cancel. 

 
The Roadway Design File 1234567_Lab12 is opened. 

9.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 12\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface 1234567_Exist.dtm is opened. 

10.  Open 1234567_SR100 SPUR_Lab12.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 12\ 
• Highlight 1234567_SR100 SPUR_Lab12.dtm  
• Click Open & Cancel. 

 
The Finish Surface 1234567_ SR100 SPUR_Lab12 is opened. 

11.  Open 1234567_Bogus1_Lab12.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 12\ 
• Highlight 1234567_Bogus1_Lab12.dtm  
• Click Open & Cancel. 

 
The Bogus Surface 1234567_Bogus1_Lab12 is opened. 
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Lab 12B Getting Started 
 
This Lab will depict the process of attaching the following Reference Files with the appropriate 
Logical Name.     
 
 
 Filename   Logical Name 

• 1234567MAIN.dgn  MAIN 
• 1234567PROP.dgn  PROP 
• 1234567LIMT.dgn  LIMT 
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12.  Open the References Window. 
 

• In MicroStation, select File ► References.  The References Window opens. 
 

13.  Attach the 1234567MAIN.dgn as a Reference File. 
 

• In the References Window, select Tools ► Attach and the Attach Reference 
dialog opens. 

• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 12\ 
• In the Attach Reference dialog, select 1234567MAIN.dgn and click Open. 
• The Reference Attachment Settings dialog opens. 
• In this dialog, Key-in the Logical Name:  MAIN  
• Ensure Coincident - World is selected in the Orientation: field. 
• Verify your entries match those shown in Figure L12-1 and then click OK. 

 
 

                               
Figure L12-1    Reference Attachment Settings 
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14.  Using Step 13 as a Guide, Attach the Files 1234567PROP.dgn and 
1234567LIMT.dgn as Reference Files. 
 
 Filename   Logical Name 

• 1234567PROP.dgn  PROP 
• 1234567LIMT.dgn  LIMT 

 
• Close the References Window by clicking the Red (X) in the upper right corner 

of the dialog box. 
• In MicroStation, click the Fit View icon (       ). 
• Verify your view in MicroStation matches that shown in Figure L12-2.  

 
 
 

 
Figure L12-2   MicroStation View 
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Lab 12C Create a New Alignment for the Required R/W for SV47 
 
The objective of Lab 12C is to create a new Alignment for the Required Right-of-Way take from 
Property Alignment SV47. 
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15.  Open the New Dialog. 
 

• In InRoads, select File ► New.  The New dialog opens. 
• In the New dialog, make the Geometry tab the active tab. 
• Enter the following information: 

o Type:                      Horizontal Alignment 
o Name:                     DE5 
o Description:           REQD R/W – PAR 71 / SV47 
o Style:                       REQD_P_REQD 
o Curve Definition:  Arc 

• Verify your entries match those shown in Figure L12-3. 
• Click Apply & Close. 
• Verify Alignment DE5 is added to the InRoads workspace bar as shown here and 

is the Active Alignment (has a Red Square) as depicted below. 
 

                                                     
 

 

 
Figure L12-3   New 
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16.  InRoads does not have an Undo Button with most commands. In order to correct 
mistakes, it is necessary to exit your Geometry File without saving and then reopen.  
Save your work now so you can return to this point if you make a mistake. 
 

• In InRoads, select File ► Save ► Geometry Project. 
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Lab 12D Add the Required R/W to Alignment  DE5  
 
The primary objective of Lab12D is to become familiar with the Horizontal Alignment and Cogo 
Point tools useful in completing the creation of the Required R/W Alignment for DE5. The 
proposed R/W for DE5 is depicted in the inset below by a red outline. (DE5 is the empty 
Required R/W Alignment you created in Lab 12C). In this Lab, you will add the Required R/W 
to Alignment DE5. 
 
 

  
 
 
 
  

Required R/W 
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17.  Zoom to Property Alignment SV47 in MicroStation. 
 

• In MicroStation, select the Window Area icon (        ) and window area as shown 
outlined by a Red Square in Figure L12-4  

• Verify your view matches that shown in Figure L12-5. 
 

 
 
 

 
Figure L12-4   MicroStation View 

 

 
Figure L12-5   MicroStation View 

 

SV47 

SV47 
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18.  The Intersection Command Allows a Cogo Point to be Stored at the Intersection of 
two Alignments.  Open the Intersection Dialog. 
 

• In InRoads, select Geometry ► Locate ► Intersection.  The Intersection 
dialog opens as shown in Figure L12-6. 

 
 

 
Figure L12-6   Intersection 

 
Figure L12-7   Intersection   

 
19.  Change the Intersection ‘Type:’ from Direction/Direction to Alignment/Alignment. 

 
• In the Intersection dialog, use the pull-down arrow to select 

Alignment/Alignment as shown in Figure L12-7 above. 
 

20.  Define Alignment 1 to be DE31 (SR100 Spur). 
 

• In the Intersection dialog next to the Name:  field, click the Locate button ( ). 
• Notice in the lower left corner of the MicroStation window you are prompted to 

>Identify alignment. 
• Left click on Alignment DE31 shown in Figure L12-8.  It turns purple as shown 

in Figure 12-9. 
• Notice in the bottom left corner of the InRoads window and the bottom middle of 

the MicroStation window the phrase Selected Alignment ‘DE31’ appears. 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

>Accept/Reject.  Left click in the MicroStation window to Accept. 
• The Intersection dialog re-appears with DE31 entered in the Name:  field. 

 

Set Type to Alignment/Alignment. 
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Figure L12-8   MicroStation 

 
Figure L12-9   MicroStation 

 
21.  Define Alignment 1 to be offset 190’ to the Right. 

 
• In the Intersection dialog next to the Offset: field, key-in 190. 

 
*NOTE:  A positive value offsets to the right and a negative value offsets to the left. 
 
• Verify the Intersection dialog at this point matches Figure L12-10. 

 
 

 
Figure L12-10   Intersection 

Alignment DE31 
Selected Alignment 
turns purple 
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22.  Define Alignment 2 to be SV47. 
 

• In the Intersection dialog next to the Name:  field, click the Locate button ( ). 
• Notice in the lower left corner of the MicroStation window you are prompted to 

>Identify alignment. 
• Left click on Alignment SV47 in the area shown in Figure L12-11. 
• Notice in the bottom left corner of the InRoads window the phrase Selected 

Alignment ‘SV14’ appears. 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

>Accept/Reject.  Right mouse click in the MicroStation window to Reject. 
• Notice in the bottom left corner of the InRoads window the phrase Selected 

Alignment ‘SV47’ now appears and all of SV47 is highlighted in purple as 
shown in Figure L12-12.  

• Notice in the bottom left corner of the MicroStation window you are prompted to 
>Accept/Reject.  Left mouse click in the MicroStation window to Accept. 

• The Intersection dialog re-appears with SV47 entered in the Name: field. 
 
 

 
 
 

 
Figure L12-11  MicroStation 

 
Figure L12-12          MicroStation 

 
 
 
 
 

 
 
 
 

Select SV47 by Left 
clicking on the 
Alignment in the area 
shown here. 

When selected, SV47 
will highlight in 
purple. 
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23.  Store a COGO Point at the Intersection of DE31 offset 190’ and SV47. 
 

• In the Intersection dialog, verify your settings match those shown in  
Figure L12-13. 

• Click Apply.  The Locate Results dialog opens as shown in Figure L12-14 and 
the Point is tentatively marked by a purple X ( ) as shown in Figure L12-15. 

• In the Locate Results dialog, change the Style: to REQD_P_RWRM.  This style 
ensures a Required Right-of-Way Marker symbol (  ) is drawn. 

• Verify your entries in the Locate Results dialog match those shown in  
Figure L12-16. 

• Click Accept and then click Cancel.  The Intersection dialog reappears. 
• If a Results window appears – click Close to exit the Results window. 
• Next – click Close to exit the Intersection dialog. 
• Verify point DE10238 was drawn in MicroStation as shown in Figure L12-17. 

 
 

 
 
 

 
Figure L12-13   Intersection 

 
 
 
 

 
 
 
 
 
 
 
 

 
Figure L12-14   Locate Results 
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Figure L12-15 MicroStation View 

 
 

 
Figure L12-16   Locate Results 
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Figure L12-17  MicroStation View 

 
24.  Open the New Cogo Point Dialog. 

 
• In InRoads, select Geometry ► Cogo Points ► New.   The New Cogo Point 

dialog opens as shown in Figure L12-18. 
 

 
 

 
Figure L12-18  New Cogo Point 
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25.  Store a Cogo Point at Station 34+00 on Alignment DE31 Offset 160’ Right. 
 

• In the New Cogo Point dialog, use the pull down arrow to change the Define By: 
method to Station/Offset. 

• Match the remaining entries as shown in Figure L12-19. 
• Click Apply but do not close the New Cogo Point dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10243 was stored and drawn in MicroStation as shown in  

Figure L12-20. 
 
 

 
 
 

 
Figure L12-19 New Cogo Point 

 

*NOTE: When no point name is entered 
in the Name: field, InRoads assigns the 
next available point name based on the 
options loaded in the Options dialog. 
We defined these options in Step 5 of 
this lab.  Leave the field blank to see 
what happens. 
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Figure L12-20 MicroStation View 

 
 

26.  Store a Cogo Point at Station 33+00 on Alignment DE31 Offset 115’ Right. 
 

• In the New Cogo Point dialog, match the entries as shown in Figure L12-21. 
• Click Apply and Close the New Cogo Point dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10244 was stored and drawn in MicroStation as shown in  

Figure L12-22. 
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Figure L12-21 New Cogo Point 

 
 

 
Figure L12-22 MicroStation View 
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27.  Store a Point at the Intersection of SV47 and Alignment DE31 Offset 115’ Right. 
 

• In InRoads, select Geometry ► Locate ► Intersection.   
• Match the entries shown in Figure L12-23. 
• Click Apply.  The Locate Results dialog opens. 
• In the Locate Results dialog, select the Style:  REQD_P_RWRM. 
• Notice in MicroStation a purple X ( ) identifies the tentative location of the 

Point as shown in Figure L12-24.  The first tentative location is the wrong 
location. 

• In the Locate Results dialog, click Reject to select a new tentative location as 
shown in Figure L12-25. 

• The new location shown in Figure L12-25 is the correct location.   
• Click Accept to accept the location and store the Point.   
• If a Results window appears – click Close to exit the Results window. 
• Close the Intersection dialog. 
• Verify point DE10245 was stored and drawn in MicroStation as shown in  

Figure L12-26. 
 

 
 

 
Figure L12-23 Intersection 

 
 



Introduction to InRoads - Design  InRoads SS2 – Lab 12 
 

   
 Lab12-24   

 
Figure L12-24 MicroStation View 

 
 

 
Figure L12-25 MicroStation Window 

 

The first tentative 
intersection location appears 
here.  Click Reject in the 
Locate Results dialog to 
select a different tentative 
location. 

After rejecting the first solution, 
InRoads finds the next intersection 
solution if there is one.  In this case 
the new intersection is found to be 
here.  This location is correct. 
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Figure L12-26 MicroStation View 

 
 

28.  InRoads does not have an Undo Button with most commands. In order to correct 
mistakes, it is necessary to exit your Geometry File without saving and reopen.  Save 
your work now so you can return to this point if you make a mistake. 
 

• In InRoads, select File ► Save ► Geometry Project. 
 
 

29.  Store a Cogo Point at Station 12+00 on Alignment DE8 Offset 60’ Right. 
 

• In InRoads, select Geometry ► Cogo Points ► New. 
• In the New Cogo Point dialog, match the entries as shown in Figure L12-27. 
• Click Apply but do not close the New Cogo Point dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10246 was stored and drawn in MicroStation as shown in  

Figure L12-28. 
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Figure L12-27 New Cogo Point 

 
 
 

 
Figure L12-28 MicroStation View 
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30.  Store a Cogo Point at Station 34+50 on Alignment DE31 Offset 110’ Left. 
 

• In the New Cogo Point dialog, match the entries as shown in Figure L12-29. 
• Click Apply but do not close the New Cogo Point dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10247 was stored and drawn in MicroStation as shown in  

Figure L12-30. 
 

 
 
 

 
Figure L12-29 New Cogo Point 

 

*REMEMBER: A negative 
value offsets to the left and a 
positive value offsets to the right. 
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Figure L12-30 MicroStation View 

 
 

31.  Store a Cogo Point at Station 35+25 on Alignment DE31 Offset 100’ Left. 
 

• In the New Cogo Point dialog, match the entries as shown in Figure L12-31. 
• Click Apply and Close the New Cogo Point dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10248 was stored and drawn in MicroStation as shown in  

Figure L12-32. 
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Figure L12-31 New Cogo Point 

 
 

 
Figure L12-32 MicroStation View 
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32.  InRoads does not have an Undo Button with most commands. In order to correct 
mistakes, it is necessary to exit your Geometry File without saving and reopen.  Save 
your work now so you can return to this point if you make a mistake. 
 

• In InRoads, select File ► Save ► Geometry Project. 
 

33.  Store a Point at the Intersection of SV47 and Alignment DE31 Offset 100’ Left. 
 

• In InRoads, select Geometry ► Locate ► Intersection.   
• Match the entries shown in Figure L12-33. 
• Click Apply.  The Locate Results dialog opens. 
• Notice in MicroStation a purple X ( ) identifies the tentative location of the 

Point as shown in Figure L12-34.   
• In the Locate Results dialog, select the Style:  REQD_P_RWRM. 
• In the Locate Results dialog, click Accept to accept the location and store the 

Point.   
• The Locate Results dialog finds a second solution after storing the first solution.  

Click Reject. 
• Click Cancel to close the Locate Results dialog if it is still open. 
• Close the Intersection dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Verify Point DE10249 was stored and drawn in MicroStation as shown in  

Figure L12-35. 
 

 
Figure L12-33 Intersection 
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Figure L12-34 MicroStation View 

 
 

 
Figure L12-35 MicroStation View 
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34.  InRoads does not have an Undo Button with most commands. In order to correct 
mistakes, it is necessary to exit your Geometry File without saving and reopen.  Save 
your work now so you can return to this point if you make a mistake. 
 

• In InRoads, select File ► Save ► Geometry Project. 
 

35.  Store a Cogo Point at the PT of the Curve identified in Figure L12-36 on Alignment 
DE8 Offset 60’ Right. 
 

• In InRoads, select Geometry ► Cogo Points ► New. 
• In the New Cogo Point dialog, ensure Station/Offset is selected as the 

 Define By:  mode. 
• Select the Horizontal Alignment: DE8 from the pull down menu. 
• The Station: of the PT will be selected using the Locate button.  Press the Locate 

button to the right of the Station:, Offset:, and Elevation: fields. 
• Notice in the bottom right corner of the MicroStation window you are prompted 

to < Identify station. 
• Move your mouse around the MicroStation View and notice the dynamic line that 

jumps from one point to another along Alignment DE8.  Notice also as you do 
this that in the bottom middle of the MicroStation window the occupied Station is 
given. 

• Move your mouse so that the dynamic line is drawn from the PT identified in 
Figure L12-36 and Station 14+57.77 is listed in the bottom middle of the 
MicroStation Window. 

• While Station 14+57.77 is listed in the bottom middle of the MicroStation 
window, Left click to select this Station.  The New Cogo Point dialog returns 
with the Station 14+57.77 entered in the Station: field. 

   
*NOTE: Even though the Station is listed to only 2 decimal places, all the decimal  
places are retained in InRoads memory because of the manner in which we selected  
the Station. 
 
• In the Offset:  field key-in 60.00. 
• Notice the Elevation 1147.663 has been entered in the Elevation: field.  This 

value is obtained from the Active Vertical Alignment associated with the 
Horizontal Alignment. 

• In the Elevation: field, key-in 0.000   
 

*NOTE:  All 2D Points, which include Property Points such as those being stored 
here, should always be given a value of 0.000. 
 
• In the Style: field, select REQD_P_RWRM. 
• Verify your entries match those shown in Figure L12-37. Click Apply and Close. 
• If a Results window appears – click Close to exit the Results window. 
• Verify Point DE10250 was drawn in MicroStation as shown in Figure L12-38. 
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Figure L12-36 MicroStation View 

 
 

 
Figure L12-37 New Cogo Point 

 
 

Store a Point at the PT on this 
curve offset 60’ right. 
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Figure L12-38 MicroStation View 
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36.  At this Point we have stored 9 Cogo Points to define the Required R/W for Property 
Alignment SV47.  We will now add these Points to Alignment DE5 which was 
created earlier in the Lab.  In Lab 3 you were introduced to the Create/Edit 
Alignment by Cogo Points command to add Points to an Alignment.  In this Lab 
you will again use the Create/Edit Alignment by Cogo Points command.  Before 
using the command, ensure Alignment DE5 is the Active Alignment. 
 

• In the InRoads Workspace bar, ensure the Geometry tab is the active tab. 
• Right mouse click over Alignment DE5 and select Set Active as shown here. 

 

                        
 
 
 
 
 
 
 

• Ensure a Red Square now exists next to DE5 as shown here. 
 

                                                                       
 
 
 
 
 
 
 
 
 
 
 
 

Ensure a Red Square 
exists next to DE5 
indicating it is the Active 
Alignment. 
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37.  Before using the Create/Edit Alignment by Cogo Points command, it is also 
important to set the InRoads Lock setting to Point Snap. 
 

• In InRoads, select Tools ► Locks and ensure a check mark exists next to Point 
Snap as shown here.   

 

                                                                        
 
 

* REMEMBER: The Point Snap lock is an InRoads snap setting that snaps directly 
to InRoads stored Points such as the Cogo Points stored in the 
previous steps. 

 
 

38.  Open the Create/Edit Alignment by Cogo Points command. 
 

• In InRoads, select Geometry ► Utilities ► Create/Edit Alignment by Cogo 
Points.  The Create/Edit Alignment… dialog opens as shown in Figure L12-39. 

 

Ensure a check mark exists 
next to Point Snap. 
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Figure L12-39     Create/Edit Alignment by Cogo Points 

 
39.  Add Points DE10238, DE10243, DE10244, DE10245, 549, 550 and DE10250 to the 

Create/Edit Alignment by Cogo Points dialog. 
 

• In the Create/Edit Alignment… dialog, click the Start button. 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

> Identify Point. 
• Left click on Point DE10238 as shown in Figure L12-40. 
• Notice in the bottom middle of the MicroStation window and the bottom left 

corner of the InRoads window you are prompted: Point DE10238 selected. 
• Also, notice in the bottom left corner of the MicroStation window you are 

prompted > Identify Point. 
• Left click on Point DE10243 as shown in Figure L12-40. 
• Ensure the Point DE10243 selected is displayed in the bottom middle of the 

MicroStation window before selecting the next Point. 
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*NOTE: If at any time the wrong Point is selected, Right mouse click and you will 
be returned to the Create/Edit Alignment… dialog.  Click the Stop button and the 
selected Points will be returned to the Alignment Definition: field in the Create/Edit 
Alignment… dialog.  From here you can manually remove the incorrect Point.  Once 
the incorrect Point is removed - you can click the Start button and continue selecting 
Points in MicroStation. 
 
• Left click on Point DE10244. 
• Ensure Point DE10244 selected is displayed in the bottom middle of the 

MicroStation window before selecting the next Point. 
• Left click on Point DE10245. 
• Ensure Point DE10245 selected is displayed in the bottom middle of the 

MicroStation window before selecting the next Point. 
• Continue adding Points 549, 550 and DE10250 in the same manner. 
• Right mouse click to return to the Create/Edit Alignment… dialog. 
• In the Create/Edit Alignment… dialog, click the Stop button. 
• Ensure your Create/Edit Alignment by Cogo Points dialog matches that shown 

in Figure L12-41. 
 
 

 
 

 
Figure L12-40      MicroStation View 

DE10238 

550 

DE10245 

DE10244 

DE10243 

549 DE10250 
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Figure L12-41  Create/Edit Alignment by Cogo Points 

 
 

40.  The next step is to add a Curve between Points DE10250 and DE10246.   
 

• In the Create/Edit Alignment… dialog click Start. 
• Immediately Right mouse click over the MicroStation window to return to the 

Create/Edit Alignment… dialog. 
• Notice the remaining buttons in the dialog are now active. 
• Click Center Point Left. 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

< Identify circle left.  InRoads is requesting the Center Point of a Curve. 
• In MicroStation, change the snap setting from Keypoint to Center.  This may be 

accomplished by clicking the Snap icon ( ), located in the bottom middle of the 
MicroStation window and selecting Center. 

• Using the MicroStation snap procedure (typically a combination of the left/right 
mouse buttons or Tentative), snap onto the Curve identified in Figure L12-42. 
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• Notice in the bottom middle of the MicroStation window, the statement Point 
DE10075 selected.  DE10075 is the Center Point of the Curve. 

 
*NOTE: If an error is made, return to the Create/Edit Alignment… dialog by Right 

mouse clicking in the MicroStation window.  In the Create/Edit 
Alignment… dialog, click the Stop button to return the selections to the 
Alignment Definition: field.  At this point you can back out the incorrect 
Curve Data and try again.  Proper use of the Create/Edit Alignment… 
command requires practice. 

 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

> Identify Point.  Once the Center of the Curve was selected, InRoads 
immediately returned to requesting normal Points. 

• Left click on Point DE10246 identified in Figure L12-42. 
• Continue selecting Points DE10247, DE10248, DE10249 and DE10238, 

identified in Figure L12-42. 
• Right mouse click to return to the Create/Edit Alignment… dialog. 
• In the Create/Edit Alignment… dialog, click Stop to return the selections to the 

Alignment Definition: field. 
• Verify your entries match those shown in Figure L12-43. 
• Click Apply & Close. 
• Verify your view in MicroStation matches that shown in Figure L12-44 and the 

Required R/W Alignment DE5 was drawn. 
 
 

 
Figure L12-42 MicroStation View 

Use the MicroStation 
Snap Procedure to select 
the Center Point of this 
Curve. 

DE10246 

DE10247 

DE10248 

DE10249 

DE10238 
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Figure L12-43 Create/Edit Alignment by Cogo Points 

 
 

*NOTE: Notice the beginning Point and 
ending Point match.  This creates a closed 
Alignment.  Required R/W Alignments must 
be closed. 
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Figure L12-44 MicroStation View 

 
 

41.  This completes the Creation of Required R/W Alignment DE5.  Save your Work. 
 

• In InRoads, select File ► Save ► Geometry Project. 
 

 
  

Require R/W Alignment 
DE5.   



Introduction to InRoads - Design  InRoads SS2 – Lab 12 

   
 Lab12-43   

Lab 12E Create the 1234567REQD.dgn File 
 
When all the Required R/W Alignments for a Project have been created, they should be viewed 
in MicroStation and saved as a PI#REQD.dgn file per the Electronic Data Guidelines (i.e. 
1234567REQD.dgn). 
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42.  Prepare MicroStation. 
 

• In MicroStation, select Edit ► Select All. 
• Click the Delete icon ( ). 
• In MicroStation, select File ► References. 
• In the References dialog, select Tools ► Detach All. 
• If an Alert dialog box appears – click OK. 
• Close the References Window by clicking the Red (X) in the upper right corner 

of the dialog box. 
 
 

43.  Open the View Horizontal Annotation dialog. 
 

• In InRoads, select Geometry ► View Geometry ► Horizontal Annotation… 
and the View Horizontal Annotation dialog appears. 

 
 

44.  Load the ‘NO BEARING & DISTANCE Preference. 
 

• In the View Horizontal Annotation dialog, click the Preferences button. 
• In the Preferences dialog, highlight NO BEARING & DISTANCE. 
• Click Load and Close. 

 
 

45.  Select the Required R/W and Easement Alignments. 
 

• Place your cursor in the Horizontal Alignments Include: key-in field to activate 
the Filter button. 

• Click the Filter button. 
• In the Geometry Selection Filter dialog, click the Preferences button. 
• Select the REQD.dgn Alignments Preference and click Load and Close. 
• Verify the  Geometry Selection Filter dialog matches that shown in  

Figure L12-45. 
 

*NOTE: The REQD.dgn Alignments Preference filters the data so only the 
Alignments with the Feature Styles REQD_P_DWESMT, REQD_P_PESMT, 
REQD_P_REQD, and REQD_P_TESMT are included. 

 
• In the Geometry Selection Filter dialog, click the All button to move the 

Available: Alignments to the Selected: field. 
• In the Geometry Selection Filter dialog, click OK. 
• In the View Horizontal Annotation dialog, verify Alignment DE5 is showing in 

the Horizontal Alignments Selected: field as depicted in Figure L12-46. 
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Figure L12-45 Geometry Selection Filter 

 
 

 
Figure L12-46 View Horizontal Annotation 

 
 
 
 

The REQD.dgn Alignments filter loads the 
settings in the Style: field to Include only the 
Styles REQD_P_DWESMT, 
REQD_P_PESMT, REQD_P_REQD, and 
REQD_P_TESMT. 

DE5 should now be showing in 
the Selected: field. 
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46.  Select the Required R/W and Easement Points. 
 

• Place your cursor in the Cogo Points Include: key-in field to activate the Filter 
button. 

• Click the Filter button. 
• In the Geometry Selection Filter dialog, click the Preferences button. 
• Select the REQD.dgn Points Preference and click Load and Close. 
• Verify the Geometry Selection Filter dialog matches that shown in  

Figure L12-47. 
 

*NOTE: The REQD.dgn Points Preference filters the data so only the Points with 
the Feature Styles REQD_P_DWESMT, REQD_P_PESMT, REQD_P_REQD, 
REQD_P_TESMT and REQD_P_RWRM are included. 

 
• In the Geometry Selection Filter dialog, click the All button to move the 

Available:  Points to the Selected:  field. 
• In the Geometry Selection Filter dialog, click OK. 
• In the View Horizontal Annotation dialog, verify the Points DE10238, 

DE10243, DE10244, DE10245, DE10246, DE10247, DE10248, DE10249 and 
DE10250 are showing in the Cogo Points Selected: field as shown in 
 Figure L12-48. 

• Click Apply and Close. 
• In MicroStation, click the Fit View icon (       ). 
• Verify your view in MicroStation matches that shown in Figure L12-49. 

 
 

 
Figure L12-47 Geometry Selection Filter 
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Figure L12-48 View Horizontal Annotation 
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Figure L12-49 MicroStation View 

 
 

47.  Create the 1234567REQD.dgn File. 
 

• In MicroStation, select File ► Save As. 
• In the Save As dialog, navigate to  

C:\InRoads Data\1234567\Design Labs\Lab 12\  
• In the Save As dialog, key-in 1234567REQD.dgn as shown in Figure L12-50. 
• Change the Save as type: to MicroStation V8 DGN Files (*.dgn) as shown in 

Figure L12-50. 
• Click Save. 
• The 1234567REQD.dgn file is now created and ready for any cleanup that may 

be required. 
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Figure L12-50 Save As 

 
48.  The Required R/W Lines that are drawn on top of Existing R/W Lines are normally 

deleted from the MicroStation File.  Delete the Required R/W Lines that are drawn 
on top of existing R/W Lines. 

• In MicroStation, click the Drop Element icon ( ).    The Drop Element 
dialog should open. 

• Match the settings shown here in the Drop Element dialog. 
 

             
 

• In MicroStation, Left click on Alignment DE5 to drop complex. 
• Left click in the MicroStation window again to Accept the operation. 
• In MicroStation, click the Delete icon and delete the Lines identified as Line 1 

and Line 2 in Figure L12-51. 
• Ensure your view matches that shown in Figure L12-52. 
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Figure L12-51 MicroStation View 

 

 
Figure L12-52 MicroStation View 

 
  

Line 2 

Line 1 
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Lab 12F Create the R/W Table for REQ’D R/W Alignment DE5 
 
All Required R/W Alignments on a Project require a Table like the one shown below.  This Lab 
guides you through the creation of this Table in preparation for its placement in MicroStation. 
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49.  The R/W Tables are placed directly in the Right of Way Plan Sheets.  Open the 
MicroStation Right of Way Sheet File where the R/W Table is to be placed. 
 

• In MicroStation, select File ► Open. 
• Browse to C:\InRoads Data\1234567\Design Labs\Lab12\ 
• Highlight 1234567_60-003.dgn and click Open. 

• Ensure your view in MicroStation matches that shown in Figure L12-53. 
 

 
 

 

 
Figure L12-53 MicroStation View 

 
 
 
 
 
 
 
 
 
 
 
 
 

Notice the solid red 
lines from the 
Required R/W 
Alignment DE5 don’t 
obstruct the view of 
the existing R/W.  
This is because of the 
cleanup performed in 
Step 48. 
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50.  The GaDOT Legal Description is used to create the GDOT R/W Table.  It is the 
same as other XML Reports used in InRoads except that it is accessed differently 
than other XML Reports.  Open the GaDOT Legal Description Tool. 
 

• In InRoads, select Tools ► XML Reports ► Hold down the CTRL key on your 
key board while Left clicking Legal Description.  The GaDOT Legal 
Description dialog opens as shown in Figure L12-54. 

 
 
 

 
Figure L12-54 GaDOT Legal Description 
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51.  The Alignment: field is where the Required R/W Alignment is entered.  Enter the 
Required R/W Alignment DE5. 
 

• In the GaDOT Legal Description dialog, use the pull-down arrow next to 
Alignment:  to select DE5 as shown in Figure L12-55. 

 
 
 

 
Figure L12-55 GaDOT Legal Description 

 
 
 
 
 
 
 
 
 
 
 

The Required R/W Alignment is entered 
in the Alignment: field.  Ensure DE5 is 
shown here. 
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52.  The Reference Alignment: field is where the primary Centerline Alignment from 
which all Points in the Required R/W Alignment will be referenced.  Enter the 
Reference Alignment DE31 (SR 100 SPUR). 
 

• In the GaDOT Legal Description dialog, use the Locate button next to the 
Reference Alignments Include:  field to select DE31 as shown in Figure L12-
56. 

• Notice when this is done that all the Points in the Overrides: field change to refer 
to the Reference Alignment: DE31. 

 
 
 

  
Figure L12-56 GaDOT Legal Description 

 
 
 
 
 
 

 

The primary Centerline Alignment from 
which all Points in the Alignment: field 
are referred to is entered in the 
Reference Alignment: field.  Ensure 
DE31 is shown here. 

Notice all the Points in the Overrides: 
field now refers to the Reference 
Alignment: DE31. 
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53.  Many Right-of-Way Alignments are bound by two or more Roadways.  In such 
cases the Designer may choose to reference some Right-of-Way Alignment Points to 
different Roadway Centerline Alignments.  The GaDOT Legal Description dialog 
allows Points to be manually edited to reference different Roadway Alignments in 
the ‘Overrides:’ field.  Change Points 549, 550, DE10250 and DE10246 to reference 
the Centerline Alignment DE8 (Stoffel Rd.). 
 

• In the GaDOT Legal Description dialog, Left click on DE31 next to Point 549. 
• Notice the cell now contains a pull-down arrow as shown in Figure L12-57. 
• Use the pull-down arrow to select Alignment DE8 as shown in Figure L12-58. 
• Use the pull-down arrow to select Alignment DE8 for the Points 550, DE10250 

and DE10246. 
• Ensure your GaDOT Legal Description dialog matches that shown in  

Figure L12-59. 
 

 
 

 
Figure L12-57  GaDOT Legal Description 

 
 

 
Figure L12-58  GaDOT Legal Description 

 

A pull-down arrow 
will appear whenever a 
Reference Alignment 
is highlighted. 

Use the pull-down 
arrow to select DE8 as 
the Reference 
Alignment for Point 
549. 
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Figure L12-59 GaDOT Legal Description 

 
54.  Open the Bentley Civil Report Browser. 

 
• In the GaDOT Legal Description dialog, click Apply.  The Bentley Civil 

Report Browser opens as shown in Figure L12-60. 
 

 

 
Figure L12-60 Bentley InRoads Report Browser 
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55.  Create the R/W Table. 
 

• In the Bentley Civil Report Browser, highlight GDOT RW Table.xsl. 
• Verify your view matches that shown in Figure L12-61. 

 
 
 

 
Figure L12-61 Bentley Civil Report Browser 

 
 

56.  Before the R/W Table can be included in MicroStation it must be saved as a .TXT 
file.  Save the R/W Table as ‘DE5 R/W Table.txt’. 
 

• In the Bentley Civil Report Browser, select File ► Save As.  The Save As 
dialog opens. 

• Browse to C:\InRoads Data\1234567\Design Labs\Lab 12. 
• In the File name: field, key-in DE5 RW Table.txt.   
• Verify your Save As dialog matches that shown in Figure L12-62. 
• Click Save to create the text file DE5 RW Table.txt. 
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Figure L12-62 Save As 

 
 

57.  Close the Bentley Civil Report Browser and the GaDOT Legal Description Tool. 
 

• In the Bentley Civil Report Browser, select File ► Exit. 
• In the GaDOT Legal Description dialog, click Close. 

 
 

58.  For Information Only. 
 
A  MicroStation Macro has been developed for the proper placement of the R/W Table 
text file in MicroStation. The Macro is accessed via the GDOT Menu in MicroStation 
under the GDOT Tools menu. 
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Lab 12G Alternate Method of Storing REQ’D R/W Alignment 
 
In Lab 12G you will be shown an alternate method of storing the R/W Alignment shown below 
in Red.  The commands shown in this section of Lab 12 are useful on any type of Horizontal 
Alignment not just R/W Alignments. 
 
 

 
  

R/W Alignment to store. 
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59.  Open the MicroStation Working File. 
 

• In MicroStation, select File ► Open. 
• Browse to C:\InRoads Data\1234567\Design Labs\Standards. 
• Highlight GDOT 3D Working File.dgn. 
• Click Open. 
• Attach the Reference Files 1234567MAIN.dgn, 1234567LIMT.dgn and 

1234567PROP.dgn.  This may be accomplished in MicroStation by selecting 
File ► References and selecting Tools ► Attach from the References dialog.  
Remember to attach as Coincident World with the Logical Names of MAIN, 
LIMT, and PROP respectively. (NOTE: See Previous Step 13 in this Lab for 
Reference File Attachment instructions if needed). 

• When completed – Close the References dialog. 
• In MicroStation, click the Fit View icon. 
• Ensure your view in MicroStation matches that shown in Figure L12-63. 
• In MicroStation, Window Area the location identified by the Red Square in 

Figure L12-63. 
• Ensure your view matches that shown in Figure L12-64. 

 
 

 
 

 
Figure L12-63 MicroStation View 

 
 

Window Area to the extents 
identified here by the Red 
Square. 



Introduction to InRoads - Design  InRoads SS2 – Lab 12 
 

   
 Lab12-62   

 
Figure L12-64 MicroStation View 

 
 

60.  Store a Cogo Point at Sta. 15+20 offset 25’ Right of Pequanoc Drive Tie-in (DE3). 
 

• In InRoads, select Geometry ► Cogo Points ► New. 
• Match the entries shown in Figure L12-65. 
• Click Apply but do not close the New Cogo Point dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10251 was drawn in MicroStation as shown in Figure L12-66. 

 
 
 

Pequanoc Drive Centerline (DE3) 
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Figure L12-65    New Cogo Point 

 
 

 
Figure L12-66    MicroStation View 

 
 
 
 
 
 
 

DE10251 
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61.  Store a Cogo Point at Sta. 15+20 offset 50’ Right of Pequanoc Drive (DE3). 
 

• Match the entries shown in Figure L12-67. 
• Click Apply but do not close the New Cogo Point dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10252 was drawn in MicroStation as shown in Figure L12-68. 

 
 
 

 
Figure L12-67    New Cogo Point 
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Figure L12-68     MicroStation View 

 
 
 
62.  Store a Cogo Point at the PT located at Station 14+50.59 offset 50’ Right of 

Pequanoc Drive (DE3). 
 

• In InRoads, ensure Point Snap is the active Lock.  This may be accomplished by: 
o Selecting Tools ► Locks and ensure a check mark is showing next to 

Point Snap. 
• In the New Cogo Point dialog, click the Locate button next to the Station:, 

Offset: and Elevation: fields as shown here. 
 

            
 

• Notice a dynamic line ‘jumps’ along Alignment DE3 and in the bottom left 
corner of the MicroStation window you are prompted to > Identify Station. 

• Notice also in the bottom middle of the MicroStation window you are provided 
the Station and Offset information which changes as you move your cursor. 

• Move the cursor so that the dynamic line is shown extending from the PT at 
Station 14+50.59 and ‘Station 14+50.59 Offset 0.00’ is shown in the bottom 
middle of the MicroStation window. 

 
 

DE10252 

Click this Locate button. 
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• Left click in the MicroStation window.  The New Cogo Point dialog reappears 
and Station 14+50.59 is in the Station: entry field.  Selecting the Station for the 
PT in this way ensures the exact Station value has been captured and stored in 
memory even though only 2 decimal places are showing. 

• Notice the Elevation: has also been captured.  Since this is a Property Point, 
manually key-in 0.000 for the Elevation: . 

• In the Offset:  field, key-in 50.000. 
• Ensure your entries match those shown in Figure L12-69. 
• Click Apply and Close the New Cogo Point dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10253 was drawn in MicroStation as shown in Figure L12-70. 

 
 

 
 

 
Figure L12-69   New Cogo Point 
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Figure L12-70     MicroStation View 

 
 
63.  Store a Cogo Point at the Intersection of DE3 offset 50’ Right and the Property 

Alignment SV29. 
 

• In InRoads, select Geometry ► Locate ► Intersection. 
• Match the entries shown in Figure L12-71. 
• Click Apply. The Locate Results dialog opens. 
• Notice in MicroStation a purple X ( ) identifies the tentative location of the 

Point. 
• In the Locate Results dialog, select the Style:  REQD_P_RWRM. 
• In the Locate Results dialog, click Accept to accept the location and store the 

Point.   
• Close the Intersection dialog. 
• If a Results window appears – click Close to exit the Results window. 
• Ensure Point DE10254 was drawn in MicroStation as shown in Figure L12-72. 

 
 

 
 

SV10/
SV29 

DE3 

DE10253 
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Figure L12-71 Intersection 

 
 

 
Figure L12-72     MicroStation View 

 
 
 

 

DE10254 
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64.  Create a new Horizontal Alignment for the Required Right-of-Way take from SV29. 
 

• In InRoads, select File ► New.  
• Match the entries shown in Figure L12-73. 
• Click Apply and Close. 

 
 
 

 
Figure L12-73    New 

 
 
65.  Save your work. 

 
• In InRoads, select File ► Save ► Geometry Project. 

 
 

66.  The Commands you will use to Define Alignment DE105 place data directly into the 
Active Alignment.  Ensure Alignment DE105 is the Active Alignment. 
 

• In the InRoads Workspace bar, Right mouse click over Alignment DE105 and 
select Set Active.   

• DE105 should now have a Red Square next to it indicating it is the Active 
Alignment. 

 
 

REQD R/W – PAR 33 / SV29 
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67.  Create a Line from DE10251 to DE10252. 
 

• In InRoads, select Geometry ► Horizontal Element ► Add Fixed Line.  The 
Add Fixed Horizontal Line dialog opens as shown in Figure L12-74. 

• Place check marks in the check boxes for both Point 1 and Point 2. 
• Use the Locate button for Point 1 to select Point DE10251. 
• Use the Locate button for Point 2 to select Point DE10252. 
• Ensure your entries match those shown in Figure L12-75. 
• Click Apply. 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

> Accept/Reject.  Left click in the MicroStation window to Accept.   
• Do not close the Add Fixed Horizontal Line dialog. 
• Verify your view in MicroStation matches that shown in Figure L12-76 and the 

Line from DE10251 to DE10252 was drawn in MicroStation. 
 
 

 
 

 
Figure L12-74   Add Fixed Horizontal Line 

 
Figure L12-75   Add Fixed Horizontal Line 
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Figure L12-76   MicroStation View 

 
68.  Review Alignment DE105. 

 
• In InRoads, select Geometry ► Review Horizontal.  The Review Horizontal 

Alignment window opens as shown in Figure L12-77. 
• Notice the Line from Point DE10251 to DE10252 is already added to DE105. 
• Click Close to exit the Review Horizontal Alignment window. 

 
 
 

 
Figure L12-77 Review Horizontal Alignment 

 
 

Ensure the Line from 
DE10251 to DE10252 was 
placed. 
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69.  Create a Line from DE10252 to DE10253. 
 

• In the Add Fixed Horizontal Line dialog, use the Locate button for Point 1 to 
select DE10252. 

• In the Add Fixed Horizontal Line dialog, use the Locate button for Point 2 to 
select DE10253. 

• Verify your entries in the Add Fixed Horizontal Line dialog match those shown 
in Figure L12-78. 

• Click Apply. 
• Left click in the MicroStation window to Accept the operation. 
• Verify your view in MicroStation matches that shown in Figure L12-79 and the 

Line from DE10252 to DE10253 was drawn in MicroStation. 
• Do not close the Add Fixed Horizontal Line dialog. 

 
 
 

 
Figure L12-78 Add Fixed Horizontal Line 
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Figure L12-79 MicroStation View 

 
 
70.  Create a Line from 394 to DE10251. 

 
• In the Add Fixed Horizontal Line dialog, use the Locate button for Point 1 to 

select 394. 
• In the Add Fixed Horizontal Line dialog, use the Locate button for Point 2 to 

select DE10251. 
• Verify your entries in the Add Fixed Horizontal Line dialog match those shown 

in Figure L12-80. 
• Click Apply. 
• Left click in the MicroStation window to Accept the operation. 
• Verify your view in MicroStation matches that shown in Figure L12-81 and the 

Line from 394 to DE10251 was drawn in MicroStation. 
• Close the Add Fixed Horizontal Line dialog. 

 
 
 

Ensure the Line from 
DE10252 to DE10253 was 
placed. 
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Figure L12-80 Add Fixed Horizontal Line 

 
 

 
Figure L12-81 MicroStation View 

 
 
 
71.  Save your work. 

 
• In InRoads, select File ► Save ► Geometry Project. 

 

Ensure the Line from 394 to 
DE10251 was placed. 
It may be difficult to see 
because the Existing Property 
Alignment takes priority and is 
shown on top of Alignment 
DE105. 
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72.  Open the Add Fixed Horizontal Curve dialog in order to add a Curve to Alignment 
DE105.  
 

• In InRoads, select Geometry ► Horizontal Element ► Add Fixed Curve.  The 
Add Fixed Horizontal Curve dialog opens as shown in Figure L12-82. 
 

 

 
Figure L12-82  Add Fixed Horizontal Curve 

 
 
73.  Set the Mode. 

 
• In the Add Fixed Horizontal Curve dialog, use the pull-down arrow next to 

Mode: and ensure the Mode is set to By Two Points and Radius as shown here. 
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74.  Define Point 1 
 

• In the Add Fixed Horizontal Curve dialog, place a check in the check box for 
Point 1. 

• Use the Locate button for Point 1 to select Point DE10253 as shown here. 
 

             
 

75.  Define Point 2 
 

• In the Add Fixed Horizontal Curve dialog, place a check in the check box for 
Point 2. 

• Use the Locate button for Point 2 to select Point DE10254 as shown here. 
 

                     
 

76.  Define the Radius 
 

• In the Add Fixed Horizontal Curve dialog, click the Locate button next to the 
Radius:  entry field. 

• Notice in the bottom right corner of the MicroStation window you are prompted 
to > Identify first radius point. 

• Left click on Point DE10253. 
• Notice in the bottom right corner of the MicroStation window you are prompted 

to > Identify second radius point. 
• Change the MicroStation snap mode to Center by clicking the snap icon ( ) 

near the bottom center of the MicroStation window and selecting Center from the 
pop-up window. 

• Using the MicroStation snap procedure, tentative snap to the center of the Curve 
identified in Figure L12-83.   

• If snapped properly the message > Radius from ‘DE10253’ to ‘DE10044’: 
622.958 will appear in the bottom middle of the MicroStation window. 

• Left click in the MicroStation window to accept the tentative snap location and 
return to the Add Fixed Horizontal Curve dialog. 

• Ensure your entries match those shown in Figure L12-84. 
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• Click Apply. 
• Left click in the MicroStation window to Accept the operation. 
• Verify your view in MicroStation matches that shown in Figure L12-85 and the 

Curve from DE10253 to DE10254 was drawn in MicroStation. 
• Do not close the Add Fixed Horizontal Curve dialog. 

 
 

 
 
 

 
Figure L12-83 MicroStation View 

 
 

Snap to the center of this 
Curve to select the second 
Radius Point. 
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Figure L12-84 Add Fixed Horizontal Curve 
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Figure L12-85 MicroStation View 

 
 
77.  Add a Curve to Alignment DE105 from Point DE10254 to 394.  

 
• In the Add Fixed Horizontal Curve dialog, use the Locate buttons to select 

Point 1 and Point 2 as DE10254 and 394 respectively. 
• In the Add Fixed Horizontal Curve dialog, click the Locate button next to the 

Radius:  entry field. 
• Notice in the bottom right corner of the MicroStation window you are prompted 

to > Identify first radius point. 
• Left click on Point DE10254. 
• Notice in the bottom right corner of the MicroStation window you are prompted 

to > Identify second radius point. 
• Change the MicroStation snap mode to Center by clicking the snap icon ( ) 

near the bottom center of the MicroStation window and selecting Center from the 
pop-up window. 

• Using the MicroStation snap procedure, tentative snap to the center of the Curve 
identified in Figure L12-86.   

• If snapped properly the message > Radius from ‘DE10254’ to ‘DE10094’: 
495.871 will appear in the bottom middle of the MicroStation window. 

• Left click in the MicroStation window to accept the tentative snap location and 
return to the Add Fixed Horizontal Curve dialog. 

• Ensure your entries match those shown in Figure L12-87. 
 
 

• Click Apply. 

Ensure this Curve was added 
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• Left click in the MicroStation window to Accept the operation. 
• Verify your view in MicroStation matches that shown in Figure L12-88 and the 

Curve from DE10254 to 394 was drawn in MicroStation. 
• Close the Add Fixed Horizontal Curve dialog. 
 

 
 
 

 
 

 
Figure L12-86 MicroStation View 

 
 

Snap to the center of this 
Curve to select the second 
Radius Point. 
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Figure L12-87 Add Fixed Horizontal Curve 
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Figure L12-88 MicroStation View 

 
 
 
78.  Review Alignment DE105 

 
• In InRoads, select Geometry ► Review Horizontal.  The Review Horizontal 

Alignment window opens as shown in Figure L12-89. 
• Notice the Alignment appears correct in MicroStation but is not stored in a 

clockwise order.  It is stored DE10251, DE10252, DE10253, 394, DE10251, 
Curve, Curve. 
 

*NOTE: Many commands in InRoads allow Alignments to be pieced together in a 
non-coincident manner yet still view correctly in MicroStation.  In the case of 
Centerline Alignments and R/W Alignments the order of the Points and Curves must 
be in order and in a clockwise direction.  The Check Integrity command in InRoads 
can be used to properly order the elements in an Alignment. 

 
• Click Close to exit the Review Horizontal Annotation window. 

 
 

 
 

Ensure a curve from DE10254 
to 394 was drawn.  It may be 
difficult to see because the 
existing property alignment 
takes priority and is shown on 
top of alignment DE105. 
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Figure L12-89 Review Horizontal Alignment 
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79.  Open the Check Integrity dialog. 
 

• In InRoads, select Geometry ► Horizontal Element ► Check Integrity. 
• If an Alert dialog box appears, click OK. 
• The Check Horizontal Integrity window opens as shown in Figure L12-90. 
• Notice the Line highlighted in the Check Horizontal Integrity tool is also 

highlighted purple in MicroStation. 
• Click the Next button several times and notice as you do this the elements are not 

in order. 
 

 
 

 
Figure L12-90 Check Horizontal Integrity 

 
 
80.  Place the elements in Alignment DE105 in coincident and clockwise order beginning 

and ending at Point DE10251. 
 

• In the Check Horizontal Integrity dialog, highlight the third Linear element 
from the top as shown here. 

 

  
 

• Click the Move Forward button twice. 
• Verify the Elements are now in the order shown in Figure L12-91. 
• Notice the Integrity comments Non-coincident are no longer listed. 
• Click Apply and Close. 
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Figure L12-91 Check Horizontal Integrity 

 
 
81.  Review Alignment DE105. 

 
• In InRoads, select Geometry ► Review Horizontal.  The Review Horizontal 

Alignment report opens as shown in Figure L12-92. 
• Notice the Alignment now follows a coincident clockwise path. 
• Click Close to exit the Report. 
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Figure L12-92 Review Horizontal Alignment 
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82.  Prepare MicroStation for Design Lab 13. 
 

• In MicroStation, select Edit ► Select All. 
• Click the Delete icon ( ). 
• In MicroStation, select File ► References. 
• In the References dialog, select Tools ► Detach All. 
• If an Alert dialog box appears – click OK. 
• Close the References Window by clicking the Red (X) in the upper right corner 

of the dialog box. 
• In MicroStation, select File ► Compress ► Design 

 
83.                  

This concludes Lab 12.  Do not proceed until the Instructor directs you to 
do so. 
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Lab 13 
Survey Enhancements 

 
Objective 
 
The objective of this Lab is to learn how to include Survey Enhancements received during the 
Design Phase of a Project. 
 
Enhancements --- PI#_SDE.dtm 
When the Designer receives a new PI#_SDE.dtm from the SDE, the Designer will delete their 
PI#_Exist.dtm and replace it with this new one.  The Designer will then rename the 
PI#_SDE.dtm both externally and internally to PI#_Exist.dtm (as previously described in Lab 2).  
The steps outlined in this Lab will instruct the user how to do this.   
 
 
Enhancements --- PI#_SDE.alg 
When the Designer requests additional property or additional existing alignment enhancements 
that affect the InRoads .ALG file, the SDE will add or change the data in the original 
PI#_SDE.alg file that is kept by the Survey Office.  When changes are complete, the Designer 
will be notified and provided with a copy of the revised PI#_SDE.alg file.  The Designer will 
delete out all Survey Data from the PI#_Design.alg file they are working in and will import all 
Survey Data from the revised PI#_SDE.alg to the PI#_Design.alg they are working in, using the 
LandXML Translator.  The steps outlined in this Lab will instruct the user how to do this. 
 
 
 
 
 
 
 
  



Introduction to InRoads - Design  InRoads SS2 – Lab 13 
 

   
 Lab13-2   

Lab 13A Set  Project Defaults  
 

1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 scale project.  Enter 50 for the Text, Cell & Line Style Scale 

Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference. 
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Lab 13B Copy the Enhanced 1234567_SDE.dtm and Rename the File 
              Externally and Internally to 1234567_Exist.dtm 

 
In Lab13B, you will copy the Enhanced 1234567_SDE.dtm file from the Survey Data (SDE) 
folder to the proper InRoads Data folder for use in this Lab. The 1234567_Exist.dtm will then be 
deleted and replaced using the new Enhanced DTM.  The 1234567_SDE.dtm will be renamed 
both internally and externally to 1234567_Exist.dtm.   
 
Please Note:  A new Enhanced DTM may not always be provided to the Designer if no changes 
were made to the DTM by the SDE.  The SDE will only provide an Enhanced DTM if new 
Features have been surveyed and incorporated into the DTM. 
 

6.  Copy the Enhanced 1234567_SDE.dtm file. 
 

• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 13\SDE\.  The 
Enhanced 1234567_SDE.dtm and the 1234567_SDE.alg files (as well as any 
applicable Enhanced DGN Files) which are provided by Survey will be in this 
folder for use in the Lab. 
 

• Copy  the 1234567_SDE.dtm file 
 

            From: C:\InRoads Data\1234567\Design Labs\Lab 13\SDE 
            To:     C:\InRoads Data\1234567\Design Labs\Lab 13\ 
 

• Next – Delete the current 1234567_Exist.dtm file located in C:\InRoads 
Data\1234567\Design Labs\Lab 13\. 

 
7.  Change the External Project Name from 1234567_SDE to 1234567_Exist. 

 
In Windows Explorer -- Rename the file called 1234567_SDE.dtm which is located in 
C:\InRoads Data\1234567\Design Labs\Lab 13\ to the following: 
 
 1234567_Exist.dtm.   
 
This may be accomplished by Right mouse clicking over the file and selecting Rename. 
 
*NOTE: Although you have now renamed the file, it is only renamed Externally.  It must 
still be renamed internally to InRoads as will be demonstrated later.   
 

8.  Open the 1234567_Exist.dtm Surface. 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 13\ 
• Highlight 1234567_Exist.dtm 
• Click Open and Cancel. 
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9.  Make the InRoads Surface tab the active tab 
 

• In InRoads, Right mouse click  
over any of the tabs in the  
Workspace Bar and select  
Surfaces. 

• Verify your view matches that 
shown in Figure L13-1 and that 
the Surfaces tab is the active 
tab showing the Surface(s) listed.  
  
 
 
 
** NOTE: Even though you opened 1234567_Exist, 1234567_SDE is showing as 
the Active Surface.  Even though we changed the Name of the file externally, 
InRoads retains the Project Name internally and must also be changed internally to 
match. 

 
 
 

 
Figure L13-1 Main InRoads Window 

 
 
10.  Change the Internal Project Name from 1234567_SDE to 1234567_Exist. 

 
• Select Surface ► Rename Surface.  The Rename Surface dialog opens. 
• In the Rename Surface dialog, match the entries shown in Figure L13-2. 
• Click Apply. 
• Click Close to exit the Rename Surface dialog. 
• In the InRoads workspace bar verify that the Surface is now renamed 

1234567_Exist as shown in Figure L13-3. 
 
 

Workspace 
Bar 

Right mouse 
click over any 
of these tabs to 
easily switch 
to any of the 
other tabs. 
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Figure L13-2 Rename Surface 

 
 

 
Figure L13-3 Main InRoads Window 

 
 
11.  Save the InRoads Surface File 

 
Even though the Surface has been renamed – the data has not yet been saved.  InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Surface – Save the Project and its associated 
modifications or changes. 
 

• Select FileSave Surface from the InRoads Menu.   
 
 The Surface Project (1234567_Exist.dtm) will be saved to Lab 13 in the following path: 
C:\InRoads Data\1234567\Design Labs\Lab 13\ 
 
Note that the InRoads and MicroStation Status Bar (Located at the bottom of both the 
InRoads and MicroStation Interface) will depict a message when the Surface Project has 
been saved.  The Enhanced DTM has now been added to the InRoads Surface Project.            
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Lab 13C Copy the Enhanced 1234567_SDE.alg   
 

In Lab13C, you will copy the Enhanced 1234567_SDE.alg file from the Survey Data (SDE) 
folder to the proper InRoads Data folder for use in this Lab.     
 
Please Note:  A new Enhanced Survey ALG file may not always be provided to the Designer if 
no changes were made to the Property or Existing Alignment data by the SDE.  The SDE will 
only provide an Enhanced ALG if new data has been surveyed and incorporated into the ALG. 
 
12.  Copy the Enhanced 1234567_SDE.alg File. 

 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 13\SDE\.  The 

Enhanced 1234567_SDE.dtm and the 1234567_SDE.alg files (as well as any 
applicable Enhanced DGN Files) which are provided by Survey will be in this 
folder for use in this Lab. 
 

• Copy  the 1234567_SDE.alg File 
 

            From: C:\InRoads Data\1234567\Design Labs\Lab 13\SDE 
            To:     C:\InRoads Data\1234567\Design Labs\Lab 13\ 

 
13.  Open 1234567_Design.alg 

 
• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab13\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design is opened. 
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Lab 13D Delete All Alignments with an SV Prefix in the  
              1234567_Design.alg File 

 
In Lab13D, you will delete all Survey Alignments (i.e. those Alignments with an SV Prefix) in 
the 1234567_Design.alg file. This will remove all of the Survey Alignments from the database 
but all of the Design data will remain in the ALG file.  When the SDE stores Alignments, the 
Prefix of SV is always given.  The reason for this is so when Survey Enhancements must be 
performed during the design phase of a project - there is a method to get the Survey 
Enhancements into the Designer’s Project.  This method begins by deleting all Alignments with 
an SV Prefix in the Designer’s PI#_Design.alg file. 
 
14.  Make the InRoads Geometry tab the active tab 

 
In InRoads, ensure the Geometry tab is the active tab as shown here and that the file 
1234567_Design is listed and has a Red Square. A Red Square next to the project reflects 
that 1234567_Design is the active project. 

 

   
 

15.  In InRoads, select Geometry ►Delete Geometry and the Delete Geometry dialog 
opens as shown in Figure L13-4. 
 

 
 

                                   
Figure L13-4 Delete Geometry 

1234567_Design 
is the active 
project. 
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16.   
• In the Delete Geometry dialog, change the Type: to Horizontal Alignment. 
• In the Geometry Project: pull down – select 1234567_Design    
• Select all the Alignments (highlight in blue) that have an SV prefix. 

   
     *HINT: This may be accomplished by Left clicking on the first Alignment with an 

SV prefix to highlight it in blue and then scrolling to the last Alignment with 
an SV prefix and holding down the Shift key while Left clicking the 
Alignment with the mouse.  All the Alignments between the first and last SV 
Alignment should now be highlighted in blue indicating they are selected. 

 
     **WARNING:  Be careful not to select any of your Design Alignments (i.e. those 

Alignments that begin with the DE prefix). 
 

17.   
• Verify the settings in the Delete Geometry dialog match those shown in 

 Figure L13-5. 
• Click Apply.  
• An Alert dialog prompting whether or not you want to Delete Alignments will be 

displayed.  Click Yes to delete the Alignments. 
• Click Close to close the Delete Geometry dialog. 

 
 
 

 
Figure L13-5 Delete Geometry 
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Lab 13E Delete All Points without a Prefix in 1234567_Design.alg  
 
In Lab13E, you will delete all Survey Cogo Points (i.e. those Cogo Points without a Prefix).  
When the SDE stores Cogo Points or includes Cogo Points from the Data Collector, no Prefix is 
applied to them.  The reason for this is when Survey Enhancements must be performed during 
the design phase of a project; there is a method to get the Survey Enhancements into the 
Designer’s project.  This method includes deleting all Cogo Points without a Prefix in the 
Designer’s PI#_Design.alg file. 
 
18.  Select Geometry ► Cogo Points ► Delete and the Delete Cogo Point dialog opens as 

shown in Figure L13-6. 
 

 
 

                                       
Figure L13-6 Delete Cogo Point 

 
19.  In the Delete Cogo Point dialog, click the Filter button.  The Geometry Selection Filter 

dialog opens. 
 

20.  • Select (highlight in blue) all the Points that do not contain a Prefix. 
 
   *HINT: This may be accomplished by Left clicking on the first Point without a Prefix 

to highlight it in blue and then scrolling to the last Point without a Prefix and 
holding down the Shift key while Left clicking the Point with the mouse.  All 
the Points between the first and last should now be highlighted in blue 
indicating they are selected. 

 
     **WARNING:  Be careful not to select any of your Design Points (i.e. those Points 

that begin with the DE Prefix). 
 

• Verify the Geometry Selection Filter dialog matches that shown in  
Figure L13-7. 
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Figure L13-7 Geometry Selection Filter 

 
21.  • In the Geometry Selection Filter dialog, click the Add -> button.  This will 

move the highlighted Points from the Available: field to the Selected: field. 
 

• Click OK.  The selected Points are populated in the Delete Cogo Point dialog as 
shown in Figure L13-8. 

 
 

 
Figure L13-8 Delete Cogo Point 

 
22.  • Click Apply.  

• An Alert dialog will appear prompting whether or not you want to delete the data.  
Click Yes to delete the Points. 

• Click Close to exit the Results Report if one opens. 
• Click Close to exit the Delete Cogo Point dialog. 
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Lab 13F Export Survey Data from 1234567_SDE.alg using LandXML 
 
At this point you have deleted all the Survey Data (Survey Points and Survey Alignments) in the 
1234567_Design.alg.  In Lab13F you will open the new 1234567_SDE.alg and export all the 
Survey Data to an .XML file using the LandXML Translator. The Survey Data will then be 
imported into your 1234567_Design.alg file. 
 
     **WARNING:  Be careful and always ensure that you are in the correct ALG file before 

importing and/or exporting data during this process.  
 
 
23.  Open 1234567_SDE.alg 

 
• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab13\ 
• Highlight 1234567_SDE.alg 
• Click Open & Cancel. 

 
24.   In InRoads, ensure the Geometry tab is the active tab as shown here and that the file 

1234567_SDE is the active project (has a Red Square next to it). A Red Square next to 
the project reflects that 1234567_SDE is the active project. 
 

  
 
 

25.  Select File ► Translators ► LandXML Translator and the LandXML dialog opens 
as shown in Figure L13-9.    
 

 
 
 
 
 

Ensure 1234567_SDE 
is the active project. 
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Figure L13-9 LandXML 

 
 
26.  Make the Export Alignment tab the active tab. 

 
• Click on the Export Alignment tab. 
• In the Geometry Project: pull down – select 1234567_SDE. 
• Place a check mark in the Include All Cogo Points check box. 
• Place your cursor in the Include: field to activate the Filter button.   
• Click the Filter button and the Geometry Selection Filter dialog opens. 
• In the Geometry Selection Filter dialog, click the All button to move all the 

Survey Alignments from the Available: field to the Selected: field. 
• Click OK.   
• In the Linear Units: pull down – select US Feet. 
• In the State: pull down – select existing. 
• The selected Alignments are populated in the LandXML dialog as shown in 

Figure L13-10. Ensure your inputs match the screen capture below. 
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Figure L13-10 LandXML 

 
 
27.  • Click the Save As button.  An Alert dialog box may appear which informs you 

that “One or more of the selected Alignments has an integrity issue” as shown 
below. A Results Report listing the Alignments may also appear. 
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28.  Save the XML File. 
 

• Click Yes in the Alert dialog to continue. The Export dialog opens. 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab13\ 
• In the File name: field – enter NEW SURVEY.xml. 
• Click the Save button. 
• Click Close to exit the LandXML dialog.  
• Click Close to exit the Results Report if it is still open. 
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Lab 13G Import Survey Data into 1234567_Design.alg using LandXML 

 
At this point you have created an XML file that contains all the Survey information (Survey 
Alignments and Survey Cogo Points) for the Project from the 1234567_SDE.alg file provided by 
the Survey Office.  The remaining Steps will be to import the XML file into the Designer’s 
1234567_Design.alg file. 
 
     **WARNING:  Be careful and always ensure that you are in the correct ALG file before 

importing and/or exporting data during this process.  
 
 
29.   In InRoads, ensure the Geometry tab is the active tab as shown here and that the file 

1234567_Design is the active project (has a Red Square next to it). To make 
1234567_Design the active project – Right mouse click and select Set Active. A Red 
Square next to the Project reflects that 1234567_Design is the active project. 
 

 
 
 

30.  Select File ► Translators ► LandXML Translator and the LandXML dialog opens 
as shown in Figure L13-11.    
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Ensure 
1234567_Design is the 
active project. 
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Figure L13-11 LandXML 

 
 
31.  Make the Import tab the active tab. 

 
• Click on the Import tab. 

 
In the Geometry Frame – input in the following: 

• In the Duplicate Geometry: radio button – select Replace. 
• Leave all other entries as Default. 
• Click the Browse button and navigate to  

C:\InRoads Data\1234567\Design Labs\Lab 13. 
• Select the File ‘NEW SURVEY.xml’ and click Open. 
• Verify your entries match those shown in Figure L13-12. 
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Figure L13-12  LandXML 

 
 
 
 
 
 
32.  Click Apply and Close to exit the LandXML dialog.  Importing of the Survey Data into 

the 1234567_Design.alg file is now complete. 
 

33.  Save the InRoads 1234567_Design.alg File 
 
Even though the Enhanced Survey Data has been imported – the data has not yet been 
saved.   

• Select FileSave Geometry Project from the InRoads Menu.   
 
The Geometry Project (1234567_Design.alg) will be saved to Lab 13 in the following 
path: 
 
C:\InRoads Data\1234567\Design Labs\Lab 13 
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34.  Delete the 1234567_SDE.alg File 
 
In Windows Explorer – delete the 1234567_SDE.alg file currently located in  
C:\InRoads Data\1234567\Design Labs\Lab 13\   
   
*NOTE: Make sure that you retain a backup copy of this Enhanced 1234567_SDE. alg 
file on the Server.  
 

35.  For Information Only: 
 
The Enhanced Survey Data (both the DTM and Property/Existing Alignment Information) 
have been added to the 1234567_Design.alg File.  
 

• The Enhanced Existing DTM contains all of the Surface Points, Breaklines and 
Features along with the triangulated data. 

 
• The Enhanced Property/Existing Alignment information contains all of the SV 

Prefix Alignments and the Survey Cogo Points. 
 

36.                    
                 This concludes Lab 13  Do not proceed until the Instructor directs you to do 
                  so. 
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Lab 14  
InRoads Style Sheets 

 
Objective 
 
Style sheets are used by InRoads to present data in a particular format.  The purpose of this lab is 
to introduce InRoads style sheets to the designer by generating 2 of the Style Sheet reports 
required in the GDOT Designers Checklist for Plans Submittal to the Office of Construction 
Bidding Administration.  The GDOT Alignment Report and End-Area Report-Standard are 
required deliverables in electronic format to the Office of Construction Bidding Administration 
when submitting final plans.  Listed here are 22 GDOT customized style sheets which are 
available by downloading and running the InRoadsALL.exe from the R.O.A.D.S webpage. 
 
  

• GDOT 3D Alignment Comparison 
Report 

• GDOT Alignment File Descriptions 
• GDOT Alignment Points List 
• GDOT Alignment Report 
• GDOT Deed 
• GDOT Earthwork Volumes Report 
• GDOT End-Area Report-Compressed 
• GDOT End-Area Report-Standard 
• GDOT Feature Lengths Report 
• GDOT Feature Volumes Report 
• GDOT Feature-StationElevationOffset 

Report 
 

• GDOT GPS Grading Report 
• GDOT HEC RAS Bridge Features 

Report 
• GDOT HEC RAS Cross Section 

Geometry Report 
• GDOT Intersecting Alignments Stations 
• GDOT Ponding Report 
• GDOT RW Table 
• GDOT Stakeout Report 
• GDOT Station-Offset Report 
• GDOT Superelevation Data Report 
• GDOT Surface Check Report 
• GDOT Vertical Clearance Report 

 
The InRoadsALL.exe places the Style Sheets listed above in the following location: 
 

C:\InRoads Data\Style Sheets\GDOT\ 
 

The InRoadsALL.exe places Style Sheet help files for the Style Sheets listed above in the 
following location: 
 

C:\InRoads Data\Style Sheet Documentation\ 
 
In addition to the 22 GDOT customized Style Sheets listed above, InRoads includes numerous 
Style Sheets in the C:\InRoads Data\Style Sheets\ folder. 
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Lab 14A Set  Project Defaults and Open Files 
 
The objective of Lab 14A is to ensure that the proper settings are in place and open the files 
necessary for demonstrating the use of the Style Sheets. 
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1.  Starting Clean  
 
In order to ensure that you are working with a “clean” database – you will close 
MicroStation and InRoads if they are still running from a previous Lab: 
 
To CLOSE MicroStation and InRoads -  
 
Select FileExit from the [MicroStation Menu]. 
If any messages appear regarding the saving of projects – Select  
 
This closes BOTH the MicroStation and InRoads Software(s).    

2.  Starting MicroStation and InRoads in the GDOT Workspace. 
 
From the desktop, double-click on the MicroStation icon labeled GDOT MicroStation 
V8i SS2 (x86). 
 
 
 
 
 
 
 

• When the MicroStation Manager dialog box appears – navigate to the 
C:\InRoads Data\1234567\Design Labs\Standards folder and select the 
“GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working File.dgn’ 
is documented in the Design Guidelines).  Click Open.   

 
• Now open InRoads from within MicroStation by selecting:  

InRoads  InRoads Suite (SELECTseries 2) V8i 08.11.07.566 from the 
[MicroStation Menu]. 

 
The MicroStation and InRoads Software(s) will open. 

3.  Clear the MicroStation Window (This step may be ignored if your MicroStation 
Window is already clear of graphics) 
 

• Select Edit ►Select All from the [MicroStation Menu]. 
• Then select the <DELETE> key on the computer keyboard. 

 
The MicroStation Window is now clear of all graphics from the previous lab and ready 
for this lab. 

 
  

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86). 
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4.  Verify Project Defaults 
 

• In InRoads, select File ►Project Defaults 
• Use the pull down next to Configuration Name: to select 1234567_Design 

which you created in Lab 1. 
• Click Apply & Close. 

 
Sets Project Defaults. 

5.  Set the Design Default Preferences 
 

• Select File ► Project Options and the Project Options dialog box appears. 
• Select the Factors tab. 
• This will be a 50 scale project.  Enter 50 for the Text, Cell & Line Style Scale 

Factor(s). 
• Then in the same Project Options dialog box select the Geometry tab. 
• Click the Preferences button at the bottom of the dialog box. 
• Choose Design Default.  Click Load and Close.  This will set the remainder of 

the Design Defaults. 
**IMPORTANT:  As stated previously the Design Default Preference loads 
the appropriate settings for use during Design. These settings include the 
Alignment and Point name settings.  These settings are of particular 
importance to the Designer.  Alignments must have a DE prefix.  Points must 
also have a DE prefix as well as beginning the point numbering scheme at 
Number 10000.  In order for survey enhancements to be properly added 
during the design phase of a project, it is essential that Designers pay 
particular attention to this setting.  

• In the Project Options dialog box click Apply and Close. 
 
Sets the Design Default Preference. 

6.  Open 1234567_Design.alg 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 14\ 
• Highlight 1234567_Design.alg 
• Click Open & Cancel. 

 
The Geometry Project 1234567_Design.alg is opened. 

7.  Open 1234567_Exist.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 14\ 
• Highlight 1234567_Exist.dtm 
• Click Open & Cancel. 

 
The Surface 1234567_Exist.dtm is opened. 
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8.  Open 1234567_SR100 SPUR_Lab14.dtm 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\Design Labs\Lab 14\ 
• Highlight 1234567_SR100 SPUR_Lab14.dtm  
• Click Open & Cancel. 

 
The Finish Surface 1234567_ SR100 SPUR_Lab14 is opened. 
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Lab 14B GDOT Alignment Report 
 
This Lab will depict the process to create a GDOT Alignment Report.  The GDOT Alignment 
Report is a required deliverable with the Final Plans submittal package and must include 
information on all centerline alignments in the projects ALG database. 
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9.  Open the Geometry Report dialog. 
 

• In InRoads, select Tools ► XML Reports ► Geometry.  The Geometry 
Report dialog opens as shown in Figure L14-1. 

 
 

 
 

 
Figure L14-1   Geometry Report 

 
 

10.  Open the Geometry Selection Filter dialog. 
 

• In the Geometry Report dialog, left click in the Horizontal Alignments – 
Include: field.  This activates the Filter button. 

• Click the Filter button.  The Geometry Selection Filter opens as shown in   
Figure L14-2. 
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Figure L14-2   Geometry Selection Filter 

 
 
11.  Filter the ‘Available:’ field to Include only those Alignments with the Feature Styles 

MAIN_P_CONSTCL and MAIN_P_SIDECL. 
 

• Use the pull-down arrow next to the Style: field to change the entry from Ignore 
to Included. 

• In the Style: – Included key-in field, key-in:  
MAIN_P_CONSTCL;MAIN_P_SIDECL and click the Tab key on the 
keyboard to accept the entry. 

                                                                      
*IMPORTANT:  Ensure no spaces are entered either before or after the semi-colon (;) 

when entering the feature styles.  A space entered after the semi-
colon will prevent additional feature styles from being recognized. 

 
• The alignments in the Available: field should now be filtered as shown in    

Figure L14-3. 
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Figure L14-3   Geometry Selection Filter 

 
12.  Move all the Filtered Alignments from the ‘Available:’ field to the ‘Selected:’ field. 

 
• In the Geometry Selection Filter dialog, click the All button.  This moves all the 

alignments visible in the Available: field to the Selected: field as shown in   
Figure L14-4. 

 
 

  
Figure L14-4   Geometry Selection Filter 
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13.  Move all the Selected Alignments to the Geometry Report dialog and set the 
Reporting Interval to 50.00. 
 

• In the Geometry Selection Filter dialog, click OK.  The Geometry Selection 
Filter dialog closes and returns the selected alignments to the Horizontal 
Alignments – Include: field of the Geometry Report dialog. 

• Place a check in the Interval: check box and enter 50.000 in the entry field for 
the interval. 

• Verify your entries match those shown in Figure L14-5. 
 

 
 

  
Figure L14-5   Geometry Report 

 
 
14.  Open the Bentley Civil Report Browser. 

 
• In the Geometry Report dialog, click Apply.  The Bentley Civil Report 

Browser opens similar to that shown in Figure L14-6. 
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Figure L14-6   Bentley InRoads Report Browser 

 
 

15.  View the ‘GDOT Alignment Report’. 
 

• In the Bentley Civil Report Browser, highlight the style sheet GDOT 
Alignment Report.xsl.  The GDOT Alignment Report displays as shown in 
Figure L14-7. 
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Figure L14-7   Bentley InRoads Report Browser 

 
 

16.  Save the ‘GDOT Alignment Report’. 
 

• In the Bentley Civil Report Browser, select File ► Save As.  The Save As 
dialog opens as shown in Figure L14-8. 
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Figure L14-8   Save As 

 
 

17.  Save the ‘GDOT Alignment Report’ in HTML format 
 

• In the Save As window, navigate to C:\InRoads Data\Design Labs\Lab14. 
• In the File name: entry field, key-in GDOT Alignment Report. 
• Enter the Save as Type: as HTML File (*.html). 
• Verify your entries match those shown in Figure L14-9. 
• Click Save. 
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Figure L14-9   Save As 

 
 
18.  Prepare InRoads for Lab 14C. 

 
• Close the Bentley Civil Report Browser. 
• Close the Geometry Report dialog. 
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Lab 14C GDOT End-Area Report-Standard 
 
This Lab will depict the process to create a GDOT End-Area Report-Standard for the 
proposed DTM 1234567_SR100 SPUR_Lab14.  The GDOT End-Area Report - Standard is a 
required deliverable with the Final Plans submittal package for all cross sections. 
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19.  Ensure the Active Alignment is set to DE31 (SR 100 Spur). 
 

• In the InRoads Workspace bar, ensure the 
Geometry tab is the active tab as shown at 
right. 

• Ensure DE31 is the active alignment by right 
mouse clicking over it and selecting Set 
Active. 

 
                                
 
 
 
 
 

                        
20.  Before the ‘GDOT End-Area Report-Standard’ can be generated, Cross Sections 

must be created in MicroStation.  Open the Cross Sections dialog. 
 

• In InRoads, select Evaluation ► Cross Section ► Cross Sections.  The Cross 
Sections dialog opens as shown in Figure L14-10. 

 
 

   
Figure L14-10   Create Cross Section 

Make the Geometry tab the 
active tab. 

Ensure DE31 is the active 
alignment.  It should have a 
red square as shown here. 
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21.  Load the Preference ‘50 Scale Work Sec 2x Vert Exg’. 
 

• Ensure the Create Cross Section “folder” is highlighted/selected as 
depicted here:  

 
       NOTE: Depending on which folder is selected 
       (either “Create Cross Section, Annotate Cross  
       Section, Update Cross Section or End-Area  
       Volumes), the available Preferences will change. 
 
 
             
 

 
• In the Cross Sections dialog, click the Preferences button.  The Preferences 

dialog opens as shown here. 
 
 

       
 
 

• Highlight the Preference 50 Scale Work Sec 2x Vert Exg. 
• Click Load and Close.   

 
  
   
 
    * NOTE: This loads settings into the Cross Sections dialog intended to be  
        enough to fit the entire cross section at each station.   

 
*NOTE: For projects with cross sections whose cut or fill slopes that extend beyond 
the range set up by this preference, the user is instructed to manually set the Left and 
Right Offsets to a distance that will encompass the entire cross section. 
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22.  Select the Surfaces for the ‘GDOT End-Area Report-Standard’ to be created from. 
 

• In the Cross Sections dialog, place an ‘X’ in check boxes for the surfaces listed 
here. 

o 1234567_Exist 
o 1234567_SR100 SPUR_Lab14 

 
• Ensure your settings match those shown in Figure L14-11. 

 
 
 
 

 
Figure L14-11   Create Cross Section 

 
 
 
 
 
 
 
 

Ensure the check boxes 
for these 2 Surfaces 
contain an ‘X’. 
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23.  Create the Cross Sections. 
 

• In the Cross Sections dialog, click Apply. 
• Notice, in the bottom left corner of the MicroStation window you are prompted to 

> Identify Location.   
• Left click anywhere in the MicroStation window.  The cross sections are drawn 

and the Cross Sections dialog reappears. 
• Do Not close the Cross Sections dialog. 
•  In MicroStation, click the Fit View button (        ). 
• Your view in MicroStation should now match that shown in Figure L14-12. 

 
 
 

 
Figure L14-12   MicroStation View 
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24.  Open the End-Area Volumes Folder in the Cross Sections dialog. 
 

• Ensure the End-Area Volumes “folder” is highlighted/selected as 
depicted here:  
 

       NOTE: Depending on which folder is selected 
       (either “Create Cross Section, Annotate Cross  
       Section, Update Cross Section or End-Area  
       Volumes), the available Preferences will change. 
 
 
 
 
 
 
 
 

 
• In the Cross Sections dialog, click the Preferences button. The Preferences 

dialog opens as shown here. 
 

           
 

• Highlight the Preference GDOT Earthwork Volumes. 
• Click Load and Close. 
• Verify your settings match those as shown in Figure L14-13. 

 
*NOTE: As our ultimate goal is to generate a GDOT End-Area Report-Standard 

and not a GDOT Earthwork Volumes Report, loading the GDOT 
Earthwork Volumes preference is technically not necessary.  This step is 
added here because loading the GDOT Earthwork Volumes preference is a 
good habit to get into.  If you choose not to load the GDOT Earthwork  
Volumes preference when creating the GDOT End-Area Report-
Standard ensure the Create XML Report check box is checked as shown 
in Figure L14-13. 
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Figure L14-13   End-Area Volumes 

 
 

25.  Open the Bentley Civil Report Browser. 
 

• In the Cross Sections dialog, click Apply and click Close to exit the Cross 
Sections dialog.  The Bentley Civil Report Browser opens similar to that shown 
in Figure L14-14. 
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Figure L14-14   Bentley InRoads Report Browser 

 
 
 
26.  View the ‘GDOT End-Area Report-Standard’ Style Sheet. 

 
• In the Bentley Civil Report Browser, highlight the style sheet GDOT End-Area 

Report-Standard as shown in Figure L14-15. 
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Figure L14-15   Bentley InRoads Report Browser 

 
 

27.  Save the Report as a Text (.end) file. 
 

• In the Bentley Civil Report Browser, select File ► Save As.  The Save As 
dialog opens. 

• Navigate to C:\InRoads Data\Design Labs\Lab 14\ 
• Change the Save as type: to All Files (*.*). 
• Enter the File name: as 1234567_ DE31.end 
• Verify your entries match those shown in Figure L14-16. 
• Click Save. 

 
 

 

Highlight the ‘GDOT 
End-Area Report-
Standard’ style sheet as 
shown here. 
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Figure L14-16   Save As 

 
 

28.  Prepare MicroStation for the next student. 
 

• In MicroStation, select Edit ► Select All. 
• Click the Delete icon ( ). 
• In MicroStation, select File ► Compress ► Design 

 
29.                  

This concludes Lab 14.  Do not proceed until the Instructor directs you to 
do so. 
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