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InRoads to HEC RAS for  
Bridge Hydraulics  

 
Introduction 
 
The objective of this Lab is to generate data and reports from InRoads for use in the HEC-RAS 
(Hydrologic Engineering Center - River Analysis System) software.  The minimum data required 
to perform these steps is an InRoads Surface (.dtm) and an InRoads Geometry file (.alg). These 
two files should be requested directly from the Designer. 
 
Before Starting… 
 
The instructions in this Lab are to be performed in conjunction with a training data set named 
InRoads to HEC RAS Labs.exe.  The InRoads to HEC RAS Labs.exe is a WinZip Self 
Extracting executable file that will unzip and place sample training files on the user’s computer 
in a folder named C:\InRoads to HEC RAS Labs\.  
 
The training dataset may be found and downloaded to the user’s desktop from the GDOT web 
page: 
 
http://www.dot.ga.gov/PS/DesignSoftware/InRoads 
 
Once the file is downloaded to the user’s desktop, the InRoads to HEC RAS Labs.exe file should 
be double clicked and unzipped accepting the defaults. 
 
You are now ready to begin Lab 1. 
 
 
 
 
 
 

 
 
 
 
 

http://www.dot.ga.gov/PS/DesignSoftware/InRoads
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Lab 1 
Start InRoads and Set Project Defaults 

 
Objective 
 
After the required files have been obtained from the Designer, a Folder Structure needs to be set 
up for InRoads.  The recommended Folder Structure for InRoads is a Project Folder (which is 
named for the PI # of the Project – Example: 1234567) located as a sub-folder under C:\InRoads 
Data – Example: C:\InRoads Data\1234567).  This Project Folder will contain the individual 
InRoads Data Files.  The two InRoads data files the bridge hydraulics engineer will work from 
are: 
 
1. PI#.DTM ------ (Digital Terrain Model File) – contains Surface data 
2. PI#.ALG------- (Geometry File) – contains Geometric Point, Horizontal and Vertical data 
 
Additional InRoads data files that are used by Photogrammetry, Survey and/or Design are:   
 
4. PI#.IRD ------- (Roadway Design File) – contains the cross sectional roadway design. 
5. PI#.RWK------ (Project File) – contains project data for InRoads files in ASCII format 
6. PI#.ITL-------- (InRoads Template File) – contains InRoads Templates for cross-sections 
7. PI#.SDB------- (Drainage File) – contains the InRoads Storm and Sanitary data   
8. PI#.FWD ------ (Survey File) – contains Field Survey data 
 
 

 
  
 
 
 
 
The objective of Lab 1 is to: 
 

• Create a Project Folder 
• Start InRoads 
• Set the InRoads Project Defaults 
• Set Design Default Preferences 
• Set the InRoads “Locks” 
• Add the Application and Variable Manager Add-Ins 

 

 
 

It is highly recommended to backup the Project Folder (which contains these individual 
data files) after each work session to your Group Account on the GDOT Server if you are a 
GDOT Employee (or to an appropriate Business Server if you are a GDOT Consultant).  
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Lab1A Create a Project Folder & Copy Lab Project Files 
 
In this section of the Lab you will be creating a folder or directory.  This folder is where your 
projects and all of your InRoads project data files will be located.  The newly created InRoads 
project directory will be (C:\InRoads Data\PI#).  This is the recommended file structure for 
InRoads projects.  (For this tutorial only -- you will also copy the “InRoads to HEC RAS Labs” 
folder to this location.)  
 
1.  From the desktop, double-click on the My Computer icon.  

 
This will open the My Computer dialog box.  This is your computer’s file manager.  Via 
this dialog box, you may view the content of your computer’s various hard-drives.   

2.  Double-click on the C: directory (also referred to as folder or drive). 
 
This will open the C: directory box, listing the contents of the C: drive. 

3.  If the C: directory does not contain a folder named InRoads Data -- create the folder. 
 
Creates folder InRoads Data under the C: drive. 

 

 
Figure L1-1 InRoads Project Folder In C:\ directory 

 
4.  Using Windows Explorer, create a new folder under InRoads Data and name it 

1234567. This is the project folder you will use for the Lab Lessons (C:\InRoads 
Data\1234567).   
 
Creates folder 1234567 under C:\InRoads Data. 

5.  Using Windows Explorer, copy the folder InRoads to HEC RAS Labs from C:\ to 
(C:\InRoads Data\1234567).   
 
Places the InRoads to HEC RAS Labs in C:\InRoads Data\1234567 
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Figure L1-2 Folder InRoads to HEC RAS Labs in the C:\InRoads Data\1234567 folder 
 
 

6.  Close the Explorer window by clicking on the          in the upper right-hand corner of the 
window. 
 
This will close the Explorer window. 
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Lab1B Start InRoads 
 
In this section of the Lab you will be opening MicroStation V8i Select Series 2 in the ‘GDOT 
Corporate Workspace’ and InRoads Suite V8i Select Series 2. You will also select a “seed” file 
to use for the “Working” DGN file.  This “Working” DGN file is used to display the temporary 
and/or permanent graphics in InRoads.  MicroStation is opened first and then InRoads is 
opened from the MicroStation Menu bar. 
 
7.  From the desktop, double-click on the GDOT MicroStation V8i SS2 (x86) icon.   

 
 
 
 
 
 

• When the MicroStation Manager dialog box opens – navigate to the 
C:\InRoads Data\1234567\InRoads to HEC RAS Labs\Standards folder and 
select the “GDOT 3D Working File.dgn”.  (Creation of the ‘GDOT 3D Working 
File.dgn’ is documented in the Design Guidelines).  Click Open. 

 
• Now open InRoads from within MicroStation by selecting InRoads  InRoads 

Suite (SELECTseries 2) V8i 08.11.07.566 from the [MicroStation Menu]. 
 
After the MicroStation Splash Screen appears, the MicroStation Manager dialog (See 
Figure L1-3) will open so that you can select a “Working” DGN file.   Once InRoads 
and MicroStation are up and running, your desktop should look similar to that of Figure 
L1-4 and Figure L1-5. 

  

                
Figure L1-3 Starting MicroStation V8i and InRoads Suite 

 

Double click on the icon labeled 
GDOT MicroStation V8i SS2 
(x86) 
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Figure L1-4 Main MicroStation V8i Window 

 
   
 
 
 
 
 
 
 
 
 

Figure L1-5 Main InRoads V8i Window 
 
 
 
8.  As mentioned previously - you will be working in both the InRoads Design Software 

and the MicroStation CADD Software.  The InRoads Software is the database in 
which the Design data is created and processed.  The MicroStation CADD Software is 
used for the viewing and manipulation of graphics derived from InRoads.  
 
Please review the diagram depicted below for a brief overview of the InRoads Explorer 
Interface: 
 
Details the components of the InRoads Explorer Interface. 
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• Workspace Bar – Contains all of the InRoads Project Data information   
• Menu Bar – Contains the pull-down menus to access InRoads commands  
• Toolbars – Contains default and customized toolbars to access InRoads commands 
• Feedback Pane – Contains details of selected Project Data from the Workspace Bar 
• Scroll Bar – Enables the user to view more of the InRoads Explorer Interface. (The 

Scroll Bar may not be visible if the InRoads Interface is already viewed to extents). 
• Status Bar – Contains InRoads messages and prompts (Please note:  InRoads may direct 

you to locate something graphically in MicroStation -- some of these prompts may 
display in the MicroStation Status Bar instead).  It is very important that the user review 
both the InRoads and the MicroStation Status Bar for prompts and information. 

  

Menu Bar 

Workspace 
Bar 

Toolbars Feedback 
Pane 

Status Bar 
Scroll Bar 
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Lab1C Set InRoads Project Defaults 
 
The InRoads Project Defaults setting allows you to define the “default folder locations” for 
projects.  A Project Default configuration can then be saved for each project so that multiple 
projects can be accessed.  This configuration allows you to easily navigate between projects. 
Once the Project Folder locations are saved in the Configuration, the projects can be accessed by 
selecting the appropriate Project Configuration Name.  The Project Defaults also contains the 
location for selecting the standard GDOT InRoads Preference File (GDOT_Standard 
V8i_SS2.xin). 
 
 
 
 
9.  Click FileProject Defaults from the InRoads pull-down menu.   

 
 
The Set Project Defaults dialog box appears.  Each Project will require an individual 
setup as detailed in the following steps.  

10.  Click New and enter 1234567_Bridge in the New Configuration dialog box.  
Then click OK. 
 
 
The New Configuration dialog box will appear.  After entering in the Project Name and 
clicking OK – a new configuration will be created that is named 1234567_Bridge. 

11.  Under the Default Preferences section - Click in the Preferences (*.xin): field and then 
click the Browse button to navigate to the following file:  
 
 
C:\InRoads Data\1234567\InRoads to HEC RAS Labs\Standards\GDOT_Standard 
V8i_SS2.xin.  Select the GDOT_Standard V8i_SS2.xin file and click Open.  
 
 
 
The GDOT_Standard V8i_SS2.xin file is added as the Project Preference File. 

12.  Under the Default Directory Paths Section - Click in the Project Default Directory: 
field and then click the Browse button to navigate to the folder:  
 
 
C:\InRoads Data\1234567\InRoads to HEC RAS Labs\. Next - click Open. 
 
 
 
 
 
The Current Configuration for the 1234567 project will now default to the following 
path: C:\InRoads Data\1234567\InRoads to HEC RAS Labs\. 
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13.  Under the Default Directory Paths Section – copy and paste the following text into each 
entry field shown below: C:\InRoads Data\1234567\InRoads to HEC RAS Labs\  
 
• Report Directory:  

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
• Projects (*.rwk):  

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
• Surfaces(*.dtm):  

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
• Geometry Projects:(*.alg): 

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \  
• Template Libraries:(*.itl):  

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
• Roadway Design: (*.ird):   

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
• Survey Data: (*.fwd):  

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
• Drainage: (*.sdb):  

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
• Quantity Manager: (*.mdb):  

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
• Site Modeler Projects: (*.gsf):  

C:\InRoads Data\1234567\InRoads to HEC RAS Labs \ 
 

14.  Under the Default Directory Paths Section - Click in the Style Sheet (*.xsl): field and 
then click the Browse button to navigate to the folder:  
 
C:\InRoads Data\Style Sheets\GDOT\.  Next - click Open. 
  

15.  The Project Defaults should now correspond to the screen capture depicted in  
Figure L1-6 (as shown below).  Verify to ensure that your 1234567 Project Defaults 
match the inputs in the screen capture.   
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Figure L1-6 Set Project Defaults 

 
 
 

16.  Click Apply and then click Close. 
 
The Set Project Defaults dialog box will close and the settings for this configuration of 
Project 1234567_Bridge will be the default settings until the configuration is changed to 
another Project.  This folder location will also be the default folder when FileSave and 
FileClose are used.   
 

Ensure that the 
“Preferred Preference” 
is set to “Design 
Default”. 
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Lab1D Set Design Default Preferences 
 
 The Design Default Preferences must be loaded in InRoads in order to conform to standards for 
the processing of Design Projects.  This is a very important step to ensure that standards are 
followed for any Design data that will be processed. The Design Default Preference loads the 
Precision Settings, Tolerances, Units and Formats, etc.  Once the Design Default Preference is 
loaded – the project will retain these settings each time the project is accessed.  
 
17.  Click File Project Options from the InRoads pull-down menu to access the Project 

Options dialog box.   
 
The Project Options dialog box appears.    

18.  In the Project Options dialog box - click on the General Tab.   
 

      
  
 
 
The General Tab dialog box appears.   

19.  In the General Tab dialog box click the command button named Preferences… 
(Located at the bottom of the dialog box). 
 
                            

   
 
 
 
 
 
 
 
 
The Preferences dialog box will open. 

20.  In the Preferences dialog box – select Design Default.  Then click Load and then click 
Close.  
 
The Design Default Preference will be loaded. This will load the appropriate data for 
ALL of the tabs in the Options dialog box. The individual tabs (Tolerances, Geometry, 
Units and Format, etc.) will automatically be configured for use in Design. These 
individual tab options will NOT need to change. Once the Design Default Preference is 
loaded – the project will retain these settings each time the project is accessed.    

General Tab 



InRoads to HEC RAS for Bridge Hydraulics  InRoads SS2 -Lab 1 

   
 Lab1-11   

21.  Important Information: 
 
In the Project Options dialog box - click on the Geometry Tab.   

 
Notice in the image at right, the Seed  
Alignment Name: and Seed Point 
Name: 
default settings of DE1 and 
DE10000.  These  
values were set when the Design 
Default 
Preference was loaded in the 
preceding step. 

These settings are of particular importance 
to the Designer.  Alignments must have a DE 
prefix.  Points must also have a DE prefix  
as well as numbering starting at 10000.  In order for  
survey enhancements to be properly added during  
the design phase of a project, it is essential that  
Designers pay particular attention to this setting.  
DE stands for design. 
 

22.  Click back to the General Tab.   
 
 
The Design Default Preference should now correspond to the screen capture depicted in  
Figure L1-7 (as shown below).  Verify to ensure that the Project Options dialog box for 
Project 1234567 matches the inputs in the screen capture.   
 
The Project Options are verified for accuracy.    
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Figure L1-7 Design Default Settings 

 
23.  Click Apply and then click Close. 

 
The Project Options dialog box will close and the Design Default Preference for this 
configuration of Project 1234567 will be the default settings until the configuration is 
changed to another Project.   

  

Ensure that the  
“Refresh Command 
Settings on Preference 
Change” is checked: 
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Lab1E  Set InRoads “Locks” 
 
 InRoads contains several “Locks” which are used by many InRoads commands to control 
different aspects of the selection and viewing of data as well as the reporting of data.  There are 
basically two types of “Locks” – On/Off “Locks” and Switch “Locks”. (Switch “Locks” contain 
different modes but one mode is always active and the user can switch between modes). Both 
types of “Locks” can be changed by the user as the situation dictates during the course of the 
database generation.  These locks affect many commands – so it is very important that the user 
understand the use of these locks.    
 
The following Lab contains a brief overview of some of the InRoads “Locks”.  These “Locks” 
must be set according to the following Lab --- (Lab1E) ---- for the use in upcoming Labs. This is 
a very important step to ensure that the “Locks” are set accordingly.     
 
24.  Click ToolsLocks from the InRoads pull-down menu.   

 
This command accesses the available InRoads “Locks”. Each time a “Lock” is changed 
– the pull-down menu will close and the user must click on ToolsLocks again to access 
the Locks pull-down. 

25.  Ensure that the following locks are selected/unselected as appropriate: 
 
Feature Filter        _____ Unchecked   
 
Feature Highlight         __ Unchecked 
 
Style         ____________ Unchecked 
 
Pencil/Pen        ________ Set to Pencil 
 
Delete Ink    ________ Unchecked 
 
Locate         ___________Set to Features 
 
Point Snap        ________ Checked 
 
Element Snap        ______Unchecked 
 
Station        ___________ Unchecked 
 
Report          __________ Checked 
 
Cogo Audit Trail         __ Unchecked 
                             
Toolbar            ________ Checked 
 
The InRoads “Locks” are set accordingly. 
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26.  Following is a brief overview of the “Locks”: 
 
 Feature Filter   
 displays or obscures Surface Features based on a filter (also controls Survey Style Filter) 
 
Feature Highlight 
 highlights the feature in plan view when selected from a list 
 
Style 
 determines if a dialog box is displayed for a surface command or cross sections 
 
Pencil/Pen   
controls the redisplaying of Graphics 
 
Delete Ink  
allows redisplayed graphics to replace graphics in pen mode 
 
Locate    
controls if Locate Buttons snaps to Graphics or Features 
 
Point Snap   
 controls the ability to snap to points in Geometry Project 
 
Element Snap 
controls the ability to snap to elements in Geometry Project 
 
Station   
controls the Stationing as it pertains to Cross Sections 
 
Report  
controls if Report is displayed or not displayed in a dialog box    
 
Cogo Audit Trail  
controls the reporting of coordinate geometry results to a text file 
                          
Toolbar 
displays or turns off the Locks Toolbar 
 
Describes a “brief” overview of the InRoads “Locks”. 
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Lab1F Add Application and Variable Manager Add-Ins 
 
InRoads contains several Application and Variable Manager “Add-Ins” which must be selected 
and added to the InRoads Program in order to access the standard GDOT customized menu 
applications/translators for Survey.  Once the Application and Variable Manager Add-Ins are 
selected – the settings are written to registry keys in the user’s profile.  This ensures that each 
time InRoads is accessed in the user profile -- these settings will already be available. These add-
ins will only need to be added once and will then be accessible in all of the InRoads Modules and 
InRoads Projects.   
 
The following Lab contains a brief overview of the InRoads “Application and Variable Manager 
Add-Ins”.   These “Application and Variable Manager Add-Ins” must be set according to the 
following Lab --- (Lab1F) ---- for their use in upcoming Labs. This is a very important step to 
ensure that the “Add-Ins” are set accordingly.     
 
 
27.  The Application Add-Ins will be selected: 

 
Click ToolsApplication Add-Ins from the InRoads pull-down menu and the following 
dialog box will appear:   
 

 
 
 Select the following Application Add-Ins by clicking an         by the appropriate Add-In:  

        
 
 
The InRoads “Application Add-Ins” are selected accordingly.   
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28.  Click OK to accept the settings and to close out of the dialog box. 
 
The Application Add-Ins dialog box will close and the selected Application Add-Ins will 
be available for use.  

29.  Next the Variable Manager Add-Ins will be selected: 
 
Click ToolsVariable Manager from the InRoads pull-down menu and the following 
dialog box will appear:   
 

 
 
Select the following Variable Manager Add-Ins by clicking an         by the appropriate 
Variable:  
 

 
 
The InRoads “Variables” are selected accordingly.   

30.  Click Apply to accept the settings and then click Close to close out of the dialog box. 
 
The Variable Manager dialog box will close and the selected Variables will be available 
for use. 

31.                    
                 This concludes Lab 1.  Do not proceed until the Instructor directs you to do so. 
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Lab 2 
The InRoads Surface and Geometry File 

 
 
Objective 
 
The objective of Lab 2 is to open and learn about the InRoads 1234567_Exist.dtm Surface file 
and the InRoads 1234567_Design.alg geometry file.  
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Lab 2A Open the 1234567_Design.alg and 1234567_Exist.dtm  
 
 
32.  Open the 1234567_Design.alg Geometry File. 

 
• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\InRoads to HEC RAS Labs\ 
• Highlight 1234567_Design.alg 
• Click Open and then click Cancel. 

 
The 1234567_Design.alg file is opened. 

33.  Make the InRoads Geometry tab the active tab 
 

• In InRoads, Right mouse click  
over any of the tabs in the  
Workspace Bar and select  
Geometry.  

• Verify your view matches that 
shown in Figure L2-1 and that 
the Geometry tab is the active 
tab showing the Geometry  
Projects. 

 
 
 
 
 
**HINT:  Another way to open the Geometry File is to Right Mouse click over 

Geometry Projects in the Workspace bar. 
 

 

 
Figure L2-1 Main InRoads Window 

 

Workspace 
Bar 

Right mouse 
click over any 
of these tabs to 
easily switch 
to any of the 
other tabs. 
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34.  Open the 1234567_Exist.dtm Surface. 
 

• In InRoads, select File ► Open 
• Navigate to C:\InRoads Data\1234567\InRoads to HEC RAS Labs\ 
• Highlight 1234567_Exist.dtm 
• Click Open and then click Cancel. 

 
35.  Make the InRoads Surface tab the  

active tab 
 

• In InRoads, Right mouse click  
over any of the tabs in the  
Workspace Bar and select  
Surfaces.  

• Verify your view matches that 
shown in Figure L2-2 and that 
the Surfaces tab is the active 
tab showing the Surface(s) listed.  

 
 
 
 

 
 

 
Figure L2-2 Main InRoads Window 

  

Workspace 
Bar 

Right mouse 
click over any 
of these tabs to 
easily switch 
to any of the 
other tabs. 
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Lab 2B Setting the Active Surface/Project 
 
When working with more than one Surface/Project, it is important that you keep in mind which 
project is Active.  This Lab will discuss setting the Active Surface and Active Project and how to 
determine which Surface/Project is Active. 
 
36.  In the InRoads Workspace Bar the Active Surface has a red square next to it as shown 

here. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

37.  Make the Default Surface the Active Surface 
 

• In InRoads, Select Surface ► Active Surface.  The Active Surface dialog 
opens. 

• Highlight Default in the Active Surface dialog as shown in Figure L2-3. 
• Click Apply & Close. 

 
A Default Project will always exist in the InRoads Workspace Bar.  This is internal to 
InRoads and is required.  The Default project should never be used to design a project. 

 
                   

                           
Figure L2-3 Active Surface 

The red square next to a project 
name indicates the Active Surface. 
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38.  Look in the InRoads Workspace Bar.  The Default Surface should now be the Active 
Surface as demonstrated by the red square as shown here. 
 

 
 
 
 
 
 
 

** HINT:  You may Right Mouse click over the 
project name and click ‘Set Active’ to set the 
Active Surface also. 

 
 
 
 
 

Either the Active Surface command or right mouse clicking may be used to set the active 
Surface. 

39.  Before continuing, make the 1234567_Exist Surface the Active Surface. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The 1234567_Exist Surface is made the Active Surface. 

 
 
 
 
 
 
 
 

The red square next to a project 
name indicates the Active Surface. 

A red square should be next to 
1234567_Exist. 
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40.  The Active Geometry Project is set the same way as the Active Surface.  Make the 
Geometry Tab the Active Tab and ensure a Red Square is shown next to 
1234567_Design as depicted here. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
  

A red square should be next to 
1234567_Design. 
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Lab 2C The InRoads Surface (.DTM) 
 
The InRoads Surface (.DTM) is where the triangulated data as well as all of the Surface Features 
are located.  A Surface Feature is a collective term and may refer to either a survey chain or point 
and may be either a 2D or 3D object.  Examples of Surface Features are random terrain points, 
existing edge of pavement lines, topo break lines, stream banks and stream centers.  Each 
Surface Feature is assigned a Feature Style.  Examples of Feature Styles are TOPO_E_DSC for a 
stream center, TOPO_E_DHWM for a high water mark and TOPO_E_TEAP for existing edge of 
asphalt pavement.  Lists of all the Feature Styles used by GDOT may be found in the InRoads 
Design Guidelines available on the R.O.A.D.S. website. 
 
 
41.  Make the Surface Tab the Active Tab. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

42.  View All Surface Features. 
 

• In InRoads, select Surface ► View Surface ►Features. 
• In the View Features dialog use the pull down menu and ensure the Surface is set 

to 1234567_Exist. 
• Right mouse click in the Features: window and choose Select All.  
• Verify your View Features dialog matches that shown in Figure L2-4 and all the 

Features are highlighted in blue. 
• Click Apply. Be patient, viewing may take a moment. 
• Click Close. 
• In MicroStation, click the Fit View button as shown here. 

 

 
                         

                       Fit View 
• Verify your view in MicroStation matches that shown in Figure L2-5. 

The Surface Tab should be the 
Active Tab and 
1234567_Exist should be the 
Active Surface. 
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Figure L2-4 View Features dialog 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure L2-5 MicroStation View Window 
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43.   
• In MicroStation, select  the Window Area tool  

 

 
                                                                Window Area 

 
• Window into the area depicted in Figure L2-6. 
• Verify your view is similar to that shown in Figure L2-7. 

 
 
    

      
Figure L2-6 MicroStation View Window 

 
 
 
 
 
 
 
 
 
 
 
 

Window Area to the 
extents depicted by 
the red line. 
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Figure L2-7 MicroStation View Window 
 
44.  InRoads contains a function called Pop-up that is similar to ‘Data Tips’ in CAiCE 

 
• In the [MicroStation Menu] -- Select SettingsSnapsAccuSnap 
• The AccuSnap Settings dialog box will appear. Ensure that your settings 

correspond to the screen capture depicted below: 
 

                                               
                                                   
 
 
 

• Close the AccuSnap Settings dialog box by clicking the       in the upper right-
hand corner of the window. 
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45.   
• In MicroStation, click the Element Selection tool button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

46.  Information about elements in InRoads can be displayed using the Element Selection 
tool and Snapping to elements in MicroStation. 
 

• In MicroStation, with the Element Selection tool selected, Snap to the stream 
identified in Figure L2-8 and verify the element information is displayed as 
shown in Figure L2-9. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Element Selection tool 
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Figure L2-8 MicroStation View Window 
 

 
 
 

  
Figure L2-9 MicroStation View Window 

 
 
 
 
 

Snap to the steam center. 
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47.  Clear the MicroStation View Window. 
 

• In MicroStation, select Edit ► Select All.  All of the elements in MicroStation 
should turn purple. 

• In MicroStation Click the Delete button. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This clears the MicroStation View Window of all Graphics. 

 
 
  

Delete Button 
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Lab 2D The InRoads Geometry File (.ALG) 
 
The InRoads Geometry File (.ALG) is where geometric data is stored including centerlines, 
property, and other horizontal alignments.  It is also the repository for vertical alignments and 
cogo points. 
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48.  Make the Geometry Tab the Active Tab. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

49.  Horizontal Alignments are set active the same way projects are. 
 

• Follow Steps 1-3 in the yellow boxes. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 

The Geometry Tab should be 
the Active Tab and 
1234567_Design should be 
the Active Project. 

1. Click the plus (+) 
next to 
1234567_Design to 
expand the project. 

2. Right mouse click 
over DE1 and select 
Set Active.   

3. Verify Alignment 
DE1 has a red square 
next to it identifying it 
as the Active 
Alignment. 
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50.  The View Horizontal Annotation dialog is where Alignments and Cogo Points are 
selected for Viewing.  Open the View Horizontal Annotation dialog.   
 

• In InRoads, select Geometry ► View Geometry ►Horizontal Annotation. The 
View Horizontal Annotation dialog opens as shown in Figure L2-10 and  
Figure L2-11. 
 

 

    
Figure L2-10 View Horizontal Annotation 

  
 
 

Figure L2-11 View Horizontal Annotation 
 
 

51.  InRoads uses Preferences to Save Settings and Load Settings that are frequently used.  
GDOT has set up Preferences for several commands in InRoads including the View 
Horizontal Annotation command.   
 

• In the View Horizontal Annotation dialog, click the Preferences button. 
• Select the Preference named NO BEARING & DISTANCE. 
• Click Load and Close. 
• Compare Figures L2-10 and L2-11 to see the settings that were loaded by the NO 

BEARING & DISTANCE Preference. 
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52.  Horizontal Alignments and Cogo Points may be manually keyed into their respective 
Include: fields and they may also be selected by using the Filter button. 
 

• Notice the Filter button is currently grayed out. 
• Activate the Filter button by left clicking in the Horizontal Alignments Include: 

field. 
• Click the Filter button.  The Geometry Selection Filter opens as shown in 

Figure L2-12. 
 

 

 
Figure L2-12 Geometry Selection Filter 

 
53.  The Geometry Selection Filter is where you move items from the Available: field to 

the Selected: field for viewing. 
 

• Highlight Alignment DE1 and click the Add -> button. 
• Verify the Selected: field has been populated with Alignment DE1 as shown in 

Figure L2-13. 
• Click OK.  
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Figure L2-13 Geometry Selection Field 

 
54.  The View Horizontal Annotation dialog has now been populated with the Horizontal 

Alignment DE1. 
 

• Verify your entries match those shown in Figure L2-14. 
• In the View Horizontal Annotation dialog, click Apply & Close. 

 

Verify Alignment DE1 
has been moved to the 
Selected: field. 



InRoads to HEC RAS for Bridge Hydraulics  InRoads SS2 -Lab 2 

   
 Lab2-19   

                                      
Figure L2-14 View Horizontal Annotation 

 
 

55.   
• In MicroStation, click the Fit View button as shown here. 

 

 
 

              Fit View 
• Verify your view in MicroStation matches that shown in Figure L2-15. 
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Figure L2-15 MicroStation View Window 

 
 

56.  Annotate Alignment DE1 with Stationing. 
 

• In InRoads, select Geometry ►View Geometry ► Stationing. 
• Click the Preferences button. 
• Select the Preference named CONSTCL. Click Load and then click Close. 
• Click Apply & Close. 
• Verify your view matches that shown in Figure L2-16 and that Alignment DE1 

has been stationed. 
 

 



InRoads to HEC RAS for Bridge Hydraulics  InRoads SS2 -Lab 2 

   
 Lab2-21   

 
Figure L2-16 MicroStation View Window 

 
 
57.   

• Do not clear the MicroStation View.  Lab 3 will begin with this view. 
 
 

58.                    
                 This concludes Lab 2.  Do not proceed until the Instructor directs you to do so. 
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Lab 3 
Create Cross Section Report for HEC-RAS 

in Comma Delimited .TXT Format 
 
Objective 
 
The objective of Lab 3 is to create offset Parallel Alignments from the Roadway Centerline 
through a Stream Center and to generate a comma delimited text file for importing Cross 
Sectional geometric data into HEC-RAS. 
 
 
 
 
 
59.  Open the View Features dialog. 

 
• In InRoads, select Surface ► View Surface ► Features. 

 
 

60.  Deselect all the Features in the View Features dialog. 
 

• Right Mouse click in the Features: window and choose Select None from the 
pop up.  None of the Features should now be highlighted in blue. 

 
61.  Sort the Features by Style. 

 
• In the View Features dialog, click the Style heading until the Feature Style 

TOPO_E_DCB is at the top as shown here. 
 

            
 

Features can be sorted by Name, 
Style or Description by clicking 
the column heading.  
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62.  Select and view the Features Styles TOPO_E_DSB, TOPO_E_DSC and 
TOPO_E_DSE. 
 

• In the View Features dialog, use a combination of the CTRL and/or Shift keys 
on the keyboard and the Left Mouse button to select the Feature Styles 
TOPO_E_DSB, TOPO_E_DSC and TOPO_E_DSE as shown here. 
 

                    
            
 

• Click Apply and Close. 
• Verify your view in MicroStation matches that shown in Figure L3-1. 
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Figure L3-1 MicroStation View Window 
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63.  Create an Alignment parallel to DE1 that is 50’ to the Right of DE1 from Station 107+00 
to Station 117+00. Name the Alignment BH50RT. 
 

• In InRoads, select Geometry ► Utilities ► Parallel Horizontal Alignment… 
• Match the settings shown in Figure L3-2. 
• Click Apply and Close. 
• Verify the Alignment BH50RT was drawn as shown in Figure L3-3. 

 
 
 

  
Figure L3-2 Parallel Horizontal Alignment 
 

The Prefix BH stands for Bridge Hydraulics. 

The Feature Style BRDG_E_Hydraulics is 
for use by Bridge Hydraulics when storing 
offset parallel Alignments to gather existing 
ground line information to be used in HEC-
RAS. 



InRoads to HEC RAS for Bridge Hydraulics  InRoads SS2 -Lab 3 

   
 Lab3-5   

 
Figure L3-3 MicroStation View Window 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Horizontal Alignment 
BH50RT. 
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64.  Create an Alignment parallel to DE1 that is 50’ to the left of DE1 from Station 107+00 to 
Station 117+00.  Name the Alignment BH50LT. 
 

• In InRoads, select Geometry ► Utilities ► Parallel Horizontal Alignment… 
• Match the settings shown in Figure L3-4. 
• Click Apply and Close. 
• Verify the Alignment BH50LT was drawn as shown in Figure L3-5. 

 
 

  
Figure L3-4 Parallel Horizontal Alignment 
 
 
 

*IMPORTANT: Verify DE1 is entered in this 
field.  InRoads automatically repopulates this 
field when the Apply button is clicked. 

A Positive value will store an Alignment to the 
Right and a Negative value will store an 
Alignment to the Left. 

*IMPORTANT: Verify BH50LT is entered 
in this field.  InRoads automatically 
repopulates this field when the Apply button is 
clicked. 
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Figure L3-5 MicroStation View Window 

 
 
 
65.  Save the InRoads Geometry File 

 
Even though the Alignments have been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the Project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
 

66.  Before a Report can be generated for import into HEC-RAS, a ground line profile must 
be created and placed as a Feature into the Surface for each Alignment.  Open the Create 
Profile dialog. 
 

• In InRoads, select Evaluation ►Profile ► Create Profile.  The Create Profile 
dialog opens as shown in Figure L3-6. 

 
 

Horizontal Alignment 
BH50LT. 
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Figure L3-6 Create Profile 

 
 

67.  Create a Profile for Alignment BH50RT. 
 

• Click the Preferences button and Load the Preference 50h_10v_SHEETS. 
• In the Create Profile dialog, make the Source leaf the active leaf and match the 

settings shown in Figure L3-7. 
• Click Apply. 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

> Identify Location.  Left click in the general vicinity identified by the ‘X’ in 
Figure L3-8.  

• The Create Profile dialog reappears and the Profile was drawn in MicroStation. 
• Close the Create Profile dialog and verify the existing ground profile for 

BH50RT was drawn in MicroStation as shown in Figure L3-9. 
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Figure L3-7 Create Profile 

 

 
Figure L3-8 MicroStation View Window 

Left click in the general 
vicinity identified by the 
white ‘X’. X 

Ensure BH50RT is selected from the 
pull down arrow.  This field will be 
automatically populated by the active 
Alignment in the InRoads Workspace 
bar. 
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Figure L3-9 MicroStation View Window 

 
 

68.  Create a Profile for Alignment BH50LT. 
 

• Select Evaluation ► Profile ► Create Profile. 
• Click the Preferences button and Load the Preference 50h_10v_SHEETS. 
• In the Create Profile dialog, make the Source leaf the active leaf and match the 

settings shown in Figure L3-10. 
• Click Apply. 
• Notice in the bottom left corner of the MicroStation window you are prompted to 

> Identify Location.  Left click in the general vicinity identified by the ‘Y’ in 
Figure L3-11.  

• The Create Profile dialog reappears and the Profile was drawn in MicroStation. 
• Close the Create Profile dialog and verify the existing ground profile for 

BH50LT was drawn in MicroStation as shown in Figure L3-12. 
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Figure L3-10 Create Profile 

 

 
Figure L3-11 MicroStation View Window 

Ensure BH50LT is selected from the 
pull down arrow.  This field will be 
automatically populated by the active 
Alignment in the InRoads Workspace 
bar. 

Y 

Left click in the general 
vicinity identified by the 
white ‘Y’. 
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Figure L3-12 MicroStation View Window 
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69.  Add the newly created Profile for BH50RT to the Surface 1234567_Exist.dtm as a 
Feature. 
 

• Select Evaluation ► Profile ► Profile to Surface. 
• In the Profile to Surface dialog, match the settings shown in Figure L3-13. 
• Click Apply but do not close the Profile to Surface dialog. 

 
 

 
 

  
Figure L3-13 Profile to Surface 

 
 
 

70.  Add the newly created Profile for BH50LT to the Surface 1234567_Exist.dtm as a 
Feature. 
 

• In the Profile to Surface dialog, match the settings shown in Figure L3-14. 
• Click Apply & Close. 

 
 

 
 

The Profile Surface must be 
highlighted as shown.  Be careful to 
notice when you highlight the 
Surface, the Seed Name field is 
automatically populated with the 
Profile Surface Name and must be 
manually edited. 

Ensure BH50RT is 
selected from the 
pull down arrow.  
This field will be 
automatically 
populated by the 
active Alignment in 
the InRoads 
Workspace bar. 
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Figure L3-14 Profile to Surface 

 
 

71.  The reason we added the Profiles BH50RT and BH50LT as Features to the Surface is 
that this is the best method to generate a Report from InRoads that will provide a Station 
and Offset from a different Horizontal Alignment.  Verify the Features BH50RT and 
BH50LTwere added to the Surface. 
 

• Select Surface ► Feature ► Feature Properties. 
• Verify the features BH50RT and BH50LT are listed in the Feature Properties 

dialog as shown in Figure L3-15.  Click the Name column heading as necessary 
to find the Features. 

• Close the Feature Properties dialog. 
 

 

The Profile Surface must be 
highlighted as shown.  Be careful to 
notice when you highlight the 
Surface, the Seed Name field is 
automatically populated with the 
Profile Surface Name and must be 
manually edited. 

Ensure BH50LT is 
selected from the 
pull down arrow.  
This field will be 
automatically 
populated by the 
active Alignment in 
the InRoads 
Workspace bar. 
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Figure L3-15 Feature Properties 

 
72.  Save the InRoads Surface File 

 
Even though the Features have been added to the Surface – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. Whenever a change has been made to an InRoads Surface – Save the Surface and its 
associated modifications or changes. 
 

• Select FileSave Surface from the InRoads Menu.   
 

73.  Create a Station/Elevation comma delimited text file (.txt) of BH50RT for use in 
importing Cross Section Geometric data into HEC-RAS. 
 

• Select Tools ► XML Reports ► Clearance. 
• Select the General leaf and match the settings shown in Figure L3-16. 
• Select the Features leaf and match the settings shown in Figure L3-17. 
• Click Apply. The Bentley Civil Report Browser opens. 
• Select the .XSL Style Sheet named: 

            GDOT HEC RAS Cross Section Geometry Report.xsl 
• Verify your view matches that shown in Figure L3-18. 
• In the Bentley Civil Report Browser, select File ► Save As. 
• Save the Report as BH50RT.txt 
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Figure L3-16 Clearance Report 

 
 

  
Figure L3-17 Clearance Report 

 

Select DE1.  The Horizontal 
Alignment of the Roadway 
Centerline from which you want 
your station and offsets to be 
reported from is entered in this 
field. 

Select BH50RT.  A separate 
Report must be generated for each 
Feature. 
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Figure L3-18 Bentley Civil Report Browser 

 
74.  Create a Station/Elevation comma delimited text file (.txt) of BH50LT for use in 

importing Cross Section Geometric data into HEC-RAS. 
 

• Close the Bentley Civil Report Browser. 
• If not still open, open the Clearance Report dialog, Select Tools ► XML 

Reports ► Clearance. 
• Select the General leaf and match the settings shown in Figure L3-19. 
• Select the Features leaf and match the settings shown in Figure L3-20. 
• Click Apply. The Bentley Civil Report Browser opens. 
• Select the .XSL Style Sheet named: 

            GDOT HEC RAS Cross Section Geometry Report.xsl 
• Verify your view matches that shown in Figure L3-21. 
• In the Bentley Civil Report Browser, select File ► Save As. 
• Save the Report as BH50LT.txt 
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Figure L3-19 Clearance Report 

 

  
Figure L3-20 Clearance Report 

 
 
 
 
 
 
 
 
 
 
 
 

Select DE1.  The Horizontal 
Alignment of the Roadway 
Centerline from which you want 
your station and offsets to be 
reported from is entered in this 
field. 

Select BH50LT.  A separate 
Report must be generated for each 
Feature. 
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Figure L3-21 Bentley Civil Report Browser 

 
 
 
 
 
 
 
 
 

75.   
• Close the Bentley Civil Report Browser. 
• Close the Clearance Report dialog. 

 
 

76.  The Text files BH50RT.txt and BH50LT.txt which were just created can now be 
imported into HEC-RAS. 
 

• Open HEC-RAS and Open or Create a new HEC-RAS Project. 
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77.  Import BH50RT.txt into HEC-RAS. 
 

• In HEC-RAS, select Edit ► Geometric Data… 
• In the Geometric Data dialog, select File ► Import Geometry Data ► CSV 

(comma separated value) Format… 
• Navigate to BH50RT.txt located in C:\InRoads Data\1234567\InRoads to HEC 

RAS Labs. 
• Select BH50RT.txt and click OK. 
• Select Station-Elevation Format then click OK. 
• Click Next. 
• Check the Import Stream Lines check box. 
• Click Next. 
• Click the Create RS in feet button. 
• Key-in 50.00 in the Import As RS key-in field as shown here. 

            
 

• Click Finished – Import Data. 
• Click the Edit and/or Create Cross Section button in HEC-RAS to 

view the Cross Sections.                    
 

78.  Import BH50LT.txt into HEC-RAS. 
 

• In the Geometric Data dialog, select File ► Import Geometry Data ► CSV 
(comma separated value) Format… 

• Navigate to BH50LT.txt located in C:\InRoads Data\1234567\InRoads to HEC 
RAS Labs. 

• Select BH50LT.txt and click OK. 
• Select Station-Elevation Format then click OK. 
• Click Next. 
• Uncheck the Import Stream Lines check box. 
• Change the Merge Mode to Append Upstream. 
• Click Next. 
• Click the Create RS in feet button. 
• Key-in -50.00 in the Import As RS key-in field as shown here. 

           
 

• Click Finished – Import Data. 
• Click the Edit and/or Create Cross Section button in HEC-RAS to 

view the Cross Sections.               
 
 



InRoads to HEC RAS for Bridge Hydraulics  InRoads SS2 -Lab 3 

   
 Lab3-21   

79.  • Close HEC-RAS. 
 

80.                    
                 This concludes Lab 3.  Do not proceed until the Instructor directs you to do so. 
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Lab 4 
Create Cross Section Report for HEC RAS in 

.GEO Format 

 
 
Objective 
 
The objective of Lab 4 is to create a Stream Centerline in the InRoads ALG Geometry file from 
the InRoads DTM Surface and generate an InRoads .geo file containing Cross Sectional 
geometric data along a Stream Centerline for import into HEC-RAS. 
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81.  Clear MicroStation of all Screen Graphics. 
 

• In MicroStation, select Edit ►Select All. 
• In MicroStation, click the Delete button, . 

 
 

82.  View Horizontal Alignment DE1. 
 

• In InRoads, make the Geometry Tab the Active Tab. 
• Right Mouse click over DE1 and choose View from the popup menu. 
• In MicroStation, click the Fit View button        . 

 
 

83.  Annotate Alignment DE1 with Stationing. 
 

• In InRoads, select Geometry ► View Geometry ► Stationing. 
• Load the Preference named CONSTCL. 
• Click Apply and Close. 
• Verify your view matches that shown in Figure L4-1. 

 
 

 

 
Figure L4-1 MicroStation View Window 
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84.  Open the View Features dialog. 
 

• In InRoads, select Surface ► View Surface ► Features. 
 
 

85.  Deselect all the Features in the View Features dialog. 
 

• Right Mouse click in the Features: window and choose Select None from the 
popup menu.  None of the Features should now be highlighted in blue. 

 
86.  Sort the Features by Style. 

 
• In the View Features dialog click the Style heading until the Feature Style 

TOPO_E_DCB is near the top as shown here. 
 

            
 
 

87.  Select and view the Features Styles TOPO_E_DSB, TOPO_E_DSC and 
TOPO_E_DSE. 
 

• In the View Features dialog, use a combination of the CTRL and/or Shift keys 
on the keyboard and the Left Mouse button to select the Feature Styles 
TOPO_E_DSB, TOPO_E_DSC and TOPO_E_DSE as shown in Figure L4-2. 

• Click Apply and Close. 
• Verify your view in MicroStation matches that shown in Figure L4-3. 
• Close the View Features dialog. 

 
 

 

Features can be sorted by Name, 
Style or Description by clicking 
the column heading.  
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Figure L4-2 View Features 

 

 
Figure L4-3 MicroStation View Window 

Stream Center 
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88.  Create a Stream Centerline Alignment in the InRoads Geometry File (ALG) from the 
Stream Centerline in the InRoads Surface File (DTM).  
 

• In InRoads, select File ► Import ► Geometry. The Import Geometry dialog 
opens. 

• Ensure the From Graphics Tab is the Active Tab. 
• Match the entries shown in Figure L4-4 and then go to Step 89. 

 
 

 

                            
Figure L4-4 Import Geometry 

 
 
 
 
 

*NOTE: The Stream Center you will 
import is already a single element but 
in many cases the Stream Center may 
be composed of several elements.  
The All Selected Elements Added 
to Single Alignment will ensure in 
those cases that the Stream Center is 
added to the Geometry File as a 
single Alignment. 
 

The BHSC Name represents (Bridge 
Hydraulics Stream Center). 
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89.  Continue creating the Stream Centerline Alignment in the InRoads Geometry File 
(ALG). 
 

• In the Import Geometry dialog, Click Apply.  The Import Geometry dialog 
disappears and you are prompted in the lower left corner of the MicroStation 
Window to >Identify element. 

• Left Click on the Stream Center.  It will highlight in purple as shown in Figure 
L4-5 and you are prompted in the lower left corner of the MicroStation window to 
>Accept/Reject. 

• Left click in a blank part of the MicroStation window to accept or Right Mouse 
click to reject and select a different element. 

• Notice in the bottom left corner of the MicroStation window you are prompted to 
< Identify element. 

• Since there are no further elements representing the Stream Center, Right Mouse 
click in a blank part of the MicroStation window to complete the operation and 
return to the Import Geometry dialog.  If there had been more elements 
representing the Stream Center, you would select and accept them until all 
elements had been selected and then Right Mouse click to complete the operation 
and return to the Import Geometry dialog. 

• Close the Import Geometry dialog. 
 

 

 
Figure L4-5 MicroStation View Window 
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90.  Verify the Stream Centerline Alignment BHSC has been imported into the InRoads 
Geometry Project. 
 

• In InRoads, make the Geometry Tab the Active Tab in the InRoads Workspace 
Bar. 

• Verify BHSC exists in the Workspace Bar as shown here: 
• Right Mouse click over BHSC and select Set Active.   
• Verify Alignment BHSC has a Red Square next to it identifying it as the Active 

Alignment. 
 
 

                                                                     
 
 
 
 

91.  View Alignment BHSC. 
 

• Right Mouse click over Alignment BHSC and choose View from the popup 
Menu. BHSC is drawn as a solid white line in MicroStation. 

 
 

92.  Save the InRoads Geometry File 
 
Even though the Alignment has been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the Project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 
 

BHSC is shown in the 
Workspace Bar.  It should 
also be the Active 
Alignment as depicted by 
the Red square.  The plus 
(+) sign in front of the 
Alignment lets you know a 
Vertical Alignment is 
associated with the 
Horizontal Alignment. 



InRoads to HEC RAS for Bridge Hydraulics  InRoads SS2 -Lab 4 

   
 Lab4-8   

93.   
• In MicroStation, Window Area as shown in Figure L4-6. 
• Verify your view is similar to that shown in Figure L4-7. 

 
 
 
 

 
Figure L4-6 MicroStation View Window 

 

 
Figure L4-7 MicroStation View Window 
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94.  The Generate Water Surface Data command is used in InRoads to generate a Cross 
Sectional Geometric data file along the Stream Centerline Alignment for use in HEC-
RAS.   Open the Generate Water Surface Data dialog. 
 

• Select Evaluation ► Hydrology and Hydraulics ► Generate Water Surface 
Data… 

 
95.  The Generate Water Surface Data dialog – Step 1.    

 
• The Banks field is where Features in the DTM are selected that represent the Left 

and Right Stream Banks and Overbanks.  These Features are not always picked 
up by Survey, none the less a selection is required in InRoads.  This particular 
Project contains features in the DTM representing the Left and Right Stream 
Edges and Left and Right Stream Banks which we will use as the Left and Right 
Banks and Overbanks respectively. 

o Click the Locate Button ( ) to the right of the Left Bank: selection 
field. 

o The Generate Water Surface Data dialog disappears and you are 
prompted in the bottom left corner of the MicroStation window to             
> Select Feature.   

o Left Click on the Feature representing the Left Stream Edge shown here: 
 

                                                                
 

o The Feature highlights purple and you are prompted in the bottom left 
corner of the MicroStation Window to >Accept/Reject SVA91. 

o Left Click in a blank part of the MicroStation window to accept and return 
the Feature to the Generate Water Surface Data Left Bank: selection 
field as shown here: 

                                                      
o Click the Locate Button ( ) to the right of the Left Overbank: 

selection field and select the Feature SVA90 identified here: 
 

                                                                      
 

Left Click on 
the Left Stream 
Edge. 

Select the Feature 
SVA90 shown here. 
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o Use the Locate Button for the Right Bank: (SVA93) and Right 
Overbank: ( SVA94) identified here: 
 

        
 

o Verify the Banks selection fields are populated as shown here. 
 

                              
 
 

96.  The Generate Water Surface Data dialog – Step 2.   
 

• In the Source field select the Alignment Radio button. 
o In the Interval: key-in field, enter a value of 10.000.  The Interval: field 

defines the frequency that Cross Sections will be created.  A value of 
10.00 means Cross Section data will be created every 10 feet along the 
Stream Centerline Alignment. 

• In the Offsets field, key-in a Left: value of -100.000 and a Right: value of 
100.000. 

• Place a check in the Station check box. 
o In the Start: field click the Locate Button ( ) to the right of the entry 

field. 
 

                                  
o The Generate Water Surface Data dialog disappears and you are 

prompted in the bottom left corner of the MicroStation Window to > 
Identify start station.   

o In the MicroStation window, move your mouse cursor up and down the 
Stream Alignment and notice the white line that extends from your cursor 
to the Stream vertices.  

SVA93 

SVA94 

Click the Locate Button 
for the Start: field. 
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o Notice also as you move your cursor along the Stream Alignment, in the 
bottom middle of the MicroStation window you are provided with the 
Station and Offset of the vertices.  

o Move your cursor until the Station 6+61.59 is shown in the bottom middle 
of the MicroStation window and Left click.  You are returned to the 
Generate Water Surface Data dialog and 6+61.59 is now entered in the 
entry field for the Station Start: as shown here. 
 

        
 

o In the Stop: field click the Locate Button ( ) to the right of the entry 
field. 

                                
 

o The Generate Water Surface Data dialog disappears and you are 
prompted in the bottom left corner of the MicroStation Window to > 
Identify stop station.   

o Move your cursor until the Station 8+69.14 is shown in the bottom middle 
of the MicroStation window and Left click.  You are returned to the 
Generate Water Surface Data dialog and 8+69.14 is now entered in the 
entry field for the Station Stop: as shown here. 

        
 

o Place a check in the Display Section Lines check box. 
 

97.  The Generate Water Surface Data dialog – Step 3.   
 

• Verify your entries match those shown in Figure L4-8. 
• Click Apply. 
• In the Save As window, ensure HEC-RAS geometry file (*.geo) is selected as the 

type and key-in a filename of  1234567 HEC-RAS.geo 
• Click Save.  The .geo file is created and the Cross Section scan lines are drawn in 

MicroStation as shown in Figure L4-9. (PLEASE NOTE: The line symbology is 
based on the Active Level, so the color/linestyle may not exactly match the 
Figure L4-9 screen capture as shown below). 

• Close the Generate Water Surface Data. 

Click the Locate Button 
for the Stop field. 
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98.  Save the InRoads Surface File 
 
Even though the information has been added to the Surface – the data has not yet been 
saved. InRoads retains the data in temporary memory but does not save the data on the 
fly. Whenever a change has been made to an InRoads Surface – Save the Surface and its 
associated modifications or changes. 
 

• Select FileSave Surface from the InRoads Menu.   
 

99.  Save the InRoads Geometry File 
 
Even though the Alignment has been stored – the data has not yet been saved. InRoads 
retains the data in temporary memory but does not save the data on the fly. Whenever a 
change has been made to an InRoads Geometry Project – Save the Project and its 
associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 

 

 
Figure L4-8 Generate Water Surface Data 
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Figure L4-9 MicroStation View Window 

 
 

100.  Import the 1234567 HEC-RAS.geo file into HEC-RAS. 
 

• Open HEC-RAS and create a new Project. 
• In HEC-RAS, select Edit ► Geometric Data 
• In the Geometric Data dialog, select File ► Import Geometry Data ► GIS 

Format 
• Navigate to C:\InRoads Data\1234567\InRoads to HEC RAS Labs\ 
• Highlight the file 1234567 HEC-RAS.geo created in the previous steps. 
• Click OK. 
• Click Next. 
• Ensure Import Stream Lines is checked. 
• Click Next. 
• Click Finished – Import Data. 
• Click the Edit and/or Create Cross Section button in HEC-RAS to 

view the Cross Sections 
• Review your data. 

 
 

101.                    
                 This concludes Lab 4.  Do not proceed until the Instructor directs you to do so. 
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Lab 5 
Create Bridge Station and Offset Report for  

HEC RAS  

 
 
Objective 
 
The objective of Lab 5 is to generate a Station & Offset report of the existing Bridge Corners, 
Bridge Gutter Lines and Bridge Center Lines to the proposed Roadway Centerline for use in 
HEC-RAS. 
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102.  Clear MicroStation of all Screen Graphics. 
 

• In MicroStation, select Edit ►Select All. 
• In MicroStation, click the Delete button.  

 
 

103.  View Horizontal Alignment DE1. 
 

• In InRoads, make the Geometry Tab the Active Tab. 
• Right Mouse click over DE1 and choose View from the popup menu. 
• In MicroStation, click the Fit View button.  

 
 

104.  Annotate Alignment DE1 with Stationing. 
 

• In InRoads, select Geometry ► View Geometry ► Stationing. 
• Load the Preference named CONSTCL. 
• Click Apply and Close. 
• Verify your view matches that shown in Figure L5-1. 

 
 

 

 
Figure L5-1 MicroStation View Window 
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105.  Open the View Features dialog. 

 
• In InRoads, select Surface ► View Surface ► Features. 

 
 

106.  Deselect all the Features in the View Features dialog. 
 

• Right Mouse click in the Features: window and choose Select None from the 
popup.  None of the Features should now be highlighted in blue. 

 
 

107.  Sort the Features by Style. 
 

• In the View Features dialog click the Style heading until the Feature Style 
TOPO_E_DCB is near the top as shown here. 

 

            
 
 
 
 
 
 
 

Features can be sorted by Name, 
Style or Description by clicking 
the column heading.  
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108.  Select and view the Features Styles TOPO_E_DSB, TOPO_E_DSC and 
TOPO_E_DSE. 
 

• In the View Features dialog, use a combination of the CTRL and/or Shift keys 
on the keyboard and the Left Mouse button to select the Feature Styles 
TOPO_E_DSB, TOPO_E_DSC and TOPO_E_DSE as shown in Figure L5-2. 

• Click Apply but do Not close the View Features dialog. 
• Verify your view in MicroStation matches that shown in Figure L5-3. 

 
 

 
 
 

 
Figure L5-2 View Features 

 



InRoads to HEC RAS for Bridge Hydraulics  InRoads SS2 -Lab 5 

   
 Lab5-5   

 
Figure L5-3 MicroStation View Window 

 
 

109.  Select and view the Features Styles TOPO_E_TBCL, TOPO_E_TBGL and 
TOPO_E_TBRDGCOR. 
 

• In the View Features dialog, use a combination of the CTRL and/or Shift keys 
on the keyboard and the Left Mouse button to select the Feature Styles 
TOPO_E_TBCL, TOPO_E_TBGL and TOPO_E_TBRDGCOR as shown in 
Figure L5-4. 

• Click Apply and Close. 
• Verify your view in MicroStation matches that shown in Figure L5-5. 
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Figure L5-4 View Features 

 

 
Figure L5-5 MicroStation View Window 

The Bridge Features 
representing the bridge 
centerline, gutter line and 
corners were drawn in 
MicroStation.  
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110.  Zoom into the Bridge. 
 

• In MicroStation, Use the Window Area tool to zoom into the area identified by 
the White Square in Figure L5-6. 
 

 
                                                                       
                                                                 Window Area  
 

• Verify your view matches that shown in Figure L5-7. 
 
 

 
 

 
Figure L5-6 MicroStation View Window 
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Figure L5-7 MicroStation View Window 

 
 

111.  Annotate the Bridge Features 
 

• In InRoads, select Surface ► View Surface ► Annotate Feature. 
• Click the Preferences button. 
• Select the Preference named Bridge Hydraulics.  This Preference loads viewing 

settings that attempt to minimize text overlap and improve the annotation of the 
Bridge Features. 

• Click Load and Close. 
• Right Mouse click in the Features: window and choose Select None. 
• Sort the Features by Style. 
• Select the Features TOPO_E_TBCL, TOPO_E_TBGL and 

TOPO_E_TBRDGCOR. 
• Verify your selections match those shown in Figure L5-8. 
• Click Apply & Close. 
• Verify the Features were annotated as shown in Figure L5-9. 
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Figure L5-8 Annotate Feature 
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Figure L5-9 MicroStation View Window 

 
 
112.  Generate a Station & Offset Report from the Roadway Centerline, DE1, to the Surface 

Features TOPO_E_TBCL, TOPO_E_TBGL and TOPO_E_TBRDGCOR 
representing the existing bridge center line, bridge gutter lines, and bridge corners for use 
in HEC-RAS. 
 

• In InRoads, select Tools ► XML Reports ► Clearance. 
• Make the General leaf active and choose the Horizontal Alignment DE1 

representing the roadway centerline from the pull down arrow. 
• Ensure your entries match those shown in Figure L5-10. 
• Make the Features leaf active and select the Features TOPO_E_TBCL, 

TOPO_E_TBGL and TOPO_E_TBRDGCOR. 
• Ensure your selections match those shown in Figure L5-11. 
• Click Apply.  The Bentley Civil Report Browser opens. 
• Select the Style Sheet GDOT HEC RAS Bridge Features Report.xsl 
• Verify your Report provides the information shown in Figure L5-12. 
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Figure L5-10 Clearance Report 

 
 

 
Figure L5-11 Clearance Report 

 
 
 
 
 
 
 
 
 
 
 

Select DE1.  The Horizontal 
Alignment of the Roadway 
Centerline from which you 
want your station and offsets 
to be reported from is entered 
in this field. 

Select Feature Styles 
TOPO_E_TBCL, 
TOPO_E_TBGL and 
TOPO_E_TBRDGCOR
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Figure L5-12 Bentley Civil Report Browser 
 
 

113.  Save the Report as Bridge Points.txt. 
 

• In the Bentley Civil Report Browser, select File ► Save As. 
• Set the Save as type: to Text File (*.txt) 
• Key-in a File name: of Bridge Points.txt. 
• Verify your entries match those shown in Figure L5-13. 
• Click Save.  The file Bridge Points.txt has been created and saved in the folder 

C:\InRoads Data\1234567\InRoads to HEC RAS Labs\. 
• Close the Bentley Civil Report Browser. 
• Close the Clearance Report dialog. 
• The Report Data may now be used for the manual entry of the Bridge Data into 

HEC-RAS. 
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Figure L5-13 Save As 

 
114.  Save the InRoads Surface File 

 
Whenever a change has been made to an InRoads Surface – Save the Surface and its 
associated modifications or changes. 
 

• Select FileSave Surface from the InRoads Menu.   
 

115.  Save the InRoads Geometry File 
 
Whenever a change has been made to an InRoads Geometry Project – Save the Project 
and its associated modifications or changes. 
 

• Select FileSave Geometry Project from the InRoads Menu.   
 

116.                    
                    This concludes Lab 5 and the InRoads to HEC RAS for Bridge Hydraulics                   
                    Labs.    
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